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COURSE GUIDE DESCRIPTION 

You must read this Course Guide carefully from the beginning to the end. It tells 
you briefly what the course is about and how you can work your way through 
the course material. 

INTRODUCTION 

Digital Imaging is a course offered for Commonwealth of Learning project, 
particularly for Web Application Development Certificate.  It should be covered 
within 8 weeks. 

COURSE AUDIENCE 

This course is offered to all learners taking the Web Application Development 
certificate. You as the learners are required to attend this course and master the 
subject. This course is crucial for you to be able to design Websites.  Besides 
developing them, you are also able to balance between aesthetical values and 
usability values in the Websites you designed. Hence, you are expected to apply 
the principles and eliminate excise. As an open and distance learner, you should 
be able to learn independently and optimize the learning modes and 
environment available to you.   

COURSE OUTCOMES 

By the end of this course, you should be able to: 

1. Apply concept of digital imaging. 

2. Digitize images using different devices. 

3. Manipulate images using graphic tools. 

4. Create digital images for web page development. 
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COURSE SYNOPSIS 

This course is divided into 10 topics. The synopsis for each topic is briefed below: 
 
Topic 1 is an introduction to the concept of digital imaging that briefly discusses 
the basic knowledge of the tools and devices involved in digital imaging. It 
differentiates between raster and vector images that are suitable for use, and 
focuses on the computer as a tool for creating and manipulating the digital 
images.  
 
Topic 2 introduces the GNU Image Manipulation Program or GIMP, as a 
computer program used for editing, creating and manipulating digital images. It 
will also introduce the interface and work space used in digital imaging. 
 
Topic 3 focuses on the tools and features provided in the GIMP software. It 
explains that each tool in the software plays a role as an agent acting on editing 
and manipulating images. This topic also describes in depth the types of tools to 
make the process of transforming images more efficient. 
 
Topic 4 discusses the GIMP software, and how it manages files and the data 
contained therein with the suitable file format. It explains size and resolution 
which affect the quality of the images, and also describes how to save files in a 
number of different formats.   
 
Topic 5 focuses on the GIMP used in repairing imperfections in an image, 
including retouching and colour corrections. Besides that, there is a brief 
explanation about the process involved in the making of image manipulation and 
the suitable tools to edit and modify images. 
 
Topic 6 explains how to combine text with images. Before combining text with 
the images, there is an explanation on how to identify the function of the text 
before the process of combining with image begins. There is also in-depth 
discussion on the process of adding the text to an image, creating text effects and 
changing text attributes. 
 
Topic 7 describes the use of drawing and painting tools as powerful tools in 
developing image creation. The elements of drawing consist of shapes and paths 
which can be used in different drawing styles to make creative images. This topic 
also shows the ways to make beautiful lines and draw an object using the best 
tools available in GIMP.  
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Topic 8 focuses heavily on the effects and filters that are readily available in 
GIMP. A variety of effects and filters in the software can create beautiful images. 
In a nutshell, effects and filters allow users to modify an image through 
programs that has flexible adjustments. 
 
Topic 9 is continuation of Topic 8, on using effects and filters. It introduces 
advanced techniques to create stunning images. In this topic learners learn about 
how to use the functions in more advanced techniques in order to create amazing 
visual effects. 
 
Topic 10 discuses GIMP (GNU Image Manipulation Program), a software that 
allows various images related tasks such as preparing images to be used for 
website purposes, alongside an open-source community that contributes to each 
other across all platforms. 

TEXT ARRANGEMENT GUIDE  

Before you go through this module, it is important that you note the text 
arrangement. Understanding the text arrangement will help you to organise your 
study of this course in a more objective and effective way. Generally, the text 
arrangement for each topic is as follows: 
 
Learning Outcomes: This section refers to what you should achieve after you 
have completely covered a topic. As you go through each topic, you should 
frequently refer to these learning outcomes. By doing this, you can continuously 
gauge your understanding of the topic. 
 
Activity: This component requires you to perform certain task. It is very 
important for you to do all activities because they are designed to ensure you 
understand the topic you are going through. In certain contexts, you are required 
to discuss with your peers. 
 
Summary: You will find this component at the end of each topic. This component 
helps you to recap the whole topic. By going through the summary, you should 
be able to gauge your knowledge retention level. Should you find points in the 
summary that you do not fully understand, it would be a good idea for you to 
revisit the details in the module. 
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Terminology: This component can be found at the end of each topic. You should 
go through this component to remind yourself of important terms or jargon used 
throughout the module. Should you find terms here that you are not able to 
explain, you should look for the terms in the module. 
 
References: The References section is where a list of relevant and useful 
textbooks, journals, articles, electronic contents or sources can be found. You are 
encouraged to read or refer to the suggested sources to obtain the additional 
information needed and to enhance your overall understanding of the course. 

PRIOR KNOWLEDGE 

A basic knowledge regarding some creative works is useful in learning this 
course. However, it is not compulsory. Always believe that everything is a 
learning process, which requires a starting point.  



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 WHAT IS DIGITAL IMAGING?  

This topic focuses on the use of computers as tools for creating digital images and 
manipulation. It will also include an introduction to digital imaging and the use 
of monitors, scanners, cameras, printers and additional hardware that are related 
to the production of digital imaging. 
 
Digital imaging technology has been a success over the past decade. It is adopted 
by people from all walks of life across the country. The success of digital imaging 
can be seen through the diversity of technological advances in machines. 
Generally, digital imaging can be seen everywhere, regardless of whether you are 
at home, work or on the go. This is because digital imaging has monopolised the 
communication medium in conveying a picture or writing.  
 

1.1 

TTooppiicc

11  
 Introduction 

to Digital 
Imaging 

 
 

By the end of this topic, learners should be able to: 
 

1. Explain what digital imaging is; 
 

2. Identify the devices used in digital imaging; 
 

3. Use input and output devices; and 
 

4. Differentiate between raster and vector. 

LEARNING OUTCOMES 
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Figure 1.1 shows how digital imaging works to generate communication to the 
public.  
 

 

Figure 1.1: Digital imaging that has been used to convey information 
 
The basic process of digital imaging can be summarised into the following steps: 
 
(a) Image creations and manipulations (Figure 1.2); 
 
(b) Raster image processing; and 
 
(c) Product finishing.  
 
Examples of digital imaging are posters, brochures, pamphlets, booklets, 
magazines, newspapers, billboards, packaging or editing of old photographs. 
Digital imaging can also be prepared through imaging software like GNU Image 
Manipulation Program (GIMP) for the purpose of print or websites as shown in 
Figure 1.3.  
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Figure 1.2: Digital image manipulation 
 

 

Figure 1.3: Digital images from print media 
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Figure 1.4: Digital image editing using software 
 
Anyone can learn how to produce digital imaging. With current technology, it 
does not matter if you are a professional or an entry level person. In digital 
imaging, there are mobile applications for the Android or iOS which can enable 
image editing or manipulation with ease. However, those in the creative field 
would have the appropriate knowledge in producing digital imaging in 
comparison to those who merely download with basic knowledge. Figure 1.4 
shows an example of an image that was edited using the GNU Image 
Manipulation Program (GIMP) software.  

 

  
 

1. What are some medium designs using digital imaging techniques 
that you have come across? List them. 
 

2. Explain the importance of digital imaging to the public. 

ACTIVITY 1.1 
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 BASIC NEEDS IN DIGITAL IMAGING  

A digital image is created with a computer. The device takes a visual image and 
translates it into a series of mathematical values, or bits of information. The 
image can be acquired via the digital camera or by scanning any two-
dimensional image such as a photograph, a printed page or any other type of 
picture. A three-dimensional object can be placed on the scanner and its surface 
captured, then the scanner digitises the image and displays it electronically on 
the monitor.  

1.2.1 Monitors 

A monitor is an essential computer equipment used to produce digital imaging 
(Figure 1.5). The function of the monitor is to display video and graphic 
information generated by the computer through the video card. A monitor 
displays the information at a higher resolution than a television. The monitor is 
also known as a display, screen, video display and video screen. The higher 
resolution will influence the quality and the sharpness of the image displayed.  
 

 

Figure 1.5: A monitor 
 
The sharpness of the image on display depends on the resolution and the size of 
the monitor. Resolution is the number of pixels (individual point of color) used 
on the display monitor. The higher the resolution used, the sharper the  image 
that can be produced.  
 

1.2 
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1.2.2 Input and Output Devices 

There are specific devices that act as basic requirements which meet the needs for 
importing and digitising images. Figure 1.6 shows the examples of input and 
output devices used to support the digital imaging process. Each of the devices 
has its own function. A scanner scans images, the camera captures images and 
the printer prints out an image in hard copy.  
 

 

Figure 1.6: Examples of input and output devices 
 
(a) Scanner  
 The scanner is a device used to scan images of photographs, posters, books, 

magazines or similar sources for computer editing and display. To get a 
good quality image, the user can use a scanner that is capable of producing 
high resolution images. In addition, the high cost of the device also plays a 
role as it guarantees the quality of the scanned image. 

 
 The image can be scanned either in black and white or in color depending 

on its use. For example, it is suitable for image editing and manipulation 
process when scanning images in color regularly. Usually the scanned 
image can use 300 dpi for high resolution in printing. This is to ensure that 
the image displayed through printing gives a clear image and resembles the 
actual image as shown in Figure 1.7. Additionally, your computerÊs display 
can be set to a low resolution to 72 dpi. 
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Figure 1.7: The left image shows the high-resolution display,  
while the right image uses a lower resolution 

 
(b) Digital Camera  
 A digital camera is an essential tool for digital imaging. The ability to 

capture people and objects instantly makes it a necessity in our lives. 
Previously we have discovered the camera but now the smart phone also 
has a high pixel camera which has similar abilities to that of a camera. The 
pixel camera function is the same as the resolution in the scanner, but the 
main difference is the size of image captured, that is, measured in 
megapixels (millions of pixels). Figure 1.8 shows the pixel image that was 
captured using the digital camera.  

 

 

Figure 1.8: Image shows the pixels on the camera 



  TOPIC 1    INTRODUCTION TO DIGITAL IMAGING  
 

8 

(c) Printer 
 There are two types of printers which are the ink jet and laser printers. Ink 

jet printers are primarily designed to support individual users, and may be 
connected to a single computer. These printers are designed for low volume 
and require minimal set-up time to produce a hard copy. A laser printer 
rapidly produces high quality images and text. The price of laser printer is 
also high and can speed up the printing process because it runs with a 
single set of replacement cartridges. Most designers and publishers prefer a 
laser printer because it has a significant effect on the operation, speed, 
quality and permanence of documents. 

1.2.3 Hardware Extras 

Hardware refers to all physical parts of a computer. From the typical computer, 
the keyboard, mouse, Internet modem or printer are hardware that we use every 
day. A speaker, thumb drive and external hard drive are often also part of the 
hardware as shown in Figure 1.9. Now, the user may recognise additional 
hardware that can be used in a digital image, which are, graphic tablets and 
storage devices. 
 

 

Figure 1.9: The hardware extras that are commonly used in digital imaging 
 
(a) Graphic Tablet 
 A graphic tablet is a computer input device that allows users to hand-draw 

and edit images, animations and graphics by using a special pen-like stylus. 
The graphic tabletÊs function is similar to drawing using a pencil and paper. 
The tablet can also be used to capture data or signatures. It can also be used 
to detect an image of a piece of paper that is captured on the tablet surface. 

 
 It is used is to display an image on the desktop computer and charts the 

image to a more realistic picture. The creation of graphic tablets is not to 
replace the mouse, but aims to help designers produce work more easily 
and effectively while using digital imaging and manipulation. 

 
 



                                              TOPIC 1    INTRODUCTION TO DIGITAL IMAGING     
 
 

9 

(b) Storage Devices 
 Storage devices like pen drives, external hard disks, CDs, DVDs and floppy 

disks are the important devices in producing digital images. The storage 
device is a computer hardware that is used for storing, transferring and 
extracting data files and objects. It is capable of holding and storing 
information either permanently or temporarily. Storage devices can be 
found in two types of storage, one of which is the primary storage device 
that is designed to hold data temporarily and in smaller sizes. The storage 
can be found internally in a computer. It has the fastest data access speed, 
and includes RAM and cache memory.  

 
 The second data storage usually is permanent and has a large storage 

capacity. This storage can be found both internally and externally, such as 
hard drives, compact discs and USB storage devices. Figure 1.10 shows the 
examples of hard disks and pen drives that are used in storing data. 
SamsungÊs hard disk has the capacity to store data up to 16 terabytes 
(16TB), while the USB storage device has  a storing capacity of 128 
gigabytes (128GB).  

 

 

Figure 1.10: The hard disk and pen drive used for storing data 

 RASTER AND VECTOR IMAGES 

There are two types of computer graphics that are used in producing digital 
images, which are, raster images and vector images. Figure 1.11 depicts a raster 
image on the left and a vector image on the right. 
 

1.3 
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Figure 1.11: Raster image and vector image 
 

 

Figure 1.12: Image A is a raster image consisting of  
pixels and image B is a vector image composed by path 

 
Raster images are technically called bitmap images and consist of pixels. Each 
pixel can be of different shades and colors due to the use of a grid of individual 
pixels as shown in Figure 1.12. Bitmap images use pixels rather than objects or 
shapes. We can observe the technique when using photographs or any other 
digital painting by dragging the image from small to large. As a result, shown in 
Figure 1.13, a bitmap becomes jagged when the image is scaled up. 
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Figure 1.13: Bitmap images become jagged when using the magnification level 
 
Bitmaps sometimes require large amounts of storage space because of the large 
file size compared with vector images. When using bitmap images for 
magazines, newspapers, billboards or any other related tasks, the image 
resolution must be large (300 dpi) so user can get a bitmap image that is clearer, 
reflecting the actual image. Imagine if we have 2GB of data storage and the 
bitmap image is more than 2GB, what should we do? Of course, we will provide 
a larger storage space to accommodate the data. 
 
Vector images consist of paths and use mathematical interactions between points 
and the paths to describe an image according to its geometric characteristics. 
Vector images function can move, drag or modify the objects without losing the 
thoroughness and detail of objects because they are not resolution-
based. They maintain crisp sound edges when resized, printed to a PostScript 
printer, saved in the PDF file or imported into a vector-based graphics application.  
 
Vector images are the best choice to produce designs such as logos to be used in a 
variety of sizes. The size of the logo on posters and business cards is different. By 
simply dragging the logo, no matter how small or large, the logo still has the 
same position without being jagged as shown in Figure 1.14. 
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Figure 1.14: A scalable vector image will always appear smooth 
 

  
 

 
 
 Technology has enabled us to create high quality with digital imaging. 

Technology also has brought us various hardware and software, and users 
have to have the ability to understand and use them efficiently.  
 

 Although the most powerful smartphone has a lot of features, scanners and 
cameras are still the top priority when it comes to digital imaging. The 
technological advancements allow photographers to update and upgrade their 
hardware.  
 

 Another key thing to note is that in this field, large storage is very crucial . 
This is because of the large number of files that will be created and worked 
on.  

 

 

1. Use technologies that are around you such as smart phones, 
cameras or scanners to get the raster image. Then transfer the files 
onto a digital imaging software to see pixels in an image. 

 
2.  Explain the difference between raster images and vector images. 

ACTIVITY 1.2 
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Digitised  Converts (pictures or sound) into a digital form that can 

be processed by a computer. 
 

Devices  Gadget. 
 

Resolution  The number of pixels (individual point of color) used. 
 

Raster image  Image consisting of pixels.
 

Vector image  Consists of path and uses mathematical interactions 
between points and the paths. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 INTRODUCTION TO GIMP  

Hello students! Welcome to the world of computer programming. In this topic, 
you will be introduced to GNU Image Manipulation Program or GIMP. GIMP is 
a computer program used for editing, creating and manipulating digital images. 
It is a free and open-source program that has many capabilities for tasks such as 
resizing, cropping, photo retouching, image composition and web image. 
 

2.1 

TTooppiicc

22  
 Introduction 

to GNU Image 
Manipulation 
Program 
(GIMP) 

 
 

By the end of this topic, learners should be able to: 
 

1. Explain  the advantages of GIMP; 
 

2. Recognise the image menu bar; 
 

3. Name the toolbox; and 
 

4. Work with tools. 

LEARNING OUTCOMES 
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GIMP has an expandable and an extensive amount of tools that can be used for 
modifying images. It is designed to be enhanced with the use of extensions and 
plug-ins in order to accommodate what the user intends to do. It also has a 
flexible and in-depth scripting interface that allows access from simple tasks to 
advanced procedures in image manipulation. 
 
Refer to the following Figure 2.1. The image looks more attractive and beautiful 
after the editing process. Have you ever experienced when an image you 
captured, did not satisfy you? Have you ever imagined your images having the 
potential to be more interesting with image manipulation techniques such as 
having a galaxy as a background or with an actor that interests you? With GIMP, 
everything is possible. You just need to download the program and you are 
ready to go. You can get GIMP at www.gimp.org.  
 

 

Figure 2.1: Images shown before (left) and after editing using GIMP program 
 
GIMP was developed by Peter Mattis and Spencer Kimball in 1995 as a semester 
long project at University of California, Berkeley. The acronym GIMP originally 
stood for General Image Manipulation Program, but then it was changed to GNU 
Image Manipulation Program because of the operating system it worked on, 
which was GNU by Richard Stallman. GIMP was first released to the public in 
1996. Today, GIMP has grown into a popular open source digital imaging with 
users and contributors from around the world. 
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GIMP offers something different in comparison with other similar software. It 
has windows and dialogs that have a non-blocking function. This means that you 
are able to have the File Open, File Save, or Preferences windows up, yet GIMP 
does not prevent you from changing tools in the Toolbox or editing on your 
images in the background. This is very useful in terms of productivity. You can 
perform time-consuming operations on the image and do seamless multitasking 
with various works. You can customise your choice quickly and change them as 
you work to suit your needs. Basically, GIMP sticks with what you are doing and 
does everything in its power to get out of your way while you work. 

 INTERFACE LAYOUT OF GIMP 

One of the first things you might notice about GIMP is that it appears to be like 
Adobe Photoshop because of the number of windows that it opens. In the large 
window, it contains the various images which allow you to control and use the 
toolbox, image window and layers on each image separately. You can select a 
window which can be viewed at any time. 
 
To be familiar with GIMP, first you must know the GIMP interface layout and its 
functions. When the GIMP launches you are welcomed with a window that 
displays the preloaded GIMP plug-ins and extensions into memory (Figure 2.2) 
and this only takes a few seconds. When GIMP loads, you usually have three 
windows that appear on the screen which is the toolbox (tool options on the left), 
image window in the centre and dock on the right side of the dialog options to 
include layers, brushes and pallets as shown in Figure 2.3.  
 

 

Figure 2.2: Welcome screen of GIMP 
 

2.2 
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Figure 2.3: The interface layout of GIMP also known as GIMP windows 
 
Each of these windows has its own purpose in GIMP, but as you may have 
guessed, the main image window with animate menu bar along the top is where 
all the action happens. Almost all editing operations can be applied directly from 
the image window and the image menu bar. When there is no image loaded, 
there is only a gray box with a shadow Wilbur, the GIMP mascot and an image 
menu bar at the top.  
 
However, when you load the first image in GIMP, it is placed in this window. If 
you have more than one image open, each one gets its own image window with 
image menu bar that is included in it (Figure 2.4). 
 

 
Figure 2.4: Image Menu Bar 
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 UNDERSTANDING THE WORKSPACE 

Before beginning the first task in digital imaging, you have to understand in 
detail the work space in the GIMP. GIMP has a very straightforward interface, so 
it does not take a long to get used to. GIMP was created to help users and act as a 
friend for anyone interested in digital imaging. The GIMP user interface can be 
used in two modes which are the multi-window mode and the single-window 
mode shown in Figure 2.5. 
 

 

Figure 2.5: Single window mode 

2.3.1 Single-Window Mode 

GIMP introduced the single-window mode in version 2.8++. Martin Northolt and 
Michael Natterer were the people responsible for developing the single-window 
mode GIMP. To enable the single-window mode you can switch between the 
default multi-window mode and single-window mode through windows in the 
image menu bar and select single-window mode. In single-window mode, GIMP 
will put the toolbox, image window and layers in one tab. When using this mode, 
the panel on the left and right cannot be moved, but you can still reduce and 
increase the width of the panel by dragging the corner or edge of the panel. 
Single-window mode settings can be preserved if you quit and start GIMP again. 
The single window mode will be removed if the user switches to the multi-
window mode. 
 
 

2.3 
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2.3.2 Multi-Window Mode 

In the multi-window mode, windows are floating along the edges of that main 
window (Figure 2.6). This mode is called floating because the left and right dock 
is flexible and can be moved. The image window can also be moved, minimised 
and maximised. To use this mode, you can change the settings in the image menu 
bar and select the window, and enable it by pressing a single-window mode that 
is shown in Figure 2.7. Indirectly it will change the mode into the multi-window 
mode. 

 

Figure 2.6: Multi-window mode 
 

 

Figure 2.7: Unable single-window mode to change multi-window mode 
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 THE IMAGE MENU BAR  

The image menu bar is available to you in the image window. It gives you access 
to almost every action in GIMP. Another image menu bar is available by right-
clicking anywhere within the image area of any image window. When you right-
click your mouse, a menu list will appear like the one shown in Figure 2.8. This 
menu bar is easier to access without the need to move the mouse as far to get the 
menu item that you are looking for. Here you can find each menu item: 
 

 

Figure 2.8: The Image Menu Bars 
 
File 
Functions in order to open existing 
files, create new files, saves and 
export images. This menu (Figure 
2.9) also gives the ability to acquire 
images like screenshots and images 
from a scanner. 

 

Figure 2.9: The file dialog 
 

2.4 



  TOPIC 2    INTRODUCTION TO GNU IMAGE MANIPULATION PROGRAM (GIMP)     
 
 

21 

Edit 
The Edit menu is where a lot of 
the basic work gets done on your 
images. From here you can copy, 
paste, undo and perform basic 
actions like filling and stroking 
as shown in Figure 2.10. 

 

Figure 2.10 
 

Select 
From this menu (Figure 2.11), 
you can control your selections 
within the image window. It also 
provides various options for 
choosing and modifying 
selections. 

 

Figure 2.11 
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View  
Provides viewing options for 
images and also shows and hides 
features as shown in Figure 2.12, 
like guides and layer boundaries 
as well as turn on snapping. 

 

Figure 2.12 
 

Image  
The image menu allows you to 
adjust image orientation, perform 
basic transformations, size 
adjustments, cropping, printing 
images and canvas settings shown 
in Figure 2.13. 

 

Figure 2.13 
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Layer 
Function used to create new 
layers, duplicate existing layers, 
delete layers and also provides 
works with layer properties 
(Figure 2.14). 

 

Figure 2.14 
 

Colors 
Accesses the color adjustment 
dialogs, such as color balance, 
levels, posterize, curves, 
desaturate and hue-saturation as 
shown in Figure 2.15. 

 

Figure 2.15 
 

Tools 
This functions as a toolbox like 
on dockable dialogs (Figure 
2.16). 
 

 

Figure 2.16 
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Filters 
Provides tools for filtering 
images, such as blurring or 
sharpening, as well as artistic 
and specialty filters (Figure 
2.17). 

 

Figure 2.17 
 
Windows 
Figure 2.18 shows the toolbox and dockable dialogs and provides the window 
modes such as single-window mode and multi-window mode. 
 

 
Figure 2.18 

 
Help 
The menu (Figure 2.19) is the route to find help needed by linking to the online 
GIMP user manual. 
 

 

Figure 2.19 
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 THE IMAGE NAVIGATION BAR  

This is a new feature available in GIMP 2.8. The Image Navigation Bar as shown 
in Figure 2.20 allows you to easily view all the thumbnails that are open in GIMP. 
 

 

Figure 2.20: Image Navigation Bar 
 
To select the image, simply click on the thumbnail images displayed in the 
workspace. The thumbnail image will be active at the forefront. The Image 
Navigation Bar only displays if two or more images are open. 

 THE TOOLBOX 

The toolbox window is the main window of GIMP. It appears automatically 
when running GIMP. The purpose of the toolbox window is used to provide a 
variety of tools to make it easier to create, manipulate and edit digital images. 
Figure 2.21 is an example of the toolbox window of GIMP. 
 

2.6 

2.5 
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Figure 2.21: The toolbox window 
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Each tool can be identified when hovering the cursor over the icon where the tool 
name will appear. The small call-out will pop up a brief description of its 
function and the keyboard shortcut. 
 

 

Figure 2.22: The small call-out describing Scissors Select Tool 
 
As a beginner you do not have to memorise all the keyboard shortcuts of GIMP. 
The important thing is to identify the function and purpose of each tool. Refer to 
Table 2.1 which shows the tool name, function and shortcut key. 
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Table 2.1: Tool Shortcuts and Functions 

Icon Name Shortcut 
Key Tools Function 

 
Rectangle R Selects areas in a rectangular or square 

shape 

 
Ellipse E Selects areas in an elliptical or circular 

shape  

 
Free Select F Selects areas in a free-form or polygonal 

shape 

 
Fuzzy Select U Selects continuous areas of color 

 
Select by Color Shift + O Selects areas of similar color 

 
Intelligent Scissors I Selects shapes, using intelligent edge fitting 

 
Foreground Select (none) Selects an area with foreground objects 

 
Path  B Creates and modifies paths 

 
Color Picker  O Selects colors from image pixels 

 
Zoom  Z Adjusts the level of magnification of the 

current image 

 
Measure Shift + M Shows distances and angles 
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Move  M Moves current selections and layers 

 
Align  Q Aligns or arranges current layers and other 

objects 

 
Crop  Shift + C Removes edge areas from the image or 

layer 

 
Rotate  Shift + R Rotates active layer, selection, or path 

 
Scale  Shift + T Scales active layer, selection, or path 

 
Shear  Shift + S Shears active layer, selection, or path 

 
Perspective Shift + P Changes the perspective of the active layer, 

selection, or path 

 
Flip  Shift + F Reverses layers, selections, or paths 

vertically or horizontally 

 
Cage  Shift + G Deforms a selection with a cage 

 
Text  T Creates or edits text layers 

 
Bucket Fill  Shift + B Fills an area with a color or a pattern 

 
Blend  L Fills an area with a gradient 
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Pencil  N Draws hard-edged lines 

 
Paintbrush  P Paints smooth strokes with a brush nib 

 
Eraser  Shift + E Removes pixels from a layer 

 
Airbrush  A Paints with variable pressure, similar to a 

paint spray gun 

 
Ink  K Paints in calligraphy-style 

 
Clone  C Copies pixels from one part of an image to 

another 

 
Healing  H Blends the surrounding to patch image 

irregularities 

 
Perspective  (none) Clone from an image source, after applying 

perspective 

 
Blur/Sharpen  Shift + U Selective blurring or sharpening, by using a 

brush 

 
Smudge  S Selective smudging, by using a brush 

 
Dodge/Burn  Shift + D Selective lightening or darkening, by using 

a brush 
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 An introduction to GIMP is important not only for improving skills but to 

understand the function of each dockable dialog on the GIMPÊs window. This 
knowledge helps you to understand every aspect of the GIMP and purpose of 
the tools. As stated previously, an overview will help you to get acquainted 
with GIMP, in order to get a more in-depth look. However, access to GIMP 
User Manual is also required. 

 

 
 
Interface  The controls used in a software that allow the user to 

interact with the software. 
 

Menu bar  Is a region of a screen or application interface where 
drop down menus are displayed. 
 

Navigation bar  A set of buttons or images in a row or column that 
serves as a control point to link to the other sections. 
 

Toolbox  A window that contains icons and buttons that are tools 
in the software. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 THE IMPORTANCE OF TOOL FUNCTIONS  

In the last topic, you learned briefly about the types and purposes of each tool. 
Each tool plays a role as an agent  editing and manipulating images that need to 
be improved. Identifying the types of tools is essential because it makes the 
process of transforming images more efficient. The types of tools are now 
divided into four categories: selection tools, paint tools, transform tools and color 
tools.  

3.1 

TTooppiicc

33  
 Tool 

Functions 
and Layers  

 
 

By the end of this topic, learners should be able to: 

1. Explain the function of selection tools; 
 

2. Differentiate between various selection tools; 
 

3. Apply the selection tools; 
 

4. Describe the purpose of layers; and 
 

5. Work with the layers panel. 

LEARNING OUTCOMES 
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3.1.1 The Selection Tools  

GIMP provides a range of selection tools that enables you to select certain parts 
of the image you are working on. The main purpose of the selection tools can be 
summed up by the selected boundary in which you are able to make edits to the 
pixels of that specific area without affecting the rest of the image that is outside 
of the boundary. Each tool has its specific purpose, but there are also some things 
in common in terms of options and features. There are seven selection tools that 
are shown in Figure 3.1. 
 

 

Figure 3.1: The Selection Tools 
 
In the following figure (Figure 3.2), the Free Select tool is one of the most 
commonly used selection tools. It allows you to create an outline selection by 
drawing around the area desired. If you prefer to select according to the color 
types, then Fuzzy tool is the better option as it determines the specific parts that 
shares the same color palette or attribute (Figure 3.2). 
 

 

Figure 3.2: The left is The Free Select tool and the right is The Fuzzy Select tool 
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3.1.2 The Paint Tools  

The Paint tools mainly lets you paint, fix problems or irregularities and also 
applies local exposure correction. The Paint tools consist of 13 different tools 
within the dialog, as shown in Figure 3.3. Amongst all of the main tools in the 
dialog that are used for retouching and restoration, there are two tools that 
synergise with each other, that is the Clone tool and Healing tool. These two are 
often used to fix damages or problems in the image you are editing as shown in 
Figure 3.4 and Figure 3.5. 
 

 

Figure 3.3: The Paint Tools 
 

 

Figure 3.4: Correcting the imperfections using the Clone tool 
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Figure 3.5: Repairing damage with the Healing tool 
 
The Clone tool works by taking samples of the pixels from a part of an image. 
Then, it is pasted on a separate part of the image. The Healing tool uses the 
textures and tones of the sampled region around the area. The pixels are then 
blended in with the image to fix the irregularities. The Clone tool can be accessed 
by clicking Tools > Paint Tools > Clone Tool or you can find it in the toolbox. To 
clone from an image, use the Ctrl key to select the base color. If you are cloning a 
pattern, it has no effect. Cloning can be done on any layer of any image. While 
the layer is active, by holding the Ctrl key, then clicking on the image, the cloning 
action has taken place.  
 
Usually, the Clone tool is best used for fixing large irregularities such as crease 
and cracks, while the Healing tool can also be used to fix small irregularities. It is 
best used in removing facial flaws when retouching portraits. The Healing tool 
can be accessed by clicking Tools > Paint Tools > Healing Tool or you can find it 
in the toolbox. Similar to the Clone tool, healing can be done on any layer as well. 
By holding the Ctrl key, then clicking on the image, the healing action has taken 
place.  
 
When the alignment is set to „Aligned‰ or „Non-aligned‰, the origin of the 
healing takes place at the point you clicked on. The Heal tool will take the data of 
the image from the point taken, then converts it as the first paint afterwards. In 
source-selection mode, a crosshair symbol will take place instead of the cursor. 
Once the source is set and the key is pressed, a thin line will appear that connects 
the previously clicked point with the location of the current pointer. If it is 
clicked once again while holding the Shift key, the tool will heal along this line. 
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3.1.3 The Transform Tools  

Transform tools (Figure 4.6) enable you to change the position, orientation, 
perspective and size of an image, layers or selected regions. These tools are very 
beneficial for re-composting, straightening images and as well as correcting lens 
distortion. 
 

 

Figure 3.6: The Transform Tools 
 

 

Figure 3.7: Using the Scale tool 
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The Scale tool that is shown in Figure 3.7 is used to scale subjects such as 
selections, paths and layers. When the Scaling Information dialog opens, and you 
click on an image, it allows Width and Height to be changed. Simultaneously, the 
object will have a superimposed preview with the corners and borders having 
handles so that you are able to drag and click to change dimensions. At the center 
of the Preview, a circle will appear that allows the preview to be moved. The 
Scale tool can be accessed through Tools > Transform Tools > Scale Tool or 
clicking the tool in the toolbox. 

3.1.4 The Color Tools  

Color tools enable access to features such as adjusting hue, saturation, color 
balance, brightness, levels of lightness and contrast. You are also able to 
greyscale an image, convert it into black and white according to pixel value and 
adjust the intensity range of a channel, color, brightness, contrast or transparency 
in a suitable way, decrease the number of colors and change all color channels to 
shades of grey. 
 

 

Figure 3.8: The Color tools 
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Figure 3.9: Colorising an image 
 
Figure 3.9 shows the Colorise tool being used to convert the base image into one 
with desired color. The Colorise tool converts or selects a color by hue, saturation 
and lightness. 

3.1.5 Other Tools  

There are other tools which are not mentioned in previous topics. The tools are 
Path tool, Color Picker, Zoom tool, Measure tool and Text tool. Figure 3.10 shows 
the other tools used to support the image editing process.  
 

 

Figure 3.10: Tool that is not listed in any category 
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 LAYER  

In simple terms, a layer is the stack of images on top of one another. The purpose 
of layers is the ability to work on an individual surface or plane without affecting 
other layers of the image. Another example of layers is similar to transparency 
papers that are stacked on top of another, which can also be adjusted and 
individually drawn on without affecting each other. The final image can be seen 
when the top layer is opaque. If the top layer is transparent, you are able to see 
through to the following layers below. Additionally, if the following layer also 
has transparency, you can see the next layer down. Figure 3.11 shows how the 
image is arranged layer by layer.  
 

 

Figure 3.11: The image created by layer 
 
Layer also makes the working process efficient if there are any changes or 
updates to be made on your work. A project with multiple layers makes it easier 
to pinpoint the origin of changes or mistakes. Simultaneously, it makes the work 
flow much more manageable. The sample illustration shown in Figure 3.12 
shows how a complete composite is made with varying elements of layers 
blended together. 
 
 

3.2 
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Figure 3.12: Separate layers form a complete picture 

3.2.1 Learning Basic Layer 

In update 2.8, GIMP added Layer groups. It is a very helpful feature for 
managing large amount of layers. You have the ability to toggle a group to 
visible or invisible. This enables smoother workflow when you work with large 
number of layers of complex images (Figure 3.13). I named the layer group Tonal 
Adjustment Layer Group due to some images that may consist of more than one 
layer group, varying on working complexity. 
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Figure 3.13: The layers dialog 
 
(a)  Layer Mode 
 Up until now, you have only seen layers in the Normal mode: where the 

top layer is visible and opaque, while transparent layers allows you see 
through following layers. However, layers also have their own features, 
such as Overlay, Multiply, Dodge or Burn. With varying mathematical 
functions you are able to combine two layers to complement the features 
above. 

 
(b)  Opacity 
 Previously, you were able to create transparent regions, now a layer can be 

fully transparent, opaque or in-between. When making a drop shadow: the 
opacity is automatically set within the Drop-Shadow dialog in the 
transparency entry of the shadow drop layer. By selecting the shadow layer 
in the Layers dialog, from the Opacity slider, you can see that a particular 
part is not at 100%. Now try modifying the opacity, and see the changes it 
has made on the shadow. The opacity slider can be used to produce effects 
that can be beneficial such as being able to make a text layer look like it is 
floating over an image by making it translucent.  
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(c)  Keep Transparent  
 Keep Transparent is used as a synonym for the Lock icon. Next to it is a 

checkered icon similar to the GIMP background. This indicates 
transparency. It acts as a reminder for the buttonÊs definition. Each GIMP 
version has its own position variation: it might appear to the right of the 
Layer mode menu or under it, but for easier inspection, find the checkered 
icon. While Keep transparent is checked, you are not able to draw 
anywhere because the current layer is transparent. This can be beneficial for 
drawing, but it could also create confusion. 

 
(d)  Layers List 
 Under the opacity slider is the list of layers of the image (a scrollbar is 

provided when the amount increases), one layer for each line. Another term 
is layer stack, because they are stacked on top of one another. While you are 
already know some of the buttons, there are still some you have not seen 
yet. 

 
(e)  The Visibility Eye 
 To the furthest left is the Visibility icon, with an eye indicator. When 

enabled, the layer becomes visible; when disabled, it turns invisible. By 
clicking on the eye, it toggles the layerÊs visibility. Shift-clicking only makes 
that layer visible; consecutive Shift-click returns all the other layers back. 

 
(f)  The Chain Link 
 Next is the Chain link icon. When this icon is displayed on several layers, 

they are bound together. Modifying or moving any one of the layers (such 
as Rotate tool) will simultaneously work on all of them. By Shift-clicking on 
the icon, the link between layers are then removed. This can be used as a 
shortcut when working with a lot of layers to either link or unlink them. A 
second Shift-click will select the whole layer of the image. 

 
(g)  The Layer Preview 
 The Layer preview provides a small thumbnail of how the layer looks like. 

Although you are unable to differentiate two text layers, it can be used to 
differentiate image layers apart. Double-clicking on the preview brings up a 
dialog that enables layer attributes to be edited except for a text layer, in 
which double clicking will bring up the text edit window. Another method 
of selecting a layer is to click on the preview image in order to make it 
active. This is also to ensure that if you draw, you are not drawing on its 
mask, but on the layer itself. 
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(h)  Layer Masks 
 The Layer mask preview is located on the right of the layer preview (if a 

layer mask is visible). Visible parts of the layer can be controlled by masks. 
Not all layers have masks; however when a mask does exist, even if it is 
white, the layer is visible. While if it is black, the layer is determined to be 
invisible (transparent) regardless of the contents on it. In order to use layer 
masks, simply click on it. When drawing within a masked area, only the 
mask area will produce results, not the layer itself. While selecting a layer, a 
border indication will highlight either the layer preview or mask. This is to 
indicate that the selection is active. A layer mask can also be used to 
represent transparency. Furthermore, in some cases, it is more suitable to 
work with masks compared to transparency.  

 
(i) Layer Name 
 Besides the layer and mask previews is the layer name. You can select the 

layer by clicking the name; you can edit the layer name by double clicking 
the name. 

 
(j)  Layer Buttons 
 The bottom part of the Layers is a row of icons that enables you to produce 

or remove layers as well as change the existing orders of layers. You can 
choose to click on them or drag a layer on top of them. Each of them have 
tooltips, which can help you to determine what each button does.  

 
(k)  The New Layer Button 
 The button at the furthest left is the New Layer button; it creates a new 

layer. You can then pick a layer name, size and fill color. When dragging an 
existing layer onto the New layer button, it produces a blank new layer 
with the similar size and position. New layer can also be used to change a 
floating selection into a regular layer. 

 
(l)  The Raise and Lower Buttons 
 The buttons with the up and down arrow indicates the Raise and Lower 

buttons, it is used to move a layer stack accordingly. When you want an 
item to appear on top of something else, simply change the orders with 
these buttons. 

 
 You can also reorder the layers by dragging a layer preview to a new place 

in the layer stack. In addition, you can drag a layer preview outside of the 
Layers dialog to create a new image, creating a copy as a new layer in that 
image. You can also drag to the Toolbox to make a new image only 
containing that layer. 
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(m)  The Duplicate Layer Button 
 Duplicate layers make an exact copy of the current active layer with the 

exact properties, or any layers when you drag onto the button. The layer 
can be then moved up or down in the layer stack, or it can be changed in 
many ways. 

 
(n)  The Anchor Layer Button 
 Anchor layer enables merging of a floating selection with whichever layer 

was previously active. 
 
(o)  The Delete Layer Button 
 Delete layer removes the active layer. Dragging the layer to the button will 

also delete it. 

3.2.2 Creating a New Layer 

Now you will learn how to make a new layer. It is simple to learn in the 
following detailed tutorial. You can give it a try after this tutorial. 
 
To create an image, first you must select File > New as shown in Figure 3.14. 
 

 

Figure 3.14 
 

If the layers dockable dialogs does not open, you can access it from Windows > 
Dockable Dialogs > Layers. 
 

 

Figure 3.15 
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There are two methods to create a new layer. First is from the menu Layer > New 
layer (Figure 3.15). Second is from the icon at the bottom left of Layers Dockable 
Dialogs (Figure 3.16). 
 

 

Figure 3.16 
 
On the pop up dialogs, you can set layer name, size and layer fill type. If you 
want to change the layer color just set at the foreground color according to the 
color in the toolbox (Figure 3.17). 
 

 

Figure 3.17 
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(a) Adding Images  
 To add images you can directly open images as a layer in the same 

document image without copying and pasting. Just go to File > Open as 
Layers. Figure 3.18 shows how to directly open images.  

 

 

Figure 3.18: Open image from Open as Layers 
 

An alternative is to open your images from File > Open. After you find and open 
your image, go to Edit > Copy as shown in Figure 3.19. Then paste it on your 
working image file. 
 

 

Figure 3.19: Copy and Paste features 
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(b) Erasing Image 
 To erase an image of the current layer, open two images from File > Open 

as Layers and press Ctrl on your keyboard while selecting the images. The 
selected images will automatically open as a layer in your working image 
file. Now click the layer image on top. Go to Layer > Transparency > Add 
Alpha Channel (Figure 3.20). This will make the selected image transparent 
when erasing the background. Then select Eraser Tool (Figure 3.21) on 
Toolbox group and start to erase the selected image layer. 

 

 

Figure 3.20: Erasing image by Alpha Channel 
 

 

Figure 3.21: Erasing area that has been selected 
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(c) Layer Mask 
 This can also be used as an alternative for erasing or removing background 

images. However, this only covers some parts without permanently erasing 
while having the ability to control which area is visible or invisible 
(transparent). To start using the Layer Mask, open your image from File > 
Open as Layers. Click on the image layer and then go to Layer > Mask > 
Add Layer Mask (Figure 3.22). On the pop up dialog choose White (full 
opacity) and click Add. Then you can see white rectangle beside the layer 
preview. 

 

 

Figure 3.22: Layer Mask 
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Select Paths Tool on Toolbox as shown in Figure 3.23, then start drawing around 
the area where you want to make it visible. 
 

 

Figure 3.23: Selection object using Path Tool 
 
After finishing drawing the paths, go to Select > From Path. Again from Select > 
Invert to make it select the area you want to be transparent. See Figure 3.24 
which shows the steps on the process of transparent background.  
 

 

Figure 3.24: Invert Function 
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Choose Bucket Fill Tool as shown in Figure 3.25. Make sure your Foreground 
color is black and fill it on the selected area. 
 

 

Figure 3.25: Bucket Fill Tool 
 
You can now see the layer mask preview (Figure 3.26) showing black and white 
drawings. The white color is the visible one while the black is transparent. 
 

 

Figure 3.26: Layer Mask preview 
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(d) Grouping and Merging Layers  
 Grouping layers is a way to make your layers look more organised. It is 

important, so that if you have many layers, it makes it easy to find related 
edited images. Another method is by merging or flattening layers. 
Although this is simple and fast, you cannot tweak or adjust the originals 
after it has merged into single layer. 

 
(e) Grouping Layers 
 To make a new group, go to Layer > New Layer Group. You will see a 

folder icon and by default its name is ÂLayer GroupÊ. You can change the 
name by double clicking on the Layer Group folder as shown in Figure 3.27. 

 

 

Figure 3.27: Grouping Layers 
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Select which layer you want to put in the Layer Group and drag it into the folder. 
Figure 3.28 shows how to select a layer and create it in Layer Group.  
 

 

Figure 3.28: Layer Group 
 
The Layer Group folder icon will change into a preview of the image layers 
inside it that is shown in Figure 3.29. 
 

 

Figure 3.29: Preview Layer Group 
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Merging Layers 
There are three ways available for merging layers. Merge Down (Layer > Merge 
Down)  This option will merge selected layers together with the layer below it 
(Figure 3.30). 
 

 

Figure 3.30: Merging Layers 
 
Figure 3.31 shows the function of Merge Visible Layers (Image > Merge Visible 
Layers)  This option will merge more than two layers. It only merges visible 
layers that you can see with the eye icon . 
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Figure 3.31: Merge Visible Layers function 
 
Flatten Image (Image > Flatten Image) shown in Figure 3.32  this will flatten the 
entire layers into a single layer. This option does not support alpha channel 
(transparent) like the other options. 
 

 

Figure 3.32: Flattern image function 
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 Understanding the key functionalities of a program is very crucial and 

beneficial as it can be used in preparations for becoming a designer. Having 
the proper amount of knowledge indirectly builds and expands our skills.  
 

 Every function has its own purpose and objective, functions such as 
cropping, painting, erasing, cloning, scaling, colorising and so forth, 
contributes the most to creating an image.  
 

 GIMP is easy and simple to understand, from basic functions such as layers, 
in which the layer dialog itself is fully equipped with a variety of tools that 
can be used for edits and manipulations.  

 

 
 
Tools  A set of basic components or accessories that performs a 

specific task. 
 

Retouching  Alteration of work for enhancement.
 

Layer  Different level on which objects or drawings are place 
on. 
 

Transparent  Invisible.

 
 
 
 
 
 
 
 



 

 

 

 

 

 

 

 

 

 

 

 

 A FILE FORMAT  

GIMP helps to create, manipulate and edit digital images. Modified images are 
then saved as a file. With GIMP, it is possible to manage files and the data 
contained therein. Whether you have a high or low resolution image, you can 
still save it. The stored data can be found everywhere, on the desktop, internal 
storage such as the Local Disk C or an external storage such as a pen drive or 
hard disk provided when opening the file, GIMP must be installed in the system. 
For example, say you edited an image on your personal computer and then you 
wish to open the file on another computer. If the computer does not have GIMP 
software, these images cannot be opened. Before going further into file storage, 
you will need to learn how to open a file and what format you need to save the 
file in. 
 

4.1 
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 File Format 

and Sizes 

 
 

By the end of this topic, learners should be able to: 

1. Determine document file formats; 
 

2. Determine the image size; 
 

3. Explain the relationship between size and resolution; and 
 

4. Determine files compression. 

LEARNING OUTCOMES 
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4.1.1 Opening Files 

The first step is to open the file. There are two methods to open a file, first is by 
going to the image menu bar, and then select open (File > Open) as shown in 
Figure 4.1. An image dialog will appear. Wait for instructions to select the image 
to be edited. Another way is to drag the image from the computer desktop to the 
GIMP image window (Figure 4.2). 
 

 

Figure 4.1: GIMPÊs file image menu bar and the available options therein 
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Figure 4.2: Dragging image from desktop file to GIMP image window 
 
GIMPÊs Open Image dialog will bring up files and folders that are ready to be 
opened. In  Figure 4.3, a sequence of buttons represents the location of the 
current selected folder. Clicking on the button moves you up by one level, or 
more. You can select one or more files at a time in the file list. Click on the first 
file, and then press the Shift key while clicking to highlight multiples files then 
release Shift to open the files (Figure 4.4). Another option is to hold down the Ctrl 
key while you click individual files. GIMP will open each file as a separate image 
(Figure 4.5).  
 

 

Figure 4.3: GIMPÊs Open Image dialog 
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Figure 4.4: Use Shift key while clicking to highlight multiple files 
 

 

Figure 4.5: Use Ctrl key to select individual files 
 
In order to locate a particular file, you can use Ctrl + L (Figure 4.6) or click a 
bookmark by typing the file name in the file list. On the left side of the dialog is a 
list of bookmarks, you can click on a bookmark to jump directly there, or add the 
current folder to the bookmarks list by clicking the Add button. Below is a list of 
files according to the file name, start All Images. You can use this menu to limit 
the types of images you see in the dialog. Under the Add and Remove buttons is 
the Expander to select the file type. 
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Figure 4.6: Use Ctrl L to locate the file 
 
GIMP also provides two more options in the file menu which are Open Location 
and Open Recent as shown in Figure 4.7. Open Location is used to open a 
website by putting the URL of the site, while Open Recent is show your recently 
created or edited works. If the file is no longer listed in Open Recent menu, you 
can find it in Document History at the bottom of the Open Recent menu. 
 

 

Figure 4.7: Open Location and Open Recent file 
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 MANAGING FILE SIZE  

File size management is a feature in an operating system or program used to 
determine the appropriate size of the file depending on the design requirements. 
For example, images used to produce billboards certainly have to use large size 
images so that the image is clear and unambiguous. In the next subtopic, you will 
learn how to determine the size of a file or image, which is scaling and size 
requirements in the image. 

4.2.1 Scale the Image Size 

Image scaling is usually used to enlarge or reduce the horizontal (X axes) or 
vertical (Y axes). It can also scale on both axes simultaneously. Scaling depends 
on the image file captured on a scanner or camera. Resolution plays an important 
role because it determines how clear the image can go up to. As an example, 
modern digital cameras can take amazing and stunning photos in high resolution 
which is 10 megapixels or even more. That is great, but higher resolution makes 
larger files for at least half a megabyte each and perhaps much more. If you put a 
large image on the web or e-mail, the resolution of the image will be downscaled 
so that the image on the web and e-mail will be lightweight and easy to handle. 
Remember, if you edit with a digital camera photo or scanner, it is a good idea to 
make a copy of the image first, and then edit the copy. Although you can use 
GIMPÊs Save As dialog to save a file to a different name, it is easy to forget to do 
that and thus overwrite your original image. 
 
After opening an image, the first thing is that GIMP opens the file at a resolution 
suitable for viewing. For example, for images such as a sample or original image, 
which are usually large, GIMP will zoom accordingly for a suitable viewing of 
the image itself. The status area at the bottom of the Image Window shows the 
current zoom level. However, the actual image remains unchanged. 
 
 

4.2 
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Figure 4.8: The scale image dialog 
 
The dialog shown in Figure 4.8, is the Scale Image. It is accessible under the 
Image menu under image window: Image > Scale Image. 
 
In Figure 4.8, within the scale image dialog, there are three key things to note: 
width, height and resolution. The resolution only takes effect during printing, not 
when displayed on a monitor or mobile device. This is because different displays 
have their own pixel density. For example, images that are displayed on mobile 
phones usually appear smaller due to its size in comparison to a large projected 
LCD panel. For this reason, the resolution section can be ignored. In addition, 
strictly only work with pixel within the height and width fields. 
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Here, you can see an icon between the width and height indicating a chain that is 
linked together. In this state, if you input a new number on either width or height 
field that is shown in Figure 4.9, then hit the Tab key or click on another surface. 
The numbers will then scale accordingly to the chained aspect ratio. This chain 
linking prevents your images from getting distorted. 
 

 

Figure 4.9: The scale image dialog with pixels 
 

If you want to scale the parts separately, unchaining the icon will disable the 
linking feature that is shown in Figure 4.10. This enables you to change singular 
parts of the content. Afterwards, clicking on the link icon will bring it back to the 
previous linked chain state. While working in pixels, you could also use pre-set 
scaling in percentages within the units menu. The scaling will use the current size 
as base percentage which is 0 per cent. If a number is set on either width or 
height, such as 200, the image is then scaled twice as large, while setting it to 50 
will reduce the image to half of its original size. 

1. Explore two ways to open an image file. Open images as much as 
possible and see the image on the image navigation bar. Which 
techniques do you prefer to open it with? 
 

2. Use the scale images to create three different image scales and see 
the difference. Explain why the scale images are important. Share 
your findings with your coursemates in the online forum or face 
to face interaction. 

ACTIVITY 4.1 
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Figure 4.10: Unlinks width and height 

4.2.2 Images Compression 

In instances where an image takes up a large chunk of space on your disk, you 
can reduce its size without affecting the dimensions of the image. In order to 
achieve the optimal compression, save it in JPG format. Even if the file itself is 
already in the format mentioned, you are still able to reduce its size. JPG has a 
special compression ability which it enables various compression levels. The 
downside of this is even if it does take lesser space, the original details of the 
image are reduced accordingly. Another important thing to note is that, saving 
repeatedly as a JPG while reduce the quality even further. You can save an image 
in JPG through File > Export As dialog (Figure 4.11). In previous versions of 
GIMP, Save As was the universal command in order to save files. However, XCF 
is the only format that will make the Save As dialog appear, while other file 
formats can only use Export As. 
 

 

Figure 4.11: The export as dialog 
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Figure 4.12: The export as dialog 
 
In Figure 4.12, a dialog is shown with the same file name in the Name box. If an 
image is yet to be saved as a JPG image, remove the existing file extension and 
type JPG. GIMP will then determine the file based on the file extension. From the 
file extension list, you can view the types of file formats supported by GIMP. The 
extensions vary depending on the installed libraries. 
 
The Export as JPEG dialog uses default values that reduce size while retaining 
good visual quality; this is the safest and quickest thing to do. 
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Figure 4.13: Export as dialog with poor quality 
 
By reducing the quality of an image, the file itself will continue to be smaller. 
Taking note that quality reduction will make the image deteriorate, always make 
sure to „Show preview in image window‰, in order to measure the quality 
deterioration. Figure 4.13 shows the Quality is set to 10 and the image produced 
is of very poor quality while using little space. Figure 4.14 shows that a more 
suitable image is present. At 75 Quality level, the image produced is suitable for 
web pages. It also still uses lesser space, which in turn, loads faster for viewing 
purposes. 
 

 

Figure 4.14: Example of Low and High JPEG Compression 



                                                                  TOPIC 4    FILE FORMAT AND SIZES     
 
 

67 

  

4.2.3 Other Files Compression 

GIMP is capable of reading and writing with a large library of graphic file 
formats. The only exception to this is XCF, which is GIMPÊs native file type; 
however, file handling is done by the use of the plug-ins. For this reason, it is 
simple to have GIMP support extensions of upcoming file types when they 
arrive. 
 
When you are working with an image, you usually want to save the result. A key 
tip is to always save often at random stages of the process. While GIMP looks like 
a very solid program, there are possibilities that a software fault can occur. The 
files that GIMP are able to open, are also able to be saved as well. The exception 
for this is the XCF mentioned in the previous context. It is a format that is able to 
store every detail of an image, however it cannot undo information. For this 
reason, XCF is usually used for saving as a cache or as a temporary file for it to be 
reopened later. Note that XCF is native only to GIMP, so other software is unable 
to open it. Thus, once you are done, you should export the image in a more 
widely accepted format, such as JPEG, PNG, BMP and TIFF. 
 
There are several controls for saving images. A list can be found over the File 
Menu containing information on how to use the command. GIMP enables you to 
export images you create in a large variety of formats. It is always important to 
remember, again, that the only file that can save every attribute of an image is the 
XCF format. Other formats, however only preserve the property of the image 
while losing others. It is best to understand the capabilities of each format as 
much as possible. 

4.2.4 JPEG 

Joint Photographic Expert Group (JPEG) is the most commonly known and used 
format for photographs. JPEG is the usually known file extension for JPEG. JPEG 
images use high compression that consists of full color encoding, thus it is a very 
efficient file for photographs or other images with a wide range of colors. 
 

Open as many images and use Export As to save a jpeg file of different 
quality. See the difference in image quality. Share your findings with 
your coursemates in the online forum or face to face interaction. 

ACTIVITY 4.2 
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The downside of this file is the lossy compression. Lossy means that for every 
time that JPEG is read, a minor change in the file will happen in the write 
process, resulting in the image quality slowly becoming worse. Therefore, do not 
edit and save the same JPEG file repeatedly. However, it excels in transferring 
photographs to other people. This is because transferring does not affect the read 
and write, only editing does.  
 
A question might come to you such as, when a camera saves its images as JPEG 
as default, will it affect the quality? Yes, it does. However, many cameras usually 
provide a lossless format (the „Other Formats‰ section will explain this in detail). 
In addition, JPEG is still the most efficient file format for its ability to be stored 
even in its raw state on the same storage device. If you are particular with 
keeping the details as much as possible, consider saving in the raw format. But if 
you are not, then just save as JPEG as most people do. 
 

 

Figure 4.15: The JPEG export dialog 

4.2.5 GIF 

GIF is the Graphics Interchange Format. As an indexed format, it has fixed color 
channels instead of individually encoded colors. An image with small amount of 
colors such as a corporate logo would benefit the most being a GIF due to its 
efficiency with small color channels. The amount of colors a GIF contains is up to 
256 colors (256 equals to 2 to the power of 8, alternatively called 8-bit). The 
reason why it is rare to see photographs in GIF is because of the severe lack of 
color channels, while the usual photograph image has a vast amount of colors in 
tens or thousands. An example, if a GIF is saved to match a full color JPEG, the 
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file will turn out to be far larger than the JPEG. For this reason, strictly use GIF 
for icon and logos (Figure 4.16). 
 
The most dominant feature of a GIF is for transparency and also animations. 
Since transparency does not count as a color, you are able to produce a clear 
background of an icon. On a web page, a GIF is usually used as a button in the 
program interface for its transparent background. Partial transparency is strictly 
not allowed in GIF, so a pixel can only be either transparent or not. Another thing 
to note about GIF is that some users do not prefer animated content on web 
pages, thus they avoid using them. But an animation still has its use.  
 

 

Figure 4.16: The GIF export dialog 

4.2.6 PNG 

PNG refers to Portable Networks Graphics (Figure 4.17). It was actually intended 
to replace GIF as a new format due to legal reasons about the GIF format. PNG 
comes in two variants: it is able to utilise full color channels, similar to JPEG or 
an indexed format, similar to GIF. With full color channels, while it is not as 
efficient as JPEG in terms of size, it is a lossless image able to retain its quality 
even after multiple read and writes. This is useful in saving original copies of an 
image to edit it later. With its indexed format, it acts similar to GIF in every 
aspect from colors and transparency. Current web browsers and web pages 
utilises normal PNG as a normal medium for transparency. However, old 
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browsers such as older versions of Internet Explorer do not support PNG, thus 
they use GIF instead. Another thing that differentiates PNG and GIF is that it is 
unable to support animation. 
 

 

Figure 4.17: The PNG export dialog 

4.2.7 XCF 

This format is uniquely made for GIMP. This format uses the Save As dialog. 
When you are working on an image and have multiple layers, paths and other 
attributes to save, XCF has you covered. If not, do not use this format. The 
exported files are very large and is strictly only able to be accessed by GIMP. 
There are methods in compressing XCF with BZIP2 or GZIP by saving the files in 
xcf.bz2 or xcf.gz. Afterwards, the file is then compressed and decompressed by 
GIMP for when the file is used for read or write. 
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Figure 4.18: The XCFsave image dialog 

4.2.8 TIFF 

TIFF is the name for Tagged Image File Format, which is similar to PNG with its 
full color channel and lossless format. While it also shares the file size attribute 
for not being compact, it is not advisable to use it on web pages as no web 
browsers are able to display it. For this reason, it is best use to store original 
images for future editing. The main reason why PNG is more acceptable than 
TIFF, is that TIFF actually has a variety of standards with different attributes. An 
example is that a TIFF made by program A is not always compatible with 
program B. While GIMP is able to read TIFF, each TIFF will have its own 
attributes. 
 
The benefit of TIFF is that it is capable of handling a larger range of colors. In a 
technical sense, it is able to utilise 16-bit color, which is quite essential in a 
professional level. Despite that, currently GIMP is unable to use 16-bit color. 
While you can edit into 16-bit in GIMP, the TIFF will not get the full support. 
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Figure 4.19: The TIFF export dialog 

4.2.9 Other Formats 

There are a lot of other image formats. The following are the most commonly 
found: 
 
(a) Raw 
 It is not exactly a format, but it is a name used for unique formats by 

camera manufacturers. GIMP is able to support this by the use of an 
external plug-in, ufraw, for example. Some raw formats are kept as hidden 
language by camera manufacturers and the only method to edit them is to 
use a separate program just to convert the image into a standard format. 

 
(b) BMP  
 Bitmap comes from Microsoft Windows, usually large and has no benefit 

over PNG or TIFF. If you are using Windows, you can choose to save as 
BMP if you wish, but you are better off saving as something else. 

 
(c) PCD  
 This is KodakÊs own unique Photo CD format. It has multiple resolutions 

within a file, thus making it very large and it is also lossless. While GIMP is 
unable to use PCD by default, there are plug-ins that enable it to do so. It is  
advised to convert PCD to a more common format. 
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(d) PSD 
 This is Adobe PhotoshopÊs unique format. It has the ability to save layers 

and other attributes similar to XCF for GIMP. Even though PSD is a unique 
format, the older version of it can be opened in GIMP while newer ones are 
not able to be viewed outside of Adobe programs. 

 
(e) ICO 
 This is the Icon format for Microsoft Windows. It has similar attributes to 

PCD as it has several resolutions in a file. While this format is usually used 
as icons for Windows, it is able to make icons for bookmarks on sites that 
you link the icon with. ICO files can be used and saved in GIMP directly. 

 
(f) PDF and PostScript 
 These files are very different compared to the previous ones discussed, as 

they are vector graphics formats instead of raster (which is pixel). Vectors 
represent itself by using drawing instructions with points, lines and curves 
instead of an image that is dense with pixels. GIMP is unable to edit vectors 
by default. A plug-in would enable one to do so but has very limited 
support. GIMP could also import PDF or PostScript with the use of a plug-
in that converts it into a raster image. Note that if you are planning to make 
them as either PDF or PostScript, it is better off using a proper program for 
vector purposes. 

 
(g) SVG 
 Another vector format that is on the rise is Scalable Vector Graphics. Images 

from SVG can be imported in GIMP, and in future builds, GIMP would be 
able to export to SVG as well.  

 

 
 
 It is best to understand the requirements of the said image. For the time 

being, sample images will still be used for manipulation as well as GIMPÊs 
XCF because these files enable the use for editing again and again in the 
future.  
 

 File size is used to determine the image resolution. For example, an image is 
used for two purposes, for a site and a poster. For the one on the site, it is best 
to stick with 72dpi or lower mainly because users want to see your content as 
fast as possible. On the other hand, a poster is best to have a dpi as high as 
300 for printing purposes because it requires in depth detail to convey 
information on the poster. 

 



  TOPIC 4    FILE FORMAT AND SIZES   
 

74 

 
 
Compression The process of reducing a file to save storage on disk. 

 
Image dialog Drop down menu or popup menu.

 
Scale Enlarge or reduce in horizontal (X axes) or vertical  

(Y axes). 

 
 
 
 
 
 
 



 

 

 

 

 

 

 

 

 

 

 

 WORKING WITH IMAGE  

GIMPÊs most common feature is to repair an imperfection of an image. Examples 
of imperfections can range from an over- or under-exposed image in terms of 
color corrections. In this topic, you will learn the basics of using images to be 
edited and modified using the tools easily. A scanner or a high-resolution camera 
usually can be used for better image quality. With modern technology, the 
smartphone camera is also one of the devices that serves to get clear image 
quality. 

5.1.1 Scanning Image  

It is important to scan the original image at the correct resolution and have 
enough data to work with, especially when the edited image will have an 
enlargement after exporting for printing. In a scenario where the input of the 
data is deemed too low, the image will have jagged appearances as a final result. 
The following figure shown in Figure 5.1, shows two parts of the enlarged 
section scanned; a 3‰  5‰ image of the medicine descriptions of the bottle. The 
image on the left is scanned at 300 DPI (for printing), while the one on the right is 
scanned at 72 DPI (usually used to view images on the web). 96 DPI is also used 
for web-based images. 

5.1 
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 Simple Image 

Changes 

 
 

By the end of this topic, learners should be able to: 

1. Identify the image function from different devices; 
 

2. Apply basic image editing using variety of tools; and 
 

3. Determine the process for image manipulation. 

LEARNING OUTCOMES 
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Figure 5.1: A comparison between 300 dpi and 72 dpi 
 
Usually, 300 DPI is enough for photograph scannings, that is, if the final output 
size does not increase at a large margin than the original image size. When an 
image is upscaled, the software recreates the image by adding pixels to the image 
through interpolation or estimation. Insufficient data of a photograph can cause 
an enlarged photo to look terrible when printed. After editing an image, the 
output size of the image can be scaled based on the userÊs will.  
 
For printing, 300 DPI is commonly used by down-sampling. Most scanners are 
capable of using 48-bit (16 bits per channel) color. However, GIMP 2.8 currently 
is only able to handle 24 bits (8 bits per channel). If a 48-bit image is imported, it 
will be converted to 24 bits while being prompted by a window first. In GIMP 
2.10, support for 48-bit will be made available. An option if you have an ample 
amount of storage, is that you could scan your images in the 48-bit format and 
save the files in a lossless format, such as TIFF. These can be used to preserve the 
maximum image density of an image as a digital negative. 

5.1.2 Using Digital Camera  

The usual tasks to be performed when you want to repair an imperfect image are 
improving the composition, colors, sharpness and clearing artifacts or other 
undesirable properties of the image. 
 
(a)  Image Composition 
 Composites of an image appear when an image is captured and imperfectly 

aligned which results in the image looking as if it was tilted at an angle. 
This can be fixed by using the Rotate tool (Figure 5.2). To use this, simply 
click its icon in the toolbox. Alternatively, you can access by clicking 
Shift+R. Another thing to note is to make sure that the Tool Options are 
present, while having the left button Transform Layer selected. Then, if you 
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click the mouse on the image and drag, a grid will appear enabling you to 
rotate the image as you drag. If you are done, click Rotate or Enter, and the 
image will be rotated as shown in Figure 5.3. 

 

 

Figure 5.2: Rotate icon in the toolbox 
 

 

Figure 5.3: Rotate dialog appears when clicking on the toolbox or pressing shortcut key 
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 However, it is not as simple as instructed. In order to get things right, 
sometimes you could find imperfections in broad daylight. You could 
always rotate a bit more, but that approach has a negative effect on the 
image. Every time an image is rotated, the original pixels are not aligned 
properly to the rotated pixels. This results in blurred effects found in the 
image. A single rotation causes small amounts of blurring but doubling the 
rotations results in double the blur. An option to combat this is to undo the 
rotation and create another copy, in order to separately adjust the angle. 

 
 In GIMP, there is a specific tool that can be used to aid this issue, called the 

Backward (Corrective). It can be accessed through the Rotate Tool Options, 
under the Transform Direction. By using this, instead of manually adjusting 
the grid to attempt to fix the error, you are able to rotate it to line up with 
the error. Give it a try and you can see that the process is straightforward. 

 
 After an image has been rotated, triangular shapes appear on the corners. 

This can be fixed by creating a background fill with neutral colors or colors 
according to the image, but the most common method is to crop the image. 
The larger the resolution, the larger amount of cropping required, so it is 
best to have the camera aligned as properly as possible before taking the 
image itself. 

 
(b)  Cropping 
 When taking images with a digital camera, you are able to utilise functions 

readily available for the image but it does not offer as much, such as when 
an image captured requires trimming. With this, the impact of an image can 
be improved by trimming it so that the focal points are located at key 
points. It can determine the maximum impact gained by putting the centre 
of interest one-third of the way across the image, from both width and 
height. 

 
 Cropping an image can be accessed through the Crop tool in the Toolbox 

that is shown in Figure 5.4, or by pressing the Shift+C. While the tool is 
active, clicking and dragging on the image will create a new crop rectangle. 
Figure 5.5 shows that a pop up dialog will appear that allows you to adjust 
the crop regions. When the cropping adjustments have been made, hit 
the Crop button to see the results. 
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Figure 5.4: Crop tool in the toolbox or pressing Shift+C 
 

 

Figure 5.5: Crop on the image necessary 
 
(c)  Colors Improvement 
 Even with a vast amount of tools for exposure, images captured with digital 

cameras usually come out either over- or under-exposed, or have lighting 
irregularities that cause color casting. GIMP offers a large amount of tools 
that can be used to fix colors in an image. With a single click, you are able to 
use a range of automated tools that can simply execute controls of a specific 
range of functions. When it comes to color correction, GIMP provides 
multiple automated tools that aid the process. However, it does not always 
give the end result you want, but you are able to get around the controls in 
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a short time. Additionally, if you have no options left, you are usually 
provided with possibilities of fixing the issue by using the inherent settings 
of the image. This can be utilised under the Auto Level, which can be found 
under Colors > Auto in the image menu that is shown in Figure 5.6. 

 

 

Figure 5.6: Auto levels 
 

(i) Equalize 
 It has the ability to adjust and even the spread of colors across the 

image by using the possible intensity range. In most cases, it can 
result in providing amazing effects by bringing out the contrast of the 
image that would be sometimes difficult to do. However, it usually 
makes the image look off in a few places. But it only takes a second to 
try. 

 
(ii) White Balance 
 This enhances the lacklustre white or black of an image by removing a 

minimal amount of colors used and extends the remaining possible 
range. 
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(iii) Normalize 
 It is a plug in that can be useful when working with under-exposed 

images: it uniforms the whole image by adjusting it up to the brightest 
point at the saturation limit, while using the darkest point that is 
black. The negative effect of this, however, is that it relies heavily on 
the lightest and darkest points of the image, thus limiting the amount 
of brightening. If a single pixel white or black pixel is causing an 
issue, then normalization is ineffective. 

 
(iv) Color Enhance 
 Increases the layerÊs saturation range based on the colors available 

without changing its hue or brightness (Figure 5.7). Take note that this 
does not have any effect on grayscale images. 

 
(v) Stretch Contrast 
 This is similar to Normalize, except that it is used only the RGB (red, 

green and blue) channels. Particularly useful when fixing color casting 
of an image. 

 
(vi) Stretch HSV 
 This is similar to Stretch Contrast, except it uses HSV color channels, 

instead of RGB color channels to maintain the hue. 
 
(vii) Auto Levels 
 Levels tool can be used to adjust the lighting of an image. It gives you 

control of a semi-automatic adjuster that usually fixes both brightness 
and colors of the whole image very well. It can be accessed by Tools > 
Color Tools > Levels or Colors > Levels. Now, look near the bottom of 
the Layers dialog. There are three buttons with symbols on them that 
look similar to eye-droppers. On the left, if you hover to it, the Pick 
Black Point function is shown. Clicking this, then clicking on another 
point in the image will produce something that appears to be perfectly 
black. Next, on the right is the Pick White Point, similar to the 
previous instructions, the image will once more change. If you are 
satisfied with the result, click the Okay (OK) button, otherwise click 
Cancel. You can refer to the tools position in Figure 5.8 and the result 
can be seen in Figure 5.9, that is, the image before and after 
application of auto color levels.  
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Figure 5.7: Another option for auto levels 
 

 

Figure 5.8: Three buttons with symbols similar to eye-droppers 
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Figure 5.9: Before and after using auto color levels 
 
(d)  Exposure Problems 
 Brightness/Contrast can be considered to be the most simplest tools. It is 

usually useful for fixing over- or under-exposed images, however, it is not 
for color cast corrections. The tool provides you the ability to adjust two 
sliders, for Brightness and Contrast (Figure 5.10). The option Preview can 
be used to inspect any changes made on the image. 

 

 

Figure 5.10: Brightness/Contrast and Curves 
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 The Curves tool is a powerful component for correcting exposure problems. 
It allows you to adjust the points on a curve by simply clicking and 
dragging, this creates a function mapping that can be used to change the 
input brightness levels to the output brightness levels. This tool is able to 
produce transformations achieved with Brightness/Contrast or the Levels 
tool. It is not just a powerful tool without a reason.  

 
 The best approach when adjusting the image brightness and contrast, 

especially for advanced GIMP users, is to create a new layer on top of the 
one you are currently working on. Then, in the Layers dialog, set the top 
layer to Multiply. The new layer will then act as a gain control for the layers 
under it, with white having its maximum gain and black having zero gain. 
Thus, when painting on the new layer, you are able to individually adjust 
the gain for every area of the image, providing you with accurate control. 
As a note, paint by only using shades of gray and not colors, unless you 
wish to make color shifts on the image. 

 
 However, Multiply is not the only mode in order to utilise the capabilities 

of gain control. In fact, the Multiply mode only darkens part of an image, 
not altering the light parts, so it is best used on parts of an over-exposed 
image. Divide mode has the contrary function: it is able to brighten areas of 
an image instead. The following is a trick to use the best of both modes in 
order to get as much detail of the image: 

 
(i) Start by duplicating a layer (placing similar layer on top of another). 

 
(ii) Desaturate said duplicate layer. 

 
(iii) Applying a large radius Gaussian blur to the result (100 or more). 

 
(iv) Choose Divide mode in the Layers dialog. 

 
(v) Alter corrections either by changing the opacity in the Layers dialog, 

or by utilising the Brightness/Contrast, Levels, or Curves tools on the 
duplicated layer. 
 

(vi) Then Merge Down both the original layer and the controlled layer 
into a single layer. 

 
 In addition, other than Multiply and Divide, you may also get useful effects 

by using other modes of layer combinations, such as Burn, Soft Light 
or Dodge. While it may look simple, once you start indulging yourself 
without looking away from the computer for a moment, you have now 
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spent well over two hours just adjusting the parameter. A useful thing to 
note: More options available does not make it necessarily easier to make a 
decision. 

 
(e)  Hue and Saturation adjustment 
 This is a more complicated tool in comparison to the Color Balance or 

Brightness/Contract tool, even more so that the results cannot be replicated 
by using Curves. Nevertheless, it is a rare occasion to use the tool for 
enhancement or touch up. Hue-Saturation allows the adjustment of the 
imageÊs hue, saturation and lightness. It can be used for either an entire 
image, or for any channel combinations from RGB (Red, Green, Blue) or 
CMY (Cyan, Magenta, Yellow) components. 

 

 

Figure 5.11: The Hue-Saturation dialog 
 
 The sole reason why Hue-Saturation is not recommended or used at all for 

correcting colors is that it is hard to gauge in making changes in order to 
enhance the image. With the Curves tool, the parameter of the colors can be 
picked by using the Color picker, resulting in precise and predictable 
changes to an image. In the other hand, Hue-Saturation does not have a 
measurable method to distinguish the wrongs in an image. In addition, 
issues regarding color rarely correlate with shadows, highlight and 
midtone. Hue-Saturation does not have the capabilities of differentiating 
varying color components of an image. Therefore, Hue-Saturation serves 
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little to no purpose for color correction. Nevertheless, unlike Brightness-
Contrast and Color Balance, Hue-Saturation can prove to be useful when 
used to show interesting things that would seem difficult to obtain with any 
other color tool as shown in Figure 5.11. 

 

 

Figure 5.12: Right image after using hue-saturation tool 
 

 

Figure 5.13 
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 In Figure 5.11, in the Hue-Saturation dialog, it shows that the slider for 
Cyan channel has been changed to -100% (Figure 5.13). As a result, it 
completely desaturates similar color properties such as the sky and water, 
while leaving unrelated colors untouched such as the tree. Any changes 
made with the Hue and Lightness sliders could also provide interesting 
results as well. 

 
(f)  Adjusting Sharpness 
 
 Unblurring 
 In a situation where the camera is not set properly or the camera is in 

motion when the image is captured, it will result in a blurred image. If there 
is a lot of blurring in the image, most likely it cannot be fixed with any 
available method. However, if there is little to average amount of blurring, 
then it can still be improved to make the image better. 

 
 One of the most useful methods for fixing a fuzzy image is to sharpen it by 

using the Unsharp Mask. Regardless of its unique name, which originated 
by film developers, it is actually able to sharpen images and not vice versa. 
It is a plug-in that can be accessed through Filters > Enhance > Unsharp 
Mask in the image menu (Figure 5.14). Two parameters are available, which 
is Radius and Amount. Figure 5.15 shows the dialog box for Unsharp Mask 
Tool that contained of two parameters. Usually, the default value is 
sufficient, so give that a try first. Modifying the strengths of either of the 
parameters, increases its effects. Make sure not to overdo things as it will 
result in unnecessary noise that can cause artifacts in the image. 

 

 

Figure 5.14: Unsharp Mask Dialog Box 
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Figure 5.15: Unsharp Mask tool 
 
 Next to Unsharp mask is the Sharpen tool. It does similar actions. Although 

it is slightly easier, it is not as efficient. It is recommended to ignore it and 
just use Unsharp Mask instead. 

 
 However, some occasions might actually get you useful results. Examples 

of this would be sharpening specific areas of an image by using either the 
Blue or Sharpen tool while in Sharpen mode. This enables you to improve 
the sharpness in regions by simply painting on them with a paintbrush. 
One thing to note is that while it does not look natural, sharpening an 
image increases the amount of noise in an image. 

 
(i) Reducing Graininess 
 When taking pictures with a high speed exposure timer or in low-

light conditions, usually cameras are unable to have sufficient data in 
order to gauge the proper color pixels, which then results the image to 
appear grainy. You can opt to soften the graininess by using the 
blurring tool, but that would result in losing sharpness. There are of 
course, a few methods that can provide better results. One of the best, 
provided the graininess is not severe, would be to use the Selective 
Blur filter, with settings around 1 or 2 pixel blur radius. Another 
method is the Despeckle filter. It has a nice preview in which you can 
modify the settings for trial and errors in order to obtain the best 
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results. However, when graininess is severe, it is usually very hard to 
repair with filters except for retouching by using paint tools. 

 
(ii) Softening 
 Sometimes, while images do not always turn out to be too blurry, the 

opposite could occur as well. The usual method is to slightly blur the 
crisp parts a bit. In comparison to sharpening an image, blurring is 
much easier to execute. Considering that you do not want to blur 
excessively, the easiest method is to just use the Blur plug-in, which 
can be accessed through Filters > Blur > Blur. This will reduce the 
focus of an image slightly and concurrent softenings could also be 
achieved by repeating the said method. 

 
(iii) Removing Unwanted Objects from an Image 
 There are two types of imperfections that you would want to clear 

from an image. First is the artifacts that can be seen on the lens such as 
dust or hair. The second would be objects that reduces the focus or 
causes impairment to the quality of the image such as telephone wires 
present across a mountain. 

 
(iv) Despeckling 
 The best method to remove dust or other types of gunk is to use the 

Despeckle filter, which can be accessed in Filters > Enhance > 
Despeckle. An important thing to note is, in order to use this filter 
effectively, you have to start by creating a small selection that has the 
artifact within the area. The selected region has to be small in order to 
prevent the pixels from not distinguishing each other. If despeckle is 
used on the whole image, the results would not look any different 
than it is. After making the appropriate selections, click Despeckle and 
look at the preview while you modify the settings. If done correctly, 
the junk will be completely removed while not large affecting the 
quality of the image. However, if it does not work, then it would be 
advisable to cancel the filter, find new regions and repeat the same 
process once again. Always remember, if you have multiple artifacts, 
Despeckle each respectively. 

 
(v) Garbage Removal 
 A useful method in clearing unwanted criteria or impurities of an 

image is to use the Clone tool. It allows you to paint a part of the 
image on top of another by using pixel information from a separate 
part of an image (or different image). The method of using Clone tool 
effectively is to be able to distinguish regions of the image that could 
potentially be used to touch up an unwanted area: if a region contains 
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unwanted items around that are very different than the spot you are 
trying to clear, then you are out of luck. An example for this is that if 
you have a beautiful scene of the beach that has unwanted people 
inside of it, that you wish to clear, then you would just need to find an 
empty area of the beach that is identical to the area that you want it to 
be cleared and then use it to clone over the said area. Sometimes it 
could produce brilliant results depending on how well the technique 
is used. 

 
 You could also use the Help function for Clone Tool for proper 

instructions. Cloning is like art that is similar to science, the more you 
do it, the better you get. Initially, it may look impossible due to the 
fact that it looks like ugly blotches, but gradually it will become the 
best that you would ever want. 

 
 Another method that is similar to the Clone Tool is the Healing tool. It 

is similar to Clone tool in functionality but smarter in execution. It 
uses the area around the region into consideration when cloning. It is 
generally used to remove wrinkles or minor imperfections in an 
image. 

 
 Alternatively, you could also get the same best result simply by 

removing intrusive objects from the image, then use a plug-in called 
„Resynthesizer‰ in order to fill the empty area. However, this plug-in 
does not come bundled with GIMP, but you are able to get a hold of it 
simply by going to the authorÊs website [PLUGIN-RESYNTH]. 
Always note, your end result may vary. 

 
(vi) Removing Red-eye 
 If you take a picture of a person that is directly looking at the camera 

with the flash on, the eyes will appear bright red: this is called a red-
eye. It is caused by the light bouncing off from the flash to the iris and 
back to the camera. While many modern cameras are able to minimise 
red-eyes by using special flash modes, it only works when you are 
using flash on them, but it does not work perfectly even with said 
mode enabled. Interestingly, the same effect can be achieved with 
animals, but it would appear as another color instead, green, for 
example. 

 
 In order to remove red-eye, simply use the selection tool to mark the 

red parts of the eyes, then use the „Remove Red Eye‰ filter. 
Sometimes you also need to manually adjust yourself with the sliders 
in order to get the color you want. 
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(g)  Saving Files 
 When saving your work that is ready to be exported, always ask yourself 

which format should be used for end results. Also, is there any need to 
shrink the image? The answer lies in the purpose of the image itself. 

 
 If the intention is to further open and edit the file in GIMP, it is advisable to 

save as the native XCF format for GIMP. This is because the image 
properties are kept and locked at its maximum default to prevent loss of 
information of the image. 

 
 If you have the intention of printing an image on paper, you should not 

consider shrinking the image; the only exception is cropping. This is 
because average printers are able to produce a far superior resolution 
compared to video monitors, ranging from 600 to 1400 DPI or dots per inch. 
A monitor, on the other hand, is usually only able to reproduce 72 to 100 
pixels per inch. An image with 3000 by 5000 pixel may look large on screen, 
but it is actually just 5 inches by 8 inches on paper on 600 ppi settings. 
While there is no good reason to expand an image, since it does not increase 
the actual resolution, it could always be scaled up during the printing 
process. As for file types, it is generally fine to use JPEG with quality level 
around 75 to 85. However, in some cases, when an image has a large 
amount of uniform color swatches, it is best to set the quality higher or even 
consider using lossless format such as TIFF. 

 
 If you wish to project an image on a screen with a video projector, always 

note that the average highest resolution capable for most systems are 
capped at 1600 by 1200, going more than that has no significant benefits 
when viewing at all. For this, JPEG suits the job well. 

 
 When sending an image by e-mail or putting it on a web page, it is best to 

make the image file size output as small as possible. First, change the scale 
of the image to the smallest size while making sure that the important 
details are still visible. Note, always remember that not everyone is using 
the same resolution or monitor size to view your images. Second, save the 
scaled image as a JPEG. While in the save dialog, make sure to check 
„Preview in image window‰, then proceed to adjust the slider of the 
Quality to the reasonable lowest level possible. Simultaneously, the image 
will change its effects for every change made. Always make sure to view 
the image at the 1:1 so that when doing this, you are not misguided by 
zooming. 
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 GIMP offers a wide variety of tools that are capable to help users repair 

images better. For an example, an old image that has ink stains can be edited 
out with the use of image retouching.  
 

 If an image is not as crisp clear, it could also be fixed by using the sharpening 
tool.   
 

 The benefits of GIMP allows large possibilities in digital imaging and 
manipulations   such as in magazines, newspapers and posters. 

 

 
 
Cropping To cut off or remove a part of a digital image to retain a 

smaller section of the original image. 
 

Blurring Unclear image.
 

Capture The process of grabbing or catching an object or image 
for the next necessary process. 

 
 
 
 
  
 
 



 

 

 

 

 

 

 

 

 

 

 

 TEXT  

Text tools let you put text into your image. In GIMP 2.8, you have the option to 
type your text on the canvas directly. While you still have the option to use the 
Text Editor (by making sure to check the Use Editor within the Tool Options 
dialog), it is now an option to write directly instead. A toolbar for text has been 
added to allow multiple ways of text editing; however, you can still use the Text 
Option dialog in order to change the font, color, size as well as alignment 
interactively (Figure 6.1). The context menu will be available when you right 
click on the frame. Inside you will find the options to copy, cut, paste and load 
your text. 
 

6.1 

TTooppiicc

66  
 Combining 

Text with 
Image  

 
 

By the end of this topic, learners should be able to: 

1. Identify the function of text tools; and 
 

2. Manipulate the text with images. 

LEARNING OUTCOMES 
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Figure 6.1: The Text tool in Toolbox 
 
When you are about to type your text, a rectangular frame will appear on the 
canvas. You can also choose to draw the frame before writing; the frame will 
automatically make the text follow its appropriate dimensions. It also can be 
enlarged, similar to rectangular selections. 

6.1.1 Activating the Tool 

This tool can be accessed in multiple ways: 
 
(a) Access through Tools > Text from the image menu; 

 
(b) Locate the tool icon  in Toolbox and click on it; or 

 
(c) Using the shortcut T. 

6.1.2 Tool Options 

Usually, when you activate a tool, there will be a window that is attached under 
the Toolbox that displays the tool options. If it does not appear, you can access by 
going to the Windows > Dockable Windows > Tool Options through the image 
menu bar. Firstly, make sure to create a new document and input image with 
1024  768 pixels resolution as shown in Figure 6.2. However, the size of the 
document varies depending on what task your document is for. 
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Figure 6.2: Create a new image 

 
Select the Text Tool in the Toolbox. The Tool Options will then display the Text 
setting (Figure 6.3). If nothing displays, then you can go through Windows > 
Dockable Windows > Tool Options. 
 

 
Figure 6.3: Tool Options 
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On the image, you have the option to modify the settings of the text before or 
after the text is placed. On the image windows, click on it to display a rectangle 
that will be used as a placeholder. The Text Tool Box will appear at the same time 
within the placeholder if you wish to do a quick set-up of the text as shown in 
Figure 6.4. 
 

 
Figure 6.4: The text toolbox 

6.1.3  Text Tool Box 

 
Figure 6.5: Text Tool Box 

 
When clicking on the canvas while the Text Tool is active, the top of the text 
placeholder will display the Text Tool Box. Aside from having the ability to 
change Font and Size, you can also modify the style of your text. Under the Font 
and Size box, five buttons are present  Clear style, Bold, Italic, Underline and 
Strikethrough. To the right is the Baseline Offset and Kerning, as well as the 
option of altering the text color of a selection. Now try typing „FLOWER‰ at the 
placeholder. A new layer dialog will appear to confirm that a layer has been 
made; simultaneously the preview of the text is present. 
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 CUSTOMIZING TEXT  

Customizing text comes in two options. First is the Text Tool Options and the 
other is on top of the text placeholder, the Text Tool Box that is shown in Figure 
6.6. 
 

 
Figure 6.6: Customizing text 

6.2.1  Text Tool Options 

(a) Font  
GIMP will use a standard Sans font by default for the Text Tool. The 
simplest method to change the font is by clicking the font icon next to the 
left of the font. A drop-down menu consisting of all the fonts available in 
your computer will then be available. Within the menu, there is a quick 
preview of how the font will appear as with a combination of uppercase 
and lowercase of the letter „A‰. 

 
(b) Size 

By default, the font size is usually counted in pixels. You can choose to 
change the size either by typing the size or using the up/down arrows on 
the right of the size. If you wish to modify the measurement units to either 
inches, millimeters, points or another type, you can click on the font size 
unit at the furthest right. 

6.2 
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(c) Use Editor  
When the Use Editor is checked, an external editor window will pop up 
automatically. It has similar functions to the text option on top of the text 
placeholder. 

 

(d) Antialiasing 
If you want your text to look smoother on the curves and edges, then 
antialiasing is the option you need. This process is achieved by the 
combination of blurring and merging the edges of an object. The result of 
the rendered typeface will have significant improvements in its appearance. 
Take note on trying to use this option on images that are not within the 
RGB color space. 

 

(e) Hinting 
In order to produce small letters that look clear, hinting modifies the 
characters by using the index of adjustments in order to obtain the results. 

 

(f) Color 
When you click on the current color sample in the color picker dialog box, it 
enables you to modify the text color. 

 

(g) Justify 
The text will then be aligned depending on the four rules that can be 
selected according to the appropriate icons.  

 

(h) Indent 
Alters the spacing of the indent for the first line from the left margin.  

 

(i) Line Spacing 
Alters the text spacing of successive lines. 

 

(j) Letter Spacing 
Alters the letter spacing. 

 

(k) Box 
Provides additional options for the text box. Two options will appear from 
the drop-down list:  
 

(i) Dynamic 
The text box will scale according to how much you type. If you want 
to prevent the text from going out of the image, press Enter to create a 
new line. 
 

(ii) Fixed 
This will constrain the text to only be able to type within a set size. 
The size of the text box has to be input first. The right side of the box 
will indicate the limit of the width of the box. 
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 TEXT AND IMAGE  

Start by creating a new image document (refer Figure 6.2), input the size to 1024 
 768 pixels. Then set the X and Y resolution under the Advanced Options to 300 
pixels as shown in Figure 6.7. 
 

 

Figure 6.7: A new image document 
 

1. Select the Text Tool from the Toolbox. 
 
2. Type „Nature‰ on the image window. Proceed to select the whole type and 

change the settings to 200px and Bold on the Text Tool. Refer to Figure 6.8. 
 

 
Figure 6.8: Type text nature 

 

6.3 
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3. Go to Open Layers to open an image. You will get the screen as shown in 
Figure 6.9:  

 

 
 

Figure 6.9: Open Layers 
 

4. Now click on the text layer, and then select the Layers > Transparency > 
Alpha to Selection from the image menu. Refer to Figure 6.10. 

 

 

Figure 6.10: Adding Alpha to Selection 
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5. Figure 6.11 shows the output when the Alpha to Selection is applied to the 
image.  

 

 

Figure 6.11: Output of Alpha to Selection 
 

6. Select the image layer (Figure 6.12), and then select the Layer > Mask > Add 
Layer Mask that is shown in Figure 6.13 from the image menu to prompt a 
dialog. In the dialog, select Selection and proceed to Add (Figure 6.14). See 
the output of the text displayed as shown in Figure 6.15. 

 

 

Figure 6.12: Image layer on Layer window 
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Figure 6.13: Adding Layer Mask 
 

 

Figure 6.14: To add Selection into Mask Layer 
 

 

Figure 6.15: Output of Layer Mask 
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7. Release the selection through Select > None (Figure 6.16). 
 

 

Figure 6.16: Release None selection 
 

8. Select the Paintbrush Tool from the Toolbox. Now use white as the 
foreground color. Select the hardness brush from the Paintbrush Tool 
Options, set it to 100, and change the size accordingly. Refer to Figure 6.17. 

 

 

Figure 6.17: Paintbrush tool 
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9. On the masking layer, select it and start restoring the masking leaf around 
the text (Figure 6.18). In order to remove the restored area, simply change 
the foreground color to black or by pressing X (Figure 6.19). 

 

 

Figure 6.18: Restoring the masking layer 
 

 

Figure 6.19: Remove restored area 
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10. Apply changes to the masked area, now proceed to Layers > Mask > Apply 
Layer Mask as shown in Figure 6.20. 

 

 

Figure 6.20: Applying Layer Mask 
 

11. Now go to Filters > Lights and Shadow > Drop Shadow to apply a drop 
shadow (Figure 6.21). When prompted, modify the value to 0 for Offset X, 
10 for Offset Y and 100 for Opacity, then click OK. Refer to Figure 6.22. 

 

 

Figure 6.21: Applying Drop Shadow 
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Figure 6.22: Modify the amount of Offset X and Y 
 

12. Now create an alpha selection from Layer > Transparency > Alpha to 
Selection (Figure 6.23). 

 
13. Create a new transparency layer. 

 

 

Figure 6.23: Creating transparent layer 
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14. On the new layer, create a selection feather through Select > Feather and 
input 10px as the value (Figure 6.24 and Figure 6.25). 

 

 

Figure 6.24: Applying Feather effect 
 

 

Figure 6.25: Set the feather effect 
 

15. Select the Bucket Fill Tool in the toolbox, then set the foreground color as 
white and fill the selected area (Figure 6.26). 

 

 

Figure 6.26: Applying Bucket Fill tool 
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16. Now proceed to emboss through Filters > Distorts > Emboss as shown in 
Figure 6.27. In the dialog, modify the values to 100 for Azimuth, Elevation 
and 10 for Depth. Press OK. See Figure 6.28. 

 

 

Figure 6.27: Emboss effect 
 

 

Figure 6.28: Modify the Emboss values 
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17. Choose Soft Light as the layer mode. Figure 6.29 shows the layer mode in 
the dialog window: 

 

 

Figure 6.29: Choosing Soft Light for the layer 
 

18. Proceed to mask the layer through Layer > Mask > Add Layer Mask. When 
prompted, choose White (full opacity) and press OK. Refer to Figure 6.30 
and Figure 6.31. 

 

 

Figure 6.30: Adding Layer Mask 
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Figure 6.31: Initialize Layer Mask 
 

19. Pick the Eraser Tool from Toolbox that shown in Figure 6.32. Proceed to 
erase the remaining embossment outside of the text of the leaf (Figure 6.33). 

 

 

Figure 6.32: Eraser tool 
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Figure 6.33: Erase the remaining embossment 

 
20. Make a new transparency layer. Figure 6.34 shows how to create a new 

layer:  
 

 

Figure 6.34: Create a new transparency layer 
 

21. In the Toolbox, pick the Blend Tool and create a gradient by applying the 
blend on half of the selection. Refer to Figure 6.35: 

 

 

Figure 6.35: Applying gradient using Blend Tool 
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22. Change the gradient layer mode to Multiply. See Figure 6.36: 
 

 

Figure 6.36: Multiply feature in Layer mode 
 

23. For the background layer, use the soil image and put on top of the white 
layer. This is to make sure that the background layer lies beneath the 
„Nature‰ text. The simplest way to achieve this is to go to the layer itself, 
and then proceed to drag the background layer above the „Nature‰ text or 
layer. 

 

 

Figure 6.37: Finalized output 
 

As seen in Figure 6.37, the „Nature‰ text now has a far more appealing factor 
with the use of the background available. 
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 In GIMP, text can be considered as one of the most used feature among users. 

It is not only used as a means of reading, but it can also be made to look 
visually pleasing with the aid of the various effects according to your needs.  
 

 The types of fonts in GIMP are all according to the fonts available in your 
computer, so if none of the defaults fit your bill, you can search for some of 
the nicely made ones online as well. In addition, you could also add 
additional effects to the fonts to suit your needs, such as; horror, romantic, 
humor and others.  

 

 
 
Placeholder  The place where descriptive text is displayed in an input 

field. 
 

Restoring   To return the object to its former condition. 
 

Options   Alternatives that are given to come to the decision. 
 

Modify   The process of changing parts.

 
 
 
 
 



 

 

 

 

 

 

 

 

 

 

 

 DRAWING TOOL  

In this topic, you will learn ways to make beautiful lines and objects using the 
best tools available in GIMP where even after finishing, adjustments can still be 
made. First, begin with making a new document File > New or shortcut Ctrl+N. 
Now, create an image and pick the suitable size to go along with it. For drawing 
practice purposes, it is recommended to pick a size that goes well with your 
screen while having spare room for Toolbox and Layers. Personally, it would be 
better to go for 1024  768 as my go-to canvas size for the appropriate size in 
printing and fine detailing in high resolution. Above the New Image dialog, there 
is a Template with a drop-down menu that enables you to pick from a variety of 
commonly used image sizes as shown in Figure 7.1. 
 

7.1 

TTooppiicc
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 Drawing and 

Painting Tools 

 
 

By the end of this topic, learners should be able to: 

1. Use different drawing tools; 
 

2. Use painting tools to color images; and 
 

3. Apply digital painting in GIMP. 

LEARNING OUTCOMES 
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GIMP usually provides your new image with a background according to the 
current color. You can start with by using white as your background, although, 
you could always modify the color to fit other needs for better effects. You can 
modify the color of your background by using the color swatch available in the 
Toolbox. However, for white, you could simply access the Fill from the New 
Layer dialog and pick White as the color. 
 

 

Figure 7.1: Opening a new image 

7.1.1  Using Layers 

Using a new layer is always the first rule of drawing because you will start with 
an empty canvas that is ready to go. But, is adding another layer necessary? 
What happens if you wish to change the color of the background in the future? 
Maybe make it transparent? Or when you would want to change the placement 
of a part inside of the image onto a different area? Or if you are planning to make 
a duplicate of your drawing against each other with the same background? 
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Although you could make future changes in GIMP; it takes far more effort in 
comparison to just creating new layers from the beginning. However, this does 
not mean that you have to create a new layer for every stroke or line you draw. 
But treat each current or new layer with a purpose of its own, for example: 
having one layer specifically for background, one for glass, one for trees and 
another one for sky. Let us begin with creating a new blank layer. Start by going 
to the Layers dialog; go to the lower left corner and click on the New Layer 
button. A New Layer will then appear and will automatically be placed above 
the current one you have. There is a field that allows you to put a custom name 
for the layer that is called the Layer Name field. It is recommended to have a set 
of names to remember for long-term work. But, in an instance where the image 
itself is not large, you can choose to save some memory by working on a smaller 
size sample instead (where you can crop the said part in the future).  
 
If you want to specify a new layer to be transparent at the start, then the Layer 
Fill Type provides you with a set of choices. By default, Transparency is usually 
checked, especially when making new layers for drawing. In future chapters, you 
will learn using solid-colored layers for works or layers that require special 
effects. When all settings are ready, simply click the OK button to create a new 
layer. You have the option of changing the order of the layer inside the layer 
stack, either dragging up and down, or by clicking on the Up and Down arrow 
buttons next to the New Layer at the bottom of the Layers dialog. 
 

 
Figure 7.2: The New Layer dialog 
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7.1.2  Lines and Curves 

The tools used for drawing lines and making freehand curves are available in a 
set of four in GIMP; pencil, air brush, paint brush and ink pen. 
 
(a)  The Pencil Tool 
 It allows you to create sharp-edged lines as in Figure 7.3. From the Toolbox, 

select the Pencil Tool and try to scribble on the image by dragging the tool 
to see the result. A trail of the action done by the pencil will be visible on 
the image; the trail will continue to go for as long as you press the left 
mouse button. 

 

 
Figure 7.3: Using the Pencil tool 

 
 In Figure 7.3, you can see that the mouse cursor now is a pencil icon; this 

indicates that the drawing tool has been selected. Another thing to note is 
the circle that appears around the pointer of the arrow, which indicates the 
brushÊs current size. 

 
 With the use of the line-drawing tools, it is quite simple to create straight 

lines. Start off with where you want the first dot to be (GIMP will show on 
the image the location of the first dot made), then proceed to move your 
mouse to another part of the image to create another end of the dot to 
produce a straight line. If you hold down Shift while moving, GIMP will 
provide a preview of a line from the last point you made.  
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(b)  The Brushes 
 In GIMPÊs drawing tools, there are a variety of brushes; you have the ability 

to change its setting according to the shape and width. The brush can be 
swapped with two methods; first by accessing the Tool Options and 
pressing on the brush icon. A drop-down menu will be available (Figure 
7.4). Second option is to go to the Toolbox and click on the brush icon 
located on the right of the colorswatch; this will prompt the Brushes dialog. 
The way that the Brushes dialog may appear is dependent on your current 
GIMP version; it may appear as a separate dialog or it may share a tab 
alongside Layers and other dialogs. 

 

 

Figure 7.4: Choosing a brush from the menu 
 
 From the menu or the dialog, when you click on the new brush, it will 

automatically use the brush you chose making it an active brush. You can 
test the brush and undo if it does not fit the bill, or you could try using 
another brush without closing the dialog. The small images in the preview 
determine the type of brush. It works similar to a paint brush when dipped 
in color. If you are using the Pencil tool, the image of the brush will appear 
when you single tap and moves along when you drag it. 
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 While usual brushes come in forms of solid edged circles, there are also 
some that appear to have fuzzy edges. The Pencil tool however, ignores 
fuzzy edges; The Clipboard brush was added in GIMP 2.4, it is a special 
brush that allows users to copy an area of an image simply by selecting 
with the brush. When selected, in the first entry in either the Brushes dialog 
or brush menu, the copied material will appear. It can now be used as a 
brush. Take note of some brushes, where slashes that are diagonal will 
appear asymmetric.  

 
 The pattern of the brush varies on how you control the direction of the 

mouse drag. This can be useful when creating calligraphy because of its 
similar properties of using a quill pen. There are also some brushes that 
appear as animated images. Now you must be wondering, what does an 
animated brush do? It allows you to get random or varied results across the 
screen when you drag it along. An example of the use of the Sparks and 
Vine brush is shown in Figure 7.5. 

 

 

Figure 7.5: The sparks and vine brush 
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 In Figure 7.6, there are a few options available in the Brushes dialog. First is 
Spacing, this allows the pattern of the brush to spread out for as long as you 
drag. Now, experiment with the Vine brush in order to see the result, in 
addition, you could also use non-animated brushes as well to produce 
similar effects. The buttons located at the bottom of the dialog provides 
other useful features for brushes or even adds new ones:  

 
(i) Edit brush makes the Brush Editor dialog appear. Take note that some 

of the brushes in the dialog will appear greyed out; this indicates that 
they are fixed and cannot be edited due to being „read-only‰. 

 
(ii) New brush brings up the Brush Editor dialog and allows you to make 

a parametric brush as in Figure 7.7. You can input the size, shape, 
hardness or any related parameters. On the lower left, there is a 
button that lets you save your brush according to the name appeared 
at the top of the editor. Now, every time you open up GIMP, the 
Brushes dialog will have the new brush you just saved, until you 
choose to delete it. 

 
(iii) Duplicate brush creates another copy of the parametric brush. You 

can choose to edit and save it with a different name. 
 
(iv) Delete brush removes the brush. However, this is not applicable to 

any of built-in brushes, only for the ones that you added yourself. 
 
(v) Refresh brushes scans and rechecks the brushes available in the 

brushes directory to see if there are any newly installed brushes or 
any of them have been removed. It is recommended to press this 
button right after editing a brush. 
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Figure 7.6: The Brushes dialog (docked with Layers and many other dialogs) 

�
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Figure 7.7: Creating a parametric brush with the Brush Editor 
 
 While most of the brushes available are in the form of images, when you 

create your own either by Edit or New in the Brushes dialog, it will appear 
as a parametric brush. There are a few templates to start off with, starting 
with simple shapes such as square, diamond or round; then proceed to 
input the size for the Radius, Hardness (controls the edge fuzziness), 
Aspect ratio (determines the ratio of width or height or just a square), 
Angle (controls the rotation) and Spacing (determines the distance between 
brushes when dragged, it could also make the brush not appear as a line).  

 
 It has been previously mentioned that image and parametric brushes act 

differently. However they cannot be changed or blended into one another, 
for example, such as trying to Edit an image brush or Open a parametric 
brush. To differentiate the two brushes, within the Brushes dialog, 
parametric brush appears to have a blue triangle on the corner to the lower 
right, while image or animated brushes have a red color instead. A plus 
symbol enables a larger preview of the brush than the current size in the 
dialog. 
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(c)  The Paintbrush Tool 
 The Pencil tool and Paintbrush tool both are different in their own ways. 

Paintbrush tool allows the use of fuzzy-edged brushes. For hard-edged 
brushes, it is slightly different in comparison to Pencil tool. 

 
 Antialiasing is a technique used by the Paintbrush tool to smoothen the 

edges of an object. The technique makes the edges semi-transparent, or 
simply blending with the background, to produce a result that will look 
smooth to the eyes. The Pencil tool, however, does not have this and results 
in jagged edges (Figure 7.6). 

 

 

Figure 7.8: The Paintbrush tool 
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(d)  The Airbrush Tool 
 There are two additional tools for drawing in GIMP, Airbrush tool is one of 

them as in Figure 7.9. 
 

 

Figure 7.9: The Airbrush tool, using a large, hard-edged brush 
 
 The Airbrush usually draws and results in fuzzy edges, regardless of the 

type of brush edge used, however, it is also time sensitive. If you drag at a 
slower pace, the line will appear darker similar to how a normal airbrush or 
a spray paint works. Continuously holding the mouse button down while 
hovering on a spot will make the spot darker until it becomes opaque (This 
allows the edges to become smooth or sharp the more you work on it, 
resulting in an edge that does not look fuzzy). Airbrush painting takes a lot 
of practice and time. In addition, Airbrush adds two new functions to the 
set: 

 
(i) Rate controls the sensitivity of the Airbrush tool on movement, for 

example, on the speed of which the brush gets darker when slowed 
down. 
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(ii) Pressure limits the darkness. Similar to how much paint is left which 
can be sprayed in an airbrush. 

 
(e)  The Ink Pen Tool 
 The most complicated drawing tool available in GIMP is the Ink Pen Tool 

as in Figure 7.10. It is the high risk, high reward of the bunch. It works 
similarly to a fountain pen that has nibs (tips) that can be replaced. You also 
have the option to change the nib into different shapes. The Ink Pen uses 
reaction as the basis of the drawing, mainly taking speed into account. It 
has the ability to create lines with varying width similar to a real ink pen, 
with similar hazards as to create blobs of ink. However, do not worry about 
staining your shirt pocket! 

 

 

Figure 7.10: The Ink Pen, showing how changing pressure can vary the line thickness 
 
 If you have a drawing tablet, or prefer it over a mouse, then the Ink Pen is 

definitely for you. Drawing tablets has its own input value when it comes 
to pressure, as well as tilting; this results in the varying thickness of the line. 
Of course, that does not limit this feature to tablets only, because even a 
mouse can still provide similar effects. 
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 In contrast to the other tools for drawing, Ink Pen ignores the current brush 
that GIMP is using. Ink Pen comes with its own type of brush, and acts 
similar to the parametric brushes with the following options: 

 
(i) Adjustment controls the nibÊs width and its initial angle (if 0, it is 

horizontal). 
 

(ii) Sensitivity determines the pressure and reaction of the Ink Pen 
according to your speed and style on the tablet. 
 

(iii) Type lets you pick from any of the three basic shapes of the nib. 
 

(iv) Shape box allows you to refine the nib. It has a preview of the shape 
chosen alongside a small square in the middle. The square can be 
dragged in order to alter the aspect ratio as well as the nib's tilt in 
Figure 7.11. 

 

 

Figure 7.11: The ink pen options 
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7.1.3  Drawing a Tree 

In order to start a new drawing, start off by creating a new layer. Always start 
creating a new layer for a new drawing. Follow these steps on how to draw a 
tree: 
 
Step 1: Creating a Trunk 
 
1. Name the layer „Trunk‰.  
 
2. Now change the foreground color to brown.  
 
3. While sometimes brown does not appear automatically in the color swatch, 

you can choose to change the setting of the hue first to orange, then proceed 
to slowly drag the cursor to the left and down to get a darker color as in 
Figure 7.12. 

 

 

Figure 7.12: Using Foreground Color to find brown colour 
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4. Proceed to draw the trunk with the Paintbrush tool.  
 You can choose to draw the trunk in a vertical straight line, if you wish. But 

we are trying to emulate a real tree, in which the trunk tapers slightly 
narrow at the top and the base wider.  

 

5. In order to obtain the results, you can try to use a narrow brush, then start 
drawing a few slightly vertical lines.  

 

6. Then click on another place to control where the top of tree will be. Now 
click on the left side and press Shift Click.  

 

7. From the top, Shift Click again at the bottom right as in Figure 7.13.  
 

8. Proceed to fill the trunk in by drawing additional lines inside of the outline 
until it looks like the trunk has a solid brown color.  

 

 

Figure 7.13: Example of the drawing of a tree trunk 
 

Tips: 

 Having issues with filling in holes located in the trunk? Try zooming in, 
however, another method is to use multiple views.  

 Access it through View > New View, and it will create an external window 
of the same image.  

 Changes made to either of the windows, be it original or external will 
reflect onto each other.  

 Another benefit of this is that you can have one window completely 
zoomed in to be the magnified piece, while the original piece can be left to 
be viewed at actual size. 
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Step 2: Insert Branches  
 
1. When you are done drawing your trunk, proceed to insert branches.  
 
2. Make sure to create a new layer for branch. Also remember to use 

transparency for the layer, so that the branch looks like it is connected to 
the trunk.  

 
3. Then use the similar Shift Click technique with the Paintbrush as in Figure 

7.14. 
 

 

Figure 7.14: A new branch layer 
 
Step 3: Insert Leaves 
 
1. Now you will be switching the foreground color to green which will be 

used to create the leaves.  
 
2. Again, create a new layer.  
 (Later on, you may change how your leaves will look like, for example 

instead of green, you may want it to be either autumn or winter). 
 
3. Moving onto the branch, choose the smallest brush available from the 

Pencil Tool in order to create thin lines.  
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Tips: 

Paintbrush does not work well with very small brush sizes, thus, increasing 
the size of your drawing makes it possible for Paintbrush to make small 
details for it to look far smoother than the Pencil Tool. 

  
4. Now for the leaves; change into a larger brush size as in Figure 7.15.  

 

 

Figure 7.15: Different types of leaves 
 

5. Use trial and error as to what is suitable for your tree.  
 

6. Proceed to put more leaves by using short strokes until the tree looks 
properly filled in as in Figure 7.16.  

 

7. Switch to the Branches layer if you wish to add additional branches. 
 

 
Figure 7.16: A tree filled with leaves 
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Step 4: Make a Real Tree 
Real trees actually have a range of colors for the leaves. For this, you might want 
to add multiple variants of leaves, some darker and lighter than the original. 
 

Tips: 

In addition, remember to add layers for each type of color. This is to prevent 
multiple colors from blending into each other and it would be difficult to 
change in the future as in Figure 7.17. 

  
1. Now the tree looks fresher than before, but wait, you still need to work on 

the trunk.  
 

2. To correct it, you will need to add a shadow to it. 
 

 

Figure 7.17: Using several different leaf colours 
 

3. In order to create the trunkÊs shadow, first turn off the visibility of 
everything else except for the trunk.  

 

4. On the trunk layer, proceed to duplicate the layer; this will become the 
shadow layer called the „Trunk shadow‰.  
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5. Place the layer on top of the trunk layer but under the branches.  
 

6. Change the property of this layer to semi-transparent: Start off with 35 per 
cent opacity; it can be changed later.  

 

7. Select the Paintbrush tool (if it is not active) with a medium sized fuzzy 
brush alongside a darker foreground color.  

 

8. While you have the option to use black, try using a different color so that 
the shadow will provide ample amount of depth to the trunk as if there is a 
reflection of light coming from objects nearby.  

 

9. Prepare to line up to the right portion of the tree and proceed to draw a 
dark shadow on it.  

 

Tips:  

 If you wish to make sure your shadow does not overshadow the tree, 
make sure the Keep Transparency button is toggled in the Layers dialog.  

 After toggling, now start drawing a line as shown in Figure 7.18.  

 

 

Figure 7.18: The effect of the shadow 
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10. Make sure that the edge of the trunk is the limit for the centre of the fuzzy 
brush. If you wish the right edge to be the darkest, and then start fading 
away towards the middle.  

 
11. You can leave the large fuzzy brush hanging at the edge of the trunk; the 

toggled Keep Transparency will stop from it overhanging.  
 
12. Now you can add shadows to your leaves as well.  
 
13. Considering that the leaves are small and massive in number, you could 

use the shortcut of creating a drop shadow for the leaf layer, then proceed 
in using small unit values for blur radius and offset.  

 
14. In Figure 7.19, the complete effect of the shadow is now done. The tree does 

not look flat anymore; it is now a 3D tree! 
 

 
Figure 7.19: The effect of the shadow 
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 PAINTING TOOLS  

When making a digital painting in GIMP, there is one thing that fellow artists 
really fall in love with: Everything is at the tip of your fingers without the need to 
clean brushes or purchase paint.  

7.2.1 Five Important GIMP Painting Tools 

There are five different tools that you would usually use for painting within the 
Toolbox; Select, Fill, Gradient, Paintbrush and Dodge/Burn as in Figure 7.20. 
Each one of them has their own options located under the toolbox. To improve 
yourself even further, you may want to explore all of the available options. 
 

 

Figure 7.20: Painting Tools 
 
Knowing your shortcuts is as good as knowing your way to the closest 
emergency exit in a building: it makes things more efficient and productive. The 
following are the available shortcuts for the more important functions in GIMP: 
 
(a) The Fuzzy Selection Tool (U) creates an area with boundary limits (the 

reason why it was used for the previous sketch). 

(b) The Paint Bucket or Fill Tool (Shift+B) fills part of the image with solid 
color. 

(c) The Gradient Tool (L) fills part of an image with multiple colors fading into 
each other. 

7.2 
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(d) The Paintbrush (P) paints a pattern or line according to the color, edge or 
size that you wish to create. 

(e) The Dodge/Burn Tool (Shift+D) creates tones on the onscreen colors to 
either light or dark. It is very useful in making highlights or shadows of an 
image. 

7.2.2 Painting the Image Scanning 

Is this your first time trying to paint with GIMP? You are recommended to start 
with scanning a sketch and work from there. In an instance, where you do not 
have a scanner, you can choose to use a photograph a sketch you made taken by 
your digital camera and upload the image into your computer instead. There are 
helpful tips in beginning the route to GIMP.  
 
Step 1: Drawing Scanning Image 
 
1. In Figure 7.21, a simple pencil rough sketch of leaves is shown. Begin with 

scanning the sketch.  
 

 

Figure 7.21: Rough simple sketch of leaves 
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2. Proceed to crop the sketch accordingly to your digital painting needs. 
Figure 7.22 shows how the crop tool is used to remove edges.  

 

 

Figure 7.22: Using crop tool to remove edge areas 
 

Tips:  

When scanning an image, even after removing eraser crumbs off or even if it 
was carefully drawn, there will always be something to clean up.  

 

3. Try zooming into the scanned image with Z and proceed to erase using the 
Eraser Tool Shift+E as shown in Figure 7.23. Figure 7.24 shows how the 
erase tool is used to remove and clean unnecessary objects.  

 

 

Figure 7.23: Eraser Tool 
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Figure 7.24: Erasing anything unnecessary 
 
4. After you determine that everything is clean and looks good, you can save 

your file.  
 
5. In the meantime, save the image with GIMPÊs default .xcf format. 
 

Key features or benefits of working with digital painting are that the canvas 
has its own safety limits that are provided by the software. Now, after 
cleaning the image with the eraser tool, remember to duplicate the first 
layer for safety precautions, in an event where a problem occurs with the 
image itself. You could also choose to change the name of the layer by 
double clicking on the respective layer.  

 
6. In order to duplicate a layer, always remember to have the Layers tab active 

in the Layers > Channels > Paths > Undo dialog box.  
 
7. Then Click proceed to drag the Leaves 1 layer into the Duplicate Layer 

button; when that is done, release the mouse button as shown in Figure 
7.25.  
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Figure 7.25: Create a duplicate of the layer and add it to the image 
 
Step 2: Painting Scanning Image 
 
1. Before you start the painting process, make sure the mode for the top layer 

is set to Multiply, so that you are able to see the layers beneath it (the ones 
you will be using later on). See Figure 7.26. 

 

 

Figure 7.26: Using Multiply Tool 
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2. You can choose to lock the layer to prevent mistakes happening on it 
simply by clicking on the eyeball symbol to make sure that it cannot be 
seen.  

 

Tips:  

A reminder if you think this process takes a long time to prepare; the process 
itself is as important and similar as to when you paint traditionally.  

 
3. Next, from the toolbox, proceed to choose the foreground color from the 

dialog box that pops up with all the hues possible as shown in Figure 7.27.  
 
4. Another method to switch your background color is to locate a small white 

arrow beside the mouse in the image to simply change accordingly. 
 

 

Figure 7.27: Foreground Color Tool 
 

5. Begin by choosing a color; next, select the Fuzzy Selection Tool (U), then 
simply click on your drawing in any region. Refer to Figure 7.28.  

 
6. There will be an animated sprite similar to ants marching around the edges 

of an area; this shows that it has been successfully selected. 
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Figure 7.28: Using Fuzzy Selection Tool and marching ant will appear 
 

7. When that is done, change to Paint Bucket (Shift+B) and proceed to fill 
inside the area with marching ants as shown in Figure 7.29. 

 

 

Figure 7.29: Using Paint Bucket 
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8. From the toolbox, click on the Dodge/Burn Tool or Shift+D, then proceed 
to lighten the colors of the parts you have already painted. Figure 7.30 
shows the using of Dodge/Burn tool.  

 
9. If you wish to use darken or Burn instead, click Ctrl to swap. 
 

 

Figure 7.30: Using Dodge/Burn Tool 
 

10. In order to create a gradient, first take a part of your image using the Fuzzy 
Selection Tool (U), then click on the Gradient Tool (L).  

 
11. Now proceed to click a starting point and start dragging within the 

selection. A gradient will then appear as shown in Figure 7.31.  
 (In an instance where transitioned colors are incorrect, you can simply 

cancel and redo once again.) 
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Figure 7.31: Using Gradient Tool 
 

12. In the toolbox, there are various types of gradient options available. Figure 
7.31 shows the types of gradient types that can be applied in painting 
objects.  

 

 

Figure 7.32: Types of Gradients 
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There are multiple options, such as linear gradients, radial gradients and 
many others. On the Layers box, there is a gradient tab that allows you to 
create and save templates of gradients that can be used in the future. Of 
course, you could always use the preset gradients provided as well. 

 
13. For finishing touches, it is best to use Paintbrush Tool (P) as shown in Figure 

7.32. 
 

Tips:  

Take advantage of all the brushes available in GIMP as shown in Figure 7.33. 
Some of them have rough texture, soft edges and for those who prefer using 
tablets, always experiment the Pressure sensitivity to suit your need. 

 

 

Figure 7.33: Using Paintbrush Tool 
 
14. The opacity level can also be changed to suit various needs such as trying to 

obtain watercolor or pastel results, alongside the appropriate brush texture 
and shape.  

 
15. Proceed to select areas and put as much detail until you feel that the entire 

image is satisfying to you. See Figure 7.34 for the completed painting.  
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Figure 7.34: Completed Painting 
 

Tips:  

Always remember, since you are doing digital painting, you can also access 
the magical undo button that is Ctrl+Z. 

 

  
 GIMP is not only to be used to edit and manipulate images, it also has the 

ability to aid those who wish to do painting and drawing with the software as 
well. The amount of tools for drawing and painting makes the learning 
experience more fun in the long run.  
 

 This topic highlights the use of tools and techniques before starting a project.  
For example the use of layers and duplicating images so that if any mistakes 
happen, there will always be a back-up ready.  
 

 When scanning an image, either by scanner, Internet or camera, make sure to 
touch up with as much detail as possible to have the best image before 
starting your work and after finishing your work.  
 

 This topic is all about learning and mastering the curve of tools that serves as 
the key to success in building an image.  
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Dragging  The process of selecting the object and grabbing it to a 

different location. 
 

Parametric brush  A brush can be modified and its parameter can be 
changed. 
  

Duplicate   An exact copy of the original object.

 
 
 
 
 
 
 



 

 

 

 

 

 

 

 

 

 

 

 INTRODUCTION  

The starting portion of this topic will focus heavily on the filters that are readily 
available in GIMP. In a nutshell, filters allow users to modify an image through 
programs that have flexible adjustments. First, it takes the input from the image 
data and processes the image according to what the user wants as well as the 
inputs required, then the results are shown. The adjustments usually come in 
forms of parameters, allowing full control of each filter. In GIMP, the input used 
for the filter is determined by the current active layer.  
 
In this topic, you will focus on the filters that are used on a daily basis for image 
editing. An example of a filter would be the Blur filter; it is usually used to 
provide a distinctive focal point to the viewer by making unimportant details 
obscure. The Enhance filter allows you to highlight parts of some or the whole 
image in order to make them stand out. Another notable filter set would be the 
ones within the Distort submenu; it has the ability to alter your image into 
something completely different with hints of what the source actually has. 
Interesting possibilities are there as well. 

8.1 
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 Effects and 

Filters  

 
 

By the end of this topic, learners should be able to: 

1. Use variety of effects and filters; 
 

2. Explore image and text with effect and filters; and 
 

3. Experiment with effects in the filter gallery. 

LEARNING OUTCOMES 
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 THE FILTERS MENU  

GIMP stores most of its plug-ins in the Filters menu. You could consider it as a 
library filled with practical results. If exploring is your thing, then most likely 
you can self-indulge with the vast amount of possibilities available, while not 
even making any progress or being unable to finish your work. At the top part of 
the Filters menu, there are two actions available, Repeat Last and Re-Show Last. 
Repeat Last will instantly repeat the last filter you have made to your work; this 
is further helped by the menu providing what the last action was made, for 
example, Repeat „Gaussian Blur‰. Another thing to note is that the settings for 
the filter is exactly the same as the previous action.  
 
Re-Show Last, on the other hand, provides a contrasting option than Repeat Last. 
Instead of instantly repeating without changing settings, it will access the filter 
and allows users to modify the settings in the dialog of the filter. However, the 
Repeat menus will only show filters and not scripts. Another action is the Reseat 
All Filters; this basically just brings every filter value to default.  
 
By default, GIMP usually memorizes the settings made to a filter until the 
program is closed. If you are looking to reset only that one particular filter from 
the menu, sadly you are out of luck because the closest option for that is Reset All 
Filters. However, you could always go to each individual filter, and reset from 
the dialog within. In the Filters menu, there are two partitions, the Repeat and 
Reset, and the filter options as shown in Figure 8.1. 
 

 

Figure 8.1: Filters menu 

8.2 
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8.2.1  The Original Image 

Now, before you explore GIMP further, Figure 8.2 is a sample image that will be 
used for the various filter processes throughout this topic.  
 

 

Figure 8.2: Bougainvillea flower 

8.2.2  Blur Filters 

Within the Blur submenu, there are many options that enable you to either blur 
the image or only some portion of it. If you wish to have a part of an image 
blurred, it can be done by selecting that portion and only that portion will be 
blurred. An additional note on selective blurring: There are possibilities that 
color leakage will occur around the blurred area. Remember at the start of the 
topic about how each filter has its own parameter? This comes in handy during 
the trial and error period. There are a few types of blur; Blur, Gaussian Blur, 
Motion Blur, Pixelize, Selective Gaussian Blur and Tileable Blur. To start making 
a blur, start from Filters > Blur > choose any type of Blur effect that is shown in 
Figure 8.3.  
 

 

Figure 8.3: Blur filters menu 
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Figure 8.4 shows the example of the output of an image that uses Pixelize filter.  
 

 

Figure 8.4: Using Pixelize filter 

8.2.3  Enhance Filters 

Repairing or compensating imperfections of an image is usually what the 
Enhance Filter is made for. Imperfections comes in multiple types; noise, dust 
particles, lack of sharpening and interlaced frames (usually caused by a TV 
frame-grabber). There are eight types of enhance filter that provide by GIMP 
software. To start Enhancing, start from Filters > Enhance > choose any type of 
enhance filter as shown in Figure 8.5. 
 

 

Figure 8.5: Enhance filters menu 
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The following shows the image that applies the eye removal filter. Figure 8.6 
shows the flowerÊs color change from pink to purple.  
 

 

Figure 8.6: Using Red eye removal filter 

8.2.4  Distorts Filters 

If you wish to alter the behaviour of your image, you could use Distort. To start 
distorting, start from Filters > Distorts > Apply Lens or Blinds or Curve Bend 
and more as shown in Figure 8.7. 
 

 

Figure 8.7: Distort Filters menu 
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Figure 8.8: Sample of Distort  Apply Lens filter 

8.2.5  Light and Shadow Filters 

In this submenu there are two divisions available; the Light Effect filters, Script-
Fu and Python-Fu. The Light Effect filters allow a multitude of lighting effects to 
be created on the image while Script-Fu and Python-Fu is used to create shadow 
effects. To start creating light and shadow, start from Filters > Light and Shadow 
> choose any type of Gradient Flare as shown in Figure 8.9. 
 

 

Figure 8.9: Light and Shadow Filters menu 
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The Lighting effects used in image are shown in Figure 8.10. 
 

 

Figure 8.10: Using Lighting effects filter 

8.2.6  Noise Filters 

If you want to add film grain effects, Noise Filter does the job. There are six types 
of Noise Filters that can be used in order to put some effect into the image. To 
start adding noise effects, start from Filters > Noise > choose any type of Noise 
filter that is shown in Figure 8.11.  
 

 

Figure 8.11: Noise Filters menu 
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The Noise Filter will give a foggy or smoky effect to the image when you apply 
it. Figure 8.12 shows how the Hurl Filter looks like when it is applied to the 
image.  
 

 

Figure 8.12: Using Hurl filter 

8.2.7  Edge-Detect Filters 

The Edge-Detect allows you to find the contours of an object as well as multiple 
color borders. It is usually used solely for artistic purposes and finding selections. 
 
The levels are determined on the calculative methods of the gradients, giving 
thick border lines. The graph shown in Figure 8.13 (a), represents various color 
intensities. To the left, there is a slow gradient color that does not constitute a 
border, while on the right, an edge indicates that there is a potential border.  
 
Moving into calculations, the graph in Figure 8.13 (b) shows this gradient from 
the first derivative in terms of speed variation of the edge. Now see if it is above 
a threshold value (actual border is located on top of the curve, but varies) for the 
gradient in order to determine the border. Most commonly, the threshold is 
located under the top, while the border is thick. 
 
Moving into the finding the Laplacian edge, by using the second derivative that 
is shown in Figure 8.13 (c), you can see that the value of the top of the curve is 
zero and can be easily found. The main difference is that it shows a thin,  
one-pixel wide border instead. However, the amount of ripples that reacts to this 
derivation is in multiple of zeroes, resulting in false edges. The most common 
way to fix this issue is to apply some blurring on the image or selection, then 
apply the mentioned filter, as this prevents false edges by flattening the small 
ripples. 
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Figure 8.13: Levels of edge detection 
 
To use edge-detect go to Filters > Edge-Detect > Difference of Gaussians > Edge 
> Laplace > Neon > Sobel. See Figure 8.14: 
 

 

Figure 8.14: Edge-detect filters menu 
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The following image in Figure 8.15 shows the output when the image uses the 
Neon filter.  
 

 

Figure 8.15: Using Neon filter 

8.2.8  Generic Filters 

Generic Filters function as a comprehensive filter. To start using Generic Filters, 
start from Filters > Generic > Convolution Matrix or Dilate or Erode that is 
shown in Figure 8.16. See Figure 8.17 for the output of the image using 
Convolution Matrix Filter. 
 

 

Figure 8.16: Generic Filter menu 
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Figure 8.17: Using Convolution Matrix Filter 

8.2.9  Combine Filters 

To use multiple images on an image to create something new, Combine does it 
for you. To start Combining, start from Filter go to Filters > Combine > Depth 
Merge or Filmstrip. Refer to Figure 8.18 for the Combine filter menu.  
 

 

Figure 8.18: Combine Filter menu 
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When you choose the filmstrip filter to your image, it will make the image look 
like a filmstrip. Figure 8.19 shows the image using the filmstrip filter which looks 
more nostalgic. 
 

 

Figure 8.19: Using filmstrip filter 

8.2.10  Artistic Filters 

If you desire to have an oil painting, cubism or canvas effect on your image, then 
you could try the artistic filter. To use Artistic Filter, start from Filters > Artistic > 
Apply Canvas or Cartoon or Clothify or Cartoon or any type of Artistic Filter 
that is shown in Figure 8.20. Figure 8.21 shows the example of an image using the 
Cubism Filter.  
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Figure 8.20: Artistic Filter menu 
 

 

Figure 8.21: Using Cubism Filter 

8.2.11  Deco Filters 

In order for this filter to work, it uses Script-Fu scripts dependent images to make 
decorative borders as well as adding special effects to the piece. To start using the 
Deco Filter choose menu Filters > Décor > Add Bevel or Add Border or Coffee 
Stain and etc as shown in Figure 8.22. Figure 8.23 shows the example of image 
that applies one of the Deco Filters.  
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Figure 8.22: Decor Filter menu 
 

 

Figure 8.23: Using Old Photo filter 

8.2.12  Map Filters 

Map Filters modify images through the use of an object called map, which can be 
created by mapping an image of an object. You could create 3D effects by 
mapping a readily available image onto another embossed image („Bump Map‰ 
Filter) or a sphere („Map Object‰ Filter). To start using Map Filter, start from 
Filters > Map > Bump Map or Displace or Fractal Trace and etc. in Figure 8.24. 
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Figure 8.24: Map Filter menu 
 
Figure 8.25 shows the image that uses Illusion filter as an effect.  
 

 

Figure 8.25: Using Illusion filter 

8.2.13  Render Filters 

Usual filters utilise layers in order to modify the contents of an image; for Render 
Filter, it's treated slightly different. Render requires a totally new process that 
makes patterns from scratch, which means it ignores everything done previously 
on the layer and makes a completely new one. Some of the options available are 



                                                                     TOPIC 8    EFFECTS AND FILTERS     
 
 

161

the ability to make a random or grainy pattern, or even fractal patterns, as well as 
a (GFig) which is a simple tool for vector graphics. To start using Render filter, 
start from Filters > Render > Clouds or Nature or Pattern and more. See Figure 
8.26 and 8.27 for the example of image that applies one of the Render Filters. 
 

 

Figure 8.26: Render Filter menu 
 

 

Figure 8.27: Using Clouds > Difference Cloud filter 
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8.2.14  Web Filters 

Web Filters, as the name implies, are used on images used on websites. Image 
Map is a common tool used to enable parts of an image to be hot spotted (adds 
the ability to click on the spots). Semi-Flatten is usually used to provide minor 
transparency into an image without altering its alpha channel. Slice filters allow 
users to make HTML tables of sensitive images. To start using Web Filter, start 
from Filter > Web > Image Map or Semi Flatten or Slice as shown in Figure 8.28. 
Look at the example of filters that is applied in an image as shown in Figure 8.29. 
 

 

Figure 8.28: Web Filters menu 
 

 

Figure 8.29: The layout of Image Map filter options 
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8.2.15  Animation Filters 

If an image you are working on will be used for animation purposes, then the 
Animation Filter can help either by viewing or optimising (decrease the output 
file size). „Optimize (Difference)‰ and „Optimize (GIF)‰ are considered to be 
similar to each other in terms of purpose. To start using Animation filter, start 
from Filter > Animation > Blend or Burn-in or Rippling or Spinning Globe and 
more as shown in Figure 8.30. 
 

 

Figure 8.30: Animation Filter menu 
 

 

Figure 8.31: Using Waves filter 
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 A Filter is loaded with a library of tools to experiment with. Usually when 

you first start out with GIMP and explore the functions available, you could 
still miss out on the good things that can be useful in your future endeavours.  
 

 Thoroughly experimenting with GIMPÊs functions, allows possibilities such 
as adding lighting, shadow, noise or detecting edges as well as having the 
ability to map images for use on either three-dimensional effects or website 
purposes with the Map filter. You can even have the chance of converting 
your work into art by using the Artistic filters.  

 

 
 
Filters menu A process that allows the user to modify the appearance 

of an image. 
 

Alter To change something or an object.

 
 
 

  
 



 

 

 

 

 

 

 

 

 

 

 

 THE TECHNIQUES  

Would you believe that the best artwork can be produced through GIMP? In 
Topic 8, you have studied in detail about the functions of effects and filters. Now 
you will learn how to use those functions in more advanced techniques in order 
to create a planet that has incredible lighting effects. It may sound difficult to 
grasp; however, you will be amazed at what the result will look like using the 
appropriate tools offered in GIMP.  

9.1 

TTooppiicc

99  
 Advanced 

Techniques 

 
 

By the end of this topic, learners should be able to: 

1. Apply image manipulations with advanced features of GIMP; 
 

2. Demonstrate the basic to advanced techniques and tricks; and 
 

3. Create stunning images with visual effects. 

LEARNING OUTCOMES 
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9.1.1  Shaping a Planet 

1. Create a New Image and set the size to 1024px  768px and put in a 
background color as shown in Figure 9.1. Refer to Figure 9.2 on filling black 
as the background color. 

 

 

Figure 9.1: Create a New Image 
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Figure 9.2: Use Bucket Fill Tool to change foreground color 
 
2. Make a new layer as shown in Figure 9.3 and modify the size to 300px  

300px and set White as the Layer Fill Type. Refer to the criteria of a New 
Layer in Figure 9.4. 

 

 

Figure 9.3: New layer 
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Figure 9.4: New layer options 
 
3. Once you have created a New Layer with the appropriate size as mentioned 

previously, you will get the output as follows. See Figure 9.5 on what the 
layout of the screen looks like.  

 

 

Figure 9.5: Current state of the layout just created 
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4. Proceed to Filters > Distorts > Polar Coordinates as in Figure 9.6. When a 
pop-up appears, click Ok. Polar coordinates will form white boxes that are 
shown in Figure 9.5 into a white circle in Figure 9.7. 

 

 

Figure 9.6: Filter menu 
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Figure 9.7: Shape of the Polar Coordinate 
 
5. Access the Toolbox by clicking on the white circle, then choose the 

Alignment Tool and click on the white circle image. Also in the Tool 
Options, choose both „Align Center of Target‰ and „Align Middle of 
Target‰. Refer to Figure 9.8. 
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Figure 9.8: Alignment Tool 
 
6. Figure 9.9 shows the output once you have altered the polar coordinate and 

alignment.  
 

 

Figure 9.9: State of the layout has changed after altering  
the polar coordinates and alignment tools 
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9.1.2 Shaping Blur Effects 

1. Proceed to Layer > Layer to Image Size as shown in Figure 9.10.  
 

 

Figure 9.10: Layer to Image Size 
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2. Choose the first white circle layer and proceed to Filters > Gaussian Blur. 
Set the Blur Radius as 40px  40px. Refer to Figure 9.11 and 9.12.  

 

 

Figure 9.11: Types of Blur effects 
 

 

Figure 9.12: Gaussian Blur Options 
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3. You will get the output as shown in Figure 9.13 once you add the Gaussian 
Blur effect. 

 

 

Figure 9.13: State of the layout after using Gaussian Blur 

9.1.3 Creating Light and Shadow Effects 

1. Create a New Layer with Layer Fill Type as Transparency as shown in 
Figure 9.14. 
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Figure 9.14: New layer options 
 
2. Go to Filters > Light and Shadow > Supernova (Figure 9.15). Set Center of 

Nova as X = 512px and Y = 384px, also value for Radius and Spokes as 100. 
Refer to Figure 9.16.  

 

 

Figure 9.15: Filter  Light and Shadow 
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Figure 9.16: Supernova options 
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3. The next step is to set the layer Mode as Grain Merge as shown in Figure 
9.17. 

 

 

Figure 9.17: Layer Mode options 



  TOPIC 9    ADVANCED TECHNIQUES   
 

178 

9.1.4  Creating Texture 

1. Now make a New Layer with size 250px  250px and Layer Fill Type as 
Transparency. Refer to Figure 9.18 on how to set the Transparency layer. 

 

 

Figure 9.18: New layer options 
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2. Then go to Filters > Render > Sphere Designer and using Alignment Tool 

, make it align center  and middle  of the image window as 

shown in Figure 9.19. 
 

 

Figure 9.19: Filter Options 
 



  TOPIC 9    ADVANCED TECHNIQUES   
 

180 

3. Once the Sphere Designer windows appear, set the criteria amount based 
on Figure 9.20.  

 

 

Figure 9.20: Sphere Designer Options 
 
4. Your sphere will look as in Figure 9.21. The planet that you created by 

using the sphere looks stunning with the effects applied.  
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Figure 9.21: Image of the planet with the effects applied 

9.1.5  Creating Gradient 

1.  The next step is to make a New Layer with black as the Foreground. Figure 
9.22 shows the criteria that should be applied in creating a new layer. 

 

 

Figure 9.22: New Layer Options 
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2. Set the layer Mode as Screen as shown in Figure 9.23. 
 

 

Figure 9.23: Layer Mode options 
 
3. On the Toolbox select Blend Tool and on the Tool Options change the 

Shape to Radial. Make sure the Background color is black. See Figure 9.24.  
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Figure 9.24: Layer Mode options 
 
4. Make a small gradient at the left corner of the shape that is shown in Figure 

9.25. 
 

 

Figure 9.25: Click the Blend Tool at the left corner 
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5. Figure 9.26 shows the output after the gradient is applied into the shape.  
 

 

Figure 9.26: Light reflection shown on the image of the planet 

9.1.6  Creating Color 

1. Go to Color > Levels and change the Input Level for black point as 70 and 
white point as 230 as in Figure 9.27. 
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Figure 9.27: Level Options 
 

2. Then change the color on Colors > Color Balance. Figure 9.28 shows the 
colors option. Set Midtones color as Cyan = -100 and Blue = 100. Refer to 
Figure 9.29.  
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Figure 9.28: Colors Option 
 

 

Figure 9.29: Midtones color adjustment 
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3. Once you have already applied the color balance, the next step is to tick 
Shadows and change Cyan = -30 and Blue = 30 as shown in Figure 9.30. 
Click Ok. 

 

 

Figure 9.30: Shadows and colors adjustment 

9.1.7  Making Duplicate Layers and Light 

1. After the process of shadows and color adjustment, duplicate the layer. 
Figure 9.31 shows the Duplicate Layer function under the LayerÊs menu 
bar.  
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Figure 9.31: Duplicate Layer 
 
2. Go Filters > Light and Shadow > Supernova. On Supernova options, 

change Radius as 20 and Spokes as 50. On the preview, drag the Nova to 
the center of the gradient. Click Ok. Refer to Figure 9.32 and 9.33. 

 

 

Figure 9.32: Filters  Light and Shadow 



                                                               TOPIC 9    ADVANCED TECHNIQUES     
 
 

189

 

Figure 9.33: Supernova options 
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3. Select the Background layer and go to Filters > Noise > HSV Noise and set 
the Value as 100 as shown in Figure 9.34. 

 

 

Figure 9.34: HSV Options 
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4. Figure 9.35 shows the finished product  a beautiful planet with the special 
effects explained in this topic.  

 

 

Figure 9.35: The finished product of the planet with all of the effects applied 

 

 
 
 A few tools were used such as File (in order to create a new layer), Filters, 

Layers and the Toolbox (Alignment Tool) as the main tools for creating an 
image. 
 

 While the other remaining tools are subcategories within Filters, such as 
Distort (Polar Coordinates), Blur (Gaussian Blur), Light and Shadow 
(Supernova), Render (Sphere Designer) and Layer for the image size. All 
these tools are used in advanced techniques to design and produce stunning 
images.  

 
 Filters play a very important and effective role to get special effect and make 

your image appear more impressive.  
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Alter To change something or an object.

 

Mode  A distinct setting within a program.
 

Foreground  Opposite of the background.

 
 
 
 
 

 



 

 

 

 

 

 

 

 

 

 

 

 

 

 PREPARING IMAGES 

GIMP (GNU Image Manipulation Program) is a very formidable software that 
allows for various image-related tasks such as preparing images to be used for 
website purposes at no value, alongside an open-source community that 
contributes to each other across all platforms. 
 
In recent years, browsing through the Web has been a very visual experience, 
filled with mostly photos and images. While this does help stimulate visual 
attraction and attention, some sites however, lack the proper optimisation for 
their images. This would drive your potential viewers away. Unoptimized 
images come in various forms such as an image having a large file size, taking a 
very long time to load or display properly. 
 

10.1 

TTooppiicc

1100  
 Preparing 

Images  
for Web 

 

By the end of this topic, learners should be able to: 

1. Prepare images with appropriate size and save option for the Web 
use; and 
 

2. Identify the file types used for Web images. 

LEARNING OUTCOMES 
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Now you will move into how to properly prepare your images for website use. In 
this topic, you will be focusing on how to optimize and prepare images through 
GIMP. In addition, these steps can also be used in other programs as well, 
however, we will keep it GIMP friendly. The main purpose and result is the same 
across most image editing software. 

10.1.1  Large Image 

The most common mistake found on websites is that administrators rarely 
prepare their images before proceeding to upload it. When your images take a lot 
of resources and bandwidth just for the sake of viewing, it makes the experience 
an uneventful one. Now let us take a look at the following steps: 
 

1. Load your image and start from the main menu and then go to Image > 
Scale Image as in Figure 10.1. 

 

 

Figure 10.1: Image menu 
 

2. A new dialog box will appear, proceed by modifying the width and height 
in Image Size parameters accordingly as in Figure 10.2. 
 

Tips: 

The sizes that you use on each image vary according to where and what 
purpose it will be used for on your website. It is recommended to streamline 
the amount you resize with the websiteÊs overall design. But in case you are 
unaware of the exact size required, then using a rough approximate should 
suffice. Now, proceed to resize the images until they fit. 
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Figure 10.2: Scale Image 
 
3. While you are still in the dialog box shown in Figure 10.2, the first thing to 

make sure is that you have the resolution for pixels per inch (ppi) to 72ppi 
for both X and Y resolution (a ppi higher than this would result in 
unnecessary pixel data to download on most regular screens). 

 
4. The pixels of an image behave differently when scaled, they either increase 

(enlarge) or decrease (reduce). In GIMP, there is a drop-down for 
Interpolation that enables various type of scaling. Each of these provides 
their own process and results on the quality when scaling an image. 

 
(a) Note: Cubic is the default method and can be considered as user-

friendly. 
 

(b) None: The fastest method produces low quality results due to having 
no Interpolation involved. Pixels are simply removed or added 
similar to zooming. 
 

(c) Linear: Uses Interpolation at a relatively fast pace with decent results. 
 

(d) Cubic: Detailed process that takes a while to finish, but produces the 
best results. 
 

(e) Sinc (Lanczos 3): Reduces the amount of blur appearing on certain 
areas, a new addition to the GIMP 2.4 build. 
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5. Once prepared, press Scale to begin the process. When the image is done, 
there is still one more step to go. Make sure to save your image for Web 
before uploading. 

 SAVE FOR THE WEB 

Once your image is set with the proper conditions, you will be moving into the 
optimization phase. First is to rename the file to according to the Web standards. 
With Image Optimization, the file size of your image is significantly reduced in 
order to decrease the bandwidth required which will make your viewer happy. 
 
1.  When you are done setting your image, proceed to File > Export. Refer to 

Figure 10.3: 
 

 

Figure 10.3: Export As menu 
 

10.2 
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2. A dialog pops up and you need to find a location to store your images. 
Once done, make sure to name the files accordingly and proceed to Save As 
(Figure 10.4). 

 

 

Figure 10.4: Export Image menu 
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3. Figure 10.5 shows that from the dialog box you would need to save your 
files using the most suitable file format (extension). 

 

 

Figure 10.5: File Format 
 
 Using the correct file format not only enhances the look of your website, it 

is also crucial in order to make sure that your images render properly. Two 
common scenarios would be; saving an animated image as a .jpg will not 
make it animated nor will saving as a format that is not supported by the 
browser. 
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4. After selecting a suitable format for your image, go ahead and click Export 
as in Figure 10.6. 

 

 

Figure 10.6: Export file 
 
5. After exporting, a dialog box will appear depending on the format that the 

file has been saved as. Make sure to understand the file format before 
exporting as they serve different purposes. 

 
 If you have no clue on how the mechanics work, then using the default 

option is still possible. 
 
6. After fully setting up your files, proceed to Export. 
 
Congratulations, your images are now properly optimized and ready to be used 
on your website. 

 FILE TYPES 

10.3.1 Optimizing GIF (.gif) 

This is a common file format used for logos, patterns, shapes and solid colors 
usually incorporated with GIF that is shown in Figure 10.7. While it has the 
ability to use 8-bit or 256 colors for transparency, it is not advised to use it for 
images that have a high range of colors. In addition, GIF also has the ability to 
support animation but it also takes a longer time to load due to its file size. 
 

10.3 
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Figure 10.7: GIF export menu 
 
Interlace is usually beneficial for slow Internet users as it displays the image in 
progression while loading. For animations, it saves the cache of the animation so 
that it can be instantly viewed at a later date. 

10.3.2 Optimizing JPEG (.jpg) 

If you wish to use high quality images, ranging from 24-bit or up to 16.7 million 
color count without transparency, then JPG or JPEG is the choice (Figure 10.8). 
JPEG has always been the format to use for images with vast amount of colors. 
Another key benefit of JPEG is that it is flexible in terms of compression, and in 
return provides a satisfactory image quality at quite a lot of size variants. 
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Figure 10.8: JPEG export menu 

10.3.3 Optimizing PNG (.png) 

PNG offers similar options to GIF in terms of functionality, minus the ability to 
do animation as shown in Figure 10.9. PNG-8 has the same capacity as GIF in 
terms of color support (8-bit/256 colors); while PNG-24 is similar to JPEG  
(24-bit/16.7m colors), it could also support transparency which can be useful for 
a variety of opacity levels. 
 
You can choose to use PNG to Save background color, especially if an image has 
a few levels of opacity. Take note that some browsers do not necessarily support 
all levels of transparencies, and at most two levels. For this case, the browser will 
utilise the background color if you chose this setting in the toolbox. 
 
Gamma: Gamma correction acts as a corrector for computing values of color. 
When you select Gamma, the information of the gamma is then saved alongside 
the PNG, this can be used to prevent an image being too bright or too dark on 
different displays. 
 
Compression Level: Determines the rate of how much compression is done, 
resulting in various file sizes. 
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Figure 10.9: PNG export menu 

 

 
 
 This topic describes the proper methods in preparing images that can be used 

for websites. It explains the appropriate size and format of images for 
websites. Each file has their own purpose that contributes into a website.  
 

 It is advised to explore using the three common types (GIF, JPEG and PNG) 
for the images you wish to upload on the Web. Keep exploring and trying to 
be better in GIMP. 

 

 
 
Web Also known as World Wide Web which is an Internet 

system that serves special formatted documents (HTML 
language). 
 

Uploading  To transfer data or files to the Internet.
 

File format Types of files where information is stored.
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