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Module 4 
Spreadsheets using OpenOffice 
CALC 
Module Overview 

In this module you will learn how to develop, work with and manipulate 
spreadsheets using the computer application OpenOffice Calc. 
 
At its core, a spreadsheet is a table of rows and columns, creating a grid 
of cells in which numeric or text values are displayed. In most situations, 
spreadsheets are used for manipulating numeric data. The spreadsheet 
computer application is designed to enable you to model and observe the 
relationships among data in the respective rows and columns.  
 
Spreadsheets can be useful in a variety of contexts, e.g., to analyse 
business data, to track personal finances, or to create charts for visual 
interpretation of data. 
 

 
 

Upon completion of this module you will be able to: 
 
 

Develop, format, modify and use a spreadsheet 

 
Generate and apply standard formulae 

 
Create and format graphs and charts  

 
Output a spreadsheet to print 

Terminology 
 

 
 

A spreadsheet is a large sheet of rows and columns 
that lays out information about a financial 
transaction, including things like costs, taxes, 
income, etc., so that a business person or manager 
can easily make decisions 

Spreadsheet 

 
A worksheet is one page of a spreadsheet. An 
electronic spreadsheet document can incorporate 
many worksheets. 

Worksheet 

 
A cell is the area formed by the intersection of a 
row and a column. Spreadsheet cells contain 
information such as text, numbers, and formulas. 

Cell 

 
Toolbars are areas in the application that contain 
most of the common commands and functions you 
need to use the application. 

Toolbars 

 
A formula is a spreadsheet function entered in a 
cell. 

Formulas 

 
 A function is a formula that is built into the Calc 

program. 
Functions 

 
A diagram that displays data in a pictorial form. Chart 
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A reference to a worksheet cell that is dynamic. 
The reference changes with changes in the 
worksheet. 

Relative Cell 
Reference 

 
A reference to a worksheet cell that is static. The 
reference doesn’t change with changes to the 
worksheet. 

Absolute Cell 
Reference 

 
Study Tips 
 
You may find it useful to skim through an entire block of content first, 
paying special attention to the headings and introductions, and then go 
through a second time for more in-depth study and practice. 
 
However, we recommend that you do the activities as they appear. They 
are essential study materials, offering practice in particular skills that will 
build your proficiency in using spreadsheets. 
 
Keep linking the new content that you are studying with content in this 
module that you have already covered and with your own general 
knowledge, to deepen your understanding of the operations you are 
learning. 
 
If you have difficulty understanding any area, try working at it slowly. If 
you still do not understand, seek help. 
 
Preknowledge 
 
Before beginning this module, we recommend that you: 
 
• complete the modules on Computer Applications (Modules 1 and 

2) and Word Processing (Module 3) 
• be skilled in arithmetic computation: addition, subtraction, 

multiplication, division, computation with decimal numbers, 
computation of percents 

• be skilled at estimating the results of simple calculations, so when 
entering formulas the results can be mentally checked 

• be a logical thinker, that is, capable of following a series of 
calculations from one step to the next 
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Introduction to Spreadsheets 
 
More than any other application software in history, the spreadsheet has 
been instrumental in helping personal computers gain widespread 
acceptance in the business community. Called a “killer” application, 
spreadsheets made such an immediate impact on financial accounting that 
businesses couldn’t afford to not take notice. 
 
Section Overview 
 
This section will introduce you to the key concepts of the spreadsheet 
application. 
 
By the end of this section, you will: 
 

• appreciate the impact that the development of the spreadsheet had 
on growth of the personal computer industry 

• become familiar with some design considerations for spreadsheet 
documents 

 
Development of the spreadsheet 
 
Spreadsheets, in their original paper form, have been used in financial 
accounting for hundreds of years. A spreadsheet is a large sheet of rows 
and columns that lays out information about a financial transaction, 
including things like costs, taxes, income, etc., so that a business person 
or manager can easily make decisions. 
 
Electronic spreadsheets are much more recent. Their development dates 
back to 1978, when Dan Bricklin and Bob Frankston, two MIT 
acquaintances, developed a program called VisiCalc (from the words 
visible and calculator). VisiCalc became an instant success and 
convinced a lot of business people to purchase a personal computer for 
their business. (reference: http://www.bricklin.com/history/sai.htm) 
 
In 1983, a new spreadsheet application called Lotus 1-2-3, designed to 
run on personal computers being produced by IBM, was introduced. It 
added integrated charting, plotting, and database features, and established 
the spreadsheet as a tool for data presentation and complex calculations. 
 
The next milestone was in 1985, when Microsoft Excel was written for 
the Apple Macintosh personal computer. The Macintosh offered the 
advantage of a graphical user interface, with pull-down menus and the 
point-and-click capability of the mouse, which made it easier for most 
people to use. When Microsoft released the Windows operating system, 
Excel was the first spreadsheet software designed to run on it. 
 
  

http://www.bricklin.com/history/sai.htm�
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Design considerations for spreadsheet documents 
 
The two features of a good spreadsheet are: 

• good data, and  
• good design. Good design makes it easier to enter data and 

retrieve valid results. Poor design can make a spreadsheet 
unusable despite having excellent data to work with. 

 
The points below will help you to avoid becoming disoriented in the 
maze of spreadsheet cells by designing your spreadsheet so that you can 
navigate easily. Other suggestions will help you create a spreadsheet 
document that analyses data quickly and efficiently. You may not 
understand all of the terms described below until you work through the 
practical exercises, but refer back to this list often as you create new 
spreadsheets. 
 

1. You should start your design with an end in mind. Establish how 
you are going to layout the columns and rows of your 
spreadsheet. Spreadsheet software has far more rows than 
columns, so generally you should create your spreadsheet 
document with the headings running across the columns, and the 
data in rows underneath. 
 

 
 

2. Sometimes the number of rows or columns will increase over 
time, and sometimes they will remain fixed, but you should 
assume that you will have to add more data or formulas sometime 
in the future (because you probably will). 

3. Use descriptive labels for rows, columns, and cells in your 
spreadsheet. 

4. Use different type faces or font colours to distinguish data and 
highlight features of your spreadsheet, but keep it simple. Use 
Bold for data headings. 

5. All raw data should be included in a single worksheet (a 
worksheet is one page of your spreadsheet). 

6. Leave about four blank rows at the top of your spreadsheet above 
your column headings. These can be used for keeping totals, 
since this location is much easier to find than at the bottom of 
your data. 
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7. Have your data sorted as much as possible. This will help keep 
your spreadsheet organised, but will also help speed up some 
calculations. 

8. Use a date format that the spreadsheet recognises as a date (as 
opposed to text). This will allow you to use this data in formulas. 

9. Don’t combine data into one cell. For example, a person’s name 
should go into at least two cells: Family Name and Given 
Name. 

10. Decide what formulas you need to use to perform the calculations 
in your spreadsheet. 

11. Decide what charts or graphs are most appropriate to display the 
results of your spreadsheet analysis. 
 
The following main types of graphs/charts are possible: 

Column 
 

  

Bar 

 

Pie 

 

Area 

 

Line 

 

XY 
Scattered 

 

 
Summary 
 
This section discussed the development of the spreadsheet application, 
and introduced the concept of spreadsheet design, in particular how good 
design makes it easier to enter data and retrieve valid results from your 
spreadsheets. 
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Using the Spreadsheet Application: The Basics 
 
Section Overview 
 
OpenOffice Calc is the application we will be using to develop and work 
with spreadsheets. Calc is similar to Microsoft Excel; in fact you can save 
your Calc spreadsheets in Excel format for sending to Microsoft users. 
 
In this section we will become familiar with the basic features of the Calc 
application and learn how to perform basic spreadsheet operations. 
 
Upon completion of this section you will be able to: 

• open and close Calc 
• identify the core components of the Calc workspace 
• open one and several spreadsheets; close a spreadsheet 
• create a new spreadsheet 
• save spreadsheets in different locations and under different 

conditions 
• switch between worksheets in a single spreadsheet 
• use help functions in Calc 
• use tools to adjust settings 

 
Opening and closing Calc 
 
Opening and closing OpenOffice Calc is done the same way as opening 
and closing OpenOffice Writer from Module 3, by using the 
Applications menu in the top-left of the Ubuntu desktop. 
 

 
 
To open CALC: 
 

1. Click on the Applications menu. 
2. Click Office 
3. Click OpenOffice.org Spreadsheet. 
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This will present the OpenOffice splash screen as the operating system 
loads the Calc application. 
 

 
 
To close CALC: 
 

• Click on the File menu in Calc, then click Exit  
or 

• Click on the Exit icon  in the top right hand corner of the 
Calc window. 

 
Creating, opening, and closing spreadsheets 
 
Creating a new spreadsheet 
 
When you launch the Calc application, a blank spreadsheet is created for 
you automatically. To create a new spreadsheet from within the Calc 
application: 
 

1. Click on File on the menu Bar. 
2. Click on New on the drop down menu. 
3. Click on Spreadsheet. This will display a blank spreadsheet. 
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Your work area is one of the worksheets of the spreadsheet that you are 
working on. The tabs in the bottom left corner of the work area allow you 
to switch between worksheets. If the tab for Sheet 1 is highlighted, then it 
is the first worksheet that is being displayed. If you click on Sheet 3, then 
the third worksheet replaces the first on the screen. The spreadsheet 
consists of all these worksheets. 
 
A spreadsheet consists of text, numbers and formulas that are entered into 
the cells of its worksheets. Collectively, text, numbers and formulas are 
referred to as data. Spreadsheets that contain data are saved as files, just 
as in the case of word processed documents. 
 
Opening an existing spreadsheet from within Calc 

 
1. Click on File in the menu bar. 
2. Click on Open. This brings up the Open Dialogue window. The 

dialogue lists a series of directories and files. 
3. Locate the directory in which the desired file is held. 
4. Click on the directory to open it. 
5. Highlight the file. 
6. Click Open.  

 

 
 

Tip: If you are not sure about the directory that contains your file and 
you have to search a bit, you will find the Up one Level icon useful.  
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Closing a single spreadsheet 
 
Before we perform this task, we need to be clear about the difference 
between the 'close' and 'exit' commands. Close closes the spreadsheet, 
but leaves the program Calc and other spreadsheets open. Exit closes the 
spreadsheet you are working on, any other spreadsheet that is open, as 
well as Calc. 
 

1. Click on File on the menu bar. 
2. Click on Close. This command is in the top section of the drop 

down menu. Exit is in the bottom section. 
 

 
 

Tip: Always save your data before closing or exiting. Calc will help you 
here if the version of the document that you have on the screen differs 
from the one already saved on the hard disk. Calc will ask you whether 
you want to save the new version. Secondly, always close Calc before 
you shut down the system. 

 
Working with multiple spreadsheets 
 
If you need to work on more than one spreadsheet at the same time, you 
can open multiple spreadsheets and move between them. You may want 
to do this if you need to copy data from one spreadsheet to another. 

 
1. Click on File then Open. 
2. Locate the directory containing the files you wish to open. 
3. Click on the first file. 
4. Hold down the CTRL key and click on each of the additional 

files you wish to open.  
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5. Click Open. The last of the files loaded will appear in the 

window. This will be the active spreadsheet. The others are also 
loaded but are in the background.  

 
You can make one of the other spreadsheets active as follows: 
 

1. Click on Window to list the spreadsheets that are loaded. 
2. Click on the spreadsheet that you wish to make active. 

 

 
 
Close more than one spreadsheet 
 
If you wish to close some but not all the spreadsheets you have loaded, 
then you will use the Close command for each separately. If you want to 
close all spreadsheets as well as exit CALC, then you will use the Exit 
command. 
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Saving spreadsheets 
 
You will want to save your documents often so that you don’t lose data if 
your computer crashes or if your application is inadvertently closed. If 
you exit the application without saving, Calc will prompt you to save 
your work. 
 
Saving on the hard drive of your computer 

 
1. Click on File, then click Save As. This will bring up the Save As 

dialogue. 
2. Locate the drive and /or the directory in which you wish to save 

the file. You can save files to your hard drive, floppy drive, Flash 
Memory stick, or many other storage memory devices. 

3. Enter the name of the file in the File Name window. 
4. Click Save. 

 

 
 
Save an existing file under another name 
 
Sometimes we may want to have the same spreadsheet saved under a 
number of different names. Alternatively, we may want to save a 
spreadsheet before making changes. We would then have a copy of the 
new version as well as the version before changes were made. Suppose 
we have a spreadsheet loaded as shown below. In this case the 
spreadsheet already has the name demo.sxc. 
 
We can now save what is displayed on the screen in two ways: 
 

• As the existing file: After loading demog.sxc from the hard disk, 
we made some changes to it. Those changes exist only on the 
version on the screen and will not automatically be made to the 
file that is located on the hard disk. To replace the version on the 
hard disk with the contents as displayed on the screen. 
 
Click on File, then Save. 
 



12 
 
 

 

• Under another name: Suppose we do not want to overwrite the 
contents on disk but would still like to save what is on the screen.  
 
Click on File, then Save as. 
 
This will bring up the Save As dialogue. You use this in exactly 
the same way as you would if you were saving a completely new 
file. 

 
Save in another file type 
 
Sometimes it is useful to convert the spreadsheet format into another 
format, for example, a text file that can be manipulated using a word 
processor. Alternatively, you may wish to save the spreadsheet in a 
format used by another spreadsheet program such as Microsoft Excel. To 
save a spreadsheet in a different format: 
 

1. Click on File, then Save as 
2. Click on the File Type window. This will display a list of file types 
3. Use the vertical scroll bar to view all the file formats.  

 

 
 

The following table lists some of the main file formats and a brief 
explanation of each. 
 

File type  Extension Explanation 
OpenOffice.org Calc 
Spreadsheet  

sxc This is the format of Calc itself 

OpenOffice.org 
Spreadsheet template  

stc A template is an outline for new templates. 
This may include text, values and formulas 
that are automatically inserted when a new 
template is created using template. It could 
also include formatting of cells such as font 
type and colour. 

dBase  dbf This would save the spreadsheet in a format 
used by some database programs. These 
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File type  Extension Explanation 
databases would then be able to access the 
data in the spreadsheet and work with it as if it 
had been created by a database. 

Microsoft Excel  xls, xlsx Although Microsoft Excel is also a 
spreadsheet, it uses a different format. By 
saving the spreadsheet in the xls format, it 
could be opened directly by Microsoft Excel. 

Web Pages  html In order to read files, web browsers need to 
have them saved in a special format known as 
HTML or Hypertext Markup Language. Calc 
is able to save a spreadsheet in this format. 

Text CSV  csv This format is also called a comma delimited 
file. In this format, each row is converted into 
a paragraph. The columns of the spreadsheet 
are separated by commas. A word processor 
will read this file as an ordinary text file. 

Data Interchange 
format  

dif A DIF is an industry standard for exchanging 
data between different types of application. 

Portable Document 
Format  

pdf Pdf files are a common way of sending 
documents that you do not wish the receiver to 
be able to edit. These files can be read with 
Acrobat Reader. Unlike the previous formats 
that are created using the Save As ... function, 
pdf files are created using the Export as pdf 
... option in the File menu. 

 
Save different Versions 
 
On the file menu there is an option called Version that allows you to save 
different versions of the spreadsheet in the same file. You are asked to 
give the version a name and this is recorded along with the date and time 
of the changes that were made. If you want to open another version of a 
file, simply click on File->Version and choose the Version you want to 
open. 
 
Getting Help 
 
OpenOffice has a help file for each application. The help files are 
searchable and can assist you with almost any OpenOffice Calc task. 
 

1. To access the help file, click on the Help menu in the Menu 
toolbar, and then click on OpenOffice.org Help. Alternatively, 
press the F1 key on your keyboard. 
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2. Perhaps you are interested in getting help with inserting charts 

into your spreadsheet. When the Help window opens, you can 
browse through the Help contents by clicking on the Contents 
tab.  
 

 
 

3. The Index tab lets you search for specific help topics by typing a 
search term. 
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4. The Find tab lets you search all of Help for specific words. 
 

 
 

5. You can bookmark Help pages that you are likely to revisit using 
the Bookmarks tab. 
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Self Assessment 
 
To assess your learning, make sure you are comfortable carrying out the 
following tasks in OpenOffice Calc: 
 

1. Find and select OpenOffice.org Spreadsheet from the 
Applications menu. 

2. Create a new spreadsheet. 
3. Save your spreadsheet to disk as My First Spreadsheet. 
4. Close the spreadsheet and exit OpenOffice Calc. 
5. Again, start OpenOffice Calc and open your recently saved 

spreadsheet. 
6. Save your spreadsheet again under a different document 

format. 
7. Use OpenOffice Calc Help to search for help on a subject, 

and bookmark a help. 
8. Close the document and exit the application. 

 
Summary 
 
This section introduced the OpenOffice Calc application and described 
the basics steps to using Calc, including opening and closing 
spreadsheets, saving your documents, and using Calc functions and help. 
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Working with spreadsheets 
 
Section Overview 
 
So far in this module you have been introduced to the features of the 
OpenOffice Calc spreadsheet application and have learned some of the 
basic operations, such as opening, closing, and saving documents. 
 
In this section we are going go further into the Calc workspace to learn 
how to use the toolbars and other components in Calc, and how to 
customise Calc for your use. 
 
In this section, we will 

• identify the core components of the Calc workspace 
• learn about the Calc toolbars and their function 
• perform some basic tasks with spreadsheet documents 

 
Locating the components of the Calc window 
 
When you open the Calc application, you will see running across the top 
of the Calc window a set of four toolbars each of which displays a series 
of icons or buttons that you can click on when you want to perform 
certain tasks. Beneath that you will see a worksheet window ready to 
receive your data, and another toolbar to provide a shortcut to perform 
common tasks. 
 
The Calc window explained 
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Calc toolbars 
 
The Menu Toolbar 
 
The menu toolbar displays the names for categories of basic commands, 
many of which also are found in the other OpenOffice tools. For 
example, the File menu consists of a set of commands related to file 
operations such as opening an existing file, creating a new file, closing 
files, and so on. 
 

 
 
The Function Toolbar 
 
The second bar is the function toolbar. It contains icons to provide quick 
access to commands found in the drop down boxes on the main menu, 
e.g., New, Open, Print, Copy, Paste, etc. 
 

 
 
The Formatting Toolbar 
 
The third bar is the formatting toolbar. It contains icons and drop down 
menus for commands used to format cells, e.g., to select a font, font 
colour, alignment, number format, border option and background color. 
 

 
 
The Formula Toolbar 
 
The fourth bar is the formula toolbar. It contains the Name Box drop 
down menu. In this dialog box you will see the address of the cell or cell 
range that is currently selected (e.g., C1:D5, if the block of cells from cell 
C1 to cell D5 is selected). Also you will see  a long box called the Input 
Line, which serves as the entry point for all data to be entered in the 
highlighted cell. 
 

 
 
 

Tip: When you place your mouse cursor over an icon on a toolbar, the 
name of the function appears on your screen. 
Selecting the >> drop down menu on the far right of the function and 
formatting toolbars opens a menu of options for customising the toolbars. 
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The Calc Work Area 
 
The work area consists of a grid formed by the intersection of rows and 
columns. Each grid is called a worksheet, and a spreadsheet can be made 
up of many such worksheets. 
 
Columns, Rows and Cells 
 
The main feature of a worksheet is that it is organised into columns and 
rows. Columns run vertically from top to bottom of the work area and are 
named by the letters of the alphabet seen at the top of each column. The 
rows run horizontally from left to right and are numbered. 
A cell is the point where a row and a column intersect or cross each other. 
For example, cell A7 is the cell lying at the intersection of Column A and 
Row 7. A7 is also referred to as the address of the cell. 
 

 
 
Tabs 
 
The tabs are located at the bottom left corner of the work area. By 
default, there are 3 of them, named Sheet 1, Sheet 2, Sheet 3. These tabs 
identify the worksheets that are contained in a single spreadsheet.  
 
When you click on a tab, its worksheet is displayed. The work area that 
we have been looking at thus far is essentially the work area of a single 
worksheet when displayed on the Calc screen.  
 
We will look more closely at spreadsheets and worksheets in a later 
section. 
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Adjusting the application settings 
 
When you first open the Calc application, the workspace is organised so 
that the most used toolbars and features are available to you. As you 
become more proficient at using spreadsheets, you will find that you want 
to customise the Calc workspace to better meet your needs. 
 

 
 
Magnification Tools 
 
You can enlarge or decrease the screen display of the spreadsheet you 
have open by clicking on the Zoom tool on the Function toolbar. 
Choose the magnification that works best for your screen. 
 

 
 
Modifying Options (show/hide toolbars) 
 
OpenOffice Calc comes with a very large array of tools to format text and 
objects in your spreadsheet. When you install the application, the default 
toolset contains most of the tools that you will need to work on your 
documents, but you can also choose to show or hide toolbars or to modify 
toolbars if you need to. 
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To show or hide toolbars: 
 

1. From the View menu click on Toolbars 
2. Click in the boxes to either show or hide toolbars as needed. 

 

 
 
To modify a toolbar: 

 
1. From the Tools menu, click on Customize. The Customize 

dialogue window will open. You can use this to modify menus, 
keyboard functions, toolbars, or events. 
 

 
 

2. Click on the Toolbars tab. 
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3. Choose the toolbar you want to modify from the dropdown list. 
4. In the Toolbar Content Commands section, check the 

commands you want to include on the toolbar, and uncheck the 
commands you don’t want to show. If the command you want is 
not in the list, click on the Add button to choose from a list of 
other commands. 

5. Click OK to save your changes. 
 
Self Assessment 
 
To assess your learning, make sure you are comfortable carrying out the 
following tasks in OpenOffice Calc: 
 

1. Identify the following parts of the Calc window: 
1. The menu toolbar 
2. The function toolbar 
3. The formatting toolbar 
4. Rows and row headings 
5. Columns and column headings 
6. Worksheet tabs 

2. Be able to adjust the application settings such as zoom, and to 
modify toolbars by adding commands. 

 
Summary 
 
This section covered the Calc workspace, and how the workspace can be 
modified by hiding or showing toolbars, modifying toolbars, and 
changing the view settings. 
  



 23  
 

 

Adding content to Calc spreadsheets 
 
Section Overview 
 
In this section you will begin to work with OpenOffice Calc spreadsheets 
by putting data into cells and formatting the data so that it is presented in 
a way that makes your spreadsheet documents easy to read and 
understand.  
 
Cells are the basic building block of spreadsheets – these are the areas 
that hold data, functions, and formulas. A row is a group of cells adjacent 
to each other running horizontally in the spreadsheet. A column is a 
group of cells running vertically. 
 
It’s important that you learn to enter data into cells correctly. If one cell is 
incorrect, it can have consequences for your whole spreadsheet. 
 
In this section we will: 

• work with cells: 
o enter and edit numerical, text, and other data into cells 
o search, sort, and manipulate data 
o format data 

• work with rows and columns: 
o insert, delete, and resize rows and columns 
o format rows and columns 

• learn the basic techniques to work with worksheets: 
o rename worksheets 
o insert and delete worksheets 
o copy worksheets 

 
Scenario 
 
In this section, we will use a real-life example to begin creating our 
spreadsheet, based on rainfall data for Vancouver, Canada. This data is 
interesting because there is a clear trend in rainfall patterns in Vancouver, 
and we will see how spreadsheets can be used to display and emphasise 
this trend. 
 
We will work with the following sample data sample collected at 
Vancouver International Airport: 
 

Precipitation for Vancouver International Airport 
 Year: 2005 2006 2007 
January  249.6 283.6 181.4 
February  45.8 57.0 116.0 
March  132.8 92.4 214.8 
April  90.2 70.0 76.2 
May  68.6 42.8 37.0 
June  49.6 54.4 80.0 
July  43.6 25.2 53.0 
August  28.6 4.8 8.4 
September  53.6 39.4 73.6 
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 Year: 2005 2006 2007 
October  155.4 57.8 155.2 
November  136.6 350.8 116.2 
December  160.8 146.0 210.6 
 
Do the following activities using the above file.  Please remember to save 
the file under a name that you can retrieve the file again.  Save the file 
after each activity. 
 
Working with cells 
 
Before we begin entering data into cells, we should take a little time to 
plan our worksheet by asking ourselves a few questions: 
 

1. What do we want the data to show us? 
In this case, we want to determine the average rainfall in 
Vancouver for each month over a three year period. Therefore we 
should arrange our worksheet with a column for each month, and 
a row for each year. 
 

 Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec 
2005             
2006             
2007             
Avg             

 
We enter the data this way because we want to be able to increase 
the length of our spreadsheet if we get more data, not the width.  
 
In this case, there will always be 12 months in a year, so the 
width will stay constant, but the length will increase as we add 
more years. 
 

2. What formulas will we need? 
The formula for finding the average. 
 

3. How will we display the results? 
A column graph with one column for each month should work. 
 

Selecting cells and cell ranges 
 
In Calc you select cells with your mouse: 
 

1. If you want to select a group of cells in a single row, click on the 
left-most cell, hold the left mouse button down, and drag your 
mouse to the right (alternatively, click on the right most cell, hold 
the left mouse button down and drag left). 

2. If you want to select a group of cells in a column, click on the top 
most cell and drag down, or click on the bottom most cell and 
drag up. 

3. If you want to select a group of cells spanning a number of 
columns and rows, click on one of the corner cells in the range 
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you want, and drag left or right and up or down until the range 
you want is selected. 

4. To select a whole row, click on the row heading (the number 
along the left side of the worksheet). 

5. To select a whole column, click on the column heading (the letter 
at the top of the worksheet). 

6. If you want to select the whole worksheet, click on the top left 
corner of the worksheet (to the left of column heading A and 
above row heading 1). 
 

 
 
Entering data in cells 
 
We enter data into cells by clicking on a cell and typing in our data using 
the keyboard. Remember that it’s good practice to leave a few blank rows 
at the top of a worksheet for totals, headings, etc. 

1. Enter the months of the year in Row 4 of your spreadsheet. These 
are our column headings. 

2. To move vertically or horizontally in a spreadsheet, either use 
your mouse to click on the next cell, or use the arrow keys on 
your keyboard. 

3. To enter a list of data, enter the data for the first cell and then 
type the <Enter> key to go to the cell directly below. Keep doing 
this for each column until the list is finished. 

4. Enter the precipitation measurement for each month in the three 
rows beneath the column headings. Your spreadsheet should now 
look like this: 
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Editing data 
 
If you make a mistake entering data into cells, you can correct it easily by 
clicking on the cell and typing the new data. You can do this either in the 
cell itself or in the input line in the spreadsheet: 
 
To edit data in the cell: 

 
1. Double-click in a cell, and then highlight the data you want to 

replace. 
2. Type in the new data. 

 
To edit data using the input line: 
 

1. Click inside the cell. 
2. In the input line, highlight the data you want to replace. 
3. Click on the Checkmark to accept the new data. 

 

 
 
Using Undo/Redo 
 

If you make a mistake when you are inputting data, applying 
formatting, or just about an other action in Calc, you can use 
the Undo button to go back one step. 
 
 

The Redo button will take an action you have just finished and 
repeat it. This is handy if you need to repeat the same action on 
a number of cells. 
 

 
Numerical data 
 
Calc tries to interpret whether the data in our spreadsheet is numerical or 
text. By default, text data is aligned to the left of a cell, and numerical 
data is aligned to the right. 
 
Numerical data can be formatted a number of ways, depending on the 
nature of the data. For example, our precipitation data is an integer with 
one digit after the decimal point. 
 
To set the type of numerical data in a spreadsheet: 

 
1. Select the cells you want to format. 
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2. Choose Format->Cells from the Calc menu. 
3. Choose the category: 

• Number: for general numerical data 
• Percent: display numerical data as a percent 
• Currency: for currency data. Negative values are 

generally displayed in red type. 
• Date: To display data as a date, in a variety of formats. 
• Time: To display data as a time, in a variety of formats. 
• Scientific: for exponent data. 
• Fraction: to display numbers as fractions. 
• Boolean value: displays True or False. 
• Text 

4. Choose the format. For numerical data, your choice is with or 
without a comma separating the hundreds, thousands, millions, 
etc. 

5. Choose the number of places after the decimal point. 
 

We can see from the data in our spreadsheet that if the digit after the 
decimal point was zero, it was automatically dropped. Change the data 
format for all of our cells to include 1 digit after the decimal point. 
 
Your worksheet should now look like this: 
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Date format of data 
 
You can format a cell that contains date data a number of different ways: 
 

 
 

• Long text: December 31, 1999 
• Abbreviated text: Dec. 31, 1999 
• Numerical format: 31/12/1999 
• Abbreviated numerical format: 31/12/99 

 
Using Find and Replace 
 
Find and replace in Calc functions much like in OpenOffice Writer. 
 
Finding text or data: 
 

1. Choose Edit->Find & Replace from the Calc menu. 
 

 
 

2. In the Search for box type the text or data you want to search 
for. 

3. Click on the Find button to find the first instance of your search 
term. 

4. Clicking again on the Find button will search through the 
document to find further instances of your search term. 
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Replacing text or data 
 

1. Choose Edit->Find & Replace from the Calc menu. 
2. In the Search for box type the text or data you want to search 

for. 
3. In the Replace with box, type in the text or data you would like 

to replace the search term with. 
4. You can either replace instances of the search term all at once, or 

one at a time.  
 

Sorting data 
 
As much as possible, it is helpful to sort the data you are working with in 
a way that makes sense. For example, you may want to sort rainfall data 
from largest to smallest amount. You may want to sort birth date data 
chronologically. Or you may want to sort name data alphabetically. 
 
To sort data in a Calc worksheet: 
 

1. Highlight the cells that you want to sort. 
 

 
 

2. Choose Data->Sort from the Calc menu. 
3. Select the sort criteria you want to use first, and then choose to 

sort either in ascending or descending order. If you like, set 
further sort criteria. These will be applied in order (e.g. first by 
name, in ascending order alphabetically, then by age, in 
ascending order). 

4.  
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5. View the results. 

 

 
 
 
Formatting cells 
 
You’ve already learned how to format cells for the type of data they 
contain (numerical, date, or text). You can also apply many of the 
formatting options that are available in other applications such as Writer. 
 
As in other applications, the objective of adding formatting is to enhance 
the visual appearance of your documents in order to make them more 
readable and better understood. 
 
Formatting appearance 
 
You can format the appearance of cell contents by applying font choices, 
borders and shading, and alignment. 
 
Font appearance 

 
1. Select the cells you want to format. 
2. From the formatting toolbar, apply the font formatting options 

you want. 
For your precipitation spreadsheet, bold the column headings 
(months). 

 

 
 
Borders and shading 
 
Borders and shading can help make your worksheets more readable by 
providing emphasis to some of your worksheet cells. For example, row 
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and column headings can be shades to set them off from the rest of the 
data. Cells that form a table can be enhanced by placing a border around 
them. 
 
To apply shading: 
 

1. Select the cells you want to shade. 
2. Choose Format->Cells from the Calc menu. 
3. Click on the Background tab. 

 

 
 

4. Choose a background colour for your cells. 
 
To apply borders: 

 
1. Select the cells you want to apply a border to. 
2. Choose Format->Cells from the Calc menu. 
3. Click on the Borders tab. 
4. Choose the line arrangement for borders. The default settings are 

no border, outside border, outside border with horizontal inside 
border, or outside and inside borders. Further, you can set you 
own borders by using the user-defined option. 

5. Choose the line style and colour. 
6. Choose the border spacing. 
7. If you like, include a shadow for your bordered section. 
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Here is what our precipitation worksheet looks like with bold, shading, 
and borders applied: 
 

 
 
Merging cells 
 
You may find that you want to create an area for information that is 
larger than a single cell. Calc gives you the option of merging cells to 
make a larger area. (Please do not confuse it with Mail Merge in Writer) 
The merged cell acts as one cell. 
 
To merge adjacent cells: 
 

1. Select the cells you want to merge. 
2. Choose Format->Merge Cells from the Calc menu. 
3. Place your content into the merged cell. 
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Text wrapping 
 
If the content you want to place in a cell is too long for the cell, you can 
choose to wrap the text so that it will go on to a second line once it 
reaches the full width of the cell. 
 
To wrap text in a cell: 
 

1. Select all the cells that you want the text to break at the right 
border. 

2. Choose Format->Cells from the Calc menu. 
3. Click on the Alignment tab. 
4. Check the box for Wrap text automatically. 

 

 
 
It will look like this: 
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Copying and Moving cells 
 
To copy cells: 
 

1. Select the cells you want to copy. 
2. Choose Edit->Copy from the Calc menu. 
3. Click where you want the cells to be placed. 
4. Choose Edit->Paste from the Calc menu. 

 
To move cells: 
 

1. Select the cells you want to copy. 
2. Choose Edit->Cut from the Calc menu. 
3. Click where you want the cells to be placed. 
4. Choose Edit->Paste from the Calc menu. 

 
Using Autofill 
 
Autofill is useful if you are placing the same content in the cells of a 
column, or when you are placing incremental content (e.g. the months of 
the year) in the cells of a column. 
 
To use Autofill with incremental content: 
 

1. Type the first entry into a cell (for example, January) 

 
 

2. Click somewhere else on the worksheet (click out of the cell). 
Then move your mouse to the bottom-right corner of the cell with 
the data in it, until your cursor turns to a crosshair. 
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3. Hold the mouse button down, and drag down the column to 
complete the Autofill. 
 

 
 
To use Autofill with repeating content: 

 
1. Type the first entry into a cell (for example, January) 

 

 
 
 

2. Click somewhere else on the worksheet (click out of the cell). 
Then move your mouse to the bottom-right corner of the cell with 
the data in it, until your cursor turns to a crosshair. 
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3. While pressing the <Ctrl> key, hold the mouse button down, and 
drag down the column to complete the Autofill. 
 

 
 
 
Working with rows and columns 
 
Earlier you learned how to select a whole row or column by clicking on 
the row headings and column headings. When you select rows or 
columns, any of the formatting options you apply are applied to the whole 
row or column. You can also set the row height and column width to fit 
your data, and insert or delete columns or rows as needed. 
 
Inserting and deleting rows and columns 
 
To insert a row or column: 

 
1. For rows, click on the row heading where you want the new row 

to be created. 
2. Choose Insert->Row from the Calc menu. 
3. The new row is inserted above the row you selected. 
4. For columns the process is the same, using the column heading. 

 
Exercise on the Scenario 
 
On the Vancouver Precipitation spreadsheet, insert a column on the left 
of the worksheet, and add the years 2005, 2006, and 2007. Align the 
values to the left, and bold them. Then, change the border and shading to 
include these values. 
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Delete a row or column 

 
1. For rows, select the row or rows you want to delete. 
2. Choose Edit->Delete cells from the Calc menu. 
3. For columns the process is the same. 

 
Formatting rows and columns 
 
Row height 
 
You can set the height of a row manually by dragging on the bottom of 
the row header, or by using the menu options. The menu options give 
much greater control over the row height: 
 

1. Select the row or rows you want to format. 
2. Choose Format->Row->Height from the menu. 
3. Type in the height you want to set the rows. All of the rows you 

have selected will change to that height. 
 
Column width 

 
1. Select the column or columns you want to format. 
2. Choose Format->Column->Width from the menu. 
3. Type in the width you want to set the column. All of the columns 

you have selected will change to that width. 
 
Working with worksheets 
 
We now move from working with cells, rows, and columns to working 
with worksheets. You can think of a worksheet as the basic functional 
unit of your spreadsheet – it can contain the data from cells, the functions 
that are used to modify the data, and graphs and charts to interpret the 
data. The worksheet can stand on its own as a document. 
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Rename a worksheet 
 
The default names of worksheets are Sheet1, Sheet2, and Sheet3. You 
can change the name of a worksheet as follows: 
 

1. Select the worksheet you wish to rename by clicking on the tab for 
that worksheet. 

2. Choose Format->Sheet->Rename from the Calc menu.. 
3. Enter the new name in the dialogue. 
4. Click OK. 

 

 
 
Switch between worksheets 
 
To switch between the different worksheets, you simply click on the tab 
of the worksheet you wish displayed. 
 
Insert a new worksheet 

 
1. Click on the tab next to the location where you wish to insert the 

new worksheet. 
2. Click Insert->Sheet. This displays the Insert worksheet dialogue. 

 

 
 

 
3. Choose the position before or after the selected sheet. 
4. Choose the number of worksheets you wish to insert. If you choose 

only one sheet, you have the option to enter the name of that sheet 
in the Name window. 

5. Click OK  
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Duplicate a worksheet 
 
You may duplicate a worksheet either within the same spreadsheet or 
between spreadsheets. The other spreadsheet may be one that is already 
open or a new one to be created. In all cases, you will use the Copy 
command to carry out this task. 
 

1. Right-click on the worksheet you wish to duplicate. 
2. Choose Edit->Move/Copy Sheet from the context menu. 

 

 
 
 The Move/Copy Sheet dialogue box appears. 

 

 
 

 
3. If you want to copy the worksheet to a new location, check the 

Copy checkbox. If you want to move the worksheet without making 
a copy, leave it unchecked. 

4. Select the document you want to move/copy the worksheet to. The 
current document is the default choice. 

5. Select the position for the worksheet in the Insert before window. 
6. Click OK. 
7. Rename the duplicate worksheet if you wish.  
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Delete a worksheet 
 

1. Right click on the tab of the worksheet you wish to delete. 
2. Select Delete in the menu that appears. A dialogue will appear 

asking you to confirm that you wish to permanently delete the 
worksheet and its contents. 

3. Click Yes to confirm that you wish to delete the worksheet or 
Cancel if you do not wish to. 

 
Self Assessment 
 
To assess your learning, make sure you are comfortable carrying out the 
following tasks in OpenOffice Calc: 

1. Select a cell, a row, a column, or a group of cells. 
2. Enter data in a cell. 
3. Format the cell for the following: 

• Type of data (numerical, date, text) 
• Font style 
• Alignment 

4. Format cell borders and shading. 
5. Use Find and Replace to replace data in cells. 
6. Sort a group of cells 
7. Merge a group of cells into one cell. 
8. Use Autofill to input content. 
9. Format row height and column width. 
10. Insert and delete rows and columns. 
11. Insert, copy, move and delete a worksheet. 
12. Rename a worksheet. 

 
Summary 
 
In this section you learned some basic skills for working in worksheets, 
including inputting and formatting data in cells and columns, creating, 
deleting, and copying worksheets. 
 
We also discussed some of the choices that should be made before we 
input data. When we answer some basic questions about our data and 
plan our spreadsheet, it makes the process of creating our spreadsheet 
much easier. 
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Formulas and Functions 
 
Section Overview 
 
Formulas and functions are very useful features of spreadsheets. They 
allow you to perform analysis on the data in your spreadsheet. 
Furthermore, when the data changes, the formula updates the results 
accordingly. 
 
A formula is a spreadsheet function entered in a cell, complete with its 
arguments. A function is a formula that is built into the Calc program.  
 
Calc has many built-in functions, but also allows you to create and apply 
your own formulas. This section will guide you through applying and 
creating formulas for your spreadsheets. 
 
In this section you will: 
 
• develop good practice in formula creation 
• create formulas using cell references 
• use arithmetic operators 
• understand standard error values in formula results 
• use standard functions 
• use logical functions 

 
Arithmetic formulas 
 
Arithmetic formulas are formulas that can be carried out on numerical 
data. They include the everyday mathematical formulas such as addition, 
subtraction, multiplication, and division, as well as formulas for finding 
the average, mean and standard deviation. 
 
Creating formulas 
 
In a Calc worksheet, formulas are input into cells the same as other data 
like numbers and text. The difference is that formulas begin with an equal 
sign (=). 
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To input a formula into a cell: 
 

1. Select the cell you want to contain the formula. 
2. Begin with an equal sign. 
3. Type the rest of your formula. For example, =45+55 is a formula 

that can be used in Calc. 
 

 
 
The formula appears in the cell input window, but the formula 
result appears in the cell itself. 

 
Arithmetic operators 
 
The following table lists the common in Calc. These are the symbols that 
should be used for creating formulas. 
 
Operator  Name  Example  
+ (Plus)  Addition  =1+1  
- (Minus)  Subtraction  =2-1  
- (Minus)  Negation  -5  
* (asterisk)  Multiplication  =2*2  
/ (Slash)  Division  =10/5  
 % (Percent)  Percent  15%  
^ (Caret)  Exponentiation  2^3  

 
Using cell references in formulas 
 
In the last example, we input a simple formula into a cell. The formula 
added the numbers 45 and 55 and displayed the results in the cell. 
 
More often we are interested in performing operations on cell contents. 
For example, if the content of one cell was 45, and the content of another 
cell was 55, we would want a formula that added the contents of each 
cell. More importantly, we would want the result to update automatically 
if the contents of either cell changed. 
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We accomplish this by using cell references instead of real numbers in 
formulas. For example, if the contents of cell A1 was 45, and the contents 
of cell A2 was 55, we could write a formula in cell A3 that added A1 and 
A2: 
 

=A1+A2 

  
 
 
Now, if the contents of cell A1 or A2 change, the result in A3 changes 
automatically. 
 

  
 
 
Relative cell references 
 
The cell reference we used in the last example , =A1+A2, is called a 
relative cell reference. What that means is if we were to copy the cell 
contents to cell B3, the formula would change to =B1+B2. If we were to 
copy the formula to cell D5, the formula would change to =D3+D4. 
If we were to insert a new row before row 1, the formula would also 
change automatically to reflect the change in the cell contents. 
 
This is exactly what we want to happen when we are applying the same 
formula to a series of columns or rows. 
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Absolute cell references 
 
There are times when we don’t want the cell references in a formula to 
change when we copy the formula or when we insert cells into a 
worksheet. In this example, we are referencing a constant value that is in 
cell A1in our formula, and we use this same value throughout: 
 

  
 
We can keep the cell reference A1 in our formula if we use an absolute 
cell reference. This involves simply placing a $ in front of the row and 
column part of the reference: A1 becomes $A$1: 
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Functions 
 
Functions are formulas in Calc that are built into the application. 
Typically, functions are more complicated formulas and can save us the 
time of developing our own formula for things such as mean or standard 
deviation. 
Click on the Function Wizard button for a list of Calc functions: 
 

 
 
The list of functions available in Calc is very impressive. They are broken 
into categories so that you can more easily find the function you need. 
Some of the common mathematical functions are: 
 

• ABS –absolute value 
• COS, SIN, TAN – trigonometric functions for cosine, sine, and 

tangent 
• GCD – greatest common divisor 
• LCM – least common multiple 
• LOG – logarithm 
• SUM – calculates the sum 

 
Cell ranges 
 
In a previous example, we used the formula =A1+A2 for a formula in cell 
A3. This is fine for adding a few numbers, but if we are adding a long 
column of numbers it is more useful to reference a cell range than 
individual cells. We reference a range of cells by specifying the starting 
cell and the ending cell, and separating them with a colon. 
So our formula for the last example would become: 

=SUM(A1:A2) 
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Exercise on the Scenario 
 
Use the AVERAGE function in the Vancouver Precipitation spreadsheet 
to calculate the average monthly precipitation for each month over the 
three year period. 
 

 
 
Self Assessment 
 
To assess your learning, make sure you are comfortable carrying out the 
following tasks in OpenOffice Calc: 
 

• Insert a formula in a cell that performs an operation on the 
contents of two or more other cells. 

• Copy the formula to adjacent cells to perform the same operation. 
• Use cell references for creating a formula. 
• Use cell ranges for creating formulas. 
• Use absolute cell references and relative cell references 

appropriately. 
• Insert a function into a cell that performs an operation on two or 

more other cells. 
 
Summary 
 
This section discussed the importance of formulas and functions in 
spreadsheets. You learned how to input formulas and functions to 
perform mathematical operations on the contents of worksheet cells. You 
also learned the difference between relative and absolute cell references 
and how each can be used effectively. 
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Charts and graphs 
 
Section Overview 
 
During this section you will learn how to display worksheet data using a 
chart. Calc automates the creation of charts from data, and like formulas, 
charts automatically update when data changes. 
 
Using the right chart can display your data in a way that makes trends 
obvious, thereby enhancing the quality of your document. 
 
In this section you will: 
 
•  become familiar with the common chart types: column charts, bar 

charts, line charts and pie charts from spreadsheet data 
• create a chart to display information 
• format charts for appearance 
• add data labels to charts 

 
Types of charts 
 
You are likely familiar with the common types of charts: bar chart, pie 
chart, line graph, and scatter plot. Although you can use different charts 
to display the same data, certain types of charts lend themselves better to 
certain types of data: 
 

 

Column (Vertical Bars) charts emphasise 
differences and values across multiple categories. 
 

 

Bar (Horizontal) charts are used to compare 
categories and values during a specified timeframe. 

 

Line charts are to display trends over a particular 
timeframe. 

 

Pie charts are useful for showing relationship 
(percentage) of parts to a whole 

 
Creating charts from cell data 
 
This exercise will guide you through creating a chart to display the data 
in our Vancouver Precipitation spreadsheet scenario. 
 

1. Click on a cell below somewhere below the data in your 
worksheet. This is where the chart you create will be inserted. 

2. Choose Insert->Chart from the Calc menu. This starts the 
Chart Wizard. 
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3. The first step in the Chart Wizard is to choose a chart type. For 
this chart we will choose the Column chart. 
 

 
 
Then click the Next button to go to Step 2 of the Wizard. 
 

4. The second step is to select the data range. 
 

 
 
This is the data we want to display. 

Click on the Select Data Range button to begin.  
 

5. Select the data in from the row containing the average 
precipitation values. In the spreadsheet below, it is the data from 
cell B8 to cell M8. 
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6. Since the data series is part of a row, Data series in rows should 
be selected. Unselect the remaining choices, since the rows and 
columns are not acting as labels. 
 

 
 
Click the Next button to go to Step 3 in the Wizard. 

7. We will now capture the names of the months that go with our 
data. These form the data categories. 

In the Wizard, click on the Select Data Range button for 
Categories.  
 

 
 

8. Select the data in the row containing the names of the months. In 
the worksheet, this is the data from cell B4 to cell M4. 
 

 
 
Click the Next button to go to Step 4 in the Wizard. 
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9. Uncheck the Display legend checkbox, as we will be using the 
names of the months on the chart. 

10. Fill in the values for Title, Subtitle, and X-axis. 
 

 
 

11. Click the Finish button to end the wizard. 
 
Modifying a chart 
 
The chart, as created, is quite small. We can do a number of things to 
modify the chart to make it more readable. 
 
Move the chart to its own worksheet 

 
1. Click on the chart and choose Edit->Cut from the Calc menu. 
2. Click on the tab for Sheet2. 
3. Choose Edit->Paste from the Calc menu to paste the chart. 
4. Rename Sheet2 to Rainfall Chart. 
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Resize the chart 
 

1. Move the chart close to the top-left corner of the worksheet. 
2. Click on the resize handle on the bottom-right corner of the chart 

and drag with your mouse to resize the chart. 
 

 
 
Change chart type 
 
We can change the chart type easily without having to go through the 
Chart Wizard again: 
 

1. Select the chart by double-clicking on it. 
2. Right-click on the chart area. 
3. Choose Chart Type from the context menu. 
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4. Select Bar for the new chart type, and click the OK button. 
 

 
 

5. The chart will update to the new chart type. 
 

 
 
 
Self Assessment 
 
To assess your learning, make sure you are comfortable carrying out the 
following tasks in OpenOffice Calc: 
 

1. Select an appropriate chart type to display your data. 
2. Create a chart from worksheet data. 
3. Edit the chart by adding labels, resizing, and moving it. 
4. Change the chart type. 
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Summary 
 
This section discussed the use of charts in OpenOffice Calc to display 
worksheet data. The proper chart can make our data clearer by providing 
a pictorial representation that more clearly shows trends in data than a 
table or text description. The chart you created in the exercise clearly 
shows a trend in Vancouver precipitation towards very heavy in the 
winter months and relatively light in the summer. 
 
On the practical side, you learned how to insert and modify a chart in 
Calc. 
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Preparing spreadsheets for output 
 
Section Overview 
 
This section discusses the steps you will take in the final preparation and 
printing of your OpenOffice Calc documents.  
 
In this section you will learn how to: 

• Set margins and page orientation. 
• Use headers and footers. 
• Set the print area of your spreadsheet. 
• Print your spreadsheet. 

 
Setting up a worksheet for printing 
 
Worksheet orientation 
 
Worksheet orientation is a style that applies to the whole document. By 
default, when you create a new spreadsheet it is oriented in portrait mode. 
 
You can edit the orientation of your document as follows: 
 
1. Choose Format->Page from the Calc menu. 
2. Click on the Page tab. 
 

 
 

3. Select the size of paper you will be printing on. If you choose one 
of the standard formats from the Format list, the paper size will 
be set automatically. You can also create a custom paper size by 
inputting values for the paper height and width. 

4. Choose Portrait or Landscape for your document's orientation. 
5. Set the margins to the desired width. 
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Headers and Footers 
 
Headers and footers allow you to create text that will appear at the top 
(header) or at the bottom (footer) of every page in your document, or on 
every even or odd page. As you add text to your document, the header 
and footer don't move – they are always at the top and bottom of every 
page.  
 
Examples of common header and footer information include the 
document title, author, date, or page numbers. 
 
Headers 
 
To enable headers: 
 

1. Choose Format->Page from the Calc menu. 
2. Click on the Header tab. 
3. Enable headers by checking the Header on box. 
4. Choose whether you want the same header content on left and 

right pages, or different content on each side. 
5. Set the margins and spacing attributes for your header. 

 

 
 

6. Click on the Edit button to edit the information in the header. 
You can enter text in any of the three header areas, or you can use 
the buttons to insert fields such as the date, time, etc. 
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7. Click OK to close the dialogue. 
8. You will now have a header on your spreadsheet. What you add 

to the header will be displayed on every page of the document, or 
every odd or even page if you so specified, when you send the 
document to print. 
 

Footers 
 
Setting the footer is the same as setting the header. 
 
To enable footers: 
 

1. Choose Format->Page from the Calc menu. 
2. Click on the Footer tab. 
3. Enable headers by checking the Header on box. 
4. Format the footer the same was as for headers. 

 
Printing worksheets 
 
The steps you have gone through prior to printing your document help to 
ensure that your document is as polished and as correct as possible. 
 
You are now almost ready to send your document to print. As a final step, 
you should preview what your document will look like when it's printed 
to make sure that pagination, margins, and formatting appear correctly. 
 
To preview your document: 
 

1. Choose File->Page Preview from the Calc menu. 
2. Scroll through your document to view the pages as they will look 

when printed. 
 
Setting the print area 

 
1. With your mouse, select the area of the worksheet you want 

printed. 
2. Choose Format->Print Ranges->Add to add your selection to 

the print area. 
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Printing 
 
To print your document: 
 

1. Choose File->Print from the Calc menu. 
3. Choose your printer and adjust the printer properties if necessary. 

Some printer properties are specific depending on the type of 
printer you are using. For example, you may need to set 
properties for your printer if you are printing in high quality 
colour. 

4. Choose the pages you would like printed (by default the complete 
document is printed). 

5. Choose the number of copies you want to print (by default one 
copy is printed). 

6. Click on the OK button to print your document. 
 

 
 
Self Assessment 
 
To assess your learning, make sure you are comfortable carrying out the 
following tasks in OpenOffice Calc: 
 

1. Set the print area of your worksheet. 
2. Set the page options, including margins, paper size, and 

orientation. 
3. Enable headers and footers and add content to each. 
4. Preview the document before printing. 
5. Print your document. 

 
Summary 
 
This section outlined the options for setting your document up for 
printing. We discussed document formatting techniques such as setting 
margins, orientation, footers and headers. 
 
Finally, this section outlined the process for previewing and printing your 
document. 
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