2D ANIMATION
Graphics and advertising (Practical)

Diploma in Multimedia and Animation (DMA)
2D Animation
Block – III: Graphics & Advertising (Practical)
2D Animation

This course has been developed with the support of the Commonwealth of Learning (COL). COL is an intergovernmental organisation created by Commonwealth Heads of Government to promote the development and sharing of open learning and distance education knowledge, resources and technologies.

Odisha State Open University, Sambalpur (OSOU) is the first Open and Distance learning institution in the State of Odisha, where students can pursue their studies through Open and Distance Learning (ODL) methodologies. Degrees, Diplomas, or Certificates awarded by OSOU are treated as equivalent to the degrees, diplomas, or certificates awarded by other national universities in India by the University Grants Commission.

© 2018 by the Commonwealth of Learning and Odisha State Open University. Except where otherwise noted, 2D Animation is made available under Creative Commons Attribution-ShareAlike 4.0 International (CC BY-SA 4.0) License: https://creativecommons.org/licenses/by-sa/4.0/legalcode

For the avoidance of doubt, by applying this license the Commonwealth of Learning does not waive any privileges or immunities from claims that it may be entitled to assert, nor does the Commonwealth of Learning submit itself to the jurisdiction, courts, legal processes or laws of any jurisdiction. The ideas and opinions expressed in this publication are those of the author/s; they are not necessarily those of Commonwealth of Learning and do not commit the organisation.
Acknowledgements

The Odisha State Open University and COL, Canada wishes to thank those Resource Persons below for their contribution to this DMA-03:

Concept / Advisor

Dr. Srikant Mohapatra
Vice-Chancellor
Odisha State Open University, Sambalpur

Course Writer

Ramyaranjan Tripathy
Senior Graphic Artist, News World Odisha Television, Bhubaneswar

Course Editor

Dr. A Bijaya Bishnu
Associate Professor, English, BJB (Auto) College, Bhubaneswar
Prateek Das
Centre Head, Om Animations and Graphics Institute, Cuttack
Olive Ashish Munda
Teaches 3D Animation, Om Animations and Graphics Institute, Cuttack

Video Production

R. Mohana Sundaram
Creative Director
Jai Ram Institute of Visual Academy, Khurda, Odisha
Guest Faculty, National Institute of Fashion Technology (NIFT), Bhubaneswar
Biranchi Prasad Sahoo
Freelance Graphic Designer
Prateek Das, Centre Head, Om Animations and Graphics Institute, Cuttack
Olive Ashish Munda,
Teaches 3D Animation, Om Animations and Graphics Institute, Cuttack

Published by:

Dr. Jayanta Kar Sharma
Registrar on behalf of Odisha State Open University, Sambalpur

Contribution of following staff members of Odisha State Open University is acknowledged:

- Jyoti Prakash Mohapatra
- Sambit Mishra
- Debidatta Behera
- Prashansa Das
- Radhakanta Suna
- Abhinandan Tripathy

OSOU and COL acknowledge the support extended by Prof. Madhu Parhar, STRIDE, IGNOU, New Delhi in conducting several workshops in the process of preparation of course material for DMA.
Contents

Course Overview 5
Welcome to Graphics & Advertising (Practical) ........................................ 5
Digital Layout Creation ........................................................................ 5
Professional Image Editing ................................................................. 5
Advertising & Graphics .................................................................... 6
Vector Composition & 2D Animation .................................................. 6
Course outcomes .............................................................................. 7
Timeframe ......................................................................................... 7
Study skills ....................................................................................... 7
Need help? ....................................................................................... 8
Assignments ..................................................................................... 8
Assessments ...................................................................................... 8
Video Resources .............................................................................. 9

Getting around this course material 10
Margin icons .................................................................................... 10

Unit 1 11
Digital Layout Creation ..................................................................... 11
Introduction ..................................................................................... 11
Outcomes ......................................................................................... 11
Terminology ...................................................................................... 11
GIMP Installation ........................................................................... 12
GIMP – Main Window ..................................................................... 12
GIMP Basics ................................................................................. 13
Keyboard Shortcuts for Rectangle Regions ................................. 17
Summary ........................................................................................ 43
Assignments ................................................................................... 43
Resources ....................................................................................... 43

Unit 2 44
Professional Image Editing ................................................................. 44
Introduction ..................................................................................... 44
Outcomes ......................................................................................... 45
Terminology ...................................................................................... 45
Colour Tool ....................................................................................... 46
Colour .............................................................................................. 51
1. Blur filters ................................................................................... 59
2. Noise filter .................................................................................. 62
3. Edge detect filters ................................................................. 65
4. Enhance filters ................................................................. 66
5. Generic filters ................................................................. 68
6. Glass Effects filters ............................................................ 70
7. Light Effects filters ............................................................ 71
8. Distort filters ................................................................. 72
9. Artistic Filters ................................................................. 75
10. Map filters ................................................................. 76
11. Rendering filters ............................................................. 79
12. Combine filters ............................................................... 81
Unit Summary ........................................................................ 82
Assessment ........................................................................... 82
Resources ............................................................................... 82

Unit 3 .................................................................................. 83

Advertising and Illustration ....................................................... 83
Introduction ............................................................................ 83
Outcomes ............................................................................. 83
Terminology .......................................................................... 84
Pixlr Editor ........................................................................... 84
Getting Started ...................................................................... 85
Cropping an Image ................................................................ 86
Resizing an Image .................................................................. 87
Rotating an Image .................................................................. 88
How to save an Image ........................................................... 89
Working with Layers .............................................................. 90
Adding Text in a new layer ....................................................... 91
Using layers to make a composite image ................................ 92
Advanced Techniques ............................................................ 94
Using Gaussian Blur to remove the Moire effect ......................... 94
Adjusting hue, saturation ......................................................... 95
Adjusting the levels manually .................................................. 96
Using the colour curves to modify an image ............................. 97
Removing a background to create a Transparent Image .............. 99
Pixlr Express ......................................................................... 101
Unit Summary ........................................................................ 103
Assignment ............................................................................ 103
Resources ............................................................................... 104

Unit 4 .................................................................................. 105

Vector Composition & 2D Animation ....................................... 105
Introduction ............................................................................ 105
Outcomes ............................................................................. 105
Terminology .......................................................................... 106
Course Overview

Welcome to Graphics & Advertising (Practical)

In this block, you are going to study about the Graphics and Advertising Practical. Before setting your hands into the practical, you have to learn about the theoretical aspects of 2D graphics. There are some common ingredients for a successful 2D design. For creating creative advertising and graphics layout creation and vector composition is very necessary.

Digital Layout Creation

This course is intended for people who want to create perfect design layouts. A good design stands on the elements of design which are being used by the designers for ages, in organised as well as unorganised manner. After lots of experimentations, some common design elements have been derived which make the output meaningful and attractive. In this unit, you are going to learn about each element in elaborate manner.

Professional Image Editing

This course is intended for people who want to be perfect image editors. Image editing is at the heart of creative photographic printing – it is where you transform a well-crafted snapshot into a work of art. One reason you need to edit is that a print can rarely capture the tonal range of an actual scene, particularly a naturally illuminated landscape.
Advertising & Graphics

This course is intended for people who want to use Image Editing for advertising. Preparing Graphics through Pixlr is very easy with PCs and smart phones. Using advance techniques such as auto levels, Gaussian blur to remove moiré effect, adjusting hue and saturation; colour curves to modify an image make the designer and animator smarter.

Vector Composition & 2D Animation

This course is intended for people who want to become vector graphic designers & 2D animators. 2D animation, which is also called frame-by-frame animation, is created by drawing images or frames one-by-one. The more frames that an animator draws the better will be the illusion of movement.

This video will provide a brief overview of this course.

<table>
<thead>
<tr>
<th>Topic</th>
<th>YouTube link</th>
<th>QR Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Video 1 – Understanding 2D Animation software</td>
<td><a href="https://youtu.be/JQt57cRF8s">https://youtu.be/JQt57cRF8s</a></td>
<td></td>
</tr>
<tr>
<td>Video 3 – Environment texturing Technique</td>
<td><a href="https://youtu.be/g4Ky3mKkccU">https://youtu.be/g4Ky3mKkccU</a></td>
<td></td>
</tr>
</tbody>
</table>
Course outcomes

Upon completion of preproduction you will be able to:

- Describe about the basics of GIMP open source free image editor
- Identify and learn to use various tools like colour tools and filters using GIMP
- Learn about the fundamental techniques to animate and revive any picture
- Understand the process of adding colours, linking and animation basics.

Timeframe

This course will be completed within “4” classes.
This course is of “1” credit.
8 hours of study time is required for this unit.

Study skills

This is a combination of theory and practical. Hence, you should have access to a personal computer or personal laptop for better understanding of this unit.

Each and every option is explained step by step in the course material.

Apart from this course material, the learner needs to adopt the tendency of learning from multiple sources i.e.; Internet tutorials.
Course Overview

Video tutorials on YouTube
Collaboration with people working in the industry etc.
Only classroom study will not make you a professional. You have to be active to grab the opportunity of learning wherever you get a chance.

Need help?

In case you need any help, you can browse the internet sites such as youtube.com for video tutorials about the subject.

Assignments

There will be some assignments at the end of each unit.
These assignments are mostly practical based and should be submitted in CDs or DVDs. Theoretical assignments are to be submitted written on A4-size sheets.
All assignments will be submitted to respective study centres of the Odisha State Open University or as directed by the co-ordinator.
All assignments should be unit wise on separate CD/DVDs clearly mentioning course title and unit on the top. Theoretical assignment will be neatly filed or spiral bind with cover mentioning necessary information of course, student detain on top.

Assessments

There will be “1” assessment for each unit.
All practical assessments will be submitted to the OSOU.
Assessment will take place once at the end of each unit.
Learner will be allowed to complete the assessment within stipulated time frame given by the university.
Video Resources

This study material comes with additional online resources in the form of videos. As videos put in human element to e-learning at the same time demonstrating the concepts visually also improves the overall learning experience.

You can download any QR code reader from Google Play to view the videos embedded in the course or type the URL on a web browser.
Getting around this course material

Margin icons

While working through this course material, you will notice the frequent use of margin icons. These icons serve to “signpost” a particular piece of text, a new task or change in activity; they have been included to help you find your way around this course material.

A complete icon set is shown below. We suggest that you familiarize yourself with the icons and their meaning before starting your study.

<table>
<thead>
<tr>
<th>Activity</th>
<th>Assessment</th>
<th>Assignment</th>
<th>Case study</th>
</tr>
</thead>
<tbody>
<tr>
<td>Discussion</td>
<td>Group activity</td>
<td>Help</td>
<td>Note it!</td>
</tr>
<tr>
<td>Outcomes</td>
<td>Reading</td>
<td>Reflection</td>
<td>Study skills</td>
</tr>
<tr>
<td>Summary</td>
<td>Terminology</td>
<td>Time</td>
<td>Tip</td>
</tr>
</tbody>
</table>
Unit-1

Digital Layout Creation

Introduction

GIMP is software that is freely available and is meant for editing images and correcting colors. It is available for GNU/Linux, Windows, OS X, and other operating systems. Whether you are a graphic designer, an image editor, an illustrator, or a scientist, GIMP provides sophisticated tools and filters to aid in graphic designing, illustrations, scientific application and image editing tasks. Productivity of GIMP can be supplemented with various customization options using 3rd party plug-ins. The instructions for GIMP have been sourced from its documentation that has been accessed under GNU Free Documentation License.

Outcomes

Upon completion of this unit you will be able to:

- The basics of GIMP open source free image editor
- The use of various tools and functions associated with GIMP
- Various shortcut keys for ease of image editing

Terminology

**RGB:** Red, Green, Blue – Primary Colour

**Rectangle tool:** Rectangle selection tool is used to choose rectangular regions of an image or a picture.

**Ellipse Tool:** Ellipse Selection tool is used to create circular or elliptical regions from an image.

**Fuzzy selection Tool:** Fuzzy Select (also known as Magic Wand) tool is used to selection regions of the image based on similarity in color.
Path Tool: Paths tool allows for the creation of complex regions called Benzier Curves.

GIMP Installation

The GIMP software may be installed from their official website- [https://www.gimp.org/downloads/](https://www.gimp.org/downloads/)

Select the Current Stable Version-

The current stable release of GIMP is 2.8.22 (2017-05-11). Download the official GIMP installer for Windows (approx. 100MB) by clicking on the above link. The installer contains both 32-bit and 64-bit versions of GIMP. The appropriate version shall be automatically installed.

GIMP – Main Window

![Screenshot](image.png)

Screenshot

The above screenshot shows the Main window of GIMP. The various sub-windows available in the main windows are listed below:

Main Toolbox, Tool options, Image window, Layers dialog, and Brush/Pattern/Gradient

Image Window-

Image Window of GIMP helps with the editing of multiple images at the same time. Each image is shown in its own separate window.
The following tools/functions are available-

a. Title Bar
b. Image menu
c. Menu button
d. Ruler Quick Mask Toggles
e. Pointer co-ordinates,
f. Unit menus
g. Zoom button
h. Status area
i. Cancel Button
j. Navigation control
k. Inactive peddling area
l. Image display
m. Image window resize toggle

**GIMP Basics**

**GIMP Image**

GIMP image format contains many layers also includes several objects such as a selection mask, sets of channels and paths, undo history etc. making it complicated.

There can be three possible modes to define an image:

a. RGB
b. Grey scale
c. Indexed

In GIMP, each Colour channel includes the alpha channel (which represents the opacity) with a range from 0 to 255.

**Creation of New Files**

New files can be created by navigating to File → New

In the popup window, the initial width and height of the files can be defined.

**Opening Files**

Navigate to File → Open from Toolbox menu. Browse and open the required file from this window.
An image can also be opened by choosing the file URL or web address. Click File, open Location from Toolbox menu or Image menu and enter the image URL.

Some images can be simply copied and pasted by clicking on File→Acquire → Paste as New from toolbox Menu.

**Saving Files**
GIMP allows saving the image with all layers in a format which is known as XCF format. It is allowed only in Native XCF format. In other formats, it does not store all the data with all its layers and properties in a GIMP image. XCF format is GIMP default format which can save data with all its properties. Saving a file is available in several types of formats. The easiest way to save a file is to go to File and save it.

**Main Toolbox**

The main tool box is shown in the figure on the right. The various tools available in the main tool box are as listed below -

- Rectangle selection tool
- Ellipse tool
- Free select tool/lasso
- Fuzzy selection tool
- Select by colour
- Scissors
- Foreground
- Path tool
- Colour picker tool
- Zoom tool
- Measure tool
- Move tool
- Alignment tool
- Crop tool
- Rotate tool
- Scale tool
- Shear tool
- Prospective tool
- Flip tool
- Cage transform/deform tool
- Text tool

To demonstrate the use of the tools, we have taken the example of India Gate
Title-India gate
Source- inspiretourism.com
Link- http://www.inspiretourism.com/?s=delhi

Rectangle Tool

Rectangle Selection tool is used to choose rectangular regions of an image or a picture. It is a basic yet useful selection tool. It is also used to produce a rectangle or square selection on an image to be filled or modified using other types of Tools.
Keyboard Shortcuts for Rectangle Regions

**Ctrl Key:** Click and hold down the left mouse button. Then press down the Ctrl key until the rectangle is created. The starting point will be used as the centre of the rectangle.

**Shift Key:** Click and hold down the left mouse button. Then press down the Shift key until a square is created.

**Ctrl + Shift Keys:** Click and hold down the left mouse button. Pressing both keys together combines the two effects given above, giving a square with its centre at the starting point.

**Activating Tool:** Rectangle Selection Tool can be accessed in different ways:
- Click on the Rectangle tool icon in toolbox
- Use the keyboard shortcut R or
- Go to the ‘Tools’ menu, hover over ‘Selection Tools’ and click on ‘Rectangle Select’

**Ellipse Tool**

Ellipse Selection tool is used to choose circular or elliptical regions from an image, with high-quality antialiasing if needed. It can produce a circular or elliptical region on an image and then fill it using the Bucket Fill Tool.

**Activating tool**

Ellipse Selection Tool can be activated in three different ways:
- First click on the Ellipse tool icon in toolbox.
- Use the keyboard shortcut E.
- Go to the ‘Tools’ menu, hover over ‘Selection Tools’, and click on ‘Ellipse Select’.

![Screenshot](image.png)
Keyboard Modifiers

**Ctrl Key:** Click and hold down the left mouse button. Now press the Ctrl key until the ellipse has been created. The starting point is used as the centre of the selected ellipse.

**Shift Key:** Click and hold down the left mouse button. Now press the Shift key until the ellipse has been created. Holding Shift creates a circle instead of an ellipse.

**Ctrl+Shift Keys:**
Click and hold down the left mouse button. Pressing both keys together will combine the two effects, giving a circular selection centred at the starting point.

Free Selection Tool or Lasso
Free Selection tool or Lasso helps create a selection by clicking around an object (any part of the image). The Lasso is best used for outlining a selection. However, it is not precise. The practice image is in the folder Toolbox/Free Select Tool. Most users find the Lasso tool convenient to begin with, but then swiftly move on to Quick Mask mode to get an accurate selection. (You will learn more about Quick Mask later).

Activating tool
This tool can be activated in several ways as listed below -
- Click on the Lasso tool icon in toolbox;
- Use the keyboard shortcut F;

Go to the ‘Tools’ menu, hover over ‘Selection Tools’, and click on ‘Free Select’
Tool handling

When you click around an area with the Lasso tool, each anchor point will change colour briefly. When you hover over the first point again, it will change its colour. Click on it and the selection will be created automatically.

Alternatively, when you hold down the left mouse button, the lasso becomes a free-hand tool and enables you to draw a selection. To delete the selection, navigate to the ‘Select’ menu and click ‘None’.

Fuzzy Selection Tool

Fuzzy Select (also known as Magic Wand) tool takes colour similarities into account to select areas of the image. The Magic Wand works well when the objects have sharp edges. It works best for selection of a solid-coloured (or nearly solid-coloured) background area. As the selected area expands outwards from the centre, it spreads to pixels that are connected to each other by jumping over small gaps, depending on the Threshold option number selected.

To increase or decrease the threshold, drag the pointer downward (or to the right) or upward (or to the left) after the first click. The further you drag the mouse, the larger the selected region will
become. You can reduce the selection region by dragging upwards or to the left. The Fuzzy Tool starts selecting as you click at a spot on the image and go outwards, thereby selecting colours which are same or similar to the initial colour.

**Screenshot**

**Select By Colour Tool**

This tool is used when you need to select areas of an image based on colour similarity. It works mostly like the Fuzzy Select tool (‘Magic Wand’).

**Screenshot**

The main thing that differentiates the two tools is that the Magic Wand selects adjacent regions with similar colours where all colours are connected to the starting point, but having no large colour barriers. Recall that the objects of separate colours prevent
the Magic Wand from spreading everywhere in the Fuzzy Tool lessons.

On the other hand, the Select by Colour tool selects all pixels that are sufficiently similar in colour to the pixel clicked on, regardless of where they are located.

In case of Fuzzy Tool, the selection starts once clicked with the reference being the first clicked colour. With the Select by Colour tool you can change the threshold by dragging across the image in the same way as with the Fuzzy Tool.

**Activating Tool**

The ‘Select by Colour’ tool can be accessed in several ways as listed below

- From the image menu, Bar Tools then Selection Tools then By Colour Select
- Using the keyboard shortcut Shift +O

**Scissors Select Tool**

![Screenshot](image.png)

The Intelligent Scissors tool has an interesting function. It has some features in common with the both Lasso and the Path Tool while having some features of its own. If you are trying to select a region defined by strong colour-changes at the edges, this can be very useful. To use the Scissors, you need to create a set of
"control nodes", also referred to as anchors or control points, at the edges of the region you are trying to select. The tool produces a continuous curve passing through these control nodes, following any high-contrast edges it can find. With some luck, the path that the tool finds will correspond to the contour you are trying to select.

However, the edge-following logic for this tool results in the selection being pretty crude in many cases. A good way to clean them up is to switch to Quick Mask mode and use paint tools to paint the problematic areas.

Overall, Path tool is more useful than the Intelligent Scissors tool as the paths it produces are retained until you delete them and can be altered at any time.

Activating tool

From the image menu, go to Bar Tools, then Selection Tools, then Scissors or you may use the keyboard shortcut I.

Foreground Select Tool

Screenshot

This tool allows extraction of the foreground from the active layer or from a selection.
Activating Tool

Clicking on the tool icon in the Toolbox through Tools> Selection Tools> Foreground Select in the image menu.

Key modifiers

Ctrl- By pressing the Ctrl key, you can switch between foreground and background selection painting.

Path Tool

Path tool allows for the creation of complex regions called Bézier Curves. It is similar to Lasso but has the adaptability of vectorial curves. You can edit your curve; you can paint with your curve or even save, import and export the curve. Paths can also be used to create geometrical figures. These paths have their own dialog box.

Activating Tool

In the image menu through Tools then Paths or by using the keyboard shortcut B

Key modifiers

Shift

This key has several functions depending on the context. See Options for more details.

Ctrl; Alt

Three modes are available to work with the Paths tool: Design, Edit and Move.
Ctrl key toggles between Design and Edit. Alt (or Ctrl+Alt) key toggles between Design and Move.

**Colour Picker Tool**

Colour Picker Tool, as the name suggests, is used to pick or select a colour from the screen. By clicking on an image, you can change the foreground colour or background colour to the colour that you have selected. To test this tool we will load a sample image. Go to Toolbox/Colour Picker folder and load carnations.jpg.

**Colour Picker Options**

Tool options are displayed in a window attached under toolbox the moment a tool is activated.

![Screenshot](image)

**Zoom Tool**

Open a new image that you want to zoom. A magnifying glass with a ‘+’ sign will appear on the image. The default action is to ‘Enlarge’ the image. This means with each left click of the mouse the image gets bigger.
To enlarge a specific area, simply click on that spot in the image. It can also be done by drawing around the area with the zoom tool. The image can be shrunk by holding down the Ctrl key and clicking the left mouse button. When you press Ctrl after selecting the Zoom tool a minus sign will appear inside the magnifying glass. You can also see the size of the image in pixels and the percentage of enlargement at the lower left part of the screen.

**Screenshot**

**Measure Tool**

The Measure Tool is used to measure pixel distances in the image. By clicking and holding the left mouse button, you can determine the angle and number of pixels between the point where you click and the place where the mouse pointer is subsequently located.
The Move Tool is used to move the image, layers, regions or guides along with text.

You should make it a habit to use this tool as it prevents the accidental use of a tool which may then corrupt the image.

**Activate Move Tool**

The Move Tool can be activated in the following ways:

- Click on the 'Move' Tool icon in the 'Toolbox'.
- Press keyboard shortcut M.
- Go to the 'Tools' menu, hover over 'Transform Tools' and select 'Move'.

**Key modifiers for the Move Tool**

Alt Key: This key should be used to move regions or layers without altering the image. Only the frame is moved and not the contents.

**Using Arrow Keys:**

Arrow keys can be used to move the active layer by one pixel, instead of using the mouse. Pressing Shift and the arrow key, moves it by 25 pixels.

**Alignment Tool**

The Align tool is used for aligning the image layers with various image objects. When this tool is selected, the mouse pointer turns
into a small hand. By clicking on an element of a layer in the image, you can choose the layer which is required to be moved (with Shift + click, you can choose several layers to be aligned). This focalized layer has small squares in the corners. Several buttons in the dialog allow you to select the mode in which the layer will be moved. You can also select the image, an object (other layer, selection, and path) the selected layer to which other layers is required to be aligned on. This object is called Target.

**Screenshot**

**Activating the Tool**

You can activate the Align tool in several ways as listed below:

- From the image-menu, through Tools, Transform Tools, to Align

By using the keyboard shortcut Q.

**Crop Tool**

**Screenshot**
The Crop Tool is used to crop or clip an image or layer. This tool is often used to get a more focused working area, by removing the borders or unwanted areas. It can also be used if you need a specific image size that is different from the dimensions of your original image. To use the Crop Tool, click inside the image and drag a rectangular region before releasing the left mouse button. When you click, a dialog pops up showing you the dimensions of the cropped region and allows you to perform various actions. If you want to change the region, you can do so either by clicking and dragging the corners or by altering the values in the dialog box. When you are done, you can crop your image by clicking inside the crop region or by pressing the Crop or Resize buttons in the dialog box.

**Activating Tool**

The Crop Tool can be called from the image-menu: Tools Transform Tools Crop and Resize

**Rotate Tool**

The Rotate Tool: To Level the Horizon.

Navigate to toolbox/Rotate Tool folder. Select an image. Select the Rotate tool depicted by two blue rectangles.
Set Clipping to 'Crop to Result'. Set Guides to 'Number of Lines'. Then gently drag the image up, from the right corner, to rotate it until the image horizon is between two guidelines. When the horizon is aligned, click 'Rotate' to create a horizontal horizon. The Rotate tool will crop the image automatically.

**Scale tool**

The Scale Tool is used to scale layers, regions or paths. When you click on the image using the tool, the Scaling Information dialog box is opened, allowing you to change dimensions of the image separately. At the same time a Preview with a grid or an outline is superimposed on the object and handles appear on corners of the image which you can click on and drag to change the width and height. A small circle appears at the centre of the Preview allowing us to move this preview.

**Activating tool**

The Scale Tool can be called in the following order, from the image-menu: Tools -Transform Tools-Scale or by using the Shift T key combination.

**Screenshot**

**Shear Tool**

Shear tool is used to tilt an image. For example, the upper part of the image may be tilted to the left and the bottom tilted to
the right. The image is not rotated (as with the Rotation tool) but deformed. See the example image below. Shear tool may also be used to distort a layer, a selection, or a path.

Shear dialog box

Shear magnitude X - Tilt the image to the left or to the right (horizontal movement). Positive numbers create a clockwise tilt. Negative numbers create a counter-clockwise tilt. The unit of measurement is half-pixels.

Shear magnitude Y - Tilt the image up or down (vertical movement). Of course, we can set X and Y dialog to create the complete Shear effect without activating tool twice.

Activating tool

Click on the Shear icon in toolbox. Keyboard shortcut: Shift+S or go to Tools menu, hover over 'Transform Tools' and select 'Shear'.

Perspective Tool

Perspective Tool is used to change the position or angle of a part or whole image: Leaning buildings, monuments, pillars, etc. can all be corrected.

Select an image. Click on the image and a rectangular frame or a grid pops up around the image with a handle on each of the four corners. By moving these handles, using click-and-drag motion we can change the perspective. At the same time, a ‘Perspective’ box pops up seeking
agreement to the transformation. At the centre of the grid, a circle also allows movement of the image by click-and-drag.

**Screenshot**

**Flip tool**

This tool flips layers or regions either horizontally or vertically. When a selection is flipped, a new layer with a Floating Selection is created. This tool can also be used to create reflections.

**Screenshot**

**Activating tool:** Click the Flip tool icon in toolbox. Use the ShiftF keys. Go to tools menu, hover over Transform Tools and select 'Flip'.
Key modifiers

**Ctrl Key:** Ctrl allows toggling the modes between horizontal and vertical flipping.

**Flip Type:**
This setting controls flipping in either horizontal or vertical direction. This tool can also be switched by using the Ctrl key modifier.

**Flip Tool Actions:**
The ‘Horizontal flip’ is very simple: Click on the ‘Flip’ tool, select ‘Horizontal’ from the ‘Flip type’ and click on the image. The image will flip horizontally.

**Cage Transform/Deform Tool**

Cage tool is a special transformational tool that allows us to select the transforming area by setting anchor points by free hand drawing, similar to the free selection-Lasso tool.

**Activating Tool** - From the image menu, go to Tools, then Transform Tools, then Cage transform
Text Tool

A text item created using the Text tool can be transformed into a path using the Create path from text button in the Tool Options for the Text tool. It can be used for converting text into a path, then transforming the path and finally either stroking the path or converting it to a selection and filling it. This action often leads to much higher-quality results than rendering a text as a layer and transforming the pixel data.

Bucket Fill Tool

This tool fills a selection with the current foreground colour. If you Shift+click and use the Bucket tool, it will use the background colour instead. Depending on how the tool options are set, the Bucket Fill tool will either fill the entire selection or only parts whose colours are similar to the point you click on. The tool options also affect the way transparency is handled.

The amount of fill depends on the Fill Threshold specifications provided. The Fill Threshold determines how far the fill will spread (similar to the way in which the magic wand works). The fill starts at the point where you click and spreads outward until the colour or alpha value does not apply any more.

Activating tool

The Bucket Fill can be called as follows:
From the image-menu: Tools ➔ Paint Tools ➔ Bucket Fill
Blend Tool/Gradient Tool

Blend/Gradient tool fills the selected area with a gradient blend of the foreground and background colours by default, but there are many options. To use the blend, drag the cursor in the direction you want the gradient to go and release the mouse button when you feel you have the right position and size of your blend.

Activating Tool

The Blend Tool can be called in the following order:
From the image-menu: Tools ➔ Paint Tools ➔ Blend
Pencil Tool

The Pencil tool is used to draw free hand lines with a hard edge. The pencil and paintbrush are similar tools.

Activating Tool

The Pencil Tool can be called in the following order:
From the image-menu: Tools ➔ Paint Tools ➔ Pencil or clicking N keyboard shortcut

Paintbrush Tool

The paintbrush tool is used to paint fuzzy (soft) or hard (sharp edged) brush strokes. All strokes are rendered using the current brush. The size of a brush is adjustable. The Paintbrush is the tool used while employing the Quick Mask. It can also be used to paint on images, regions or layers.

Activating tool

The Paintbrush Tool can be called upon in the following ways:
- Click the Paintbrush icon in toolbox;
- Use the P keyboard shortcut;
- Navigate to 'Tools' menu, hover over 'Paint Tools' and select 'Paintbrush'.

Key modifiers

Ctrl Key: Changes the paintbrush to a Colour Picker.
**Shift Key:** Pressing the Shift key places the paintbrush into straight line mode. Holding Shift key, left click the mouse will create a straight line. Consecutive clicks will continue drawing straight lines that originate from the end of the previous line.

**Paintbrush tool options:** Tool options are displayed in a window attached under toolbox as soon as a tool is activated: Mode; Opacity; Brush; Dynamics; Dynamics Options; Apply Jitter; Smooth Stroke; Incremental

**Erase Tool**

Eraser tool is used to delete anything in the image.
In case of over-deletion, you can press Ctrl+Z to recover lost areas of the image. Instead of painting with the eraser, it is advised to work click by click. You can recover the deleted areas by using Ctrl+Z. This will reverse one click at a time.

**Airbrush tool**

This tool is used to paint soft areas of colour. While it mostly works just like the paintbrush, it offers with a lighter touch. With multiple clicks, the Airbrush darkens the flow of paint.

**Activating tool**

Airbrush tool may be activated in several ways:

- Click on the Airbrush icon in toolbox
- Use the A keyboard shortcut
- Go to the 'Tools menu', hover over 'Paint Tools', select 'Airbrush'

**Ctrl Key:** It changes the airbrush to a Colour Picker. Choose the colour for the airbrush from the image and paint over the area of the image required to be enhanced.

**Shift Key:** It changes the airbrush to straight line mode. Hold down the Shift key and left click the mouse. Release the left button of the mouse and move the mouse across the image and click again. A straight line of multiple images could be seen.
Tool options: These are displayed in a window attached under Toolbox as soon as a tool is activated. See image above.

Rate: The Rate slider adjusts the speed of colour application. A higher setting produces darker brush strokes in a shorter amount of time.

Flow: This slider controls the amount of colour that the airbrush paints. A higher setting here will result in darker strokes.

Ink Tool

The Ink tool simulates an ink pen with a controllable nib to paint solid brush strokes with an anti-aliased edge. The size, shape and angle of the nib can be set to determine how the strokes need to be rendered.

Activating the Tool

In the Image menu navigate to Tools then Paint Tools then Ink or by using the K keyboard shortcut.

Clone Tool

The Clone tool uses a 'brush' to copy from an image. It is used to repair problem areas in digital images, by 'painting over' them with stuff copied from other areas. Hold down Ctrl key while selecting the source, if cloning from an image.
Heal tool is used for removal of wrinkles, lines and fixing of discoloured spots in portrait image graphs. Areas of the image are not simply copied, but the area around the wrinkle, line or spot is assessed and reproduced before the healing process begins.

First load an image. Then, set up Heal tool as shown above. All other settings can remain untouched (default). To use the Heal tool, you need to first set a brush size slightly larger than the flaw on the skin. You can zoom in to the image for easy viewing.
Hold down the Ctrl key and click on a perfect area of the skin which is close to the flaw. Release the Ctrl key and drag the Heal tool to the flaw. Left click on the mouse. If the defect is slight and not very different from its surrounding skin, it will get corrected quickly. Painting with the heal tool is possible if the brushing is confined to a small area.

**Blur/Sharpen Tool**

The Blur/Sharpen tool uses the current brush to locally blur or sharpen your image. Blurring with it can be useful if some image elements stand out too much and you would like to soften it. If you want to blur a whole layer or a large part, it is probably better using one of the Blur Filters. The direction of a brushstroke has no effect. If you want directional blurring, use the Smudge tool.

The “Sharpen” mode works by increasing the contrast where the brush is applied. A little bit of this may be useful, but over-application will produce noise. Some of the Enhancement Filters, particularly the unsharp Mask, do a much cleaner job of sharpening areas of a layer.

**Activating the Tool**

From the image-menu: Tools → Paint tools → Blur/Sharpen OR by using the keyboard shortcut Shift+U.

**Key modifiers**

**Ctrl**

Holding down the Ctrl key toggles between Blur and Sharpen modes; it reverses the setting shown in the Tool Options.
Smudge Tool

The Smudge tool uses the current brush to smudge colours on the active layer or a selection. It picks colour while moving the brush and uses it to mix it to the colours it meets next.

Activating tool

The Smudge tool can be activated in several ways as listed below:
- Click on the Smudge tool icon in toolbox.
- Hit the S key on keyboard.
- Navigate to the Tools menu, hover over 'Paint Tools', select 'Smudge'.

Key modifiers

**Shift Key** - The **Shift** key places the smudge tool into straight line mode. Holding **Shift** while holding the left click on the mouse will smudge in a straight line. Consecutive clicks will continue smudging in straight lines that originate from the end of the last line.

**Ctrl Key** - Using **Ctrl** with **Shift**, constrains the angle between two successive lines to vary by steps of 15°.
Dodge/Burn Tool

The Dodge or Burn tool uses the current brush to darken or lighten the colours in your image. The mode will determine the types of pixels that will be affected.

Activating Tool

From the Image menu: Tools → Paint Tools → Dodge / Burn. The Tool can also be called by clicking the tool icon or by using the Shift+D keyboard shortcut.

Key modifiers

Ctrl - Toggles between dodge or burn types. The type will remain switched until Ctrl is released.

Shift - Shift places the Dodge or Burn tool into straight line mode. Holding Shift, while clicking the mouse Left Button, will Dodge or Burn in a straight line. Consecutive clicks will continue Dodge or Burn in straight lines that originate from the end of the last line.
Summary

In this unit, you have learned about animation. It would introduce and expand the knowledge, understanding and skills for a diverse range of different types of animation by exploring relevant techniques and processes. Also, it explains the history of animation. You should be able to apply the 12 principles of animation and production processes to create an animation film.

Assignments

- Explain what is animation
- Examine the basic types of animation
- List various steps for creating a 2D animation
- Explain basic techniques used in 2D animations
- Describe animation process
- List principles of animation
- Explain stop motion animation
- What is layout design
- List the types of colour use in inking and colouring

Resources

- http://resumbrae.com
- https://upload.wikimedia.org
- https://cdn.pixabay.com
- https://google.com
Unit 2

Professional Image Editing

Introduction

Images produced by scanners and digital cameras are mostly quite good, though not always perfect. They may suffice as records of a scene or event, but they rarely have the dramatic impact of a great print. If your aim is to make prints that go beyond simple records to capture the essence of people and places--to create prints that stand as works of art--you will need to edit the image.

Image editing is at the heart of creative photographic printing--it is where you transform a well-crafted snapshot into a work of art. One reason you need to edit is that a print can rarely capture the tonal range of an actual scene, particularly a naturally illuminated landscape. If you try to transfer a scene literally to a print, the contrast may be too low, resulting in a flat appearance. A print has a maximum tonal range of not more than 100:1. Scenes have widely varying tonal ranges, often much greater. More often it's too high, blocking out highlights and shadows.

Our eyes function differently while viewing prints and viewing scenes. As they move about a scene, they constantly adapt to differences in illumination using all sorts of cues not present in a print. The scene we experience is the result of numerous adaptations, both small and large. When we look at a print, our eyes adapt very little. They grasp the print as a whole. In order to capture the feeling of a scene, those adaptations have to be put into the print. You can achieve this by editing selected portions of the print.

Some of the specific goals of image editing are -

- Adjustment of geometry: crop, rotate, correct perspective distortion, etc.
- Removal of dust specks and scratches.
• Correction for lens aberrations, if needed: distortion (barrel and pincushion), chromatic aberration (colour fringing) and light falloff (in wide angle lenses).
• Adjustment of brightness, contrast, colour tint and colour saturation of the image as a whole.
• Adjustment of portions of the image to bring them into balance with the image as a whole. This typically involves the use of masks and may be facilitated by sophisticated techniques such as contrast masking.
• Sharpening of the image and if necessary, reduced grain.

Outcomes

Upon completion of this unit you will be able to:

• Understand various tools of professional image editing using GIMP.
• Learn to use various tools like colour tools and filters using GIMP.
• Leading to advanced image editing skills.

Terminology

Hue-Saturation: This is used to adjust hue, saturation and lightness levels on a range of color weights for the selected area of active layer.

Threshold: It can be used to enhance a block and white image (a scanned text for example) or to create section masks.

Curves: The Curves tool is by far the most sophisticated tool and is used to adjust the tonality of images.

Gradient map: This filter uses the current gradient, as shown in the Brush/Pattern/Gradient area of the Toolbox, to recolour the active layer of the image to which the filter is applied.
Colour Tool

Colour Balance

- Helps modify the colour balance of the active selection or layer.

**Screenshot**

**Activation**

- The Colour Balance Tool can be called in the following order, from the image menu: Tools>Colour Tools>Colour Balance.

**Hue-Saturation**

This is used to adjust hue, saturation and lightness levels on a range of colour weights for the selected area or active layer.

**Activation**

You can call the Hue-Saturation Tool in the following order, from the image-menu: Tools>Colour Tools>Hue - Saturation.

**Screenshot.**
Colourize

This helps render the active layer or selection into a greyscale image seen through a coloured glass. See HSV Colour Model for Hue, Saturation and Luminosity.

Screenshot

Activation

The Colourize Tool can be called in the following order, from the image-menu: Tools>Colour Tools>Colourize.

Brightness-Contrast

This tool helps to adjust the brightness and contrast levels for the active layer or selection. This tool is easy to use, but relatively unsophisticated. The Levels and Curve tools not only allow you to make the same types of adjustments, but also give you the ability to treat bright colours differently from darker colours. Although Brightness-Contrast tool is great for doing a quick adjustment in a few seconds, but if the image is important and you want it to look as good as possible, some other tools have to be used.

In GIMP 2.4, a new way of operating this tool has been added by clicking the mouse inside the image, and dragging it while keeping the left mouse button down. Moving the mouse vertically changes the brightness and moving it horizontally changes the contrast.
Once are satisfied with the result, you can either press the "OK" button on the dialog, or hit the Return key on your keyboard.

Activation

The Brightness-Contrast Tool can be called from an image menu: Tools>Colour Tools

Brightness - Contrast. If you find yourself using this tool often, you can add it to the Toolbox using the Tools dialog.

Threshold

It helps to transform the current layer or the selection into a black and white image, where white pixels represent the pixels of the image whose Value is, in the threshold range and black pixels represent pixels with Value, out of the threshold range. It can be used to enhance a black and white image (a scanned text for example) or to create selection masks. As this tool creates a black and white image, the anti-aliasing of the original image disappears. If this poses a problem, consider using the Levels tool.
Activation

The Threshold Tool can be called in the following order, from the image-menu: Tools>Colour Tools>Threshold or by clicking on the icon in Toolbox, if this tool has been installed in it. You can do that through the Tool dialog.

Levels

This tool not only provides features similar to the Histogram tool but can also change the intensity range of the active layer or selection.
Activation

You can call the Level Tool in the following order, from the image-menu: Tools> Colour Tools> Levels

Curves

The Curves tool is by far the most sophisticated tool and is used to adjust the tonality of images.

Screenshot

Activation

The Curves Tool can be called in the following order, from the image-menu: Tools> Colour Tools> Curves.

Posterize

This is designed to intelligently weigh the pixel colours of the selection or active layer and reduce the number of colours while maintaining a semblance of the original image characteristics.
Activation

The Posterize Dialog can be called in the following order, from the image-menu: Tools> Colour Tools> Posterize or by double-clicking on the icon in ToolBox, if Colour Tools has been added to it.

Colour

Introduction to Colour Filters

This tool contains several filters to modify colours in an image, a layer or a selection. You can find filters to compose, decompose, uncolour and many other effects.

Alien Map 2

Found in Filters> Colours Map> Alien map 2, this filter renders much modified colours by applying trigonometric functions. Alien Map can work on RGB and HSV.
Two Colours Exchange
This filter is found in Filters> Colours Map> Colour Exchange. This filter replaces a colour with another one.

Colormap Rotation
This filter is found in Filters> Colours Map> Colour Map Rotation. Colormap Rotation lets you exchange one colour range with another range.
Main Options

There are two colour circles, one for the "From" colour range and the other for the "To" colour range.

Grey Options

In this tab, you can specify how to treat grey. By default, grey is not considered as a colour and is not taken into account by the rotation. You can convert slightly saturated colours into grey and vice-versa.

Map Colour Range

Found in Filters> Colours Map> Colour Range Mapping, the Map Colour Range filter maps a defined colour range against another defined colour range.

Sample Colourize

This filter is found in Filters> Colours Map> Sample Colourize. This filter allows you to colourize old black and white images by mapping a colour source image or a gradient against it. Any grey-tone image must be changed to RGB before using this filter (Image/Image>Mode>RGB).

Options - The filter window is divided into two parts: Destination on the left and Sampling on the right.
**Gradient map**

This filter uses the current gradient, as shown in the Brush/Pattern/Gradient area of the Toolbox, to recolour the active layer of the image to which the filter is applied. To use it, first choose a gradient from the Gradients Dialog, and then select the part of the image you want to alter and activate the filter by choosing Filters, Colours Map, and Gradient Map from the image menu. The filter runs automatically, without showing any dialog or requiring any further input. It uses image colour intensities (0 - 255), mapping the darkest pixels to the left end colour from the gradient and the lightest pixels to the right end colour from the gradient. Intermediate values are set to the corresponding intermediate colour.

**Screenshot**

**Border Average**

**Overview**

Found in Filters> Colours> Border Average, this tool calculates the average colour in a border around active layer or selection. Calculated colour becomes the foreground colour in Toolbox. This filter is interesting when you have to find a Web page colour background that differs as less as possible from your image.
border. The action of this filter is not registered in Undo History and cannot be deleted with Ctrl+Z.

**Channel Mixer**

Found in Filters > Colours > Channel Mixer, this filter combines the values of the RGB channels. It works with images with or without an alpha channel. It also has a monochrome mode and a preview.

**Colourcube Analysis**

Found in Filters > Colours > Colourcube Analysis, this tool gives data about the image: dimensions, file size, colour number and compression ratio.
**Colourify**

Found in Filters> Colours> Colourify, this filter renders a greyscaled image like it is seen through coloured glass.

**Colour to Alpha**

Found in Filters> Colours> Colour to Alpha, this filter makes all pixels transparent with a selected colour. An Alpha channel is created. It will attempt to preserve anti-aliasing information by using a partially intelligent routine that replaces weak colour information with weak alpha information. Thus, areas that contain an element of the selected colour will maintain a blended appearance with their surrounding pixels.

![Screenshot](image.png)

**Compose**

This filter is found in Filters> Colours> Compose. This filter is active in Filters/Colours after using Decompose. This filter is used to reconstruct an image from its RGB, HSV... components.
Decompose

Found in Filters> Colours> Decompose, this filter separates an image into its different components (RGB, HSV).

Filter Pack

This tool provides a collection of unified filters to treat the image. Of course, same functions can be performed by particular filters, but what one can have here is an interesting and intuitive overview.

Starting filter

This filter is found in the image menu via Filters> Colours> Filter Pack.
Hot

Overview

This filter is found in the image menu via Filters>Colours Hot. It identifies and modifies pixels which might cause problems when displayed onto PAL or NTSC TV screen.

Screenshot

Filter - Introduction

Filters are special kind of tools that are designed to take an input layer or image by applying a mathematical algorithm to it and return the input layer or image in a modified format. The GIMP uses filters to achieve a variety of effects and those effects are discussed here.

- Blur
- Noise
- Edge-Detect
- Enhance
- Generic
- Glass Effects
- Light Effects
- Distorts
- Artistic
- Map
- Render
- Combine
1. Blur filters

Blur filters: Introduction

This includes a set of filters that blurs images or parts of them in various ways. If there is a selection, only the selected parts of an image will be blurred. There may, however, be some leakage of colours from the unblurred area into the blurred area. To help you pick the one you want, we will illustrate what each does when applied to the image shown at right. These are of course only examples; most of the filters have parameter settings, which allow you to vary the magnitude or type of blurring.

Gaussian blur is one of the most used filters. This filter makes an image blurry in the most basic way. It has an efficient implementation that allows it to create a very blurry blur in a relatively short time. If you only want to blur the image a little bit—to soften it, you might use the simple "Blur" filter. In Gimp 2.2 this runs automatically, without creating a dialog. The effect is subtle enough that you might not even notice it, but you can get a stronger effect by repeating it. In Gimp 2.0 the filter shows a dialog that allows you to set a "repeat count". If you need a strong blurring effect, this filter is too slow to be a good choice; the Gaussian blur can be used instead.

Blur

This simple Blur filter produces an effect which is similar to that of an out of focus camera shot. To produce this blur effect, the filter takes the average of the present pixel value and the value of adjacent pixels and sets the present pixel to that average value. The advantage of this filter is its calculation speed. It suits big images. The drawback of this filter is that its action is hardly perceptible on big images, but very strong on small images.

Activation - This filter can be called from the image menu: Filters> Blur> Blur
Gaussian Blur

This filter can be found in the image menu under Filters > Blur > Gaussian Blur. The IIR Gaussian Blur plug-in acts on each pixel of the active layer or selection, setting its value to the average of all pixel values, present in a radius defined in the dialog. A higher value will produce a higher amount of blur. The blur can be set to act in one direction more than the other by clicking the Chain Button so that it is broken and altering the radius. GIMP supports two implementations of Gaussian Blur: IIR G.B. and RLE G.B. They both produce the same results, but each one can be faster in some cases.
Motion blur

This filter can be found in the image menu under Filters>Blur>Motion Blur. The Motion Blur filter creates a movement blur. The filter is capable of Linear, Radial and Zoom movements. Each of these movements can be further adjusted, with Length, or Angle settings available.

Pixelise

This filter can be found in the image menu under Filters>Blur>Pixelise. The Pixelise filter renders the image using large colour blocks. It is very similar to the effect seen on television when masking a criminal during trial.
Tileable blur

This filter can be found in the image menu under Filters>Blur>Tileable Blur. This tool is used to soften tile seams in images used in tiled backgrounds. It does this by blending and blurring the boundary between images that will be next to each other after tiling. If you want to treat only image borders, you can’t apply filter to the whole image. The solution to get the desired effect is as follows: Duplicate layer (Layer Duplicate Layer) and select it to work on it. Apply "Tileable Blur” filter with a 20 pixels radius to this layer. Select all (Ctrl+A) and reduce selection (Selection Shrink) to create a border with the wanted width. Delete selection with Ctrl+K. Merge layers with Layer Merge down.

2. Noise filter

Noise filters - introduction

Noise filters add noise to the image. To remove small defects from an image, see Despeckle filter.

Hurl

Overview

Found in Filters>Noise> Hurl. The Hurl filter changes each affected pixel to a random colour, so that it produces real random noise. All colour channels, including an alpha channel (if it is present) are randomized. All possible values are assigned with the same probability. The original values are not taken into account. All or only some pixels in an active layer or selection are affected, the
percentage of affected pixels being determined by the Randomization (%) option.

![Screenshot]

**Screenshot**

**Scatter RGB**

Found in the image window menu under Filters> Noise> Scatter RGB, this filter adds a normally distributed noise to a layer or a selection. It uses the RGB colour model to produce the noise (noise is added to red, green and blue values of each pixel). A normal distribution means, that only slight noise is added to most pixels in the affected area, while fewer pixels are affected by more extreme values. If you apply this filter to an image filled with a solid grey colour and then look at its histogram, you will see a classic bell-shaped Gaussian curve. The result is very natural looking noise.
Pick

Overview

Found in Filters > Noise > Pick, this filter replaces each affected pixel by a pixel value which is randomly chosen from its eight neighbors and itself (from a 3×3 square the pixel is centre of). All or only some pixels in an active layer or selection are affected. The percentage of affected pixels is determined by the Randomization (%) option.
3. Edge detect filters

**Edge-detect: Introduction**

Edge detect filters search for borders between different colours so that they can detect contours of objects. They are used for making regions and for many artistic purposes.

Based on gradient calculation methods, most of them give thick border lines. Look at fig.1 which represents colour intensity variations. On the left is a slow colour gradient which is not a border. On the right is a quick variation which is an edge. Now, let us calculate the gradient and the variation speed of this edge i.e the first derivative (fig.2). We have to decide that a border is detected when gradient is more than a threshold value (the exact border is at top of the curve, but this top varies according to borders). In most cases, threshold is under top and border is thick. The Laplacian edge detection uses the second derivative (fig.3). The top of the curve is now at zero and clearly identified. That is why Laplace filter renders a thin border, only a pixel wide. But this derivative gives several zeros corresponding to small ripples, resulting in false edges. Some blurring before applying edge filters is often necessary as it flattens small ripples in signal and so prevents false edges.

**Difference of Gaussians**

This filter is located at Filters> Edge detect> Difference of Gaussians. This filter is new in GIMP 2.2. It does edge detection using "Difference of Gaussians" algorithm, which works by performing two different Gaussian blurs on the image with a different blurring radius for each and subtracting them to yield the result. This algorithm is very widely used in artificial vision and is pretty fast because there are very efficient methods for doing Gaussian blurs. The most important parameters are the blurring radii for the two Gaussian blurs. It is probably easiest to set them using the preview, but it may help to know that increasing the smaller radius tends to give thicker-appearing edges and decreasing the larger radius tends to increase the "threshold" for
recognizing something as an edge. In most cases you will get nicer results if Radius 2 is smaller than Radius 1, but nothing prevents their reversal. In situations where you have a light figure on the dark background, reversing them may actually improve the result.

4. Enhance filters

Enhance filters: Introduction

Enhance filters are used to compensate for image imperfections, which include dust particles, noise, interlaced frames (mostly coming usually from a TV frame-grabber) and insufficient sharpness.

Deinterlace

Overview

This filter is found in Image>Filters/Enhance/Deinterlace. Images captured by videocards, especially when fast movement is recorded, may look blurred and stripped with splitted objects. This is due to the way cameras work. They don't record 25 images per second but 50, with half vertical resolution. There are two interlaced images in one frame. The first line of the first image, it is followed by the first line of the second image then second image followed by second line of first image, etc. Thus, if there has been an important move between the two images, objects will appear splitted, shifted and stripped. The Deinterlace filter keeps only one of both images and replaces missing lines by a gradient between
previous and following lines. The resulting image or selection will be somewhat blurred, but can be improved by Enhance filters.

Despeckle

Found in Image>Filters/Enhance/Despeckle, this filter is used to remove small defects due to dust, or scratches on a scanned image and also Moiré effect on image scanned from a magazine. One must select isolated defects before applying filter.

Sharpen

This filter is found in Image>Filters/Enhance/Sharpen. Most of digitized images need correction of sharpness. This is due to the
digitizing process that must chop a colour continuum up in points with slightly different colours. The elements thinner than sampling frequency will be averaged into a uniform colour, so sharp borders are rendered a little blurred. The same phenomenon happens when printing colour dots on paper, the Sharpen filter accentuates not only edges but also any noise or blemish. It may also create noise in graduated colour areas like the sky or a water surface. It competes with the Unsharp Mask filter, which is more sophisticated and renders more natural results.

5. Generic filters

Generic filters introduction

Generic filters are filters that you can build your own filters with. Convolution Matrix filter could help you understand this better.

Convolution matrix

Overview

This filter can be found via the image menu under Filters> Generic> Convolution Matrix. Most filters use convolution matrix. With the Convolution Matrix filter, one can build a custom filter.

It is possible to get a rough idea about Convolution Matrix without using mathematical tools. Convolution is the treatment of a matrix by another one which is called "Kernel". The Convolution Matrix filter uses a first matrix which is the Image to be treated. The
image is a bi-dimensional collection of pixels in rectangular coordinates. The used kernel depends on the effect you want. GIMP uses 5x5 or 3x3 matrices. We will consider only 3x3 matrices as they are the widely used and are enough for all required effects. If all border values of a kernel are set to zero, then system will consider it as a 3x3 matrix. The filter studies every pixel of the image successively. For each of them, which we will call the "initial pixel", it multiplies the value of this pixel and values of the 8 surrounding pixels by the kernel corresponding value. Then it adds the results and the initial pixel is set to this final result value.

**Screenshot**

**Dilate**

**Overview**

Found in Filters> Generic> Dilate, this filter widens and enhances dark areas of the active layer or selection. For every image pixel, it brings the pixel Value (luminosity) into line with the lowest Value (the darkest) of the 8 neighboring pixels (3x3 matrix). So, a dark pixel is added around dark areas. An isolated pixel on a brighter background will be changed to a big pixel, composed of 9 pixels and that will create some noise in the image.
6. Glass Effects filters

Glass Effects filters: Introduction

Glass Effects filters result in an image as if it were seen through a lens or glass tiles.

Apply lens

Overview

This filter can be accessed via the image menu under Filters> Glass effects> Apply Lens. After applying this filter, a part of the image is rendered as through a spherical lens.
7. Light Effects filters

Light Effects filters: Introduction

Light Effects filters render several illumination effects of the image.

FlareFX

Overview

Found in Filters> Light Effects>FlareFX, this filter gives the impression that the sun hit the objective when taking a shot. You can locate the reflection with a reticule you can move, but you would not have the possibilities that Gflare filter offers.

Gflare

Overview

Found in Filters> Light Effect>Gflare, this filter reminds you of the effect you get when you take a photograph of a blinding light source, with a halo and radiations around the source. The Gflare image has three components: Glow which is the big central fireball, Rays and Second Flares.
Lighting Effects

Found in Filters > Light Effects, this filter simulates the effect you get when you light up a wall with a spot. It does not produce any drop shadows and of course, does not reveal any new details in the dark zones.

8. Distort filters

Distort filters: Introduction

The distort filters transform images in many different ways.
Blinds

Found in Image>Filters/Distorts/Blinds, this filter generates a blind effect with horizontal or vertical battens. You can lift or close these battens, but you cannot lift the whole blind up.

CurveBend

Found in Filters>Distorts>Curve Bend, this filter allows you to create a curve that will be used to distort the active layer or selection. The distortion is applied gradually from an image or selection border to the other.
Emboss

Found in Image>Filters/Distorts/Emboss, this filter can be used only with RGB images. If your image is greyscale, it will be greyed out in the menu. It stamps and carves the active layer or selection, giving it relief with bumps and hollows. Bright areas are raised and dark ones are carved. You can vary the lighting.

Ripple

Found in Image>Filters/Distorts/Ripple, this filter displaces the pixels of the active layer or selection to waves or ripples thus simulating a reflection on disturbed water.
9. Artistic Filters

Artistic filters: Introduction

Artistic filters create artistic effects like cubism, oil painting, and canvas.

Apply Canvas

Found in Image> Filters/Artistic/Apply Canvas, this filter applies a canvas-like effect to the current layer or selection. It textures the image as if it is an artist’s canvas.

Cubism

Screenshot
Found in Filters> Artistic> Cubism, this plugin modifies the image so that it appears to be constructed of small squares of semi-transparent tissue paper. If setting possibilities of this filter are not enough for you, see GIMPressionist filter, which offers more options.

**Oilify**

*Screenshot*

Found in Filters> Artistic> Oilify, this filter gives the image a semblance of an oil painting. The Mask Size controls the outcome. A high value gives the image less detail, as if you had used a larger brush. The GIMPressionist filter can produce similar effects, but it also allows a much wider variety of options.

**10. Map filters**

**Map filters: Introduction**

Map filters use an object named map to modify an image in which you map the image to the object. Thus, you can create 3D effects by mapping your image to another previously embossed image ("Bump Map" Filter) or to a sphere ("Map Object" filter). You can also map a part of the image elsewhere into the same image ("Illusion" and "Make Seamless" filters) or bend a text along a curve ("Displace" filter).
Bump Map

Overview

Found in the image window menu under Filters> Map> Bump Map, this filter creates a 3D effect by embossing an image (the card) and then mapping it to another image. Bump height depends on pixel luminosity and you can set light direction. See Emboss for more information about embossing. You can bump map for any type of image, unlike the Emboss filter.

Displace

Overview

This filter can be accessed from the image menu Filters> Map> Displace. It uses a 'displace-map' to displace corresponding pixels of the image. This filter displaces the content of the specified drawable (active layer or selection) by the amounts specified in X and Y Displacement multiplied by the intensity of the corresponding pixel in the 'displace map' drawables. Both X and Y displace maps must be grey-scale images and have the same size as the drawable. This filter allows interesting distortion effects.
This filter can be accessed from the image window menu under Filters> Map> Illusion. With this filter, your image (active layer or selection) looks like a kaleidoscope. This filter duplicates your image in many copies, more or less dimmed and split and puts them around the centre of image.
Warp

Found in the image window menu under Filters> Map Warp, this filter has no Preview. This filter displaces pixels of active layer or selection according to grey levels of a Displacement map. Pixels are displaced in accordance with the gradient slope in the displacement map. Pixels corresponding to solid areas are not displaced. Higher the slope, the higher is the displacement.

11. Rendering filters

Render filters introduction

Although most Gimp filters act on a layer by transforming its contents, the filters in the "Render" group are a bit different. They create patterns from scratch, in most cases obliterating anything that was previously in the layer. Some create random or noisy patterns, others have regular fractal patterns and one (Gfig) is a general-purpose (but rather limited) vector graphics tool.

Plasma

This filter can be found in the image menu following Filters> Render> Clouds Plasma. You can generate colourful clouds through Plasma, which can be used for textures. The turbulence in the plasma cloud can be controlled with the Turbulence slide. All of the colours produced by Plasma are completely saturated. Sometimes the strong colours may be distracting and a more
interesting surface will appear when you desaturate the image using Layer/Colours/Desaturate. An enhanced version of the Plasma plug-in called Plasma2, with many more options and parameters, is available from the Gimp Plugin Registry.

**Screenshot**

**Solid noise**

This filter can be accessed through the image menu through Filters> Render> Clouds> Solid noise. Solid Noise is a great texture maker. Note that this noise is always grey, even if you apply it to a very colourful image (it doesn't matter what the original image looks like -- this filter completely overwrites any existing background in the layer it is applied to). This is also a good tool for creating displacement maps for the plug-in. With the "turbulence" setting active, the results look quite a bit like real clouds.

**Screenshot**
12. Combine filters

Combine filters: Introduction

The combine filters associate two or more images into a single image.

Depth merge

It combines the two pictures selected as "sources" by blending them. Darkest values are predominant in the resulting image. This could be done using blending modes but in this case there aren’t any options. To work with this filter, at least two images are needed that have to be of the same size. This filter can be accessed through Filters/Combine/Depth Merge.

Film

The film filter allows a user to merge several pictures into a photographic film drawing. This filter does not invert colours, hence it does not imitate negative film of the sort used to produce prints. Instead you should think of the result as an imitation of slide film or cinema.

This filter can be accessed via Image/Filters/Combine/Film Options. A double click on the tool buttons opens the Tool Options dialog.
Unit Summary

In this unit you have learnt about advanced image editing using GIMP open source software. We have learnt about Colour Tool and various filters using examples from a screenshot. In Colour Tool we have learnt about Colour Balance Tool, Hue Saturation Tool, Colourize Tool, Brightness Contrast Tool, Threshold Tool, Levels Tool, Curves Tool and Posterize Tool. In Filters, we have learnt about various filters and their sub functions like Blur, Noise, Edge-Detect, Enhance, Generic, Glass Effects, Light Effects, Distorts, Artistic, Map, Render and Combine filters.

Assessment

1. What are filters?
2. What are the various types of filters and their uses?
3. What is the current stable version of GIMP?

Resources

1. All images describing the Toolbox functions are screenshots taken while working with India Gate image.
2. Some of the key modifiers are referenced from https://docs.gimp.org/odftest/en.pdf which is an open source material with no copyrights by GIMP.
Unit 3

Advertising and Illustration

Introduction

Pixlr is a cloud-based set of image tools and utilities that include a number of photo editors, a screen grabber browser extension and a photo sharing service. The apps provide tools for simple to advanced photo editing. Pixlr can be used on PCs and on smartphones or tablets using a mobile app. Time put Pixlr on its list of the top 50 websites of 2013. It has web-based 'paint' features similar to online image manipulation software such as Sumo Paint.

Pixlr Editor- It is an open source online photo editor of PIXLR used for advanced photo editing. It is free and no download is required.

Pixlr Express- It is another open source online photo editor of Pixlr and as the name suggests it is used for minor photo editing. It is free and easy to use.

Pixlr-o-Matic- It is a photography/darkroom tool that makes it easy to add style to photos using effects, overlays and borders.

Outcomes

Upon completion of this unit you will be able to:

a) Dynamic ways to transpose images.
b) To use Lasso, Clone Stamp, and the Magic Wand tool to edit your pictures.
c) The fundamental techniques to animate and revive any picture
   d) Advanced techniques to animate and edit images.
Terminology

**Pixlr Editor:** Image Editing Software.

**Cropping:** Cropping lets you “cut” unwanted parts from sides, top or bottom of a picture.

**Moire effect:** Moire is a pattern that is created in some photos by grids or series of lines.

**Pixlr Express:** Pixlr Express is a faster way to crop, resize, rotate, adjust and add photo effects to your photos.

**Pixlr Editor**

Pixlr Editor is a type of browser photo editor that addresses your editing needs. It allows you to have full control over your images, including layers and effects. It is the most popular advanced online photo editor and contains features that are available in desktop graphic design applications. Tools have features such as red-eye reduction, a spot healing tool, drawing tools, clone tools, sharpen, blur and many more. Similarly, filters include mimic HDR, glamour glow, tilt-shift, Gaussian blur, vignetting, noise and many others. Adjustments include advanced concepts like Levels, Curves, Cross Process, Desaturate, Auto Levels, Hue/Saturation and Brightness/Contrast.

**Screenshot**

**Advantages of Pixlr Editor**

- Account is not necessary. You can create an account for free storage space if you wish to do so.
- No special download or installation. You can fire it up in your browser when needed
• The Pixlr Editor provides tools such as Layers, Lasso Tool, Brush controls, Cloning and Filters.
• An optional private Pixlr Library where you can store all your photos and images.

Website- https://pixlr.com/editor/

Getting Started

1. At the initial screen, choose Open Pixlr editor.

2. You have to choose from the following:
   a. Create a new image - To make a brand new image, or to cut-and-paste an image from somewhere else.
   b. Open image from computer - Open a picture stored in your computer or on a flash drive.
   c. Open image from URL - Open a picture by putting in its unique Internet address.
   d. Open image from library - Open from an account at Pixlr, Facebook, etc.

3. At the point when the picture is open in Pixlr, you can modify the span of the picture window by dragging it in or out (see the red hover in the picture underneath). You can zoom in and out by holding down the [Ctrl] key and squeezing either the [+] or [-] keys.
The Pixlr screen. Main menu is at top (green oval).

**Basics**

Pixlr is much similar to a basic variant of Photoshop. Apparatuses are on the left, the work territory is in the center and boards are put on the correct side of the screen. The program offers full help for layers. Huge numbers of the apparatuses - for example, the Clone Stamp Tool - work particularly like their partners in business programming programs and are simpler to use than with some other Web 2.0 picture editors.

The Move Tool is the best instrument to choose for a lot of your work in Pixlr. Consider it the "default" apparatus.

Fix the last activity by squeezing the [Ctrl] and [Z] keys all the while. Then again, select Edit from the best menu of the Pixlr window and pick Undo.

At whatever point you pick a device, its choices are shown simply under the menu at the highest point of the Pixlr window. Infrequently these settings significantly influence the utilization of the instrument.

Bear in mind that this arrangement of apparatuses is easy to utilize and can add some exceptionally fun impacts to pictures.

Try not to fear the "propelled" mode. It isn't difficult to utilize, and is by a long shot the most effective piece of Pixlr.

**Cropping an Image**

Via cropping, you can "reduce" undesirable parts from the sides, pinnacle or bottom of an image. you can additionally absolutely change the character of a picture by disposing of distracting or unnecessary elements of it.

1. Select the Crop Tool from the Tools at the left.

2. Click on the image and "drag" out a "box". This is the area that will remain after cropping.

3. Adjust the cropping area:
   a. Click the blue boxes at the corners of the cropping area and drag them to resize the part of the image to crop.
b. Place your cursor on the cropping area. It should change to a "plus sign" with four arrows, then click and drag the cropping area to where you want it.

4. Press the [Enter] key to crop.

Screenshot

Resizing an Image

This tool is used to change the dimensions of an image. After cropping the above photograph, it measures 1388 x 777 pixels (width is continually indexed first). That is too extensive for use in maximum of the functions and approximately four-five times too wide for an internet web page.

1. Select the Move Tool.

2. From the menu at the top of the Pixlr window, select Image, then choose Image size.

3. The Image size window should appear. Make sure the Constrain proportions box (circled in red) is checked, to keep the image from being distorted in the resize.

4. Type in the width or height you want and the other dimension will automatically be adjusted. Click [OK].
Rotating an Image

You can rotate an image in Pixlr in two ways – select Image from the menu for simple rotation (90 or 180 degrees), and choose the appropriate amount of rotation.

To get the finer control of rotation, you can use Free Transform:

1. Just select the Move Tool and click the image.
2. In the Menu, select Edit and Free transform, the "frame" of which should appear around the image.
3. Move the cursor around the outside edge of the image to rotate, until it changes into an arrow bent into a circle. Click and drag to rotate the image.
4. Then click any tool in the Tools to finish editing in free transform. You have to choose [Yes] to apply the changes made.
How to save an Image

Saving an image in Pixlr is easier and simpler as it allows you to save an image to your Facebook account.

1. Choose File and select Save
2. Type the filename for the image in the Name box
3. Select the Format (several formats to choose from):
   - JPEG—It is the best final format for most photos (which are not required to be edited again in Pixlr).
   - PNG - PNG format is used when the image has a transparent background. Else, JPEG is a better choice.
   - BMP—It is also known as a Bitmap file format. Since it is an uncompressed format, file size tends to be very large.
   - TIFF—It stands for Tagged Image File Format, another file format with very large file sizes. Again, JPEG will be a better choice.
PXD—This is called Layered Pixlr image. You can use this format if you plan to open the file again in Pixlr. This maintains layers, while other formats "flatten" them.

4. Look in the lower-right corner to make sure the file size is acceptable, and then click

Working with Layers

Pixlr, like Photoshop and many other expert-stage applications, allows you to work on photographs with layers.

By unlocking and renaming the historical past layer, adjustments to an picture can't be made till the principle layer of the picture is unlocked. Pixlr calals this the heritage layer.

1. First, open an image in Pixlr

2. Ensure the Layers panel is visible to the right of the image. If not select View, choose Layers to make it visible

3. In the Layers panel, just double-click the padlock icon (circled in red in the image to the right) in the Background layer, which will change the padlock to a check box and unlock the layer to enable you to edit

4. The name of the layer has been changed from Background to Layer 0. Double-click the name and type in something descriptive

Screenshot
Adding Text in a new layer

Typing text in a new layer will allow you to move the text around, edit it, and delete it without causing disturbance to the rest of the image.

1. First, select the Type tool to find if your cursor changes
2. Then click on the image where you want your text to appear
3. Type the text, which will probably be black in colour

Moving text

1. Choose the Move tool
2. Check the Layers panel to ensure text layer is selected. If not, click the text layer
3. Now, you can move the text anywhere on the image

Modifying text

1. First, select the Type tool
2. And choose the layer for the text in the Layers panel
3. Now click the text and editing window should appear
4. Edit the Text. You can change the Font and change the Size or the Style.
5. Click the colour picker (circled in red, below) to change the Colour. You have to choose a tab at the top of window for the colour format and select a colour. Remember to click [OK] in both windows.
Layer order

Keep in mind the layers as being on clean plastic. Layers are visible at one time, however the Layers panel controls how they overlap. The layer on the top inside the Layers panel seems "closest" to the viewer. You have to click a layer and drag it up or down to exchange the order of layer.

Hiding layers

An image comprises several layers. By selecting the layers to hide and to keep them visible, many images can be saved from one "master" image.

1. In the Layers panel, select the checkbox to remove the check mark and hide the layer.

2. To make the layer visible again, click the checkbox.

Using layers to make a composite image

Setting multiple photograph collectively with layers is easy. You presently have a JPG image for the historical past, however the popcorn picture is a GIF with a "obvious" heritage, because of this when it's miles inserted into some other photograph, the popcorn flashes.
1. You have to download the images below and save them to your computer.

2. Then open the photo.

3. Select the Move Tool.

4. Choose Layer and select Open image as layer.

5. Browse to and open the popcorn image. Notice that a new layer has been created.

6. Double-click the name of the new layer and rename it.

7. Make sure the layer for the image is selected, then click and drag it to where you want it to appear.

8. To resize/rotate the image
   
   a. Select the image layer in the Layers panel.

   b. Hold down the [Ctrl] key and press [T]. This will turn on the Free Transform mode for the layer.

   c. Move the cursor near the Free Transform box and it should turn into an arrow bent into a circle (see image, below). Click and drag to rotate the contents of the Free Transform box.

   d. To resize, hold down the [Shift] key to prevent distortion and click any of the corners of the Free Transform box. Click and drag inwards or outwards to resize.

   e. Select any tool in the Tools to finish editing in free transform. Choose [Yes] to apply the changes you've made.

   ![Screenshot](image_url)
Advanced Techniques

Pixlr offers you options to adjust the image’s look:

Moire Effect

Moiré pattern is created in pix by using grids or collection of traces. It now and again props up in television images, whilst the camera faces trouble with sure patterns on clothing, and is visible while a digital camera is used to take a photograph of a television display screen. Let us now see the description of the Moiré effect:

Moire effect is a visual perception that occurs when viewing a set of lines or dots that is superimposed on another set of lines or dots, where the sets differ in relative size, angle or spacing. The Moiré effect can be seen when looking through ordinary window screens at another screen or background.

Using Gaussian Blur to remove the Moire effect

To remove Moiré effect, Gaussian Blur is used. Any kind of blur is applied after image editing is complete, but it’s an exception when you are using the Gaussian blur to remove Moiré patterns.
The effect is visible in this drawing at some resolutions:

Choose Filter from the menu and select Gaussian blur.

Carefully adjust the amount of blur, to try to lessen the Moiré effect without blurring the image in general.

**Quick adjustment auto levels**

Auto levels are supposed to adjust colour, brightness, contrast, etc. in one quick-and-easy step.

1. Select Adjustment from the menu and choose Auto levels. Observe the changes (if any) in your picture.
2. Use Edit > Undo to reverse the adjustment, if desired. You may wish to try some of the adjustments described below.

**Adjusting hue, saturation**

1. First choose adjustment from the menu and select Hue and Saturation.
2. Next, you have to use the sliders for Hue, Saturation and Lightness to adjust your image.

**Hue** is used to change the colours in an image.

**Saturation** alters the intensity of colours. In the extremes, change the image colours to pure, saturated colours. Else, you can just wash the colour completely out of a picture.

**Lightness** changes the colours along a lightness–darkness scale.
Adjusting the levels manually

This is a perfect feature to use with "murky" images not having a true black or a true white anywhere. The process is a bit intimidating, but it's simple and easy.

The following image is well-composed and framed. It is somewhat "washed out." Colours may be brighter and the photo contains only a small amount of "true black" colour. You can use the levels to improve the photograph.

1. Select Adjustment and choose Levels...

2. The Levels window shows a histogram, with three "sliders" at the bottom of it. The curve shows how colour lightness values are distributed in the image.

3. To achieve a true black in the image, move the leftmost slider (circled in red in image below) inwards, onto the bulk of the histogram.

4. To adjust the image to have a true white, move the rightmost slider (circled in green in image below) inwards to meet the right edge of the bulk of the histogram. This will also lighten colours in the photo.
5. The middle slider can be used to adjust mid-tone values.

6. If you wish, you can also click the Channel selector and adjust the red, green and blue colour channels individually. In our example, we'll just try the small adjustments shown below.

Screenshot

**Using the colour curves to modify an image**

The challenging Colour Curves give the fastest and most powerful tools to edit an image. Each "curve" appears as a straight and diagonal line. There are many ways to modify the curves:
Use the Channel selector at the top of the window to adjust, Red, Green or Blue channels or leave it set to RGB to adjust all three at once.

Move either endpoint of the line.

Click anywhere on the line and drag, to "bend" it into a curve.

Click and drag other points to create a complex shape.

Let’s look at two easy changes you can make:

**Correcting tonality**

This will help make dark colours more distinct and brighter, and improve colour balance of a picture.

1. First choose Adjustment and select Curves.
2. Click the Histogram box to make its shape visible.
3. Move the left endpoint horizontally toward the histogram.

**Screenshot**

**Using the Curves to "Solarize" Images**

When a film is exposed to light during or after the developing process, it is called “Solarization”. This extra exposure could cause extreme brightness or even colour inversion in the photo. To do in Pixlr, you have to select Adjustment and choose Solarize. Use of Curves gives you more control over the finished effect.
1. Choose Adjustment and then select Curves.
2. Click the Histogram box to make its shape visible.
3. Move the RGB curve to match the shape of the histogram roughly. There are many possibilities.

![Screenshot](image.png)

**Screenshot**

**Removing a background to create a Transparent Image**

To remove a background from a Pixlr image is different from the process in other image editors, but it isn't tough to do. Some YouTube tutorials talk about copying of the main layer and the creation of another file, but these steps are necessary if you unlock the background layer.

1. Open the image
2. Choose the Move tool
3. In the Layers panel, double-click the padlock icon that is circled in yellow in the image to the right in the Background layer. This will change the padlock to a check box and unlock the layer to enable for edit
4. Select the Wand Tool
5. Click the background of the image to select it to see dotted lines "running" around the background. Now, unlock the background layer.

6. Press the Delete key to remove background, which will be replaced with a checkerboard pattern, indicating that it is transparent.

7. Select File and choose Save. Change the format to PNG and see the background in the preview image changed to transparent (checkerboard). Click [OK].

---

**Free, High-Quality Images**

You should not use bad clip art in the Web pages, PowerPoints or lesson plans. Neither should you use copyrighted images.

Wikipedia (en.wikipedia.org) - Free or Fair to use images. Click an image on the browser if think it is usable. Some images are either in the public domain or are available for fair use for the educators.

MorgueFile (www.morguefile.com)- Free images. The morgueFile database of free pictures is extensive and you can search the images subject. You should avoid the Dreamstime images, which are not free.
Pixlr Express

As the name suggests, Pixlr Express is a faster way to crop, resize, rotate, adjust and add photo effects to your photos. It’s a great tool to use if you want a quick fix to a photo in a hurry!

1. In Google, type in Pixlr
2. Once you are at the Pixlr site, select Pixlr Express
3. Select Open image from computer or from URL
4. When your photo appears, select Basic to crop, resize, rotate or flip

Note: You may need to do each task in the order that they appear. For some reason, if you rotate and Flip first and then Crop or Resize, your image will rotate back to the original position.

Cropping Photos
Select Crop. Frame your photo by dragging the blue boxes in each corner. Click on Apply when you have finished.

Resizing Photos
Pixel width and the height will automatically change.

Typically a pixel (or DPI) is 300 per inch. For instance, if you want a 3 X 4 photo, you can change the pixel width to 900 X 1200.

If you aren’t going to print your photo, but are going to post it online or insert it into a power point slide show, the proportions aren’t critical. If, however, you plan to print the photo, you may need to go back to crop and play around with the dimensions again to get a closer width to length proportion.

Rotate and Flip
Click to rotate left or right or flip horizontally or vertically.

Click on Apply when you have finished.

Photo Adjustments
Once you are satisfied with the basic size of your photo you can try out some, out of many adjustments.

Click on Adjustments and you will find a list of options.
The most used options are usually Red eye removal, Auto levels and Brightness & Contrast.

Practice with your photo to see what kinds of adjustments you can make! You can undo anything you don’t like. Click on the green back arrow above the word Basic to undo a move.

Adjust the size of your photo by dragging the radio button just to the right of the green arrows to zoom in on the area you want to change or adjust.

Click on Done when you have finished.

Save your photo before going to Photo effects. You can open it up again as needed.

The above photo is an example of what happens when you select invert.

**Note:** Pixlr Express will save your photo in whatever format it was in originally. However, if you change the name of the photo, you’ll need to add .jpg or .gif after the name to save the photo as a .jpg or .gif.

**Photo effects**

Open your saved photo. You can now play with some of the many photo effects. Once you are done with your final image, save it.
Unit Summary

In this unit, we have learnt the use of online tool Pixlr to edit images professionally. We discussed in detail about the Pixlr Express, which is used for minor editing, and Pixlr Editor, which is used as a professional image editing tool.

We have learnt the use of Pixlr to edit images using its various online tools. We have learnt how to open, crop, resize and rotate images and subsequently save them. We have seen how to work in layers, add layers to an existing project, hide layers and turn an image into a composite one by using layers.

We have gotten comfortable with cutting edge methods, for example, auto levels, utilizing Gaussian obscure to remove Moire impact, altering tint and immersion, physically changing the levels, utilizing the shading bends to adjust a picture, revising tonality, utilizing bends to solarize pictures, expelling foundation to make straightforward pictures and so forth.

Assignment

1. What are the three different types of Pixlr tools?
2. True/False
   a. Tools in Pixlr are on the left side of the screen
   b. In Pixlr, work area is on the right of the screen
   c. In Pixlr, panels are in the middle of the screen
3. What is the major difference between Pixlr Editor and Pixlr Express?
4. What is the Moire effect? Give examples?
5. What is used to remove the Moire effect?
Resources

1. All images saved from screenshots which are done manually using the above editors.

2. Some material is referenced from

   http://pixlrtutorial.blogspot.in/p/tutorials-navigation.html The material is not copyrighted.
Unit 4

Vector Composition & 2D Animation

Introduction

Animation is the rapid display of a sequence of images in order to create an illusion of movement. Traditionally, 2D animation is created by drawing each displayed image individually. These images are called "Frames", thus the method is called "Frame-by-Frame Animation". To create a good illusion of movement, you need to draw many frames. As such, the method requires a lot of time and resources. Synfig Studio is open-source 2D vector animation software designed to produce film having quality animation with fewer people and resources. It is built to eliminate the need to draw each frame individually. The instructions in this unit have been sourced from Synfig Studio’s user documentation that is available under Creative Commons Attribution license.

Outcomes

Upon completion of this unit you will be able to:

- Learn the use of Synfig vector 2D animation open source software
- Study the use of various functions of Synfig like toolbox, canvas, panels
- Understand the process of adding colours, linking, and animation basics
- Learn to animate shapes and add layers
Terminology

Canvas: It displays the artwork and animation.

Panel: It contains tools and information about certain elements of your project.

Navigator: It shows a thumbnail image of what the currently selected canvas looks like. You can also zoom in and move the focus around with this panel.

Getting Started

The screenshot below displays Synfig Studio’s complete window layout.

Screenshot

Illustration 1: Standard Synfig Studio’s window layout

The main interface components of Synfig Studio are:

- Toolbox — is the main Synfig Studio window. It contains system menu and buttons, tools and more to create and edit your artwork. Closing it exits the application.
• Canvas — displays your artwork and animation.

• Panels — contain tools and information about certain elements of your project. Some panels will allow you to modify those elements.

**Note**

To reset Synfig to its default window arrangement, you have to select "Panels/Reset Windows to Original Layout" from the “File” menu of the Toolbox.

The centre window is the Canvas Window. A new Canvas Window appears each time Synfig Studio starts. The window represents the Root Canvas. In the upper left corner of the Canvas Window, you'll see a button with a caret. If you click on this caret button, the canvas window menu will pop up. If you right-click on the canvas area and there is no Layer under the mouse position, this menu will also appear. The other two windows (one on the bottom, and one to the right) are customizable dock dialogs. Each dock dialog contains a set of panels, arranged horizontally or vertically. Some panels share the same space inside the dock dialog and you can switch between them by clicking on their tabs. You can rearrange the contents of dock dialogs as you wish by dragging the panel tab to your need. You can even create a new dock dialog by dragging a tab out of its dock dialog. If you accidentally close a panel, (by dragging it out of the dock dialog or closing the new dock dialog that gets created) you need not worry. Simply go to the Toolbox, select "File/Panels" in menu and click on the name of the panel you need.

The most important panels are:

- **Layers Panel** — shows the hierarchy of the layer of your working canvas. It also allows you to manipulate these layers.

- **Parameters Panel** — shows the parameters of the layer currently selected. When multiple layers are selected, only the parameters that the selected layers have in common are displayed.
• **Tool Options Panel** — shows any options specific to the currently selected tool.

• **Navigator** — shows a thumbnail image of what the currently selected canvas looks like. You can also zoom in and move the focus around with this panel.

• **History Panel** — shows you the history stack for the current composition. You can also edit the actions in history.

There are also many other panels in Synfig Studio. In order to know what a panel does, simply hold the mouse over its icon and a tooltip will pop up describing its function.
First steps

Let's create something to work with.

First, go over to the toolbox and click on the Circle Tool (if you don't know which one it is, just mouse over them until you find the one with the tooltip that says "Circle Tool").

When you click on the Circle Tool, you should notice that the Tool Options Panel has changed. But we'll get to that later.

With the Circle Tool selected, you can now create circles in the Canvas Window. This works as you might expect — click on the canvas, drag to change length of the radius and release the mouse button when you are done. Go ahead and create two circles. If you accidentally release the mouse button before dragging, you end up creating a circle with 0 radius and it is effectively invisible! However, you can easily fix this. In the Parameters Panel, you can change the parameters of the selected object. If you just made a 0 radius circle, it should be the current selected object. You can change its radius to some value other than 0, say 10 and manipulate it to your liking with the handles later.

Note

Some users might experience the following problem: when you click and drag on the canvas using the Circle Tool, either nothing seems to happen or you end up making insanely huge circles. To fix this, go to "File/Input Devices" and disable all the devices you can find there.

Now go back to the toolbox and click on the Transform Tool (the button with the arrow on it). After you do this, click on one of your circles. You will see a "bounding box") a green dot at the centre and a cyan dot on the radius. Those dots are called "Handles". If you want to modify the circle, grab a handle and drag it around.

You can select a Layer by clicking on it. If you want to select more than one layer, hold down Ctrl key while you are clicking — this works in both the Canvas Window and the Layers Panel. You can do this in several ways. First, you can hold down Ctrl and individually click the handles that you want to select, but this can be tedious. However, there is a much faster method — just create a selection box by clicking the mouse and drag it over the handles that you want.
Go ahead, select two circles and select all of their handles. With several handles selected, moving one handle will move all of them.

**Note**

Synfig Studio has an auto-recovery feature. If it crashes, even if the current file has not been saved, you will not lose more than 5 minutes of work. At restart, it will automatically prompt you to recover the unsaved changes. Unfortunately history isn’t recovered yet.

The rotate and scale tools work much like the Transform Tool, except in the case where you have multiple handles selected. Select a few circles then select all of their handles and try using the rotate and scale tools.

Note that tools manipulating with handles have options associated with them. If a particular tool isn’t doing what you want, take a look at the Tool Options Panel to see the available options.

**Linking**

Suppose we always want these two circles to be of same size. Select two circles and then select both of their radius handles (the cyan dots).

To select multiple handles, you have to either drag a rectangle around them or select the first one and then hold the Ctrl key while selecting the rest. Once you have selected the two radius handles, right click on either of them and a menu will pop up. Select "Link". Now the parameters are linked together. You can prove it to yourself by selecting just one of the circles and changing its radius.

Linking is a fundamental concept in Synfig. You can create links not only for handles, but also between parameters as well, by selecting multiple layers then right clicking on the parameter in the Parameters panel and selecting "Link".

**Colour selection**

Let’s say you want one of the circles to be a different colour. If you look in the toolbox below the tools, you’ll see the outline/fill colour selector, the outline width selector and some other stuff like the default blend method and gradient. The outline/fill colour widget works exactly as you might expect — you can click on the
fill colour and a modest colour chooser will appear. Now you can change the colour pretty easily.

But sometimes you may just want to click on a colour and go. This is where the palette editor tab comes in.

Click on the Palette Editor Panel tab and have a look — it's the one with the palette-ish looking icon. Clicking on colours with the left mouse button will immediately change the default outline colour and clicking with the middle mouse button will change fill colour.

That's all great, but we still haven't changed the colour of the circle. There are three ways to do this. The first is to click on the "Fill Tool" from the toolbox and then click on the circle in the Canvas Window. This works with more than just circles. Also, you can select the circle layer you want to modify. Go to the Parameters panel, right-click on the Colour parameter and select "Apply Fill Colour" or "Apply Outline Colour" at your preference or simply double-click on the "Colour" parameter - a colour selector dialog will show up and you can just tweak away. To start, try out to set the Feather Parameter to 5.

**Animation Basics**

Creating an animation in Synfig Studio is really easy. It basically means to change a drawing — you just need to create the first stage and last stage of a change and Synfig takes care of the steps in between.

Let's look at a simple example. Consider a moving light like the one at the front of the Knight Rider car. Drop the realism, you get a circle moving from left to right and back. In other words, you need to create three 'steps' or 'stages':

1. The circle is on the left.
2. The circle is on the right.
3. The circle is back on the left.

**Setting up**

Let's do it. Start Synfig Studio. A new file is created at the start automatically. Click the caret menu (between the horizontal and vertical rules, in the top left hand corner of the canvas), then
select "Canvas/Properties" or select "Canvas/Properties" from the menu and the Canvas Properties Dialog will appear.

Now we need a circle. Change the fill colour to red, select the Circle Tool and create a circle. It doesn't matter if it's not perfect: You can edit it. Select the Transform Tool and click the circle. It will go into an editing mode which is easy to detect by the small green dot in the middle and the white rectangle around it. You can move the circle by grabbing it on its green dot (the Origin) in the middle.

Give a name and description for your canvas, then click "Apply" (don't click "OK" yet — we're not quite done with the Properties dialog). Go to the "Time" tab and make sure to edit "End Time". Change "5s" to "2s" — that will make our animation 2 seconds long. Now click "OK". Select the Rectangle Tool and create a simple black rectangle that will serve as our background.

These are the first steps to draw an object and to move it, but not an animation yet.
Adding movement

In the beginning, you entered a value of 2 seconds in the Properties dialog. Because the length of your animation is non-zero, your canvas window (the one where you draw) has a grey time slider at the bottom of the Timebar. You can click on it and a small orange indicator will appear indicating your position in time. Try clicking in several places on the time slider and you will notice that the entry field on the left of the time slider is changing its values to something like "12f", "1s 15f", etc. You can set your position on the time slider by changing values in that field. For example, if you enter "1s" and press Enter, the orange indicator will move in the middle of the time slider and entering "2s" will move it to the end of the time slider.

Note:

At 2s the orange indicator won’t be visible. That’s because "2s" is at the far right boundary of the time slider, putting the indicator out of view.

You may notice that nothing changes on the canvas at this point. Return to "0s" and switch to Animate Editing Mode by clicking the green man button to the right of the grey time slider. The canvas will display a red outline. It reminds you that changes to your objects now affect your animation at the time shown in the time slider.

In animate editing mode, every change to your object’s parameters creates a waypoint that associates the changes with the current time. As you will see, Synfig can create smooth intermediate changes between waypoints and you can even choose the way in which the intermediate changes take place. You will probably find it helpful to associate some or all of your waypoints with keyframes.
Previously, three "steps" or "stages" were mentioned. These are represented by keyframes. (Just in case you're familiar with video encoding: No, it's not the same!) A keyframe is an image in time where something important happens with your objects.

Default keyframe at 0f when creating a new project- a default "keyframe" is already set at 0f. If for any reason you do not have this default keyframe, go to the Keyframes Panel — click on the little tab with the small key icon in the bottom window to edit keyframes. Now press the small button with the "plus" sign and you should get a new entry in the list displaying "0f, 0f, (JMP)". Now, go to the "1s" mark in the time slider. The small orange indicator should move there. Then add another keyframe by clicking the small plus sign. Repeat the process with the time slider indicator set to "2s" (it's at the end of your animation). You should now have three keyframes in the list.

**Understanding the Timeline**

By now, you may have figured out what those mysterious "1s 10f"-type marks represent. They indicate a specific point on the timeline, expressing a location in terms of seconds (s) and frames (f). By default each second is divided into 24 frames, much like a meter on a measuring tape is divided into 100 centimeters. The frame markings begin at zero (0) and go up to 24, whereupon a new second frame is entered and the frame-count returns to zero.

For example, when five whole seconds and three frames have passed using this, the timeline notation would be "5s 3f".
The Keyframes Panel

The Keyframes Panel is rather easy to understand. It displays "Time" which is basically the start time, "Length" which is self-explanatory, "Jump" which we’ll cover next, and "Description" which is, again, self-explanatory.

You might be wondering about the entries called ")(JMP)". In fact, these are links just like web links: click them and the indicator in your time slider will jump to the correct time.

You can use this to edit your image for a given moment in time. For instance, you can now jump to the first second and move the red circle to the right.

To see your animation click at an arbitrary position on the time slider: You will note that the red circle is in a new position, one that you didn't specify! So what happened? Synfig figured out what you would like to do, namely move the circle and drew all the images between these states. Each image will later make a frame in your animation and the circle will appear to be moving.

Note that you don't need to go to the last keyframe at "2s" and move your circle back to the left. Keyframes make Synfig remember the image states at particular times. That's why when we modified the circle's position at "1s", it stayed on the left at "2s" (as well as at "0s"). If you switch back to the Parameters Panel and look at the Time Track Panel, you will see that three orange diamonds (or green dots depending on the default interpolation) appeared on the right of the "Origin" parameter. Those are called Waypoints and they represent times at which object's parameters
like location or colour are instructed to take on specified new values.

Rendering your animation

![Screenshot]

Before you can see your animation, you need to render your work. There are two ways to do so: using the Synfig Studio (what you have been using so far) or the command-line program called "Synfig".

Let's try the first way. Leave the Animate Editing Mode by clicking on the red man icon in the timeline editing widget and save your file, for instance under the name "BasicKnightRider.sifz". Then go to menu in the Canvas Window (Canvas Menu Caret button in the upper left corner) and select "File/Render" or click on the render icon. Change the filename to "BasicKnightRider.gif" in the same location where you saved "BasicKnightRider.sifz" and choose "gif" target format instead of "Auto", then click "Render". Depending on your processor speed it should take a few moments, but finally a message should be displayed in the image window status bar (located on the bottom of the window) which says "File rendered successfully".

Note

The "magick++" target (if it is available) produces much better gif files than the "gif" target because it can optimize the palette for the image.
Open BasicKnightRider.gif in Firefox or another application that is able to show animated GIFs. However, Firefox will replay the GIF all the time which makes your short animation a rather long one. If there is a red circle moving from the left to the right and back. Now the animation is ready.

Note
You can also preview your animation. Press the "caret" menu button in the upper left corner of the Canvas Window and choose"File/Preview".

If you would rather use the command line instead of the menu to render your animation, then open a terminal (on Windows, go to "Start/Run", type "cmd" and press Enter), change to the directory you saved the file in and type: synfig -t gif BasicKnightRide.sifz

A few messages appear that don't matter right now. Depending on your processor speed it should take a few moments, but finally a line like this will appear:

BasicKnightRider.sifz ==> BasicKnightRider.gif: DONE

You can view your animated gif using Firefox or another program as mentioned above.

Adding Layers

In the previous tutorial, you made your first simple animation by changing the attributes of primitive objects, such as: position, colour and size. These simple types however, are self sufficient to create advanced characters and objects. To do so, Synfig uses layers. They are similar to layers used in other drawing applications in that they are used to separate different elements of an image.

However, Synfig's layers have the following important features:

1. Every object or element gets its own layer.
2. You can organize layers into hierarchical groups.
3. You can use upper layers to change the behavior (or look) of underlying layers. Those are called filter layers or effect layers.
Combining layers

Let's look at a simple example of how we can combine two layers to create a gradient effect on a rectangle.

Create a new file with 0 duration. There's no need to bother with a timeline at this point. Next, create a simple rectangle with the Rectangle Tool.

Pick the Gradient Tool from the Toolbox, press the left mouse button on the canvas while dragging it to change the gradient direction and then release the button when you are done. You should note that another layer was added in the Layers Panel called Gradient.

**Note**

If you see no gradient but just a plain colour, it means that you probably clicked on the canvas without dragging your mouse. To fix that, pick the Transform Tool, click into the canvas, to activate the gradient's handles. You need to grab the one you see and move a bit until a gradient appears.

You now have a gradient, but it is not what you wanted as it spreads across the whole canvas. The goal was to have a gradient in the rectangle. So, let's fix this now. In the Layers Panel, select both the gradient and the rectangle layer. Then, right-click and select "Group Layer" from the menu. The view of your Layers Panel should change now, showing a small box called “Group” with a "+" in front. By clicking on the "+" you can expand the group layer to see its contents, your previous two layers: the gradient and the rectangle.
Using locality

However, there is still a problem: the gradient still covers the whole canvas although we wanted it to be restricted to the rectangle. To do so, activate the gradient layer in the Layers Panel. Now go to the Parameters Panel (by default it resides in the bottom window) and search for the attribute called "Blend Method". Double-click the entry and select "Onto" from the drop-down menu.

The gradient should now be restricted to the rectangle. The first effect is applied by interacting layers with Synfig.

Modify layers with other layers

Make sure you have the group layer selected and create two red circles. They will appear on top of the group layer. Select the group layer and use the "Raise Layer" button in the Layers Panel to place it on top of the circles.

Now our group layer (with rectangle and gradient) is in front of those two circles.

Expand the group layer to show its contents and select the top layer inside it (should be the gradient layer). This is where we require inserting a new layer. Create another circle filled with a black colour. The black circle layer will be created over the gradient layer inside the group layer.

Now, right click on the black circle layer in the layers panel and a popup menu will appear. The first item in that popup is "New Layer". Inside the "New Layer" menu, you'll see several categories of layers you could create, but what we want is a blur, so go to the blurs category and select the "Blur" layer.
The blend method for newly created blur is "Straight" (if the default blend method in the Toolbox is set to "By Layer Default"). It blurs all around the outside edge of the contents of the group layer. You can change the default blend method for new layers from the New Layer Defaults section of the Toolbox.

Now we have all of the contents of the group layer blurred, but everything under it is sharp! This is because the effect of the Blur Layer over the underlying layers is limited to the scope of the group layer as the blur layer is inside it.

**Animating Shapes**

**Basic settings**

First, we need to create a gradient for a background. Click on the outline and fill colours in the Toolbox to select the colours of our gradient. You can also directly edit the gradient by clicking the gradient line in the toolbox.
Now that the trace of the form is closed, select the transform tool (or any another tool) to generate the proper form. This will be the base of the stem. You can tweak the tangent handles (red dots) a bit to make a rounder triangle. With the Transform Tool, right-click on each vertex and select "Split Tangents", so that the tangent handles of each vertex can be moved separately.

Select the Gradient Tool and drag your cursor vertically across the canvas to fill it with the gradient. Next select the Spline Tool and in the Tool Options Panel, make sure that only "Create Region Spline" is checked. In the tool box, set the fill colour to green. Draw a triangle with the Spline tool. To close the shape after drawing the 3 vertices, right click on the first vertex and choose "Loop Spline".

**Animate the stem**

In the Canvas Menu, select the caret menu icon in the upper left hand corner, where the rulers intersect and select "Canvas/Properties". Go to the "Time" tab, set the "End time" to "6s" and click OK button. Click at the beginning of the timetrack ("0f") then, in the Keyframes Panel (the one with a key icon) click the button with a "+" icon (add a new keyframe). Keyframes allow
us to settle down the scene i.e. on a keyframe every element of 
the scene will have all its properties remembered. Click again on 
the timetrack at "4s 12f" (ie 4.5s at 24 fps) and press the green 
circle at the bottom right of the canvas (or whatever icon you have 
there, depending on your icon theme) to switch to the Animate 
Editing Mode (the circle is now red).

With the Transform Tool, select the green sprout and move the 
upper vertex to make a stem. You can play with the vertex handles 
to bend the shape a bit if you want. While you are still at "4s 12f",
right-click on the stem border, close to the top and choose "Insert 
Item". Do the same on the other side of the stem. Right click on 
those new points and choose "Split Tangents". Then try to make a 
shape that looks like the one on the image, to create the flower 
bud. Right-click on them in the parameters list and select "Mark 
Active point as off".

The greyed parts are those parts where the bud vertices have no 
effect on the stem. Now if you click on "2s" (for example), the 
shape of the bud is slightly visible, even if the sprout is rather 
small and even if the bud handles are invisible. Let's say we want 
the bud to appear only at 3s 12f and be of full size at 4s 12f.

Click on "3s 12f" on the time track. Now take a look at the 
"Parameters" and "Time track" panels at the bottom. You'll see 
that each parameter in the Parameters Panel matches a row in the 
Time Track Panel. The last parameter is the vertices list. Click on 
the small arrow on the left to unfold the list. Each brown diamond
(or waypoint) stands for a recorded value (here the vertices positions were recorded at 0f with the key frame and at 4s when we moved some vertices or vertices handles). The two vertices we added to make the bud are marked with green and red vertical line on their 0s and 4s waypoints.

For example if you click on "2s" or even "3s" now, the bud shape is not visible. It starts to appear only a little after 3s 12f.

However, the shape of the stem may not look very nice during its growth between 0 and 4s. Make sure you're still in Animate Edit Mode, and tweak the shape at various moments in time, to get something you like. The animation of the stem is now finished, but it still lacks the petals. You can watch a preview of your animation: Go to "File/Preview", validate, wait for the preview to be generated, and watch.

**Note**

Previews are often pixelated and blurry, but the final render will be clean-cut. Higher quality previews are obtainable by using higher values for 'Quality' and 'Frames per second' in the preview dialog window.

**Adding the petals**

Now leave the "Animate Editing Mode" by clicking on the red circle at the right bottom of the canvas.

Change the fill colour to pink and create a petal with the Spline Tool. You'll notice that the green handle that allows easy movement of a shape is at the centre of the canvas. Select all the vertices of the petal with Ctrl + A and move them close to the green handle (with the Transform Tool), as shown.
Then drag the green handle very close to the top of the bud. Hit Ctrl+A again to select all vertices of the petal and tweak it a bit with Rotate Tool. Also, in the Layers Panel select the petal layer and put it under the stem layer. Click on the petal to select it, then ctrl+leftclick on the stem. Both objects should be selected. Now click on the vertex at the top of the stem and ctrl+leftclick on the green handle of the petal (both should appear in a lighter colour, as they are selected). Then right-click on the stem top vertex and select "Link". The petal will move a bit as the green handle is snapped on the stem vertex.

Now that there's a link between the petal and the top of the stem, when the top of the stem moves, the petal will follow it. (And if the green handle of the petal moves, the top of the stem will move, but we don't want to do that here.)

On the Layers Panel, select the newly created Petal layer and duplicate it (with the third button, on the bottom of the Layers Panel). On the canvas, press Ctrl+A to select all the vertices of the duplicated petal, and move them a little, so the petals are no longer overlaid. (Don't move the green handle, just the orange ones). Repeat the process several time, to get something looking like this image.

Note that the duplicated petals are also linked to the stem. If you go back to the first keyframe, you'll see that the petals are visible. We don't want that. We want the petals to appear and bloom almost at the end of the growth.

**Hiding the petals**

Let's say we want the petals to appear a little after 4 seconds in the animation and be full size at 5 seconds, instead of being visible and full size all the time.
Switch to "Animate Editing Mode" again by clicking on the green circle at the bottom right of the canvas. But if we will go to "4s" and modify them, then they also change at "5s". This is because the shape/position of the petals is not fixated at this moment of time by any waypoints or keyframes. That means we need a keyframe at "5s". Click to place the cursor at 5 seconds on the timetrack. Next, on the Keyframes Panel, click on "+" to add a new keyframe.

Now click on "4s" and on the Layers Panel, select all the petals layers (with ctrl+leftclick), then press Ctrl+A to select all the petals vertices. Scale them down with the Scale Tool and move them, so they are hidden by the stem, as shown.

From 4s to 5s, the petals will now appear and bloom. But notice that we have a keyframe at 0s which also remembers petals shape. That makes the problem — the petals are still visible from the first keyframe to the 4s keyframe. We could either make the petals tiny and hidden tweaking their size on every frame from 0s to 4s, or we could make them invisible on this interval.

Let's choose the second solution. To make things easier, we are going to group the petal layers into a Group Layer. With the entire petal layers selected, right-click on them on the Layers Panel and select "Group". You can rename the layers to make things easier to understand. Select the Petals Group Layer and jump to the first keyframe. In the Parameters Panel, set the "Amount" value to "0". The petals are now invisible on that keyframe. Note that two waypoints were added in front of the "Amount" parameter, one at 0s and the other at 5s. Drag the 5s waypoint to 4s, so that the opacity of the petals will be 1 at 4s.

There is still one problem left: from 0s to 4s, the opacity of the petals slowly increases, making the petals visible when they shouldn't. To solve this, we will change the Amount interpolation method. Right click on the Amount waypoint at 0f and select "Edit". A new dialog will appear, in which you can choose the In and Out interpolation. Set the Out Interpolation to "Constant".
Tip

You can also change waypoint out interpolation by right-clicking on it and selecting "Out/Constant". This means that after that waypoint, the Amount value will remain constant until another waypoint is encountered. So from 0f to 4s the Amount value will be equal to 0 and at 4s it will suddenly change to 1 and make the petals visible, as expected.

Alternatively, we could have achieved the same effect by setting the In Interpolation of the waypoint at 4s to "Constant". Notice how (half of) the waypoint changes from a green circle (meaning smooth animation of the amount parameter) to a red step (meaning that the amount parameter is suddenly stepped).

Now you're done. The stem grows for 4.5 seconds and staystill the last 1.5 seconds. The petals are hidden until 4 seconds and then grow quickly between 4 and 5 seconds and stay till the last 1 second too. Click on "File/Render" to render your animation. Select any format you want and ensure that "Use current frame" option is unchecked (otherwise, only one frame will be rendered). In the next and last part, we will be covering the basic usage of the bone system in Synfig.
Unit summary

In this unit, you’ve learned:

- The use of Synfig vector 2D animation in open source software
- The various functions of Synfig like toolbox, canvas, panel
- The process of adding colours, linking, and animation basics
- The process of animating shapes and adding layers.

Assessment

1. What is Synfig software?
2. What are the three main interfaces of Synfig studio?
3. List important panels and their function?
4. Which tool helps in changing the colour of the object?
5. What are the two important parameters of circle tool?
6. Which operation controls the layer of visibility?

Resources

Reading

https://wiki.synfig.org
www.gimp.org
docs.gimp.org
www.nisd.net
www.gimp2tutorials.info
www.dotputs.de