Acknowledgements

The following people and institutions are warmly thanked for their contribution to the CCNC materials:

Dr Wayne Mackintosh, Otago Polytechnic, New Zealand and formerly COL Education Specialist, for conceptualising and initiating the development of CCNC.

ICDL South Africa for providing OpenICDL materials of which these modules are a derivative work.

The South African Qualifications Authority (SAQA) for creating an accredited set of standards for the development of the materials.

Developers of the 7 modules (in alphabetical order):
Tasneem Davids, University of the Western Cape, South Africa
Norina Finger, University of the Western Cape, South Africa
Nancy Hallberg, The Pennsylvania State University, USA
Prof. Uma Kanjilal, Indira Gandhi National Open University, India
James Kariuki, University of the Western Cape, South Africa
Faghad Khan, University of the Western Cape, South Africa
Dr. Pankaj Khare, Indira Gandhi National Open University, India
Carolynne Kies, University of the Western Cape, South Africa
Olabisi Kuboni, University of the West Indies, Trinidad & Tobago
Stewart Marshall, University of the West Indies, Barbados
Thembelani Ngenelwa, University of the Western Cape, South Africa
Peter Rawsthorne, M.Ed IT, B.Tech, Learning Systems Architect, Canada
Juliet Stoltenkamp University of the Western Cape, South Africa
Ken Udas, The Pennsylvania State University, USA

Susan Dark, Open Polytechnic of New Zealand (OPNZ) for assisting with the collaborative design and reconfiguration of the Open International Computer Driving Licence (ICDL) materials.

Bob Byrne, Thompson Rivers University, BC, Canada for reviewing, writing, completing and editing the existing materials created for the CCNC.

Trudi van Wyk, Education Specialist, eLearning for final editing and finalising the materials.

Members of the WikiEducator community who have provided comments and feedback.

In addition, for critical review, we thank:
- Dr Carol Bohlmann, South Africa
- Dr Jonathan Miller, South Africa
- Prof Asha Kanwar, Vice President, COL

Commonwealth Secretariat and Commonwealth of Learning for financing the initiative.
The Commonwealth of Learning (COL) is an intergovernmental organisation created by Commonwealth Heads of Government to encourage the development and sharing of open learning and distance education knowledge, resources and technologies.

-----------------------------

Commonwealth of Learning, 2009

Any part of this document may be reproduced without permission but with attribution to the Commonwealth of Learning.

CC-BY-SA (share alike with attribution)
http://creativecommons.org/licenses/by-sa/3.0

Attribution Statement:
These course materials are a derivate work of the Open ICDL (www.openicdl.org.za)

-----------------------------

Commonwealth Computer Navigator’s Certificate
Free computer and software skills training for developing countries

Published by:

Commonwealth of Learning
1055 West Hastings, Suite 1200
Vancouver, British Columbia
Canada  V6E 2E9

Telephone: +1 604 775 8200
Fax: +1 604 775 8210
Web: www.col.org
E-mail: info@col.org
Introduction

Commonwealth Computer Navigator's Certificate (CCNC)

The Commonwealth of Learning (COL) conceptualised the Computer Navigator's Certificate (CCNC) in 2006. The CCNC widens the available learning and training options in the Commonwealth by acquiring ICT skills using free open-source software. It furthermore eliminates concerns about the illegal use of proprietary software.

The CCNC materials (Version 1.0) have been developed to the International Computer Driver’s Licence (ICDL) International Standard (www.icdl.org.za) using Open Office on either a Linux or Windows Platform. The materials are based on the ECDL/ICDL Syllabus Version 5.0 (www.ecdl.com).

The following 7 modules have been developed:
Module 1 - Basic Concepts of Information and Communication Technologies
Module 2 - Using a Computer and Managing Files
Module 3 - Word Processing
Module 4 - Spreadsheets
Module 5 - Database
Module 6 - Presentation
Module 7 - Information and Communication

The CCNC is open to participation from local tertiary education institutions, non-governmental organisations (NGOs) and private-sector training institutions throughout the Commonwealth interested in adopting the certificate in their own offerings. Alternatively, they can use the materials to obtain the full Core OpenICDL Qualification (http://www.icdl.org.za/products_detail.php?id=6).

COL envisages taking these modules further and developing e-learning formats using a share-alike rights licence.

The CCNC materials (Version 1.0) are available on the COL website.

The materials were developed with financial support from the Commonwealth Secretariat.

For more information contact:
Trudi van Wyk
Education Specialist: eLearning
Commonwealth of Learning
1055 West Hastings Street, Suite 1200
Vancouver, BC V6E 2E9 Canada
Tel: +1 604 775 8261
Fax: +1 604 775 8210
e-mail: tvanwyk@col.org
Web: www.col.org/ccnc
The Use of Icons in the Materials

While working through these modules you will notice the frequent use of margin icons. These icons serve to “signpost” a particular piece of text, a new task or change in activity - they have been included to help you to find your way around these materials.

A complete icon set is shown below. We suggest that you familiarise yourself with the icons and their meaning before starting your study.

<table>
<thead>
<tr>
<th>Outcomes</th>
<th>Knowledge</th>
<th>Summary</th>
<th>Study Tips/Skills</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tip</td>
<td>Note</td>
<td>Practice on the computer</td>
<td>Self Assessment</td>
</tr>
</tbody>
</table>
Module 1

Concepts of Information Technology

Module Overview

Welcome to Module 1: Concepts of Information Technology. This module provides necessary theoretical knowledge to understand the functioning of a modern computer, its capabilities and applications in everyday life. It also discusses information networks, data security and copyright issues.

Upon completion of this module you will be able to:

- Understand what hardware is, know about factors that affect computer performance and know about peripheral devices.
- Understand what software is and give examples of common applications software and operating system software.
- Understand how information networks are used within computing and be aware of the different options to connect to the Internet.
- Understand what Information and Communications Technologies (ICTs) is and give examples of its practical applications in everyday life.
- Understand health, safety and environmental issues in relation to using computers.
- Recognise important security issues associated with using computers.
- Recognise important legal issues in relation to copyright and data protection associated with using computers.

Terminology

<table>
<thead>
<tr>
<th>Hardware</th>
<th>The physical part of a computer, including its digital circuitry.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Personal Computer (PC)</td>
<td>A general-purpose computer whose price, size and capabilities make it useful for individuals.</td>
</tr>
<tr>
<td>Central Processing Unit (CPU)</td>
<td>Device that controls the operations of all the hardware of the system and is responsible for storing and retrieving information on disks and other media.</td>
</tr>
<tr>
<td>Term</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Primary Memory</td>
<td>Provides temporary storage of programs in execution and the data being processed.</td>
</tr>
<tr>
<td>Random Access Memory (RAM)</td>
<td>Memory that holds information for the operating system and applications while the computer is running.</td>
</tr>
<tr>
<td>Read Only Memory (ROM)</td>
<td>Forms the basic instruction set for operating the hardware in the system.</td>
</tr>
<tr>
<td>Bit</td>
<td>The smallest unit of computer data, represented by a zero or one.</td>
</tr>
<tr>
<td>Byte</td>
<td>A set of eight bits.</td>
</tr>
<tr>
<td>Input</td>
<td>The process of getting data into a computer through devices such as a keyboard, mouse, or scanner.</td>
</tr>
<tr>
<td>Output</td>
<td>The process of getting data out of a computer through devices such as a monitor or printer.</td>
</tr>
<tr>
<td>Storage</td>
<td>Devices that store computer data for a long term, such as hard drives, CD-ROM, or flash memory.</td>
</tr>
<tr>
<td>Software</td>
<td>The non-physical part of a computer; programs and documentation that play a part in a computer system’s operation.</td>
</tr>
<tr>
<td>Systems software</td>
<td>Programs that enable the computer to function, improve its performance and access the functionality of the hardware.</td>
</tr>
<tr>
<td>Application Software</td>
<td>Programs that enable the user to achieve specific objectives such as create a document, use a database, produce a spreadsheet or design a building.</td>
</tr>
<tr>
<td>Graphical User Interface (GUI)</td>
<td>Simplifies the work of the user whether by providing an interface that includes icons, folders and point-and-click functionality.</td>
</tr>
<tr>
<td>Systems Development Life Cycle (SDLC)</td>
<td>The stages of development of computer programs.</td>
</tr>
<tr>
<td>Local Area Network (LAN)</td>
<td>A group of computers within the same building, or within a group of buildings that are in close proximity, that are connected together.</td>
</tr>
<tr>
<td>Wide Area Network (WAN)</td>
<td>A group of widely dispersed computers that are connected together.</td>
</tr>
<tr>
<td>Client-Server</td>
<td>A network of computers that have special</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>----------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Network</td>
<td>dedicated tasks (servers) and computers that make use of the services (clients).</td>
</tr>
<tr>
<td>Peer-to-Peer Network</td>
<td>Network on which all computers have equal status.</td>
</tr>
<tr>
<td>Intranet</td>
<td>A collection of all computers within an organisation that can access each other in some way.</td>
</tr>
<tr>
<td>Extranet</td>
<td>An extension of an organisation’s intranet to include outside users.</td>
</tr>
<tr>
<td>Internet</td>
<td>The collection of all computers across the world which can access each other in some way.</td>
</tr>
<tr>
<td>World Wide Web</td>
<td>Part of the Internet that consists of all the sites that can be accessed using a web browser such as Mozilla, Internet Explorer, Opera or Google Chrome.</td>
</tr>
<tr>
<td>Ergonomics</td>
<td>The science of co-ordination of the physical and psychological aspects of human beings with their working environment.</td>
</tr>
</tbody>
</table>
Computer Hardware

Section overview

Welcome to this section on Computer Hardware. After studying this section you will be able to:

- understand the term “hardware”.
- understand what a personal computer (PC) is.
- distinguish between a desktop, laptop and tablet PC.
- identify common handheld devices.
- know the main parts of a computer.
- understand the functioning of the central processing unit (CPU).
- know the factors that affect computer performance.
- know about different types of computer memory, input/output devices and storage devices.
- know the common input/output ports.
- identify some common input/output devices.

Main Concepts

What is computer hardware?

Computer hardware is the physical part of a computer, including its digital circuitry, as distinguished from the computer software that executes within the hardware. The central processing unit (CPU), monitor, keyboard, mouse, etc. are some examples of computer hardware.

Personal computers

A personal computer (PC) is any general-purpose computer whose original price, size and capabilities make it useful for individuals and which is intended to be operated directly by an end user, with no intervening computer operator. Personal computers are available in a number of configurations, including desktops, laptops and tablet PC.

Desktop PC

A desktop PC is a personal computer that is designed to be stationary, as part of an office or desktop, rather than portable. Typically the computer is housed inside a metal or plastic case, along with devices such as the power supply, cooling system and a CD, DVD and/or USB drive. The monitor, keyboard, mouse and other peripherals are usually separate from the main computer.
Laptop PC
A laptop PC is designed with portability in mind. The monitor, keyboard and computer are combined into one unit. This type of computer weighs much less than a desktop PC and usually fits inside a carrying case and can be moved easily from place to place.

Laptop PCs often have all of the features of a desktop PC built in, including a sound system, network capability and camera. In addition, they usually have wireless network capability so that users can connect to networks wirelessly when they travel.

Laptop PCs have some limitations due to their small size. Typically the processors used in Laptop PCs are not as fast as those in desktop PCs because of overheating concerns. Also, laptop PCs are often more expensive than a desktop of similar capability.

Tablet PC
A tablet PC is similar to a laptop PC, but is equipped with either a touch screen or graphics tablet so that the computer can be operated with a stylus or fingertip. Some tablet PCs also come with a keyboard, making them more similar to laptops.

Originally, tablet PCs were designed to run with Windows XP Tablet Edition, but versions of Linux can be installed easily.

Handheld portable devices
A handheld portable device or simply handheld is a pocket-sized computing device, typically having a display screen with touch input or a miniature keyboard. In the case of the personal digital assistant (PDA) the input and output are combined into a touch-screen interface. Smartphones and PDAs are popular amongst those who require the assistance and convenience of a conventional computer, in environments where carrying one would not be practical.

Portable media players are a type of handheld device used to play audio or video files. They typically have an audio port through which headphones are used and may have a small screen for video. More commonly, handheld devices are being designed to combine the functions of a PDA, phone, camera and media player in one device.
The main parts of the computer

Following are the main parts of a computer:

- case/chassis
- cooling system
- motherboard
- CPU (central processing unit)
- input/output ports
- memory
- hard drive
- sound system
- power supply
- input/output devices (monitor, keyboard, mouse, printer, etc.)

Computer Performance

Computer performance is characterised by the amount of useful work accomplished by a computer system compared to the time and resources used.

Depending on the context, good computer performance may involve one or more of the following:

- short response time for a given piece of work
- high throughput (rate of processing work)
- low utilisation of computing resource(s)
- high availability of the computing system or application
- fast (or highly compact) data compression and decompression
- high bandwidth/short data transmission time

What can affect computer performance?

- The number of programs that automatically run during startup,
- The number of applications opened at the same time.
- Memory capacity.
- Disk space.
- Clock rate.

Central Processing Unit (CPU)

At the core of every computer is a device known as the central processing unit, or CPU in short. The CPU, generally referred to as processor, is the brain of the computer. The CPU reads and executes program instructions, performs calculations and makes decisions. It controls the operations of all the
hardware of the system and is responsible for storing and retrieving information on disks and other media.

On large computers CPUs require one or more printed circuit boards. In the case of PCs and small workstations they are housed in a single chip called a microprocessor.

**Parts of the CPU**

There are three main components to the CPU: the Arithmetic and Logic Unit (ALU), the Control Unit and Primary Memory.

**Arithmetic and Logic Unit**

The actual data processing takes place in the Arithmetic and Logic Unit (ALU) of a computer. The ALU is responsible for carrying out arithmetic operations such as (+, -, *, ^, /), logical operations such as (AND, OR, NOT) and relational operations such as (≤, <, >, ≥). All programs consist of complex sets of arithmetic and logical operations. All mathematical operations are performed in binary numbers and all logic operations through binary operations.

**Control Unit**

The Control Unit is responsible for loading and interpreting the individual instructions that constitute the computer program. These instructions are in a language called machine code represented in a pattern of ones and zeros. The Control Unit also has the task of fetching the data needed by the instructions and returning the results after the instruction has been executed.

The Control Unit controls and coordinates all hardware operations. The ALU responds to commands from the Control Unit. The primary functions of Control Unit are to:

- read and interpret machine language instructions
- control transmission of data between ALU, registers, caches, primary memory and auxiliary memory
- control sequence of execution of program instructions
- direct ALU to mathematical or logic operations

**Primary Memory**

Primary Memory provides temporary storage of programs in execution and the data being processed. It is an immediate access storage device. Primary Memory is covered in detail in the section on Memory and Storage.
Speed of the CPU: The CPU operates as a result of electronic pulses sent to it by another device on the motherboard called the clock. The speed of a CPU is measured by the maximum number of pulses it is able to handle. This is measured in MHz (megahertz) or GHz (gigahertz):

\[
1 \text{ MHz} = 1 \, 000 \, 000 \text{ pulses per second} \\
1 \text{ GHz} = 1 \, 000 \, 000 \, 000 \text{ pulses per second}
\]

A good personal computer will use a CPU with a clock speed of over 3 GHz. This means it receives 3 000 000 000 million pulses every second from the CPU.

Previously CPUs could only do one operation per pulse but with advances in technology, they have been able to improve this. For example, they can do one operation at the start of the pulse and one at the end of the pulse.

Present day systems are coming with multi-core processors. Multi-core systems allow for more than two separate processors housed in the same integrated circuit. For example, a dual processor system has two separate physical computer processors located on the same motherboard or on separate boards, but a dual-core configuration has two processors in the integrated circuit. This provides much greater processing power.

Memory and Storage

Like our brains, computers have the need for short-term memory (primary memory) and long-term memory (storage). Primary memory stores information that the CPU needs to access while the operating system and application software are running. It is memory that can be accessed very quickly. Storage memory is a place to store information
that needs to be saved for a long time, such as a word document or a digital photo.

Primary memory and storage memory work together. When you open a document you have saved on your computer, it is transferred from storage (e.g. your hard drive) to primary memory. When you are finished working with the document, it is saved back to the storage memory.

In this part we will:

- understand different types of computer memory such as: RAM (random-access memory), ROM (read-only memory) and cache
- understand the difference between primary memory (RAM and ROM) and storage memory
- become familiar with some common storage devices
- Compare the main types of memory storage devices in terms of speed, cost and capacity such as: diskette, Zip disk, data cartridges, CD-ROM, internal, external hard disk

Primary Memory

Primary memory is broken down into Read Only Memory (ROM) and Random Access Memory (RAM).

Read Only Memory (ROM)

ROM forms the basic instruction set for operating the hardware in the system. It resides on a chip on the computer main board and generally speaking does not change even when the computer is shut down (although it can be updated manually). It is the memory that is used when you first turn your computer on, before any operating systems or applications are loaded. If ROM is damaged, the computer won’t function.

Random Access Memory (RAM)

RAM is memory that holds information for the operating system and applications while the computer is running. It is volatile, constantly changing as the computer is working. Unlike ROM, RAM is completely cleared when the computer is shut down. RAM is stored on chips that attach to the computer main board and these chips can be easily changed or upgraded.

RAM is measured by its capacity to store information, typically in megabytes (MB) and gigabytes (GB). As operating systems and computer applications become more complex, the amount of RAM needed to

support the computer's operation increases. In the year 2000, a PC might have shipped with 256 MB of RAM, but systems in 2009 typically ship with 2 GB of RAM or greater.

**Cache**

Because the CPU can perform its operations much faster than data can be transferred from RAM, many CPUs have on-board cache memory. This is a type of RAM that the control unit can access very quickly and use for intermediate storage. Further, data and instructions can be loaded into cache before they are actually needed. When they are needed, the transfer is much faster than it would have been if the main RAM had been used.

**Memory Measurements**

**Bits:** In all the components of a computer, data and instructions are stored as patterns of ones and zeros. These individual ones and zeros are called bits.

In electronic components the one is stored by switching an electronic switch on and a zero by switching it off. On a magnetic material, such as the surface of a hard disk, the one may be stored with a clockwise magnetic field and a zero with a counter-clockwise field.

The reason for the use of only ones and zeros stems directly from the fact that modern circuitry makes use of electronic switches and these can only be on or off. The term for circuitry based on switches is **digital**. Arithmetic based on the use of only ones and zeros is called **binary arithmetic**.

**Bytes:** Bits are grouped together into sets of eight. A set of eight bits is called a byte.

**ASCII** or **American Standard Code for Information Interchange** was a system of representing all the characters of the western alphabet and certain special characters in a single byte. You can think of the byte as the amount of memory required to store a single character.

As there are only 256 possible variations within eight bits, this is not sufficient to represent other alphabets. As a result a new system, called Unicode, has been developed to represent all the alphabets of the world. This makes use of two bytes or sixteen bits. With two bytes 65,536 different characters and symbols can be represented.
Units of Memory

Because we use very large numbers of bytes for storage, abbreviations are used for large numbers. These are based on powers of two and are set out in the following table.

<table>
<thead>
<tr>
<th>Unit</th>
<th>Abbreviation</th>
<th>Definition</th>
<th>Approx. Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>kb</td>
<td>kilobyte</td>
<td>$2^{10} = 1024$ bytes</td>
<td>1000 bytes</td>
</tr>
<tr>
<td>Mb</td>
<td>Megabyte</td>
<td>$2^{20} = 1048576$ bytes</td>
<td>1000000 bytes</td>
</tr>
<tr>
<td>Gb</td>
<td>Gigabyte</td>
<td>$2^{30}$ bytes</td>
<td>1000000000 bytes</td>
</tr>
<tr>
<td>Tb</td>
<td>Terabyte</td>
<td>$2^{40}$ bytes</td>
<td>1000000000000 bytes</td>
</tr>
</tbody>
</table>

The capacity of hard drives is measured in bytes. A modern hard drive has a capacity of one Terabyte or more.

When files are stored on disk, the amount of space they occupy is measured in bytes. The following screen shows a partial listing of files in a directory. Notice the second column which contains the size of the file in bytes. (Don’t be concerned with the detail of this screen - it is shown purely for illustrative purposes.)
When we work with files and directories, we often need to know how large the files are or how much space a directory and its files occupies.

- One byte is one character which is a number, letter or symbol. It consists of eight bits (binary digits) and is the smallest unit of information a computer can process.
- One kilobyte is 1,024 characters and is approximately equal to one page of text in double-spacing.
- One megabyte is 1,048,576 characters and is approximately equal to one book.
- One gigabyte is 1,073,741,824 characters and is approximately equal to 1000 books.
- One terabyte is 1,099,511,627,776 characters and is approximately equal to a whole library of books.

**Storage**

Storage memory is where information is stored for a longer term, such as the files you save from your word processing program, the digital photos and videos that you store on your computer, the software programs that you have installed, or your computer’s operating system. When it is actively being used by the CPU, this information is transferred from storage memory to RAM, where it can be accessed very quickly.

When you load a software program such as Open Office or GIMP, the time lag you experience is related to the transfer of information from storage memory to RAM. Some storage devices transfer this information much more quickly than others.

Storage devices are also characterised by the amount of information they can contain.

**Storage Devices**

**Diskette**

A diskette comprises a plastic flexible disk enclosed inside a tough plastic cover. At one end is a window. When the diskette is placed inside a diskette drive, the window is pushed to the side. The read-record head inside the drive makes contact with the magnetic disk.

Diskettes are slow and have a low capacity (1.44 Mb). Since they are cheap, they still tend to be commonly used for storing small amounts of data. Another advantage is that they can be used over and over again. Unfortunately, many are not very good quality and data can become corrupted and unusable very quickly. The disks can become corrupt through many causes including disk, heat, magnetism or moisture. Because of this they are not suited to backup purposes.


**Zip disk**

A zip disk is a removable magnetic disk which fits into a special zip drive. The surface is coated with a special scratch resistant material which makes a zip disk a very robust storage device. It comes in a number of capacities: 100, 250 and 750 Mb. The speed of a zip drive is faster than all but the very fastest of CD drives. Its robustness and speed make it an excellent backup device. However, its capacity is much less than that of hard drives and tape drives which limits its use for very large amounts of data.

**Data cartridge**

A data cartridge is a tape very similar to that found in a tape recorder, only of much higher quality. These are used in a device called a tape streamer to record data. Data cartridges, especially if good quality, are reliable and cheap devices for creating backups of large quantities of data. They are, however, rather slow and are not suitable for storing information that needs to be accessed frequently. Data cartridges are sequential devices, which means that to access an item of data on them, all the preceding data needs to be read first. They are tending to become obsolete as newer, faster and more reliable technologies are available.

**CD ROM**

A CD ROM uses optical technology. When data is written, small pits are burned into the surface using a highly focused laser beam. These are read by another laser beam.

There are two types of CD ROM used for storage. The CD-R disks can only be written to once. Once data has been written to part of the surface, this part can no longer be used. CD-RW disks are designed so that one set of data can overwrite another. This allows the disks to be re-used many times.

CD ROM provides a reliable and storage medium for backing up and storing data. The speed is greater than that of a diskette but slower than that of a hard drive. Writing to a CD ROM is a much slower process than reading it. The capacity of a CD ROM is 750 Mb.
**DVD**

The Digital Versatile Disk is a development of the storage technology of the CD ROM. Using newer storage methods and higher quality media, a DVD can store about 4 Gb of data or 7.6 GB of data on a dual-layer DVD. This is enough to store a full length film.

**Hard disk drive**

A hard disk drive can be internal or external. An internal drive is housed inside the main unit and is connected directly to the motherboard of the computer. An external drive is housed inside a special caddy which connects to the computer through one of its ports on the main board.

An external hard drive is a good backup medium and allows large quantities of data to be stored. Since the same drive can be connected at different times to different computers, these drives provide a useful way of transferring data between computers that are not connected through a network. As they are electromechanical devices, they are subject to mechanical failure if not handled with care. The small 2½” drives used in laptops make excellent external hard drives since they are constructed to be moved around.

Modern hard drives commonly have capacities up to a terabyte. They are also relatively cheap in terms of the storage capacity they offer.

Because they contain moving parts, they do eventually fail. It is difficult to predict when a hard drive might fail. Any suspicious noise coming from a hard drive should be viewed with great caution and the data it contains should backed up immediately. The expected life span of a hard drive is measured as the mean time between failures. This is a very rough average of the working life. Figures of 250,000 hours are often quoted but these should be viewed with caution.

Numerous systems have been developed to protect data on hard disks. One of these is mirroring, where the data is stored simultaneous on two disks. The one disk becomes the mirror image of the other. If one fails, the data is still one the other. In this case, the first disk is replaced, the system creates a mirror image of the first disk automatically and the system continues.

There are a number of measures of performance of a hard disk. One is the speed at which the platters turn. Typically this is somewhere between 4800 and 7200 rpm, although there are faster, more expensive disks. Another is the access time. This is the time it takes the disk to access an item of data. A good figure here would be around 10 milliseconds (ms). An ms is one thousandth of a second. Disks are also sometimes compared in terms of their data transfer rates. This is a measure of how many bytes can be read or written per second.
**Flash memory**

Flash memory is another type of external memory used by memory cards and USB flash drives. These are solid state devices (no moving parts) that connect to the computer via the USB port or other ports built for a specific card type. These devices provide a very fast and reliable method of storing data externally.

Flash memory devices are typically quite small and can be made to fit directly inside digital cameras, video cameras, audio devices, smart phones and personal data assistants (PDAs). Information can easily be transferred from these devices to the computer, or between computers, by moving the flash memory.

At the moment they are more expensive per storage unit than hard drives, especially the larger capacity devices, but they make up for it in convenience and portability. They tend to be limited in their storage capacity, currently to about 32 GB, however this figure can be expected to increase quite dramatically over time.

**Online file storage**

Online file storage is an emerging technology that allows users to upload their files over the Internet to a file storage site. This is typically a free service for the storage of small amounts of data and a paid service for larger amounts.

The advantage of storing files with one of these services is that users can access their files from anywhere that there is an Internet connection. A major disadvantage, of course, is that the files can’t be accessed if there is no Internet connection. Other major concerns are the reliability of the service and the security of the data. These services, therefore, are not recommended for confidential documents or when access to files is essential.

**Relative cost of storage**

As in the case of computers, the cost of memory is continually changing. The price varies from country to country as well as according to international demand. In order to compare the cost of memory, a common measure is to calculate the cost per Mb. The following table compares the cost per Mb of the different media.

<table>
<thead>
<tr>
<th>Medium</th>
<th>Hard disk</th>
<th>CD</th>
<th>Data cartridge</th>
<th>Zip disk</th>
<th>Flash disk</th>
<th>Floppy disk</th>
</tr>
</thead>
<tbody>
<tr>
<td>Relative cost per Mb</td>
<td>0.04</td>
<td>0.15</td>
<td>0.3</td>
<td>0.3</td>
<td>3</td>
<td>4</td>
</tr>
</tbody>
</table>

This table tells you that it is about 100 times as expensive to store an Mb of data on a floppy disk as it is on a hard drive.
Use this table with caution. Treat the values as very approximate relative values. In other words use them as comparative values, not as monetary values.

**Formatting disks**

A new diskette or hard disk is not able to record data immediately. The disk first needs to be prepared by a process known as formatting. This marks out concentric circles called tracks. Each track is divided into a number of sectors. The tracks and sectors are marked out using magnetic markers.

As data is recorded on a disk, it fills up. To be able to re-use a disk, it may also need to be reformatted. This releases the areas that contain data so that new data may be stored in its place. When a disk is reformatted, the old data is lost.

When data is stored on a disk, it is not always stored in a continuous pattern. Rather, the system stores data in the first free area it finds. When this has been filled, it looks for additional free space and continues storing the data. A file ends up being stored as a series of segments across the disk. This breaking up a file into many segments is called fragmentation.

Fragmentation slows down the operation of the disk as the system needs to keep track of all the different segments. A disk may be re-organised to reduce fragmentation by a process called defragmentation.

There are different file systems available, but in all cases the disk needs to be prepared with the index area, tracks and sectors through formatting.

As mentioned previously, disks can be reformatted. In this process everything on the disk is erased and the disk is formatted as if it was a new disk.

This diagram represents the tracks (green) and sectors (red triangular area) that are created when the disk is formatted and ready to store data.
Input and Output

The central processing unit, memory and storage form the core of your personal computer, but for a computer to be truly useful there must be a method to get information in (input) and out (output). This is accomplished by using a variety of input and output devices that communicate with the computer through input and output ports.

Input/Output ports

Input/Output ports refer to the memory addresses used by the CPU for direct communication with input and output devices. The exchange of commands or data between the processor and the device takes place through the I/O port address of the device. There is a specific memory address for each type of device.

Ports also refer to physical connections located on the outside of a computer that allow for input or output devices to be connected to it. The graphic below illustrates the common input/output ports found on a computer.

Input/Output Devices

Input/Output devices are the hardware devices that allow you to communicate with your computer. Input devices such as a keyboard, mouse or scanner allow you to send information to the central processing unit. Output devices such as a monitor or printer allow you to get information back from the CPU.

Input devices

The original input device was the punched card, a technology that predates computers by many years. Stiff paper cards were prepared by punching holes in specific locations and then fed into a computer to input information.

The most common input devices for modern computers are the keyboard and mouse. Keyboards have been part of personal computers from the beginning. Originally, computer operating systems and applications were
very text-based. A keyboard enabled a user to input text to operating systems and applications such as word processors. They are still essential for inputting text into word processed and other documents.

The computer mouse was developed to help computer users navigate around a graphical user interface such as Microsoft Windows, Macintosh OS, or Ubuntu Linux. A mouse makes it faster to load programs, open documents and place your cursor where you want it or select objects within an application. Extensions of the mouse include the trackball, joystick, touchpad and touch screen display.

**Multimedia Input Devices**

More recently, input devices have been developed to take advantage of the multimedia capabilities of modern computers. These include scanners that allow you to scan and input graphic images; sound cards and microphones that allow you to input audio files; digital cameras and video capture cards that allow you to input photographic images and video; and graphic tablets that allow you to draw directly into your computer graphics applications.

Multimedia devices, together with the Internet and other networks, have enabled us to use computers to communicate with others using text, audio and video.

**Specialised Input Devices**

Computers in places such as banks and retail stores make use of such specialised input devices as card readers and barcode scanners. A card reader reads electronic information that is embedded in bank cards, credit cards or other information cards. The card reader sends the information to a computer CPU which then processes the information by enabling a financial transaction or displaying information on a screen.

A barcode reader is a type of optical scanner that reads the barcode of an item and sends that information to the CPU. The barcode is used to gather information about the item, such as price and to use that information to prepare a receipt or to track inventory.
Output devices

Output devices are computer hardware that receive information from the CPU and present that information to the computer user. Common examples of output devices include computer monitors, printers and speakers.

Output for graphics

Computer graphics can be displayed using a monitor or a display projector connected to the graphics output port.

Original computer graphics systems were capable of displaying only one colour and used a monochrome monitor that could display 80 columns and 25 lines of text. Modern graphics cards are circuit boards that attach to the computer’s main board and are capable of much higher-end graphics such as 3-dimensional and full-screen video. The following subunits make up a graphic card:

- **Graphics Processing Unit (GPU)** – a processor dedicated to graphics functions such as graphics acceleration and 3-dimensional graphics.
- **Video Bios** – a basic program that governs the operation of the graphics card and provides instructions so that the computer can interact with the graphics card.
- **RAMDAC** – a set of instructions for displaying information on analog monitors.
- **Video ports** – for attaching monitors or other display equipment.

Computer monitors have evolved with the increased graphics capabilities of computers, to the point now where monitors are capable of displaying high-definition video. The most common types of displays are:

- **CRT Monitors** – use a cathode ray tube to send a stream of electrons onto a screen coated with phosphor. The screen glows when struck by the electrons. CRT monitors are still used in many desktop computer systems. CRT monitors typically present excellent image contrast and the viewing angle is very good compared to other types of monitors.
• **LCD Monitors** – liquid crystal displays (LCDs) use two pieces of polarised glass with a liquid crystal trapped between them. The screen is lit from the back and the crystals align to allow varying levels of light to pass through. LCD monitors require much less thickness than CRT monitors and are therefore typically used on laptop systems. Also, since they take up less space, generate less heat and use less electricity, they are becoming the monitor of choice for desktop systems as well.

• **Display projectors** – display the computer graphics by sending light from a metal halide bulb through a prism that separates the light into its red, green and blue components and then projecting the image onto a wall or screen. These projectors have the advantage of creating a large display that can be viewed by an audience.

Computer displays are characterised by the following:

- **screen size**: the size of the viewable area of the screen, measured from one corner to the opposite corner
- **aspect ratio**: the comparison of the width of the display to height. Historically computer monitors had a 4:3 aspect ratio, the same as traditional television sets. Widescreen LCD monitors typically have an aspect ratio of 16:9 or 16:10
- **colour depth**: the number of bits used to describe the colour of a single pixel. High end displays can produce 16.8 million different colours
- **dot pitch**: a measure of the distance between dots of colour on a display
- **refresh rate**: the number of times each second at which the display draws the data it receives (i.e. the screen refreshes). A high refresh rate is important to prevent flickering and eye strain while using the computer

**Output for sound**

Computers have been equipped with sound chips and internal speakers from very early in their development but because of the limitations of the hardware, the types of sounds that could be played were simple “beeps”. The audio suffered from low volume and distortion which required other system processes to stop while the sound played.
Modern computer systems use sound cards either attached to or integrated with the computer main board. These sound cards usually come with their own memory and therefore don’t take away processing resources from the main computer. The sound cards have ports for attaching speakers, headphones, microphones and other devices such as media players. Modern sound cards, when accompanied by high-end speaker systems, are capable of very good sound reproduction.

**Output for print**

Printers are output devices that produce a hard copy of electronic documents on print media (usually paper or transparencies). Like computers, printers have evolved to support such features as high-definition graphics, full-colour reproduction and photography.

Printers are classified by the type of print technology they use. The most common types of printers are:

- **Toner-based printers** – such as laser printers, use toner to produce an image either in colour or shades of grey. Laser printers have good print quality, good print speed and a low cost per page compared to other print technologies. The high-end colour laser printers are capable of producing photographic-quality images, but at a relatively high cost.

- **Liquid-ink printers** – such as colour inkjet printers, work by propelling droplets of ink onto a page. They are the most common type of printer for the consumer because of their low cost and excellent print quality.

**Note:** some devices act as both input and output devices. An example is the touch screen monitor, which has a graphics output function and a touch pad input function.
Summary

In this section, you learned:

- Computer hardware is the physical part of a computer, including its digital circuitry. The central processing unit (CPU), monitor, keyboard, mouse, etc. are some examples of computer hardware.

- The main types of personal computers are:
  - Personal computers
  - Desktop PC
  - Tablet PC
  - Handheld portable devices

- The main parts of the computer are:
  - case/chassis
  - cooling system
  - motherboard
  - CPU (central processing unit)
  - input/output ports
  - memory
  - hard drive
  - sound system
  - power supply
  - input/output devices (monitor, keyboard, mouse, printer, etc.)

- Computer memory can be classified as:
  - Primary Memory (read only memory or ROM and random access memory or RAM)
  - Storage Memory (hard drives, CD-ROM, flash memory)

- Hardware can be classified as:
  - Input Devices (mouse, keyboard, scanner)
  - Output Devices (monitor, printer, speakers)
Section overview

Welcome to this section on Software. After studying this section you will

- understand the term “software”
- distinguish between operating systems software and application software
- understand reasons for software versions
- understand the main functions of an operating system
- know about different operating systems
- know about graphical user interfaces (GUI)
- know about common software applications such as: word processing, spreadsheet, database, Web browsing, desktop publishing, accounting, together with their uses
- know about the process of analysis, design, programming and testing often used in developing computer-based systems

Main Concepts

What is computer software?

Computer software is the non-physical part of a computer. It is a term used to describe the programs and documentation that play a part in a computer system’s operation. It is an integral part of a computer system since it forms the set of instructions that a computer needs to run. Without software, a computer system is simply a collection of metal, plastic and other elements with no function.

Types of Software

Software is divided into two broad categories: systems software and application software.

Systems software

Systems software is the term used to describe programs that enable the computer to function, improve its performance and access the functionality of the hardware. Systems software’s sole function is the control of the operation of the computer. You can think of systems software as providing the foundation for applications software.

Systems software is further subdivided into operating systems and utilities. The operating system is the program that actually makes the computer operate. Utilities are programs which either improve the functioning of the operating system or supply missing or additional functionality.
Application software

Application software is the term used for programs that enable the user to achieve specific objectives such as create a document, use a database, produce a spreadsheet or design a building.

Versions

Software developers continually strive to improve the performance of their products and add new features. Especially in a world of competing products, each developer needs to make their product perform better, have fewer problems and have more features. The new releases of software products are called versions. The versions use a numbering system such as:

- Ubuntu Linux 7.04
- OpenOffice.org 2.0

A change in the number before the decimal point represents a major new version while a change in the numbers after the decimal point represents a less significant change.

Operating System Software

As mentioned earlier, it is the operating system that actually makes the computer function. The following is a list of some of the functions of the operating system:

- boot-up the computer
- control the hard drives: this includes such features as formatting as well as saving files to and retrieving files from disk
- control the input/output ports
- control input devices such as keyboards, mice and scanners
- control output devices such as the video display and printer
- provide the functionality for computers to be linked in a network
- provide the foundation for application software to be launched
- enable application software to access and use the hardware

The following list names some operating systems. They are grouped according to similarity.

- Unix; Linux; Free BSD
- Windows 95; Windows 98; Windows Me, Windows NT4 Workstation/Server; Windows 2000 Workstation/Server; Windows XP; Windows 2003 Server; Windows Vista
- Macintosh OS 9; Macintosh OS X
Application Software

The following table lists some types of application software, brand names and function.

<table>
<thead>
<tr>
<th>Application</th>
<th>Brand names</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Word processor</td>
<td>OpenOffice.org Writer, StarWriter, Kword, Microsoft Word, Lotus Ami Pro, Corel WordPerfect</td>
<td>Create, store, format and edit documents, letters and articles. Word processors are used where the emphasis is on manipulation of text.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Spreadsheet</td>
<td>OpenOffice.org Calc, StarCalc, Kspread, Microsoft Excel, Quattro Pro, Lotus 123</td>
<td>Create financial statements, balance sheets, perform statistical and numerical analysis of data and make forecasts based on numeric data. Spreadsheets are used where the emphasis is on arithmetic.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Presentation</td>
<td>OpenOffice.org Impress, StarImpress, Kpresenter, Microsoft PowerPoint</td>
<td>Create slide shows, lectures, seminars and other types of presentation.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Database</td>
<td>Sybase, MySQL, Microsoft Access</td>
<td>Store and convert data into information. Databases are particularly useful in working with large quantities of data.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Email client</td>
<td>Evolution, Kmail, Microsoft Outlook</td>
<td>Send, receive, store and organise electronic mail.</td>
</tr>
</tbody>
</table>
### Application | Brand names | Function
--- | --- | ---
Web browser | Mozilla
Netscape
Microsoft Internet Explorer | Surf the Internet and view web sites.

Desktop publishing (DTP) | Microsoft Publisher
Page Maker | DTP is similar to word processing except that there is more emphasis on page layout and the integration of diagrams.

Accounting | GnuCash
Pastel Accounting | Store accounting information and produce reports, statements and invoices.

Web development | Dreamweaver
Microsoft FrontPage | Create web sites that can be read by a browser.

Graphics and imaging | The GIMP
Adobe Photoshop | Create and manipulate graphics images and store images in a variety of formats.

### Graphical User Interface

A graphical user interface or GUI is designed to simplify the work of the user whether they are using the operating system or an application package. The interface consists of a screen with a number of icons or menus. Functions are executed by pointing and clicking with the mouse.

Some of the advantages of using a GUI are:

- Less work for the user. To execute a function all you have to do is point and click on an icon instead of typing out an instruction.
- Quicker to learn.
- Easy access to the basic functionality of the operating system or application package.
- Hides the underlying complexity from the user.
- Simplifies and integrates multitasking. Multitasking refers to using several applications at the same time. Opening a new application or document involves a couple of mouse clicks. Likewise switching between tasks also involves only a couple of mouse clicks.
There are some disadvantages to using a GUI based operating system.

- Not all the functionality is available. The icon represents the most commonly used form of a function. A text based system gives you access to all the options associated with a function. Power users tend to switch between the GUI and the system prompt as needed.
- Being graphics based, a GUI runs more slowly than a text based system. However, with the power and speed of modern computers this is not the problem it once was.

The following screens illustrate a GUI in Linux (Ubuntu) and Windows (Windows XP).
The following screen illustrates the use of a menu:

![Menu Screen](image)

In each case, clicking on an icon will either execute a function or display another set of icons containing the function.

**Software for accessibility**

Software for accessibility was developed to assist people with challenges related to computer use. It encompasses a number of software programs that are designed to address visual, auditory and kinesthetic challenges. The programs can be classified as an extension to operating systems.

**Speech recognition**

Speech recognition software converts spoken word into machine-readable input that can be opened with text editing software. It is especially useful for people who have difficulty using their hands because of injury. Other uses are for transcription, where long recordings of human speech have to be transcribed to text.

**Screen readers**

A screen reader is a software program that interprets the information that is on a screen and relays that information to the user in the form of spoken word (text to speech) or Braille output.

**Screen magnifiers**

A screen magnifier is a software program that enlarges a portion of the computer screen for visually impaired people with some visual function.

**On-screen keyboard**

An on-screen keyboard, or virtual keyboard, is a program that allow users to enter keystrokes with multiple input devices, such as a computer mouse, a head mouse, or an eye mouse. It provides an alternative mechanism for people who cannot use a physical keyboard to enter characters.
System Development

Program Development Life Cycle

The development of computer programs is a highly developed and structured process involving a number of distinct stages as shown in the table below. The stages of development are known as the program development life cycle.

<table>
<thead>
<tr>
<th>Stage</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analysis</td>
<td>The problem or task is analysed and clarified. This involves analysis of the way the task is currently being done and consultation with end users. The project is set out in broad outline. The work of this stage is performed by systems analysts.</td>
</tr>
<tr>
<td>Design</td>
<td>The project is broken down into smaller sections. These too may be further broken down until there are units. The method of programming each unit is then specified in great detail. The most suitable programming language for each unit is then chosen. The complete specification is the final design. The work of this stage is also performed by systems analysts.</td>
</tr>
<tr>
<td>Programming</td>
<td>The design is handed over to programmers who code the design into programming languages such as C+ or Java. The work of this stage is carried out by computer programmers.</td>
</tr>
<tr>
<td>Testing</td>
<td>Since programs are long and complex, they may contain errors called bugs. These may be syntactical errors, in which the programmer made a mistake in the structure of the command, or logical errors. In these the program appears to work, but works incorrectly. The process of testing is designed to find and eliminate bugs. This stage involves end users to try out the program, programmers to fix syntactical mistakes and systems analysts to fix errors in the logic of the program.</td>
</tr>
</tbody>
</table>

The following are often also included as part of the development cycle.

<table>
<thead>
<tr>
<th>Implementation</th>
<th>Once the systems analysts are satisfied that the system is operating correctly, it is installed and implemented. Usually this is done using a pilot group. In this implementation, the system is implemented on a limited scale to start with. If any further bugs are found, these can be eliminated before full scale implementation.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Further development</td>
<td>Once the system has been in use for a while, further problems, limitations or performance problems may become apparent. The system will then be modified and new versions released with the changes.</td>
</tr>
</tbody>
</table>
Summary

In this section, we learned:

• Computer software is the **non-physical part of a computer**. It is a term used to describe the programs and documentation that play a part in a computer system’s operation.

• Software is divided into two broad categories: systems software and application software.
  - Systems software is the term used to describe programs that enable the computer to function, improve its performance and access the functionality of the hardware.
  - Application software is the term used for programs that enable the user to achieve specific objectives such as create a document, use a database, produce a spreadsheet or design a building.

• A graphical user interface or GUI is designed to simplify the work of the user whether they are using the operating system or an application package. The interface consists of a screen with a number of icons or menus. Functions are executed by pointing and clicking with the mouse.

• The stages of software development are known as the program development life cycle. The stages of the program development life cycle are:
  - Analysis
  - Design
  - Programming
  - Testing
  - Implementation
  - Further development
Information Networks

Section Overview

Welcome to this section on Information Networks. After studying this section you will be able to:

- Understand the concept of networks
- Distinguish between Local Area Network (LAN) and Wide Area Network (WAN)
- Understand the term client/server
- Know the advantages associated with group working such as: sharing printers, applications and files across a network
- Differentiate between Intranet, Extranet and Internet
- Understand what the Internet is and know some of its main uses
- Understand what the World Wide Web (WWW) is
- Distinguish the WWW from the Internet
- Know about different types of communication technologies
- Understand the terms analogue, digital, modem, transfer rate
- Know about the use of telephone network in computing
- Understand the terms Public Switched Telephone Network (PSTN), Integrated Services Digital Network (ISDN), Asymmetric Digital Subscriber Line (ADSL)

Main Concepts

What are computer networks

A set of computers connected together so that they can communicate is called a computer network. This involves installing network cards in each computer. Each computer is then connected through cabling or wirelessly to a central device called a hub. Operating systems contain components that are dedicated to the task of enabling computers to communicate over a network. This software makes use of special rules of communication called protocols. There are many different types of protocols used for a variety of purposes. The most commonly used protocol for establishing and maintaining communication across a network is called TCP/IP or Transmission Control Protocol/Internet Protocol.
Client-server and peer-to-peer networks

Networks on which all computers have equal status are called peer-to-peer networks.

On most networks, certain computers have special dedicated tasks. Since these machines provide services to other computers, they are called servers. The computers that make use of the services of servers are called clients or workstations. A network such as this is called a client-server network.

A server which is used for the central storage of files is called a file server. Using a file server, users can access their work from anywhere on the network. They can also make these files available to users on other computers. File servers also enable users to co-operate on a task by centralising the results of their work. Sending files to a server from a client computer is called uploading, whereas receiving a file from a server to a client computer is called downloading.

A computer attached to a printer which users can access is called a print server. Having a single printer rather than a printer attached to each computer obviously saves capital.

An increasingly important type of server is an applications server. In the case of applications servers, application packages are not installed on the workstations but on the applications server.

A communications server is a computer dedicated to connecting a network to the outside world. These are often called proxy servers.

As the case of print servers illustrates, one of the greatest values of having a network is that it enables resources to be shared.

LAN

A LAN or Local Area Network is a group of computers within the same building or within a group of buildings that are in close proximity, that are connected together.

WLAN (Wireless LAN)

A WLAN is a Local Area Network that is connected wirelessly.

WAN

A WAN or Wide Area Network is a group of widely dispersed computers that are connected together. These could be across the same town or across a country or even across the world. Apart from distance, the other feature that distinguishes a WAN from a LAN is that the WAN would make use of a range of communication technologies such as telephone, microwave and satellite links.
Advantages of Networking

Sharing Printers and Files

A peer-to-peer network is where two or more computers are linked together in order to share information and hardware.

It is a major advantage to be able to share printers, plotters and scanners. When computers are networked together, there can be many PCs sharing a printer as opposed to each one having to have its own printer which is much more costly.

It is also possible to share data files across the network by creating a share on the hard drive and allowing other people access to that information.

If you want to share applications you would need to investigate a client/server network solution and some of the advantages are listed below.

File Servers
- Users can access their work from any workstation connected to the network.
- Users can easily exchange work with colleagues.
- Users can easily co-operate on tasks.
- Backing up is centralised and can be placed under the control of experts who will follow the correct procedures.

Printer Servers
- Instead of having printers attached to each computer, printers only need to be purchased for the print servers. This results in financial savings.
- As there are fewer printers to look after there is lower maintenance.
- As far fewer printers need to be purchased better quality printers with advanced features can be purchased.

Application Servers
- Software only needs to be installed on the applications server instead of each workstation.
- The software is configured in the same way for all users.
- Upgrading of software only needs to be done on the server.
- Cost of licensing software for an applications server is less than the cost of many stand-alone versions.
- Centralising applications software simplifies the process of implementing software policies in an organisation. Software policies refer to what software may be installed on computers and how it may be used.
Internet Connection Sharing (Proxy Servers)

- Proxy servers contain a repository of Internet sites recently visited and cached for quicker access at a future date.
- Proxy servers can be configured with firewall software. This helps protect the network from attack by hackers.
- Files can be filtered for computer viruses before being passed on to the network.
- Organisations can control access of users to outside sites.
- Since there is only one point of communication there is a large saving on line costs.

Communication Terminology

Analogue signals

Analogue signals are used on the Public Switched Telephone Network (PSTN) as well as for normal AM and FM radio transmissions. An analogue signal is one which varies continuously as, for example, in ordinary speech. An analogue signal has a graphical form as shown in the diagram below.

Digital signals

Digital signals are used in Integrated Services Digital Network (ISDN) and Asymmetric Digital Subscriber Line (ADSL) connections (to be discussed later). Newer television and radio transmission techniques are also making use of digital technology.

Digital signals are two state signals corresponding to a switch which is on or off. The same two state signal can also represent TRUE and FALSE or 1 and 0. A digital signal is also represented graphically in the diagram below.

Modems

A modem or modulator-demodulator is a device connected between a computer and a telephone line. Its function is to convert the digital signals of the
computer into a form suitable for transmission over a telephone line. It
must also do the reverse and convert the telephone line signals into a
form suitable for the computer. Note that the modem used to connect to
an ISDN line is different to that used to connect to an analogue line.

Data transfer rates

Each 1 or 0 that is transferred is referred to as a bit. The speed of a data
transfer is measured by the number of bits that can be transferred each
second or bps (bits per second). This is also sometimes called the baud
rate or bandwidth.

High speed lines have their speed measured in kbps or Mbps.

\[ 1 \text{ kbps} = 1024 \text{ bps} \text{ (roughly 1000 bps)} \]

\[ 1 \text{ Mbps} = 1024 \text{ kbps} = 1048576 \text{ bps} \text{ (roughly 1000000 bps)} \]

To put these figures in perspective, the maximum theoretically attainable
speed with an analogue line is 56 kbps. This figure is very seldom
attained and the reality is usually substantially lower. ISDN lines operate
at 64 kbps.

The Telephone Network in Computing

Communications between computers rely heavily on the public telephone
system. Newer telephone line technologies have improved the standard of
communications between networks considerably. The following is a brief
description of some of the technologies that are available.

PSTN

The PSTN or Public Switched Telephone Network refers to the original
telephone network. From a communications perspective it was slow and
unreliable. Some of the exchanges on a PSTN may still make use of
mechanical switches to route telephone calls. These add additional noise
to the line. When lines are noisy, signals have to be resent repeatedly
between the source and the destination. The PSTN makes use of analogue
technology which uses continuously variable signals. An example of an
analogue signal is ordinary speech. Newer digital technologies make use
of pulses of fixed magnitude and duration.

In order to improve connections, it is possible to have an analogue leased
line. This is a dedicated permanent telephone connection between two
computers using the PSTN.

In order to connect a computer to a telephone network, you need a
modem (modulator-demodulator). The function of the modem is to
convert the digital signals from the computer into an analogue form
suitable for transmission on the PSTN.
**ISDN**

*ISDN* or **Integrated Services Digital Network** is a technological development that is able to make use of the existing PSTN cabling to transmit digital signals.

Technically ISDN is an international standard for the transmission of data, voice and video or normal voice or digital telephone lines. ISDN supports rates of up to 64kbps. An ISDN connection consists of two lines which can be used independently or together to give a combined rate of 128 kbps.

If you wish to connect a computer to an ISDN line you need a special ISDN modem. This is a different type of modem to the one used with an analogue line. Its purpose, however, is the same, to convert the digital signals of the computer into a form suitable for transmission on an ISDN line.

It is possible to get a dedicated connection between two computers using ISDN. This is called a diginet connection.

The older telephone systems make use of electrical currents transmitted through copper cabling. As electric signals are subject to interference, they are not the ideal method of transmitting data. Newer telephone systems make use of fiber optic cable. In fiber optic technology, light is transmitted along the cable. As light signals are not subject to the same interference problems as electrical signals, fiber optic is a far more efficient and reliable system.

**ADSL**

*ADSL* or **Asymmetric Digital Subscriber Lines** allow the transmission of high speed digital data over ordinary telephone lines using a modulation technology called DMT or Discrete MultiTone. Ideally, fiber-optic is the ideal medium for high speed digital transmission. As the installation of fiber-optic is expensive, ADSL provides a solution until copper cable is replaced by fiber-optic.

**Intranet, Extranet and Internet**

**Intranet**

An intranet is a collection of all computers within an organisation that can access each other in some way. Users may browse computers within an intranet using a browser but will usually not be able to access the wider Internet. In the same way, outsiders will not be able to access the intranet of an organisation. An intranet can be thought of as a private Internet.
Extranet

An extranet is an extension of an organisation’s intranet to include outside users. In an extranet, outside organisations or individuals are allowed access to certain parts of the intranet. This access is usually controlled by means of passwords and access rights. These restrict which users can access the extranet and what they can do once they have access. The purpose of the extranet is to facilitate business transactions with other organisations.

Internet

The Internet is the collection of all computers across the world which can access each other in some way. The links between computers might include telephone, fiber optic cable, radio, microwave or satellite. Today tens of millions of computers are able to access each other. The Internet has no central organisation which controls its use. Because the Internet knows no borders, many governments have tried to control the flow of information across the Internet. However, communications technology is so varied and so widespread that this is a near impossible task.

Uses of Internet

Some of its main uses are to:

- integrate the operations of multinational corporations
- provide access to and share information and databases
- transfer and share files between computers
- facilitate business transactions
- share resources and information
- promote scientific co-operation between research institutions
- provide a communications channel for the military
- advertise a product or service

World Wide Web

The World Wide Web or WWW is a part of the Internet. The WWW consists of all the sites that can be accessed using a web browser such as Mozilla, Internet Explorer, Opera or Google Chrome. In order for a browser to access a web site, the web site must contain files that have a particular format constructed using HyperText Markup Language or HTML. These sites are typically developed using special web development applications, but it is possible to create simple web sites using a word processor by saving the document in HTML format.

The HTML documents are stored as web pages on special servers known as web servers. These run special web server software such as Apache Web Server or Internet Information Services.

The WWW enables the free flow of information across the world. Developments in technology have made access to the Internet easier and
faster. As a result the WWW also became known as the Information Superhighway.

Most of the activities listed under the Internet in the previous section are now actually carried out using the World Wide Web. In other words, the sites are created in HTML or a similar format, are installed on web servers and are accessed by web browsers.

**Connecting to the Internet**

Connecting to the Internet requires a client computer connected to some type of device that transfers data to a server computer, which is also connected to the Internet. Connection speeds and costs can vary quite greatly between the connection types.

**Dial-up connections**

Accessing the Internet through a dial-up connection means that your computer is literally dialing a telephone number. You must use a modem between your computer and your phone line to convert the digital signal coming from your computer to an analog signal carried by the phone line. This analog signal is converted by another modem at the other end of the phone line, which then connects to a computer that is connected to the Internet.

Dial-up is a relatively slow way to access the Internet, with maximum speeds of 56 kbps. Also, when you are connected to the Internet, your phone line can’t be used make or receive phone calls.

**Connecting with a mobile phone**

Similar to dial-up, you can connect to the Internet using some mobile phones. Again, the connection is relatively slow, depending on whether your cell phone and access is analog or digital. Also, you probably will have to pay your cell phone provider for a data service plan.

Some cell phones come equipped with e-mail applications and Web browsers to make your Internet experience more usable.

**Broadband connections**

Broadband connections are able to carry a broad range of frequencies. The broader the bandwidth of a connection, the greater the capacity for carrying data. The two main types of broadband Internet connections are ADSL and Cable.

Because broadband connections are “always on”, they require a high level of security, including the installation of a firewall (a program designed to prevent unauthorised access to a computer).

**Cable**

Cable connections to the Internet work by using the same cable that carries television signals. The theoretical maximum speed for a cable
connection is 30 Mbps, but this is seldom achieved for a variety of reasons, chief among which is that the more people in close proximity that are using the Internet at any time, the slower the connection. However, cable connections provide a much higher speed than dial-up and are comparable to ADSL.

**ADSL**

ADSL (asynchronous digital subscriber line) connections work by splitting your phone line into two separate channels, one for data (Internet) and one for voice (phone calls). This means you can talk on the phone and be connected to the Internet at the same time.

The speed of an ADSL connection ranges from between 256 kbps to 8 Mbps, depending on what your Internet Service Provider offers.

**Satellite connection**

If ADSL and cable connections to the Internet are unavailable, a third broadband choice is satellite Internet. In this scenario, a computer is connected through a modem to a satellite dish, which sends and receives data from a satellite. Speeds are comparable to ADSL, but setup, equipment and service costs are relatively high.

**Summary**

In this section, we learned that:

- Computer networks are a set of computers connected together so that they can communicate.

- There are two main categories of computer networks:
  - **Peer-to-peer network networks** are networks on which all computers have equal status.
  - **Client-server network** are networks on which certain computers have special dedicated tasks (called *servers*) and other computers that make use of the services or servers (called *clients*).

- Networks can also be categorised by their range:
  - A LAN or Local Area Network is a group of computers within the same building, or within a group of buildings that are in close proximity, that are connected together.
  - A WAN or Wide Area Network is a group of widely dispersed computers that are connected together.
  - An intranet is a collection of all computers within an organisation that can access each other in some way. Users may browse computers within an intranet using a
browser but will usually not be able to access the wider Internet.

- An extranet is an extension of an organisation’s intranet to include outside users. In an extranet, outside organisations or individuals are allowed access to certain parts of the intranet.

- The Internet is the collection of all computers across the world which can access each other in some way.
The Use of Information Technology (IT) in Everyday Life

Section Overview

Welcome to this section on the use of IT in everyday life. After studying this section you will:

- understand the use of computers and communication technology in our everyday life
- be able to identify some situations where a computer might be more appropriate than a person for carrying out a task and where not
- know some of the uses of large scale computer applications in corporate, public, health and education
- understand the term teleworking
- list some of the advantages of teleworking such as reduced or no commuting time, greater ability to focus on one task, flexible schedules and reduced company space requirements
- list some disadvantages of teleworking such as lack of human contact and less emphasis on teamwork
- understand the term electronic mail (e-mail) and know its main uses

Computers at Work

Computers are ideal for repetitive work requiring speed and accuracy. This is especially true of those situations where human beings would become bored or simply cannot work fast enough. Some examples include:

- corporate data processing including functions such as sorting, selecting and summarising
- analysis of census and other demographic data
- administration of the national revenue system
- actuarial calculations
- statistical analysis
- corporate accounting functions
- creation of animations for films
- weather forecasting
- forensic analysis such as DNA and fingerprint matching
- manufacture of electronic components and circuitry

Computer Application in Different Sectors

Corporate Application

Corporations have to keep records of their staff, details of their clients, levels of their stock, production schedules, debtors, creditors and a
myriad of other details. Many of these activities are themselves linked in one or more ways. For example, stock levels of raw materials and production schedules are very closely linked.

The ideal solution in a corporate environment is Enterprise Software. This is a complex suite of applications that are created to work together. Enterprise Software is designed to automate all the activities of an organisation in one system. The different components or modules interact with each other. For example, if production requires certain raw materials, the appropriate production module will send a message to the stock module that certain materials are needed and when they will be needed. If the stock module determines that existing levels are too low, it will send a message to another module responsible for orders. This module will then check which supplier to use and automatically generate an order stating the quantity needed and a deadline for delivery. Organisations do not buy an entire enterprise package, but only the modules that are relevant to the operation. Because of cost and complexity, Enterprise Software is usually found only in large organisations.

All organisations, no matter their size, can benefit from computer applications. Examples found in business include:

- Office application suites such as OpenOffice.org, Koffice, StarOffice or Microsoft Office for creating documents, spreadsheets and presentations.
- Accounting packages such as Pastel Accounting for keeping debtors and creditors records and creating statements and invoices.
- Inventory systems for keeping track of stock.
- Desktop publishing packages such as Microsoft Publisher and Page Maker for creating newsletters and press releases.
- Client tracking software such as Gold Mine for representatives to maintain regular contact with clients and record their activity.
- Airline bookings systems which manage large amounts of data and reservation details and also have the flexibility to handle frequent changes to bookings.
- Insurance claims systems to manage the processing and payment of claims.
- Online banking systems enable corporations and individuals to have easy access to funds transfer and account maintenance.

Public Sector Applications

Inland Revenue

Governments need to keep records on millions of tax payers, both individual and corporate. It also needs to calculate the tax each has to pay and send out tax assessments. Sophisticated computer systems manage these tasks. For example, the South African Revenue Services (SARS) has a website that a taxpayer can register on and submit returns
electronically by filling in the return online and authorising payment directly from their bank account.

National census and other demographic data

National economic and social planning requires that governments have a good idea of the number of people in the country and in each region. They need to know income and health levels and size of families. They also need to know the skills and educational levels of different sections of the population.

This information is obtained by means of a national census. Part of this involves people filling in census forms and these being collected and checked by census officials. In other cases, figures are obtained by indirect methods such as aerial photographs. In all cases the data has to be analysed to produce summaries that planners can use. This task can only be done by specialised software designed for the purpose.

Other organisations also collect data for specific research purposes. For example, Medical Research Councils will conduct research to determine the prevalence of HIV/AIDS. This research relies on sophisticated statistical software to analyse the data.

Vehicle Registration

Every vehicle has a unique registration number. This number, together with the vehicle and owner details is kept in a central database. This database can be accessed not only by the municipal officials, but also by other interested parties such as the police.

Voting registers

In order to vote, a person must be recorded on the voting register. This register of voters contains millions of records. Records need to be changed, deleted and added on a regular basis. Because of the sheer volume, it would be difficult to maintain in any other way than a computerised system.

Electronic voting

This is a system that is being introduced which will allow voters to register their choice online to submit their ballot instead of the traditional method of marking a piece of paper with a pen.

National Identity System

Governments are keeping records of all the citizens in a country. It keeps records of births, marriages and deaths. It also issues identity documents and passports. All this is only possible through the use of computerised systems.
Health Sector Applications

Patient records

Patient records need to record not only personal details such as name, address, relatives and employer, but most importantly detailed health history, record of operations and medication. The more efficiently this information can be stored and retrieved, the more efficiently the health care system can be administered.

Scheduling

Hospitals are extremely busy organisations which usually function amidst considerable stress. In order to use the facilities efficiently, where possible, activities need to be scheduled. For example, the availability of surgeons needs to be coordinated with the availability of operating rooms and the urgency of treatments. With good scheduling systems, much of the stress of the more routine activities can be reduced.

Ambulance control systems

By their very nature, ambulances do not work to a schedule. They are needed at unexpected places and unexpected times. The best a system can do is to optimise their use. That means knowing which ambulance is nearest to a scene at any given moment. Modern software can provide the ambulance driver details of the shortest route and the latest on-board software makes use of speech synthesis which actually tells the driver how to get to a destination as he is driving. This technology makes use of in-built maps and global positioning (GPS).

Diagnostic tools

With diagnostic tools, a doctor feeds information about a patient’s symptoms into the system. The system will respond with a series of possible causes. It may ask for further information to refine the diagnosis. At the moment these tools are not replacing the diagnostic skills of a doctor, but rather help him/her explore alternative diagnoses.

Other diagnostic tools connect the patient directly to the computer. This is commonly used in the diagnosis of cardiac problems. Not only are all the different heart waves displayed on the screen, but the physician has the option of magnifying or analysing any of the patterns in more detail. They can also be stored and compared with the heart patterns at a later stage.

Specialised surgical equipment

A modern trend is towards less invasive surgery. This involves inserting catheters into different parts of the body through which miniature cameras and surgical instruments are placed. The output from the cameras is displayed on large screens. Other relevant data is also analysed and displayed on screens. All of the activities are assisted by special computer programs.
Education Sector Applications

Student records

Education institutions have electronic registration that allows students to be registered on the system first and further information such as personal records and results can be added as they progress through the course.

Student records keep personal details of students as well as their academic records and fees/accounts. Where students have had disciplinary problems, these are also recorded. Some institutions offer health and accommodation services to students. All this information needs to be recorded on a centralised system that can be accessed according to the rights different users have. For example, although health data may be recorded on a centralised system, only health workers would have access to it.

The same student administration system would need to send out examination results and accounts.

Timetabling

The process of timetabling involves scheduling staff, students and lecture rooms at the same time. The scheduling also needs to take into account the correct total amount of time allocated to staff, students and courses. Further public holidays and term holidays need to be taken into account. The larger the organisation, the more complex the process becomes. Software programs are now available which can factor in all the different parameters and produce a timetable. This can still be fine-tuned manually.

Computer Based Training (CBT)

Computer Based Training makes use of the computer to instruct students. The quality of CBT material varies widely. Some CBT material is little more than a text book on the screen, but other makes use of interaction or simulation to instruct. For example, if a student were learning word processing, a simulated version of the word processor would appear on-screen. The program would demonstrate how to perform a task by showing the activity of the cursor and the display of the menus. Most of this software produces an audible output so that the student is able to listen to a commentary on headphones as the activity is taking place on-screen.

Automated examinations

Automated examinations allow computerised systems to test students’ skills. These are most relevant to knowledge based or skills based courses. Courses requiring critical analysis such as literature or philosophy are not suited to this type of testing.

Knowledge based courses can be tested using randomised multiple choice, true/false or similarly highly structured types of questioning. If there is a sufficiently large test bank, students can be given a random set
of questions. This would mean that no two students would get the same set of questions.

Skills based courses can be tested using a simulated environment. For example, a pilot could take a test on flying an aircraft by taking a test in a simulator. This would appear exactly like the inside of the cockpit. Instead of windows, there would be computer screens with a simulation of the outside. An examiner would control all aspects of the simulation from a computer. The pilot would be required to respond by actually “flying” the simulator. The computer in turn would be able to analyse the quality of the “flying”.

Distance learning

In distance learning, the student manages their own learning timetable, when and where to learn and how long to participate in activities. Information and Communications Technologies can facilitate part of the whole process. The student can send assignments and questions to the lecturer using email/online tools and the lecturer can respond using email/online tools. An institution may put the courses on a web site that is password protected. A student either reads the coursework directly on the Internet or downloads it from the Internet. This has obvious cost and administrative savings for the institution.

It also means it can recruit students from all over the world. Registration and payment of fees can also be done online.

Homework/Projects using the Internet

The Internet contains enormous quantities of information. Some of this is excellent, some very poor and much incorrect. To access information on the Internet, a student makes use of a search engine such as Google. Feeding in a number of key words can result in a list of many thousands of sites being displayed. Each of these is represented by a hyperlink. This is a link to another site. When you click on a hyperlink, you are immediately taken to the site.

There are two important aspects to using the Internet to search for information to do assignments:

1. **The skilled use of a search engine**: First you need to become familiar with the different ways of using keywords and the various criteria you can set. This comes with practice.

2. **Sifting the good from the bad**: There is no control over the Internet. People can, and do, deliberately post incorrect or biased information on the Internet. You need to be able to assess the quality of what you read. For example, does the site give references to its sources or is the information corroborated by that on another independent site. Developing a critical mind in determining the quality of information is as important as being able to access information in the first place.
Teleworking Applications

Teleworking means literally doing work at a distance. This means instead of going into an office, you work from home, a holiday cottage, another country or any other location. When you telework, you can be thought of as having a virtual office.

Modern technologies such as email, the Internet and Virtual Private Networks (VPNs) have made teleworking a reality for many people. A VPN makes use of the Internet and various security protocols to enable remote users to connect to a company network. Apart from speed limitations, it will appear as if they are working on the network inside the organisation.

Not all occupations lend themselves to teleworking, but there are many that do. Examples include journalists, writers, computer programmers, graphic artists, consultants and representatives. Often teleworking is associated with contract work. Professionals are paid to do specific tasks and are given deadlines within which these have to be created. Where they do it is not relevant as long as it is done professionally and on time.

Advantages of Teleworking

Professionals
- Do not waste time on commuting between home and work.
- Are free to undertake work where ever they are.
- Have greater ability to focus on one task.
- Have flexibility to arrange their work time according to their needs and inclinations.
- Generally have tax advantages as they can claim business expenses.

Organisations
- Save on office space, equipment and facilities.

Disadvantages of Teleworking

Professionals
- May suffer from lack of human contact.
- Need to be highly self-disciplined.

Organisations
- May not get the benefits of teamwork.
- May have less control over workers.

The disadvantages of teleworking can be overcome by requiring professionals to spend a certain amount of time at the office. This does not require that they actually have a workstation or office of their own. They could be required to attend meetings or seminars. If they are structured as part of a team working on a project, they could be required
to attend team meetings which focus on planning, allocation of tasks, feedback or general motivation.

**Electronic Mail (email)**

Email refers to the transmission of messages between computers across a network or across the Internet. Email allows text, graphics and sometimes sound. Users are able to send files together with messages. These are sent as attachments to the email. To use email, you need to have access to a network or the Internet. A mail client is installed on the computer. This is used for the creation, sending, receiving and storage of email messages. Well known email clients include Evolution, KMail, Microsoft Outlook and Outlook Express.

Web based email systems only require that you have access to the Internet. Many of these such as Yahoo, Hotmail, Gmail and Eudoramail are free. Web based mail systems act as remote mail clients. Effectively, you log on to the mail client on the server using a web browser. From that point on, it acts in much the same way as a mail client installed on your own computer. You can log on to your web based mail system wherever in the world you happen to be.

**Email Addresses**

Email addresses consist of two parts separated by an @ symbol. The first part is the name of the user and the second part is the name of the mail server.

For example, in the email address david@icdlafrica.com, the user name is david and the name of the mail server is icdlafrica.com. This is the address of the computer which holds his mail.

**Advantages of email**

- It is very fast and efficient. Mail is transmitted from the sender to recipient in a matter of seconds. Recipients can reply immediately. If both happen to be on-line at the same time, they can conduct a conversation using email.
- Documents and files can be sent with the email. The only limitation is the maximum size of attachments that your system will permit.
- It is very cost effective. The cost of sending an email is a fraction of the price it would be to send it as a letter.
- There is a saving on paper, printing, postage and envelopes.
- Email clients can be organised so that copies of emails that have been sent can be stored under appropriate directories.

**Disadvantages of email**

- If there is a problem with the telephone lines/networks, email cannot be sent or received.
- There are certain security problems such as the interception of email by hackers. This can be overcome by encrypting email. This requires the email to be coded into an unintelligible form.
using a key. The recipients system has access to the key and is able to decrypt the email.

- Occasionally problems in the complex system between sender and recipient may occur, causing email to disappear. To know when this has occurred, it is possible for your system to request a receipt of delivery from the recipient’s computer.

- Unsolicited email or spam is becoming a problem. Because it is simple to send thousands of identical emails to users at the same time, some merchants acquire lists of email addresses and compile these into distribution lists. They then send the same advertising email to everyone on the distribution list. To overcome this, anti-spamming software is now available which identifies certain addresses as sources of spam and discards any mail that comes from them.

**Electronic Commerce (E-commerce)**

E-commerce is the name given to the process of carrying out commercial transactions over the Internet.

One of the best known examples is Amazon.com. You can purchase books anywhere in the world from this web site. You make payment using your credit card at the time you make the purchase. Amazon.com exemplifies many of the characteristics of e-commerce. You are entitled to post a comment on the site, whether good or bad, about any book you buy. Before you purchase a book, you can look through the comments of other purchasers. They also have a procedure in place that allows you to return books under certain circumstances.

To purchase goods using an e-commerce site you need to provide a name and physical address to which the goods must be sent and a credit card. You can also specify the delivery method. This will depend on how urgently you need the goods and how much you are willing to spend on delivery. Good e-commerce sites will tell you in advance the availability of the goods, how long delivery will take depending on the delivery method chosen and the cost of delivery.

There are two types of e-commerce site. Business to consumer or B2C sites sell directly to the consumer. Other sites involve transaction between business themselves. These are Business to Business or B2B sites.

**CNP transactions**

When a purchaser uses a credit card to purchase goods, this is known as a Card Not Present or CNP transaction, since the vendor does not physically see the credit card. A purchaser not only has to give the credit card number but also the three digit security code. This means that there are a number of dangers associated with CNP transactions.

In utilising CNP transactions, vendors need to be sure that:

- The card is not being used fraudulently.
Purchasers need to be sure that:

- They can afford the goods they are buying. It is very easy to spend money using a credit card on the Internet.
- The vendor will not abuse the information and make unauthorised debits. Purchasers should not deal with any unknown sites.
- The information will not be stolen by employees and used fraudulently. Once again, well known reputable sites will have measures in place and will generally take responsibility if anything does go wrong.
- The information will not be stolen and used by hackers. Only use sites that are able to encrypt the information you send using a secure link such as SSL. This eliminates the risk of insecure payment methods.
- They do not use public accessible computers such as in Internet cafés to do transactions. People can easily access information provided through the computer after you have left.

**Doing Business over the Net**

**Advantages of on-line purchasing**

- No restriction on shopping hours. You can purchase goods 24 hours a day, seven days a week.
- You are not put under pressure by a salesperson and have time to make a more rational purchase decision.
- You are not restricted to shopping in an area to which you have physical access. You can shop across the world.
- Usually it is much cheaper to purchase goods on-line from a virtual store. If you purchase at source you can eliminate the mark up of intermediaries. Further, on-line sites have lower overheads than conventional shops.
- You have access to a wider range of alternatives.

**Disadvantages of on-line shopping from a virtual store**

- It is more impersonal as you do not interact with a human being with whom you can discuss the product you wish to buy.
- You cannot physically see and touch the item you are buying.
- There are certain risks associated with purchasing goods on the Internet with a credit card. See the section on CNP transactions above.
- Returning defective or incorrect goods can be a problem. This is especially the case if they have come from another country.
Summary

In this section you:

- Discussed the use of computers and communication technology in our everyday life, including:
  - Corporate Applications
  - Public Sector Applications
  - Health Sector Applications
  - Education Sector Applications

- Identified situations where a computer might be more appropriate than a person for carrying out a task and where not.

- Discussed some of the advantages of teleworking such as reduced or no commuting time, greater ability to focus on one task, flexible schedules, reduced company space requirements.

- Discussed some of the disadvantages of teleworking such as lack of human contact, less emphasis on teamwork.
Computer Security

Section Overview

Welcome to this section on computer security. After studying this section you will:

- understand the term information security
- be familiar with privacy issues in computing
- understand the importance of data backup
- be aware of possible implications of theft of computers
- understand the danger of computer viruses and the best practices for downloading

Information Security

Because information and information technology are fundamental to just about all aspects of modern life, the modern era is often referred to as the Information age. By its very nature, much information is private and confidential. Information security refers to all the procedures which are used to protect information for deliberate or accidental misuse or dissemination. Technically, it refers to the maintenance of the integrity of information. Integrity means that the information remains correct at all times and cannot be accessed by unauthorised agents.

Personal privacy

If personal information such as health or finance status, personal or family issues and background details became available to unauthorised agents, this could lead to the standing of individuals being seriously compromised. In some cases it may have little more effect than a feeling of invasion of personal privacy, while in other cases it may lead to serious embarrassment, loss of status or job and even blackmail.

Company confidentiality

Business functions by trying to achieve a competitive edge. This is achieved by making better products and having better marketing strategies. If competitors found out the formulation of products or details of manufacturing or the marketing plans for new products, a company would lose its competitive edge. There is a whole dark area to business known as industrial espionage in which a variety of means are used to discover trade secrets and business dealings. Obviously, there is an absolute imperative to maintaining the confidentiality of all company information.

A less obvious breach of information security occurs through industrial espionage where information is either changed or deleted to sabotage the functioning of the organisation.
Protecting company information

There are a number of procedures companies can take to protect their information and these would usually be detailed in a company policy document which would be explained to staff on appointment. Often a personal copy of this document is given to each employee for their records.

Staff employment practices

Basic to good company security is loyal and trustworthy staff. If staff members are likely to have access to sensitive information, they should be thoroughly screened before they are employed. The more sensitive the information they have access to, the more vital is this process. Promotion to more sensitive positions can be based on a good history or loyalty and trust. Part of the staff induction process and on-going staff training should inculcate in staff the importance of security and an awareness of the consequences of its violation.

Security procedures

Information should be classified on the basis of its sensitivity. Access rights to this information should be limited to those who need to know. To access certain information, an employee might need a special security clearance. All access to sensitive information should be recorded. The question of access rights is discussed further in the next section. Sensitive information that is stored in the form of paper files should be kept in a secure vault. Procedures should be in place to enable staff to report breaches or suspected breaches of security. They should be able to report these without fear of reprisal. In large organisations security departments can be established specifically for the purpose of providing such channels and monitoring security on an on-going basis. This is often done in conjunction with forensic auditing. This is a special form of auditing to detect mismanagement and corruption.

Privacy Issues

Information stored on computers

All computers from laptop computers to mainframes contain information. Much of this, whether corporate or personal, is confidential. Many thousands of laptop computers containing important company or State information have been stolen. Since most corporate records are now kept in electronic form on computer systems, procedures need to be put in place to protect the computers.

Apart from deliberate violations by people, computers are also subject to accidental damage and natural disasters.

Physical procedures

Physical access to mainframes should be restricted to operators and systems administrators. Facilities should be fire and flood proof. Highly
sensitive installations should also have adequate protection from criminal and terrorist activities.

Desktop and laptop computers are very vulnerable to theft. A simple procedure is to only allow authorised people access to offices. The use of security cameras can also act as a deterrent. Desktop computers can be physically attached to the floor or a work surface.

Laptop computers present the greatest risk. They are not only light and easy to pick up, but they are also more expensive and valuable than desktops. The best protection is not to let them out of site. If a manager is staying at a hotel, he or she can leave the computer in the hotel safe rather than their room.

Software procedures

Information can be stolen, altered or deleted without the computer being physically removed. The information may even be accessed across the Internet.

Firewalls

A firewall is the first line of defence against hackers. It is a computer program that is installed on a computer that connects a network to the Internet. The firewall analyses the packets that pass in and out of the network. It is programmed to follow certain rules which enable it to decide whether or not to allow a packet to pass. There is firewall software available that can be installed on a stand-alone PC.

Access rights

Access rights can refer to both physical and software. In a physical sense, these refer to different members of staff who have to gain physical access to certain areas. For example, access to the room containing the mainframe may be restricted to operators. Software rights refer to the level of access different users have to different levels of data and information. For example, some users may have no access to certain data, others may only be able to read the data but not change it. Others in turn may have full rights to create and change data. Access rights are associated with a user id and password. A user id could be a user name or a combination of letters and numbers. To log on to a system a user would need a user id and a password. As other users may know the user id of colleagues, another level of security in terms of passwords needs to be added. Passwords are private and should never be divulged to anyone else. Users could have several user ids, each with a different level of security. They would log on each time with the lowest level of security they need to accomplish a given task.
Password policies

Password policies refer to guidelines or requirements on the structure and use of passwords. They can be required for access to a computer system or a group of files or a single file. The following are some guidelines for password policies:

- They should never be blank.
- They should not be the names of family members or pets or anything else that would be easy for an intruder to try out.
- Ideally they should never be words, especially words like administrator, admin or root.
- They should never be less than five characters and preferably longer. Short passwords can easily be determined by a brute force password cracker. This is a piece of software that repeatedly feeds in all combinations of letters and numbers until access is gained. With short passwords this can be done in seconds.
- A good policy is to use a meaningless combination of letters and numbers that is seven or eight characters long. What some users do is to take a meaningful word such as looking and replace the o with the number 0 and the letter i with the number 1 so that the password becomes l00k1ng. You could also make a less obvious change, for example replace k with 3 and g with 9 so that the password becomes loo3in9.
- Passwords should be changed on a regular basis. Administrators can set a policy that automatically causes passwords to expire after a certain period of time, for example 7 days.
- When using a PC, you would need to use an operating system that provides genuine access protection with a user id and password. This means using Linux or Windows NT/2000/XP/2003. In Windows 95/98/Me the logon procedure can be bypassed. If Windows NT, 2000, XP or 2003 are used, it should be in conjunction with the NTFS file system (NTFS is the standard file system of Windows NT and later versions of Windows).

Data encryption

Data should be encrypted. Encryption scrambles the data and makes it unintelligible without the use of a key. The key is used to decipher the data.
Vulnerability of data (Data Backup)

Data is vulnerable in many ways:

- The system on which it is stored can fail. For example, a hard drive may crash due to component failure.
- The medium itself may become corrupt. Where data is stored on a magnetic medium, this can become corrupt due to a number of factors including moisture, heat, magnetic fields and electromagnetic radiation. Even optical storage which is highly reliable should never be regarded as infallible.
- The system can be stolen.
- The system could be physically damaged through war, criminal activity, vandalism or carelessness.
- The system could be damaged as a result of a natural disaster such as a flood, fire or earthquake.
- The data could be deleted or changed through criminal activity, vandalism or carelessness.

No matter what care you may take to protect a system, additional copies of data need to be made and stored on a regular basis. Copies of data are referred to as backups. The following are some guidelines to working with backups.

Once backups have been created, they should be stored in a secure area at a different site. Never keep backups on the same site as the system. They could be stolen or destroyed along with the rest of the system.

- Backups should be made on a very regular basis. Even for a small organisation, this should be done daily. Even the loss of a single day’s work would be a major problem. In large organisations backing up may take place on an on-going basis. A schedule of backing up should be clear policy and strictly adhered to.
- More than one copy of data should be made. If the data is very valuable, the different copies could be stored in different secure locations.
- Different versions of the backup should be retained. The following is an example of a backup schedule that could be followed.

The cycle of backing up starts on the first Monday of the month. At the end of each day of the week a backup is made. At the end of the week, there is a Monday, Tuesday, Wednesday ... Saturday backup. On Sunday a backup is created and labeled Week 1 backup. This is kept for the rest of the month. The weekday tapes are then reused and the process repeated. At the end of the month you end up with a series of weekly backups. The last one becomes the backup for the month and the process starts over the next month. At the end of the year you then have a series of monthly backups.

- An appropriate medium for backing up must be used. In the case of companies this would generally be done using tape, although
optical storage is becoming more common. For personal use, a CD or DVD makes an excellent backup. Never use diskettes for backup purposes. They are not reliable for this purpose. Even when backing up a PC, make multiple copies and keep them at another site for safe storage. You could, for example, use a safety deposit box at a bank.

Often a network server has two identical hard drives, one being a mirror image of the other. This means that if one fails the other one can take over. In other words all the software on the first is identical to the software on the second.

Software can be backed up by making a copy of the CD/DVD media and then storing the originals and using the backups to install from. This is allowed by most software manufacturers. The original is kept under lock and key along with the licence numbers.

**Implication of Theft**

Highly portable devices such as cell phones, PDAs and laptop computers can contain vital and confidential information. Even if the information is not confidential, it could be vital to your work. Losing your contact list or diary will very seriously compromise your business operations.

PDAs, cell phones and laptops usually contain contact lists and diaries. Make sure that copies of these are kept elsewhere. Cell phones and PDAs come with synchronisation software. This software links the device with a personal computer or laptop and updates each of them with the latest data. In other words, if you keep your diary on your PDA, synchronising will automatically update the diary (and contacts) on the PC or laptop. You should make sure that your diary and contact list are on two different devices. These should be kept apart so that they are unlikely to be stolen at the same time. Ideally, you should make backups of these at the end of every day and keep these backups in a safe location.

Although you can at least retain your diary, contacts and files through the use of backups, loss of these can compromise you seriously. If for example, you keep information of your bank and credit cards details on your PDA, cell phone or laptop, a criminal could make use of these if they steal these devices.

Personal information and telephone numbers of friends and business colleagues could make them vulnerable to the activities of criminals.

**Computer Viruses**

A computer virus is a program that is deliberately created to cause annoyance or alter or delete data. Some viruses cause computer systems to slow down to the point where they are not usable. One of the features of viruses is that they are designed to replicate and spread.
Types of Viruses

**Trojan:** A Trojan (or Trojan horse) is a virus that hides itself inside another legitimate program. When the program is used, the virus is released and can begin its work of replication and annoyance or damage.

**Worm:** A Worm is a program that replicates itself over and over in the computer’s memory until the computer can barely function. One of the signs of invasion by a worm is the slowness of computers.

**Time bomb:** A time bomb is a virus which lies dormant until a certain date or time or for a period of time. At this date or time, the virus suddenly becomes active and carries out whatever task it is programmed to do. This can include the deletion of everything on the hard drive.

**Logic bombs:** A logic bomb is similar to a time bomb, except that instead of becoming active at a certain time, it becomes active when a particular activity happens. For example, instead of formatting a diskette, the virus causes the hard drive to be formatted.

**Macro-viruses:** Macro-viruses make use of a special customisation feature in applications called macros. Macros allow you to create mini-programs to carry out certain tasks in your applications.

Spread of computer viruses

Viruses are spread in a number of ways:

- downloads from the Internet
- pirated software
- exchange of diskettes
- in attachments to emails and in emails themselves
- in documents – macro-virus, described above, can be hidden in ordinary documents, spreadsheets and presentations

Virus Protection

The actions of computer viruses were discussed in the previous section. The measures you can take to protect yourself against viruses will be discussed in the next section. One of the main measures to protect against viruses, anti-virus software, is discussed in this section.

**Anti-virus software**

Anti-virus software scans files for pieces of code, called signatures, which it recognises as part of a virus. Updating anti-virus software mostly involves updating the signatures file. This should be done on an as frequent as possible basis. This is even more the case when you receive files regularly from outside sources. The actual anti-virus program itself will be updated from time to time. These updates will include additional features and improved methods of scanning.
It is important to keep in mind that no anti-virus software is perfect. It is only as good as the techniques it uses for detecting viruses and the currency of the signature file. There is always the chance that a virus will go undetected. However, a good anti-virus system installed on your system is essential and will usually detect most viruses.

When a virus is detected, the software will attempt to remove the virus. This is called cleaning or disinfecting. It sometimes happens that the system can detect the virus but not get rid of it. In this case, you will usually be given the option of deleting or quarantining the infected file. When a file is quarantined, it is made unusable and so unable to spread the virus. A future update of the software may be able to remove the virus. If it can the quarantine is removed.

**Best Practices when Downloading**

There are a number of measures you can take to protect yourself from viruses:

- Install good anti-virus software and update it on a regular basis, for example at least once a month but preferably once a week. But always remember, anti-virus software is not perfect. It cannot be the only measure you take.
- Scan all diskettes before reading them.
- Enable the auto-protection feature on the anti-virus software to scan emails.
- Be wary of emails from unknown sources, particularly if they contain attachments. Some very careful users delete emails they are unsure of without opening them.
- Use an Internet Service Provider that scans emails before delivery.
- Do not download files/software from unknown Internet sites.
- Be careful of using diskettes from unknown sources.
- Do not install pirated software.
Handling Viruses

Using Virus Scanning Applications

Because viruses are still uncommon on Linux systems, there has not been a great deal of development of anti-virus software. One example of open-source antivirus software that scans computer files as well as incoming emails is KlamAV.

The Importance of Updating Virus-Scanning Software Regularly

As viruses are created on an on-going basis, they need to be analysed continuously by the developers of anti-virus software. Not only do the developers need to be able to extract the signature of the virus, they also need to analyse how the virus acts and how it can be removed from the program. These changes then need to be incorporated into the anti-virus software.

Users in turn need to download these changes and update their software. The longer the period between updates, the more vulnerable computer systems are to the action of new viruses. Updates are often made available on a daily basis by developers.

Summary

In this section you:

- became familiar with the main aspects of information security, including:
  - Personal privacy
  - Company confidentiality
  - Staff employment practices
  - Security procedures
- understand the importance of data backup
- became aware of possible implications of computer theft
- understand the danger of computer viruses and the best practices for downloading files.
Copyright and the Law

Section Overview

Welcome to this section on Copyright and the Law. After studying this section you will:

- understand the concept of copyright when applied to software and different types of electronic information
- know about shareware, freeware and end user license agreement
- be aware of data protection legislation

Copyright Concept

Copyright refers to the legally protected right to publish and distribute any literary, musical, artistic or software material. This means that only the developer and authorised sellers have the right to copy and distribute computer software, video materials, music or text.

Because there is no control over the Internet, there are hundreds of sites where software, music and videos can be downloaded. Access to permanent connections makes downloading of large files physically possible. Many of these sites are located in countries that do not protect copyright.

The fact that it is possible to copy/download something, does not make it legally and ethically right. Authors and developers are entitled to a return on their creative efforts. Downloading pirated material is both ethically and legally wrong. By reducing revenue, piracy can hamper the development of software. Software development is expensive and part of the royalties are needed for future development.

Software piracy is a form of theft. It is both a criminal and a civil offence. Developers are entitled to claim damages in cases of piracy. Increasingly they are making use of all legal avenues to reduce piracy and obtain compensation where it has occurred. They are entitled to claim damages against not only sites, organisations and individuals who make pirated software available, but also those who make use of it.

Downloading from the Internet is not the only form of software piracy. Making copies of software, other than for personal use, as well as installing software on more computers than specified in the licence agreement are also forms of piracy.
Copyright Issues

When you purchase software, you are actually purchasing the right to install the software on a specified number of machines. Software usually comes out in two forms, standalone and network. When you purchase standalone software, you are purchasing the right to install it on a single machine. Generally there are further restrictions that are specified in the licence agreement. Licence agreements are covered in the next section.

When you purchase a network version of the software, you purchase the right to install the software on computers attached to a particular network. This may give you the right to install it on all the computers on the network or a certain maximum number.

It is important to realise that you do not purchase the actual program. The program remains the intellectual property of the developer. The concept of intellectual property is used as the developer owns something abstract, something which is the result of considerable intellectual effort. This also means that you do not have the right to alter the program in any way other than the configuration allowed in the installation.

However, you may store the program on CD, DVD, zip disk, diskette, hard drive or tape, the program still remains the intellectual property of the developer. This does not mean that you may lend the stored program out to others, though. This would be a breach of copyright. The stored version is for that purpose only as a backup and for the licensed user only.

The section on licence agreements in the next section specifies some of the copyright issues in more detail.

Licencing Issues

Licence agreements

As mentioned in the previous section, when you purchase software, you only purchase the right to use the software subject to certain conditions. These conditions are specified in the licence agreement. When you install the software onto a computer, there is always a stage where you have to make a selection that you have read and accept the terms and conditions of the licence agreement. When you do this, you are agreeing to the developer’s rights under copyright law.

The terms of the licence agreement include the following:

- clarification of the licence as meaning the right to use the software, not ownership of the intellectual property
- the number of machines on which the software may be installed
- restrictions on copying the distribution CD
- restriction on the resale of the software
- prohibitions on altering the code and reverse engineering. Reverse engineering involves a process of uncovering the logic and algorithms used to develop the program
Shareware

Shareware is software, generally downloaded from the Internet, which can be freely used and distributed. However, it does require that if users would like to continue using it, they pay the developer a fee. This is nearly always done by means of a credit card transfer across the Internet. When payment is received, users get a serial number which they insert into the software.

To attempt to enforce payment, developers usually employ a number of methods:

- Nag notices. These are notices that appear on a regular basis reminding the user that the software has not yet been registered.
- Time limitations. The software can be used for a certain period of time. At the end of this period it ceases to work.
- Function limitations. The shareware version may exclude certain key features.

These limitations would be removed when a valid serial number is entered.

Freeware

Freeware is software which can be freely copied and distributed. Usually there are certain restrictions such as it may not be resold or its source should be acknowledged.

Open Source Software

An interesting evolution in software development is the Open Source Movement. This movement has the objective of creating software that can be distributed freely, changed and used at no charge. Developers all over the world are encouraged to become part of the movement. Many corporations are playing an active role in the development of open source software. Two examples are Linux and OpenOffice.org. The development of Linux is being actively supported by corporations such as IBM and Sun Microsystems. Sun Microsystems are central to the development of OpenOffice.org.

Open source software is still subject to a licence agreement. However, the licence agreement is quite different in tone and purpose from that attached to commercial software.
The following is an extract from the licence agreement of KOffice, another Open Source office application suite.

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public Licenses are intended to guarantee your freedom to share and change free software-to make sure the software is free for all its users.

This license, the Library General Public License, applies to some specially designated Free Software Foundation software and to any other libraries whose authors decide to use it. You can use it for your libraries, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure that you have the freedom to distribute copies of free software (and charge for this service if you wish), that you receive source code or can get it if you want it, that you can change the software or use pieces of it in new free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender the rights. These restrictions translate to certain responsibilities for you if you distribute copies of the library, or if you modify it.

For example, if you distribute copies of the library, whether gratis or for a fee, you must give the recipients all the rights that we gave you. You must make sure that they, too, receive or can get the source code. If you link a program with the library, you must provide complete object files to the recipients so that they can relink them with the library, after making changes to the library and recompiling it. And you must show them these terms so they know their rights.

Data Protection Legislation

Because of the all-pervading nature of information and communications technology as well as the ease with which data can be accessed and transferred, some countries have introduced legislation to protect the privacy of individuals and organisations.

The purpose of data protection legislation is to specify how data may be obtained, stored and used. This type of legislation can be very technical and complex. Some of the key points of the Data Protection Act of 1998 of the United Kingdom are set out below as an illustration of the issues covered.
The provisions of the act refer to data in whatever way it is stored, whether electronic or paper.

- Personal data should be obtained in a fair and lawful way.
- Data should be processed in accordance with its original purpose. If data is to be used for purposes other than for which it is collected, safeguards need to be put in place to avoid abuse.
- Data must be up-to-date and accurate.
- Data must not be kept for longer than is necessary.
- Appropriate security measures must be in place to prevent:
  - unlawful or unauthorised processing;
  - accidental loss;
  - damage; and
  - theft.
- Personal data may not be transferred.
- Data may not be used for certain purposes such as direct marketing.

In addition, subjects of the data have certain rights. These include the right to access data held about them.

**Summary**

In this section, you:

- discussed the concept of copyright when applied to software and different types of electronic information
- learned about shareware, freeware and end user license agreements
- learned about data protection legislation
Health Safety and Environment

Section Overview

Welcome to this section on Health, Safety and Environment. After studying this section you will be able to:

- understand what elements and practices can help create a good working environment
- become aware of issues related to health and environment and the precautions that can be taken

Ergonomics

Ergonomics is the science of co-ordination of the physical and psychological aspects of human beings with their working environment. Although computers present us with great opportunities for making our work easier, they do present some health and safety risks if used incorrectly. The science of ergonomics tells us how to use computers correctly.

Monitors

If you work with a monitor, tired, sore or blood-shot eyes indicate eye strain. The following points indicate some aspects of monitors to be aware of.

- **Refresh rate**
  
The refresh rate of a monitor is the rate at which it updates the images on the screen. When the refresh rate is too low, the screen appears to flicker. Apart from the annoyance factor, this causes eye strain. The refresh rate should be at least 72 Hz (72 times a second) and preferably higher.

- **Reflection/Glare**
  
Reflections/glare on the screen can cause eye strain. This can be overcome by using a monitor filter with an anti-glare screen or by placing a special anti-glare cover in front of the screen.

- **Focus**
  
The image on the screen should be sharp. Poor quality monitors have a slightly blurred effect. This causes the eyes to continually attempt to reduce the blur.

- **Low radiation**
  
The beam of electrons that strikes the screen to display the image also sends out electromagnetic radiation. There is some fear that this can be a
health hazard, particularly to pregnant women. Use a monitor with low electromagnetic radiation.

- **Position**

Place the monitor in a position where you can look into the distance at regular intervals. To the side of a window is an ideal position. You need to change the focus of your eyes on a regular basis to prevent eye strain.

- **Angle**

The monitor should be slightly below eye level. Looking up at a monitor can cause strain in the neck.

- **Rest**

Take regular rest periods where you do not look at the monitor.

**Keyboards and mouse**

Repeated use of the same muscles and joints can result in a type of injury called RSI or Repetitive Strain Injury. This type of injury can range from inflammation of joints, to damaged ligaments and muscles or even hairline fractures in bones. RSI is usually caused by the incorrect use of the keyboard and mouse.

- **Ergonomic keyboards**

Ergonomic keyboards are designed in such a way that the strain on the hands and finger are reduced.

- **Touch typing**

Learning to touch type can help reduce strain as it distributes the work evenly between the fingers. Users who can touch type also tend to use far less force when striking the keyboard.

- **Mouse mats (pads)**

Mouse mats or pads are available with a cushion for the wrist to rest on. Repeated clicking of the mouse buttons can lead to inflamed finger joints. Resting the wrist on the cushion reduces this effect.

Rest: Take regular breaks to rest the muscles and joints.
**Desks and chairs**

- **Height and position of chairs**

  The height and position of the chair is an important factor in reducing strain. These should be adjusted so that:
  - the feet can rest flat on the floor. This maintains blood circulation
  - the thigh is horizontal to the floor
  - the head can be kept upright in line with the spinal column. If the chair is too high, the head will be bent. This will in turn cause backache

  A chair with adjustable height will allow you to find the most appropriate and comfortable height for your build.

- **Posture**

  The back should be slightly bent forward. Sitting rigidly upright for long periods can cause stress in the back and shoulders.

- **Support**

  There should be support for the lower back to avoid sitting in a hunched position.

- **Rest**

  It is important to get up and move around on a regular basis and do some stretching exercises to help relax tense muscles.

- **Height of the desk**

  A common problem is having a desk which is too high. This is largely a matter of trial and error. A good test is whether the elbows are able to rest comfortable on the work surface.
Health Issues

Lighting and ventilation

It is important to ensure that there is adequate lighting, but does not cause glare on the screen. Another important consideration is whether there is enough air circulation in the room as computers generate a lot of heat and if a room is not adequately ventilated it can become stuffy and cause fatigue. It is also not good for the equipment so most companies make use of air conditioning.

Other health problems associated with using a computer as discussed in the previous section are listed below:

- repetitive strain injury
- eye strain caused by the glare on the screen
- back problems due to poor seating or bad posture

Precautions

Apart from health issues, there are a number of safety issues associated with the use of computers.

Adequate grounding (earth)

A faulty grounding system can cause electrical shock. A good system will be properly grounded and will incorporate earth-leakage detection. If the system detects a fault that could lead to electrical shock, a switch will trip before any damage can be done.

Cabling

It is common to see electrical cabling lying on the floor of offices. Apart from the fact that it looks untidy, workers can trip over cabling. Electrical cabling should be installed by electricians so that there is a minimum of open cabling. Electrical power sockets should be installed close to workstations so that there is no need to run cabling across the floor. The cabling between the power point and the computer should be secured using cable ties.

Load on power points

There should be adequate power points for the equipment. Overloaded power sockets are a fire hazard. If there is any sound of sparking in a power socket, the cause should be investigated by a qualified electrician.

The Environment

Paper

One of the goals on information technology was the paperless office. The reality is quite different and users are often careless and wasteful in the
use of paper. The cost factor will be considered in the next section. From an environmental perspective, waste of paper is very damaging. Here are some things that you can do to reduce the environmental impact.

- Do not throw paper away. Set up a storage area for paper that cannot be re-used. Have this collected on a regular basis for recycling.
- Print on both sides of the paper. Unless you are producing a document in final form, print on the reverse side of used paper.
- Alternatively, look for organisations that can make use of this paper. Many poor schools would be very glad to get supplies of paper that can still be used on one side.

**Consumables**

Often users throw used toner and ink cartridges away. There are two alternatives. You can have them refilled or if this is not an option because of guarantee restrictions on printers, you could resell them to companies which refurbish cartridges for resale. In either case, you reduce the waste output from your organisation.

**Power**

Another area where users are often careless is electrical power consumption. For example, many users only switch their monitors off at the end of the day so they do not have to boot up in the morning. Apart from the security risk, this means that the computer is running all night and wasting electrical power. Switch off any equipment that does not need to be on.

When purchasing equipment, low power options should be selected. An example would be the purchase of flat LCD screens over older CRT monitors as these consume less power.

It is also possible to configure the computer to save power. For example, when a component, such as the monitor, has not been used for a while, the computer can shut it down after a period of time to save power.

**Environmental Consciousness**

Using networks and email, there is little need to send printed documents. Rather send them in electronic format. In addition to avoiding printing, it is faster and more efficient.

Avoid printing documents even for your own use unless it is necessary. It is quite possible to do much of your reading on-screen. Set the zoom and font size to facilitate on-screen reading.
Older, used computers present an environmental hazard when they go directly to a landfill before being processed. Certain chemicals in the computer’s construction can lead to degradation of land and water. Research the options in your community for environmentally safe ways to dispose of old equipment.

**Summary**

In this section you:

- Learned how the science of ergonomics helps us to use computers correctly to avoid physically injury.

- Discussed health issues and other precautions that should be taken when using computers.

- Discussed the effects of our computer use and disposal on the environment and ways we can minimise this effect.
Module summary

In this unit, you learned:

- Computer hardware is the physical part of a computer, including its digital circuitry.
- What the main types of personal computers are.
- What the main parts of the computer are.
- The common types of computer hardware, including processors, memory, input devices and output devices.
- What computer software is.
- Software is divided into two broad categories: systems software and application software.
- A graphical user interface or GUI is designed to simplify the work of the user whether they are using the operating system or an application package.
- The stages of software development are known as the program development life cycle.
- Computer networks are a set of computers connected together so that they can communicate.
- The main categories of computer networks.
- About the use of computers and communication technology in our everyday life.
- The concept of copyright when applied to software and different types of electronic information.
- How the science of ergonomics helps us to use computers correctly to avoid physically injury.
- About the effects of our computer use and disposal on the environment and ways we can minimise the negative effects.
Module 2

Using the Computer and Managing Files

Module Overview

Welcome to Module 2: Using the Computer and Managing Files.

In this module you will be introduced to Ubuntu Linux Operating System (version 9) with Gnome desktop environment.

Upon completion of this module you will be able to:

- Use the main features of the operating system including adjusting main computer settings and using built-in help features.
- Operate effectively around the computer desktop and work effectively in a graphical user environment.
- Understand the main concepts of file management and be able to efficiently organise files and folders so that they are easy to identify and find.
- Use utility software to compress and extract large files and use anti-virus software to protect against computer viruses.
- Demonstrate the ability to use simple text editing and print tools available within the operating system.
- Set up a printer in Ubuntu and use the Print Manager utility to monitor, cancel, pause and resume printing.

Terminology

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>GNOME Desktop</td>
<td>The graphical user interface for the Ubuntu operating system.</td>
</tr>
<tr>
<td>Operating System</td>
<td>An interface between the computer hardware and the computer user. It is the software program responsible for the management of activities and the sharing of resources of a computer.</td>
</tr>
</tbody>
</table>
Ubuntu is an African word meaning “Humanity to others” or “I am what I am because of who we all are”. It is also a community-developed operating system based on Linux.

Window
A rectangular area of the screen that displays an application running on your system.

Mounting and Unmounting
The process of adding and removing components to the Linux directory hierarchy.

Home directory
When a new user is added to the system, Linux creates a sub-directory of the same name in the home directory. This sub-directory is known as the user’s home directory.

Panel
An area in the GNOME Desktop where you have access to certain actions and information such as launching applications, date and time, system sound, volume and more.

Securing the system
Shutting down, logging off or locking the system so that other users cannot access your information.

File system
A specification for storing and organising files on storage devices such as hard disks.

File extension
The part of the file name that follows the final period. File type can be recognised by the extension on the file name.

File compression
File compression is a way that a number of files can be compressed into a single file or a single file can be compressed to take up less space on a hard drive or other medium.

Study Tips
You may find it useful to skim through an entire block of content first, paying special attention to the headings and introductions, and then go through a second time for more in-depth study and practice.

However, we recommend that you do the activities as they appear (where you see the icon). They are essential study materials, offering practice in particular skills that will build your proficiency in word processing.

This module forms the basis for subsequent modules in this course. Keep linking the new content that you are studying with content in this module that you have already covered and with your own general knowledge, to deepen your understanding of the operations you are learning.
If you have difficulty understanding any area, try working at it slowly. If you still do not understand, seek help.

Pre-knowledge

Before beginning this module, we recommend that you:

- Study Module 1, because it provides essential background for this module.
- Be comfortable using a keyboard to input text and a mouse to click on objects.

The Ubuntu Operating System

Section overview

Welcome to this section on the Ubuntu Operating System. After studying this section you will:

- be able to start up and shut down your computer safely
- be able to login and logout of your Ubuntu operating system
- become familiar with the features of the GNOME graphical user interface
- be able to customise the GNOME desktop
- secure your system so that the information on your system is safe from others
- use the GNOME help files to get help
- install and remove applications in Ubuntu

Introduction

In Module 1, you learned that the operating system is a set of software that enables the computer to function by controlling hardware devices, allowing network capability and allowing software applications to work with hardware. In this section you will be introduced to one brand of operating system, Ubuntu Linux version 9 – also know as Jaunty Jackalope.

Ubuntu Linux can come in variations with three graphical user interface (GUI) environments: GNOME (Ubuntu), KDE (Kubuntu) or Xfce (Xubuntu). For this module, we will concern ourselves with the GNOME GUI.
First Steps with the Computer

Starting the computer

Most computers have an On/Off switch on the front. Press the On/Off switch on the front of the computer. This will initiate the boot process. During this process the start-up routines that are stored in the ROM of the computer will take control of the computer.

One of the things these routines do is to read certain areas of the hard drive to search for the operating system. The start-up routines will then load the operating system into the RAM of the computer and pass over control to it.

Depending on how the computer has been configured, one of three things will happen:

- The operating system will automatically load the GUI (Graphical user interface) and start this for a default user. The system will be available for immediate use.

- The operating system will automatically load the GUI, but you will be prompted to enter a username and password. These will be given to you by whoever installed the system.

- Only the text based operating system will load. In this case you will need to logon and then start the GUI. In this case you will see a black screen on which the prompt Logon: appears.

Logon to Ubuntu

After Ubuntu has gone through its boot procedures, either the GUI will load or you will be prompted to input your username and password. If you need to use username and password to access your system, remember that passwords are case sensitive. If you are given a password, you must enter it exactly as given.
When you have successfully entered your username and password, the GNOME desktop will load.

The GNOME Graphical User Interface

 GNOME provides you with a graphical view that makes it easier to perform tasks either using the keyboard or with the click of a mouse.

The image below illustrates the main features of the GNOME graphical user interface.
Windows

A window is a rectangular area of the screen that displays an application running on your system. Windows usually have a border all around and a title bar at the top.

You can think of a window as a screen within the screen or as pieces of paper on your desktop. You can have many windows open at once, allowing you to have more than one application visible and work on more than one task at a time.

Windows can overlap or be side by side. You can control a window’s position of the screen, as well as its size. You can control which windows overlap other windows, so the one you want to work with is completely visible.

Below is an example of a window containing the Ubuntu Help Center application.

![Ubuntu Help Center window](image)

Working with Windows

Move the window

Drag the title bar to move the window. You can click on any part of the title bar except the buttons at either end to begin the drag action. The window will move on the screen as you drag the mouse.

Resize the window

Drag one of the borders to expand or contract the window on that side. Drag a corner to change two sides at once. The resize pointer appears when your mouse is in the correct position to begin the drag action.

Minimise the window

Click on the Minimise button in the title bar, the leftmost of the group of three on the right. This removes the window from view.
Maximise the window

Click on the Maximise button in the title bar, the middle of the group of three on the right. This expands the window so it fills the screen (the panels remain visible).

Unmaximise the window

When a window is maximised, click again on the Maximise button to restore it to its previous position and size on the screen.

Close the window

Click the Close button, the rightmost of the group of three on the right. Closing the window may also close the application itself.

Scrolling

If the application that is open is too large for the window, you will see scroll bars either on the right, bottom or both. Drag the scroll bar or click on the arrows at either end of the scrollbar to scroll through the windows contents.

Panels

A panel is an area in the GNOME Desktop where you have access to certain actions and information. For example, you can launch applications, see the date and time, control the system sound volume and more.

By default, the GNOME Desktop contains a panel at the top edge of the screen and a panel at the bottom edge of the screen. You can customise panels to your liking. You can change their behaviour and appearance and you can add or remove objects from your panels. You can create multiple panels and choose different properties, objects and backgrounds for each panel. You can also hide panels.

Working with Panels

Move a panel

Drag a panel to another side of the screen to move it there. Click on any vacant space on the panel to begin the drag.
Panel properties

Right-click on a vacant space on a panel, then choose Properties from the context menu. You can set the following panel properties:

- **Orientation**: Select the position of the panel on your screen. Click on the required position for the panel.

- **Size**: Use the spin box to specify the size of the panel.

- **Expand**: By default, a panel expands to the full length of the edge of the screen where it is located. A panel that does not expand can be moved away from the screen edges to any part of the screen.

- **Autohide**: Select this option if you want the panel to only be fully visible when the mouse pointer is over it. The panel hides off-screen along its longest edge, leaving a narrow part visible along the edge of the desktop. Move the mouse pointer over the visible part of the panel to make it move back into view.

- **Show hide buttons**: Select this option to display hide buttons at each end of your panel. Clicking on a hide button moves the panel lengthways, hiding it off-screen except for the hide button at the opposite end. Click this hide button to restore the panel to being fully visible.

- **Arrows on hide buttons**: Select this option to display arrows on the hide buttons, if the hide button is enabled.

- **Background**: Click on the Background tab to set the background colour or image for the panel.

Adding and Deleting Panels

To add a panel, right-click on a vacant space on any panel, then choose **New Panel**. The new panel is added to the GNOME Desktop. The new panel contains no objects, but you can customise it to suit your preferences.

To delete a panel right-click on the panel that you want to delete, then choose **Delete This Panel**.

**Note**: You must always have at least one panel in the GNOME Desktop. If you have only one panel in the GNOME Desktop, you cannot delete that panel.

Users Guide

Securing your system

Locking, Logging Off and Restarting the Computer

When you are finished your Ubuntu session, it’s a good practice to either lock, log off or shutdown your computer. The main reason for this has to do with security – if your computer is left unattended with you logged in, others could then use the computer and impersonate you.

- Click on the icon on the top-right part of your desktop. This will open a dialogue window with options for locking, logging off, restarting or shutting down your computer.

- Click on the option you want. The options are:
  - **Guest session**: this option effectively locks the screen for the current user, but creates a “guest” session so that someone else can use the computer, but without access to your settings or files.
  - **Lock screen**: this option locks the screen so that nobody can use the computer until you unlock the screen with your password.
  - **Log out**: this logs you out of the system. For someone to use the computer, they must first log in.
  - **Hibernate**: this option puts the computer in a “sleep” mode.
  - **Restart**: shuts down the computer and then restarts it.
  - **Shut Down**: shuts down the computer and turns the power off.

**Tip**: Never just shutdown the computer by pressing the On/Off switch. This can do damage to your operating system or hardware and could result in the loss of data. Always shut down from the Ubuntu menu.
Shut down a non-responding application

It may happen that an application freezes and will not respond to mouse clicks or keyboard commands. You can close the application without restarting your system by using System Monitor.

1. From the **Ubuntu System menu**, click on **Administration**, then on **System Monitor**.

2. When System Monitor loads, click on the **Processes** tab to view all of the processes running on the system.

3. Click on the non-responding process and then click the **End Process** button to shut down the application.

4. When done, quit System Monitor by clicking on the Close icon in the top right of the screen.

**What to do if the entire system freezes**

If the entire system freezes, do not immediately switch of the system with the power switch. This could cause serious damage to the entire system. This is only a final resort.
The most likely cause of a frozen system lies with the GUI.

1. Wait a while. The system may wake up on its own.
2. If the system doesn’t respond after a few minutes, press these keys on your keyboard at the same time: \texttt{Ctrl + Alt + Backspace}.

This will cause you to lose all unsaved work, but it will preserve the system itself.

### Getting Help

The help systems in \texttt{Ubuntu} are searchable databases of information about the operating system and applications you will be using. Along with help information on the Internet, they are a very good starting point for when you have questions or problems with your system.

#### The Ubuntu Help Center

To access the Ubuntu Help Center, click on the Help icon on the top of your screen.

You can either browse the help files by clicking on the links in the Help window or you can search for help on a specific topic.

#### Context Help

You can access help files on any application you are using by clicking on the \texttt{Help menu} from within the application. For example, if you want to get help with using the System Monitor, click on \texttt{Help} from within System Monitor and the click on \texttt{Contents}. 
Using Help as a Tutorial

Become as familiar as possible with the help system. These notes will provide you with an introduction to Linux using the GNOME desktop. When you have worked through a section in these notes, you could read what the GNOME help system has to say on the topic. If you wish to become an expert, you will need to read further and discover the full power of Linux. The help system is the best place to start.

Basic Information and Operations

The System Monitor

The System Monitor displays basic system information and monitors system processes and resources. As you have already seen in the previous section, you can also use System Monitor to change how your system behaves, such as closing non-responding programs.
To start **System Monitor**:  

1. From the **Ubuntu System menu**, click on **Administration**, then on **System Monitor**.

![Ubuntu System Monitor menu](image)

To close **System Monitor**:  

1. Click on the Close icon `❌` in the top right corner of the application.

**Viewing System Information**

The **System tab** in System Monitor will show you the following information about your system:

- distribution version (the version of the operating system you have installed)
- hardware: RAM, processor type and processor speed
- system status: available disk space

**Viewing Active Processes**

You have seen in the previous section that you can click on the **Processes tab** in **System Monitor** to view and, if needed, stop processes that are running on your system.

**Viewing Resource Use**

Clicking on the Resources tab shows you a display of your system’s CPU usage, memory usage and network activity as it is being monitored.

**View the File Systems**

The File Systems tab shows you what file systems are in use and how much disk space is being used and how much is available.
Desktop Configuration

In this section you will learn how to adjust your operating system settings to customise your GNOME desktop. You can access most system preference settings from the System menu by clicking on System and then Preferences:

or by clicking on System and then Administration:

Other settings can be accessed directly from the system window.
Set the Date and Time

1. From the **System-Administration** menu, click on **Time and Date**.

2. Click on **Unlock** to unlock the settings window and enter your system password when prompted.

3. Adjust the **time zone**, **date** and **time** on the calendar and clock.

4. Click **Close** when done.
Set the volume level

1. To access your sound settings, click on the Volume icon at the top of your system workspace.

2. Slide the volume control slider to the left or right to set the volume on your system.
Change the desktop appearance

3. From the System menu click on Preferences and select Appearance.

4. Click on the Theme tab to set a desktop theme. A theme is a group of coordinated settings that specify the visual appearance of the desktop.

5. Click on the Background tab to set the desktop background. You can either set a background colour or use a picture for the background.

6. Click on the Fonts tab to specify the fonts that are used in the desktop.

7. Click on the Interface tab to customise the appearance of menus, menu bars and tool bars.

8. Click on the visual effects tab to enable or disable a group of visual effects intended to make your desktop easier to use.

Change screensaver

A screensaver is a visual effect that occurs on your screen when your computer has been idle for a certain amount of time. Screensavers were designed to be visually interesting and to provide some motion on the screen since some older computer monitors are susceptible to damage if the same image is left on the screen for a long period of time.
1. To access screensaver settings, from the System-Preferences menu click on Screensaver.

2. Choose a screensaver theme from the list on the left of the window.
3. Set the length of time for the computer to be idle before the screensaver is activated.
4. Make sure the box is checked beside Activate screensaver when computer is idle. Uncheck this box to disable the screensaver.
5. If you like, you can have the screensaver lock the screen when it activates. This means that for someone to use the computer they will have to input their password.

**Set screen pixel resolution**

Note: This setting is not standard for all computers; it depends on the display card being used. You should refer to your video card documentation to set the screen resolution.

**Set keyboard language**

The keyboard language defines the position of the various keys on the keyboard. For example, British, American and French keyboards all have different layouts. If some of the keys generate a different letter to that shown on the key itself, it could be that the keyboard language setting needs to be changed.

1. Click on System>Preferences>Keyboard
2. When the Keyboard dialogue window opens, click on the Layouts tab.
3. Click on the Add button to add a keyboard layout.
4. Click on the **By language** tab to choose your new keyboard layout by language.

5. Choose a new keyboard layout from the **Language list** and **Variants list** and then click the **Add button**.

6. Click on the **Default radio button** to make this your default keyboard layout and then click **Close**.
Formatting Discs

Formatting a disk, device or partition means to prepare that device for storing data. When you format a device, you apply a specific data-storage format to that device. It’s important to keep in mind that the format you apply may not be read or written to by all operating systems. For example, you can’t format a hard disk for a Macintosh system and have the disk read by a Microsoft Windows system.

File systems

A file system is a specification for storing and organising files on storage devices such as hard disks. A file system is absolutely necessary for your operating system to be able to store and access files. Common file systems are:

- **ext2 and ext3**: These are Linux files systems. Ubuntu uses ext3 as its default file system.
- **FAT16 and FAT32**: These are older Windows file systems. If you need to format a disk that is going to be used on a number of different operating systems, FAT32 is a good choice because it can be read and written to by Linux, Macintosh OSX and newer versions of Microsoft Windows.
- **NTFS**: This is the file system for newer versions of Microsoft Windows.
- **HFS+**: This is the Macintosh OSX default file system.
You can access disks on your system from the GNOME menu by clicking on System>Administration>Partition Editor.

Installing and Uninstalling Applications

Install applications from distribution CDs

**Ubuntu Linux** maintains a database of applications and their locations. Initially these are applications that are stored on the distribution CDs. Depending on the particular installation, only certain of these may be installed on a given system. The following illustrates how to install **OpenOffice** from the **Ubuntu** distribution CDs.

1. System>Administration>Synaptic Package Manager.
2. Enter the root password when prompted.
3. Click All.
4. Click on OpenOffice to expand its contents.
5. Click on Mark for installation. A window appears warning you of dependencies. A dependency refers to other software which needs to be installed on the machine before the application can be installed.
6. Click Apply.
7. When prompted, insert the required CD and click OK.
8. Other prompts may appear. Respond by clicking OK if you wish to proceed with the installation.
9. Verify that the application has been installed.

Open Office can also be downloaded from [http://www.openoffice.org](http://www.openoffice.org)

**Install applications from a CD with an install program**

You may get an application as part of a CD or through a download across the Internet. In some cases these applications are distributed with an install file. Double clicking on this in a file manager will initiate an automated installation process. You then simply sit back and wait for the entire process to complete.

**Install an application using the File Manager**

The following illustration assumes the application is located on a CD.

1. Double click on the CD-ROM icon on the desktop.
2. Locate the directory in which the application installation file is located.(This process will be explained fully in the next section on file management)
3. Double click on the application.

**Uninstall an application**

The following example illustrates how to uninstall an application

1. Start Applications>System>Synaptic Package Manager.
2. Enter the root password when prompted.
3. Select the software you want to remove.
4. Select **Mark for Removal**.
5. Click **Apply**.

**Summary**

In this section, you learned:

- How to start up and shut down your computer safely and how to login and logout of the **Ubuntu** operating system.
- About the main features of the GNOME graphical user interface.
- How to customise GNOME to suit your personal preferences.
- How to secure your system so that your information is safe from other users.
- How to install and remove applications in **Ubuntu**.
- How to access help files in **Ubuntu**.
Section overview

Welcome to this section on File Management. After studying this section you will:

- understand the concept of directories and files as they apply to the Linux operating system
- be able to use the Nautilus File Browser to navigate through directories
- be able to change the view options for directories
- create, rename, move, copy and delete directories
- change permissions for directories
- understand how files are named and what filename extensions are
- be able to sort files by name, size and date modified
- create, rename, move, copy and delete files
- understand the importance of backing up data
- restore files from the trash bin
- empty the trash bin
- search for files and directories
- use a file compression utility

Concepts

To understand the concept of a directory, consider an analogy of an office block containing a number of offices. Each office has a name. Inside each office there are a number of filing cabinets, each of which is named. Files are stored in the filing cabinets. Each file also has a name.

Suppose a file called Lombard is located in the Staff cabinet of the Administration office. This could be described in a shorthand form as:

/Administration/Staff/Lombard

In the same way /Stores/Suppliers/Kumar would indicate a file called Kumar in the Suppliers filing cabinet in the Stores office.

Directories on a computer system are similar to the offices and filing cabinets. A directory is a container that can contain files or other directories. A directory located inside another directory is called a sub-directory. Sometimes the word folder is used in place of the word directory. One difference between the analogy and a computer system is that in the former case we are dealing with physical objects whereas in the latter we are dealing with a more abstract structure.

Directories, sub-directories and files are arranged in a hierarchical structure called a tree. A typical computer will contain many thousands of files stored in many directories. Each directory contains files that are related in some way. The starting point of the tree is called the root. Do not confuse this usage of the word with the special user that has complete
control over the system. Root is designated by the / symbol. This symbol is also used to separate the different levels of the hierarchy.

A directory structure may contain many levels of sub-directories. The following diagram illustrates part of a Linux system directory structure.

![Linux Directory Structure Diagram]

The full description of the location of a file is called is path. If we wish to describe a file fully, we need to include its path. An example from the previous diagram would be: `/home/david/Letters/Tax(2004-04-04).

Linux names are case sensitive. Hence the three names tax, Tax and TAX are all different as far as Linux is concerned. Using the wrong case for letters is a common source of errors.

If you have worked with Windows, the Linux directory structure may seem confusing at first. Each system has a single directory system. Drives are located within branches of the structure rather than the structure starting with a drive. Linux goes much further and includes devices such as ports and printers within the directory structure. This follows from the fact that Linux treats files and devices in the same way.

The process of adding components to the Linux directory hierarchy is called mounting and removing them is called unmounting.

The home directory is of special importance in Linux. When a new user is added to the system, Linux creates a sub-directory of the same name in home. For example, if the user dorothy is added, Linux will create the directory /home/dorothy at the same time. This sub-directory is known as the user’s home directory. Each user will create a further series of sub-directories in which he/she will store files.

Each user’s home directory is private to that user. Apart from the owner of the home directory, the only other user that normally has access to it is the root user.
Each user can access his/her home directory by clicking on the System Menu then Home.

**Storage Devices**

You already know that the devices used by an operating system to store files and folders are the hard disk, diskette, CD-ROM, network drives.

For long term storage, files are stored on various secondary memory devices. These include hard disks, floppy disks, CD-ROMs, DVDs, Zip disks, tape and flash memory. These devices were described in Module 1.

Although we can think of directories as containers for files and subdirectories, these are logical structures rather than physical areas on a disk. The actual method of physically storing files on disk and organising them in directories is a very technical topic. From a user’s perspective, the important thing is to understand directories as providing a logical method of grouping related files together in one place.

Where computers are connected together through a network, each user will see the disk drives on other computers as part of his/her own directory tree. In fact, if the user has not set up the system, he/she will not necessarily even be aware of the physical location of different parts of the directory tree.

One of the strengths of Linux is that it fully integrates a network into a single system.

**Directories/Folders**

**Nautilus File Browser**

Ubuntu has a built-in application called Nautilus for navigating through the file system on your computer and for managing your computer’s desktop. Nautilus is always running while you are using GNOME. To open a new Nautilus window, choose an item from Places menu on the top panel.

**The Home Folder**

Whenever a new user is created in Ubuntu, a folder, called the Home Folder, is also created for that user. You can access your Home Folder by clicking on the Places menu and choosing Home Folder.
The Home Folder contains a number of default folders to hold documents for each user. These folders are:

- **Desktop**: this folder contains all of the objects that will appear on your desktop, such as files, folders and shortcuts to places or applications.
- **Documents**: A folder to store documents such as word processor files, spreadsheets or databases.
- **Music**: a folder to store your music files.
- **Pictures**: a folder to hold graphics and photographs.
- **Public**: a folder that you can use to share files with other users.
- **Templates**: used to store documents that will be used as a template to create new documents in OpenOffice or other applications.
- **Videos**: a folder used to store video files.

Alternate views

You can change how Nautilus displays directories and files by changing the view from the folder menu. You can choose to view the folder contents as icons, as a list or in “Compact View” which has small icons with the file names.
List View

![List View](Image)

Note: Viewing directories in List View also displays the size of the file or the number of files or sub-directories within a directory, the type of file and the date the file or folder was last modified.

Navigating through directories

There are many ways to navigate through folders. As you use Ubuntu, you will find the navigation style that suits you best.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Back</td>
<td>The Back and Forward icons allow you to trace your steps back and forward through the directories you have visited during your current session.</td>
</tr>
<tr>
<td>Forward</td>
<td></td>
</tr>
<tr>
<td>Up</td>
<td>To navigate up one level in the directory structure, click on the Up button.</td>
</tr>
<tr>
<td>Home</td>
<td>To return to the home directory at any stage, press the Home icon.</td>
</tr>
<tr>
<td>Computer</td>
<td>To view all of the storage devices on your computer, click on the Computer icon.</td>
</tr>
<tr>
<td>Search</td>
<td>To search for a file or directory, click on the Search button and type the file name or directory name in the search bar.</td>
</tr>
</tbody>
</table>
You can also move to a new directory, by double clicking on a directory icon in the main pane or choosing a directory from the list of Places in the left pane.

Finally, you can also type the name of the directory into the location window if you know its path. Recall that Linux file and directory names are case sensitive.

**Creating and deleting directories**

The following example illustrates how to create directories and sub-directories in your home directory.

1. Click the Home icon.
2. From the File menu, click on Create Folder.
3. Enter the name for the new directory (in this case, it is named Recipes).

You could, if you wish, create sub-directories and create another level of sub-directories within each. First work out a meaningful directory structure for your own needs, and then create this structure using the method that has just been described.

To delete a directory, click on the directory name or icon and press the **Delete** key on your keyboard.
### Renaming directories

<table>
<thead>
<tr>
<th>Extension</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>sxw</td>
<td>jamaica.sxw</td>
<td>A Writer text file</td>
</tr>
<tr>
<td>sxc</td>
<td>populationSA.sxc</td>
<td>A Calc spreadsheet file</td>
</tr>
<tr>
<td>stw</td>
<td>invoice.stw</td>
<td>A template file that can be used as the basis for creating Writer text files</td>
</tr>
<tr>
<td>sxi</td>
<td>client.sxi</td>
<td>An Impress presentation</td>
</tr>
<tr>
<td>pdf</td>
<td>contract.pdf</td>
<td>A picture document format file. This format allows a file to be sent in a format that can only be read and not edited. To read such a file you would need a pdf reader</td>
</tr>
<tr>
<td>htm, html</td>
<td>index.htm</td>
<td>Htm and html files are files that can be read using a web browser</td>
</tr>
<tr>
<td>txt</td>
<td>notes.txt</td>
<td>A text file containing pure text without any formatting</td>
</tr>
<tr>
<td>rtf</td>
<td>plans.rtf</td>
<td>A rich text format file. This is a format that can be used for exchanging files between different types of system</td>
</tr>
<tr>
<td>doc, docx</td>
<td>jamaica.doc</td>
<td>A Microsoft Word document file</td>
</tr>
<tr>
<td>xls, xlsx</td>
<td>populationSA.xls</td>
<td>A Microsoft Excel spreadsheet file</td>
</tr>
<tr>
<td>ppt, pptx</td>
<td>client.ppt</td>
<td>A Microsoft PowerPoint file</td>
</tr>
<tr>
<td>pps, ppsx</td>
<td>client.pps</td>
<td>A Microsoft PowerPoint presentation file</td>
</tr>
<tr>
<td>mdb</td>
<td>vendors.mdb</td>
<td>A Microsoft Access database file</td>
</tr>
<tr>
<td>zip</td>
<td>install.zip</td>
<td>A compressed file in zip format</td>
</tr>
<tr>
<td>gz</td>
<td>install.gz</td>
<td>A compressed file in gzip format</td>
</tr>
<tr>
<td>tar</td>
<td>oo-137.i586.tar</td>
<td>A tarball file .tar files are used for creating installation packages</td>
</tr>
<tr>
<td>png</td>
<td>sky.png</td>
<td>A common format for storing graphic images</td>
</tr>
<tr>
<td>jpg, jpeg</td>
<td>sky.jpg</td>
<td>A common format for storing graphic images</td>
</tr>
<tr>
<td>tif</td>
<td>sky.tif</td>
<td>A common format for storing graphic images</td>
</tr>
<tr>
<td>gif</td>
<td>sky.gif</td>
<td>A common format for storing graphic images</td>
</tr>
</tbody>
</table>
You can rename a directory by clicking on the icon or name of the directory and clicking on Edit->Rename. Then simply type the new name in the name field.

**Copying, Pasting and Moving Directories**

To move a directory to another place:

1. Click on the directory name or icon and hold down the left mouse button while you drag it to the new location.

or

1. Click on the directory name or icon, then choose Edit>Cut from the menu.

2. Go to the location you want to place the directory and the click on Edit->Paste from the menu.

To copy a directory:

1. Click on the directory name or icon, then choose Edit>Copy from the menu.

2. Go to the location you want to place the directory and the click on Edit->Paste from the menu.

**Working with Files**

Files can be recognised by the extension on the file name. This is the part of the file name that follows the final period. The following table illustrates some common file names and examples of each.

<table>
<thead>
<tr>
<th>Extension</th>
<th>Example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>wav</td>
<td>trumpet.wav</td>
<td>An audio file</td>
</tr>
<tr>
<td>au</td>
<td>trumpet.au</td>
<td>An audio file</td>
</tr>
<tr>
<td>mpg</td>
<td>concert.mpg</td>
<td>A video file</td>
</tr>
<tr>
<td>avi</td>
<td>concert.avi</td>
<td>A video file</td>
</tr>
<tr>
<td>tmp</td>
<td>ws0001.tmp</td>
<td>A temporary file</td>
</tr>
</tbody>
</table>

File extensions are a Microsoft concept and are not actually needed in Linux. They are however useful in providing information for users about the contents or format of files.
Change folder and file permissions

By default, other users can’t access the files in your home directory. As the owner of these directories and files, you can change the permissions so that other users can access them.

You can set permissions for three categories of users:

- **owner**: The user that created the file or folder
- **group**: A group of users to which the owner belongs
- **others**: All other users not already included

For each category of user, different permissions can be set. These behave differently for files and folders, as follows:

- **read**: Files can be opened, Directory contents can be displayed
- **write**: Files can be edited or deleted, Directory contents can be modified
- **execute**: Executable files can be run as a program, Directories can be entered

Change permissions on a directory

In this example, you will change the permission on the Public directory of your Home folder to allow other users to access these files.

1. Open your **Home folder** (click on Places>Home Folder)
2. Click on the **Public** directory and choose **File>Properties**
3. Click on the **Permissions** tab
4. Change the permissions for Owner, Group and Others to **Create and delete files**.

5. Click the **Share** tab.

6. Check the boxes **Share this folder** and **allow other people to write in this folder**.

**Change permissions on a file**

By default, **Linux** locks access to files so that they cannot be changed by anyone other than the owner or members of the group.

1. Open Nautilus and locate the file whose permissions you wish to view or change.

2. Click on the file and select **File>Properties** from the menu.

3. Click the Permissions tab. The current permissions will be checked.
4. Change the permissions as desired.

Sort files by name, size, type, date modified

Files can be sorted by name, type, size and date by clicking on the titles at the top of the pane.

1. Open the Nautilus file browser and access the directory you wish to sort.

2. Switch to List view.

3. Click on Name. This will sort the files in ascending alphabetic order by name.

4. Click on Name a second time. This will now sort the files in descending order of name.
When you sort files, the directories will appear ahead of the files. Directories and files will be sorted separately.

1. Click **Date Modified**: This will sort the files in date order starting with the most recent.
2. Click **Date Modified** a second time: This will now sort them with the oldest appearing first.
3. Click **Size**: This will sort the files in order of size with the largest at the top.
4. Click **Size** a second time: This will sort them in the reverse order of size.
5. Click **Type**: This will sort the files alphabetically by type.
6. Click **Type** a second time: This will sort them by type in the reverse order.

**Copying, Pasting, Moving and Deleting Files**

To move a file to another place:

1. Click on the file name or icon and hold down the left mouse button while you drag it to the new location.

or

1. Click on the file name or icon, then choose **Edit>Cut** from the menu.
2. Go to the location you want to place the file and the click on **Edit>Paste** from the menu.

To copy a file:

1. Click on the file name or icon, then choose **Edit>Copy** from the menu.
2. Go to the location you want to place the file and the click on **Edit>Paste** from the menu.

**Renaming Files**

You can rename a file by clicking on the icon or name of the file and clicking on **Edit> Rename**. Then simply type the new name in the name field.

**Note:** The part of a file name following the final period (full stop) is called the file extension. This often has a special significance which will be lost if it is changed. For example, the system will recognise that a file having a pdf extension can be opened with a pdf reader or that a file with a png extension is a graphic image.

If you do change a file name, only change the part that is to the left of the first period.
Importance of Backups

There are many things that can cause loss of files. These include:

1. Mechanical failure of a hard drive.
2. Damage to the system due to natural disasters such as fire, floods and earth movement.
3. Theft of the system.
4. Corruption of data due to computer viruses.
5. Deliberate corruption or deletion of data through criminal activity.

In order to protect data, it is important that copies of important files are made and kept in a separate location so that if loss occurs to the main system, data can be recovered from the copies. Copies of important files are referred to as backups.

Deleting and Restoring Files

When you delete files or directories in Ubuntu, by default the files are moved to the trash bin where they wait until the trash is emptied. This means that if you delete files by mistake, you can restore them from the trash bin. However, once you empty the trash those files can no longer be easily restored, so be careful when you are deleting items.

Delete files, directories/folders to the trash bin

1. Select (highlight) the files you wish to delete.
2. Do any one of the following:
   - press the Delete key
   - drag the file to the trash bin
   - choose Edit>Move to Trash from the menu.

Restore files, directories/folders from the recycle bin/wastebasket/trash

1. Double click on the Trash icon on the desktop OR open your home folder by choosing Places>Home Folder. From there navigate to Trash.
2. Select the files you wish to restore.
3. Choose Edit>Restore. The files are then restored to the folder from which they were deleted.
Empty the recycle bin

With time Trash will accumulate hundreds of files. Rather than waste space, empty Trash on a regular basis.

1. Double click on the Trash icon on the desktop OR open your home folder by choosing Places>Home Folder. From there navigate to Trash.

2. Choose File> Empty Trash from the menu.

Searching for files and folders

The first step to keeping track of your files and directories is to create a logical set of directories that works for you. When you are having trouble locating a file or directory, however, Ubuntu has a search utility that can help.

Find Files

1. Choose Places>Search for Files from the desktop menu.

2. In the Name contains field, type in the name of the file.

3. Choose a directory to search in from the Look in folder field.
4. Click on the **Find** button. Your search results will appear in a new window. If your file is in the results, you can double-click on it to open.

---

**Note:** In searching for files, the wildcard character, *, plays a very useful role. * represents any number of characters.

For example:

- `doc*` means any file with a name beginning with the letters doc
- `*doc` means any file with a name ending with the letters doc
- `*doc*` means any file containing the letters doc in its name
Search for files by content, date modified, date created, size, wildcards

You can narrow your search by specifying other search options such as when the file was modified, who the owner of the file is, what the file size is and what text is contained in the file. You can also use a combination of the other options.

Expand the Select more options field and choose the options you want from the drop-down menu. You will then be prompted for information regarding the option you chose.

Compressing Files

Each file has a size associated with it. Roughly speaking the amount of space a file occupies of disk is about the same as its file size (in reality, it takes up somewhat more space than this). When files are stored on a CD or transmitted across the Internet, it is important to know the amount of disk space they occupy. Special algorithms (methods) have been developed to compress files into smaller sizes.

File compression is a way that a number of files can be compressed into a single file or a single file can be compressed to take up less space on a hard drive or other medium. For a compressed file to be usable, it must first be decompressed.
There are numerous utilities that enable you to work with compressed files. The next example will illustrate the use of Archive Manager, an open source compression utility for Ubuntu.

Compressed archive formats

The following formats are installed by default with Ubuntu. There are other types of archives in use, but they require additional software to be installed on your system.

<table>
<thead>
<tr>
<th>Format</th>
<th>File extension</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>tar</td>
<td>.tar</td>
<td></td>
</tr>
<tr>
<td>gzip</td>
<td>.tar.gz, .tgz, .gz</td>
<td>Compressed .tar or compressed single file</td>
</tr>
<tr>
<td>bzip</td>
<td>.tar.bz, .tbz, .bz</td>
<td>Compressed .tar or compressed single file</td>
</tr>
<tr>
<td>bzip2</td>
<td>.tar.bz2, .tbz2, .bz2</td>
<td>Compressed .tar or compressed single file</td>
</tr>
<tr>
<td>lzma</td>
<td>.tar.lzma, .lzma</td>
<td>Compressed .tar or compressed single file</td>
</tr>
<tr>
<td>zip</td>
<td>.zip</td>
<td>Common format used in Microsoft Windows systems</td>
</tr>
<tr>
<td>jar</td>
<td>.jar, .ear, .war</td>
<td></td>
</tr>
<tr>
<td>CD images</td>
<td>.iso</td>
<td>Read-only</td>
</tr>
</tbody>
</table>
Compress files in a folder on a drive

1. Using Nautilus, open the directory with the files you want to compress.
2. Select (highlight) the files which you want to compress.
3. Choose **Edit>Create Archive** to open the Archive Manager utility.
4. In Archive Manager, type in a name for the archive and then choose the type of archive you want to create.
5. Click on the Create button. The compressed file will be saved in the same folder.

Extract compressed files from a location on a drive
1. Using Nautilus, open the directory with the compressed archive you want to extract.
2. Select (highlight) the archive which you want to extract.
3. Choose **Edit>Extract Here** to open the Archive Manager utility.

4. The archive will be extracted to the same folder, creating a subdirectory with the archive name. This subdirectory will contain the extracted files.
Summary

In this section, you learned:

- the concept of directories and files as they apply to the Linux operating system
- how to use the Nautilus File Browser to:
  - navigate through directories
  - change the view options for directories
  - create, rename, move, copy and delete directories
  - change permissions for directories
- how files are named and what filename extensions are
- how to use the Nautilus File Browser to:
  - sort files by name, size and date modified
  - create, rename, move, copy and delete files
- the importance of backing up data
- How to use the Trash Bin
- How to search for files and directories
- How to use a file compression utility
Ubuntu Utilities

Section overview

Utilities are programs that are included with the operating system. They are installed with the operating system, but are in fact application software. They can be very helpful, as they perform important tasks but tend to use very little of your system’s resources.

You have already been introduced to the file compression utility, Archive Manager, in the previous section. In this section, you will use utilities for capturing images of your computer screen and for editing text files.

After studying this section you will be able to:

- Use the **Print Screen utility** to take screenshots or images of your computer screen.
- Use the **Text Editor** utility as a simple word processing application for editing text files.

Print Screen

Print screen takes a snapshot of your desktop and saves it as an image, which you can then use in documents.

1. Press the **Print Screen** button on the keyboard (it may be abbreviated to Prt Scr or similar). This activates an application which captures an image of your screen.
2. Choose whether to capture the whole screen, the active window or a portion of the screen.
3. If you would like a few seconds to get the screen ready before capture, set the delay time.
4. Click the **Take Screenshot** button.
5. Specify a name and location in which to save the snapshot and click on the **Save** button.

The snapshot will be saved in .png format, which can be opened with most standard graphics programs. The image can then be inserted into a document, edited with a graphics program or sent by email.

**Text Editing**

Text editing is an application that allows you to create text documents. It is a simple word processor application and although it doesn’t have the features of an advanced word processing program like OpenOffice Writer, it can be very helpful.
Start Text Editor

1. Click on Applications from the desktop menu
2. Go to Accessories
3. Click on Text Editor

The components of the screen are shown below.

Close Text Editor

1. Choose **File>Quit** from the text editor menu.

This will close all open documents and exit Text Editor. If you have made any modifications to open documents, Text Editor will remind you that the document has not been saved and ask you whether you wish to save or keep it. It will also give you the option of cancelling the Quit operation.
Open a file

One of the advantages that text editors provide for us is the facility to save our work and recall it at a later time. We can then print our work or make further changes (edit). In addition, we are able to create many versions of the same document, each of which can be saved on our hard drive under an appropriate name.

To open a document:

1. Choose **File>Open** from the Text Editor menu
   OR
   Click on the **Open** button in the Text Editor tool bar.

The Open dialogue will appear. In general, this will point to your home directory.

1. If necessary, navigate to the desired directory.
2. Highlight the file you wish to open.
3. Click **Open**.
Create a new document

A new document is created for you each time you open Text Editor.

To create a new document from within Text Editor:

1. Choose File> New from the Text Editor menu. This will display a blank screen in which you can create a document.
2. Using your keyboard, type the text for the document. Use the <Enter> or <Return> key on your keyboard to start a new paragraph.

Save your document

When you work with a document on your computer, the working form resides in the computer's RAM. Remember from Module 1, this is temporary memory used for your current activities. Since RAM is volatile, when the computer is switched off, everything that is in RAM is automatically lost. In order to keep your work you will need to save your documents before you shut off your computer.

When you save a document, you give it a name and you specify where it is to be stored.

If you have opened a document and made some changes, the process of saving it is very simple:

1. Choose File>Save from the Text Editor menu.

This will change the contents of the stored version so that it is identical to the version that is displayed on your screen. In this case, the previous version on disk is overwritten. If you use File>Save in a newly created document, Text Editor will automatically assume that you wish to use File/Save as.

Saving a new document

When you create a document from scratch, there is no version stored on disk. To save the file to disk:

1. Choose File>Save as from the Text Editor menu.

The Save as dialogue will appear. In general, this will point to your home directory.
2. If necessary, navigate to the directory in which you wish to save the file.
3. Enter a name into the Name window.
4. Click Save.

Summary

In this section, you learned:

- How to use the Print Screen utility to take screenshots or images of your computer screen.
- How to use the Text Editor utility as a simple word processing application for editing text files.
Section overview

Remember from Module 1, you should avoid printing documents unless it is necessary because of the impact on the environment and since it is quite possible to do much of your reading on-screen.

However, you may want to print documents to read when you can’t be near a computer, for handouts for meetings or presentations or even your photographs.

After studying this section you will be able to:

- Set up a printer in Ubuntu.
- Print documents from an application such as Text Editor.
- Monitor your print jobs.
- Pause, resume or cancel print jobs.

Printer Setup

Adding a Printer

1. Open System > Administration > Printing from the desktop menu.
2. The printer configuration utility will open. Double click the **New** icon to add a new printer.

![Printer configuration utility](image1.png)

3. The printer configuration utility will then look for connected printers and printer ports. Select the printer you want to install and click on the **Forward** button.

![Select Device](image2.png)
4. The printer configuration utility will search for the proper printer drivers (software) for your printer. It may find the drivers and install them automatically or it may ask you to select the printer.

5. Select the model of printer and click on the **Forward** button.
6. Apply the changes and your printer is set up.

![Describe Printer]

7. Print a test page to test your printer settings.

![Would you like to print a test page?]

**Note:** Suppose you have more than one printer available. The default printer is the printer that will automatically be offered to you when you wish to print. Other printers have to be specifically selected.

---

**Print Outputs**

**Print a document from a text editing application**

1. To print from Text Editor, first open the document you want printed. Then click on **File>Print** from the Text Editor window.
2. Select a printer from the Print dialog box that opens. Choose which pages you wish to print and the number of copies, and then click the Print button.

3. Adjust Print range and Copies, if necessary.

4. Click OK.

**View a print job's progress using a desktop print manager**

Print manager is a utility that lets you view the print jobs in progress and to cancel or pause them if necessary. To open the print manager:

1. Open System>Administration>Printing from the desktop menu.
2. Click on the printer you sent the print job to and then choose Printer> View Print Queue from the menu.

![Printer configuration screen]

3. When the Print Queue opens, you can see the print jobs in process.

![Print Queue window]

4. You can manage the print job by choosing Job from the menu and clicking on the appropriate choice:

- **Cancel** will cancel the print job in progress
- **Hold** will pause the print job in progress
- **Release** will resume a print job that is being held
- **Reprint** will start the print job from the beginning
Summary

In this section, you learned how to:

- Set up a printer in Ubuntu.
- Print documents from an application such as Text Editor.
- Monitor your print jobs.
- Pause, resume or cancel print jobs.
Module summary

In this unit you learned:

- The main features of the **Ubuntu** operating system including how to adjust the main computer settings and use built-in help features.

- How to operate effectively around the computer desktop and work effectively in the GNOME graphical user environment.

- The main concepts of file management and how to efficiently organise files and folders so that they are easy to identify and find.

- How to use utility software to compress and extract large files.

- How to use simple text editing and print tools available within the operating system.

- How to set up and monitor a printer in Ubuntu.
Module 3
Word Processing Using OpenOffice Writer
Module Overview

This module explores the use of OpenOffice Writer as a word processing application. The module is built to explore the writer application to an intermediate level. The focus will be upon using the word processing and formatting features to create visually rich and articulate documents.

Upon completion of this unit you will be able to:
 Describe a word processor and how it can be utilised.
 Discuss the difference between a word processor and the other OpenOffice applications.
 Identify the main operations performed by the Writer word processor.
 Format the document as a whole, its paragraphs, sentences and text.
 Insert tables, pictures, images and charts into a document.
 Describe and perform a mail-merge.
 Check the document errors, spelling and layout.
 Print a document.

Terminology

Word Processing

The term “word processing” was coined by IBM in the late 1960s and is used to describe the “combination of people, processes and equipment used to transform ideas into printed communication”.

White space

White space is the space in your document that has no text or graphics.

Template

A template is a document with a design that can be used by other documents.

Toolbars

Toolbars are areas in the application that contain most of the common commands and functions you need to use the application.

Print Layout

Print Layout shows how the document will look like when it is printed.

Web Layout

Web Layout shows how the document will look when viewed with a web browser.
Study Tips

You may find it useful to skim through an entire block of content first, paying special attention to the headings and introductions, then go through a second time for more in-depth study and practice.

However, we recommend that you do the activities as they appear. They are essential study materials, offering practice in particular skills that will build your proficiency in word processing.

Keep linking the new content that you are studying in this module with the content that you have already covered and your own general knowledge, to deepen your understanding of the operations you are learning.

If you have difficulty understanding any area, try working at it slowly. If you still do not understand, seek help.

Preknowledge

Before beginning this module, we recommend that you:

- Study Module 1 and Module 2, because they provide the essential knowledge for you to work with word processors, including saving files, formatting text and retrieving information from other files.
- Be comfortable using a keyboard to input text and a mouse to click on objects.
Introduction to Word Processing

Word processing was one of the first applications developed for computers and is one of the most used applications for personal and office productivity. Originally it was an application developed for the production of print material as a replacement for the typewriter. The advantages of using a word processor over the typewriter is that mistakes can be corrected easily and documents can be saved for future use and edited as needed.

Section Overview

This section will introduce you to the key concepts in word processing.

By the end of this section, you will:

- Understand the main capabilities of modern word processor applications.
- Appreciate the impact that the development of the word processor had on the modern office.
- Become familiar with some design considerations for word-processed documents.

Development of the Word Processor

The term “word processing” was coined by IBM in the late 1960s and was used to describe the “combination of people, processes and equipment used to transform ideas into printed communication” (New York Times, September 12, 1972). Soon after the term was understood to mean a typewriter with automatic features for editing and correcting documents electronically, making it possible to produce a perfect original document.

Originally word processors had no screens and saved copies of documents on magnetic tape for retyping, corrections or printout. Later models could display one line of text on a small screen, making it easier to edit documents. The labour and cost savings of word processing technology were immediate. Documents no longer had to be retyped to fix simple errors and could be saved, stored, reused and worked on later.

The next generation of word processors consisted of dedicated machines with CRT monitors capable of displaying many lines of text at once. These word processing appliances were produced by large companies such as IBM and sold for as much as US $10,000. Hand in hand with the development of word processing technology was the development of new technologies for storing and printing documents, such as the floppy disk and daisy wheel printer.

In the early 1980s the development of word processing software and the pricing of personal computers was the beginning of the end for word processing devices. Personal computers had the advantage because they came with other software, such as spreadsheets and eventually the graphical user interface to make working with documents easier.
Modern word processors

Word processors have evolved into multifunctional publishing applications. Some of the tasks modern word processing applications are capable of are:

- preparing batch mailings by combining a form letter template with a database file containing individual information
- creating keyword indexes
- creating tables of contents with page numbers
- creating footnotes
- grammar checking, spell checking and thesaurus functions
- creating custom headers and footers for documents

Design considerations for word processed documents

At its most basic level a word processed document is a means to convey your message. Incorporating the fundamentals of good design in your documents makes it easier for the reader to understand that message. Even a well-written document that is not laid out well can be hard to read, resulting in your message being lost.

Organisation

Effective documents are organised so that information is presented in easily digestible pieces, important information is emphasised and ideas are presented logically. Here are some guidelines:

- **Write effective paragraphs**
  An effective paragraph organises a sentence or group of sentences around a single main idea. There is no ideal paragraph length although a paragraph that is overly long can be harder to read thus hiding your message. Make sure your paragraphs have one main idea and split paragraphs if necessary.

- **Write effective sentences**
  Just as with paragraphs, a reader’s understanding of your message depends on logically organised sentences. Good sentences are clear, coherent and have good “flow”.

- **Use headings and subheadings**
  Headings and subheadings serve as guideposts for your reader. They help to organise material into smaller sections within a common theme, breaking up your document into digestible pieces.

- **Use bulleted or numbered lists**
  Lists help organise parallel ideas or ideas that need to be presented in a sequence. For a list to be effective, it should:
  - form a logical group
  - use parallel structure
  - use words, phrases or short sentences
use numbers to imply a hierarchy or order, either for a list of items in priority sequence or a set of step-by-step procedures

Visual design

• **Use white space to separate and emphasise points**
  White space is the space in your document that has no text or graphics. White space is a good way to separate points or sections in your document and makes your document easier to read.

• **Use graphics and illustrations effectively**
  Graphics are also a good way to make your document seem less text-heavy but they should only be used when they have a direct relationship with the message of your document. Graphics should be placed close to the text they refer to, in a way that doesn’t obstruct the flow of the reader. Graphics should be of good quality, clear and have descriptive captions.

• **Emphasise headings**
  Use larger type, a different typeface, surrounding white space or bold type for headings to draw the reader’s attention.

• **Use a different typeface for contrast**
  Capitalise words used as headings for emphasis. Use italics or bolding for phrases or single words for emphasis.

• **Choose the right font**
  Fonts can create a visual impression that acts upon your reader. Use at least a font size of 10. Limit the number of different fonts you use in a document. Colour, highlighting and other decorative elements should be used sparingly and only for emphasis when needed. Serif fonts have ornamental strokes at the ends of letters and work well for bold type and for printed copies. Sans serif fonts are simpler and are easier to read on a computer screen.

<table>
<thead>
<tr>
<th><strong>Serif</strong></th>
<th><strong>Sans Serif</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>(Times 16 point bold)</td>
<td>(Verdana 12 point bold)</td>
</tr>
</tbody>
</table>

Summary

In this section, you learned:
• The main capabilities of modern word processor applications.
• The impact that the development of the word processor had on the modern office.
• The major design considerations for word-processed documents.
Using the Word Processor Application: The Basics

Section Overview

The OpenOffice suite’s word processing application is called **Writer**. Writer has many unique and powerful features and is comparable to Microsoft Word.

In this section we will become familiar with the basic features of the Writer application and learn how to perform basic word processor operations.

In this section you will learn how to:

- open and close **Writer**
- open and close one or several documents
- create a new document
- save a document to a location on a drive
- save a document to different formats
- work with multiple documents
- use available **Help** functions

Opening and Closing Writer

OpenOffice applications are typically opened from the **Applications** menu in the top left of the Ubuntu desktop.

To open **Writer**:

1. Click on the **Applications** menu
2. Click **Office**
3. Click **OpenOffice.org Word Processor**
This will present the OpenOffice splash screen as the operating system loads the **Writer** application.

To close **Writer**:
- Click on the **File** menu in **Writer**, then click **Exit**
- Click on the **Exit** icon in the top right hand corner of the **Writer** window

**Creating, opening and closing documents**

**Creating a new document**

When you launch the **Writer** application, a new document is created for you automatically. To create a new document from within the **Writer** application:

1. Click on **File** on the menu Bar
2. Click on **New** on the drop down menu
3. Click on **Text Document**. This will display a blank **Writer** document
Creating a new document from a template

A template is a document with a design that can be used by other documents. Templates are very useful if you are working with a group of documents that should all look the same.

For example, a manager may have a set of templates for letters, memos, faxes and reports. An accounting clerk may have templates for invoices and account statements. Each template would be designed differently and any document created from a template would start out having the same design as the template.

1. Click on **File** on the menu Bar
2. Click on **New** on the drop down menu
3. Click on **Templates and Documents**

This will open the **Template dialogue window**.
Double-click on the **Business Correspondence** link to see the templates in that category.

4. Select the **Project Proposal** template and click on the **Open** button to open it. The document that opens looks like this:
As you can see the document already has much of the formatting done for you, making it easy for you to create a new project proposal document based on this template.

You can also create and save your own templates in OpenOffice Writer. We will discuss this more in a later section.

**Opening an existing document from within Writer**

Much of the time you will be opening documents that you created earlier and saved on your computer.

1. Click on *File* in the menu bar.
2. Click on *Open*. This brings up the **Open Dialogue** window. The dialogue lists a series of directories and/or files.
3. Locate the directory in which the desired file is held
4. Click on the directory to open it
5. Highlight the file
6. Click *Open*

**Tip:** If you are not sure about the directory that contains your file and you have to search a bit, you will find the **Up one Level** icon useful.
Closing a single document

Before we perform this task, we need to be clear about the difference between the “close” and “exit” commands. **Close** closes the document, but leaves the **Writer** program and other documents open. **Exit** closes the document you are working on, any other documents that are open, as well as the **Writer** program.

1. Click on **File** on the menu bar
2. Click on **Close**
Tip: Always save your document before closing or exiting. **Writer** will help you if the version of the document that you have on the screen differs from the one already saved on the hard disk. **Writer** will ask you whether you want to save the new version. Secondly, always close **Writer** before you shut down the system.

**Working with multiple documents**

If you wish to work on more than one document at the same time, you can open multiple documents and move between them. You may want to do this if you need to copy information from one document to another or if you need to compare two documents.

1. Click on **File** then **Open**
2. Locate the directory containing the files you wish to open
3. Click on the first file
4. Hold down the **CTRL** key and click on each of the additional files you wish to open
5. Click **Open**. The last of the files loaded will appear in the window. This will be the active document. The others are also loaded but are in the background.
You can make one of the other documents active as follows:

1. If your windows are arranged so that you can see part of the other document, click anywhere on it to make it the active document or
2. Click on Window to list the documents that are loaded
3. Choose the document that you wish to make active

Close more than one document

If you wish to close some but not all the documents you have open, then you should use the Close command for each document separately. If you want to close all open documents as well as Writer, then you should use the Exit command.

Saving documents

You will want to save your documents often so that you don’t lose information if your computer crashes or if your application is inadvertently closed.

1. Click on File, then click Save

If this is the first time you’ve saved the document, it will bring up the Save As dialogue.
2. Locate the drive and/or the directory in which you wish to save the file. You can save files to your hard drive, floppy drive, Flash Memory stick or many other storage memory devices
3. Enter the name of the file in the File Name window
4. Click Save

If you exit the application without saving, Writer will prompt you to save your work.

Save an existing file under another name

Sometimes we may want to save the same document under a number of different names. Alternatively, we may want to save a document before making changes. We would then have a copy of the new version as well as the version before changes were made. Suppose we have a document loaded as shown below. In this case the document already has the name demo.odt.

We can now save what is displayed on the screen in two ways:
- To replace the version on the hard disk with the contents as displayed on the screen:

    Click on File, then Save.
To save another copy of the document under another name:
Suppose we do not want to overwrite the contents on disk but would still like to save what is on the screen.

Click on File and then Save as.

This will bring up the Save As dialogue. You use this in exactly the same way as you would if you were saving a completely new file.

Save in another file type

Sometimes it is useful to convert the document format into another format, for example, a Microsoft word file. To save a document in a different format:

1. Click on File, then Save as.
2. Click on the File Type. This will display a list of file types that you can save the document under.
3. Use the vertical scroll bar to view all the file formats.
The following table lists some of the main file formats and a brief explanation of each:

<table>
<thead>
<tr>
<th>File type</th>
<th>Extension</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>ODF Text Document</td>
<td>.odt</td>
<td>This is the format of Writer itself</td>
</tr>
<tr>
<td>ODF Text Document Template</td>
<td>.ott</td>
<td>A template is an outline for new documents. This may include text, images and formatting.</td>
</tr>
<tr>
<td>OpenOffice.org 1.0 Text Document</td>
<td>.sxw</td>
<td>Version 1 of OpenOffice Writer</td>
</tr>
<tr>
<td>OpenOffice.org 1.0 Text Document Template</td>
<td>.stw</td>
<td>Version 1 of OpenOffice template</td>
</tr>
<tr>
<td>Microsoft Word 2007</td>
<td>.docx</td>
<td>Microsoft Word document</td>
</tr>
<tr>
<td>Rich Text Format</td>
<td>.rtf</td>
<td>A text format that can be read by most word processing applications. It saves text and most formatting styles.</td>
</tr>
<tr>
<td>Text</td>
<td>.txt</td>
<td>A text format that can be read by most word processing applications. It saves text only.</td>
</tr>
<tr>
<td>HTML Document</td>
<td>.html</td>
<td>Hypertext Markup Language – a World Wide Web document format</td>
</tr>
<tr>
<td>Portable Document Format</td>
<td>.pdf</td>
<td>Pdf is a document format that can be read with Acrobat Reader and some other applications, but can’t be edited. Unlike the previous formats that are created using the <strong>Save As ...</strong> function, pdf files are created using the <strong>Export as pdf ...</strong> option in the File menu.</td>
</tr>
</tbody>
</table>

Save different Versions

On the file menu there is an option called Version that allows you to save different versions of the document in the same file. Later, you can view each version on its own.

1. From the **File** menu, click **Versions**

2. The **Versions dialogue window** opens. In this window you can see the versions of the document that you have already saved.
Click on **Save New Version** to save a new version

3. You are asked to give the version a name and this is recorded along with the date and time of the changes that were made. The new version is saved when you click **OK**.

4. If you want to open another version of a file, simply click on **File>Version** and choose the version you want to open.

**Getting Help**

The help file is a searchable database that allows you to get help on specific features of OpenOffice Writer.

To access help:

1. Click on **Help**, then **OpenOffice.org Help**
2. Perhaps you are interested in getting help with spellchecking your document. When the Help window opens, you can browse through the Help contents by clicking on the Contents tab.

3. The Index tab lets you search for specific help topics by typing a search term.
4. The **Find tab** lets you search all of Help for specific words.

![Find tab image]

5. You can bookmark Help pages that you are likely to revisit using the **Bookmarks tab**.

![Bookmarks tab image]

### Self Assessment

To assess your learning, make sure you are comfortable carrying out the following tasks in OpenOffice Writer:

1. Find and select **OpenOffice.org Word Processor** from the Applications menu
2. Create a new document
3. Save the document to disk as **My First Document**
4. Close the document and exit OpenOffice Writer
5. Again, start OpenOffice Writer and open your recently saved document
6. Save your document again under a different document format
7. Use **OpenOffice Writer Help** to search for help on a subject and bookmark a help
8. Close the document and exit the application
Summary

In this section you have learned how to:

• Open and close **Writer**
• Open and close one or several documents
• Create a new document
• Save a document to a location on a drive
• Save a document to different formats
• Work with multiple documents
• Use available **Help** functions
Working with Word Processor Documents

Section Overview

So far in this module you have been introduced to the features of the OpenOffice Writer word processing application and have learned some of the basic operations, such as opening, closing and saving documents. In this section we are going to further into the Writer workspace to learn how to use the toolbars and other components in Writer and how to customise Writer for your use.

In this section, you will:

- identify the core components of the Writer workspace
- learn about the Writer toolbars and their function
- adjust OpenOffice Writer to better suit your working style and needs
- perform some basic tasks with Writer documents

Locating the components of the Writer window

When you open the Writer application, you will see running across the top of the Writer window a set of three toolbars each of which displays a series of icons or buttons that you can click on when you want to perform certain tasks.

There is also a large workspace area for you to input text, graphics and other objects. Above the workspace you will see a ruler for helping you position items in the workspace.

The Writer window explained
Writer toolbars and ruler

The Menu Toolbar

The menu toolbar contains most of the commands you need to use to work in Writer, in a drop-down menu arrangement.

Clicking on any of the menu choices presents a list of commands that you can use when you work with documents.

New: Presents choices for creating new blank OpenOffice documents.
Open: Used to open a document from saved files.
Recent Documents: Presents a list of documents you have worked on recently.
Wizards: Starts an automated process for creating and formatting a variety of documents.
Close: Closes the document you are working on without exiting the application.
Save: Saves the document you are working on.
Save As: Saves the document you are working on under a new document name or type.
Save All: Save all of the documents you have open.
Reload: Revert to the last saved version of the document.
Versions: Save multiple versions of the same document.
Export: Export the document to a different file type.
Export as PDF: Export as a PDF document.

The Formatting Toolbar

The second bar is the formatting toolbar. It contains icons and drop down menus for commands used to format the text and objects you add to the workspace, e.g., to select a font, font colour, alignment, border option and background colour.

The Standard Toolbar

The third bar is the Standard toolbar. It contains icons to provide quick access to commands found in the drop down boxes on the main menu, e.g., New, Open, Print, Copy, Paste, etc.
Tip
When you place your mouse cursor over an icon on a toolbar, the name of the function appears on your screen. Selecting the >> drop down menu on the far right of the function and formatting toolbars opens a menu of options for customising the toolbars.

Using the ruler

The ruler controls how text and other objects are positioned in your document. Using the ruler, you can set tabs and indents and adjust the width of table cells.

Setting indents

You can change the position of the left and right side of a paragraph by moving the bottom indent markers. You can also just indent the first line of a paragraph by using the top indent marker.

- To change the left or right paragraph indent, select a paragraph and drag the bottom indent marker to the left or right.
- To change the first line indent for a paragraph, drag the top left indent marker to the left or right.

Adjusting the application settings

When you first open the Writer application, the workspace is organised so that Writer’s most used toolbars and features are available to you. As you become more proficient at word processing, you will find that you want to customise the Writer workspace to better meet your needs.

Page View Modes

OpenOffice Writer presents two choices for viewing documents as you work on them: Print Layout and Web Layout.

Print Layout

Print Layout shows what the document will look like if it was printed. This is the preferred way to view documents that are designed to be printed. To set the view to Print Layout, choose Print Layout from the View menu.

Web Layout

Web Layout shows what the document will look like if it was viewed with a web browser. This is the preferred way to view documents that are designed for web.
To set the view to Web Layout, choose **Web Layout** from the **View** menu.

![Web Layout menu option](image)

**Magnification Tools**

You can easily adjust the magnification of the workspace on your screen so that text and graphics are a more comfortable viewing size and your document fits well on the screen by setting the Zoom options:

1. From the **View menu**, click on **Zoom**.

   ![Zoom menu option](image)

2. The **Zoom & View Layout** dialogue window will open. You can adjust the magnification and view as follows:
   - Zoom can be adjusted automatically by selecting **Optimal**, which allows the software to pick a zoom setting that works well for your screen.
   - You can set the zoom to **Fit width and height** so that a single page will fit on your screen or **Fit width** so that the page width will match the width of your screen.
• If you choose 100% the document will be viewed at its full size on your screen.
• If you choose Variable you can set the zoom to whatever percentage of full size you like.
• The View Layout sets how many pages appear on the screen at the same time. You can set this to Automatic to let the software decide, Single for a single page or Columns for a number of pages fitting across the width of your screen.

Page Style

The Page Style dialogue allow you set up your document’s page style by selecting the paper size, the page orientation, margins and other layout settings. To access Page Style:

1. On the Format menu, click Page
2. Click on the Page tab

Paper Format

This option sets the paper format, size and orientation:

1. Set the paper format to match the paper size in your printer
2. Set the paper width and height if needed. Usually this will match the paper format you chose
3. Set the margins by increasing or decreasing the values in the Margin area

Modifying Options (show/hide toolbars and rulers)

OpenOffice Writer comes with a very large array of tools to format text and objects in your documents. When you install the application, the default toolset contains most of the tools that you will need to work on your documents, but you can also choose to show or hide toolbars or to modify toolbars if you need to.
To show or hide toolbars:

1. From the **View menu** click on **Toolbars**.
2. Click in the boxes to either show or hide toolbars as needed.

![Toolbar Options](image)

To modify a toolbar:

1. From the **Tools menu**, click on **Customize**. The **Customize dialogue window** will open. You can use this to modify menus, keyboard functions, toolbars or events.
2. Click on the **Toolbars tab**.
3. Choose the toolbar you want to modify from the dropdown list.
4. In the **Toolbar Content Commands** section, check the commands you want to include on the toolbar and uncheck the commands you don’t want to show. If the command you want is not in the list, click on the **Add button** to choose from a list of other commands.
5. Click **OK** to save your changes.

![Customize Dialogue Window](image)
Self Assessment

To assess your learning, make sure you are comfortable carrying out the following tasks in OpenOffice Writer:

1. Find and select OpenOffice.org Word Processor from the Applications menu.
2. Identify the following components of the OpenOffice Writer window:
   - Workspace
   - Formatting toolbar
   - Ruler
   - Menu bar
   - Function toolbar
   - Status bar
3. Change the paragraph indentation.
4. Change the page view mode from Print view to Web view.
5. Create a new document.
6. Save the document to disk as My First Document.
7. Close the document and exit OpenOffice Writer.
8. Again, start OpenOffice Writer and open your recently saved document.

Summary

In this section, you learned:

- The core components of the Writer workspace.
- How to use the Writer toolbars.
- How to adjust OpenOffice Writer to better suit your working style and needs.
Adding content to Writer Documents

Section Overview

So far we have learned how to get the Writer application ready by applying or modifying various setup options. In this section we will learn how to input content into our Writer documents.

In this section you will:

- learn how to input text with the keyboard
- be able to input special symbols that aren’t found on the keyboard
- be able to select a block of text for editing
- learn how to cut, copy and move blocks of text
- learn how to search for text in your documents and automatically replace blocks of text with another block of text

Working with text

Most of your work in Writer will be with text. You can insert many other kinds of objects in Writer documents, such as images and charts, but the application was designed with text in mind and so comes with a great many ways to adjust how text is displayed in your document.

Entering text into a document

As soon as Writer opens, the document is ready to accept your text input – just start typing and your text appears in the Writer workspace.

A few points for adding text:

- Do not use the Enter key <↓> when:
  - you finished one line and going on to a next line. Continue typing until you get to the end of the paragraph. The word processor will automatically jump to the next line. This is called word-wrapping; and
  - you want to go to a next page. Press <Ctrl>↓
- To start a new paragraph, press the Enter key <↓> on your keyboard.
- You can input any key character on your keyboard by simply pressing the key for that character or combining with the Shift key type the capital letter or with a character (for example, on a North American English keyboard, holding the Shift key while pressing the number 4 will input the dollar sign character $).
Special characters

Not all characters you might want to use are available on the keyboard. Some symbols, such as the Greek alphabet, French accents or mathematical symbols have to be added manually:

1. To view a selection of all characters, choose **Insert – Special Character**.

2. In the large selection field click the desired character or several characters in succession. The characters are displayed at the bottom of the dialog. When you close the dialog with **OK**, all of the characters you selected are inserted in the current document.

Formatting marks

Formatting marks are characters that show the type of formatting in your document, including paragraph breaks, spaces, line breaks, tab spaces, etc. Formatting marks do not appear when you print the document.
Turning formatting marks on allows you to see and edit the document formatting more easily:

1. To show formatting marks: from the View menu click on Nonprinting Characters.
2. To hide formatting marks, do the same as step 1: from the View menu click on Nonprinting Characters.

---

**Editing Content**

One of the major advantages of word processing applications is the ability to edit the content you’ve created. Editing can be as simple as retyping the content you have created. Advanced editing techniques allow you to cut, copy, move or replace large blocks of text quickly.

**Selecting content**

Before you edit any content, you have to be able to select the content you want changed. The easiest way to select content is using your mouse to highlight a block of content.

1. Place the mouse cursor at the start of the content you want to edit.
2. Holding the mouse button down, drag the mouse to the right and/or down. You should see that the content you have dragged over becomes highlighted. If you drag to the right, the content along a line of text becomes highlighted. If you drag downwards, whole lines of text become highlighted.

3. Once you have highlighted a block of text, you are ready to perform editing tasks on the content.

Changing text

The simplest editing method is to retype over the text you have written.

1. Select a block of content you would like to edit.
2. If all you would like to do is delete the text, click on the **delete** key on your keyboard.
3. If you would like to replace the content with new content, begin typing the new content. The highlighted text is replaced with your retyped content.

Duplicating and moving content

The **cut**, **copy** and **paste** commands allow you to duplicate or move large blocks of content all at once, without retyping.

Copy and paste

To duplicate large blocks of content, use the **Copy** and **Paste** commands.

1. Select the block of content you would like to make a copy of.
2. Copy the content by clicking in the **Edit menu** and choosing **Copy**.
3. Move your mouse cursor to the part of the document you would like the copy to be placed and click the left mouse button once. This is called the **insertion point**.
4. Paste the content you have copied by clicking on the Edit menu and choosing Paste. The copied content is placed in the document at the insertion point.

**Cut and paste**

To move a block of content use the cut and paste commands. Unlike copy and paste, cut and paste does not leave the original content you highlighted in place. Using cut and paste, the highlighted content is deleted and then pasted into a new location.

1. Select the block of content you would like to move.
2. Cut the content by clicking in the Edit menu and choosing Cut.
3. Move your mouse cursor to the part of the document you would like the content to be placed and click the left mouse button once.
4. Paste the content you have copied by clicking on the Edit menu and choosing Paste. The content is placed in the document at the insertion point.

**Undo and Redo commands**

It’s important, especially when you are a beginner word processor user, that you are able to easily fix any mistakes you make in editing your documents. One of the most useful ways to fix a mistake is to use the Undo command. This “undoes” your last action in the document. For example, if you were to cut a block of content, then realise it was not the content you wanted, using Undo would reverse the Cut command and the document would be back to its state.

- Click on the Edit menu and choose Undo.

If you would like to perform the same action many times, you can use the Redo command.

- Click on the Edit menu and choose Redo.

**Find and Replace**

The Find and Replace tool allows you to search for words or phrases—or, for that matter, for any combination of characters in a document—and replace them with the text you want.
**Searching for text**

1. From the **Edit menu**, click on **Find and Replace**
2. In the **Search for** input box, type in the text you would like to search for.
3. Click on the **Find button** to find the first instance of your search text.
4. Clicking again on the **Find button** will search through the document to find further instances of your search text.

**Replacing text**

1. From the Edit menu, click on **Find and Replace**.
2. In the **Search for** input box, type in the text you would like to search for.
3. In the **Replace with** input box, type in the text you would like to replace the search text with.
4. You can either replace instances of the search text all at once or one at a time. To replace one at a time:
   a. Click on the Find button to find the first instance of your search text.
   b. Click on Replace to replace that instance.
   c. Continue until you have finished making replacements.

5. To replace all instances:
   a. Click on Replace All button.

6. Click Close to return to your document when you are finished replacing text.

Self Assessment

To assess your learning, make sure you are comfortable carrying out the following tasks in OpenOffice Writer:

- Turn formatting marks on and off.
- Type a few paragraphs in a new Writer document.
- Select a block of text and delete it. Then undo the deletion using the Undo command.
- Copy a block of text and paste it to another location in the document.
- Move a block of text from one location in the document to another.
- Perform a search for a phrase in your document.

Summary

In this section, you learned how to:

- Input text with the keyboard into a Writer document.
- Input special symbols that aren’t found on the keyboard.
- Select a block of text for editing.
- Cut, copy and move blocks of text.
- Search for text in your documents and automatically replace blocks of text with another block of text.
Formatting Documents

Section Overview

In this section you will learn how to format text and paragraphs to make your document more readable by enhancing its visual design.

In this section you will:
- Select and change fonts and font sizes
- Apply formatting to text: bold, italic, underline, superscript, subscript, text spacing
- Apply text decorations: colour, highlighting, line-through
- Use automatic hyphenation
- Use tabs to position text
- Create and merge paragraphs
- Format paragraphs: alignment, spacing, borders and shading
- Create ordered and unordered lists and switch between list types
- Create, edit and use styles to apply formatting to text and paragraphs

Text Formatting

The following exercises will guide you through applying formatting to text, but also apply to formatting paragraphs. It’s important to note that formatting should be used to enhance the readability of your document, according to the guidelines discussed earlier in this module. Overusing formatting can detract from your document’s readability.

Fonts and font sizes

Your choice of fonts should set the tone for a design, provide the best readability and convey the right image. There are certain established guidelines and best practices for selecting fonts for the best results, but these are not hard and fast rules:

- Don’t use more than 3 or 4 fonts in your document.
- Avoid mixing two very similar fonts.
- Serif faces are the norm for most books and newspapers, making them familiar and comfortable to readers and a good choice for many printed documents.
- Sans serif fonts are a good choice for documents that are read from a computer screen. Sans serif fonts are generally more readable when the font size is small (e.g. for footnotes or captions).
- For most documents, a font size of between 10 point and 12 point is appropriate.

To choose a font and font size:

1. Highlight the text that you want the font applied to.
2. From the formatting toolbar, click on the down arrow next to the font box and choose a font from the list.
3. From the formatting toolbar, click on the down arrow next to the font size box and choose a font size from the list.

Bold, italics and underlining

You can use bold, italics and underline to place emphasis where needed in your document. Bold face is often used to draw attention to a block of text by making it stand out from the surrounding text. Bold face is also often used for headings.

Italic face can also be used for emphasis, but its impact is more subtle than bold face. Italic face is often used for titles (e.g. book titles, movie titles), the proper names of ships or trains (e.g. the Orient Express) or for foreign words or phrases within text. Be careful not to create long blocks of text with italic face, since it is more difficult to read.

Underlining text can also be used to emphasise parts of your document. However, since underlining is used to denote a web link in HTML, it’s use should be limited.

To apply bold, italics or underline:

1. Highlight the text that you want the font face applied to.
2. From the formatting toolbar, click on the icon for bold, italics or underline.

Superscript and subscript

Superscript is when text is raised above the baseline and is often used to indicate a footnote, to represent an exponent in mathematics (e.g. $5^2 = 25$) or to indicate an ordinal number (e.g. 25th).

Subscript is when text is dropped below the baseline and is typically used in chemical formulas (e.g. H$_2$O).

To apply superscript or subscript commands:

1. Highlight the text that you want the style applied to.
2. Choose Format->Character from the Writer menu.
3. Click on the Position tab.
4. Choose superscript or subscript from the dialogue window. You can also choose how much to raise or lower the text by or what size to make the text.
5. Click OK when you are finished.

Text decoration

Text decoration includes such things as text colour, highlighting and line-through. Text decoration, like bold and italics, can be used to emphasise text in a document, but should be used sparingly because it can be distracting.
To apply text decoration:

1. Highlight the text that you want the font applied to.

2. From the formatting toolbar, click on the icon for the text decoration you want to use.

3. Choose Format->Character from the Writer menu.

4. Click on the Font Effects tab.

5. Choose the font effect you want to apply: underlining, strikethrough, font colour or other effects.

6. Click on the OK button to save your changes.

**Automatic hyphenation**

Automatic hyphenation can be used to automatically break words at the end of a line of text so that part of the word wraps to the next line of text. This has the effect of making your lines of text more even in length.

In practice, it is usually better to not use automatic hyphenation. You will typically get better results by looking at your document after you have
typed it and creating manual hyphenations where needed. One reason for this is natural variations in line length enhance the readability of your document by making a distinction between one line and the next. If a line of text is extraordinarily short, you can use hyphenation on the first word of the next line to ease this.

To turn automatic hyphenation on:

1. Choose Format->Paragraph from the Writer menu.
2. Click on the Text Flow tab.
3. Click on the checkbox to set hyphenation automatically.

![Hyphenation Settings](image)

Tip: The formatting effects described above can be applied to paragraphs as well. Simply select a whole paragraph and apply the effects as usual.

**Paragraph Formatting**

As discussed earlier, an effective paragraph organises a sentence or group of sentences around a single main idea. There is no ideal paragraph length, although a paragraph that is overly long can be harder to read. Too many one-sentence paragraphs in a document is also distracting. Please use one-sentence paragraphs only when really necessary – to emphasise a specific point.

Make sure your paragraphs have one main idea. If there is more than one main idea, split the paragraph up.

**Creating and merging paragraphs**

When you create a new document in OpenOffice Writer, you are automatically places at the beginning of your first paragraph. Type the sentences you want for your paragraph and when you are finished, press the **Enter** or **Return** key on your keyboard to end the paragraph and begin a new one.
Any formatting that you applied to your first paragraph is automatically carried over to the next paragraph.

Two paragraphs can be merged by placing your cursor at the beginning of the second paragraph and pressing the **Backspace key** or placing your cursor at the end of the first paragraph and pressing the **Delete key**.

**Text alignment**

There are four forms of alignment for text in your document:

1. **Left alignment**: Text is aligned so as to be even along the left side of a paragraph. The lines are uneven along the right side of the paragraph.
2. **Right alignment**: Text is aligned so as to be even along the right side of a paragraph. The lines are uneven along the left side of the paragraph.
3. **Centre alignment**: Text is aligned so as to be centered in the document. The lines are uneven along both the left and right side of the paragraph.
4. **Full alignment**: Text is aligned so as to be even along both the left and right sides of a paragraph. This is accomplished by adjusting the spacing between words where necessary.

Generally you should use left alignment in your documents because it enhances readability. Use the other forms of alignment for special effect when necessary.

To set the alignment of your documents:

1. Select the paragraph you want to apply the alignment to.
2. On the formatting toolbar, click on the button for the alignment you want applied.

**Using tabs**

Tabs are used to position text horizontally within a document. By default, tab stops are placed every half inch if your measurements are set in inches or every 1.25 centimeters if your measurements are set in metric units.
There are 4 types of tabs you can set in Writer:

- **Left tab**: the text starts at the tab position.

- **Right tab**: the text stops at the tab position.

- **Centre tab**: the text is centred at the tab position.

- **Decimal tab**: used for positioning a series of numbers. The decimal points line up over the tab position.

There are two steps to using tabs:

1. Setting tab positions (or tab stops).
2. Placing text at the tab positions from within the document.
Setting tab positions

Tab positions can be set on the ruler or using the tab format options. To set a tab on the ruler, simply click on the ruler at the position you want the tab. You can reposition the tab by clicking and dragging it to the left or right. By default, tabs that you set this way are Left tabs. You can change the tab type by double-clicking on the tab and setting the tab type from the dialogue box.

To set tabs using the tab format options:

1. Place your cursor at the point in the text you wish to position with a tab.
2. Choose **Format->Paragraph** from the Writer menu
3. Click on the **Tabs tab**.
4. Choose the position you want the tab, the type of tab and the fill or leader you want.

Placing text at the tab position

Once you have your tabs set, you can position your text by placing your cursor at the start of the text you want to position and then pressing on the Tab key on your keyboard.
Paragraph spacing

Paragraph spacing can be used to make your paragraphs more readable and visually presentable by making paragraphs stand out from each other. You can set spacing between paragraphs or on each side of a paragraph (indentation).

Spacing between paragraphs and indentation should be done using the paragraph formatting options rather than typing an extra paragraph marker by pressing the return key twice. This way you can control the paragraph spacing throughout your entire document.

1. Select the paragraphs you want to space or indent.
2. Select Format->Paragraph from the Writer menu.
3. Click on the Indents & Spacing tab.
4. Set the amount of left and right indentation. You can also set additional indentation for the first line of paragraphs.
5. Set the amount of spacing above and below each paragraph.
6. Click the OK button when you are finished.

Working with lists

Lists enhance the readability of your document by organising parallel ideas or ideas that need to be presented in a sequence. Lists should form logical groups and should be written using parallel structure.

Unordered lists

Unordered lists are used to organise ideas when the order of the ideas is not important to their presentation. Each list element in an unordered list is started with a bullet. To create an unordered list:

1. Type your list elements, creating a new paragraph with each element.
2. Select all of the list elements.
3. On the formatting toolbar click on the unordered list icon.
Ordered lists

Ordered lists are used when the order of the list elements are important, such as a set of instructions or a list of priorities. Each list element in an ordered list is started with a number of letter. To create an ordered list:

1. Type your list elements, creating a new paragraph with each element.
2. Select all of the list elements.
3. On the formatting toolbar click on the ordered list icon.

Modifying list format

You can modify your lists by changing the list type (ordered or unordered), changing the bullet style for unordered lists or changing the number or letter style for ordered lists. To change the list format:

1. Select the list elements you want to change.
2. To change the list type, click on the appropriate button from the format toolbar.
3. To change list style options, click on Format->Bullets and Numbering from the Writer menu.
4. Choose the type of numbering or bullets you want to use for your list.
From the **Bullets and Numbering dialogue** you can also format your list to create outlines or use graphics as bullets. As with other elements of word processed documents, keeping the style simple is usually preferable.

**Paragraph borders and shading**

Borders and shading can also make a paragraph stand out from the other paragraphs and content in a document. A border is a rectangular area surrounding a paragraph. Shading refers to the colour or image behind a paragraph or block of text.

**Setting borders**

You can choose to display and set features of borders:

1. Select the paragraph you would like the formatting applied to.
2. Choose Paragraph->Borders from the Writer menu.
3. From the Borders dialogue, choose the border features you want, such as line arrangement, border colour and thickness, spacing and shadow.

**Setting shading**

1. Choose Paragraph->Shading from the Writer menu.
2. Click on the Background tab.
3. Set the background colour or image from the dialogue window.

Creating and Applying Styles

Styles allow you to save formatting options for the content in your document and to easily apply this formatting to other content in the document.

Writer has many pre-defined styles built in to the program. You can use these styles as they are, edit them or create new styles.

To apply a style:

1. Select (highlight) the content you want to apply the style to.
2. Choose **Format->Styles and Formatting** from the Writer menu.
3. Apply the style you want to use by double-clicking on the style. You can choose styles for paragraphs, characters, frames, pages or lists by clicking on the icons at the top of the style dialogue.

You may want to create a new style specifically for your document. To create a new style:

1. Choose **Format->Styles and Formatting** from the Writer menu.
2. Choose a style from the list to base your new style on.
3. Click on the **New Style from Selection** button and choose **New Style from Selection**.
4. Type a name for your new style and click OK. You now have created a new style.

To modify a style:
1. Right-click on the style and choose **Modify** from the context menu.
2. From the style window that opens, select the features you would like in your new style.
Self Assessment

Create a new document using Writer and practice the formatting techniques you learned in this module. In particular:

- Format your characters by choosing a font, modifying the font size and using formatting options such as bold, italics and colour.
- Create text that uses a superscripted or subscripted character.
- Activate and deactivate automatic hyphenation.
- Use a variety of tabs and indentations to position your text.
- Merge two paragraphs together.
- Increase the spacing between your paragraphs.
- Create a border around a paragraph.
- Create an unordered list and then switch it to an ordered list.
- Change the ordered list from using numbers to using letters.
- Create a new paragraph style and apply it to a paragraph.

Summary

This section covered the major techniques for formatting the text and paragraphs in your document to position text on the page and to apply text decoration to make text stand out. More importantly, this section emphasised how to use these techniques to make your document more readable, but not to overuse formatting until it distracts from your document.

This section also covered how formatting can be applied to large blocks of text such as complete paragraphs and how styles can be created to save time with your document creation.
Adding tables, images and charts

Section Overview

This section discusses ways to increase the effectiveness of your documents by using tables to organise information, charts to present data and images to enhance your ideas.

In this section you will:
- Use tables to organise your content.
- Create and import charts to display data.
- Import and format images.

Tables

Tables allow you to present your content in rows and columns rather than in one large block of text. This is helpful when your content involves comparing values to each other. For example, suppose we wanted to explain how the average rainfall in Vancouver, Canada changes over the course of six months.

<table>
<thead>
<tr>
<th>Month</th>
<th>Rainfall (mm)</th>
</tr>
</thead>
<tbody>
<tr>
<td>January</td>
<td>146</td>
</tr>
<tr>
<td>February</td>
<td>121</td>
</tr>
<tr>
<td>March</td>
<td>102</td>
</tr>
<tr>
<td>April</td>
<td>69</td>
</tr>
<tr>
<td>May</td>
<td>56</td>
</tr>
<tr>
<td>June</td>
<td>47</td>
</tr>
</tbody>
</table>

Inserting tables

To insert a table:

1. Place your cursor where you want the table to be.
2. Choose Insert->Table from the Writer menu.
3. Choose the number of rows and columns in your table.
4. You can also choose from a number of table templates by clicking on the Autoformat button.
5. Click OK and your blank table is created.
Adding data to a table
To add data to a table, simply click inside a table cell and type your data as normal. You can:
- add content inside table cells just as you would elsewhere in your document, including text, images, paragraphs and lists
- format content in the same way as you would elsewhere in your document
- set tab stops, margins and indents to further organise content within a table.

Deleting a table
To delete a table:

1. Click inside one of the cells of your table.
2. Choose Table->Delete->Table from the Writer menu.

Add and delete columns and rows
You can add or delete columns and rows in your table as needed. To add a column or row:

1. Click in the table where you want the column or row to be added.
2. Choose Table->Insert->Rows to add rows to your table or choose Table->Insert->Columns to add columns to your table.
3. Choose the number of columns or rows you want to insert and choose whether you want them before or after your selected position in the table. Then click OK.
To delete a column or row:

1. Select the column(s) or row(s) you wish to delete.
2. Choose Table->Delete->Rows to delete rows or Table->Delete->Columns to delete columns.

Modifying columns and rows

You may need to adjust the columns and rows in your table to fit the data you are presenting. For example, you may need to adjust the column width or row height or apply borders and shading to cells in your table.

Row height and column width

The height of a row in your table will expand automatically to contain the objects or text you place in your table. You can adjust the height of a row by:

1. Select a row or rows that you want to change.
2. Right-mouse click on the row and choose Height from the context menu.
3. Type in a value for the row height, then click OK.
Set column width by:

1. Select a column or columns that you want to change.
2. Right-mouse click on the column and choose Width from the context menu.

3. Type in a value for the column width, then click OK.

**Borders and shading**

Borders and shading can enhance the appearance of your table by giving emphasis to cells, rows or columns and by visually separating the content within columns.

To format borders:

1. Select a column or row you want to edit.
2. Select **Table->Table Properties** from the Writer menu.
3. Click on the **Borders tab**.

4. Edit the table borders as needed and click OK.
To format column shading:

1. Select a column or row you want to edit.
2. Select **Table->Table Properties** from the Writer menu.
3. Click on the **Background tab**.

4. Select a background colour for your table cells.

**Images**

Images can add to the effectiveness of your documents. In addition to providing visual contrast to text, appropriate graphics enhance the reader’s comprehension of your content by providing details that text alone cannot (as the saying goes, a picture is worth a thousand words).

**Inserting images**

To place an image in your document:

1. Click in the document at the point you want to insert the image.
2. Choose **Insert->Picture->From File** to get the image.
3. Browse to the location (directory) of your image.
4. Select the image you want.
5. Click **Open** to insert the image.

**Modifying images**

**Copy and move an Image**

Copying and pasting images is done the same way as for text:

1. Select the image you want to copy or move.
2. Choose **Edit->Copy** (to copy an image) or **Edit->Cut** (to move an image) from the Writer menu.
3. Click in the document where you want to insert the image.
4. Choose **Edit->Paste** from the Writer menu to insert the image.

**Resize an image**

1. Select the image you want to resize.
2. Select **Format->Picture** from the Writer menu.
3. In the dialogue that comes up, you can change the image size and set other attributes for the image, such as position, spacing or borders. To change the size of the image, click on the **Type tab** and type in the size you want.

**Note:** If you put a checkmark in the Keep Ratio box, the image will maintain a constant aspec ratio (ratio between length and width of the image), so your image isn't distorted.

**Charts**

Charts or graphs provide a way to display related data, especially numerical data, in a visual form. For example, let’s use a table comparing average monthly rainfall in Vancouver, Canada:

<table>
<thead>
<tr>
<th>Month</th>
<th>Rainfall (mm)</th>
</tr>
</thead>
<tbody>
<tr>
<td>January</td>
<td>146</td>
</tr>
<tr>
<td>February</td>
<td>121</td>
</tr>
<tr>
<td>March</td>
<td>102</td>
</tr>
<tr>
<td>April</td>
<td>69</td>
</tr>
<tr>
<td>May</td>
<td>56</td>
</tr>
<tr>
<td>June</td>
<td>47</td>
</tr>
<tr>
<td>July</td>
<td>31</td>
</tr>
<tr>
<td>August</td>
<td>37</td>
</tr>
<tr>
<td>September</td>
<td>60</td>
</tr>
<tr>
<td>October</td>
<td>116</td>
</tr>
<tr>
<td>November</td>
<td>155</td>
</tr>
<tr>
<td>December</td>
<td>172</td>
</tr>
</tbody>
</table>
This information could be displayed on a bar graph to give a more visual presentation of the rainfall data and to clearly show trends:

![Average Rainfall in Vancouver](image)

You can insert a chart based on data you create in a **Writer table** or an **OpenOffice Calc spreadsheet**. This is the preferred method, since in this case, the chart automatically updates whenever the data in the table changes.

To insert a chart based on data in a table:
1. Highlight all of the data in the table.
2. Choose **Insert->Object->Chart** from the Writer menu.
3. Click on the **Chart Type tab** to choose a chart type (bar, pie, column, line etc.).
4. Click on the **Data Range tab** to choose the data range (note: if you selected the whole table, the data range should be automatic).

![Chart Wizard](image)
5. Choose whether the data range is in columns or rows and which columns or rows are the labels for the data.

6. Click on the **Data Series tab** to adjust the data series if needed.

7. Click on the **Chart Elements tab** to add elements such as a title and legend.

8. Click OK to view the chart.

**Editing charts**

All of the chart elements, including labels, data ranges, colours and borders can be edited by double-clicking on the element and changing the values for that element. In particular, the chart table can be edited and the results are immediately reflected in the chart.
Self Assessment

Test your understanding of this section by creating a document that uses a table to organise content. For example, it could be a contact list for your friends or associates organised by name.

Summary

This section emphasised using elements such as table, graphics and charts to enhance your document. The emphasis of this section is to organise and enhance content so that your document’s message is more easily understood by your reader.

Tables are essential for organising certain types of data into columns and rows that can be easily interpreted. Graphics can sometimes be used to convey a message more clearly than text. Charts can help explain complex relationships using a pictorial representation of data, again much more easily than text. The right picture really is worth a thousand words.
Section Overview

Mail merge is an advanced feature of word processor applications that makes it easy to create a document for distribution to a large number of people without having to recreate the document each time. This is accomplished by creating one main document that contains all of the static or unchanging information and merging it with another document that contains all of the individual information, such as names and addresses.

In this section you will:

- Understand how mail merge can make it easier to create a document for a large number of individuals.
- Create a mail merge document.

Preparing the documents

There are three main steps:
- creating the data source
- creating the main document
- Merge the two documents

The merged document can either be saved or printed. Fortunately, Writer comes with a mail merge wizard that will guide us through the process.

Creating the main document

Create the main document by opening OpenOffice Writer.

For now, we will start with a blank document. The Mail Merge wizard will insert some of the content for us and we can customise the document later.
Creating the data source

Next you need to create the data source (spreadsheet, address book, other file or database) that the mail merge will use.

The data source is the file that typically will hold the addresses, names and other information for the individuals that will each receive your form letter.


2. Choose **Use the current document** for Step 1 of the wizard.
3. Choose **Letter** for the document type in Step 2 of the wizard. The output document will be a printed letter rather than an e-mail message.

4. We will create a new address list for this merge document. In practice, you might already have an address list created, either as a database file or spreadsheet. Click on the **Select Different Address List** button to begin.
5. In the Select Address List dialogue, click on the Create button to create a new list.

6. You will be presented with a form to create a new contact list. In this form, you create one contact at a time by filling in all of the information for that contact. When you are finished with the first contact, click the New button to add a new contact.

When you are finished adding contacts, click the OK button.

7. Type a name for your contact list in the Name bar and click the Save button to save your contact list.
8. Select the address list by clicking the OK button.

9. We can customise the look of our merge document by selecting an address block. This will automatically place an address block in our document.

10. We can then add a salutation to our document.
11. We can then view and adjust the layout if necessary.

12. Since we haven’t yet written the text of our document, we can click on the **Edit Document** button to do so.

13. If needed, you can personalise the document for individual recipients.
14. Finally, you can save or print your documents.

Self Assessment

Go through the steps to create a document that merges a birthday invitation with a contact list of your friends. Create the contact list, merge the documents, save the document and then preview it to make sure the merge was successful.

Summary

Mail merge is a useful tool to save time when the same information is being sent to a large number of people. However, it is not that useful when the message is more personal.

This section introduced the concept of a data file – a file that stores information such as contact names and addresses that can be used to provide useful information. You will explore this concept in much more detail in a later module on databases.
Preparing documents for output

Section Overview

This section discusses the steps you will take in the final preparation and printing of your OpenOffice Writer documents.

In this section you will learn how to:

- Create Headers and Footers for your documents.
- Set margins and page breaks to make your documents more presentable.
- Check your documents for spelling errors.
- Set up documents for printing.

Document Formatting

So far we have focused on the formatting of elements in your documents such as characters, paragraphs and tables. In this section we will discuss formatting the document as a whole by adjusting margins, document orientation and page breaks and adding custom headers and footers to documents.

Document orientation

Document orientation is a style that applies to the whole document. By default, when you create a new document it is oriented in portrait mode, which is appropriate for most of the documents you will create.

You can edit the orientation of your document as follows:

1. Choose Format->Page from the Writer menu.
2. Click on the Page tab.
3. Select the size of paper you will be printing on. If you choose one of the standard formats from the **Format** list, the paper size will be set automatically. You can also create a custom paper size by inputting values for the paper height and width.

4. Choose **Portrait** or **Landscape** for your document's orientation.

**Margins**

Page margins provide white space around the outside of your documents and are important to your document's readability. Page margins that are too narrow give the visual appearance that your document is cluttered and lengthy and discourages readers. Page margins that are too wide make your document appear insubstantial. Choose a medium setting for page margins - .75 to one inch is common (1.7 – 2.5 centimetres).

To set page margins:

1. Choose **Format->Page** from the Writer menu.
2. Click on the **Page tab**.
3. Set the margins for left, right, top and bottom by typing a number in the settings box or using the arrows to increase or decrease the margins.

**Page breaks**

Page breaks are created automatically as you input text and other data into your documents. There are times, however, when you may want to insert a page break manually so that you can control where the break happens. An example would be if you had a large table that starts partway down a page and continues onto the next page. Rather than break the table in the middle, you can insert a page break just before the table so that the table will appear in its entirety on the next page.

To set page breaks in your document:

1. Click in the document at the point you want the page break to occur.
2. Choose **Insert->Manual Break** from the Writer menu.
3. Select **Page Break** and click **OK**.
Headers and footers

Headers and footers allow you to create text that will appear at the top (header) or at the bottom (footer) of every page in your document or on every even or odd page. As you add text to your document, the header and footer don't move – they are always at the top and bottom of every page. Examples of common header and footer information include the document title, author, date or page numbers.

Headers

To enable headers:

1. Choose **Format->Page** from the Writer menu.
2. Click on the **Header tab**.
3. Enable headers by checking the Header on box.
4. Choose whether you want the same header content on left and right pages or different content on each side.
5. Set the margins and spacing attributes for your header.
6. Click **OK** to close the dialogue.
7. You will now have a header bar on your document. You can add text or images to the header and format just the same as in the rest of the document. What you add to the header will be displayed on every page of the document or every odd or even page if you so specified.
To enable footers:

1. Choose **Format->Page** from the Writer menu.
2. Click on the **Footer tab**.
3. Enable footers by checking the **Footer on** box.

4. Choose whether you want the same footer content on left and right pages or different content on each side.
5. Set the margins and spacing attributes for your footer.
6. Click **OK** to close the dialogue.
7. You will now have a footer bar on your document. You can add text or images to the footer and format just the same as in the rest of the document. What you add to the footer will be displayed on every page of the document or every odd or even page if you so specified.

**Special header and footer content**

**Page numbering**

It's often desirable to have page numbers on your document, especially for long documents. Here is how you can insert page numbers to your headers and footers:

1. Click on the header or footer where you would like the page number to be.
2. Choose **Insert->Fields->Page Number** from the Writer menu.
3. The page number will appear at the point you chose. Also, the page number will change automatically as you scroll through the pages of your document.

Using fields

Page numbers are an example of a field. You can insert other fields in your document such as date, time, page count and author.

1. Click in your document at the place you want to insert a field.
2. Choose Insert->Fields from the Writer menu.
3. Choose the field you want to insert.
Spell check and grammar check

Writer offers the ability to check the spelling of the words in your document. Although this is a great tool, it shouldn't replace careful spelling and proofreading. Just because a word is spelled correctly doesn't mean that it is used correctly, as in this sentence:

I'd like to go driving, but I can't get my care to start.

Also, some words may appear as incorrect in your document, when they are indeed correct. For example, the British spelling of “colour” appears as incorrect in many spell check programs. Thankfully, writer also gives you the ability to add to its internal dictionary.

Grammar check is a useful tool to pick up grammatical errors, but like spell check, it's not a replacement for careful editing and proofreading.

You can perform a spell check on your document at any time, but Writer monitors your spelling for you as you are typing and indicates a misspelled word with a wavy line underneath.

To spell check your document:

1. Choose Tools->Spelling and Grammar from the Writer menu.
2. The spell check program will scan your document for errors and when it finds one it will offer suggestions to correct the error.
3. You can then choose to ignore the suggestion, add the word to the dictionary or correct the spelling based on the suggestions.

Preparing to print documents

The steps you have gone through prior to printing your document help to ensure that your document is as polished and as correct as possible and that you don't waste resources by having to reprint a document because the first printing had errors.

You are now almost ready to send your document to print. As a final step, you should preview what your document will look like when it's printed to make sure that pagination, margins and formatting appear correctly.
To preview your document:

1. Choose **File->Page Preview** from the Writer menu.
2. Adjust the zoom so that you can get a good sense of what the document looks like in Print view.
3. Scroll through the document by clicking on the **Next Page** and **Previous Page** buttons.
4. When you are finished, close **Page Preview** and edit the document if necessary or send your document to print.

**Printing documents**

To print your document:

1. Choose **File->Print** from the Writer menu.
2. Choose your printer and adjust the printer properties if necessary. Some printer properties are specific depending on the type of printer you are using. For example, you may need to set properties for your printer if you are printing in high quality colour.
3. Choose the pages you would like printed (by default the complete document is printed).
4. Choose the number of copies you want to print (by default one copy is printed).
5. Click on the OK button to print your document.
Self Assessment

To assess your learning, make sure you are comfortable carrying out the following tasks in OpenOffice Writer:

- Create a new document in Writer or open an existing document.
- Insert a header with your name and a footer with the page numbers.
- Do a spell check on your document.
- Change the margins on the document to 1 inch or 2.5 centimetres
- Print the document.

Summary

This section outlined the options for setting your document up for printing. We discussed document formatting techniques such as setting margins orientation, page breaks, footers and headers. You should keep in mind that these techniques should be used to enhance the readability of your document.

This section also emphasised that although tools such as spell check and grammar check can be very useful, they do not replace the need for careful writing and careful editing.

Finally, this section outlined the process for previewing and printing your document.
Module 4
Spreadsheets using OpenOffice
CALC
Module Overview

In this module you will learn how to develop, work with and manipulate spreadsheets using the computer application OpenOffice Calc.

At its core, a spreadsheet is a table of rows and columns, creating a grid of cells in which numeric or text values are displayed. In most situations, spreadsheets are used for manipulating numeric data. The spreadsheet computer application is designed to enable you to model and observe the relationships among data in the respective rows and columns.

Spreadsheets can be useful in a variety of contexts, e.g., to analyse business data, to track personal finances, or to create charts for visual interpretation of data.

Upon completion of this module you will be able to:

- Develop, format, modify and use a spreadsheet
- Generate and apply standard formulae
- Create and format graphs and charts
- Output a spreadsheet to print

Terminology

Spreadsheet
A spreadsheet is a large sheet of rows and columns that lays out information about a financial transaction, including things like costs, taxes, income, etc., so that a business person or manager can easily make decisions.

Worksheet
A worksheet is one page of a spreadsheet. An electronic spreadsheet document can incorporate many worksheets.

Cell
A cell is the area formed by the intersection of a row and a column. Spreadsheet cells contain information such as text, numbers, and formulas.

Toolbars
Toolbars are areas in the application that contain most of the common commands and functions you need to use the application.

Formulas
A formula is a spreadsheet function entered in a cell.

Functions
A function is a formula that is built into the Calc program.

Chart
A diagram that displays data in a pictorial form.
Relative Cell Reference
A reference to a worksheet cell that is dynamic. The reference changes with changes in the worksheet.

Absolute Cell Reference
A reference to a worksheet cell that is static. The reference doesn’t change with changes to the worksheet.

Study Tips

You may find it useful to skim through an entire block of content first, paying special attention to the headings and introductions, and then go through a second time for more in-depth study and practice.

However, we recommend that you do the activities as they appear. They are essential study materials, offering practice in particular skills that will build your proficiency in using spreadsheets.

Keep linking the new content that you are studying with content in this module that you have already covered and with your own general knowledge, to deepen your understanding of the operations you are learning.

If you have difficulty understanding any area, try working at it slowly. If you still do not understand, seek help.

Preknowledge

Before beginning this module, we recommend that you:

- complete the modules on Computer Applications (Modules 1 and 2) and Word Processing (Module 3)
- be skilled in arithmetic computation: addition, subtraction, multiplication, division, computation with decimal numbers, computation of percents
- be skilled at estimating the results of simple calculations, so when entering formulas the results can be mentally checked
- be a logical thinker, that is, capable of following a series of calculations from one step to the next
Introduction to Spreadsheets

More than any other application software in history, the spreadsheet has been instrumental in helping personal computers gain widespread acceptance in the business community. Called a “killer” application, spreadsheets made such an immediate impact on financial accounting that businesses couldn’t afford to not take notice.

Section Overview

This section will introduce you to the key concepts of the spreadsheet application.

By the end of this section, you will:

- appreciate the impact that the development of the spreadsheet had on growth of the personal computer industry
- become familiar with some design considerations for spreadsheet documents

Development of the spreadsheet

Spreadsheets, in their original paper form, have been used in financial accounting for hundreds of years. A spreadsheet is a large sheet of rows and columns that lays out information about a financial transaction, including things like costs, taxes, income, etc., so that a business person or manager can easily make decisions.

Electronic spreadsheets are much more recent. Their development dates back to 1978, when Dan Bricklin and Bob Frankston, two MIT acquaintances, developed a program called VisiCalc (from the words visible and calculator). VisiCalc became an instant success and convinced a lot of business people to purchase a personal computer for their business. (reference: http://www.bricklin.com/history/sai.htm)

In 1983, a new spreadsheet application called Lotus 1-2-3, designed to run on personal computers being produced by IBM, was introduced. It added integrated charting, plotting, and database features, and established the spreadsheet as a tool for data presentation and complex calculations.

The next milestone was in 1985, when Microsoft Excel was written for the Apple Macintosh personal computer. The Macintosh offered the advantage of a graphical user interface, with pull-down menus and the point-and-click capability of the mouse, which made it easier for most people to use. When Microsoft released the Windows operating system, Excel was the first spreadsheet software designed to run on it.
Design considerations for spreadsheet documents

The two features of a good spreadsheet are:
- good data, and
- good design. Good design makes it easier to enter data and retrieve valid results. Poor design can make a spreadsheet unusable despite having excellent data to work with.

The points below will help you to avoid becoming disoriented in the maze of spreadsheet cells by designing your spreadsheet so that you can navigate easily. Other suggestions will help you create a spreadsheet document that analyses data quickly and efficiently. You may not understand all of the terms described below until you work through the practical exercises, but refer back to this list often as you create new spreadsheets.

1. You should start your design with an end in mind. Establish how you are going to layout the columns and rows of your spreadsheet. Spreadsheet software has far more rows than columns, so generally you should create your spreadsheet document with the headings running across the columns, and the data in rows underneath.

   ![Spreadsheet example](image)

2. Sometimes the number of rows or columns will increase over time, and sometimes they will remain fixed, but you should assume that you will have to add more data or formulas sometime in the future (because you probably will).

3. Use descriptive labels for rows, columns, and cells in your spreadsheet.

4. Use different type faces or font colours to distinguish data and highlight features of your spreadsheet, but keep it simple. Use **Bold** for data headings.

5. All raw data should be included in a single worksheet (a worksheet is one page of your spreadsheet).

6. Leave about four blank rows at the top of your spreadsheet above your column headings. These can be used for keeping totals, since this location is much easier to find than at the bottom of your data.
7. Have your data sorted as much as possible. This will help keep your spreadsheet organised, but will also help speed up some calculations.
8. Use a date format that the spreadsheet recognises as a date (as opposed to text). This will allow you to use this data in formulas.
9. Don’t combine data into one cell. For example, a person’s name should go into at least two cells: **Family Name** and **Given Name**.
10. Decide what formulas you need to use to perform the calculations in your spreadsheet.
11. Decide what charts or graphs are most appropriate to display the results of your spreadsheet analysis.

The following main types of graphs/charts are possible:

- **Column**
- **Bar**
- **Pie**
- **Area**
- **Line**
- **XY Scattered**

**Summary**

This section discussed the development of the spreadsheet application, and introduced the concept of spreadsheet design, in particular how good design makes it easier to enter data and retrieve valid results from your spreadsheets.
Using the Spreadsheet Application: The Basics

Section Overview

OpenOffice Calc is the application we will be using to develop and work with spreadsheets. Calc is similar to Microsoft Excel; in fact you can save your Calc spreadsheets in Excel format for sending to Microsoft users.

In this section we will become familiar with the basic features of the Calc application and learn how to perform basic spreadsheet operations.

Upon completion of this section you will be able to:
- open and close Calc
- identify the core components of the Calc workspace
- open one and several spreadsheets; close a spreadsheet
- create a new spreadsheet
- save spreadsheets in different locations and under different conditions
- switch between worksheets in a single spreadsheet
- use help functions in Calc
- use tools to adjust settings

Opening and closing Calc

Opening and closing OpenOffice Calc is done the same way as opening and closing OpenOffice Writer from Module 3, by using the Applications menu in the top-left of the Ubuntu desktop.

To open CALC:

1. Click on the Applications menu.
2. Click Office
3. Click OpenOffice.org Spreadsheet.
This will present the OpenOffice splash screen as the operating system loads the Calc application.

To close CALC:

- Click on the File menu in Calc, then click Exit or
- Click on the Exit icon in the top right hand corner of the Calc window.

Creating, opening, and closing spreadsheets

Creating a new spreadsheet

When you launch the Calc application, a blank spreadsheet is created for you automatically. To create a new spreadsheet from within the Calc application:

1. Click on File on the menu Bar.
2. Click on New on the drop down menu.
3. Click on Spreadsheet. This will display a blank spreadsheet.
Your work area is one of the worksheets of the spreadsheet that you are working on. The tabs in the bottom left corner of the work area allow you to switch between worksheets. If the tab for Sheet 1 is highlighted, then it is the first worksheet that is being displayed. If you click on Sheet 3, then the third worksheet replaces the first on the screen. The spreadsheet consists of all these worksheets.

A spreadsheet consists of text, numbers and formulas that are entered into the cells of its worksheets. Collectively, text, numbers and formulas are referred to as data. Spreadsheets that contain data are saved as files, just as in the case of word processed documents.

**Opening an existing spreadsheet from within Calc**

1. Click on File in the menu bar.
2. Click on Open. This brings up the Open Dialogue window. The dialogue lists a series of directories and files.
3. Locate the directory in which the desired file is held.
4. Click on the directory to open it.
5. Highlight the file.
6. Click Open.

**Tip:** If you are not sure about the directory that contains your file and you have to search a bit, you will find the Up one Level icon useful.
Closing a single spreadsheet

Before we perform this task, we need to be clear about the difference between the 'close' and 'exit' commands. Close closes the spreadsheet, but leaves the program Calc and other spreadsheets open. Exit closes the spreadsheet you are working on, any other spreadsheet that is open, as well as Calc.

1. Click on File on the menu bar.
2. Click on Close. This command is in the top section of the drop down menu. Exit is in the bottom section.

Tip: Always save your data before closing or exiting. Calc will help you here if the version of the document that you have on the screen differs from the one already saved on the hard disk. Calc will ask you whether you want to save the new version. Secondly, always close Calc before you shut down the system.

Working with multiple spreadsheets

If you need to work on more than one spreadsheet at the same time, you can open multiple spreadsheets and move between them. You may want to do this if you need to copy data from one spreadsheet to another.

1. Click on File then Open.
2. Locate the directory containing the files you wish to open.
3. Click on the first file.
4. Hold down the CTRL key and click on each of the additional files you wish to open.
5. Click **Open**. The last of the files loaded will appear in the window. This will be the active spreadsheet. The others are also loaded but are in the background.

You can make one of the other spreadsheets active as follows:

1. Click on **Window** to list the spreadsheets that are loaded.
2. Click on the spreadsheet that you wish to make active.

**Close more than one spreadsheet**

If you wish to close some but not all the spreadsheets you have loaded, then you will use the **Close** command for each separately. If you want to close all spreadsheets as well as exit CALC, then you will use the **Exit** command.
Saving spreadsheets

You will want to save your documents often so that you don’t lose data if your computer crashes or if your application is inadvertently closed. If you exit the application without saving, Calc will prompt you to save your work.

Saving on the hard drive of your computer

1. Click on File, then click Save As. This will bring up the Save As dialogue.
2. Locate the drive and /or the directory in which you wish to save the file. You can save files to your hard drive, floppy drive, Flash Memory stick, or many other storage memory devices.
3. Enter the name of the file in the File Name window.
4. Click Save.

Save an existing file under another name

Sometimes we may want to have the same spreadsheet saved under a number of different names. Alternatively, we may want to save a spreadsheet before making changes. We would then have a copy of the new version as well as the version before changes were made. Suppose we have a spreadsheet loaded as shown below. In this case the spreadsheet already has the name demo.sxc.

We can now save what is displayed on the screen in two ways:

- As the existing file: After loading demog.sxc from the hard disk, we made some changes to it. Those changes exist only on the version on the screen and will not automatically be made to the file that is located on the hard disk. To replace the version on the hard disk with the contents as displayed on the screen.
  
  Click on File, then Save.
• Under another name: Suppose we do not want to overwrite the contents on disk but would still like to save what is on the screen.

Click on **File**, then **Save as**.

This will bring up the **Save As dialogue**. You use this in exactly the same way as you would if you were saving a completely new file.

**Save in another file type**

Sometimes it is useful to convert the spreadsheet format into another format, for example, a text file that can be manipulated using a word processor. Alternatively, you may wish to save the spreadsheet in a format used by another spreadsheet program such as Microsoft Excel. To save a spreadsheet in a different format:

1. Click on **File**, then **Save as**
2. Click on the **File Type** window. This will display a list of file types
3. Use the vertical scroll bar to view all the file formats.

The following table lists some of the main file formats and a brief explanation of each.

<table>
<thead>
<tr>
<th>File type</th>
<th>Extension</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>OpenOffice.org Calc Spreadsheet</td>
<td>sxc</td>
<td>This is the format of Calc itself</td>
</tr>
<tr>
<td>OpenOffice.org Spreadsheet template</td>
<td>stc</td>
<td>A template is an outline for new templates. This may include text, values and formulas that are automatically inserted when a new template is created using template. It could also include formatting of cells such as font type and colour.</td>
</tr>
<tr>
<td>dBase</td>
<td>dbf</td>
<td>This would save the spreadsheet in a format used by some database programs. These</td>
</tr>
</tbody>
</table>
### File type | Extension | Explanation
--- | --- | ---
Microsoft Excel | xls, xlsx | Although Microsoft Excel is also a spreadsheet, it uses a different format. By saving the spreadsheet in the xls format, it could be opened directly by Microsoft Excel.

| File type | Extension | Explanation |
--- | --- | ---
Web Pages | html | In order to read files, web browsers need to have them saved in a special format known as HTML or Hypertext Markup Language. Calc is able to save a spreadsheet in this format.

| File type | Extension | Explanation |
--- | --- | ---
Text CSV | csv | This format is also called a comma delimited file. In this format, each row is converted into a paragraph. The columns of the spreadsheet are separated by commas. A word processor will read this file as an ordinary text file.

| File type | Extension | Explanation |
--- | --- | ---
Data Interchange format | dif | A DIF is an industry standard for exchanging data between different types of application.

| File type | Extension | Explanation |
--- | --- | ---
Portable Document Format | pdf | Pdf files are a common way of sending documents that you do not wish the receiver to be able to edit. These files can be read with Acrobat Reader. Unlike the previous formats that are created using the Save As ... function, pdf files are created using the **Export as pdf** ... option in the File menu.

### Save different Versions

On the file menu there is an option called **Version** that allows you to save different versions of the spreadsheet in the same file. You are asked to give the version a name and this is recorded along with the date and time of the changes that were made. If you want to open another version of a file, simply click on **File->Version** and choose the Version you want to open.

### Getting Help

OpenOffice has a help file for each application. The help files are searchable and can assist you with almost any OpenOffice Calc task.

1. To access the help file, click on the **Help** menu in the **Menu toolbar**, and then click on **OpenOffice.org Help**. Alternatively, press the **F1 key** on your keyboard.
2. Perhaps you are interested in getting help with inserting charts into your spreadsheet. When the Help window opens, you can browse through the Help contents by clicking on the Contents tab.

3. The Index tab lets you search for specific help topics by typing a search term.
4. The Find tab lets you search all of Help for specific words.

5. You can bookmark Help pages that you are likely to revisit using the Bookmarks tab.
Self Assessment

To assess your learning, make sure you are comfortable carrying out the following tasks in OpenOffice Calc:

1. Find and select OpenOffice.org Spreadsheet from the Applications menu.
2. Create a new spreadsheet.
3. Save your spreadsheet to disk as My First Spreadsheet.
4. Close the spreadsheet and exit OpenOffice Calc.
5. Again, start OpenOffice Calc and open your recently saved spreadsheet.
6. Save your spreadsheet again under a different document format.
7. Use OpenOffice Calc Help to search for help on a subject, and bookmark a help.
8. Close the document and exit the application.

Summary

This section introduced the OpenOffice Calc application and described the basics steps to using Calc, including opening and closing spreadsheets, saving your documents, and using Calc functions and help.
Working with spreadsheets

Section Overview

So far in this module you have been introduced to the features of the OpenOffice Calc spreadsheet application and have learned some of the basic operations, such as opening, closing, and saving documents.

In this section we are going further into the Calc workspace to learn how to use the toolbars and other components in Calc, and how to customise Calc for your use.

In this section, we will
• identify the core components of the Calc workspace
• learn about the Calc toolbars and their function
• perform some basic tasks with spreadsheet documents

Locating the components of the Calc window

When you open the Calc application, you will see running across the top of the Calc window a set of four toolbars each of which displays a series of icons or buttons that you can click on when you want to perform certain tasks. Beneath that you will see a worksheet window ready to receive your data, and another toolbar to provide a shortcut to perform common tasks.

The Calc window explained
Calc toolbars

The Menu Toolbar

The menu toolbar displays the names for categories of basic commands, many of which also are found in the other OpenOffice tools. For example, the File menu consists of a set of commands related to file operations such as opening an existing file, creating a new file, closing files, and so on.

The Function Toolbar

The second bar is the function toolbar. It contains icons to provide quick access to commands found in the drop down boxes on the main menu, e.g., New, Open, Print, Copy, Paste, etc.

The Formatting Toolbar

The third bar is the formatting toolbar. It contains icons and drop down menus for commands used to format cells, e.g., to select a font, font colour, alignment, number format, border option and background color.

The Formula Toolbar

The fourth bar is the formula toolbar. It contains the Name Box drop down menu. In this dialog box you will see the address of the cell or cell range that is currently selected (e.g., C1:D5, if the block of cells from cell C1 to cell D5 is selected). Also you will see a long box called the Input Line, which serves as the entry point for all data to be entered in the highlighted cell.

Tip: When you place your mouse cursor over an icon on a toolbar, the name of the function appears on your screen. Selecting the >> drop down menu on the far right of the function and formatting toolbars opens a menu of options for customising the toolbars.
The Calc Work Area

The work area consists of a grid formed by the intersection of rows and columns. Each grid is called a worksheet, and a spreadsheet can be made up of many such worksheets.

Columns, Rows and Cells

The main feature of a worksheet is that it is organised into columns and rows. Columns run vertically from top to bottom of the work area and are named by the letters of the alphabet seen at the top of each column. The rows run horizontally from left to right and are numbered. A cell is the point where a row and a column intersect or cross each other. For example, cell A7 is the cell lying at the intersection of Column A and Row 7. A7 is also referred to as the address of the cell.

Tabs

The tabs are located at the bottom left corner of the work area. By default, there are 3 of them, named Sheet 1, Sheet 2, Sheet 3. These tabs identify the worksheets that are contained in a single spreadsheet.

When you click on a tab, its worksheet is displayed. The work area that we have been looking at thus far is essentially the work area of a single worksheet when displayed on the Calc screen.

We will look more closely at spreadsheets and worksheets in a later section.
Adjusting the application settings

When you first open the Calc application, the workspace is organised so that the most used toolbars and features are available to you. As you become more proficient at using spreadsheets, you will find that you want to customise the Calc workspace to better meet your needs.

Magnification Tools

You can enlarge or decrease the screen display of the spreadsheet you have open by clicking on the **Zoom tool** on the **Function toolbar**. Choose the magnification that works best for your screen.

Modifying Options (show/hide toolbars)

OpenOffice Calc comes with a very large array of tools to format text and objects in your spreadsheet. When you install the application, the default toolset contains most of the tools that you will need to work on your documents, but you can also choose to show or hide toolbars or to modify toolbars if you need to.
To show or hide toolbars:

1. From the **View menu** click on **Toolbars**
2. Click in the boxes to either show or hide toolbars as needed.

To modify a toolbar:

1. From the **Tools menu**, click on **Customize**. The **Customize dialogue window** will open. You can use this to modify menus, keyboard functions, toolbars, or events.

2. Click on the **Toolbars tab**.
3. Choose the toolbar you want to modify from the dropdown list.
4. In the **Toolbar Content Commands** section, check the commands you want to include on the toolbar, and uncheck the commands you don’t want to show. If the command you want is not in the list, click on the **Add button** to choose from a list of other commands.
5. Click **OK** to save your changes.

**Self Assessment**

To assess your learning, make sure you are comfortable carrying out the following tasks in OpenOffice Calc:

1. Identify the following parts of the Calc window:
   1. The menu toolbar
   2. The function toolbar
   3. The formatting toolbar
   4. Rows and row headings
   5. Columns and column headings
   6. Worksheet tabs
2. Be able to adjust the application settings such as zoom, and to modify toolbars by adding commands.

**Summary**

This section covered the Calc workspace, and how the workspace can be modified by hiding or showing toolbars, modifying toolbars, and changing the view settings.
Adding content to Calc spreadsheets

Section Overview

In this section you will begin to work with OpenOffice Calc spreadsheets by putting data into cells and formatting the data so that it is presented in a way that makes your spreadsheet documents easy to read and understand.

Cells are the basic building block of spreadsheets – these are the areas that hold data, functions, and formulas. A row is a group of cells adjacent to each other running horizontally in the spreadsheet. A column is a group of cells running vertically.

It’s important that you learn to enter data into cells correctly. If one cell is incorrect, it can have consequences for your whole spreadsheet.

In this section we will:

- work with cells:
  - enter and edit numerical, text, and other data into cells
  - search, sort, and manipulate data
  - format data
- work with rows and columns:
  - insert, delete, and resize rows and columns
  - format rows and columns
- learn the basic techniques to work with worksheets:
  - rename worksheets
  - insert and delete worksheets
  - copy worksheets

Scenario

In this section, we will use a real-life example to begin creating our spreadsheet, based on rainfall data for Vancouver, Canada. This data is interesting because there is a clear trend in rainfall patterns in Vancouver, and we will see how spreadsheets can be used to display and emphasise this trend.

We will work with the following sample data sample collected at Vancouver International Airport:

<table>
<thead>
<tr>
<th>Precipitation for Vancouver International Airport</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Year</strong></td>
</tr>
<tr>
<td>---------</td>
</tr>
<tr>
<td>January</td>
</tr>
<tr>
<td>February</td>
</tr>
<tr>
<td>March</td>
</tr>
<tr>
<td>April</td>
</tr>
<tr>
<td>May</td>
</tr>
<tr>
<td>June</td>
</tr>
<tr>
<td>July</td>
</tr>
<tr>
<td>August</td>
</tr>
<tr>
<td>September</td>
</tr>
</tbody>
</table>
Do the following activities using the above file. Please remember to save the file under a name that you can retrieve the file again. Save the file after each activity.

**Working with cells**

Before we begin entering data into cells, we should take a little time to plan our worksheet by asking ourselves a few questions:

1. **What do we want the data to show us?**
   In this case, we want to determine the average rainfall in Vancouver for each month over a three year period. Therefore we should arrange our worksheet with a column for each month, and a row for each year.

<table>
<thead>
<tr>
<th></th>
<th>2005</th>
<th>2006</th>
<th>2007</th>
</tr>
</thead>
<tbody>
<tr>
<td>October</td>
<td>155.4</td>
<td>57.8</td>
<td>155.2</td>
</tr>
<tr>
<td>November</td>
<td>136.6</td>
<td>350.8</td>
<td>116.2</td>
</tr>
<tr>
<td>December</td>
<td>160.8</td>
<td>146.0</td>
<td>210.6</td>
</tr>
</tbody>
</table>

We enter the data this way because we want to be able to increase the length of our spreadsheet if we get more data, not the width.

In this case, there will always be 12 months in a year, so the width will stay constant, but the length will increase as we add more years.

2. **What formulas will we need?**
   The formula for finding the average.

3. **How will we display the results?**
   A column graph with one column for each month should work.

**Selecting cells and cell ranges**

In Calc you select cells with your mouse:

1. If you want to select a group of cells in a single row, click on the left-most cell, hold the left mouse button down, and drag your mouse to the right (alternatively, click on the right most cell, hold the left mouse button down and drag left).
2. If you want to select a group of cells in a column, click on the top most cell and drag down, or click on the bottom most cell and drag up.
3. If you want to select a group of cells spanning a number of columns and rows, click on one of the corner cells in the range...
you want, and drag left or right and up or down until the range you want is selected.
4. To select a whole row, click on the row heading (the number along the left side of the worksheet).
5. To select a whole column, click on the column heading (the letter at the top of the worksheet).
6. If you want to select the whole worksheet, click on the top left corner of the worksheet (to the left of column heading A and above row heading 1).

![Image of Excel worksheet]

**Entering data in cells**

We enter data into cells by clicking on a cell and typing in our data using the keyboard. Remember that it’s good practice to leave a few blank rows at the top of a worksheet for totals, headings, etc.

1. Enter the months of the year in Row 4 of your spreadsheet. These are our column headings.
2. To move vertically or horizontally in a spreadsheet, either use your mouse to click on the next cell, or use the arrow keys on your keyboard.
3. To enter a list of data, enter the data for the first cell and then type the `<Enter>` key to go to the cell directly below. Keep doing this for each column until the list is finished.
4. Enter the precipitation measurement for each month in the three rows beneath the column headings. Your spreadsheet should now look like this:

![Image of filled Excel worksheet]
Editing data

If you make a mistake entering data into cells, you can correct it easily by clicking on the cell and typing the new data. You can do this either in the cell itself or in the input line in the spreadsheet:

To edit data in the cell:

1. Double-click in a cell, and then highlight the data you want to replace.
2. Type in the new data.

To edit data using the input line:

1. Click inside the cell.
2. In the input line, highlight the data you want to replace.
3. Click on the Checkmark to accept the new data.

Using Undo/Redo

If you make a mistake when you are inputting data, applying formatting, or just about any other action in Calc, you can use the Undo button to go back one step.

The Redo button will take an action you have just finished and repeat it. This is handy if you need to repeat the same action on a number of cells.

Numerical data

Calc tries to interpret whether the data in our spreadsheet is numerical or text. By default, text data is aligned to the left of a cell, and numerical data is aligned to the right.

Numerical data can be formatted a number of ways, depending on the nature of the data. For example, our precipitation data is an integer with one digit after the decimal point.

To set the type of numerical data in a spreadsheet:

1. Select the cells you want to format.
2. Choose **Format->Cells** from the Calc menu.
3. Choose the category:
   - Number: for general numerical data
   - Percent: display numerical data as a percent
   - Currency: for currency data. Negative values are generally displayed in red type.
   - Date: To display data as a date, in a variety of formats.
   - Time: To display data as a time, in a variety of formats.
   - Scientific: for exponent data.
   - Fraction: to display numbers as fractions.
   - Boolean value: displays **True** or **False**.
   - Text
4. Choose the format. For numerical data, your choice is with or without a comma separating the hundreds, thousands, millions, etc.
5. Choose the number of places after the decimal point.

We can see from the data in our spreadsheet that if the digit after the decimal point was zero, it was automatically dropped. Change the data format for all of our cells to include 1 digit after the decimal point.

Your worksheet should now look like this:
Date format of data

You can format a cell that contains date data a number of different ways:

- **Long text:** December 31, 1999
- **Abbreviated text:** Dec. 31, 1999
- **Numerical format:** 31/12/1999
- **Abbreviated numerical format:** 31/12/99

Using Find and Replace

Find and replace in Calc functions much like in OpenOffice Writer.

Finding text or data:

1. Choose **Edit->Find & Replace** from the Calc menu.
2. In the **Search for** box type the text or data you want to search for.
3. Click on the **Find** button to find the first instance of your search term.
4. Clicking again on the **Find** button will search through the document to find further instances of your search term.
Replacing text or data

1. Choose **Edit->Find & Replace** from the Calc menu.
2. In the **Search for** box type the text or data you want to search for.
3. In the **Replace with** box, type in the text or data you would like to replace the search term with.
4. You can either replace instances of the search term all at once, or one at a time.

Sorting data

As much as possible, it is helpful to sort the data you are working with in a way that makes sense. For example, you may want to sort rainfall data from largest to smallest amount. You may want to sort birth date data chronologically. Or you may want to sort name data alphabetically.

To sort data in a Calc worksheet:

1. Highlight the cells that you want to sort.
2. Choose **Data->Sort** from the Calc menu.
3. Select the sort criteria you want to use first, and then choose to sort either in ascending or descending order. If you like, set further sort criteria. These will be applied in order (e.g. first by name, in ascending order alphabetically, then by age, in ascending order).
4.
5. View the results.

Formatting cells

You’ve already learned how to format cells for the type of data they contain (numerical, date, or text). You can also apply many of the formatting options that are available in other applications such as Writer.

As in other applications, the objective of adding formatting is to enhance the visual appearance of your documents in order to make them more readable and better understood.

Formatting appearance

You can format the appearance of cell contents by applying font choices, borders and shading, and alignment.

Font appearance

1. Select the cells you want to format.
2. From the formatting toolbar, apply the font formatting options you want.
   For your precipitation spreadsheet, bold the column headings (months).

Borders and shading

Borders and shading can help make your worksheets more readable by providing emphasis to some of your worksheet cells. For example, row
and column headings can be shades to set them off from the rest of the
data. Cells that form a table can be enhanced by placing a border around
them.

To apply shading:

1. Select the cells you want to shade.
2. Choose **Format->Cells** from the Calc menu.
3. Click on the **Background tab**.
4. Choose a background colour for your cells.

To apply borders:

1. Select the cells you want to apply a border to.
2. Choose **Format->Cells** from the Calc menu.
3. Click on the **Borders tab**.
4. Choose the line arrangement for borders. The default settings are
   no border, outside border, outside border with horizontal inside
   border, or outside and inside borders. Further, you can set your
   own borders by using the user-defined option.
5. Choose the line style and colour.
6. Choose the border spacing.
7. If you like, include a shadow for your bordered section.
Here is what our precipitation worksheet looks like with bold, shading, and borders applied:

Merging cells

You may find that you want to create an area for information that is larger than a single cell. Calc gives you the option of merging cells to make a larger area. (Please do not confuse it with Mail Merge in Writer) The merged cell acts as one cell.

To merge adjacent cells:

1. Select the cells you want to merge.
2. Choose **Format->Merge Cells** from the Calc menu.
3. Place your content into the merged cell.
Text wrapping

If the content you want to place in a cell is too long for the cell, you can choose to wrap the text so that it will go on to a second line once it reaches the full width of the cell.

To wrap text in a cell:

1. Select all the cells that you want the text to break at the right border.
2. Choose Format->Cells from the Calc menu.
3. Click on the Alignment tab.
4. Check the box for Wrap text automatically.

It will look like this:
Copying and Moving cells

To copy cells:

1. Select the cells you want to copy.
2. Choose **Edit->Copy** from the Calc menu.
3. Click where you want the cells to be placed.
4. Choose **Edit->Paste** from the Calc menu.

To move cells:

1. Select the cells you want to copy.
2. Choose **Edit->Cut** from the Calc menu.
3. Click where you want the cells to be placed.
4. Choose **Edit->Paste** from the Calc menu.

Using Autofill

Autofill is useful if you are placing the same content in the cells of a column, or when you are placing incremental content (e.g. the months of the year) in the cells of a column.

To use Autofill with incremental content:

1. Type the first entry into a cell (for example, *January*)

2. Click somewhere else on the worksheet (click out of the cell). Then move your mouse to the bottom-right corner of the cell with the data in it, until your cursor turns to a crosshair.
3. Hold the mouse button down, and drag down the column to complete the Autofill.

To use Autofill with repeating content:

1. Type the first entry into a cell (for example, January)

2. Click somewhere else on the worksheet (click out of the cell). Then move your mouse to the bottom-right corner of the cell with the data in it, until your cursor turns to a crosshair.
3. While pressing the <Ctrl> key, hold the mouse button down, and drag down the column to complete the Autofill.

![Image of a spreadsheet]

**Working with rows and columns**

Earlier you learned how to select a whole row or column by clicking on the row headings and column headings. When you select rows or columns, any of the formatting options you apply are applied to the whole row or column. You can also set the row height and column width to fit your data, and insert or delete columns or rows as needed.

**Inserting and deleting rows and columns**

To insert a row or column:

1. For rows, click on the row heading where you want the new row to be created.
2. Choose **Insert->Row** from the Calc menu.
3. The new row is inserted above the row you selected.
4. For columns the process is the same, using the column heading.

**Exercise on the Scenario**

On the Vancouver Precipitation spreadsheet, insert a column on the left of the worksheet, and add the years 2005, 2006, and 2007. Align the values to the left, and bold them. Then, change the border and shading to include these values.
Delete a row or column

1. For rows, select the row or rows you want to delete.
2. Choose **Edit->Delete cells** from the Calc menu.
3. For columns the process is the same.

Formatting rows and columns

Row height

You can set the height of a row manually by dragging on the bottom of the row header, or by using the menu options. The menu options give much greater control over the row height:

1. Select the row or rows you want to format.
2. Choose **Format->Row->Height** from the menu.
3. Type in the height you want to set the rows. All of the rows you have selected will change to that height.

Column width

1. Select the column or columns you want to format.
2. Choose **Format->Column->Width** from the menu.
3. Type in the width you want to set the column. All of the columns you have selected will change to that width.

Working with worksheets

We now move from working with cells, rows, and columns to working with worksheets. You can think of a worksheet as the basic functional unit of your spreadsheet – it can contain the data from cells, the functions that are used to modify the data, and graphs and charts to interpret the data. The worksheet can stand on its own as a document.
Rename a worksheet

The default names of worksheets are Sheet1, Sheet2, and Sheet3. You can change the name of a worksheet as follows:

1. Select the worksheet you wish to rename by clicking on the tab for that worksheet.
2. Choose Format->Sheet->Rename from the Calc menu.
3. Enter the new name in the dialogue.
4. Click OK.

Switch between worksheets

To switch between the different worksheets, you simply click on the tab of the worksheet you wish displayed.

Insert a new worksheet

1. Click on the tab next to the location where you wish to insert the new worksheet.
2. Click Insert->Sheet. This displays the Insert worksheet dialogue.
3. Choose the position before or after the selected sheet.
4. Choose the number of worksheets you wish to insert. If you choose only one sheet, you have the option to enter the name of that sheet in the Name window.
5. Click OK
Duplicate a worksheet

You may duplicate a worksheet either within the same spreadsheet or between spreadsheets. The other spreadsheet may be one that is already open or a new one to be created. In all cases, you will use the **Copy** command to carry out this task.

1. Right-click on the worksheet you wish to duplicate.
2. Choose **Edit->Move/Copy Sheet** from the context menu.

The **Move/Copy Sheet** dialogue box appears.

3. If you want to copy the worksheet to a new location, check the **Copy** checkbox. If you want to move the worksheet without making a copy, leave it unchecked.
4. Select the document you want to move/copy the worksheet to. The current document is the default choice.
5. Select the position for the worksheet in the **Insert before** window.
6. Click **OK**.
7. Rename the duplicate worksheet if you wish.
Delete a worksheet

1. Right click on the tab of the worksheet you wish to delete.
2. Select **Delete** in the menu that appears. A dialogue will appear asking you to confirm that you wish to permanently delete the worksheet and its contents.
3. Click **Yes** to confirm that you wish to delete the worksheet or **Cancel** if you do not wish to.

Self Assessment

To assess your learning, make sure you are comfortable carrying out the following tasks in OpenOffice Calc:

1. Select a cell, a row, a column, or a group of cells.
2. Enter data in a cell.
3. Format the cell for the following:
   - Type of data (numerical, date, text)
   - Font style
   - Alignment
4. Format cell borders and shading.
5. Use **Find and Replace** to replace data in cells.
6. Sort a group of cells.
7. Merge a group of cells into one cell.
8. Use **Autofill** to input content.
10. Insert and delete rows and columns.
11. Insert, copy, move and delete a worksheet.
12. Rename a worksheet.

Summary

In this section you learned some basic skills for working in worksheets, including inputting and formatting data in cells and columns, creating, deleting, and copying worksheets.

We also discussed some of the choices that should be made before we input data. When we answer some basic questions about our data and plan our spreadsheet, it makes the process of creating our spreadsheet much easier.
Formulas and Functions

Section Overview

Formulas and functions are very useful features of spreadsheets. They allow you to perform analysis on the data in your spreadsheet. Furthermore, when the data changes, the formula updates the results accordingly.

A formula is a spreadsheet function entered in a cell, complete with its arguments. A function is a formula that is built into the Calc program.

Calc has many built-in functions, but also allows you to create and apply your own formulas. This section will guide you through applying and creating formulas for your spreadsheets.

In this section you will:

- develop good practice in formula creation
- create formulas using cell references
- use arithmetic operators
- understand standard error values in formula results
- use standard functions
- use logical functions

Arithmetic formulas

Arithmetic formulas are formulas that can be carried out on numerical data. They include the everyday mathematical formulas such as addition, subtraction, multiplication, and division, as well as formulas for finding the average, mean and standard deviation.

Creating formulas

In a Calc worksheet, formulas are input into cells the same as other data like numbers and text. The difference is that formulas begin with an equal sign (=).
To input a formula into a cell:

1. Select the cell you want to contain the formula.
2. Begin with an equal sign.
3. Type the rest of your formula. For example, =45+55 is a formula that can be used in Calc.

The formula appears in the cell input window, but the formula result appears in the cell itself.

**Arithmetic operators**

The following table lists the common in Calc. These are the symbols that should be used for creating formulas.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Name</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>+ (Plus)</td>
<td>Addition</td>
<td>=1+1</td>
</tr>
<tr>
<td>- (Minus)</td>
<td>Subtraction</td>
<td>=2-1</td>
</tr>
<tr>
<td>- (Minus)</td>
<td>Negation</td>
<td>-5</td>
</tr>
<tr>
<td>* (asterisk)</td>
<td>Multiplication</td>
<td>=2*2</td>
</tr>
<tr>
<td>/ (Slash)</td>
<td>Division</td>
<td>=10/5</td>
</tr>
<tr>
<td>% (Percent)</td>
<td>Percent</td>
<td>15%</td>
</tr>
<tr>
<td>^ (Caret)</td>
<td>Exponentiation</td>
<td>2^3</td>
</tr>
</tbody>
</table>

**Using cell references in formulas**

In the last example, we input a simple formula into a cell. The formula added the numbers 45 and 55 and displayed the results in the cell.

More often we are interested in performing operations on cell contents. For example, if the content of one cell was 45, and the content of another cell was 55, we would want a formula that added the contents of each cell. More importantly, we would want the result to update automatically if the contents of either cell changed.
We accomplish this by using cell references instead of real numbers in formulas. For example, if the contents of cell A1 was 45, and the contents of cell A2 was 55, we could write a formula in cell A3 that added A1 and A2:

\[ =A1+A2 \]

Now, if the contents of cell A1 or A2 change, the result in A3 changes automatically.

Relative cell references

The cell reference we used in the last example, \( =A1+A2 \), is called a relative cell reference. What that means is if we were to copy the cell contents to cell B3, the formula would change to \( =B1+B2 \). If we were to copy the formula to cell D5, the formula would change to \( =D3+D4 \). If we were to insert a new row before row 1, the formula would also change automatically to reflect the change in the cell contents.

This is exactly what we want to happen when we are applying the same formula to a series of columns or rows.
Absolute cell references

There are times when we don’t want the cell references in a formula to change when we copy the formula or when we insert cells into a worksheet. In this example, we are referencing a constant value that is in cell A1 in our formula, and we use this same value throughout:

We can keep the cell reference A1 in our formula if we use an absolute cell reference. This involves simply placing a $ in front of the row and column part of the reference: A1 becomes $A$1: 
Functions

Functions are formulas in Calc that are built into the application. Typically, functions are more complicated formulas and can save us the time of developing our own formula for things such as mean or standard deviation.

Click on the **Function Wizard** button for a list of Calc functions:

![Function Wizard](image)

The list of functions available in Calc is very impressive. They are broken into categories so that you can more easily find the function you need. Some of the common mathematical functions are:

- ABS – absolute value
- COS, SIN, TAN – trigonometric functions for cosine, sine, and tangent
- GCD – greatest common divisor
- LCM – least common multiple
- LOG – logarithm
- SUM – calculates the sum

Cell ranges

In a previous example, we used the formula \( =A1+A2 \) for a formula in cell A3. This is fine for adding a few numbers, but if we are adding a long column of numbers it is more useful to reference a cell range than individual cells. We reference a range of cells by specifying the starting cell and the ending cell, and separating them with a colon.

So our formula for the last example would become:

\[ =\text{SUM}(A1:A2) \]
Exercise on the Scenario

Use the AVERAGE function in the Vancouver Precipitation spreadsheet to calculate the average monthly precipitation for each month over the three year period.

Self Assessment

To assess your learning, make sure you are comfortable carrying out the following tasks in OpenOffice Calc:

- Insert a formula in a cell that performs an operation on the contents of two or more other cells.
- Copy the formula to adjacent cells to perform the same operation.
- Use cell references for creating a formula.
- Use cell ranges for creating formulas.
- Use absolute cell references and relative cell references appropriately.
- Insert a function into a cell that performs an operation on two or more other cells.

Summary

This section discussed the importance of formulas and functions in spreadsheets. You learned how to input formulas and functions to perform mathematical operations on the contents of worksheet cells. You also learned the difference between relative and absolute cell references and how each can be used effectively.
Charts and graphs

Section Overview

During this section you will learn how to display worksheet data using a chart. Calc automates the creation of charts from data, and like formulas, charts automatically update when data changes.

Using the right chart can display your data in a way that makes trends obvious, thereby enhancing the quality of your document.

In this section you will:

- become familiar with the common chart types: column charts, bar charts, line charts and pie charts from spreadsheet data
- create a chart to display information
- format charts for appearance
- add data labels to charts

Types of charts

You are likely familiar with the common types of charts: bar chart, pie chart, line graph, and scatter plot. Although you can use different charts to display the same data, certain types of charts lend themselves better to certain types of data:

<table>
<thead>
<tr>
<th>Chart Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column (Vertical Bars)</td>
<td>charts emphasise differences and values across multiple categories.</td>
</tr>
<tr>
<td>Bar (Horizontal)</td>
<td>charts are used to compare categories and values during a specified timeframe.</td>
</tr>
<tr>
<td>Line</td>
<td>charts are to display trends over a particular timeframe.</td>
</tr>
<tr>
<td>Pie</td>
<td>charts are useful for showing relationship (percentage) of parts to a whole</td>
</tr>
</tbody>
</table>

Creating charts from cell data

This exercise will guide you through creating a chart to display the data in our Vancouver Precipitation spreadsheet scenario.

1. Click on a cell below somewhere below the data in your worksheet. This is where the chart you create will be inserted.
2. Choose Insert->Chart from the Calc menu. This starts the Chart Wizard.
3. The first step in the Chart Wizard is to choose a chart type. For this chart we will choose the **Column chart**.

![Chart Wizard](image)

Then click the **Next** button to go to Step 2 of the Wizard.

4. The second step is to select the data range.

![Chart Wizard](image)

This is the data we want to display.

Click on the **Select Data Range** button to begin.

5. Select the data in from the row containing the average precipitation values. In the spreadsheet below, it is the data from cell B8 to cell M8.

![Spreadsheets](image)
6. Since the data series is part of a row, **Data series in rows** should be selected. Unselect the remaining choices, since the rows and columns are not acting as labels.

Click the **Next** button to go to Step 3 in the Wizard.

7. We will now capture the names of the months that go with our data. These form the data categories.

In the Wizard, click on the **Select Data Range** button for **Categories**.

8. Select the data in the row containing the names of the months. In the worksheet, this is the data from cell B4 to cell M4.

Click the **Next** button to go to Step 4 in the Wizard.
9. Uncheck the **Display legend checkbox**, as we will be using the names of the months on the chart.
10. Fill in the values for **Title**, **Subtitle**, and **X-axis**.

![Chart Wizard](image1)

11. Click the Finish button to end the wizard.

**Modifying a chart**

The chart, as created, is quite small. We can do a number of things to modify the chart to make it more readable.

**Move the chart to its own worksheet**

1. Click on the chart and choose Edit->Cut from the Calc menu.
2. Click on the tab for **Sheet2**.
3. Choose Edit->Paste from the Calc menu to paste the chart.
4. Rename **Sheet2** to **Rainfall Chart**.

![Rainfall Chart](image2)
Resize the chart

1. Move the chart close to the top-left corner of the worksheet.
2. Click on the resize handle on the bottom-right corner of the chart and drag with your mouse to resize the chart.

Change chart type

We can change the chart type easily without having to go through the Chart Wizard again:

1. Select the chart by double-clicking on it.
2. Right-click on the chart area.
3. Choose Chart Type from the context menu.
4. Select **Bar** for the new chart type, and click the **OK button**.

5. The chart will update to the new chart type.

---

**Self Assessment**

To assess your learning, make sure you are comfortable carrying out the following tasks in OpenOffice Calc:

1. Select an appropriate chart type to display your data.
2. Create a chart from worksheet data.
3. Edit the chart by adding labels, resizing, and moving it.
4. Change the chart type.
Summary

This section discussed the use of charts in OpenOffice Calc to display worksheet data. The proper chart can make our data clearer by providing a pictorial representation that more clearly shows trends in data than a table or text description. The chart you created in the exercise clearly shows a trend in Vancouver precipitation towards very heavy in the winter months and relatively light in the summer.

On the practical side, you learned how to insert and modify a chart in Calc.
Preparing spreadsheets for output

Section Overview

This section discusses the steps you will take in the final preparation and printing of your OpenOffice Calc documents.

In this section you will learn how to:
- Set margins and page orientation.
- Use headers and footers.
- Set the print area of your spreadsheet.
- Print your spreadsheet.

Setting up a worksheet for printing

Worksheet orientation

Worksheet orientation is a style that applies to the whole document. By default, when you create a new spreadsheet it is oriented in portrait mode.

You can edit the orientation of your document as follows:

1. Choose Format->Page from the Calc menu.
2. Click on the Page tab.
3. Select the size of paper you will be printing on. If you choose one of the standard formats from the Format list, the paper size will be set automatically. You can also create a custom paper size by inputting values for the paper height and width.
4. Choose Portrait or Landscape for your document's orientation.
5. Set the margins to the desired width.
Headers and Footers

Headers and footers allow you to create text that will appear at the top (header) or at the bottom (footer) of every page in your document, or on every even or odd page. As you add text to your document, the header and footer don't move – they are always at the top and bottom of every page.

Examples of common header and footer information include the document title, author, date, or page numbers.

Headers

To enable headers:

1. Choose **Format→Page** from the Calc menu.
2. Click on the **Header tab**.
3. Enable headers by checking the **Header on** box.
4. Choose whether you want the same header content on left and right pages, or different content on each side.
5. Set the margins and spacing attributes for your header.
6. Click on the **Edit button** to edit the information in the header.
   You can enter text in any of the three header areas, or you can use the buttons to insert fields such as the date, time, etc.
7. Click **OK** to close the dialogue.
8. You will now have a header on your spreadsheet. What you add
to the header will be displayed on every page of the document, or
every odd or even page if you so specified, when you send the
document to print.

**Footers**

Setting the footer is the same as setting the header.

To enable footers:

1. Choose **Format->Page** from the Calc menu.
2. Click on the **Footer tab**.
3. Enable headers by checking the **Header on** box.
4. Format the footer the same was as for headers.

**Printing worksheets**

The steps you have gone through prior to printing your document help to
ensure that your document is as polished and as correct as possible.

You are now almost ready to send your document to print. As a final step,
you should preview what your document will look like when it's printed
to make sure that pagination, margins, and formatting appear correctly.

To preview your document:

1. Choose **File->Page Preview** from the Calc menu.
2. Scroll through your document to view the pages as they will look
when printed.

**Setting the print area**

1. With your mouse, select the area of the worksheet you want
printed.
2. Choose **Format->Print Ranges->Add** to add your selection to
the print area.
Printing

To print your document:

1. Choose File->Print from the Calc menu.
2. Choose your printer and adjust the printer properties if necessary. Some printer properties are specific depending on the type of printer you are using. For example, you may need to set properties for your printer if you are printing in high quality colour.
3. Choose the pages you would like printed (by default the complete document is printed).
4. Choose the number of copies you want to print (by default one copy is printed).
5. Click on the OK button to print your document.

Self Assessment

To assess your learning, make sure you are comfortable carrying out the following tasks in OpenOffice Calc:

1. Set the print area of your worksheet.
2. Set the page options, including margins, paper size, and orientation.
3. Enable headers and footers and add content to each.
4. Preview the document before printing.
5. Print your document.

Summary

This section outlined the options for setting your document up for printing. We discussed document formatting techniques such as setting margins, orientation, footers and headers.

Finally, this section outlined the process for previewing and printing your document.
Module 5
Database Management using OpenOffice Base

Module Overview

Welcome to Module 5 - Database Management using OpenOffice Base. This module explores the building of a database using the OpenOffice 3.0 Base software application. The module is intended to be very hands-on and focus upon two primary areas: the **how** and **why** of designing and implementing a database, and to develop a basic understanding of relational database theory.

This balance of practice and theory is intended to bring greater design strength and data integrity to your database applications.

Upon completion of this module you will be able to:

- Describe a database and how it can be utilised
- Discuss the difference between a database and the other applications
- Understand how databases are organised and operated
- Create a simple database and view database content in various modes
- Create a table, define and modify fields and their properties; enter and edit data in a table
- Sort and filter a table or form: create, modify and run queries to retrieve specific information from a database
- Understand what a form is and create a form to enter, modify and delete records and data in records
- Build queries to retrieve and sort data
- Create routine reports
- Build and print reports for regular and ad hoc reporting of data

Terminology

**Database**  
A database is a collection of related information which is organised into a series of rows (called records) and columns (called fields) that are populated with data.

**Data**  
Data is a series of individual facts.

**Information**  
Information is the result of the organisation, processing, and interpretation of data.

**Database Management System (DBMS)**  
The computer program used to manage and query a database.
### Data Normalisation
A method used in designing the structure of your database. In its simplest form database normalisation is meant to increase the accuracy and consistency of the data stored in the database.

### Database Keys
A field in a database that is unique for each record in the database.

### Database Indexes
A database index is a data structure that improves the speed of operations on a database table.

### One-to-One Relationships
One-to-One table relationships exist when two tables are related by a single row. For every row in one table there can be either zero or one row in the other table.

### One-to-Many Relationships
One-to-Many table relationships exist when many records in one table relate back to a single row in another table (the parent). For every row in one table there can be either zero or many rows in the other table.

### Many-to-Many Relationships
Information is the result of the organisation, processing, and interpretation of data.

### Preknowledge
Before beginning this module, we recommend you:

- study modules 1, 2, and 3 before this one, because they provide the essential knowledge for you to work with databases, including saving files, formatting text and retrieving information from other files
- in specific, complete module 4 before this one, as it will provide you a deeper understanding of how to identify and organise elements of data. Knowledge of spreadsheets is required as during this module we discuss the similarities and differences of databases and spreadsheets
- think about an environment where databases are needed to manage learners, customers, friends, CDs, etc.
- gather some written or printed copies of forms and reports from within the above environments to use as reference when you think about building a database
Introduction to Databases

Section Overview

The focus of this section is on the difference between data and information and an understanding of a database and how it can be used to gather, store and report on data.

Upon completion of this section you will be able to:

- understand what a database is and how a database is organised (tables, records and fields)
- describe the difference between data and information
- understand the roles in the design, development, and maintenance of databases
- explain how databases are used within different domains
- compare and contrast the database from other OpenOffice applications

Data and Information

You have used the following table in Module 4.

**What is Data?**
This is an example of data collected at Vancouver International Airport.

**Data** is a collection of facts.

<table>
<thead>
<tr>
<th>Year</th>
<th>2005</th>
<th>2006</th>
<th>2007</th>
</tr>
</thead>
<tbody>
<tr>
<td>January</td>
<td>249.6</td>
<td>283.6</td>
<td>181.4</td>
</tr>
<tr>
<td>February</td>
<td>45.8</td>
<td>57.0</td>
<td>116.0</td>
</tr>
<tr>
<td>March</td>
<td>132.8</td>
<td>92.4</td>
<td>214.8</td>
</tr>
<tr>
<td>April</td>
<td>90.2</td>
<td>70.0</td>
<td>76.2</td>
</tr>
<tr>
<td>May</td>
<td>68.6</td>
<td>42.8</td>
<td>37.0</td>
</tr>
<tr>
<td>June</td>
<td>49.6</td>
<td>54.4</td>
<td>80.0</td>
</tr>
<tr>
<td>July</td>
<td>43.6</td>
<td>25.2</td>
<td>53.0</td>
</tr>
<tr>
<td>August</td>
<td>28.6</td>
<td>4.8</td>
<td>8.4</td>
</tr>
<tr>
<td>September</td>
<td>33.6</td>
<td>39.4</td>
<td>73.6</td>
</tr>
<tr>
<td>October</td>
<td>155.4</td>
<td>57.8</td>
<td>155.2</td>
</tr>
<tr>
<td>November</td>
<td>136.6</td>
<td>350.8</td>
<td>116.2</td>
</tr>
<tr>
<td>December</td>
<td>160.8</td>
<td>146.0</td>
<td>210.6</td>
</tr>
</tbody>
</table>

In module 4 you have taken this data and calculated the average precipitation at Vancouver International Airport and produced a graph that illustrated which months get the highest and which months get the lowest rainfall.
When you did the calculations and draw the graph, you have changed the data to **Information**.

![Graph of Average Monthly Precipitation](image)

**What is Information?**

Information is the result of processing, manipulating and organising data in a way that adds to the knowledge of the person receiving it.

**What is a Database?**

If you are familiar with spreadsheets, you will understand databases very easy.

A database is an integrated collection of logically related data and consists of objects such as tables, queries, reports, and forms.
What is a Table?

A table in a database contains data to a single subject type.

A table consists of a series of rows (called records) and columns (called fields) that are populated with data. You use tables to store data about a specific category, such as customer or employee details (remember how you did it in a spreadsheet).

Databases use a series of tables to store the data.

A table simply refers to a two dimensional representation of data using columns and rows.

For example:

<table>
<thead>
<tr>
<th>Name</th>
<th>Last Name</th>
<th>Email</th>
</tr>
</thead>
<tbody>
<tr>
<td>Peter</td>
<td>Posthumus</td>
<td><a href="mailto:peterp@huh.com">peterp@huh.com</a></td>
</tr>
<tr>
<td>Paul</td>
<td>Murray</td>
<td><a href="mailto:paulm@concorde.com">paulm@concorde.com</a></td>
</tr>
<tr>
<td>Mary</td>
<td>Daniels</td>
<td><a href="mailto:mdaniels@caddy.com">mdaniels@caddy.com</a></td>
</tr>
<tr>
<td>John</td>
<td>Rosthom</td>
<td><a href="mailto:rosthom.j@maddog.com">rosthom.j@maddog.com</a></td>
</tr>
</tbody>
</table>

Each database table must have a unique name. Without a unique name the DBMS (DataBase Management System) would get very confused and not find the data in a table.

Each column in the table is also given a unique name. In the example above it would be something like first_name, last_name, email. This doesn't mean...
each column name has to be unique within the entire database (collection of tables). It only has to be unique within this table.

Also notice that the names don't use any spaces. **When naming tables and columns be sure to keep it simple with letters and numbers.** Spaces and symbols can be illegal characters, so if you need to clarify a name use the "_" instead of spaces.

**Table name:** contacts

<table>
<thead>
<tr>
<th>first_name</th>
<th>last_name</th>
<th>email</th>
</tr>
</thead>
<tbody>
<tr>
<td>Peter</td>
<td>Posthumus</td>
<td><a href="mailto:peterp@huh.com">peterp@huh.com</a></td>
</tr>
<tr>
<td>Paul</td>
<td>Murray</td>
<td><a href="mailto:paulm@concorde.com">paulm@concorde.com</a></td>
</tr>
<tr>
<td>Mary</td>
<td>Daniels</td>
<td><a href="mailto:mdaniels@caddy.com">mdaniels@caddy.com</a></td>
</tr>
<tr>
<td>John</td>
<td>Rosario</td>
<td><a href="mailto:rosario.j@maddog.com">rosario.j@maddog.com</a></td>
</tr>
</tbody>
</table>

### What is a record and what is a field?

Each table row that contains several data entries related to each other represents a record. That means a row consisting of a person’s name, address, telephone number and age can be seen as a record.

The table above consists of 4 records.

Each piece of information in a record is called a field. You can identify a field by a field name, such as Name or Address. Each field contains the same attributes.

In the example above, the table contains 3 fields viz.: `first_name`; `last_name` and `email`.

The content in each field can be of a certain **type**. The main types are:

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>You cannot perform calculations on numbers stored in a text field. Each number is regarded as a character, therefore if you want to store a telephone number then use a Text field - 0 at the beginning will be displayed). Normally the size is 255 characters.</td>
</tr>
<tr>
<td>Memo</td>
<td>If you want to type long text, use the memo field. It is normally used for storing comments and general notes. Memo fields can hold up to around 64,000 characters.</td>
</tr>
<tr>
<td>Number</td>
<td>Entering numeric values only and with the view to calculate with other numeric fields, such as quantities or prices. Different number sizes can be chosen for varying ranges.</td>
</tr>
<tr>
<td>Date/Time</td>
<td>Enter valid dates and times only. The format can be modified. This type of data is numeric and therefore can be calculated too, e.g. to calculate a time period.</td>
</tr>
<tr>
<td>Currency</td>
<td>Enter currency or monetary values. The currency style format can be modified.</td>
</tr>
<tr>
<td>AutoNumber</td>
<td>Automatically generate the next number when a new record is added. This field is useful for creating a unique record ID. <strong>You cannot edit this type of field.</strong></td>
</tr>
<tr>
<td>Yes/No</td>
<td>Enter fields that can only use one of two values. For example, whether a product is discontinued is either true or false, so a Yes/No field would be a good choice. This is a logical value and is deemed numeric (True = -1 and False = 0).</td>
</tr>
</tbody>
</table>
This allows consistency in size (you can set the number of characters per field) and format (to keep consistency in date/time/currency/number). This makes it possible to search, sort and to link data.

You can also set the default value for a field, e.g. you can choose a default for a field as No, and then you can change it to Yes. It makes the input of data easier.

To summarise, the data is the raw information that is entered and makes up the records and fields in the database while the resulting information is the processed data.

At this point, you’re probably asking an obvious question – if a database is so much like a spreadsheet, why can’t I just use a spreadsheet?

Databases are actually much more powerful than spreadsheets in the way you’re able to manipulate and report on data. Here are just a few of the actions that you can perform on a database that would be difficult if not impossible to perform on a spreadsheet:

- Retrieve all records that match certain criteria
- Update records in bulk
- Cross-reference records in different tables
- Perform complex aggregate calculations

The purpose of organising data into a database is to answer queries and write reports, therefore turning the data into information.

**Key Point:**

**Data** is a series of individual facts – for example, the annual average global temperature readings for the past 60 years are data.

**Information** is the result of the organisation, processing, and interpretation of data – for example, the annual average global temperature has shown a rising trend over the last 60 years.

The computer program used to manage, query and report a database is known as a database management system (DBMS). A well constructed database should make it easy to manage information quickly and effectively, and to ensure the data stays accurate over a period of time.

It should be noted that database records have existed for ages in non-electronic forms, any form of recording data in ledgers, notebooks and other collections of data could also be considered databases.

There are two categories of databases:

- A flat file database contains all the data in a single table. All the information of for example learners in a school is contained in one table with multiple fields. This makes a database very big and slow to run queries and reports.
• A relational database stores data in multiple tables. In relational databases, you can store data in categories using multiple tables. For example, you can keep all the basic information of learners in one table, the information on their subjects in another, and parent data in another. You can create a link between these three tables by using a common field, such as Learner ID, contained in all the three tables. You can use the database to create a mailing list of all the learners who are in a specific class. You can then send circulars for a specific grade to them. The database assembles the appropriate data from the tables to give you the information as a single report.

Database Development/Use Roles

Professional databases are designed and created by database specialists. Common roles in the design, development, and maintenance of databases are:

Database Designer/Database Analyst

Traditionally, databases were designed by a database designer or database analyst. More and more, these roles have been taken or by the database administrator, who has a great understanding of the database management system (DBMS) in use by the organisation.

Database Developer

These are the programmers who actually build the database based on recommendations of database designers, analysts, and administrators.

Database Administrator

In addition to database design, the database administrator is responsible for:

• installing new versions of the database software on users’ computers
• monitor and administer database security
• analyse the data and recommend changes to data organisation
• data modeling and optimisation
• disaster recovery in the event of a system crash or major errors in the DBMS

User

Database users carry out the data entry, data maintenance, and information retrieval from the database.
Domains and Uses of Large-Scale Databases

Databases are used in many different domains, a few worth considering would be:

1. **Personal Banking** - whenever you use a counter, bank machine or ATM all the data regarding your transaction is saved to a database. This makes it more efficient for creating bank statements, reports and for auditing bank accounts.

2. **Health Care** - it is normal that all the data from your visits to the doctor or clinic are recorded in a database. This makes it easier for doctors and health care workers to see your health history and make better decisions regarding treatment and advice. Governments are looking into a national health care system that contains data of all patients. It would be much easier and accurate to track the medical record of a patient.

3. **Education** – All education systems make use of integrated data from an Educational Management Information System (for planning and management purposes for example where to build new schools), Integrated Examination System (for examination results and promotion of learners), Learner Tracking System (to track learner performance and progression through the system) and Personnel and Human Resource Systems (to track teachers, their qualifications, their years of service, and their payroll).

4. **Airline Booking System** (Computer Reservations System) - A computerised database system is used to store and retrieve information and conduct transactions related to air travel. Most airlines, travel agents, hotels and car hire companies make use of this system and allow users to book air tickets, hotel rooms and rental cars through one database system that is also linked to major financial institutions for payments of the transactions.

5. **Government Records** – most governments are moving towards e-Government systems to provide and improve government services, transactions and interactions with citizens, businesses, and other arms of government through integrated database systems.

6. **WikiEducator** - behind this educational wiki is a database. All the data about user accounts, wiki pages and their change history, etc. is all stored in a database. This allows for considerable flexibility when it comes to organising and reporting on the activity within a wiki.

When we look at the above systems, it is important that the data contained in the databases must be relevant, accurate, updated and useful. In database we are using two terms, viz.:

- **data integrity** we mean the accuracy and reduced duplication required to keep data healthy; and
- **longevity of usefulness** we mean the database design has considered many of the future data needs.

**Reflection**

Identify another domain where a database could be used. Ask yourself if having a database available could improve the data management for the
domain. Also ask yourself what other important factors would determine if using a database would be appropriate for the identified subject domain.

**Databases vs Other Applications**

To better understand what the OpenOffice database is (and databases in general) it is good to understand the difference to other applications. In the following table we compare and contrast a database with the other applications:

<table>
<thead>
<tr>
<th>Application</th>
<th>Compare and Contrast</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database vs SpreadSheet</td>
<td>A spreadsheet provides the ability to store and organise numeric data and allow calculations to be performed upon the data. Like a database a spreadsheet stores data in columns and rows. How these two differ is the data in the spreadsheet is in one or two related sheets of columns and rows. With a database these columns and rows can be related to many other sheets or tables (in database terminology). And the way you join the sheets or tables together allows for a rich query and reporting environment for creating information. A spreadsheet is focused on organising and graphically representing numeric data. A database is focused on organising both textual and numeric data and providing abilities to query and report upon this data.</td>
</tr>
<tr>
<td>Database vs Word Processor</td>
<td>A word processor provides the ability to store text and graphics used to document, communicate and correspond with individuals, teams and groups. A word processor is an excellent tool for writing and publishing data. In general, the data within a word processed document is unstructured. As unstructured we mean that the data is more free flow and sometimes accompanied with graphics and pictures. Unstructured data is not categorised at the field of 'word' level. A database contains structured data, for most, every word in the database is categorised by an attribute or field name.</td>
</tr>
<tr>
<td>Database vs Presentation</td>
<td>Presentation software provides the ability to present information and graphics. Presentation software is an excellent tool for giving presentations, facilitating discussions and organising the visual content for group activities. Sometimes the information found in a presentation has been derived from database queries and reports. A database is not meant as a presentation tool, though it does contain data that can be presented. A presentation tool is not meant to store, organise and report on data, it is meant to present already existing information.</td>
</tr>
</tbody>
</table>
Database Design

Introduction to Relational Databases and Database Normalisation

As explained on page 8, a relational database stores data in multiple tables. When you have a number of related tables, it can complicate your database structure if you are not cognisance of the design.

Database normalisation is a method used in designing the structure of your database. In its simplest form database normalisation is meant to increase the **accuracy** and **consistency** of the data stored in the database (by eliminating duplication).

Normalisation is the process of efficiently organising data in a database to ensure accuracy and consistency of data.

To normalise a database you have to:

- eliminate redundant data (for example, storing the same data in more than one table); and
- ensure that data dependencies make sense (only storing related data in a table).

A simple example of normalisation is to think about a family living in one home (at one address), see the table below of how this data may be organised. As you can see the table contains duplicate address data. If the family moves you would need to change the same address data in more than one record.

Consider the following scenario:

<table>
<thead>
<tr>
<th>first name</th>
<th>last name</th>
<th>birth date</th>
<th>street address</th>
<th>city</th>
<th>province</th>
<th>country</th>
<th>postal code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Peter</td>
<td>Rawsthorne</td>
<td>28/12/1963</td>
<td>1234 Millar Rd.</td>
<td>Vancouver</td>
<td>BC</td>
<td>Canada</td>
<td>V0N1B0</td>
</tr>
<tr>
<td>David</td>
<td>Rawsthorne</td>
<td>26/10/1961</td>
<td>1234 Millar Rd.</td>
<td>Vancouver</td>
<td>BC</td>
<td>Canada</td>
<td>V0N1B0</td>
</tr>
<tr>
<td>Lisa</td>
<td>Rawsthorne</td>
<td>11/03/1965</td>
<td>1234 Millar Rd.</td>
<td>Vancouver</td>
<td>BC</td>
<td>Canada</td>
<td>V0N1B0</td>
</tr>
<tr>
<td>Malcolm</td>
<td>Rawsthorne</td>
<td>03/05/1987</td>
<td>1234 Millar Rd.</td>
<td>Vancouver</td>
<td>BC</td>
<td>Canada</td>
<td>V0N1B0</td>
</tr>
<tr>
<td>Hannah</td>
<td>Pringle</td>
<td>23/09/1989</td>
<td>1234 Millar Rd.</td>
<td>Vancouver</td>
<td>BC</td>
<td>Canada</td>
<td>V0N1B0</td>
</tr>
</tbody>
</table>

Consider the above **Families** table as **not normalised**. It contains duplicate data, and if the family moved the address of the five records would have to be updated. And if one record was updated incorrectly, the data would be inaccurate and inconsistent. Now consider the two tables below:

<table>
<thead>
<tr>
<th>first name</th>
<th>last name</th>
<th>birth date</th>
<th>address_id</th>
</tr>
</thead>
<tbody>
<tr>
<td>Peter</td>
<td>Rawsthorne</td>
<td>28/12/1963</td>
<td>0062</td>
</tr>
<tr>
<td>David</td>
<td>Rawsthorne</td>
<td>26/10/1961</td>
<td>0062</td>
</tr>
<tr>
<td>Lisa</td>
<td>Rawsthorne</td>
<td>11/03/1965</td>
<td>0062</td>
</tr>
<tr>
<td>Malcolm</td>
<td>Rawsthorne</td>
<td>03/05/1987</td>
<td>0062</td>
</tr>
<tr>
<td>Hannah</td>
<td>Pringle</td>
<td>23/09/1989</td>
<td>0062</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>address_id</th>
<th>street address</th>
<th>city</th>
<th>province</th>
<th>country</th>
<th>postal code</th>
</tr>
</thead>
<tbody>
<tr>
<td>0062</td>
<td>1234 Millar Rd.</td>
<td>Vancouver</td>
<td>BC</td>
<td>CANADA</td>
<td>V0N1B0</td>
</tr>
</tbody>
</table>
When you normalise a database design you increase the **accuracy** and **consistency** of the data because you do not have to retype/replicate data.

As you can see in the above two tables the address was moved out of the Families table and created in a new table called **Address**. These two tables (People and Address) are linked via the address_id. If you change the address at address_id = 0062, the address would be changed for all the family members.

The Families and Address tables in this example would be joined via the address_id and you can build a query upon this joint.

This is the fundamental concept of normalisation.

A series of guidelines for ensuring that databases are normalised, were developed. These are referred to as **normal forms** and are numbered from one (the lowest form of normalisation, referred to as first normal form or 1NF) through five (fifth normal form or 5NF).

In practical applications, you'll often see 1NF, 2NF, and 3NF along with the occasional 4NF. Fifth normal form is very rarely seen.

Before we go deeper into **Normal Form**, you have to understand what is meant by a **Database Key** and an **Index**.

### Types of Database Keys

There are many types of database keys. The two most important are the **Primary Key** and the **Foreign Key**.

**Primary Key**

A primary key is used to **identify** the records in the table and must be **unique** for each record. It is a field or combination of fields that uniquely identify a record in a table, so that an individual record can be located without confusion.

You can choose whether you want to make a specific field the primary key or whether you want a separate id field created. You can also choose whether you want to auto-generate the number or type it in manually for each record. A table can have only ONE primary key.

**Foreign Key**

A foreign key (sometimes called a referencing key) is a key used to link two tables together. You take the primary key field from one table and insert it into the other table where it becomes a foreign key (it remains a primary key in the original table).
For interesting sake, other types are:

**Candidate Key**

Any **unique identifier** or **compound key** that guarantees the uniqueness of a record can be considered a candidate key.

In some circumstances a table may have more than one unique identifier; each of these identifiers is considered a candidate key.

**Compound Key**

A compound key is a unique identifier formed by concatenating (linking) two or more fields into a key that guarantees uniqueness.

**Alternate Key**

An alternate key (or secondary key) is any candidate key which is not selected to be the primary key.

**Database Indexes**

**What are Database Indexes?**

Think about a drawer with different files in it. We normally would use index tabs so that we can find the folder that contains the record we are looking for.

An index in a database allows quick access to table data when the fields in the query have an index. The index reduces the amount of work the database has to do to find a record in the database.

Without an index the database would have to look at EVERY record until it found the one it was looking for. When an index is applied to a field the database can use the index to significantly reduce the amount of work to find the specified record.
Primary key values in a database will have indexes automatically applied when the table is first created and most key value columns should be considered candidates for indexes (particularly a foreign key).

**Applying Indexes**

When you design a table you can define the indexes on one or more columns. These indexes will be utilised when you build database queries and reports. They will decrease the amount of time it takes for the specific data to be retrieved from the database.

---

**Note:**
Indexes speed up searching and sorting – you should only index the fields you frequently use to search or sort.

Do not index too many fields in a table. The more fields you index, the slower your searches will be.

Any field can be indexed, except *memo*, *OLE* and *hyperlinks* fields.

Primary key fields are indexed automatically.

You can choose if your indexed field must prevent duplication of data.

---

Designing indexes takes a little thought and can be done by asking yourself a few simple questions:

1. **What columns will I use when I am searching/sorting?** (for example a last_name column is often used in identifying a record, it would therefore be a good candidate for an index).

2. **Is there a variety of values in the column I am considering for an index?** (for example if your table has a column named country and 90% of the records were from the same country, an index on the country column wouldn’t help performance because most of the time it would still have to scan through almost all the records)

**What do we mean by a Scan?**

The term scan refers to a table scan and this occurs when a database search looks at every record in a table to find the record it is looking for. It is like having to read every page of a book to find an item/phrase/subject you are looking for. In most situations you would look in the book’s index to find a reference to the subject and use the page number to find the information you seek.
Try the following:

Using the People and PhoneNumbers tables:

<table>
<thead>
<tr>
<th>person_id</th>
<th>first_name</th>
<th>last_name</th>
<th>birth_date</th>
<th>gender</th>
</tr>
</thead>
<tbody>
<tr>
<td>001</td>
<td>Bill</td>
<td>Smith</td>
<td>28/12/1963</td>
<td>M</td>
</tr>
<tr>
<td>005</td>
<td>Fiona</td>
<td>Jones</td>
<td>26/10/1961</td>
<td>F</td>
</tr>
<tr>
<td>012</td>
<td>Lisa</td>
<td>Ballard</td>
<td>11/03/1965</td>
<td>F</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>phone_type</th>
<th>phone_number</th>
<th>person_id</th>
</tr>
</thead>
<tbody>
<tr>
<td>home</td>
<td>(604) 555-1234</td>
<td>001</td>
</tr>
<tr>
<td>fax</td>
<td>(604) 555-2345</td>
<td>001</td>
</tr>
<tr>
<td>cell</td>
<td>(778) 555-2333</td>
<td>001</td>
</tr>
<tr>
<td>home</td>
<td>(604) 555-4455</td>
<td>005</td>
</tr>
<tr>
<td>Fax</td>
<td>(604) 555-9988</td>
<td>005</td>
</tr>
<tr>
<td>home</td>
<td>(604) 555-6543</td>
<td>012</td>
</tr>
</tbody>
</table>

1. Can you identify columns that would be good candidates for indexes?
2. Would it make sense for any indexes to be applied to two or more columns?

Check your answers:

1. There are **five columns** that would be candidates for indexes;
   - The **person_id** field in the People table is a primary key and by default is indexed.
   - The **person_id** field in the PhoneNumbers table is a foreign key and by default is indexed.
   - The **last_name** field is a good candidate for an index for it is common to search a database table on **last_name**. However in the case where a lot of duplicate last names occur, it would not be a good choice.
   - The **birth_date** field would also be a good candidate for often searches are date based.
   - The **phone_type** field is also a good candidate for an index.
2. Yes, because indexes are the easiest way to improve the performance of long running queries with full table scans. Indexes allow the database to search the smaller indexes as opposed to searching the large table. However, we must remember that too many column indexes can slow the operation of the database down.

**Test Your Knowledge**

**Database indexes**

1. A **gender** field is a good candidate for an index?
   - **TRUE**
   - **FALSE**
2. The **person_id** column in the above example will/should be an index because?
   - **A.** it ends in "_id"
   - **B.** it is a primary key for the people table
Normal Forms

If you understand what a primary key and an index are, you can look at different levels of normalisation:

First Normal Form (1NF)

The first normal form (1NF) adheres to the very basic rules for an organised database:
- eliminates duplication of columns in the same table
- creates separate tables for each group of related data and identifies each row with a unique column or set of columns (the primary key).

Second Normal Form (2NF)

Second normal form (2NF) meets all the requirements of the 1NF and addresses the concept of removing duplicative data and separate tables of related data. It further:
- removes subsets of data that apply to multiple rows of a table and places them in separate tables
- creates relationships between these new tables and their predecessors through the use of foreign keys

Third Normal Form (3NF)

Third normal form (3NF) takes 2NF further, thus meet all the requirements of the second normal form by removing columns that are not dependent upon the primary key.

There are two basic requirements for a database to be in third normal form:
- already meets the requirements of both 1NF and 2NF
- removes columns that are not fully dependent upon the primary key.

To know in which Normalised Form a database is, answer the following questions:
- Are there any duplicative columns? No
- Do we have a primary key? Yes
  - We satisfy the requirements of 1NF
- Are there any subsets of data that apply to multiple rows? No
  - We satisfy the requirements of 2NF
- Are all of the columns fully dependent upon the primary key? Yes
  - We satisfy the requirements of 3NF

Answers
1. FALSE, Gender fields usually are split 50/50, so an index wouldn't avoid a table scan on half the data.
2. E

C. it is a foreign key for the PhoneNumber table
D. it is the first column in the people table
E. both b and c
Try out an Example

In which normal form is this database?

**Classrooms**

<table>
<thead>
<tr>
<th>classroom_id</th>
<th>class_name</th>
<th>teacher_id</th>
<th>teacher_name</th>
<th>hire_date</th>
</tr>
</thead>
<tbody>
<tr>
<td>100A</td>
<td>physics</td>
<td>2002-0911</td>
<td>Jenny Jones</td>
<td>28/12/1963</td>
</tr>
<tr>
<td>100B</td>
<td>languages</td>
<td>1998-3412</td>
<td>Martin Clark</td>
<td>26/10/1961</td>
</tr>
<tr>
<td>100D</td>
<td>arts</td>
<td>2003-6788</td>
<td>Bob Williams</td>
<td>11/03/1965</td>
</tr>
</tbody>
</table>

Consider the "Classrooms" table whose attributes are `classroom_id`, `class_name`, `teacher_id`, `teacher_name`, and `hire_date`; and suppose that each teacher can teach in one or more classrooms.

- Are there any duplicative columns? No
- Do we have a primary key? Yes, the unique one is `teacher_id` (remember, a teacher can teach in more than one classroom, so `classroom_id` would not be unique)
  - We satisfy the requirements of 1NF
- Are there any subsets of data that apply to multiple rows? No
  - We satisfy the requirements of 2NF
- Are all of the columns fully dependent upon the primary key? No, `{classroom_id}` is not dependant on the `{teacher_id}`. Although all the others are.

This means the table is not in 3NF but in 2NF.

**Test Your Knowledge**

**Database keys and third normal form**

1. A primary key is used to uniquely identify a record?
   - TRUE
   - FALSE
2. A compound key uses two or more fields to uniquely identify a record?
   - TRUE
   - FALSE
3. From the above example, to achieve third normal form you could?
   - Move the teacher_name and hire_date columns into another table
   - Move the teacher_id, teacher_name and hire_date columns into another table, while leaving a foreign key reference in the classroom table
   - Rename hire_date to class_start_date
   - Concatenate the teacher_name and hire_date fields
   - Move the teacher_id, teacher_name and hire_date columns into another table
Check your answers

1. TRUE
2. TRUE
3. Move the teacher_id, teacher_name and hire_date columns into another table, while leaving a foreign key reference in the classroom table
   (The last bullet is almost correct)

Tables and Relationships

Relating Tables

When you're working with data in a database, you rely on relationships between the tables to pull the data together in meaningful ways. A database system relies on matching values found in both tables to form relationships. When a match is found, the system pulls the data from both tables to create a virtual record.

The purpose of relating tables in a database is therefore to pull the correct data together in meaningful ways.

For example, you can have 2 tables, one of Authors and one of Books. If you want to see all the books written by a particular author, the system would take the specific Author’s primary key, match it with the foreign keys in the Books Table and identify all the books linked to the specific author, therefore match values between the Books and the Authors tables.

Those matching values/joins are the primary and foreign key values. (A primary key uniquely identifies each record in a table. A foreign key is, simply put, one table's primary key in another table).

It is important to understand the importance of maintaining the integrity of relations between tables, or else the data sets emerged out of your database will not be accurate.

Where do you Start when you want to Develop a Database?

Before starting to develop a database, first have a look at the diagram from page 4 again:
You feed data into a database by using forms:

From a database you can generate queries and reports:

A query is a question you ask the database on the data (and save the answer) and a report is a presentation of the information. A query is a tool that pulls data out of a database and a report is a tool that allows information from a database to be printed in a useful format.

There are several approaches to develop a database.

Most important is to **plan well**. Take some time and work out your database on paper. Work through certain steps and check each item when completed.

**You do not plan a database on a computer, you do it on paper. A database Management Application is a tool for database management and it is a tool in your hands, not the developer of your thinking.**
Steps in Developing a Database

You can start with the data, determining the fields and develop different tables. Then you think of the kind of form that you need to put the data in and the kind of reports that you want at the end.

- **Data**
  - Determine the fields you want to use
  - Define the data types
  - Test that it is working

- **Tables**
  - Organise the data fields identified in tables
  - Build the relationship between tables
  - Identify primary and foreign keys (joints)
  - Test that it is working

- **Forms**
  - Identify the data fields for each form
  - Organise the data fields and develop questions on each
  - Develop the format of the form
  - Test that it is working

- **Reports**
  - Develop the content of the report
  - What data is needed for the report?
  - Develop the format of the report
  - Test that it is working
Another approach is called **reversed engineering** where you start with the type of reports you have in mind. Think about the content of the report and come up with kind of data needed for the report.

You then build the tables, fields and define the data types. You then build the relationships between the tables. You have to test some sample data to validate these relationships between the tables.

A well designed database also needs to include **optimisation** techniques (the process of speeding up and increasing performance). There **indexing** comes in handy. The larger the data set, the slower your database will perform without some form of indexing.

If your database is working well, you design the forms to input your data.

**Summary**

Make sure that you can do the following:

- normalise a database to third normal form
- identify a key field; in particular, a primary key
- describe an index, its purpose, and how it is implemented
- discuss the purpose of relating tables in a database
- discuss the way you plan and design a database
Using the Database Application

Section Overview

In this section you will be introduced to how to work with databases and perform common tasks. In specific you will:

- access an existing database
- learn how to create and save a new database
- explore the application settings available within OpenOffice Base

Upon completion of this section you will be able to:

- open and close a database and work within the database application
- create a new database and save it
- use available help functions
- understand the difference between a table, query, form and report, open, close, delete each one of them and navigate between them
- sort records

Working with Databases

For the purpose of this module, you will make use of OpenOffice 3.0 Base.

You must be able to:

- start OpenOffice 3.0 Base and close it
- open an existing database
- create a new database
- connect to another data source with OpenOffice 3.0 Base

Starting OpenOffice Base

Open OpenOffice Base

From the Applications menu in the top left of the Ubuntu Desktop select Office then OpenOffice.org Database:
Selecting an Action

Once the OpenOffice database software has finished loading you will be prompted to select an action. You can either:

- **Select database** - which means:
  - create a new database
  - open an existing database file already created and saved
  - open an existing database in other formats
- **Save and proceed** - which means, register your database and save it or start working with it

You have to start with clicking on **Select database**.

Opening an Existing Database File

To open an existing database file:

1. Choose the **Open an existing database file** option (activate the radio button).
2. Expand the drop-down list and select the database from the list of available databases.
3. Hit **Open**.
Alternatively if OpenOffice base cannot find the selected database you will be prompted with the open dialog.

After selecting the open button on the dialog box the OpenOffice 3.0 Base software will open the requested database in the application main window.

Familiarise yourself with the **Database Window**.

Identify the following:

- **Title Bar**
- **Minimise Button**
- **Maximise Button**
- **Close Button**
- **Menu Bar**
- **Tool Bars**
- **Database Pane with 4 buttons:**
  - Tables Button
  - Queries Button
  - Forms Button
  - Reports Button
• Tasks Pane. Reflects the activities related to the button that was clicked on the Database pane.
• Workspace. The pane that is active in the workspace is activated by clicking on the buttons in the database pane.

Creating a New Database

If you know you want to start a new database select the option to **Save and proceed**. This will locally register your database and prompt you for the location to save this new database.

Connecting to an Existing Database (Non-OpenOffice Files)

You may also want to use OpenOffice 3.0 Base against another data source other than the OpenOffice databases. OpenOffice 3.0 Base provides access to a large selection of data sources including, but not limited to: Address Books, MySQL, MS-Access, dBase, ODBC, JDBC, Adabas, etc.
To open any of these data sources select one of the available data sources and follow the prompts to enter the required connection settings.

On choosing this option, the Wizard prompts you to 5 steps:

1. **Select a database** - OpenOffice 3.0 Base allows you to connect to many different data sources. Base natively supports some flat file database formats, such as the dBase format. You can also use OpenOffice 3.0 Base to connect to external relational databases, such as databases from MySQL or Oracle (existing databases in different formats).

You can now continue with steps 2 – 5. It is important to remember that this describes connecting to a non-OpenOffice database.

For the remainder of this module you will not use this option, but create and use an OpenOffice 3.0 database.

**Create a New Database**

Always remember to follow the steps on the left side of the screen.

1. **Select database** - To create a new database select the Create a new database option. Then press the Next >> button.
The Wizard will go to **Step 2. Save and proceed**

Choose the appropriate radio buttons to register the database (save it). You have to make decisions in the tick boxes.

It is advised that you only tick the **Open database for editing** first. It will prompt for a "New Database" name. Enter a unique new name in the Name field.

You also have to navigate to a folder location by selecting the "Browse for other folders" option.

Once finished you will have a new database that is saved in the folder of your choice.
The following screen will be displayed.

Familiarise yourself again with the Database pane and the related tasks for each button in the Tasks pane.

Save a Database

While you are working with your database, as with other documents, save regularly. To save a database, select the **Save** or **Save As** option from the **File** menu. As you know, to **Save** will save the current database using its existing name. The **Save As** will prompt you to save the database using a different name.

When you are developing a new database it is sometime useful to "Save As..." different version names. This allows you to save a version at a state of design you are happy with. Then you can continue development. If you
make a series of changes you are not happy with having multiple versions allows you revert back to the previous state you liked. You may want to consider a versioning number system similar to the following:

- Db-Namev0.1 - minor changes
- Db-Namev0.2 - minor changes
- Db-Namev1.0 - MAJOR RELEASE
- Db-Namev1.1 - minor changes
- etc..

Getting Help

OpenOffice 3.0 has a good help system. You can get help by selecting from the Help menu or pressing F1 on the keyboard.

Once the OpenOffice 3.0 help system appears you can navigate, read the index or search for the information you require.
Closing a Database

To close a database, go to the File menu and select Close.

Adjust the Application Settings in the Database Window

Changing the View

As you know, a database consists of tables, queries, forms and reports. You are familiar with the Database Window with the buttons in the Database pane that change the views (tasks and workspace).

You can also access the different views by selecting View⇒Database Objects⇒ and choosing the relevant view.

You are now going to explore each of the different views and how to change from one to another.

Working in Table View

In Tables view you work with your data in tables.

You have completed your database plan on paper:

- what tables you are going to use
- what fields will be in each table
- data types for each field
- primary keys and foreign keys for tables
- relationships
You can now create new tables from scratch or use a wizard to prompt you design decisions. You can also create a view that allows you to put "filters" on existing tables.

Working in Forms View

After your planning you will also know:

- the data fields for each form
- the data fields you are going to use, in which order and the question related to each field
- the format of the form

In *Forms* view (press the *Forms* button in the *Database* pane) you can create forms for data entry and viewing. You can also use a wizard to guide you through the process of creating a form.
Working in Queries View

In **Queries** view you can create queries that filter data, join together tables and specify which fields are to be displayed and specify the properties for sorting the data.

You can also use a wizard to guide you through the process of creating a query.

And later, if you feel comfortable using the Structured Query Language (SQL) you can create your queries by hand using only SQL syntax (not required for this certificate).

![Queries View](image)

Working in Reports View

After your planning you will also know:

- the content of your report/s
- what data is needed for the report
- the format of the report

In **Reports** view you will be guided by a wizard to create new views or you can select existing views to edit, delete or run.

![Reports View](image)
Test Your Knowledge

Open Office Base Views

1. Open Office has five views within to work?
   - TRUE
   - FALSE

2. A form is used for data entry?
   - TRUE
   - FALSE

3. In which view would you enter SQL Syntax?
   - The Table view
   - The Form view
   - The Query view
   - The Report view
   - None of the above

Answers

1. FALSE - Open Office Base has four views
2. TRUE
3. The Query view

Toolbars

Working with Toolbars

As you know, you get different toolbars. Toolbars are displayed on your screen as a series of related icons. You can easily select an action without using a drop down menu.

You can add, move and take away toolbars from your desktop.

To access, go to View → Toolbars on the menu bar. When a toolbar is selected it has a check mark to the left of the item.
When you have NO toolbars selected, the desktop will look as follow:

![Desktop view](image)

For ease of use, select the toolbars you want to use, move them and place them at a place where you feel comfortable with. You must be able to minimise them too.

Remember, you can work quite successfully within OpenOffice Base with no toolbars activated by using menu commands and view buttons. (Using toolbars is a matter of personal preference)

**Summary**

Upon completion of this section you should be able to:
- start OpenOffice Base and close it
- assess your ability to create and save a new database
- open an existing database
- save a database under a different name
- demonstrate how to use a version numbering technique
- close a database
- get help
- understand the purpose of each view and know how to change the views on your desktop
- change your desktop’s toolbars to your preference
Designing and Building Database Tables using OpenOffice 3.0

Section Overview

The focus of this section is to build a database containing a number of tables representing relationships. The section has four subsections that progress through:

- the creation of database tables
- identifying and adding keys and indexes
- building out the number of tables
- complete the definition of relationships.

We will also focus on entering data and use strategies to test the data integrity of your newly implemented database design.

Upon completion of this section you will be able to:

- perform common tasks on tables, queries, forms and reports
- design tables
- perform different tasks on records and in a table
- save your data

Basic Table Operations

Creating a New Table

The first step to a database is to create the tables that are needed. You can design a table from scratch or you can activate the Table Wizard which allows you to choose formats that have been pre-defined and are available to use.

Keep your database plan ready.
To create a new table, in the **Database Window**, click on the **Tables** button in the **Database** pane. In the **Tasks** pane, choose **Create Table in Design View**. The **Task** pane provides you with a description of the task at hand.

### Designing the Table in Design View

If you choose to **Create Table in Design View** you will get a list where you can fill in the field name and field type. Remember this is not the table, it is a list of the field names (column headings) and the data type in the field.

Here you enter the field names underneath each other. The green arrow to the left of a row shows the active row. You can specify a Field Type in the next column which can be either a Text field or a Date, Time, Number, various types of Integers etc. (see page 6-7) If you do not specify a Field type it will default to Text.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Field Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>Integer</td>
</tr>
<tr>
<td>Name</td>
<td>Text</td>
</tr>
<tr>
<td>Last_Name</td>
<td>Text</td>
</tr>
<tr>
<td>Telephone</td>
<td>Text</td>
</tr>
<tr>
<td>Age</td>
<td>Numeric</td>
</tr>
<tr>
<td>Class</td>
<td>Text</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>ID</th>
<th>Name</th>
<th>Last_Name</th>
<th>Telephone</th>
<th>Age</th>
<th>Class</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>John</td>
<td>Peterson</td>
<td>604 766 7965</td>
<td>14</td>
<td>3A</td>
</tr>
<tr>
<td>2</td>
<td>Marion</td>
<td>Fote</td>
<td>604 216 8745</td>
<td>15</td>
<td>3C</td>
</tr>
<tr>
<td>3</td>
<td>Rieke</td>
<td>Venier</td>
<td>604 877 2112</td>
<td>14</td>
<td>3A</td>
</tr>
<tr>
<td>4</td>
<td>Paul</td>
<td>Verster</td>
<td>604 879 5585</td>
<td>14</td>
<td>3B</td>
</tr>
<tr>
<td>5</td>
<td>Patric</td>
<td>Moore</td>
<td>604 786 9636</td>
<td>15</td>
<td>3B</td>
</tr>
<tr>
<td>6</td>
<td>Susanne</td>
<td>Lisco</td>
<td>604 441 7896</td>
<td>14</td>
<td>3C</td>
</tr>
</tbody>
</table>

**Table**
The screen to put in the field name and the field type will look as follow:

1. Type in the fields as the example on the previous page.
2. To exit this view and go back to the Database Window press the Close button or press File→Close.
3. Confirm your changes by pressing Yes.
4. This takes you back to the Database Window.
5. If your table has not been named properly, you can change the name of the table by right-click on the table and rename it to Personal_Info.
6. Open the table by double clicking on the relevant table in the Tables pane.
7. You can now enter the data of the 6 records in the fields created.
8. Close the view and go back to the Database Window. Remember to confirm your changes.
9. Close the database by first saving it.
Designing a Table by using the Wizard

You are now going to design a new table, using the Wizard. By this time you are familiar with the working of a Wizard. You can follow the instructions:

1. **Select fields**
   - Choose the category
   - Choose the sample table
   - Select the fields require from the available fields

When you finish, press the Next> button.

2. **Set the types and format**
   Create a personal table called **ExerciseLog_Gr3** with the following fields (in the same order):
   - **Activity** - Text - Entry Required - 10 characters
   - **Exercise Type** - Number - Entry Required - 2 characters
   - **TimeExercised** - Number - Entry Required - 5 characters
   - **MaximumPulse** - Number - Entry Required - 3 characters
   - **RestingPulse** - Number - Entry Required - 3 characters

Choose the appropriate Field information as above.

3. Set the primary key automatically using an auto value.
4. Create the table and name it **ExerciseLog_Gr3**
5. Create the following records and save the table:

<table>
<thead>
<tr>
<th>ID</th>
<th>Activity</th>
<th>ExerciseType</th>
<th>TimeExercised</th>
<th>MaximumPulse</th>
<th>RestingPulse</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Walking</td>
<td>3</td>
<td>60.00</td>
<td>120</td>
<td>80</td>
</tr>
<tr>
<td>2</td>
<td>Running</td>
<td>3</td>
<td>60.00</td>
<td>157</td>
<td>117</td>
</tr>
<tr>
<td>3</td>
<td>Volleyball</td>
<td>2</td>
<td>90.00</td>
<td>145</td>
<td>30</td>
</tr>
<tr>
<td>4</td>
<td>Football</td>
<td>3</td>
<td>160.00</td>
<td>160</td>
<td>100</td>
</tr>
<tr>
<td>5</td>
<td>Absa</td>
<td>1</td>
<td>100.00</td>
<td>125</td>
<td>30</td>
</tr>
<tr>
<td>6</td>
<td>Swimming</td>
<td>2</td>
<td>60.00</td>
<td>160</td>
<td>120</td>
</tr>
<tr>
<td>7</td>
<td>Aerobic</td>
<td>3</td>
<td>120.00</td>
<td>170</td>
<td>140</td>
</tr>
</tbody>
</table>

Deleting a table

If your planning of your database was done well, it will not be necessary to delete a table.

However, it is possible to delete a table that you have created by:
1. Open the **Database Window**.
2. Activate the **Tables View**.
3. In the **Tables** workspace, mark the table you want to delete, right click and press **delete**.

![Image of Tables workspace with marked table for deletion]

4. Confirm the deletion.

![Image of confirmation dialog box]

You can also use the **Edit→Delete** option from the Menu bar.

**Test Your Knowledge**

**Creating a new table**

1. There is more than one way to create a table?
   - TRUE
   - FALSE

2. What is the default field type when creating a table?
   - Integer
   - Date
   - Text
   - Currency
   - Auto Number

**Answers**

1. TRUE, you can use either design view or a table wizard.

2. The default type is Text.
Defining Keys and Indexes

Creating Primary Keys

What is a Primary Key?

As we have learnt in the previous section, every table needs to have a primary key defined.

The primary key is a field (or fields) that uniquely identify a record. In other words no two records can contain the same number in the primary key field.

Creating a Primary Key

To set a field as a primary key, you have to access the list of fields again. Activate the Table View and right click on the table you want to set the primary key of in the Tables pane. Click on Edit.
You are now able to see the list of Field Names that you created.

Right click on the grey button to the left of the field name to activate the popup menu. Click on Primary Key to mark it. You will see a small yellow key appearing next to the field name.

Tip: Always include an AutoValue field.

It is recommended that an AutoValue field be added to every table regardless of whether it is a part of your table design. This AutoValue field will automatically contain unique values for the life of the table. These values may become very useful some point in the future when you want to alter your database design.

Indexes

What is an Index?

You have learnt that an index improves performance by providing an alternate path to access data and speeds up searches, sorting, queries etc. An index can be applied to any data type. Indexes are applied to fields that are commonly used in searching for data (like a last name) or where data needs to be grouped together for a report.

It is not good practice to apply indexing to all fields of the database, only the ones that you want to sort by.
Creating an Index

In the field list view, select **Tools ➔ Index Design**.

You will get another dialogue box:

Notice that there is an option to make this a unique index (tick the box). In other words if you do not want duplicate entries here you would tick the box on **Unique**.

Ask yourself the following two questions?

- Will this field be an index? – Do I want to sort this field?
- Will this field be a unique identifier? – No duplication can occur.
Let’s go back to the table you have created called \textit{Personal\_Info}.

Which one of the fields would be your primary key? – ID

Which of the fields would be indexed?

- ID
- Last\_Name (You would like to sort according to the children’s surname)
- Class (You would like to sort according to the children’s class)
- Age in this case is not a good field to index, because all the kids are either 14 or 15 years old

Now you can ask yourself which ones of the above three, identified as indexes, would be unique?

- ID – definitely
- Last\_Name - This would not work here as there are going to be instances where children have the same surname. However, if you were creating the index on a field like an account number you would then choose not to allow duplicates by activating the Unique option.
- Class – This would not work because it is not unique

\textit{Index Actions}

Take a good look at the dialogue box:

In the upper left of the Indexes dialog are five buttons.
The meanings of the buttons are as follow:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a New Index</td>
<td>This button creates a new index by prompting you for the field names you would like indexed. Give this some thought and think about the discussion of table scans covered previously.</td>
</tr>
<tr>
<td>Delete an Index</td>
<td>This button deletes the highlighted index.</td>
</tr>
<tr>
<td>Rename an Index</td>
<td>This button renames the highlighted index.</td>
</tr>
<tr>
<td>Save an Index</td>
<td>This button saves the new, renamed and changed indexes.</td>
</tr>
<tr>
<td>Reset an Index</td>
<td>This button resets the index.</td>
</tr>
</tbody>
</table>

Now it is a good time to apply the primary key and indexing in the table called **Personal_Info. Remember to open the field list.**

Your results will look like this:

![Database Table Screenshot](image)

Save your file.

**Note**

It is important to note that if you try to put a duplicate entry into the field you have indexed to be unique, you will get an error message and it will not accept the record.

![Error Message](image)
After adding new fields you can add indexes to certain fields by going back to the index design and adding it.

Once the Index design dialog is available the new index button should be pressed to create a new index.

**Test Your Knowledge**

Study the following table and answer the questions on the next page:

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Data Type</th>
<th>Required</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>address_id</td>
<td>Integer</td>
<td>Yes</td>
<td>An AutoValue field for uniqueness.</td>
</tr>
<tr>
<td>address_line1</td>
<td>Text</td>
<td>Yes</td>
<td>First line describing an address. Could be street name or suite number.</td>
</tr>
<tr>
<td>address_line2</td>
<td>Text</td>
<td>No</td>
<td>Second line describing an address.</td>
</tr>
<tr>
<td>city_name</td>
<td>Text</td>
<td>Yes</td>
<td>The name of the city</td>
</tr>
<tr>
<td>region</td>
<td>Text</td>
<td>Yes</td>
<td>The name of the region. Could be province, state, etc.</td>
</tr>
<tr>
<td>country</td>
<td>Text</td>
<td>Yes</td>
<td>The name of the country</td>
</tr>
<tr>
<td>postal_code</td>
<td>Text</td>
<td>Yes</td>
<td>The localised postal code or equivalent</td>
</tr>
</tbody>
</table>

**Questions**

1. Indexes can only be applied to text fields?
   - TRUE
   - FALSE

2. From the Addresses table design above which fields would you apply indexes?
   - address_id, country_name
   - city_name, country_name, postal_code
   - address_id, address_line1, postal_code
   - city_name, region, country_name, postal_code
   - address_id, region, country_name, postal_code

3. Indexes can be applied to enforce uniqueness?
   - TRUE
   - FALSE

**Answers**

1. FALSE, they can be applied to any data type.
2. city_name, region, country_name, postal_code
3. TRUE, they can be applied to enforce uniqueness by ticking the **Unique tick** box
Table Design and Layout

By now, you must be familiar with the layout of a table, what a record is and what a field is. It is important that you are also familiar with switching between the Field List and the Table.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Field Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>Integer</td>
</tr>
<tr>
<td>Name</td>
<td>Text</td>
</tr>
<tr>
<td>Last_Name</td>
<td>Text</td>
</tr>
<tr>
<td>Telephone</td>
<td>Text</td>
</tr>
<tr>
<td>Age</td>
<td>Numeric</td>
</tr>
<tr>
<td>Class</td>
<td>Text</td>
</tr>
</tbody>
</table>

1. Close the Field List
2. In table view, right click on the table
3. Choose edit

1. Close the Field List

Field Design and Modification

Exploring the Data Types

On page 6, you were introduced to the basic set of data types.

It is good to familiarise yourself with all the different data types available when adding fields to a table.
The following screen shot provides a list of all the data types.

Add all these fields in a new database table. Once you have added the different fields, click on each one and view the field’s properties. Feel free to play around and get a sense of the differences and similarities among the different data types.
Modifying Fields Properties

When you create the fields you will notice the field properties section at the bottom of the screen that allows you to change the field properties such as the size of the field, the number and date format, etc. To change these attributes you will need to click on the field at the top which will give you access to its properties displayed in the bottom section of the screen.

To change the field size, click on the field to select it. A green arrow will appear to indicate that it has been selected. Then click in the white box next to Length. Type in the number of characters you want the field to be restricted to.

If you want to change the number or date format click on the grey button next to Format example. This will bring up a dialog box which will allow you to choose a format for the number or date.

Note - Consequences of change

It is important to note that if you change the field size in a table and there is already data in the table you may lose some of that data. For example, if you change a field size from 50 characters long to 10 characters long and there is a record that already contains 20 characters in that particular field you will lose (or truncate) the data; so be very careful.
Modify Fields

Insert New Fields

You can at any time, insert a new field at the bottom of the Field List. You can either right click on the grey bar to the left of the fields and select **Insert Rows** or just start typing in a new field at the first open space at the bottom of the list.

Be aware, if you make this column mandatory to enter data, you will receive an error message, because the current table does not have data in these fields.

To overcome this problem, design the field first as non-mandatory for data entry. Go to the table, enter data in all the records and go again back to the Field List and change the field to mandatory.

Moving the Fields within a Table

Being able to re-order the fields or columns within a table is a useful feature. This feature is only available when you are first designing the table. Once the table has been saved the field order is also dependent on the data stored in the table. Changing the order of the fields would also mean the database would have to re-order the data.

The data re-organisation would have dependencies on the table’s rules, therefore making it a complicated process. This re-ordering should be done with careful consideration and with the assistance of a database administrator so no data is lost.

IT is therefore very important to do thorough planning of the database tables and the order of fields before you start entering data.

Widening the Columns (Fields)

Sometimes the columns containing the fields are not wide enough to display the data fully on the screen.

You can widen the columns by opening the table. Click on the table heading (Field name) you want to widen, right click and select **Column Width** from the pop-up menu and type the width in.

You can also move your mouse up between the field names in the grey area (as you would to widen columns in a spreadsheet), until you get the vertical line separator, **►**. Hold down the left mouse button and drag the column width to be wider or narrower.

If you would double click on the vertical line separator, the width will be adjusted to the length of the field.
Changing the Format of a Column

To change the field format (Column format), right click on the column header and choose Column Format. You can change the general format of the field (depending on the format you have chosen) as well as the alignment.

Updating the Data

You can add new records, update data in records and delete records from your table.

To add a new record, enter it at the bottom of the table. The New Record row to enter it is indicated by and the row that you are working in (active), with a .

To change a record entry, just activate the cell by clicking on it, and enter the data.

To delete a row, activate the row by clicking on the row header (grey block to the left), right click and delete. Note that the numbering will change and you will lose the number of this row.

You can also change the table format (font and font effects) by right click on the row headers and choosing Table Format. You can change the font of the data.

Take the same database that we have worked on previously and change the table as follow:

<table>
<thead>
<tr>
<th>ID</th>
<th>Name</th>
<th>Last_Name</th>
<th>Telephone</th>
<th>Age</th>
<th>Class</th>
<th>Activity 1</th>
<th>Activity 2</th>
<th>Activity 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>John</td>
<td>Peterson</td>
<td>604 765 7865</td>
<td>14</td>
<td>3A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Robert</td>
<td>Wambier</td>
<td>604 877 2112</td>
<td>14</td>
<td>3A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Paul</td>
<td>Vinster</td>
<td>604 879 9989</td>
<td>14</td>
<td>38</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Patrick</td>
<td>Moore</td>
<td>604 788 6636</td>
<td>15</td>
<td>38</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Susan</td>
<td>Uckies</td>
<td>604 444 7895</td>
<td>14</td>
<td>3C</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Rhiva</td>
<td>Du Tatt</td>
<td>604 437 6986</td>
<td>14</td>
<td>38</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Save your table.

Sort Records in a Table

You can also sort the records in your table in ascending, descending, numerical or alphabetical order.

For example to sort the above table according to class, then surname and then name, you click on the sort button.
You have an option of 3 levels of sorting (you can choose up to 3 fields to sort by) and you have also an option of ascending or descending to choose to order them by. Ascending and descending works for both numerical and alphabetical sorting.

<table>
<thead>
<tr>
<th>Sort order</th>
<th>Field name</th>
<th>Order</th>
</tr>
</thead>
<tbody>
<tr>
<td>and then</td>
<td>Last_Name</td>
<td>ascending</td>
</tr>
<tr>
<td>and then</td>
<td>Name</td>
<td>ascending</td>
</tr>
</tbody>
</table>

Copy Data from One Table to Another

Sometimes it is necessary to copy data from one table to another. For example, if you have a database of names and addresses of people and you want to create a new table with only their names with other information, it would be time effective to copy the names to the new table without retyping all the data.

1. First create the new table you want to copy to. This will be your Destination Table. Create the fields you want to copy to (in accordance with the fields from your table you want to copy from).

Both the name of the table you are copying from (Source Table) and the table you want to copy to (Destination Table) are appearing in the Tables pane of the Tables View.

2. In the Tables pane right-click on the name of the table that you want to copy from (Source Table).
3. Choose Copy.
4. Right-click on the name of the table you want to copy to (Destination Table). Hit Paste.

5. Because you want to copy only selected data, choose Append data. Hit ```Next >```.
6. Tick the fields from the **Source Table** that will appear in your **Destination Table**.

![Image of data fields being assigned to destination table]

7. Hit [Create]

In this example you have copied the Account Numbers to the new table.

**Test Your Knowledge**

1. Making a field longer is different than making it wider?
   - TRUE. they are different.
   - FALSE, longer and wider is the same in a database field.

2. A LONGVARBINARY data type can be used as the field to store an image?
   - TRUE
   - FALSE

3. Which data type would be best to store a single character?
   - BOOLEAN
   - CHAR
   - DECIMAL
   - INTEGER
   - VARCHAR

4. A table design should never be changed?
   - TRUE
   - FALSE

5. Which is NOT a step when adding a new mandatory field to a table that already has data?
   - Setting the primary key
   - Changing the 'Entry required' field back to 'Yes'
   - Adding data to the columns that will be mandatory
   - Saving the modified table
   - Open the table for editing
Answers

1. TRUE, longer means the field has more characters, wider means more characters are displayed on the screen.
2. TRUE, the image data type is a LONGVARBINARY
3. CHAR
4. FALSE, however to change the order of fields is not possible. It is better to plan thoroughly and then create the database to avoid changes.
5. Setting the primary key, it was already set in the original design.

Table Relationships

Database Schemas (Relationships)

In your planning you have designed a set of tables and identified the relationships between them.

Preparing to Create Table Relationships

One of the early steps in creating a database is in designing as many of the tables as can be identified through analysis/planning. Once the databases table designs have begun to form the collection of tables and their relationships becomes known as the database schema.

Designing, adding and modifying a database schema becomes a task that occurs whenever the business information requirements change. This change can happen either frequently or infrequently, this depends on how much the information requirements change. In our small school example once the database has been designed we would expect very little change to the database schema.

To build a relationship you must ensure that the two tables have both a field with the same name and data format. In one of the tables, this field must be the primary key (unique field) and in the other one the foreign key. These two fields will be used to link the two tables.
Designing the Relationship

Let’s look at the two tables we have created:

**Personal_Info:**

<table>
<thead>
<tr>
<th>ID</th>
<th>Name</th>
<th>Last_Name</th>
<th>Telephone</th>
<th>Age</th>
<th>Class</th>
<th>Activity_Lng_ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>John</td>
<td>Peterson</td>
<td>604 755 7865</td>
<td>14</td>
<td>3A</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Rachel</td>
<td>Yenker</td>
<td>604 877 2112</td>
<td>14</td>
<td>3A</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Paul</td>
<td>Yenkar</td>
<td>604 879 5508</td>
<td>14</td>
<td>3B</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Dave</td>
<td>Moore</td>
<td>604 788 9636</td>
<td>15</td>
<td>3B</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Suzanne</td>
<td>Looos</td>
<td>604 441 7899</td>
<td>14</td>
<td>3A</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Ritva</td>
<td>Du Toit</td>
<td>604 587 6988</td>
<td>14</td>
<td>3B</td>
<td></td>
</tr>
</tbody>
</table>

**ExerciseLog_Gr3:**

<table>
<thead>
<tr>
<th>ID</th>
<th>Activity</th>
<th>Exercise_Type</th>
<th>TimeExercised</th>
<th>Maximum_Pulse</th>
<th>Resting_Pulse</th>
<th>Activity_Lng_ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Walking</td>
<td>1</td>
<td>180.00</td>
<td>120</td>
<td>80</td>
<td>A1</td>
</tr>
<tr>
<td>2</td>
<td>Tennis</td>
<td>3</td>
<td>120.00</td>
<td>170</td>
<td>140</td>
<td>A2</td>
</tr>
<tr>
<td>3</td>
<td>Football</td>
<td>3</td>
<td>100.00</td>
<td>190</td>
<td>200</td>
<td>F3</td>
</tr>
<tr>
<td>4</td>
<td>Running</td>
<td>3</td>
<td>60.00</td>
<td>150</td>
<td>117</td>
<td>R3</td>
</tr>
<tr>
<td>5</td>
<td>Swimming</td>
<td>2</td>
<td>60.00</td>
<td>160</td>
<td>120</td>
<td>S1</td>
</tr>
<tr>
<td>6</td>
<td>Volleyball</td>
<td>2</td>
<td>90.00</td>
<td>145</td>
<td>90</td>
<td>V3</td>
</tr>
</tbody>
</table>

The Personal_Info table gives the names of 6 Grade 3 learners who will participate in activities of their choice.

The ExerciseLog_Gr3 table gives the selection of exercises offered, their type (1/2/3), how long an exercise will take place and what the ideal pulse-rate for each exercise is (before and after exercising).

Let us sketch a scenario:

- Grade 3 learners will attend an Activity Day.
- Each learner can choose from the list of activities for the day.
- We will now link the two tables with each other.
Adding the Tables for the Relationship

The first step in setting the rules of a relationship is to open the Relationships designer in the **Database Window**.

This is done through the **Tools → Relationships** menu.

The relationship designer will start with either; a dialog prompting to add tables or a display of the existing relationships. Which gets displayed depends if there are already existing relationships.

You will be prompted to add tables.

Add both the tables you want to link.

Two screens appear that give the fields of each table called the **Relationship Design Screens**:

Close the add tables dialog and only the **Relationship Design** screen will be displayed. It is within this window that you will design the relationships.
The toolbar of the relationship designer has two important buttons:

- Add tables
- Add new relationships

**Defining the Relationship**

First drag the bottom border of the field lists to see all the fields.

To define a new relationship just drag and drop the foreign key field from one table over top of the primary key of the other table (the two keys that will link the tables).

Let's go back to the Personal_Info table and complete the following section for the learners (Activity_Unq_ID):

- John will do walking
- Riette will do abseiling
- Paul will do football
- Patrick will do football
- Suzanne will do swimming
- Rittva will do walking

Your table will look like this:

You have now successfully linked the two tables and build a relationship between the tables.
Edit the Relationship

To edit the properties of the relationship right click the line between the two filed lists in the Relationship Design screen and chooses the Edit option.

Through this action you can also delete the relationship.

Setting the Rules

You want to make sure that the records between tables remain accurate once a relationship has been created. The way to do this is to enforce referential integrity. Editing the relationship properties is how referential integrity is enforced. By default no action is taken on relationships.

By clicking on the Update cascade radio button, you are ensuring that if a change is made in the Primary Key field it will make the changes in the other tables that that field is linked to.

Clicking on Delete cascade ensures that Base will delete all the records that are linked to that field. If this option is not selected you will not be allowed to delete a record that is linked to other records.

Test Your Knowledge

Table relationships

1. The query designer is used to create relationships?
   - TRUE
   - FALSE

2. Which of these choices best describes the update options for a relation?
   - No action
   - Update Cascade
   - Set null
   - Set default
   - All of the above
   - None of the above
Answers

1. FALSE, the relationship designer is used.
2. (e) All of the above

Summary

During this section you were introduced to the design of a database containing a number of tables representing relationships.

You can now:

• Create indexes on the fields identified most appropriate for indexes.
• Identify a field that requires a uniqueness constraint and add a unique index to this field.
• Rename the new indexes to a meaningful name.
• Save the new indexes and close the Index Designer.
• Add data to the table(s) with new indexes.
• Create relationships between tables.
Data Entry using Forms

The focus of this section is to develop an introductory understanding of building forms for data entry. Forms will be built upon existing database tables using the OpenOffice Base forms wizard. The form will be used to navigate the available data to view the records in the database table. Saving new and altered forms will be discussed along with deleting forms for application maintenance.

Upon completion of this section you will be able to:
- create a form for data entry
- use a form to retrieve information
- navigate the records within a database
- delete a form
- save and close a form

Working with Data Entry Forms

On pages 18 – 19 the construction of a database was explained.

Forms are primarily used to enter data and to retrieve information.
Using the Database Pane Buttons to View Forms

The OpenOffice Base Database pane has a button that can be used to view all the existing forms (Forms View).

Using the Menus to View the Forms

Navigate the menus to view all the existing forms. Select View→Database Objects→Forms to see the forms in the current database.

Opening a Form

To open an existing form - in Forms View double click on the name of the form you wish to open. Alternatively you can right click on the name of the form and then click on Open.

Or you can highlight (select) the form to open and use the Edit→Open Database Object to open the form as a database object.
Test Your Knowledge

Viewing and opening forms

1. There is more than one way to open a form?
   - TRUE
   - FALSE

2. How many forms will be displayed when viewing the list of forms.
   - Five
   - None, forms can't be viewed
   - As many as have been created in the database
   - Ten
   - Thirty

Answers

1. TRUE
2. As many as have been created in the database

Using the Wizard to Create a Form

To create a form based on a table, first activate the Forms view. Click on Use Wizard to Create Form in the Task pane.

This will start the forms wizard, which will prompt a step-by-step building of a form.
Starting the Wizard

The wizard consists of 8 steps to follow:

1. Field Selection

First select the table you wish to base the form on by selecting it from the drop down box under **Tables or queries**.

When choosing the table it is best to start with building forms for all the parent tables, and builds forms for the child tables later.

If you have identified the table, you will use the fields in that table to build your form.

Remember, when selecting the fields that will be available of the form, use only the fields that can be edited/filled in. Fields that has values added automatically (like the auto-numbered PK field) should not be put on the form to avoid incorrect values being entered.

Now you can select the fields you want the form to contain from the **Available fields** list. Click on the field and click on the > button to move the field to the **Fields in the form** list. You can continue selecting the fields one by one and repeat the action.

If you want to select all fields click on the >> button.

To remove a field/fields, use the < or << buttons.

Ensure that you have selected all the fields from your table that you want to put on the form.

**Note – Using information from both tables**

If you want to input data from both tables in your form, you also have to select the primary/foreign key that links to the other table.

Click the Next > button to move to step 2 of the wizard. Remember to repeat this action at the end of each step.
2. **Set up a subform**

In some situations you want to include data from another table in the same form. You will make use of a sub-form. A subform is a form that is inserted in a form using data from other tables or queries. This relationship will be put onto the form using a subform. It is specifically used when you have many relationships with the fields in the second table.

For example, one person can have many phone numbers or in our example, one child could choose two or more activities.

You can skip this step by untick the **Add Subform** tick box.

3. **Add subform fields**

Selecting the table and fields for the subform follows the same path as the fields for the original form.
4. **Get joined fields**

In this step you have to identify the fields that are joining the tables.

![Image of Form Wizard: Select the joins between your forms]

5. **Arrange controls**

In this step you are looking at the layout of the form and the subforms.

![Image of Form Wizard: Arrange the controls on your form]

You have a choice of 4 layouts (also choose the alignment):

- In columns with the labels on the left hand side (hit ![Columns with labels on the left side](image)):

![Example layout with labels on the left]

- In columns with the labels on top (hit ![Columns with labels on top](image)):

![Example layout with labels on top]
• As a datasheet (hit ![Image](image1.png)):

![Image](image2.png)

• In blocks (hit ![Image](image3.png)):

Choose the label placement and layout that you want and click **Next**.

6. **Set data entry**

A form is mostly be used for data entry. It can however also be used show data in a specific format (read only). In this step you will make a choice by selecting a radio button.

If you choose to use the form for entering new data only, you will not be able to see existing data of that specific record.

If you choose to display data, you can select what action can be possible (you can select more than one), viz.:

- Do not allow modification of existing data (Read Only)
- Do not allow deletion of existing data (input is possible, but not deletion)
- Do not allow addition of new data (deletion is possible).
7. **Apply styles**

You have the opportunity to set the colour and style of a form.

It is useful to change the style to best suit the user group and their preferences. The style may set (or changed) after the users have had their first review of the new database system.

8. **Set name**

The last step is to name the form you have created. Providing a descriptive name can be beneficial as the number of forms increases. Well named forms aid in user, administrator and developer comprehension.

Now you will hit
Once the form is finished it is a good idea to test the form.

Your form will be displayed with the subform in datasheet format at the bottom.

Test Your Knowledge

The forms wizard

1. A data entry form can be read only?
   - TRUE
   - FALSE

2. A form can include:
   - A subform
   - A colour
   - Field borders
   - An alignment
   - All of the above
   - None of the above

Answers
1. TRUE
2. All of the above

Creating a new form in design view

If you do not want to use the wizard, you will be able to create a new form in Design View. In design view the form is created from scratch without any of the automations provided by the forms wizard.

In the Database Window, activate the Forms view and select Create form in Design View in the Tasks pane.
The Design View

In a form, the above consists of 2 parts:
• The word Name represents the Label
• The data that will be entered will go to a specific data field.

You have to create both to appear on your form.

Furthermore, in Design View the forms fields and buttons are added as controls. The controls are added to the form by selecting the control from the toolbar and “drawing” them on the new form.

Note:
Ensure that the Form Controls and Form Design toolbars are activated. Place them on your desktop where you feel comfortable. Just note where you put each one.

Also note that some of the icons are duplicated on the two toolbars. Whenever you are referring to use one of these, you can choose from which toolbar you are activating the icon.

Your screen will be marked with blocks and you will see the above two toolbars.

Now you are ready to start designing your form. It is good to include the design of your form in your planning and do a rough plan on paper, before you start with putting the controls in place.
You first need to **identify the Table** that you want to use:

1. Click on the form button on the **Form Design** toolbar (If it is not activated, ensure that the **Design Mode** is on by clicking on the on the same toolbar.

2. In the Form Properties window, click on Content drop-down menu and select the table you want to use.

3. Close the window.
4. Then you type the structure of your form (without the controls) as you have planned. Check font and spacing.

Now you can insert the fields. For each item on your form you have to insert a label and a datafield

Use the Forms Control Toolbar and create each item.

For the following you want a text box:

**Label:** ID Name Surname Telephone

**Datafield:** <ID> <Name> <Last_Name> <Telephone> etc.

5. Click on text box and pull your space with your mouse on your form.

6. Right click on the box that you have dragged and choose Control…
7. Click on the Data tab in the **Properties: Text Box** and add the Data Field through the drop down menu.

![Image of Properties: Text Box]

Close the window.

8. To add the label, you click on the label field button ![ABC] and add the label.

9. Right click and enter the label in the **Properties: Label Field**

![Image of Properties: Label Field]

10. Repeat with all the fields that need a text box.

11. To do the list, choose the List Box from the **Form Controls** Toolbar. Various windows will lead you through the process of selecting the **ExerciseLog_Gr3 table** and the **Activities field**.

12. You can now resize your boxes, move them around in your window until you are satisfied with the design of your form.
13. Give the form a proper name and save the form. If the form is new, a prompt will ask for the name of the new form. A good naming convention will help manage the forms, make sure the name is unique and represents what the form is used for.

Play around with the design of forms. You must be comfortable with designing forms for different purposes. A well designed form, create a sense of pride and purpose in the work it is attached to.

**Open, Navigate in and Save a Form**

**Open a Form**

To open a form, double click on the name of the form in **Forms** view. It will open the form displaying the fist record in the table it is attached to.

**Navigate between Records using a Form**

Activate the **Form Navigation** toolbar.

To navigate between the various records using a form, use the arrows on the Form Navigation toolbar, meaning go to the FIRST – PREVIOUS – NEXT – LAST record.

The record that is displayed in the form is recorded in the box to the left. To enter a new record, press . An empty form will be displayed.
To delete a record, press \[\text{Delete}\]. The record that was displayed will be deleted.

You can also sort records by pressing the \[\text{Sort}\] button and define the sorting criteria.

If you press the \[\text{Sort}\] button, you will get the table (data source) of the form displayed at the top of your desktop.

![Image of form]

**Save a Form**

To save a form, close the form. It will prompt you to save the form. If you have not given it a name, it will ask you for the name. Remember the naming convention we discussed on page 69.

**Test your knowledge**

**Navigating and saving a form**

1. Forms can have duplicate names?
   - TRUE
   - FALSE

2. The form navigation buttons allow;
   - To move forward one record
   - To move backward one record
   - To move to the end of the records
   - To move to the beginning of the records
   - All of the above
   - None of a, b, c or d
Answers

1. FALSE
2. All of the above

Deleting a Form

If you want to delete an existing form, go to the Forms View, right-click on the form you want to delete and select Delete from the drop-down options.

If the toolbar is open you could also select the delete button or use the Edit ➔ Delete on the menu bar.

You can also mark it and press the Delete button on your keyboard.

Each time you will be asked to confirm the delete:

![Confirm Delete dialogue box]

Summary

During this section you were introduced to forms through:

- Creating a form for data entry
- Using a form to retrieve information
- Use a form to navigate the records within a database
- Delete a form
- Save and close a new and existing form
Retrieving Information using Queries

The focus of this section is to develop an understanding of querying the database to gather specific information from an area of the database.

The purpose of this section is twofold:

- First you will build an understanding of searching and applying filters to the database and how to sort data for simplified review. You will also build a query using the query wizard.
- The second part of this section is dedicated to using the query designer to build and save queries that can be saved and used again.

At the end of this section you will be able to:

- search for information based on a query parameter
- use filters to find select information from a table or form
- sort information using a variety of methods
- apply sorting to a query
- remove filtering and sorts from tables and forms
- use the query wizard to build a query

What is the Difference between Sort, Filter and a Query?

One of the major confusions in databases is the difference between SORT and FILTER.

It is important to know that both SORT and FILTER are temporary actions.

When a table is closed, the filter criteria and/or sorting instructions will be gone. Therefore, in order to retrieve the same records again, the filter has to be recreated.

- To SORT means to put the records in a database table in a specific order (ascending or descending) using a specific field. It can be alphabetical or numerical values. A SORT changes the structure of the table, so the records are in a different order according to the sorting criteria. Sorting is a quick and temporary tool that is created for one-time use on a specific table.
- To FILTER a database table means to show only the data that fits a certain filter criteria. It’s important to know that filters DON’T reorder the underlying data like a SORT does. The records are still in the same way, it’s simply being displayed on screen according to your criteria. It is also important to know that no record is deleted during filtering. A filter is a quick and temporary tool that is created for one-time use on a specific table.
The biggest difference between sorting and filtering on the one hand and queries is that sorting and filtering are **temporary** tools and a query is **reusable** (can be saved and used again).

A query gathers, collates and presents data from tables in usable forms (another table). Queries are capable of performing the functions of filters and sorting. A query can also perform “aggregated functions” (Summary Query) such as calculating the sum, average, maximum or minimum value of data.

In contrast to a filter, a query is **reusable**. A query allows the selection criteria and/or sorting instructions to be saved and reused.

**Basic Operations – Searching, Sorting and Filtering**

**Searching a Table for Data**

A good way to search for data is from the database table directly.

When a table is opened a number of buttons are available on the toolbar that facilitate searching, filtering and sorting data. To open the table for searching - in the **Tables View**, right-click on the table and select open.

![Opening the Search Dialog](image)

**Opening the Search Dialog**

To search for a specific word, number or date in a record or a set of records within a specific column press the **Find Record** button on the **Table Data** toolbar (There are two versions of this button - ![Find Record Button](image) or ![Find Record Button](image)).
If you cannot see this button, activate the **Table Data** toolbar through the **View**→**Toolbars** option on the **Menu bar**. This will present the Record Search dialog.

### Setting the Search Parameters

The **Record Search** dialog box will appear and you can enter the word, number or date you want to search for and select which field to look in.

Click on the Search button and the value being searched will be highlighted when it is found.

![Record Search Dialog Box](image)

### Test Your Knowledge

**Searching...**

1. Searching data can be done from within an open table or query?
   - **TRUE**
   - **FALSE**

2. Which of the following is not a valid data type for a search?
   - Number
   - Binary
   - Text
   - Date

### Answers

1. TRUE
2. Binary
Using Filters

Applying Filters

Filtering allows you to work with selected records (you can only see the filtered data). In other words the rest of the database remains hidden while only the records you want to work with are visible.

To apply a filter, open the table to be filtered in **Tables View**.

There are four icons for filtering on the Standard Toolbar.

These are:
1. **AutoFilter** - which filters the whole table for the value that is highlighted.
2. **Apply Filter** - which applies the filter currently active.
3. **Standard Filter** - which sets the filters parameters.
4. **Remove Filter** - which removes the currently applied filter.

Approaches to Filtering

**The AutoFilter** filters the whole database table for the value that is highlighted. This can be very useful when looking for individual or sets of records for a given value.

In your table you highlight the value (text or numerical) that you want to filter and click the **Auto Filter** button.

It will immediately give you a table that displayed only the values in the table you have identified.

**The Remove Filter** will return the table to include all the data as it was before the filter was applied. Keep in mind filters do not delete (remove) the data they just keep in hidden. (Note: The Remove Filter button is also used to remove a sort.)
The Apply Filter uses the last applied filter and runs it again. This is useful when looking for specific values and need to refer back to all the data in the table. This used in combination with Remove Filter allows you to "toggle" between the filtered data and all the data.

The Standard Filter

The Standard Filter presents a dialog which allows the entry of parameters to create a multi-field and multi-value filter. It could be considered an advanced filtering capability.

In the Standard Filter dialog fields to be filtered can be chosen, criteria can be selected and values can be set on more than one and up to three fields.

Test Your Knowledge

Filtering…

1. Which of the following is not a filter activity?
   - Standard Filter
   - Remove Filter
   - Assign Filter
   - Apply Filter
   - Auto Filter

2. The standard filter allows for only one criterion?
   - TRUE
   - FALSE

Answers

1. Assign Filter
2. FALSE
Sorting Data

Simple Sorting

Records can be sorted according to numeric or alphabetical order of a specific field/s.

To sort data open the table to be sorted.

On the table toolbar there are three buttons that can be used for sorting. These are:
- Sort Order - which opens the Sort Order dialog.
- Sort Ascending - which sorts the records A to Z or if numbers, lowest to highest.
- Sort Descending - which sorts the records Z to A or if numbers, highest to lowest.

Opening the Sort Dialog

To create a more advanced sort that uses more than one column within the sort, click the Sort button on the toolbar.

This will present the Sort Order dialog.

The Sort Order dialog allows a sort to be created with up to three fields using either an ascending or descending order. After choosing the sort fields and the order click OK to run the sort, the records in the table should then be sorted based upon the sort order entered. (Remember: to remove the sort order, use the "Remove Filter / Sort" button on the toolbar.)
Query Operations

Creating a Query using the Query Wizard

If you want a reusable sort/filter, you build a query and save it to be used at a later stage.

A query is a table that you have sorter and filtered according to certain criteria you have set and saved it. It is always linked to your table. Any changes you make in your table will be reflected in your query. If you ever change data in your query, it will also be changed in your table.

Starting the Wizard

Using the query wizard can be a very helpful way to quickly build a query. To start go to the Query View and select the Use Wizard to Create Query... task.

The wizard follows 8 steps to create a query. Follow these steps and press when you want to move to the next step.

1. **Field selection**

In the first step you choose the table and the fields to build your Query on.

Select the fields from the selected table to display in your query. Once all the query fields have been selected click the button to continue with the wizard.
2. Sorting Order

To assign sort orders to the query select up to four fields to sort upon. Choose the field to be sorted and the order, either ascending or descending.

The sort will occur with the first field being the priority sort with the subsequent fields sorting within the first sort.

As an example if class was the first sorting field and last_name was the second, the query will ordered in classes, and within each class sort the surnames.

3. Setting the criteria/Select the search conditions

Setting the criteria/setting the conditions is like using a filter.

The criteria will filter the data and "hide" some of the data from the query results.

To set the criteria:

- select a field,
- choose a condition, and
- enter a value to compare.

You can skip this step by selecting Match all of the following.
4. Detail or summary

Here you will be indicating if you want to show the query in detail (as a table showing all the records of the query) or in summary (showing only the results of aggregated functions – sum, average, maximum, minimum).

If you have selected the **Summary query**, you will be prompted to the grouping and grouping conditions steps (Steps 5 and 6). Follow the instructions to refine your query further.

If you want to assign aliases, you can follow the instructions in step 7.

It can be useful to change the name of the column when it is displayed in the results. The aliases step of the wizard allows this change, in the right column enter a new name to be displayed.
8. Overview

The last step of the wizard prompts for a query name. This name will be saved to the database for later retrieval and will be displayed as a saved query.

This step also provides a summary of the query, selecting the "Modify Query" option would allow editing of the query summary text. If changes to the query are required it would be better to use the "Back" button of the wizard and make the changes using the wizard.

If you are satisfied with your query, hit the Finish button.

Running the Query

To run the query, go to the Query View and right-click on the query name and select Open. You can follow any of the other means to open the query viz. the menu bar or by double clicking on the name.

Review the results to confirm they are what were desired. If changes are required the query will have to be opened in design mode.

The query will be displayed as a table or as a summary table depending on the selection made in step 4 above.

Test Your Knowledge

Using the Query Wizard

1. Setting the criteria in the wizard is like using a query filter?
   - TRUE
   - FALSE
2. Which step of the query wizard CANNOT be ignored?
   - Field Selection
   - Sorting Order
   - Search Conditions
   - Grouping Conditions
   - Aliases

**Answers**

1. TRUE
2. Field Selection

**Creating a Query using the Design View**

Creating queries in design view allows the most amount of flexibility when building a query. In design view the query is built from scratch.

The designer selects the data source (table(s)) and creates joints between tables (if necessary), adds fields to the query, sets sort order and criteria, adds aliases for column names and other design features.

**Starting a New Design**

To create a new query in design mode select the **Create Query in Design View**... task in the Query View.

<table>
<thead>
<tr>
<th>Tasks</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Create Query in Design View]</td>
<td>Create a query by specifying the filters, input tables, field names, a...</td>
</tr>
<tr>
<td>![Use Wizard to Create Query]</td>
<td></td>
</tr>
<tr>
<td>![Create Query in SQL View]</td>
<td></td>
</tr>
</tbody>
</table>

**Setting up the Query**

Remember when developing a new query in design view it is useful to incrementally test that the query is providing the results required. To run the query in design mode press the run query button.
The first step in designing a new query is to add the tables that the query will be based upon. Because queries are also tables, you are able to select existing saved queries or tables to base your new query on.

Once the tables have been added to the query designer the fields need to be selected.

You can use the query designer at the top and double click on each field you want to put in your query.

OR

You can use the table at the bottom of your screen. Click on the first cell in the Field row. A indicates that you have access to a dropdown list of all the fields in the selected tables and queries. Select a field to include in your query.
Continue adding the fields by selecting them from the available drop-down menus in the subsequent Field row. If more than one table is a part of the query it is also a good idea to review if the table relationship(s) have become a part of the query.

Confirm the relationships can be done by looking for a line joining the two tables in the query designer at the top. If no line exists one of the two fields that create the join can be dragged and dropped on top of the other. This should create the join/relationship.

Remember every action that you are doing in the query will be reflected in your original table too.

After you have selected all the fields for your query, you will see that the table of origin has also been indicated as well as the visibility of your field in the query.

Once all the fields have been added to the query:
- aliases can be added for the fields;
- sort orders can be applied the fields of the query. It’s a good idea to limit the number of sorts to three. You can choose between not sorted (default), ascending and descending.

You can also define the criterion for the specific field.

In closing the query you will be prompted to save the query under a new name.
Test Your Knowledge

Designing a new query

1. A query can include more than one table?
   - TRUE
   - FALSE

2. Joins can be created while in the query designer?
   - TRUE
   - FALSE

Answers

1. TRUE, a query can include many tables, these tables should be joined by a relationship.
2. TRUE, joins can be created by dragging and dropping the required fields.

Running the New Query

The Run Query Button

As you have learnt in the previous activity, when developing a new query in design mode it is useful to incrementally test that the query is providing the results required. To run the query in design mode press the run query button.
Query Results in Design View

After the query has run, the results will be displayed in a split window above the two query design windows. To iteratively build the query, make changes to the design and run the query again.

Keep making changes and running the query until it provides the results desired.

Saving, Opening, Deleting the Query

Saving, the Query

To save the query in design mode select File → Save... from the menu bar. Alternatively, you can close the window and if there are pending changes be prompted by the Save As... dialog.

In the Save As... dialog enters a meaningful name. Naming is important, for through time many queries may get built and having a meaningful name will make query identification easier.
Opening the Query

To open a query, right-click on the query name to run and select open. This will run the query and present the results. You can also double-click on the name or use the menu bar.

Once the result window is open the sort and filter buttons are available allowing further organising of the data to better suit the results being sought.

Deleting the Query

There are three methods to delete a query.

- Right-click on the query name and select Delete from the drop-down menu.
- Select Edit ➔ Delete from the menu bar.
- Mark the query and press the delete key on the keyboard. The delete operation will prompt to confirm the deletion.

Test Your Knowledge

Query Management

1. There are three methods to delete a query?
   - TRUE
   - FALSE

2. Which activity CANNOT be done in the query results window?
   - Sorting
   - Filtering
   - Aliasing
   - None of the above

Answers

1. TRUE
2. Aliasing
Summary

During this section you were introduced to basic querying through:

- searching for information using a query parameter
- the use of filters to find information from a table
- sorting information using a variety of methods
- apply sorting to a query
- removing filters and sorts from tables
- using the query wizard to build a query

You were also introduced to the querying designer through:

- designing a new query that included the fields from multiple tables
- added criteria to queries by using operators
- altered the fields (columns) presented in the query
- ran the query
- saved and reused the query
- Deleted a query.
Creating Reports

The focus of this section is to develop an understanding of reports. Reports are used to print selected information from a table or query.

Reports will be built upon existing database tables using the OpenOffice Base reports wizard.

By the end of this section you will be able to:
• create a report using the report wizard
• use a report to retrieve information
• identify the difference between static and dynamic reports
• delete a report
• save and close a report
• select the reports data source
• add fields to the report
• change the display order of the fields
• assign labels to the reports fields
• name a new report
• save a report
• discuss static and dynamic reports
• delete a report

Basic Reporting

The first question you have to ask yourself is what is the difference between a query and a report?

A query is a tool that pulls data out of a database. A report is a tool that allows data from a database to be printed in a useful format.

You can create Static and Dynamic reports. A static report captures the report for a given point in time. So every time you open a static report it displays the results based upon the data in the database when the report was first created (date specific).

The Dynamic report displays the results based upon the data in the database at the time the report is run. With a dynamic report if the report data in the database changes daily so will the report.

A good practice is to first develop a query with the data you want to display in your report. The creation of the report is then very easy.
Create a Report using the Report Wizard

Open the Reports View.

The Reports Window has only one task that will start the Reports Wizard.

It will prompt you to the 6 steps to create a report.

1. Read reports
2. Labeling fields
3. Grouping
4. Sort options
5. Choose layout
6. Create report
1. **Field selection**

Select the source table. The available fields can then be moved to be fields in the report by selecting the field and then selecting the \( \rightarrow \) to move the field into the report. The option available in the Field Selection step of the Report Wizard allows the following actions:

- \( \rightarrow \) move the highlighted field
- \( \gg \) move all the fields
- \( < \) remove the highlighted field from the report
- \( \ll \) remove all the fields from the report

2. **Labeling fields**

In this step you have to give the fields in your report the desired names to display in your report. Sometimes it is useful to add labels to the fields. This is particularly true when the field names of the table are not easily understood or an existing database is being used with a different country and language. Labels can be associated with every field on the report to assist in the reports comprehension.

These names can contain spaces.

3. **Grouping**

In this step you can add one or more grouping levels for the report. This is done to refine the order in which our report data is presented. For example, we may wish to break down a telephone directory by area so that all of the members of each area are listed separately. Grouping is normally used in large tables.

You select the fields by clicking on them and clicking the arrow \( \rightarrow \) to move them into the Groupings box. You can group up to four fields in a report.

If you do not wanting Grouping leave this box as it is and click on **Next**.
4. **Sort options**

You have the ability to sort your data for presentation in the report.

The ability to sort data in the report is also useful. During the sorting step the report wizard will prompt for the fields and the order to base the reports sort. The sorting step of the wizard lets you choose how you want the data to be sorted based on specific fields.

If you don't need to sort the data into any particular order then leave this screen as it is and click on **Next**.

5. **Choose layout**

In this step you can choose the layout of your data and the layout of headers and footers.

OpenOffice Base provides a number of report layouts, depending on the usage of the report or the audience who will be looking at the report different layouts can be more effective.

Investing some time to review the different report layouts will be very useful as more reports are developed. Choose the appearance for the report by selecting the layout of the data and the layout of the headers and footers. It can also be chosen whether the report will print in Portrait or Landscape by clicking on the relevant option.

6. **Create report**

The final step of the wizard is to name the report and save the report. When you hit the **Next** button, you will be prompt to give your report a title.

When saving the report the option to make the report either **static** or **dynamic** is available.

Remember, the static report captures the data based upon when the report was created, the dynamic report captures the data based upon each time the report is run.
You can also choose to modify the report layout by clicking on the radio button. You will see a report layout with the fields indicated as highlighted.

You can change the layout as you would have done to a table in Word processing. Make use of the tab key to align fields, drag the lines around, put spaces between words/fields, change fonts and sizes, and even delete some of the default fields that were put into the report such as author, date and page numbers.

If you are satisfied with the selection, click on Finish and OpenOffice Base will create the report.

You can now open the report by one of the 3 means you know by now and look at the final version. If you are not 100% satisfied, you can right-click on the name of the report in the Report View and edit the layout of your report.

You can even go back to the wizard by clicking on .

Deleting a Report

There are three ways to delete a report. After selecting the report to delete, choose either:

- from the menu bar select Edit→Delete
- right-click on the report name and select Delete from the pop-up
- highlight the name of the report and press the Delete key on the keyboard

Any of the methods will prompt to confirm the delete.
Test Your Knowledge

1. The display order of the fields can be changed?
   o TRUE
   o FALSE

2. Fields can be relabeled for the report, identify the possible reason for this activity.
   o Database table field names are hard to comprehend
   o Report needs to be in a different language than the database fields are currently in
   o The audience uses words which meaning does not match the database field names
   o All of the above
   o None of the above

3. A report can be based on a query?
   o TRUE
   o FALSE

4. The OpenOffice 3.0 Base reporting has two available tasks?
   o TRUE
   o FALSE

5. A static report will display.
   o All the static data in the database
   o A list of the static query parameters
   o The data for a when the report was first run
   o The data for each time the report is run
   o None of the above

6. Grouping and sorting are two ways to say the same thing?
   o TRUE
   o FALSE

7. Sorts can include up three fields?
   o TRUE
   o FALSE

8. Reports cannot be printed using a landscape page orientation?
   o TRUE
   o FALSE

9. Which of the following is NOT a layout for the headers and footers?
   o Controlling
   o Executive
   o Finances
   o Generic
   o Worldmap

10. The only way to delete a report is to select it from the main reporting screen, right-click and select delete?
    o TRUE
    o FALSE
Answers

1. TRUE
2. All of the above
3. TRUE
4. FALSE
5. The data for a when the report was first run
6. FALSE
7. FALSE
8. FALSE
9. Executive
10. FALSE

Summary

During this section the learner was introduced to the reporting through:
- creating a report using the report wizard
- using a report to retrieve information
- identify static and dynamic reports
- deleting a report
- saving and closing a report
Outputting and Sharing Data

The focus of this section is to output data in printed and file formats.

Upon completion of this section the learner will:

- print forms and reports
- print the result of a query
- apply appropriate print options
- output data to other formats

Preparing to Print

You can only print forms and reports and not queries and tables directly from your database.

You have to open the report or form from the appropriate view. You can either use the print button or the menu bar File ➔ Print.

Like in any other application, you can also have a preview of your print by pressing the page preview button, or select File ➔ Page preview option from the menu bar.

Remember that you can also set the printer options like other applications.

Print Selected Record(s) or a Table

To print selected records in OpenOffice.org you would have to run a report that would select the required records and then print it. The same would apply if you wanted to print the complete table.

Print a Query

To print the result of a query you would have to create a report based on that query and then print it.

Print a Report

First generate the report and then print as normal by clicking on File ➔ Print form the menu bar. If you want to print a specific page, type it into the dialog box and click OK or else simply click on OK to print the entire report.
Printing

There are two options when printing a report or form, either select the Print File Directly button from the toolbar or use the File ➔ Print from the menu bar.

Printing Options

Once printing has been selected a dialog will appear prompting for the destination Printer and providing the ability to set some properties for the selected printer. The ability to set the number of pages and the number of copies is also available on the Print dialog.

The Properties dialog will prompt to set the properties of the selected printer. Keep in mind that the properties will be printer specific, though many similar properties are held by most printers. The properties dialog will prompt for items like; Page Size, Orientation (portrait or landscape), Print tray (which paper source in the printer), etc.
Test Your Knowledge

1. The three print buttons are; 'Print Settings', 'Print File Directly' and 'Page Preview'?
   - TRUE
   - FALSE

2. There are two print orientations; portrait and legal?
   - TRUE
   - FALSE

3. Which of the following cannot be printed directly?
   - Form
   - Report
   - Query
   - None of the above

Answers

1. FALSE
2. FALSE
3. Query

Export to Another File Format

Export a Form or Report to Text, XHTML and PDF

OpenOffice provides the ability to output to other sources than just the printer.

Two other available output sources are XHTML (.html or.xhtml files), PDF files or Mediawiki (text) (.txt) files.

To export to one of these formats select **File → Export...** form the menu bar and save it.

Export a Report or Form to directly to PDF

Use the **button or **File → Export to PDF...** to export a report or form to PDF. You need Acrobat Reader to open the file.

Export a Table or Query to a Spreadsheet

A query and a table are in a format similar to a spreadsheet and can be easily exported to Calc.

You have to copy a table from Base to a new Calc sheet, then you can save or export the data to any file format that Calc supports.

1. You first have to open the table/query **view** you want to export. Click on the database table/query name to be exported.
2. Right click on the name and select **Copy** from the menu to select the whole table/query.
3. Now you have to open the Calc spreadsheet. Choose **File → New → Spreadsheet** from the menu bar.

You have both applications open on your desktop.

4. Click on cell A1 in the new Calc window, then paste the content into the spreadsheet by either press **Ctrl V** or choose **Edit → Paste** from the menu bar or right click en choose **Paste**.

Now you have the data in a spreadsheet that you can perform any action as has been discussed in Module 4.

**Summary**

After completing this unit, the learner is able to:

- print forms and reports
- print the result of a query
- apply appropriate print options
- output data to other formats
Scenario - A Database for a Small Business

1. Aim

After you have completed module 5, the following scenario must be studied. It will apply the knowledge and skills you have acquired in this module.

You have started a small business. Please get a concept of your business (what your business is all about)

1.1 What is your business’ name?
1.2 Make a list of at least 10 customers that you will supply goods to/render a service to your business.
1.3 Choose a date when your business has started (in the past).

You will now create a database with several tables for your business. You will create a database called **YourSurname_YourBusinessName**.

When you create a database planning is essential. You must decide:

- What you want the database to do
- What questions do you want to answer from your data
- What data fields will you need
- How will you enter data
- What do you want your reports to contain or show
- How do you want to sort or group your data
2. **Tables**

2.1 **Customers Account Table**

1. Initially you need one table of all your customers with just their Account numbers, name of the business, title, first names and surnames of the contact persons.
2. Create a table and call it *Cust_No_YourSurname*.
3. Use the table structure as indicated below.
4. Fill in the details of Account numbers, name of the business, first names and surnames. You should have at least 10 records.

<table>
<thead>
<tr>
<th>Structure of Cust_No table</th>
<th>Data type</th>
<th>Primary key</th>
<th>Field size</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AccountNumber</td>
<td>Text</td>
<td>Primary key</td>
<td>5</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BusinessName</td>
<td>Text</td>
<td>50</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Title</td>
<td>Text</td>
<td>4</td>
<td>Prof/Dr/Mr/Ms</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FirstName</td>
<td>Text</td>
<td>50</td>
<td>Call Name</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Surname</td>
<td>Text</td>
<td>50</td>
<td>Last Name</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Questions**

1. Why is AccountNumbers the primary key?

2.2 **Basic Table**

1. You need a table with the details all your customers, called *Basic_YourSurname*.
2. To type the whole thing over again is a waste of time.
3. Copy the Account Numbers and to the new one *Basic_YourSurname*.
4. Use the structure below to guide you with the requirements.
5. Do not add any information – that will be added via a form.

<table>
<thead>
<tr>
<th>Structure of Basic table</th>
<th>Data type</th>
<th>Primary key</th>
<th>Field size</th>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AccountNumber</td>
<td>Text</td>
<td>Primary key</td>
<td>5</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Date_of_First_Transaction</td>
<td>Date/Time</td>
<td>December, 31 1999</td>
<td></td>
<td>Transaction must be after start date</td>
<td></td>
</tr>
</tbody>
</table>
2.3 Addresses Table

1. You need another table of the customers list with their account numbers in which to add their address details.
2. To type the whole thing over again is a waste of time.
3. Copy the Account Numbers to a new table called Addresses_YourSurname.
4. Add the fields as indicated below.
5. Do not add any information – that will be added via a form.

<table>
<thead>
<tr>
<th>Data type</th>
<th>Primary key</th>
<th>Field size</th>
</tr>
</thead>
<tbody>
<tr>
<td>AccountNumber</td>
<td>Text</td>
<td>Primary key</td>
</tr>
<tr>
<td>Address1</td>
<td>Text</td>
<td>50</td>
</tr>
<tr>
<td>Address2</td>
<td>Text</td>
<td>50</td>
</tr>
<tr>
<td>Town</td>
<td>Text</td>
<td>50</td>
</tr>
<tr>
<td>PostalCode</td>
<td>Text</td>
<td>6</td>
</tr>
<tr>
<td>TelephoneNumber</td>
<td>Text</td>
<td>20</td>
</tr>
<tr>
<td>CellNumber</td>
<td>Text</td>
<td>20</td>
</tr>
</tbody>
</table>

Questions

1. Why is PostalCode a text field and not number field?
2. Why are the names of the businesses and the names and surnames of contact persons not in this table?
2.4 Credit Table

1. You need another table of the customers with their account numbers in which to add their account limits (maximum amount to allow for credit per month) details.
2. To type the whole thing over again is a waste of time.
3. Copy the Account Numbers to the new table named Credit _YourSurname.
4. Add the fields as indicated below.
5. Do not add any information – that will be added via a form.

<table>
<thead>
<tr>
<th>Field</th>
<th>Data type</th>
<th>Primary key</th>
<th>Field size</th>
<th>Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>AccountNumber</td>
<td>Text</td>
<td>Primary key</td>
<td>5</td>
<td></td>
</tr>
<tr>
<td>Credit limit</td>
<td>Numerical</td>
<td>Primary key</td>
<td>10</td>
<td>With 2 decimal places</td>
</tr>
<tr>
<td>PaymentSchedule</td>
<td>Numerical</td>
<td></td>
<td>1</td>
<td>When is payment due. Use the following codes:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• 1 – 1st of the month</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• 2 – 15th of the month</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• 3 – 25th of the month</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>• 4 – last day of the month</td>
</tr>
</tbody>
</table>

3. Relationships

1. Our goal is create a form to enter data that will go to the correct tables. So we must first link the different tables.
2. First check that the field which we are going to use to link, is the same in each table. Check that AccountNumber field is spelt the same in each table and has the same format.
3. In the Relationship window add all the tables.
4. Create a link between the …
   a. Cust_No table and the Basic table
   b. Cust_No table and the Address table
   c. Cust_No table and the Credit table
5. Save the Relationships.
6. Print the relationships window.
4. **Get Ready to Enter Data and then Enter Data**

1. Using the Wizard create an Input Form for Clients with all of its fields.
   a. Use Cust_No as the Main Form with the Addresses tables as sub-form.
   b. Join the main form and sub-form with the account number.
   c. The account number must just appear once on the form.
   d. Arrange the main form in blocks, labels above and the subform in columns with labels on the left.
   e. Allow changes and display to the form.
   f. Choose a style colour other than beige with no field border.
   g. `Name the form Cust_Input_YourSurname`

2. On the same form, use the Design View to insert your business name and Customer Input Form in 2 lines at the top. Use another font than Times New Roman or Arial and use 20 pt font size. Change the layout as follow and save the form:
3. Create the following form in design view (Name: Credit status_YourSurname):

![My Business Credit Information Form](image)

Add basic, credit and address details of all the customers through the forms.

5. **Analysing Collected Data**

5.1 **Queries**

All the information has been added via the form. Before we start analysing the information look at the tables.

5.1.1 **Queries on the Basic Table**

Perform the following queries on the Cust_No_Surname table. Save each query with the number and a short description.

1. How many contacts have the title, Mr? …
2. Perform an update query to show the number of customers (sum of) based on their title.
3. Perform a select query to show the number of customers signed up for the first 2 weeks of your business.
5.1.2 Queries on the Credit Table

Perform the following queries on the Credit_Surname table. Save each query with the number and a short description.

4. How many contacts are paying at the end of the month? …
5. What is the average credit limit for your customers? …
6. Perform a query to show the number of customers by their payment schedule.

5.2 Reports

Create the following reports based on the different tables. Save each report with the number and a short meaningful description.

BasRep1. List the customers with all the names of the contact persons, the names of the Business and their account numbers.
BasRep2. List the customers with all the names of the contact persons, the names of the Business with their account numbers sorted alphabetically according to Business Name.
BasRep3. List the customers with all the names of the business, contact persons, full address with their account numbers.
BasRep4. List the customers with all the names of the business with their account numbers sorted in ascending Date of First Transaction.
BasRep5. List the customers with all the names of the business with their account numbers sorted and grouped by payment schedule showing the number of businesses paying at a certain date of the month.
BasRep6. List the customers with all the names of the business with their account numbers sorted grouped by payment schedule showing the average credit limits for each of the 3 dates.

6. Output Data

1. Print an empty form to be duplicated for your business so that the secretary can fill it in before entering data.
2. Print a full set of filled forms for the secretary to check the data entered. Change the page orientation.
3. Print the content of the full Cust_No_Surname table.
4. Print the first query that you have run.
5. Print the first report that you have compiled.
6. Select any 2 records from the Cust_No_Surname table and print them.
7. Export the first report you have created to a PDF file and save it.
8. Export the Adressess_Surname table to a spreadsheet, name it and save it.
## Evaluation

Name of Student:  
Type of Assessment:  
Date of Assessment:  
Assessor: 

<table>
<thead>
<tr>
<th>Assessment Criteria</th>
<th>Level 1 (0)</th>
<th>Level 2 (1)</th>
<th>Level 3 (2)</th>
<th>Level 4 (3)</th>
<th>Assessment</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Conceptual Skills</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Creating a database on a defined subject</td>
<td>Unable to create a useful database at all.</td>
<td>Attempts to select fields, queries and reports, and create a switchboard with errors evident.</td>
<td>Can create some useful queries and reports.</td>
<td>Expertly selects fields, queries and reports, and creates switchboard to solve a need.</td>
<td>X10</td>
</tr>
<tr>
<td><strong>Practical Skills</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Creating a form</td>
<td>Unable to create a form at all.</td>
<td>Attempts to create a form but with either errors of formatting or structure evident.</td>
<td>Can create a simple form without errors.</td>
<td>Expertly creates a detailed form with advanced features.</td>
<td>X7</td>
</tr>
<tr>
<td>Creating a sub-form</td>
<td>Unable to create a sub-form at all.</td>
<td>Attempts to create a sub-form but with either errors of formatting or structure evident.</td>
<td>Can create a simple sub-form without errors.</td>
<td>Expertly creates a detailed sub-form with advanced features.</td>
<td>X6</td>
</tr>
<tr>
<td>Printing a form</td>
<td>Unable to print a form at all.</td>
<td>Attempts to print a form but with errors.</td>
<td>Can print a form without errors.</td>
<td>Expertly print a form with advanced layout features.</td>
<td>X2</td>
</tr>
<tr>
<td>Printing a record in a form</td>
<td>Unable to define and control printing of records from a form at all.</td>
<td>Attempts to print a record in a form but with limited success.</td>
<td>Can define and print a required record showing basic skills.</td>
<td>Expertly defines and prints a record in a form showing advanced skills.</td>
<td>X5</td>
</tr>
<tr>
<td>Performing an update query</td>
<td>Unable to perform an update query at all.</td>
<td>Attempts to perform an update query but with errors evident.</td>
<td>Can perform a simple update query successfully.</td>
<td>Expertly performs an update query with advanced formulae.</td>
<td>X5</td>
</tr>
<tr>
<td>Performing a select query</td>
<td>Unable to perform a select query at all.</td>
<td>Attempts to perform a select query with only one criteria but with limited success.</td>
<td>Can perform a select query with more than one criteria and showing basic skills.</td>
<td>Expertly performs a select query showing advanced skills.</td>
<td>X5</td>
</tr>
<tr>
<td>Creating a report</td>
<td>Unable to create a report at all.</td>
<td>Attempts to create a report but with either errors of formatting or structure evident.</td>
<td>Can create a simple report without errors.</td>
<td>Expertly creates a detailed report with advanced features.</td>
<td>X5</td>
</tr>
<tr>
<td>Creating a report based on two tables</td>
<td>Unable to create a report based on two tables at all.</td>
<td>Attempts to create a report based on two tables but with either errors of formatting or structure evident.</td>
<td>Can create a simple report based on two tables without errors.</td>
<td>Expertly creates a detailed report based on two tables with advanced features.</td>
<td>X5</td>
</tr>
<tr>
<td>Assessment Criteria</td>
<td>Level 1 (0)</td>
<td>Level 2 (1)</td>
<td>Level 3 (2)</td>
<td>Level 4 (3)</td>
<td>Assessment</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>------------</td>
</tr>
<tr>
<td><strong>Adding controls, calculations and formulae to a report</strong></td>
<td>Unable to add any controls, calculations or formulae to a report at all, or gives a report an unsuitable heading.</td>
<td>Attempts to add controls, calculations or formulae, or a heading to a report but with errors evident.</td>
<td>Can add controls, calculations or formulae, or a heading to a report.</td>
<td>Expertly adds controls, calculations and formulae, and a heading to a report.</td>
<td>X5</td>
</tr>
<tr>
<td><strong>Printing a table</strong></td>
<td>Unable to print a table at all.</td>
<td>Attempts to print a table but with errors.</td>
<td>Can print a table without errors.</td>
<td>Expertly print a table with advanced layout features.</td>
<td>X5</td>
</tr>
<tr>
<td><strong>Printing a form</strong></td>
<td>Unable to print a form at all.</td>
<td>Attempts to print a form but with either errors.</td>
<td>Can print a form without errors.</td>
<td>Expertly print a form with advanced layout features.</td>
<td>X5</td>
</tr>
<tr>
<td><strong>Exporting a report to PDF</strong></td>
<td>Unable to export a report to PDF at all.</td>
<td>Attempts to export a report to PDF but with errors.</td>
<td>Can export a report to PDF without errors.</td>
<td>Expertly export a report to PDF with advanced layout features.</td>
<td>X5</td>
</tr>
<tr>
<td><strong>Exporting a report to a spreadsheet</strong></td>
<td>Unable to export a report to spreadsheet at all.</td>
<td>Attempts to export a report to spreadsheet but with errors.</td>
<td>Can export a report to a spreadsheet without errors.</td>
<td>Expertly export a report to a spreadsheet with advanced layout features.</td>
<td>X5</td>
</tr>
<tr>
<td><strong>Work Skills</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Personalising a database</strong></td>
<td>Unable to personalise a database at all.</td>
<td>Can simply personalise a database with a basic name and or icon.</td>
<td>Can simply personalise a database with a basic name and icon.</td>
<td>Expertly personalises a database with a suitable name and effective icon.</td>
<td>X5</td>
</tr>
<tr>
<td><strong>Outward appearance of forms and reports</strong></td>
<td>No attempt to improve the appearance of forms and reports</td>
<td>Lacks design and purpose.</td>
<td>Outward appearance is purely functional with necessary details.</td>
<td>Outward appearance professional with selected details.</td>
<td>X5</td>
</tr>
<tr>
<td><strong>Initiative</strong></td>
<td>Never showed any initiative.</td>
<td>Showed limited initiative.</td>
<td>Showed a fair amount of initiative.</td>
<td>Showed a great deal of initiative.</td>
<td>X5</td>
</tr>
<tr>
<td><strong>Neatness &amp; visual impact</strong></td>
<td>Very untidy and making negative visual impact.</td>
<td>Some effort is made to produce neat work with little success, and which is visually boring.</td>
<td>Good effort to produce neat work with some room for improvement, and which is visually pleasing.</td>
<td>Great care has been taken to produce exceptionally neat work which is eye-catching and visually exciting.</td>
<td>X10</td>
</tr>
<tr>
<td>Total</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>-------</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>%</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Module 6

Presentations using OpenOffice Impress

Module Overview

Welcome to Module 6 – Presentations using OpenOffice Impress. This module explores the building of a presentation using OpenOffice 3.0 Impress. The module is intended to be very hands-on and focus on design principles for presentations in addition to the nuts and bolts of using the Impress application.

Upon completion of this unit you will be able to:

- Understand principles of design and apply them to presentations
- Work with presentations in OpenOffice 3.1 Impress and save them in different file formats
- Choose built-in options such as the Help function within the application to enhance productivity
- Understand different presentation views and when to use them, choose different slide layouts and designs
- Enter, edit and format text in presentations. Recognise good practice in applying unique titles to slides
- Choose, create and format charts to communicate information meaningfully
- Insert and edit pictures, images and drawn objects
- Apply animation and transition effects to presentations
- Print a presentation (output a presentation to print)

Terminology

Type style

The choice of type face (font, size, case and block type).

Notes View

An Impress view that provides an image of the slide at the top of the page and allows you to input notes at the bottom of the screen.

Slides Workspace View

The Slides Workspace View displays miniature versions of the slides.

Handout View

The Handout View provides a visual of the presentation on printed pages.

Master view

Master View allows you to create a presentation with different types of slides but enable them to all have the same “look”.
Study Tips

You may find it useful to skim through an entire block of content first, paying special attention to the headings and introductions, and then go through a second time for more in-depth study and practice.

However, we recommend that you do the activities as they appear. They are essential study materials, offering practice in particular skills that will build your proficiency in creating effective presentations.

Keep linking the new content that you are studying with content in this module that you have already covered and with your own general knowledge, to deepen your understanding of the operations you are learning.

If you have difficulty understanding any area, try working at it slowly. If you still do not understand, seek help.

Preknowledge

Before beginning this module, we recommend you:

- study modules 1, 2 and 3 before this one, because they provide the essential knowledge for you to work with Impress, including saving files, formatting text and retrieving information from other files.
- reflect on professional presentations you have seen or given previously. What made these presentations effective, or not effective? How could these presentations have been made more meaningful to the audience?
Introduction to Presentations

Section Overview

In this section you will be introduced to what presentations are and you will be able to apply design principles in developing your presentation.

By the end of this section you will be able to:

- apply design principles to presentations and slides
- follow the design process to present a good presentation
- consider features that make a good presentation

What is a good presentation?

The main purpose of creating a presentation is to:

- show a message in key points
- enhance the message with multimedia, i.e. text, graphics, animations and sound

A presentation has the advantages of:

- increasing the understanding of a message and reducing confusion
- increasing audience involvement
- drawing the audience attention to key points
- making a presentation more interesting
- guiding the presenter through a presentation, assist him/her to keep to the time allocated for a presentation and giving him/her a feeling of confidence and control

The disadvantages of using a presentation are:

- too many or using the wrong animations
- sound, colour and graphics create confusion and pull the attention away from the main message
- multimedia entertains without enhancing the message
- the presenter focuses on the screen, reads long parts from the screen and loses contact with the audience
- it gives too much information
Design principles

Depending on the purpose and audience of the presentation, there are a few considerations in the design of presentations:

- all slides should be well designed to fit the specific purpose and audience
- using excessive animations is distracting; unless it fits the purpose avoid them
- do not use sounds in the transition of slides, unless you want to create a specific effect. Avoid sound effects in formal presentations.
- graphical images explain more than words alone; use them when you can
- where there are generally accepted abbreviations and acronyms use them to minimise text usage
- ensure that your choices of colours are legible from a distance. Light fonts on dark backgrounds are good for textual material, but scientific graphs often work better on a light background. Keep the background colour simple.
- use the right type-faces and fonts, emphasising with bold-face or different colours. It is advisable though to keep the colours on your screen to a maximum of four.
- use descriptive headings. Don’t let your audience guess or experience difficulties in deciphering the meaning or purpose of a slide. Use of descriptive headings not only asserts the reader with the slide, but also leads to fewer slides.
- use short, concise phrases
- make use of bullet points. Golden rule is no more than five bullets per slide, then it becomes too much.
- make use of numbered lists. The same rule for bullets applies for numbers – less is more. Do not use more than five numbers per slide.

The Design Process

To create and convey a successful presentation you need to:

- plan carefully:
  - What do you want the audience to know once you have finished the presentation?
  - What do you want the audience to believe once you have finished the presentation?
- do your research
- know your audience
- time your presentation
- practice your presentation
- speak comfortably and clearly

Purpose of the Presentation
Presentations are an effective way to communicate or sell an idea to a large crowd of people at the same time. However, it is not just about communicating information or selling ideas. Determining the purpose of your presentation involves finding answers to the following questions among others:

- Why do you want to make a presentation?
- What do you want to communicate?
- What do you aim at achieving with the communication?
- Do you really need to use a presentation to achieve this?

Content

Now that you’ve focused the presentation towards its purpose, you need to find the facts that will support your point of view or the action you propose. Keep in mind you should give the audience only the facts necessary to accomplish your goals; too much information will overwhelm the audience, and too little information will leave the audience either with a sketchy understanding of your topic or with the feeling that you have not provided enough information to support the course of action you wish the audience to take.

Analyse the Audience

The most important step in designing an effective presentation is to focus on what your audience needs to know, not what you know. You now need to analyse your audience so that you can tailor your presentation to suit your specific audience’s needs and characteristics.

How to analyse your audience:

- determine your audience’s level of experience or knowledge regarding your topic
- determine the general education level and age of your audience
- determine the audience’s attitude toward the presentation topic, and based on that attitude, determine any concerns, fears, or objections your audience might have regarding the topic
- determine whether there are subgroups in the audience that might have different concerns or needs
- formulate questions that you could ask your audience regarding the topic
- check the cultural, social and political background of your audience
- determine the audience’s motivation to attend your presentation

To have advanced presentation skills you should be able to not only instill a trust between you and your audience, but also create an interest and excitement in your audience for what you are presenting.

Structure the Presentations

A hierarchical structure organises information from more-general to more specific dimensions, so that information at the top of the hierarchy is
more general than information at the bottom. And it is advisable to use such a structure when creating your presentations.

A hierarchical structure is used:

1. to comprehend information – the more marked the hierarchical structure, the easier it is for us to understand
2. to commit information to memory and later retrieve it
3. to decide about the importance of information – we assume information at the top of the hierarchy is more important than lower information, so we pay more attention to it and learn it better

Also remember to add an introduction and conclusion to your presentation. The introduction is key to an effective presentation.

Introductions should have the following components:

- background and motivation
- objective (of the briefing or the research in general)
- an overview or outline of the rest of the briefing

The conclusion at the end will give an overview of findings, recommendations and implications. Typically in the conclusion will be a way forward. The conclusion can be more than one slide.

**Rehearse the Presentation**

When creating a presentation, remember to keep it short and visual so that it guides you and keeps your audience captive and focused. This way it would also be easier for you to prepare for the presentation.

When rehearsing your presentation, you need to have a clear understanding of the message you want to bring across to your audience and what you want their reaction to be. Prepare well in advance, and avoid rehearsing directly before your presentation. Remember to proofread your presentation, or have it proofread by someone else.

**Typographical Considerations**

The typographical issues that you should consider in your presentation are:

- type style (font)
- type size
- upper or lower case
- formatting types (Bold, Italics, Underline)
Type Style

There are significant differences in the choice of typefaces between printed information and a presentation. While a serif typeface like Garamond might look presentable on paper, on a presentation it can be difficult to read. Sans serif fonts generally look better on computer displays and presentations than serif fonts (serifs are the little hooks on the ends of letters).

<table>
<thead>
<tr>
<th>Serif</th>
<th>Sans Serif</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Garamond 36 point)</td>
<td>(Verdana 28 point)</td>
</tr>
</tbody>
</table>

Also depending on the audience and the purpose of the presentation, some fonts might be more suitable than others. For example, for formal or official presentations, Arial would be suitable while Comic Sans might be suitable for a very informal presentation.

<table>
<thead>
<tr>
<th>Arial</th>
<th>Comic Sans</th>
</tr>
</thead>
</table>

Type Size

Depending on the audience and the presentation room, some font sizes might be more legible than others. It is always important to consider the room where the presentation will take place when choosing the size. In large rooms, with the audience seated a distance from the projection screen, large font sizes will be better than small ones.

Upper or Lower Case

Although upper case letters might be good to emphasise a point, their use should be sparing or avoided. Upper case letters occupy more space on the slide and are slow to read. For some audiences, the use of all upper case characters might be perceived as “SCREAMING”.

Formatting Types (bold, italics, underline)

**Bold** face makes letters more readable and appears clearer when projected on a screen.

*Italic* are slow to read especially from a distance and should be avoided or used sparingly.

Underlining is not very effective in a presentation and must be avoided. Use other means such as size, colour, bold to emphasise your main points.
Colour Considerations

Colour can have a great impact on the effectiveness of a presentation, and so colour choice deserves some thought. Improper use of colour can affect readability, recognition, retention and communication. Some colours are perceived to have meanings in different cultures and therefore their use should be in accordance to those cultures. Colour has also been used to evoke moods or states of mind. Some people also believe that colour enhances their learning.

While it is important to choose a colour theme that is line with your organisation’s colours, it is important to consider these other issues:

- colour contrast
- background effects
- colour blind people

Colour Contrast

Highly contrasting colours improve the readability of the slides. Care, however, should be taken not to use very sharp colours as they are tiring to the eyes.

Background Effects

Bright backgrounds can also be tiring to the eyes when a presentation is displayed using an overhead projector, since the bright light used by these projectors is reflected back to the audience.

Consider the following colour schemes:

<table>
<thead>
<tr>
<th>Colour Combination</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Yellow on a black background</strong></td>
<td>This is arguably the easiest colour combination to read and that’s why it is widely used for caution signs. However, because the contrast is so stark, it does not look appealing on a presentation.</td>
</tr>
<tr>
<td><strong>Red on a black background</strong></td>
<td>This colour combination is almost illegible. Although the contrast is there, the mix of the colours is not right.</td>
</tr>
<tr>
<td><strong>Yellow on a white background</strong></td>
<td>This colour combination doesn’t have enough contrast. It is very difficult to read, and also monotonous.</td>
</tr>
<tr>
<td><strong>Black on a white background</strong></td>
<td>This combination is widely used, especially for formal presentations. This combination looks good on a computer screen but the background may be too...</td>
</tr>
<tr>
<td>Colour Combination</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Colour Considerations</td>
<td>blue on a white background</td>
</tr>
<tr>
<td>For organisations with blue as one of their colours, this colour combination is not only legible but also creates a soothing mood. Again, the white background may be too bright for a projector.</td>
<td></td>
</tr>
<tr>
<td>Colour Considerations</td>
<td>dark blue on a light background</td>
</tr>
<tr>
<td>Using a light pastel background with dark text provides a good contrast of colours that’s easier on the eyes than a white background.</td>
<td></td>
</tr>
</tbody>
</table>

**Consideration for Colour Blind People**

If part of your audience consists of colour blind people (estimated as 0.5% of women and 8% of men), consider that most of them have difficulty with red, green and brown. Avoid using these colours together in a presentation.

**Graphics and Illustrations**

It is important to include visual elements to break the monotony and to illustrate important points. Graphics and illustrations are visual representations of the discussion and can greatly improve understanding and retention. Charts and graphs can help illustrate technical data or trends, and can be easily incorporated into your presentations.

Consider the following when using graphics or illustrations:

- choose images that help support the content rather than just decorate the page
- use text to augment the graphic, not dominate it
- graphics should be easily viewable and not too complex. For complex illustrations, show the illustration in its entirety, then zoom in to see the key features, or simplify the graphic by cutting out nonessential elements
- charts and graphs are excellent ways to display numerical information or trend data (for example, changes over time)
- limit graphics to one or two per page
- try to avoid using too much movement in transition of graphs and charts. When using photos or drawings, animation might be effective
- avoid using sound effects unless it is effective and needed.

**On the Day of Presentation**

- Make sure you are fully prepared. Gather all the relevant information to enable you to answer all the questions that might arise from your presentation.
• Make sure that the technology you are going to use is in working order and all connecting cables, remotes, spare batteries for the remote etc. are available in the venue.
• When using visual aids, use them effectively. Avoid a lot of concentration on the visual aids, focus on your audience.
• Show a lot of confidence when presenting.
• Know the occasion and dress appropriately. The way you dress can distract the audience from the presentation.
• Always maintain eye contact with the audience.
• Make sure you are audible, and clear.
• Maintain an appropriate tone and pace.
• Ensure that there is a smooth transition from point to point during your presentation.

Most Common Mistakes in Presentations

Avoid these common mistakes:

• Illegible content – Slides that contain information that is not easily readable force the audience to try and guess what is written. Audiences tend to lose interest in the presentation if they cannot see what is being presented.
• Poor organisation – Slides that are poorly organised make it difficult for your audience to understand the message of your presentation. Information that is poorly ordered is disruptive for the presenter and intimidating for the audience.
• Information overload on a slide – Too many details on a slide is intimidating and detracts from comprehension and retention of the information in the slide.
• Typographical and spelling errors – “typos” and spelling errors undermine your audience’s confidence in you and detract from the message of your presentation.
• Irrelevant colour, sounds, graphics and animation. Avoid what is called “bells and whistles”.

Summary

In this section you have been introduced to presentations and good design principles in developing your presentation. You have to remember these principles throughout this module and whenever you are developing slides to present.

You can now confidently:

• apply design principles to presentations and slides
• follow the design process to present a good presentation
• consider features that make a good presentation
Using the Application

Section Overview

In this section you will be introduced to the overall look and feel of the Impress Window layout and how to work with presentations.

By the end of this section you will be able to:
- understand the Impress Window layout
- save a presentation and exit Impress
- navigate through slides
- set up user preferences in the application
- use the magnifying tools/zoom
- use the help function

Working with Presentations

Impress Window Layout

When you launch Impress, a new, blank document, or default window, opens. Shown below is the OpenOffice Impress default window.

It shows the three main working areas of the Impress window, viz. Slides pane, Workspace and Task pane as well as different ribbons and toolbars across the window.
Here is a brief explanation of the Impress window.

**Title Bar**

The title bar is the upper most band on your OpenOffice Impress window.

The Title bar displays both the name of the presentation and the name of the application.
- The name of the presentation is Proposal to Funders.odp (hence the “Proposal to Funders” in the title).
- The name of the application is OpenOffice Impress (hence the name OpenOffice.org Impress).

**Menu bar**

The Menu bar is made of text menus displayed below. The Menu bar displays all the tools that are available in Impress. Each button displays a text menu (dropdown menu) when clicking on it.

Tip: A menu in computer language is a list of choices from which a user can select. In OpenOffice Impress, you can display the contents of any menu item by clicking on the menu name with the left mouse button.

**Other Toolbars**

A Toolbar contains commands that have pictures or icons associated with them. These pictures may also appear as shortcuts in the Menu Bar:

Tip: The Toolbar is a row/s of icons usually on the top of the screen, just below the menu bar. The icons usually represent the frequently used commands that are activated when the icons are clicked.
Changing toolbars

There are several toolbars built into Impress. These are:

- Display toolbars by ticking them off on the dropdown menu
- Hide toolbars by un-ticking them on the dropdown menu
- Move toolbars around by grabbing the toolbar handle on the left side of the toolbar and dragging it. You can dock them somewhere else or leave them floating in the Workspace.
- Close toolbars by dragging them into the workspace and press the on the toolbar

Task Pane

The Task pane, which by default appears on the right hand side of OpenOffice Impress, provides you with cascading menu options for:

- Master Pages (choice of 28 slide masters)
- Layouts (choice of 20 layouts)
- Table Design (choice of 11 standard tables)
- Custom Animations (a variety are listed and can be changed or removed later)
- Slide Transitions (56 transitions are available, you can change the speed or to do it manually/automatically and timing of automatic transition)

Any one of the menu options can be maximised by clicking on the. The menu with the displays the full menu.

To close the task pane, click on the or untick on View→Task Pane. To restore the task pane, tick Taskpane on View→Task Pane.
Slides Pane

The Slides pane contains thumbnail pictures of the slides in your presentation; in the order they will be shown. Clicking on a slide in the Slides pane selects it and places it in the Workspace. While it is there, you can apply any changes desired to that particular slide.

Several operations can be performed on one or more slides in the Slides pane:
- add new slides at any place within the presentation after the first slide
- mark a slide as hidden so that it will not be shown as part of the slide show
- delete a slide from the presentation if it is no longer needed
- move slides around

To close the slides pane click on the or untick on View ➔ Slide Pane.

To restore the task pane, tick Taskpane on View ➔ Slide Pane.

Page View Buttons

The Workspace has five tabs: Normal, Outline, Notes, Handout, and Slide Sorter. These five tabs are called Page View Buttons. You can access these by clicking on the tab in the Workspace or by choosing View ➔ and the appropriate view.

Each button reveals a view that is designed to make completing certain tasks easier. In summary:

- **Normal view** is the main view for creating individual slides. Use this view to format and design slides and to add text, graphics, and animation effects.
- **Outline view** shows topic titles, bulleted lists, and numbered lists for each slide in outline format. Use this view to rearrange the order of slides, edit titles and headings, rearrange the order of items in a list, and add new slides.
- **Notes view** lets you add notes to each slide that are not seen when the presentation is shown. This is typically used for speaking notes that accompany each slide.
- **Slide Sorter view** shows a thumbnail of each slide in order. Use this view to rearrange the order of slides, produce a timed slide show, or add transitions between selected slides.
• **Handout view** lets you print your slides for a handout. You can choose one, two, three, four, or six slides per page from the Tasks pane.

### Open, Save and Close a Presentation and Exit the Impress Program

You will make use of the file menu in opening, saving and closing presentations and exiting the programme as you have done in other applications. The file menu in Impress is similar to the one you used in the other OpenOffice applications. If you haven’t used any of the other applications, you will need to learn how to use the file menu for basic navigation.

As seen in the illustration below, when you click on **File**, you have a selection of actions to choose from. We start off by discussing the basic terms.

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Used to create a new presentation.</td>
</tr>
<tr>
<td>Open</td>
<td>Used to open an existing file from a floppy disk or hard drive of your computer.</td>
</tr>
<tr>
<td>Close</td>
<td>Used to close a presentation.</td>
</tr>
<tr>
<td>Save</td>
<td>Used to save a file that you have changed. If you close the presentation without saving it, the changes you made will be lost.</td>
</tr>
<tr>
<td>Save As</td>
<td>Used to save a new file for the first time or save the existing file with a different name.</td>
</tr>
<tr>
<td>Print</td>
<td>Used to print the presentation.</td>
</tr>
<tr>
<td>Exit</td>
<td>Used to exit Impress or any other application in the OpenOffice.org software suite.</td>
</tr>
</tbody>
</table>

**Opening an Existing Presentation Using the File Menu**

You can open any presentation that has been named and previously saved from the File Menu or with the Wizard.
To open an existing presentation:

1. Click the Open existing presentation button. The Open dialogue box opens.
2. In the Look-in list, click the drive, folder, or Internet address where the file that you want to open is located.
3. In the folder list, open the folder that contains the file, and then click in the file you want to open.
4. Click the Open button. The presentation will open.

Opening more than one Presentation

You can open more than one presentation. Without closing one, just follow the same instructions and open another presentation. You now have two presentations on your desktop, the one on top of the other one.

You can switch between the two open presentations:

- If your presentations are not maximised (you can see part of the second presentation), you can click on the one that you want to work on. It will move to the front and you can work on it. If you want to work on the one behind, just click anywhere on the presentation and it will move to the front. The active one’s title bar will be in the default colour and the other one will be grey.
• If the presentations are maximised, you can work on one, minimise it, and work on the back one. To maximise it again, pick it up from the bottom of your screen.

Saving a Presentation

You must assign a distinguishable name to every presentation that you create in Impress. If you don’t name the file, you won’t be able to open and update it in the future.

The first time you save a presentation, Impress will prompt you to assign a name through the Save As operation. You must then identify the location (folder and sub-folder) on the drive (A:, C:, D: etc) you want to save it to.

You can make additional changes to a file – add a slide, change text, add a picture, etc. – and then only use the Save option. The presentation will be saved to the original location and file name, thus overwriting the previous saved version.

To save a new Impress presentation:

1. Choose File ➔ Save As from the menu bar.
2. The Save As dialog box appears.
3. Click on the **Save In** drop-down menu and locate where you want to save the file.

Choose:
- 3 ½ Floppy (A:) to save the file to a floppy disk;
- Local Disk (C:) to save the file to your hard disk; or
- D: onwards means any other device you have installed to save in. It can be a network, flash memory stick or an external hard drive. Check the description.

4. Type a name for your file in the **File name** box.
5. Click the **Save** button.

To save changes that you’ve made to an existing presentation:

1. Choose **File ➔ Save** from the menu bar, or
2. Click the Save button on the Standard toolbar (third button from left on top row).

**Tip:** It is a good idea to save your work frequently when working in Impress so that you do not lose information!

You can quickly save your presentation by using the quick-key combination: **Ctrl + s**.

To save changes that you’ve made to another presentation/under a different name:

1. Choose **File ➔ Save As** from the menu bar.
2. You can now do one of the following:
   a. Choose an existing presentation that you want to overwrite. Click on the presentation name and hit **Save**.
   b. Type in a new file name to save the current presentation with the changes to a new name and hit **Save**.
   c. Change the folder of the file, by copying the existing presentation to a new folder under the same or different name and hit **Save**.
Saving a Presentation in Different Formats

If you look at the File ➔ Save As dropdown menu, you will see that there are several formats that you can save a presentation in. These are:

- ODF Presentation (.odp) – a normal presentation that you can edit in Impress
- ODF Presentation Template (.otp) that you can save as another file, edit and reuse
- various other versions of OpenOffice – both as presentations and templates
- various other versions of office applications such as MS Word, StarDraw – both as presentations and templates
- drawing object (image file format) – (odg)

Check the options that are given in the Save as type dropdown menu.

Export a Presentation in Different Formats (.pdf and .swf)

If you want to save the file in another format than what is available in the dropdown menu, you have to export the file to another format.

To execute choose File ➔ Export. You have several choices, but the following two are useful to save as:

- Portable Document Format (.pdf) gives you the ability to print and send a file in its final form.
- Macromedia Flash file (.swf) gives you the ability to view the presentation as a Flash show. Just remember you have to download the Adobe Flash Reader for reading this file.

Saving a Presentation in Rich Text Format

To save as Rich Text Format, you must copy and paste the content of your slides from the Outline View into Writer and use the Save As function in Writer to save as Rich Text Format.

Rich Text formatted files are often called RTF files. RTF files can be opened and used with any word processor, including OpenOffice, WordPad, NotePad, Word, and Star Office. An OpenOffice file can be saved in RTF through Writer. The RTF format can be a good way for
OpenOffice to exchange text files with users of other operating systems such as Microsoft Word.

**Saving a Presentation in Different Versions**

To save a file as another version, press File→Versions. Click on the Save New Version button. You will be given the option to insert a version comment e.g. Ver1.0. Press OK. The versions already saved will be reflected in the look-in list. Press Close.

If you have saved several versions and you want to access them, you can press File→Versions. In the look-in list, highlight the version you want to open and press Open. Through the same procedure you can also delete a version by pressing Delete. After you have completed the action, you press Close.

**Closing an Impress Presentation**

To close an existing presentation chooses File→Close from the menu bar. The presentation in the Impress window closes.

Alternatively – just click on the Close button to close the program. ✗

Impress prompts you to save your work if you have made any changes to the presentation between the last save and the time the file is closed.

**Exiting Impress**

To exit Impress choose File→Exit from the menu bar.

**Slide Navigation – Moving Around the Presentation**

You can move around the presentation in several different ways. You will need to know how to do this in order for you to navigate through your slides and presentation.
Scroll Through a Slide Using Scroll Bars

To move up and down in a presentation slide in the Workspace, particularly when working with magnification, use the vertical scroll bar located along the right edge of the Workspace. To move left or right, use the horizontal scroll bar, located at the bottom of the Workspace.

Scroll Through the Presentation

1. In the Workspace, use the **Page Up** and **Page Down** keys on the keyboard to move up or down through the presentation, one slide at a time.
2. Alternatively you could also click and scroll on the mouse to navigate through the presentation.
3. You can also use the **Home** key to display the first slide in the presentation, or the **End** key to display the last slide in the presentation.
4. You can also use the slides pane to move up and down through a presentation. There is also a scroll bar on the slides pane to scroll through the presentation. This scroll bar is only visible if you have created a lot of slides.
Enhance Productivity

Set User Preferences in the Application: User Name, Default Folder to Open and Save the Files

Sometimes the user wants to set up certain default settings for all his/her presentations. These can include, but are not limited to:

- User Data e.g. user name, contact details
- default folder/path to open and save the documents

To change the User Data:

1. Choose **Tools → Options**.
2. Click on **User Data** in the left block and complete the fields in the right block.
3. Press **OK**.

To change the default folder/path to open and save the documents:

1. Choose **Tools → Options**.
2. Click on **Paths** in the left block
3. Highlight **My Documents** in the right block.
4. Click on **Edit**.
5. Select the folder you want to use as default folder.
6. Press **OK** and **OK**.
Use Magnification/Zoom Tools

There is sometimes a need to change the size of the document that you are viewing/working on, for example to see more detail or to be more readable. This will however not change the printing output of the document.

- The first way to change the size of a presentation on screen is to use the maximise, minimise and tile functionalities. Use the buttons on the top right of your screen.
- The second is to use the zoom function. Just remember that zooming is handled differently on Unix, Linux, and Windows platforms. A document saved with a 100% zoom factor in Windows is displayed at a larger zoom factor on Unix/Linux platforms. To change the zoom factor:
  - double-click or right-click the percentage value on the Status bar, and select the zoom factor that you want; or
  - Click on the zoom button and select from the dropdown menu, or
  - Choose View→Zoom and choose the appropriate radio button and press OK.

How to Use the Help Function

As you know by now, you can use the Help Menu to get help.

Choose Help→OpenOffice.org Help F1 or
Press <F1>

The look-in list located at the very top is where you can select other OpenOffice.org Help modules such as Writer, Calc and Draw (other OpenOffice applications).

You can also get access to the Navigation Pane that gives you an option to choose one of the following tabs:

The Index and Find tab pages only contain the data for Impress, while the Contents tab gives you data on the whole OpenOffice.org.
The different tabs can be used as follows:

- **The Contents tab** displays an index of the main topics of all modules.

- **The Index tab** displays a list of index keywords for Impress. By typing in the first letter of a word, you can get help displayed on that specific topic.

- **The Find tab** gives you access to a full-text search. The search will include the entire Help contents. You can only type the word/term you need help on and hit **Find**. Refine your search by choosing from the list displayed and hit **Display**.
• The **Bookmarks** tab will contain bookmarks that you have defined. You can edit or delete bookmarks, or click them to go to the corresponding pages.

**Summary**

In this section you were introduced to the overall look and feel of the Impress Window layout and how to work with presentations.

By now you would have an understanding of the Impress Window layout and acquired the knowledge on how to:

- save a presentation and exit Impress
- navigate through slides
- set up user preferences in the application
- use the magnifying tools/zoom
- use the help function
Developing a Presentation

Section Overview

In this section you will be able to develop a presentation, use different presentation views, choose different slide layouts and designs.

By the end of this section you will be able to:

- create a presentation using templates
- create new presentations
- insert, duplicate and delete slides
- use presentation views to develop and edit your presentation
- develop slides using different layouts and designs for your presentation

Creating a New Presentation

Practice makes perfect is the only way to master a presentation. The following sections will enable you to perform the tasks.

Using Pre-defined Presentation Templates

Using Pre-defined Presentation Templates in Your Presentation

Impress comes with two pre-defined presentations that you can copy and use for your own presentation. Each presentation is formatted and contains pre-written content.

You can select the presentation templates whenever you create a new presentation from a template using the Wizard. You have two options:

- “Introducing a New Product”;
- “Recommendation of a Strategy”.

Compare the content below:
Remember that you can also change your presentation from the design and content of the template.

Impress is also equipped with different presentation backgrounds that you can use in your presentation. You can select these presentation backgrounds whenever you create a new empty presentation using the Wizard. Once you make a selection, Impress then displays the available templates for the selected option. If you select one, you will create a similar presentation to the one you see in the thumbnail on the right hand side of your screen.

Creating a Full Presentation from a Template

You are now going to use the Wizard to create a new presentation based on the full existing presentation template of “Recommendation of a Strategy”.

To create a new presentation based on the pre-designed template:

1. Choose File→New→Presentation from the menu bar.
2. On the Wizard Presentation dialogue box, click on the From Template button.
3. Choose Presentations.
5. Click the Next>> button to display the second screen of the Wizard.
In this screen you can select the slide design.

1. Select the presentation background to be used in your presentation (check the design in the thumbnail on the right).

2. Click the **Next>>** button to display the third screen of the wizard.

In the third screen you can select a slide transition of your slides:
- **Effect** – How one slide will change to the following one; and
- **Speed** – The speed between the transitions (slow/medium/fast).

You can also select the presentation type:
- **Default** – You can present your slides by clicking the mouse or press the **Page Down** or →/↓ arrows; or
- **Automatic** – Your presentation runs automatically and you can set the time you can view a slide and the time to move over to a next slide.

You can also decide if you want to show the logo on each page by marking the appropriate block.

In order to make these choices:

1. Under **Select a Slide Transition**, click in the drop-down area to select any of the 57 available effect transitions. The right hand area of the screen provides an example of each effect as you scroll through the available choices.
2. Under **Select a Slide Transition**, click in the drop-down area to select the Speed of the slide transition (Slow, Medium, or Fast).

3. Under **Select the presentation type**, select either Default or Automatic to define whether the presenter will manually advance slides in the presentation (default), or whether the slides will automatically advance based on Duration of page and Duration of pause timing definitions.

4. Click the **Next>>** button to display the fourth screen of the wizard.

In the fourth screen you will provide basic information on the presentation you are developing.

Type information in each of the three questions displayed on the screen:

![Fourth Screen](image)

Click the **Next>>** button to display the fifth screen of the wizard.

In the fifth screen, you have to choose your topics or pages.

The presentation comes with seven pre-written slides. Remember, on page 26 we explained that the template has pre-written content under seven headings. These slides/pages are the same as the content displayed on page 26. Please check carefully that you understand where this is coming from.

Here you have the choice to remove/include the content displayed in the template. All slides that contain a checkmark in the **Choose your pages** area will be included in the new presentation. Uncheck any slides that you do not want to include in the presentation.

![Fifth Screen](image)
Click the **Create** button to create the presentation and display the first slide.

It is advised that at this stage you save your document under a new name. Please be careful in deciding in which folder you save your document. You must be able to retrieve your document again.

You are now ready to popularise your presentation using the template. You can enter text in all the slides.

**Creating a Presentation from Scratch**

It is not always convenient to use a template if you have to make too many changes. It is sometimes better to create a presentation from scratch. If you want to create a presentation from scratch, you start the same way as on page 27.

When you want to do this, first plan your presentation. Write on a piece of paper what you want to put on each slide. Use the information from the first section of this module. If you are satisfied with your plan, you can start.

1. Choose **File**→**New**→**Presentation** from the menu bar.
2. On the Wizard Presentation dialogue box, click on the **Empty presentation** radio button.

Go through the rest of the screens 2 – 5 as above. On screen 5 you will see that you cannot choose Next>>, choose **Create**.

You will be able to start your presentation from scratch now.

**Slide Backgrounds**

In the first section you have been introduced to the importance of choosing the right colour and design for a background. Impress has several backgrounds that you can choose from.
Some examples are:

Play around with different backgrounds and see for yourself what effect different backgrounds have on a presentation.

You can also just choose a background colour without any design for your presentations.

On any slide of the presentation, choose Format→Page. Click on the Background tab to access the drop-down menu. Choose color, and make your choice of colour.

You will be asked:

If you select yes, all the slides will have the chosen colour background. If you select no, only the one slide that you are working on will have the background colour.
By doing the same you can change the background colour to have different appearances e.g.

**Gradient effect**

**Hatching effect**

**Bitmap**

To summarise, if you want to use a bitmap, colour, gradient or hatching pattern for the slide background:

1. Start a new presentation or open an existing one.
2. Click **Format** ➔ **Page** on the menu bar.
3. Click on the **Background** tab on the Page Setup dialogue box.
4. In the **Fill area**, do one of the following:
   a. Select **Color**, and then click a colour in the list.
   b. Select **Gradient**, and then click a gradient style in the list.
   c. Select **Hatching**, and then click a hatching style in the list.
   d. Select **Bitmap**, and then click a bitmap style in the list.
5. Click the **OK** button.
6. Click either the **Yes** or **No** buttons in the Page Settings dialogue box to answer the question to change the “Background settings for all pages”.
Slide Layouts

Impress allows you to select from many different Layout slide templates to use in your presentation. Impress prompts you to assign a layout each time you add a new slide. You can change the layout assigned to any slide in the presentation at any time.

The type of slide layout you should use depends on what you want to include into your presentation, whether it is to add only text or add text, graphics and charts.

To apply a layout to an existing slide:

1. Click on an existing slide without text in the slide pane to activate it in the Workspace.
2. Ensure that the Layout menu is active on the right-hand side of the screen by either clicking on the Layouts bar or choosing **Format ➔ Slide Layout** from the menu bar. On the right a variety of thumbnail layout slides will appear.
3. Click on the appropriate layout slide (thumbnail) to apply that layout to your slide.

Once you have clicked on the thumbnail it will apply that layout to your current slide.
Adding, Copying and Deleting Slides

Inserting Slides

Each Impress presentation that you create will begin with a single slide. After you change the opening slide, you’ll want to add more slides to your presentation. The number of slides that you add to the presentation is dependent on the length of your presentation.

To insert a new slide in a presentation you can do one of four actions:

1. Choose **Insert ➔ Slide** from the menu bar. A new slide will be added after the active slide on your Workspace. The slide will have the same layout as the slide on your workspace.

![Slide](image1)

2. You can also hit the **Slide** button on the tool bar. A new slide will be added after the active slide on your Workspace. The slide will have the same layout as the slide on your workspace.

3. Another way to insert a slide is to go to the slide pane, click on a slide to activate it in your workspace, right-click and select **Slide ➔ New Slide** from the menu. A new slide will be added after the one that you have first clicked on. The slide will have the same layout as that slide on your Workspace.

4. You can also go to the position for the new slide on the slide pane (between two slides), right click and hit **new slide**. The new slide will have the same format as the previous one.

After you have inserted the slide, you can change the layout by clicking on any of the 20 different Layout thumbnail images in the Task pane to apply that design to the new slide.
Duplicating Slides

Duplicating or copying a slide is another technique that you may use as you work on your slide presentation. For example, you may want to repeat a slide later in the presentation or copy a slide and make small changes to it to make a different point. When you duplicate a slide, you make an exact copy of it.

To duplicate a slide in the presentation:

1. Navigate to the slide that you would like to duplicate, either by paging through the presentation in the Workspace or by selecting the slide on the Slide Pane.
2. Choose Insert ➔ Duplicate Slide from the menu bar.
3. A new slide, an exact duplicate of the original slide, will appear at the bottom of the original slide and will be displayed on the screen.

You can now move the slide to another position by dragging it on the slide bar.
To duplicate a slide in the presentation, you can also copy and paste it to the position you want it to appear:

1. Navigate to the slide that you would like to duplicate, either by paging through the presentation in the Workspace or by selecting the slide on the slide pane.
2. Click on the slide on the slide pane so that it is highlighted.
3. Do one of the following:
   - Choose Edit ➔ Copy from the menu bar
   - Right-click and choose copy
   - Press on the tool bar
   - Press Ctrl+c
4. Move to the desired location for the slide to appear on the slide pane and paste it by:
   - Choosing Edit ➔ Paste from the menu bar
   - Right-click and choose paste
   - Press on the tool bar
   - Press Ctrl+v

A new slide, an exact duplicate of the copied slide, will appear at the pasted location and will be displayed on the screen.

You can use the same procedure to copy slides from one open presentation to another:

Follow the following steps:

1. Ensure that both presentations are open on your desktop.
2. Follow steps 1 – 3 on the presentation that you want to copy from.
3. Activate the second presentation (see page 16).
4. Follow step 4 above.

**Deleting Slides**

Sometimes you may want to take one or more slides out of your presentation. With Impress, you can delete any slide from a presentation, even if it has text or a picture on it.

To delete a slide from the presentation:

1. Navigate to the slide that you want to delete from the presentation, either by paging through the presentation or by selecting the slide on the slide pane.
2. Do one of the following:
   - Choose Edit ➔ Delete Slide from the menu bar
   - Press the delete key
   - Right click and choose Delete Slide from the shortcut menu
   - Press Ctrl+x
If a dialog box appears (if the slide you are deleting contains information on it and you have used the first option), click the Yes button to remove the slide and all the data on it.

Creating and Applying Presentation Views

(Refer to the Page View Buttons on page 14)

Various presentation views can be displayed in Impress. It is important to know that these views were created to maximise the productivity of the person who is using the program.

You must be able to:

- use different Workspace views
- apply a Textbox (text in a Title and/or Text Placeholder) to a slide
- add text in Outline view
- create a Master view

Slides Workspace View

As you work through your presentation, you may find it helpful to view only the thumbnails of your slides at the same time (such as it is displayed in the slides pane). This allows you to view the entire presentation in the Workspace instead of a single-slide in the Workspace as in the past. To identify the difference we say we want to change the Drawing Workspace to a Slide Workspace View.

The Slide Workspace View displays miniature versions of the slides. In this view, you can quickly scan through the order of the presentation and rearrange the order of your slides in the presentation, add or change transitions and hide slides.

To Switch to Slide Workspace View, choose View→Slides Sorter from the menu bar.

You can also click on the Slide Sorter button/tab at the top of the Workspace.
The Impress screen displays the slide and its content in the selected view.

Note:

- The icons at the bottom of the slide indicate the transition of the slides.
- Slide 2 has no transition, the transition has been removed.
- If a slide is hidden, a will appear over the slide number.
- Slide 3 is hidden and will not show in a slide show.

Notes View

Just because you created a presentation does not mean that you will remember all of the details or points that you would like to make throughout your presentation. People get nervous. People forget. Impress provides a Notes View that allows you to define custom-written notes for any slide in the presentation. Visually, this view provides an image of the slide at the top of the page and allows you to input notes at the bottom of the screen.

To switch to the Notes Workspace View choose View ➔ Notes Page.

You can also click on the Notes button/tab at the top of the Workspace.

The Impress screen displays the slide and its content in the selected view.
You can now add your notes in the space below the slide. It will not display on your slide show, but can be printed out for the speaker. It is important to use this space for acknowledgement of copied work.

**Handout View**

Presenters frequently want to provide printed handouts to members of their audience. The Handout View provides a visual of the presentation on printed pages.

To switch to the **Handout View**, choose **View→Handout Page** from the menu bar.

The Impress screen displays the page layout of the slides on handout pages.

**Creating a Master for your Presentation**

If you work for a company, you may be asked to prepare presentations using a photo as background and use some formatting that is not exactly what the Layout menu provides. Or, you have to include the logo of the company on each page. In order to prevent you from changing each page of the presentation, and repeatedly copy the same logo to each page, you can create a **Master** to automate that for you.

Just remember, with every photo, logo or graphic you add to a page on your presentation, you add to the size of the file. It makes a file very big. By doing it in the Master, you only use the photo, logo or graphic once, and it results in a much smaller size file.

The Master View allows you to create a presentation with different types of slides but enable them to all have the same “look”. The elements that you add to the Master View – such as a company logo, background and font colour – will be applied to all of your slides.

It is important to popularise the Master View of a presentation before you start working on the presentation. It is like setting the table for a great meal to follow.

How a presentation is presented depends on how the Master was initially created. Empty presentations generate a Master View with a plain, white background.

You can change slide and notes with the Master.
Creating a Master for a Presentation

Follow the following stages and steps. Each stage will demonstrate a certain feature of the Master.

2. Choose: View → Master and start with the Slide Master.

The slide master consists of only one slide. All the Layout templates will work on top of the settings you put in the Master.

You see a slide with a white background, a certain text format (e.g. in this case Arial), different level bullet outlines (bullet outlines), place holders for <date/time>, <footer> and <number>.
Background Design

To change the background design of all your slides to the same design in the Master:

1. Click on **Master Pages** Bar in the Task Pane. It will expand the Master Pages menu. Click on the design you want to use. Note that the format of the text on the master slide has changed with the layout.

If you created a new presentation with a coloured background or from a template, the Master Slide of that presentation will also display those unique style definitions and/or colour scheme.

*Click to edit the title text format*

- Click to edit the outline text format
  - Second Outline Level
    - Third Outline Level
      - Fourth Outline Level
      - Fifth Outline Level
    - Sixth Outline Level
    - Seventh Outline Level
    - Eighth Outline Level
    - Ninth Outline Level
Background Fills

The default background fill for empty presentations is a plain, white colour in Impress. You can choose to retain this background in the Master or change it to a different colour, gradient, hatching, or image (see page 32).

The background fill is defined on the Page Setup dialogue box.

Regardless of the background fill category you select (colour, gradient, hatching, or image) Impress gives you many choices in each category.

Remember, if you apply a background fill to a single slide, it overrides the master page background. However, objects on the master page remain visible.

Text Elements

After changing the design and background colour, the Workspace will reflect the font type, colour, size and enhancement of each level of bullet you would use in your slide.

You can change the attributes of the font on the Master and it will reflect in all your slides. Just remember to be cognisant of the design principles discussed at the beginning of this module.

As you continue working on your Master View, notice that the Master text-styles placeholder contains a model of up to nine bullets. The text becomes smaller for each bulleted level. Font sizes are pre-selected in the Master View. The sizes are based on what a normal person is able to read from a reasonable distance. You can change the font size, but this is fine-tuning that you might want to do later. Generally, the text should remain the same colour for the title and all text levels.
To Edit the Text Styles on the Master View you can:
1. Select to highlight the text (title text or body text) that is subject to formatting change.
2. Format the selected text by changing its font, size, appearance (bold, italic, underline), and alignment using the Formatting Toolbar.

Place Holders/Areas for <date/time>, <footer> and <number>

At the bottom of the Master slide you will see three placeholders for <date/time>, <footer> and <number> (default on the Master). You can decide if you want to make use of these.

- To change them you can click on the frame of the placeholder and format the block (alignment, font) or add some words.
- You can type in the footer placeholder what must appear on each slide of the presentation.
- To delete the placeholder, choose View→Master→Master Elements and select/deselect what you want to appear on the Master. Hit OK when you are finished.

Remember, if you want the date and time to be reflected as the current date (update the fields automatically), you would use the above format for date and time. However, if you want the date and time to be fixed, delete the <date/time> in the placeholder and type the date or time in. Now the date and time will not be updated.
Adding a Footer to All Slides

Another way you can add a Footer as a text object on the Master page in your presentation is as follows:

To add a Footer to all your slides:

1. Click View ➔ Header and Footer on the menu bar
2. Select the Slide tab.
3. Type in/tick the various text/tick boxes.
4. Press Apply to All tab to save changes.

Adding a Graphic or Object

You can add a picture, image or object that has been saved in a folder on the Master page in your presentation in the following way:

To insert a picture or image in a file to all your slides:

1. Click Insert ➔ Picture ➔ From File on the menu bar.
2. Browse through your files to find the picture.
3. Click on the filename to highlight it.
4. Hit Open

You can resize and move the picture to the desired location on your Master. The graphic will appear on each slide.

You can also copy a picture or image from another open presentation/file and paste it into your Master (see page 16).

To insert an object such as a Spreadsheet or Chart to all your slides:

1. Click Insert ➔ Object ➔ OLE Object
2. Choose if you want to create a new one or use one from an existing file.
3. Identify the object type/search for the appropriate file.
4. Hit OK.

You can resize and move the object to the desired location on your Master. The graphic will appear on each slide.
Removing a Graphic or Object

You can remove a picture, image or object that has been inserted in your presentation by clicking/highlighting the object and hitting the Delete button.

Changing the Master for Notes and Handouts

By following the same logic as above, you can change the Master for Notes Pages and Handouts.

In summary:

- to view – Choose View ➔ Master ➔ Notes Master

- you can edit the Header Area, Date Area, Footer Area and Page Number Area by:
  - Move them around (click and drag)
  - Change the appearance (fonts, alignment and size)
  - Add content
  - Delete content

- you can change the master elements (existence of the Header, Date/time, Footer and Place numbers)

- add headers and footer to all your slides by:
  - Click View ➔ Header and Footer on the menu bar
  - Select the Notes and Handouts tab
  - Type in/tick the various text/tick boxes
  - Press Apply to All tab to save changes
Viewing the Master View Elements

After creating or making changes to your Master, you can view all of the basic design elements in the Workspace of your Master View.

Close Master View

To close the Master View, press the Close Master View button on the floating Master View Toolbar.

Summary

In this section you have learnt how to develop a presentation, use different presentation views and to choose different slide layouts and designs.

You must now be confidently able to:

- create a presentation using templates
- create new presentations
- insert, duplicate and delete slides
- use presentation views to develop and edit your presentation
- develop slides using different layouts and designs for your presentation
Adding Text to Slides

Section Overview

In this section you will handle and format text and work with lists and tables in your presentation.

By the end of this section you will be able to:

- use standard and outline view to enter text
- edit, copy, move, delete text within and between presentations
- use the undo, redo command
- apply and change formatting of text
- edit bullet and number lists
- create, populate and format a table slide

Handling Text

Pre-Knowledge – Good Practice

Please read the first section of this module again. Make a summary of good practice relating to text and the way to plan for a presentation.

Enter Text into Placeholders

An unedited slide created by the AutoLayout contains different text placeholders, e.g.:

Click to add title

Click to add text

All placeholders were formatted in the Master as done in the previous section.
Title Placeholder

In your planning of the presentation you will have a series of titles for your slides. You will enter them in the Title placeholder on the top of each slide.

The Title placeholder is marked by the default text, “Click to add title”. To add text to the Title placeholder, simply click on the text, the words will disappear and type the relevant title.

Remember to keep it short and descriptive. Use the word wrapping feature if the title is longer than one line (do not press enter at the end of each line).

Text Placeholder

The text placeholder is marked by the default text, “Click to add text”. To add text to the text placeholder, simply click on the default text and type the relevant text. It will be formatted according to the design format and layout you have chosen.

Adding Text in Outline View

Outline view is very effective when you want to check the flow of your slides and edit text. In the Outline view, the slide is displayed in text form.

To be most effective, it must be used in conjunction with the Slides pane as shown on the following screen so that you can see what the finished slide will look like.

Adding a Textbox to a Slide

1. To Add a textbox to a slide, click on the Text icon on the drawing toolbar (as shown below)
2. Position it where you want to place the text and click. A narrow textbox is displayed.
3. Start typing the words into the text box.

You do not need to worry about the size of the text box. It will expand downwards to accommodate the text as you type. You can manually resize it or change the font size and format of the text later if you wish.

**Tip:** Move the text box by holding the mouse over one of the perimeters of the text box until the crossed arrows appear. Hold down the left mouse button and drag the text box to another position.

---

**Copy, Move and Delete Text and Text Boxes**

Text boxes as discussed above can be copied, move and deleted. This means that the whole text box, with its content and format will be copied, moved or deleted.

To copy a text box:

Hold the mouse over one of the perimeters of the text box until the crossed arrows appear (see the above tip). Click. The appearance of the text box will change and display handles (little blocks on the perimeter).

1. Do one of the following:
   - Choose Edit ➔ Copy from the menu bar.
   - Right-click and choose copy.
   - Press on the tool bar.
   - Press Ctrl+c.

2. Move to the desired location for the text box to appear. It can be:
   - on the same slide
   - on another slide in the same presentation
   - on a slide in another presentation
3. Choose one of the following:
   - Choose **Edit**→**Paste** from the menu bar.
   - Right-click and choose paste.
   - Press on the tool bar.
   - Press **Ctrl+v**.

To move a text box:

1. Hold the mouse over one of the perimeters of the text box until the crossed arrows appear (see the above tip). Click. The appearance of the text box will change and display handles (little blocks on the perimeter).

2. Hold down the left mouse button and drag the text box to another position.

The above way is quite limiting. You can also cut it and paste it at another location.

1. Do one of the following:
   - Choose **Edit**→**Cut** from the menu bar
   - Right-click and choose cut
   - Press on the tool bar
   - Press **Ctrl+x**

2. Move to the desired location for the text box to appear. It can be:
   - on the same slide
   - on another slide in the same presentation
   - on a slide in another presentation

3. Choose one of the following:
   - Choose **Edit**→**Paste** from the menu bar
   - Right-click and choose paste
   - Press on the tool bar
   - Press **Ctrl+v**

To delete a text box:

Hold the mouse over one of the perimeters of the text box until the crossed arrows appear (see the above tip). Click. The appearance of the text box will change and display handles (little blocks on the perimeter).

Press the delete key on your keyboard.
To copy, move and delete text in a Text box, without changing the text box, you can do similar actions. The only difference is that you do not select the whole text box, but only the text within a text box.

To copy text:

Highlight the text you want to copy by using your mouse.

Note that there is no change in the perimeter of the text box.

1. Do one of the following:
   - Choose **Edit**→**Copy** from the menu bar
   - Right-click and choose copy
   - Press on the tool bar
   - Press **Ctrl+c**

2. Move to the desired location for the text box to appear. It can be:
   - on the same slide
   - on another slide in the same presentation
   - on a slide in another presentation

3. Choose one of the following:
   - Choose **Edit**→**Paste** from the menu bar
   - Right-click and choose paste
   - Press on the tool bar
   - Press **Ctrl+v**

To move text:

1. Highlight the text you want to copy by using your mouse.
2. Hold down the left mouse button and drag the text to another position.

The above way is quite limiting. You can also cut it and paste it at another location.

4. Do one of the following:
   - Choose **Edit**→**Cut** from the menu bar
   - Right-click and choose cut
   - Press on the tool bar
   - Press **Ctrl+x**

5. Move to the desired location for the text to appear. It can be:
   - on the same slide
   - on another slide in the same presentation
   - on a slide in another presentation
6. Choose one of the following:
   - Choose **Edit ➔ Paste** from the menu bar
   - Right-click and choose paste
   - Press on the tool bar
   - Press **Ctrl+v**

To delete text:

Highlight the text you want to delete by using your mouse. Press the delete key on your keyboard.

---

**Tip:** At any time when you have done something and you want to undo it, you can reverse the last command or the last entry you have typed.

Click on **Undo** to undo the last command or the Undo Arrow next to the Redo Arrow on the Standard bar to undo a series of commands. You can also use: **Edit ➔ Undo** or **Ctrl+z**.

To reverse the action of the last Undo command, you can press the redo button. To select the step that you want to reverse, click the arrow next to the on the Standard bar.

You can also cancel the Undo command by choosing **Edit ➔ Redo**.

Remember: Some commands (for example, editing Styles) cannot be undone.

---

**Formatting Text**

In order to change the format of text, you have to understand the working of the Format Toolbar.

**The Format Toolbar**

Remember: The format toolbar is only visible when you work IN a textbox.

You can either set the format before entering text or change it after you have entered the text by highlighting the text you want to format.

The Format Toolbar allows you to make changes to your text to give it the preferred look of your presentation. The Format Toolbar can be used to set the colour, size, and overall look of your text. It doesn’t matter whether the text is an original slide or is in a preset layout.

Here are some of the formatting options:

1. Font type, Font size,
2. Bold, Italics, Underline, Shadow
3. Left Alignment, Center, Right Alignment and Justified
4. Increase and Decrease Font Size
5. Font Colour

You can also work only on character formatting by clicking on . It gives you options to change the:

- font:
  - type, typeface (Italic or Bold), size,
- fonts effects such as:
  - colour, overlining, strikeout, relief, underlining
- position:
  - superscript, normal or subscript
  - scaling
  - character spacing

You can also work on paragraph formatting by clicking on the to:

- indent, spacing between paragraphs, line spacing
- alignment (left, centre, right, justified)
- setting tabs and fill characters

In summary,

![Format Toolbar](image)

**Using the Format Toolbar**

To format text, follow the steps below:

1. To make formatting changes to text that you have not entered yet, click on the down-pointing arrow (e.g., Font Type, Font Colour) OR the format button that you want to apply to the slide (e.g., Bold, Italic, Underline, etc).
2. To make formatting changes to existing text, highlight the text and click on the down-pointing arrow or button.

![Format Toolbar](image)

Take some time to experiment with the different formatting options to decide what's best for your presentation.
Using the Format Menu

You can also use the Format menu to make formatting changes to the text in your presentation.

To format text follow the steps below:

1. Highlight the text that you want to format.

2. Click on Format ➔ Character on the menu bar.

3. The Character dialogue box will appear. Select the desired Font, and/or Typeface, and/or Size.

4. Click the OK button.

Changing the case of text

Sometimes it is necessary to change the case of a word you have entered. You can change the case of selected characters (highlighted), or if the cursor is in a word, change the case of all of the characters in the word.

1. Choose Format ➔ Change Case
2. Choose Uppercase – Changes the selected characters/word to capital letters or Lowercase – Changes the selected characters/word to lowercase letters.
Using Bulleted and Numbered Lists

You can create two different types of lists in Impress:

- bulleted lists
- numbered lists

Bulleted and numbered lists help a reader to simplify steps or items.

Teachers often use bulleted lists to highlight important pieces of their modules. Manuals often include numbered lists to highlight step-by-step instructions.

A bullet by default in Impress is a black circle but it can be customised to any other symbol used to highlight items in a list.

Use bullets to list items that do not have to be in any particular order. Use numbers (or letters) when information has to be in a certain order (or when the count is necessary).

You can use the default bullets by clicking on the appropriate button on the Formatting Toolbar.

Impress provides several bulleted-list template slides that you can incorporate into your presentation. You can use these slides or create new slides on your own.
Creating a Bulleted List

To Create a Bulleted List follow the steps below:

1. Highlight the text that you want to convert into a bulleted list.

2. Click the Bullet button on the Formatting toolbar.

Formatting a Bulleted List

It is important to remember that if you want to change the format of a bulleted list or use a format bullet that is not the default, you need to click on the **Bullets and Numbering** button.

You must:

1. Highlight the text that you want to convert into a bulleted list/change the format of the bullets.
2. Either choose the icon on the toolbar or choose **Format→Bullets and Numbering** on the menu bar.

3. Click the Bullets tab on the **Bullets and Numbering** dialog box.
4. You could also use bullet graphics instead of the standard bullets, by clicking the Graphics tab on the **Bullets and Numbering** dialog box.

5. Click to select a bullet style from the examples that are displayed in either the **Bullets** tab or the **Graphics** tab.

6. Click the **OK** button.

To create a line break between items in a bulleted or numbered list, place your cursor where you want the line break and press **Shift + Enter**.

To indent bulleted text, place the cursor just after the bullet. You can press the tab key (to follow the indentation of the Master) and the backspace to get to the previous level.

**Creating and Formatting a Numbered List**

To create a Numbered List on existing text:

1. Highlight the text that you want to convert into a numbered list.

2. Either choose the icon on the toolbar or choose **Format**→**Bullets and Numbering** on the menu bar.
3. Click the Numbering type tab on the **Bullets and Numbering** dialog box.

4. Click the **OK** button.

To create a Numbered List while you are entering text, follow the steps above before you are entering text.

**Tip:** To set the indent, spacing and alignment options for the numbered or bulleted list, Choose **Format** → **Bullets and Numbering**. Open **Position** tab page.

- In the **Level** space – Select the level(s) that you want to modify.
- In the **Indent** space – Set the indent size. If you mark **Relative**, it indents the current level relative to the previous level in the list hierarchy.
- In **Width of numbering** space – Enter the amount of space to leave between the left edge of the numbering symbol and the left edge of the text. Set the size you want.
- In **Numbering alignment** space – Set the alignment of the numbering symbols. Select “Left” to align the numbering symbol to start directly at the “Aligned at” position. Select “Right” to align the symbol to end directly before the “Aligned at” position. Select “Centered” to center the symbol around the “Aligned at” position.
- When you hit **Default** it resets the indent and the spacing values to the default values according to the Master.
Work with Tables in Presentations

To create tables in presentations, you have to understand the terms outlined in Module 2 and 3, viz. rows and columns.

Create a Table Slide, Enter and Edit Text

To create a table slide, change the layout of an empty slide to a Table Slide.

Double click in the Table Box to add a spreadsheet.

A spreadsheet appears on the Table Box. Enter your text in the different rows and columns. You can format the text, adjust the column width and row height as you have learned in Module 3. You can also insert formulas, exactly as in a spreadsheet.

Remember to adjust the size of your text so that it is clearly visible on the slide.
When you are finished, just click on the slide outside the spreadsheet.

<table>
<thead>
<tr>
<th>Rainfall for November</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Week</strong></td>
</tr>
<tr>
<td>Week 1</td>
</tr>
<tr>
<td>Week 2</td>
</tr>
<tr>
<td>Week 3</td>
</tr>
<tr>
<td>Week 4</td>
</tr>
<tr>
<td><strong>Total</strong></td>
</tr>
</tbody>
</table>

To return to the spreadsheet, double click inside the table.

When practicing the above, ensure that you are able to:

- open a table slide
- activate the spreadsheet
- enter and edit text
- select rows, columns and the entire table
- insert and delete rows and columns
- change the column width and row height
- adjust the font size and appearance (bold, italic, colour, different font)
- change the background colour of some cells
- change the alignment of text in cells (left, right, center)
- wrap text in a cell
- insert borders in your table
- deactivate the spreadsheet
- modify text in the table after you have deactivated the spreadsheet

**Insert a Table in a Slide, Enter and Edit Text**

You can also insert a table on a blank slide by:

1. Choose **Insert→Table** on the menu bar.
2. Enter the number of columns and rows of your table and hit **OK**.
3. A **Table Box** appears in the slide.

![Table Box](image)

4. You are now able to enter and format text as above.

**Note:** This way does not have the flexibility of a spreadsheet (e.g. formulas) and can be limiting. An advantage of this way is that you can resize the table by grabbing the handles on the perimeter of the Table Box.

**Self Assessment**

You have to develop a slide on the attendance by gender for monthly courses.

Start by developing the following table of half year training statistics on a slide.

<table>
<thead>
<tr>
<th>Months</th>
<th>Females</th>
<th>Males</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>January</td>
<td>10</td>
<td>12</td>
<td>22</td>
</tr>
<tr>
<td>February</td>
<td>21</td>
<td>13</td>
<td>34</td>
</tr>
<tr>
<td>March</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>April</td>
<td>12</td>
<td>6</td>
<td>18</td>
</tr>
<tr>
<td>May</td>
<td>10</td>
<td>9</td>
<td>19</td>
</tr>
<tr>
<td>June</td>
<td>8</td>
<td>4</td>
<td>12</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td><strong>Use a formulae</strong></td>
<td><strong>Use a formulae</strong></td>
<td><strong>Use a formulae</strong></td>
</tr>
</tbody>
</table>

Format the table as shown below. Do not enter the totals, use formulae. Resize the table so that it fits the whole slide as shown below.

![Course Attendance by Gender](image)
Summary

In this section you have worked with and formatted text. You have to ensure that you are confident in working with lists and tables in your presentations.

By now you must be able to:

- use standard and outline view to enter text
- edit, copy, move, delete text within and between presentations
- use the undo, redo command
- apply and change formatting of text
- edit bullet and numbered lists
- create, populate and format a table slide
Working with Charts

Section Overview

As we have learnt in the first section of this module, it is very good to use charts and graphical representation of data in slides.

As with tables you can both insert Charts and import Charts from Spreadsheets.

By the end of this section, you will be able to:

- input data to create built-in charts in a presentation: column, bar, line, pie
- change the chart type
- add data labels to a chart
- change colours of a chart

Inserting Charts

A chart is a type of information/data graphic or graphic organiser that represents tabular numeric data and/or functions.

Charts are often used to visually represent large quantities of data and the relationship between different parts of the data for ease of understanding.

Charts can usually be read more quickly than the raw data that they come from.

Charts add visual interest and useful information represented by lines, bars, pie slices, or other markers.

Understanding the Different Chart Types

Impress allows you to create many different kinds of charts to visually accent data.

Column Chart

A column chart uses vertical bars or columns to display values over different categories. This chart shows variation in value over time.
Bar Chart

A bar chart is similar to a column chart except these use horizontal instead of vertical bars. Like the column chart, the bar chart shows variation in value over time.

Pie Chart

A pie chart displays the contribution of each value to the total. Pie charts are a very effective way to display information when you want to represent different parts of the whole, or the percentages of a total.

Area Chart

An area chart emphasises the trend of each value over time. An area chart also shows the relationship of parts to a whole.

Line Chart

A line chart shows trends and variations in data over time. A line chart displays a series of points that can be connected.

Other Charts

Some of the other charts that you can create in Impress include XY Chart, Net chart, Stock chart, Line (3D) chart, Area (3D) chart, Bar (3D) chart, Column (3D) chart, and Pie (3D) charts.
Identifying the Parts of a Chart

Have you ever read something you didn’t fully understand but when you saw that same information in a chart or graph, the concept became clear and understandable? Charts make it easy to see comparisons, patterns, and trends in the data.

Data Source

The Data source of a chart is a table containing data (text or numbers). The chart is updated automatically whenever the information in the table changes.

Title

The title of the chart.

Legend

The chart key lists each colour used in the chart and identifies what that colour represents on the chart.

Axis

The vertical and horizontal parts of a chart. The vertical axis is often referred to as the Y-axis, and the horizontal axis is referred to as the X-axis.

Data Series

The actual charted values, usually rows or columns, of the source data.

Value Axis

The axis that represents the values or units of the source data.

Category Axis

The axis identifies each data series.
Inserting a Simple Chart

Start on a new slide.

1. In the Layout pane, click any of the 3 layouts that contain a chart.

2. Double click on the Add Chart Icon to add a chart. A Chart Box appears with the default chart displayed in it.

3. First you have to develop your Data Source (Data Table). Right-click on the chart. In the menu, click Chart Data Table.

4. Enter the information from the table in the datasheet provide. Use the buttons on the top to add and delete rows and columns.
5. Enter the data as in the table below.

<table>
<thead>
<tr>
<th>Categories</th>
<th>Values 1</th>
<th>Values 2</th>
<th>Values 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Week 1</td>
<td>24</td>
<td>23</td>
<td>36</td>
</tr>
<tr>
<td>Week 2</td>
<td>25</td>
<td>20</td>
<td>25</td>
</tr>
<tr>
<td>Week 3</td>
<td>36</td>
<td>31</td>
<td>40</td>
</tr>
<tr>
<td>Week 4</td>
<td>152</td>
<td>37</td>
<td>60</td>
</tr>
</tbody>
</table>

6. Close the data source by clicking on the 

7. The chart is now updated with the information in your data source (table).

Changing the Chart Display

When you double click on the Chart Box a formatting toolbar appears.

1. With the first button you can change the chart type.

2. The second button allows you to go back to your data source (table).

3. The third button (horizontal grid on/off), allows you to remove the horizontal lines in the chart.
4. The fourth button allows you to remove the legend on the side.

You can also insert a chart by choosing Insert ➔ Chart.

Changing the Chart Title, Appearance of the Axes, Grids, Legend and Data Labels

With Impress, you can add and change a chart title, change the appearances of the axes, grids, legend and data labels.

Insert and Change Chart Title and Axes Labels

To insert a Chart Title, choose Insert ➔ Title. You can type in a title, subtitle and labels for the axes.

When hitting OK, your chart will look like this:

You can change the Chart Title at any time to accurately represent the data that is in your chart. To change the chart title on the chart:

1. Display the slide that contains the chart that you want to edit.
2. Double-click the chart to select it for editing.
3. Double-click the Chart Title to select it for editing and change the content.
4. Click anywhere outside of the title to apply your changes.
Change Appearance of Axes

You can also change the appearance of the axes by \textbf{Insert $\rightarrow$ Axes}. If you untick one of the axes, the axis will not appear on your chart.

Change Appearance of Grids

You can also change the appearance of the grids by \textbf{Insert $\rightarrow$ Grids}. You can tick if you want horizontal and/or vertical gridlines to appear on your chart.

Major grids are gridlines with big intervals and minor grids are gridlines with small intervals (more gridlines appear on your chart).

Change Appearance of Legend

You can also change the appearance of the legend by \textbf{Insert $\rightarrow$ Legend}. You can tick if you want a legend or not, and then you can place it at the top, left, bottom or right of the chart.

You can also change the size of a legend or move it around by clicking on the legend.

\begin{itemize}
  \item \textbf{Numbers}
  \begin{itemize}
    \item Week 1
    \item Week 2
    \item Week 3
    \item Week 4
  \end{itemize}

  \begin{itemize}
    \item Year 1
    \item Year 2
    \item Year 3
  \end{itemize}

\end{itemize}

Insert and Change the Appearance of Data Labels

Sometimes a chart needs exact value of the data displayed. That is called data labels. You can insert data labels by \textbf{Insert $\rightarrow$ Data Labels}. You can tick if you want the data label as:

- Numbers

- Percentage
Changing the Background Colour of a Chart

The default white background can be too bright for a presentation and you might want to change the background colour of the chart.

1. Activate the Chart Box by double clicking on the chart.
2. Click on the background of the chart to mark the background.
3. Right click, choose object properties.
4. Ensure that the words **Chart Wall** appear on the top of the menu. Choose **Area** and choose from the drop-down menu how the background colour.
background of your chart must look. You can choose, colour, gradient, hatching or bitmap (see the difference on pages 30–31).

Remember the rule of backgrounds – it must not be too busy or too dark to distract the message of your chart.

**Importing Charts and Tables from a Spreadsheet**

We went through the process of creating tables and charts in your presentation. We are now moving a step further and import already created files into our presentation. For this, we will use OpenOffice.org Calc.

As you may be aware of by now, spreadsheets have better and more versatile mechanism of managing and presenting more complex data. All this data might not fit or serve the purpose of a presentation.

**Inserting a new Spreadsheet: A Recap**

You can add a blank OpenOffice.org Calc spreadsheet to a slide as an Object Linking and Embedding (OLE) object. That means that you will have a Calc document within your Impress document.

1. Go to the slide where you want to insert the spreadsheet.
2. Do one of the following:
   - Insert a spreadsheet as an OLE Object:
     - Choose **Insert** ➔ **Object** ➔ **OLE Object** ➔ **Create new** ➔ **OpenOffice.org 3.1 Spreadsheet**.
     - Hit **OK**. An empty spreadsheet will appear on your slide.
   - Make the spreadsheet bigger by grabbing and pulling the corner handles around the spreadsheet.
• Click in the spreadsheet to enter and format your data (see page 59-60).

Insert a spreadsheet through the Layout pane:

• Open the Layout pane, and double-click the table layout.

• Follow the instructions on page 59-60.

3. To resize the table select the object in the slide (not the spreadsheet) and then drag a corner handles.
4. To resize the cells of the spreadsheet, double-click to get into the spreadsheet, and then resize the cells (column width and row height).

**Inserting Spreadsheets from a File**

When you insert an existing spreadsheet into your slide, changes that are made to the original spreadsheet file are not updated on your slide. You can, however, make changes to the spreadsheet in your slide.

1. Go to the slide where you want to insert the spreadsheet.
2. Choose **Insert**→**Object**→**OLE Object**→**Create from file**

3. Locate the file you want to insert, and then click **OK**.

The entire spreadsheet is inserted into your slide. If you want to change the sheet that is displayed, double-click the spreadsheet, and then select a different sheet.

**Summary**

In this section you have learnt how to use charts and graphical representation of data in slides.

You are now able to:

• input data to create built-in charts in a presentation: column, bar, line, pie
• change the chart type
• add data labels to a chart
• change colours of a chart
Working with Graphics

Section Overview

“A picture is worth a thousand words”.

Pictures and images present information in a format that is easy to understand and can be visualised. In short, it adds value to your presentation and makes it look more appealing than using just text!

By the end of this section, you will be able to:

- insert a graphical object into a slide
- edit a graphical object in a slide
- copy, move and delete a graphical object in a presentation and between presentations
- apply drawing tools to create images

What is a Graphical Object?

A graphical object can be:

- picture, image, drawn object or photo stored in a file (.jpeg, .bmp, .gif, .tiff)
- Clip Art (refers to pre-made images stored in a gallery in a program)
- drawing – graphical shapes such as a rectangle, oval, arrow or stars.

To edit the detail in a graphic, e.g. to take out parts of a photo or to manipulate a photo, is normally done by Graphic Programs such as Photoshop or GIMP (GNU Image Manipulation Program). GIMP is a free software raster graphics editor. Primarily, GIMP is used as a tool for photo manipulations, such as resizing, editing, and cropping photos, combining multiple images, and converting between different image formats.

You can however manipulate graphics to a certain extent with an Office Application such as Impress.

Inserting Clip Art

Using the Gallery

First locate the Drawing Toolbar on your desktop. You will use it extensively in this section.

The drawing toolbar can be located in a floating panel or on the top or bottom of the Impress screen.
To view the Drawing toolbar, choose View→Toolbars→Drawing.

There are a number of ways of accessing the Gallery in Open Office Impress.

To insert Clip Art from the Gallery:
- Go to the relevant slide.
- Choose Tools→Gallery.

or:
- Click on the Gallery icon 📚.

The Gallery window is displayed with a number of coloured graphics (pictures).

On the left side of the Gallery window are the words, Backgrounds, Bullets, etc. These words are the names of different Themes. You will find that there are many images in your My Theme tab. (If no images are displayed, please refer to the Install section at the beginning of this course.)

To use an image, drag and drop it to your Workspace on the slide.
Inserting an Image from File

You can also add your own images into your presentation. Impress offers a number of ways to insert an image from file.

Using the Layout Template

If you have already saved the picture, and you would like to insert it, you can use the layout template. On your Task Pane, select on the Layout one of the layouts showing an image.

Double click on the image place holder for a file system browser to pop up as shown. Browse to the location of your image and select the image by hitting Open.

The image selected will be inserted to the slide as shown below.

Remember you can get rid of the bulleted text boxes by deleting them and resize the image.
Using the Menu

If you have already saved the picture, and you would like to insert, go to Insert → Picture → From File.

Browse to the location of your picture. Select your file, and click “Insert”. Your picture will appear on the current slide.

Copying from another Application or File

Images can also be pasted into your Impress presentation. If you have an image within another source, copy the image from the original source. Go to your current application and paste the art work into your presentation (See page 49 – 51).

Pasting from GIMP

If you have your image open in your graphics editor of choice, in this case GIMP, you can copy the image and paste it directly onto your slide.

First go GIMP. In GIMP, there are a number of ways of copying an image or sections of an image. One of them is, with your image open, Right-click → Edit → Copy as shown below.
With your image on the clipboard, go to the slide where you would like to past it and right-click on the slide and click on Paste.

The image will appear on the slide as shown below.

Moving Graphics

Using the Mouse

1. Click on the graphic/picture/image. The mouse pointer turns into a four-way arrow like this.

2. Click on the picture and drag it to the desired place on your page.

Using the Position and Size Window

1. In the dialog box on the Position you can alter the position by typing in numbers in the width and height, or using the slide (up and down allows).
2. Click the OK button (The picture changes location).
Resizing Graphics

There are two ways of resizing a graphic/picture/image.

Using the Mouse

1. Click on the picture and eight points (green squares), called handles, will appear along the sides of the picture as shown in the figure above.
2. Place your pointer on any of the points. Click and drag the mouse to modify the picture (A double-headed arrow in the directions shown below will appear).
3. To keep the proportions of the graphic, press and hold the Shift key. Click and drag a handle of the picture. Release the mouse button to complete the resize.
4. When you have changed the picture to the desired size, click anywhere on the page except on the picture.

Using the Position and Size Window

1. Right-click anywhere on the picture. (A menu appears)

2. Click Position and Size. (The Position and Size window appears)

3. On the Size, you can alter the size by typing in numbers in the width and height, or using the slide (up and down allows). To keep the dimensions of the image, check the Keep ratio.
Rotate Graphics

You can rotate graphics (put it at an angle for example) using the Format menu:

- Choose **Format ➔ Position and Size**
- Click on the **Rotation** tab in the Position and Size dialogue box
- Adjust the Rotation angle spin window or
- Click on one of the Default settings
- Click **OK**

Result:

![Image of rotated graphic](image)

You can also use the icon on the drawing toolbar. The handles turn to red and the centre of rotation is marked.

![Image of icon and handles](image)

When you hover the mouse over one of the red dots you will see a rotation signal over the handle. Pull on the handles to rotate the graphic.

Flip Graphics

You can flip graphics (mirror images sideways or downwards) by right clicking on the image:

- Choose **Flip**
- Choose **Horizontally** or **Vertically**

Vertically means flip the selected object(s) vertically from top to bottom.
Horizontally means flip the selected object(s) horizontally from left to right.

You can also flip an image by pulling the handles past the image. It will flip in the direction you have pulled it.

**Align Graphics**

You are also able to align graphics on the slide viz. left, center, right and top, center, bottom. Right click on the image:

- Choose **Alignment**
- Choose **left, center, right** and **top, center, bottom**

You can also make use of the button on the drawing toolbar (activate the dropdown menu to make your choice).

**Changing the Order of Graphics**

Sometimes you want a certain graphic to be in front of another, or in front of text.

For example, you have the following slide:
By right clicking on the coloured image, choose **Arrange** and look at the options provided.

In this case if you choose **Send Backward**, it will go one layer back.

If you choose **Send to Back**, it will appear at the back of all the images.

You can also make use of the button on the drawing toolbar (activate the dropdown menu to make your choice).

---

**Using the Art Gallery to Draw Objects**

Draw Objects are defined as lines, arrows, block arrows, rectangles, squares, ovals, circles and others. (In this part we will also handle text boxes.)

OpenOffice provides a host of tools that can be used for drawing user defined images.

For example you would like to put a custom process that your learners go through from the time they apply for admission, through to the time they graduate or leave your organisation. While you can draw this process on paper and scan it for eventual migration to your presentation, you can also use the drawing tools provided. This will make your presentation neater and more appealing.
**Know the Drawing Tools**

First locate the drawing toolbar.

If floating it looks like this:

The table below summarises all the frequently used icons.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Click" /></td>
<td>Click this button to then select and move objects on your slide.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Allows" /></td>
<td>Allows you to draw lines by clicking and dragging on your slide.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Allows" /></td>
<td>Allows you to draw arrows by clicking and dragging on your slide.</td>
</tr>
<tr>
<td><img src="image4.png" alt="This" /></td>
<td>This tool allows you to insert rectangles and squares.</td>
</tr>
<tr>
<td><img src="image5.png" alt="This" /></td>
<td>This tool allows you to insert ovals and circles.</td>
</tr>
<tr>
<td><img src="image6.png" alt="This" /></td>
<td>This tool inserts a text box in which you can type an unlimited amount of text in your presentation. You do this by clicking this tool and then clicking in your slide.</td>
</tr>
<tr>
<td><img src="image7.png" alt="This" /></td>
<td>This tool allows you to draw lines or curves. The dropdown arrow on the right of the graphic gives additional options.</td>
</tr>
<tr>
<td><img src="image8.png" alt="This" /></td>
<td>This tool allows you to connect graphics to create flow charts or diagrams.</td>
</tr>
<tr>
<td><img src="image9.png" alt="This" /></td>
<td>This tool gives you the option to insert pre-designed shapes such as diamonds, pentagons and cylinders. Note the dropdown arrow on the right of the graphic that gives additional options.</td>
</tr>
<tr>
<td><img src="image10.png" alt="This" /></td>
<td>This tool gives the option to insert pre-designed fun shapes such as hearts or happy faces. Note the dropdown arrow on the right of the graphic that gives additional options.</td>
</tr>
<tr>
<td><img src="image11.png" alt="This" /></td>
<td>This tool allows you to insert block shaped arrows. Note the dropdown arrow on the right of the graphic that gives additional options.</td>
</tr>
<tr>
<td><img src="image12.png" alt="This" /></td>
<td>This tool allows you to insert flowchart shapes. Note the dropdown arrow on the right of the graphic that gives additional options.</td>
</tr>
<tr>
<td><img src="image13.png" alt="This" /></td>
<td>This tool allows you to insert callouts. Note the dropdown arrow on the right of the graphic that gives additional options.</td>
</tr>
<tr>
<td><img src="image14.png" alt="This" /></td>
<td>This tool allows you to insert different star and banner shapes. Note the dropdown arrow on the right of the graphic that gives additional options.</td>
</tr>
<tr>
<td><img src="image15.png" alt="This" /></td>
<td>This tool allows you to change the size of points on a vector-created image. Click on the image and then click on a handle box. Drag the handle box to a different location to edit the vector-based image.</td>
</tr>
<tr>
<td><img src="image16.png" alt="This" /></td>
<td>This tool displays the points on a custom-drawn object. Click once on the object to select, then click on the glue point icon to display points on the object. The glue points can then selected and moved to alter the image.</td>
</tr>
<tr>
<td><img src="image17.png" alt="This" /></td>
<td>This tool gives you some dramatic, pre-designed styles for formatting your text called the Fontwork Gallery.</td>
</tr>
<tr>
<td><img src="image18.png" alt="This" /></td>
<td>This tool allows you insert pictures from file.</td>
</tr>
<tr>
<td><img src="image19.png" alt="This" /></td>
<td>This tool opens a gallery of images, sounds, bullets, web page icons, and rule dividers that can be inserted into a presentation for sound and graphic appeal.</td>
</tr>
<tr>
<td>Icon</td>
<td>Name</td>
</tr>
<tr>
<td>------</td>
<td>------</td>
</tr>
<tr>
<td><img src="image1.png" alt="Icon" /></td>
<td>Line</td>
</tr>
<tr>
<td><img src="image2.png" alt="Icon" /></td>
<td>Arrow Style</td>
</tr>
<tr>
<td><img src="image3.png" alt="Icon" /></td>
<td>Line Style</td>
</tr>
<tr>
<td><img src="image4.png" alt="Icon" /></td>
<td>Line Width</td>
</tr>
</tbody>
</table>

You also have to locate the **Line and Filling** Toolbar on your desktop. You will use it extensively in this section.

The **Line and Filling** toolbar can be located in a floating panel or on the top or the bottom of the Impress screen.

To view the **Line and Filling** toolbar, choose **View** → **Toolbars** → **Line and Filling**.
### Using the Drawing Tools

Drawing tools give you a selection of different drawings to use.

**Lines**

You can draw different kinds of lines, arrows, connectors and curves by clicking on the appropriate icon as shown below.

Because a line is a graphic, you can delete, move, copy and paste, resize, rotate, flip, align and change the order of a line by the same ways as discussed on page 77 – 81.

When you click on a connector or curve, it gives you a series of handles to pull to change the appearance of the graphic.

To change the features of the line, arrow, curve or connector, you can click on the icon or right-click and select the same icon:

- Line style, colour, width and transparency
- Arrow styles
- Corner styles
• Shadows

![Drawing tool interface]

Other Drawing Objects

You can draw different kinds of drawings in Impress (Check the dropdown menus under each of the tools).

This tool allows you to insert rectangles and squares. You can:
• delete, move, copy and paste, resize, rotate, flip, align and change the order in the same ways as discussed on page 77 – 81.
• change its lines by the icon, including:
  o line style, line colour, width and transparency
  o corner styles
  o shadows
• change the fill colour, gradient, and texture by the area icon or right click on the drawing and choose Area,
• add text to the shape by clicking on the shape and choose icon. You can format the text as you have done before (size, bold, italics, underline, alignment, etc). Then you can further change the format of the text by right clicking on the shape and choose the different options.

This tool allows you to insert ovals and circles. You can:
• delete, move, copy and paste, resize, rotate, flip, align and change the order in the same ways as discussed on page 77 – 81.
• change its lines by the icon, including
  o line style, line colour, width and transparency
  o corner styles
  o shadows
• change the fill colour, gradient, and texture by the area icon or right click on the drawing and choose Area,
• add text to the shape by clicking on the shape and choose icon. You can format the text as you have done before (size, bold, italics, underline, alignment, etc). Then you can further change the format of the text by right clicking on the shape and choose the different options.

This tool gives you the option to insert pre-designed shapes such as diamonds, pentagons and cylinders. Note the dropdown arrow on the right of the graphic that gives additional options.

You can:
- delete, move, copy and paste, resize, rotate, flip, align and change the order in the same ways as discussed on page 77 – 81.
- change its lines by the icon, including
  o line style, line colour, width and transparency
  o corner styles
  o shadows
- change the fill colour, gradient, and texture by the area icon or right click on the drawing and choose **Area.**
- add text to the shape by clicking on the shape and choose icon. You can format the text as you have done before (size, bold, italics, underline, alignment, etc). Then you can further change the format of the text by right clicking on the shape and choose the different options.

This tool gives the option to insert pre-designed fun shapes such as hearts or happy faces. Note the dropdown arrow on the right of the graphic that gives additional options.

You can:
- delete, move, copy and paste, resize, rotate, flip, align and change the order in the same ways as discussed on page 77 – 81.
- change its lines by the icon, including
  o line style, line colour, width and transparency
  o corner styles
  o shadows
- change the fill colour, gradient, and texture by the area icon or right click on the drawing and choose **Area.**
- add text to the shape by clicking on the shape and choose icon. You can format the text as you have done before (size, bold, italics, underline, alignment, etc). Then you can further change the format of the text by right clicking on the shape and choose the different options.

This tool allows you to insert block shaped arrows. Note the dropdown arrow on the right of the graphic that gives additional options.

You can:
- delete, move, copy and paste, resize, rotate, flip, align and change the order in the same ways as discussed on page 77 – 81.
- change its lines by the icon, including
  o line style, line colour, width and transparency
  o corner styles
  o shadows
- change the fill colour, gradient, and texture by the area icon or right click on the drawing and choose **Area.**
- add text to the shape by clicking on the shape and choose icon. You can format the text as you have done before (size, bold, italics, underline, alignment, etc). Then you can further change the format of the text by right clicking on the shape and choose the different options.
This tool allows you to insert flowchart shapes. Note the dropdown arrow on the right of the graphic that gives additional options.

You can:
- delete, move, copy and paste, resize, rotate, flip, align and change the order in the same ways as discussed on page 77 – 81.
- change its lines by the icon, including
  - line style, line colour, width and transparency
  - corner styles
  - shadows
- change the fill colour, gradient, and texture by the area icon or right click on the drawing and choose Area.
- add text to the shape by clicking on the shape and choose icon. You can format the text as you have done before (size, bold, italics, underline, alignment, etc). Then you can further change the format of the text by right clicking on the shape and choose the different options.

This tool allows you to insert callouts. Note the dropdown arrow on the right of the graphic that gives additional options.

You can:
- delete, move, copy and paste, resize, rotate, flip, align and change the order in the same ways as discussed on page 77 – 81.
- change its lines by the icon, including
  - line style, line colour, width and transparency
  - corner styles
  - shadows
- change the fill colour, gradient, and texture by the area icon or right click on the drawing and choose Area.
- add text to the shape by clicking on the shape and choose icon. You can format the text as you have done before (size, bold, italics, underline, alignment, etc). Then you can further change the format of the text by right clicking on the shape and choose the different options.

This tool allows you to insert different star and banner shapes. Note the dropdown arrow on the right of the graphic that gives additional options.

You can:
- delete, move, copy and paste, resize, rotate, flip, align and change the order in the same ways as discussed on page 77 – 81.
- change its lines by the icon, including
  - line style, line colour, width and transparency
  - corner styles
  - shadows
- change the fill colour, gradient, and texture by the area icon or right click on the drawing and choose Area.
• add text to the shape by clicking on the shape and choose icon. You can format the text as you have done before (size, bold, italics, underline, alignment, etc). Then you can further change the format of the text by right clicking on the shape and choose the different options.

You can combine any graphics and drawings on a slide. An example is a slide depicting how a news event flows in a Newspaper Firm from the time it is gathered, to the time it is published.

The process the slide wants to show is:

1. Call is received at the News hotline.
2. A journalist is dispatched to the scene.
3. Journalist collects all the information which involves:
   1. Taking pictures.
   2. Interviewing people around the scene.
4. Journalist gets back to the workstation and types the story.
5. Journalist forwards the story to the editorial team.
6. Editorial team:
   1. Proofreads the story.
   2. Does research on similar incidents that can enrich the story.
7. Editorial team:
   1. Rewrites the story with all the new and necessary information; or
   2. Sends it back to journalist for corrections or updates.
8. The story is sent to the desktop publishers who do the type-setting.
9. The story is printed.

For this purpose, the flowchart shapes would be the best.
The slide can look like this:

```
Call Received -> Gather Information -> Info Complete

Info Complete -> Forward to Editors -> Type Story

Research -> Rewrite Story -> Proofread -> Publish

Article Published
```

We have made use of the convention used in flow diagrams (often in IT).

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Name of Symbol</th>
<th>Description</th>
<th>Steps/stages</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Terminator</td>
<td>Terminators show the start and stop points in a process. When used as a</td>
<td>• call received&lt;br&gt;• story published</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Start symbol, terminators depict a trigger action that sets the process flow</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>into motion.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Process</td>
<td>Show a Process or action step.</td>
<td>• Interview&lt;br&gt;• Type&lt;br&gt;• Proofread&lt;br&gt;• Research&lt;br&gt;• Rewrite&lt;br&gt;• Publish</td>
</tr>
<tr>
<td></td>
<td>Decision</td>
<td>Indicates a question or branch in the process flow. Typically, a Decision</td>
<td>• Decision to send back to the journalist or go on with publishing</td>
</tr>
<tr>
<td></td>
<td></td>
<td>flowchart shape is used when there are 2 options (Yes/No, No/No-Go, etc.)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Connector</td>
<td>Shows a jump from one point in the process flow to another</td>
<td>• Connecting the processes, decisions, and Terminators</td>
</tr>
</tbody>
</table>

To join, we used the arrow and connector tools to join the various workflow elements. We used a colour legend for the arrows for the decision shapes. A green for the right to go ahead, and red for the task to go back or to be rectified.
The result is much more visual, descriptive and would look much better and will be more effective when showing to an audience than using the words.

**Working with a Group of Objects (images/pictures/graphics/drawings)**

**Move/Delete/Copy a Selection of Objects**

Sometimes you want to move/delete/copy a selection of objects. It can be quite a task to move them individually.

Use the select icon and select all the objects by drawing a rectangle around it. You can also click on one, hold down the **Shift** button and click on the next one. Continue until you have selected all the objects you want to move/delete/copy.

To move the selection hold down the **Ctrl** key and move the selection with your mouse.

To copy and paste the selection:

- Hold down the **Ctrl** key and click on the selection with your mouse.
- Without releasing the **Ctrl** key or the mouse, press down the **Alt** key and drag the selection.

You can also use any of the other means to copy/move.

To delete, hold down to **Ctrl** key and press the **Delete** button.

**Group and Ungroup a Selection of Objects**

If you have created a big image by using different objects, as shown on page 89, it would be much easier if you can handle them as one object. You can then move/copy it much easier than the individual parts of the image. We call this **Grouping**.

You can therefore combine several objects into a group so that they act as a single object. You can move and transform all objects in a group as a single unit. You can also change the properties such as line size or fill colour of all objects in a group as a whole or for individual objects in a group.

When objects are grouped, it acts as one object until it is ungrouped through a menu command.

For example when you are designing a logo, you can group all of the objects in the logo to move and resize the logo as a single object.
To group objects:

1. Select the object using the select icon and select all the objects by drawing a rectangle around it. You can also click on one, hold down the Shift button and click on the next one. Continue until you have selected all the objects you want to group.

2. Right click and choose Group.

Immediately the individually selected objects are handled as one image.

3. After you have grouped objects, selecting any part of the group selects the entire group.

You can select single objects in a group by entering the group. Double-click a group to enter it and click on the object to select it.

You can also add or delete objects to and from a group in this mode. The objects that are not part of the group are greyed out.

To ungroup, click on the group, right-click and choose Ungroup.

ALWAYS REMEMBER
LESS IS MORE
DO NOT OVERDO GRAPHICS

Summary
You are now able to:

- insert a graphical object into a slide
- edit a graphical object in a slide
- copy, move and delete a graphical object in a presentation and between presentations
- apply drawing tools to create images

Through completing this section you can now appreciate the value that graphics give to your presentation and how graphics can make it look more appealing than using just text.
Preparing for Output

Section Overview

How to present the BEST PRESENTATION!

This must be your motto – always the best!

We are going to look at how to finish off a presentation – set timings and transitions of slide. You are also going to look at animation on a slide. Finally, it is important to give the audience a printed copy of your slides.

By the end of this section you will be able to:

• check your slides for spelling errors
• set and change slide show timings
• create and change slide transitions
• hide and unhide some slides
• add animation effects to text and objects
• print a completed presentation
• add presenter notes to slides
• preview slides
• run the slide show

Check your Spelling

Spelling errors have a negative effect on the way an audience perceives the presentation.

There is just one rule: **NO SPELLING ERRORS!**

Impress assists you by identifying spelling errors by red underlining:

There is nothing so distracting as spelling errors on a slide.

To check your spelling:

1. Choose **Tools**→**Spelling**.
2. The following screen assist you to correct your identified spelling errors:
• You can:
  o **Ignore Once** – will ignore only this occurrence of the word
  o **Ignore All** – will ignore all the words in this document with the same spelling
  o **Add** – Add this word to your Dictionary. That means that this word will not be identified as a spelling error in future. Be careful in using this option, because if you add a wrongly spelled word, it will not be identified in future
  o **Change** – Change the spelling in this case to the suggestion you have identified/highlighted in the space
  o **Change All** – Change all the occurrences of the word in the document

Just remember, Impress will not identify if you have entered **from** instead of **form**. Both are spelled correctly.

**Tip:**
First run a spell check and then read carefully through your presentation to check for typos and misspelled words (has/had; from/form; like/life etc.)

---

**Preparing your Presentation**

You have now carefully constructed each slide in your presentation. The contents are clear, well presented with effective graphics to enhance key points. A very important step is now to prepare your slides for the presentation.

**Slide Transitions**

This will include:

• Take a good look at your slides and decide if you are going to present your slides by manually clicking or pressing the down-arrow or are you going to show your presentation with continuous running of the slides. Although the first one is always preferred by presenters, the second one can very effective when a presenter uses the presentation to create a certain mood, or when the presenter uses music to enhance the presentation. This is called **TIMING**.

• Decide further if there need to have transition effects between slides. This is called **TRANSITION**. That means that the slides are not just appearing, but have some pattern in the transition. This can be like wiping the slide off the screen to reveal another, reveal the next slide through a circle, dissolve, fade or split a slide to reveal another, to name a few. You also have to decide on the speed of this transition. The golden rule, again, is not to use too many different/complex transitions. Keep it simple not to distract the attention from the content of the presentation.
Slide Show Transitions

Many presentations contain slides that supplement a given talk. A slide is displayed and the presenter speaks to its main points. In this type of presentation, slides are usually manually advanced by the presenter only after the discussion of a slide has been exhausted and the presenter is ready to advance to the next slide. The default setting for an Impress Presentation is manual and you do not need to change anything when you want to use it.

In the event you want to automate your presentation, you do not want to manually advance to the next slide but instead want the next slide to dynamically appear after a length of time, Impress provides the ability to test rehearse timings for automatic slide changes.

To Set Automatic Timings in a Presentation

1. Activate the Slide Transition menu in the Task pane.

2. Go to the Advance Slide section in the menu and click on the Automatically after radio button. Type in the time on each slide and Apply to All Slides.

3. If you want only the one slide to automatically advance, press Play button.

To Rehearse Slide Show Timings

When you rehearse timings in Impress a small floating clock window records the amount of time a slide is displayed.

During the rehearsal you could practice your speech and note the length of time during which the slide needs to remain displayed until you’re finished talking. Make a printout of the slides and note the time on each slide.
To add the timing:

1. Choose Slide Show  Rehearse Timings from the menu bar.

2. Watch the floating clock window and record the length of time you want the current slide displayed in the presentation.
3. Click the left mouse button or press the Enter key to advance and time the next slide and record the timings for that slide.
4. Press the ESC key at any time to stop the Rehearse Timings clock and return to the presentation.

Setting the Duration Each Slide is Displayed

Armed with the rehearsal timings for each slide, you can then assign the timed durations to each slide in the presentation. A slide will automatically advance to the next slide based on the settings you define.

To Define Slide Duration Timings:

1. Start on the first slide. Choose Slide Show  Slide Transition from the menu bar.

2. The Slide Transition menu is displayed in the Task pane.
3. At the bottom on the Advance Slide section, click on Automatically After and enter the time as determined in your rehearsal.
4. Move to the next slide and repeat until you reached the end of your presentation.
5. You can now hit Play to check your timings.

**Defining Slide Show Settings**

Every Impress slide is governed by slide show settings, including which slide to start from, the way you advance the slides, the type of presentation, and pointer options. These settings can be changed to suit your unique presentation.

To Define Slide Show Settings:

1. Choose Slide Show ➔ Slide Show Settings from the menu bar.

2. The Slide Show dialogue box is displayed.

3. In the Range area, specify which slides are to be included in the presentation:
   - **All slides** – includes all of the slides in your slide show.
   - **From:** – define the slide number of the start slide.
   - **Custom Slide Show** – runs a custom slide show in the order that you defined in Slide Show.
4. Customise the slide show by selecting the slide show Type:
   - **Default** – a full screen slide is shown.
   - **Window** – slide show runs in the Impress program window.
   - **Auto** – define the duration of the pause before the slide show is repeated. If you enter zero, the show restarts immediately without showing a pause slide.

5. Click to insert a checkmark next to any other Options to be applied to the presentation:
   - **Change slides manually** – slides never change automatically when this box is selected. The settings, as seen in the Transition box in the Object bar, will not apply.
   - **Mouse pointer visible** – shows the mouse pointer during a slide show.
   - **Mouse pointer as pen** – changes the mouse pointer to a pen which you can use to draw on slides during the presentation.
   - **Navigator visible** – displays the Navigator during the slide show.
   - **Animations allowed** – runs animations during the slide show. If this option is not selected, only the first frame of an animation is displayed.
   - **Change slides by clicking on background** – advances to the next slide when you click on the background of a slide.
   - **Presentation always on top** – Impress remains on top during the presentation. No other program will show its window in front of your presentation.

6. Click the **OK** button to apply and save the definitions.

**Slide Show Transitions**

Once you’ve completed all of your slides, you can define slide show transitions that move from slide to slide with interesting transitions that affect the timing, entrance and exit of your slides. A transition is an effect that is applied to some or all of the slides in a presentation.

To create slide transitions:

1. Choose **Slide Show ➔ Slide Transition** from the menu bar.
The Slide Transition menu is displayed in the Task pane.

2. In the effects menu scroll up and down through the selection, select one of the transition effects available for use for the slide. Effects include Fade, Fly in, Uncover, Spilt, Diagonal, Spiral and other.

3. Choose the speed of transition under Modify transition.

4. Choose Sound. Remember, sound can be the single most distracting factor in a presentation. Only choose when 100% necessary.

5. You can do this for each separate slide (have different transitions) or press the Apply to All Slides button to apply to all slides.

Removing Transition Effects

To remove transition effects, you can reverse the above actions and choose No transition in the Slide Transition menu in the Task pane.

Animation Effects on Text and Objects

Where TRANSITION is the movement BETWEEN slides, ANIMATION is the movement of text and object ON a slide.

You can apply preset animation effects to text and objects on your slide.

The same effects that you can use for slide transitions, you can apply to text and objects on the slide.

To define animation effects on text or an object:

1. On a slide, select the text box or object that you want to animate.
2. Choose Slide Show→Custom Animation.
3. The **Custom Animation** menu opens in the **Task pane**.

![Custom Animation menu](image)

4. Click on **Add** and choose from the box that appears. You can change the entrance of the text/object, if you want to emphasise it, the exit of the text/object, its motion path between entrance and exit and other effects. You can also adjust the speed of the animation.

5. Review the effects that you want to apply to the slide(s). Remember the rule: LESS IS MORE.

6. Click the **OK** button and then the **PLAY** button on the **Task pane** to preview the transition.

**Managing the Order of Animation Effects**

Assuming that you have defined multiple animation effects on one slide, you can manage or define the order in which the different text or objects are animated.

**To change the order of the Animation Effects:**

1. Select the slide with the text/objects that you have animated.
2. Activate the **Custom Animation** menu on the **Task pane**. Each one of the identified animations appears in the window. Every object or text that you animate is listed in the window in the sequence that you initially created them in.
3. Click the text/object you want to change the order of, click on the **Change order** buttons at the bottom to change the order of animation.
4. Click the **Play** button to save the change and check the effects.

### Removing Animation Effects

To remove animation effects, you can reverse the above actions by clicking and deleting the animations from the lists in the **Custom Animation** menu in the Task pane.

![Custom Animation Menu](image)

### Add Presenter Notes to Slides

In the beginning of this module we have introduced you to different views in Impress (Normal, Notes, Handouts) that you can find on the **Page View Buttons**.

If you activate the **Notes Tab**, you will see each slide with a space underneath to enter notes on the above slide or to add speaker notes to the slide. Note that the notes will not appear when viewing the slides, but will only be accessible through the notes page.

![Notes Tab](image)

You can now add notes to the bottom of the slide by clicking on the space. A textbox will be activated. Start entering text. If you are finished, just click outside the textbox.

All the rules for text boxes apply e.g. you can format the text, change the colour or size, insert objects, charts etc.
Changing Slide Orientation and Paper Size in a Presentation

Depending on the view (normal meaning for slides, outline, notes and handout) you are in, you can change the orientation and paper size by:

1. Choose **Format ➔ Page** on the menu bar.
2. Under **Paper Format** you can change:
   - **Format** – format of the paper e.g. letter or A4
   - **Orientation** – Portrait or Landscape (remember it is not good to present a slide show in portrait, but if you want to use only a print presentation, portrait can be useful).

Printing a Presentation

Printing an Impress presentation is much like printing in other OpenOffice.org applications, like Writer or Calc, or even like Microsoft Word or Microsoft Excel. Impress defaults to printing the entire presentation. However, Impress also allows you to print select slides in a presentation.

In the beginning of this module we have introduced you to different views in Impress (Normal, Notes, Handouts). You are able to print in all three formats. Check that you understand the different uses of each.

To print a presentation:

1. Choose **File ➔ Print** from the menu bar.
2. The Print dialog box opens.

   ![Print dialog box](image)

3. Under **Printer**:
   - Specify the printer name where you want to print your presentation.
   - Add a checkmark in the Print to file field only if you are going to print the presentation to a computer file and not to a printer.
4. Under **Print content:**
   a. Select the dropdown menu for **Content**

   ![Print dialog box]

   b. Choose which documents you want to print:
      i. Slides
      ii. Handouts
      iii. Notes
      iv. Outline

5. Under **Print Range**, choose whether you want to print **All pages** or a certain range of **Pages**, where you identify the beginning and ending page numbers, e.g. 4-8.

6. Choose the **Number of Copies** that you want to print by clicking the up or down arrows or entering the number.

7. Click the **OK** button to print the documents you have identified.

Only the area that you define in the print range will print when you send the presentation to the printer for printing.

**Tip:** In the spirit of saving paper, you might instead wish to run Print Preview instead of printing the presentation at the printer. Print Preview provides images of the printed page right on the computer monitor. This could potentially save you a lot of paper. Choose File Print Preview from the menu bar.

---

**Running a Slide Show**

Once you have formatted the presentation the way you like, and after you have timed and defined all of your settings, animations, and transitions, you can run the presentation in Slide Show format.

To run a Slide Show:

1. Click Slide Show on the menu bar.
2. If you have set up the presentation to advance manually, click the mouse, press the **Page Down** button, **down arrow** or press the **Enter** key to advance to the next slide. You can move backward one slide at a time using the **Page Up** button or **up arrow**.

3. Press the **Esc** button at any time to exit the slide show.

| Tip: If you have set the slides to advance automatically (see page 94 - 99), you don’t need to click through the slides. Just sit back and enjoy the show as the slides automatically advance according to the time sequence you have defined. At the end of the show, click the left mouse button to return to Impress. |

### Summary

You know now how to present the BEST PRESENTATION!

You are now able to finish off a presentation. That includes:

- checking your slides for spelling errors
- setting and changing slide show timings
- creating and changing slide transitions
- hiding and unhiding some slides
- adding animation effects to text and objects
- printing a completed presentation
- adding presenter notes to slides
- previewing slides
- running the slide show
Module Overview

Welcome to Module 7: Information and Communication using Firefox and Novell Evolution. This module has two sections. The first is designed to give you an understanding of some of the concepts and terms associated with using the Internet and basic navigation on the World Wide Web. The second section will cover Internet communications. Internet communications can take many forms: e-mail, blogs, wikis, message boards, newswires, and podcasts to name a few.

Upon completion of this module you will:

- Understand the concepts and terms associated with using the Internet.
- Appreciate some of the security considerations.
- Learn how to search and navigate the Web using Firefox browser.
- Gain the ability to bookmark Web sites and print web pages.
- Be able to navigate and complete web-based forms.
- Use the Web for searching and finding information.
- Understand the concepts of electronic mail (e-mail) and appreciate some of the security concerns involved.
- Learn to send and receive messages, and to attach files to e-mail messages.
- Learn to organise and manage messages into mailboxes within the e-mail software Evolution.

Terminology

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>TCP/IP</td>
<td>Transmission Control Protocol / Internet Protocol, The protocol that controls communication across the Internet.</td>
</tr>
<tr>
<td>HTTP</td>
<td>Hypertext Transfer Protocol – the protocol that controls communication across the World Wide Web.</td>
</tr>
<tr>
<td>Internet Backbone</td>
<td>The main links which join continents, countries and major cities.</td>
</tr>
<tr>
<td>HTML</td>
<td>Hypertext Markup Language, a markup language that is used to create web pages.</td>
</tr>
</tbody>
</table>
FTP File Transfer Protocol - protocol required for downloading or uploading files over the Internet.

World Wide Web Part of the Internet that supports the viewing of many types of media, including text, images, audio, video and animation.

Web Pages Web pages are files that contain HTML and other types of content that can be viewed using a Web browser.

Web Browser An application that can interpret Web content and make it viewable on a computer. Examples are Internet Explorer, Mozilla Firefox and Opera.

URL Uniform Resource Locator is a unique address on the Internet for Web content.

Hyperlink A link attached to Web content that directs a Web browser to a URL.

Cache Cache is the name given to memory used for speeding up operations. A web browser uses cache to store web pages that you have accessed in the past.

Cookies Small programs transferred onto your computer when you access certain web sites. Cookies store information that is sent back to the web site when you access it.

Internet Service Provider Special types of businesses whose purpose is to provide links for individuals and small organisations to the Internet.

Digital Certificates A digital certificate is an electronic document that proves the authenticity of a web site.

Digital Encryption Digital encryption refers to the scrambling of data so that it cannot be read without a key.

Preknowledge

We recommend you study Module 1: Concepts of Information Technology before starting Module 7. Module 1 will help you become familiar with many different technology concepts. In particular, you will need to know the sections on Information Networks, IT Use in Everyday Life, and Security.

Note: You should have access to the Internet with Firefox and Novell Evolution installed on your system when attempting the activities in this module.
The Internet

Section Overview

This section focuses on The Internet. After studying this section you will understand the concepts and terms related to the Internet, the security issues for consideration and use of the Firefox browser.

By the end of this section you will:

• understand and distinguish between Internet and the World Wide Web
• understand key terms associated with the Internet
• learn what website security entails, what some of the security threats are, and what solutions are available
• be introduced to online transactions.

Concepts/Terms

The Internet consists of all computers and networks across the world which is able to communicate with each other using telephone, fibre optic, microwave, radio, satellite or any other type of link. The Internet includes private, commercial, government and military computer systems.

Large networks are interconnected with each other through what is called the Internet Backbone. The main links which join continents, countries and major cities are collectively called the Internet Backbone.
Wikipedia gives a graphical representation of the Internet backbone of the world:

Computers on the Internet use specific rules, called protocols that define the procedures for communication. Protocols are programming standards that application developers must follow, and are integral to Internet interoperability. The protocol that controls communication across the Internet is called TCP/IP or Transmission Control Protocol / Internet Protocol.

The World Wide Web, WWW or in short the Web is part of the Internet. What distinguishes the Web is its support of a variety of media, including text, graphics, audio, video, and animation. The Web is a network of servers that store web pages, which can be read by browsers (programmes/applications that are able to read the Web) such as Firefox, Opera or Internet Explorer. Web pages in turn have a specific format known as HTML or Hypertext Markup Language. A browser is an application that is able to read (but not create) web pages.

**Key Terms**

**Protocol**

A protocol is a rule for communication. Communication takes places at several levels.

**TCP/IP**

TCP/IP (Transmission Control Protocol / Internet Protocol) is the protocol that controls the flow of communication. Any specific type of communication that takes place needs additional rules that define how it will take.
HTTP

When HTML pages are transmitted across the Internet, the procedures are defined by another protocol called HTTP or HyperText Transfer Protocol.

FTP

File Transfer Protocol (FTP) is a standard network protocol used to exchange and manipulate files over the Internet.

URL

Each website has a unique address called its URL or Uniform Resource Locator. The URL is also sometimes referred to as a web address. The structure of URLs will be discussed in the next section on page 6. To access a website, you would type its URL into the browser search window and press <Enter> or click the Search button (the green right-facing triangle in the example below).

Hyperlink

Hyperlinks are links attached to text and icons in web pages and documents that enable you to go directly to another places in your document or to other sites without having to type its URL into the search window.

By convention, text which has a hyperlink associated with it is shown in a blue underlined font.

To use a hyperlink, simply click on the text. The browser is able to interpret the hyperlink and locate and display the place/site automatically.

Internet Service Providers

To access the Internet, you need certain things:

- A computer
- A connection to the Web
- Web browser software on your computer
- An account with an Internet Service Provider (ISP).

As an individual, you cannot access the Internet Backbone directly. You need to have a link to an organisation that does. Special types of businesses have arisen whose purpose is to provide links for individuals and small organisations to the Internet. These companies are called Internet Service Providers or ISPs.

In exchange for a fee, they will provide you with a link between your computer and the Internet backbone. ISPs vary in price and quality. Quality in this sense refers to how easy it will be for you to establish a connection and, once connected, how fast that connection will be.
Structure of a Web Address

To find documents on the Web, it must have a unique Web address or a URL. A web address consists of a minimum:

- a protocol
- a server name
- a domain name

Optionally it can have:
- the directory path to a particular web page
- a file name

The simplest form’s full entry will look like the following:

```
protocol server domain
```

```
http://www.amazon.com
```

- The first part http:// indicates that the browser is to use the http protocol. It is also possible to access a site where you can download files using FTP. In this case the entry should like this:

  ftp://svr5.fileaway.co.za

You can type a Web address into a Web browser without typing the protocol, if you do the browser assumes http:// and adds that part of the address as a convenience.

The rest of the address has a number of components separated by periods (full stops). Examples include: www.amazon.com, www.yahoo.co.uk, www.absa.co.za, www.icdlafrica.org, mail.sybaweb.co.za

- The first part is the name of the server, www.

- The part of the name following the server name is known as the domain name. Thus in www.amazon.com, the server www is attached to the domain amazon.com.

  Just as many people have the same name, so do many servers. In fact, most, though not all, servers on the Internet are called www. However, each combination of server and domain must be unique.

- The final part of the domain name is called the top level domain zone. Some top level zones such as .com, .net and .org are international zones as they do not relate to any country in particular.

Sometimes the top level domain zone corresponds to a country. Some examples are: .uk (United Kingdom), .za (South Africa), .ke (Kenya), .au (Australia), .ca (Canada) and .fr (France).

Most organisations in the United States use the international top level zones .com, .org, .net. There are also some newer ones available such as .biz and .info.
Most countries allocated the next level to specific organisations. For example, in South Africa you have .co.za (commercial organisations), .org.za (not-for profit organisations), .ac.za (academic and research institutions) and .gov.za (government departments).

A web site consists of a number of web pages. A web page is an item which is stored under a particular name on the web site. Often you will be required to enter a specific page to find information. Or you have to follow through a path (see module 2) to get to the page. This is called the directory path. For example:

http://www.mybook.co.za/with/thestars can be analysed as:

- http - protocol
- www - server
- mybook.co.za - domain name
- co.za - Top level domain zone telling us it is a commercial website in South Africa
- with/thestars - directory path (go to a folder called with and within it you will find a sub-folder thestars and find a file there)

http://www.galactic-info.ac.za

If you enter a URL like this, the web server will direct you to a default page (usually index.htm, index.html, default.htm, default.html).

If, for example, you enter the URL http://www.canada.com, the web server will direct you to http://www.canada.com/index.html.

To review, the browser would interpret the following address as follows:

- Use the HTTP protocol
- Go to the server named www
- It is found attached to the domain wikieducator.org
- It is an international organisation or an organisation based in the USA
- When accessing the web site, it will go to a folder CCNC and it will display the page/file index.html located within the folder CCNC.

If you want to go to another file/page in the folder, you have to type in the name of the file, e.g.:

http://www.ijurnal.ac.uk/issue_14/ij_14_04_articleframe/Petrides_Jimes.html

- Use the HTTP protocol
- Go to the server named www
- It is found attached to the domain ijurnal.ac.uk
- It is an academic institution based in the UK
- When accessing the web site, it will go to a folder issue_14 and a subfolder ij_14_04_articleframe
- In the subfolder it will find the page/file called Petrides_Jimes.html
Web Browsers

A Web browser has a very straightforward purpose, which is to locate files using their URL and display their contents on-screen.

Examples of browsers include Firefox, Internet Explorer, Opera and Netscape.

Although browsers have a very specific purpose, they can have many features which improve their functionality.

These include:
• navigate to and between sites. This is sometimes called surfing the web
• record your visits to sites called the history
• mark important sites called bookmarks
• display options to speed up access. For example, if you have a slow Internet connection browsers can be set to not display graphics. Because graphics typically are large files, the can cause the computer to appear to run very slowly.
• enforce various levels of security and privacy called privacy settings
• prevent the execution of cookies (you set your browser). Cookies are small programs that are downloaded from web sites. Usually they do such things as collect information about your computer or browser, but there have been privacy issues with cookies.
• change the display in various ways

Cookies

Web sites frequently make use of graphics. Web sites may also need to know certain things about your computer or be able to make changes to the way your computer is functioning in order for you to do things on the website. In order to achieve the above, they transfer small programs called cookies onto your computer when you access the site.

Although cookies are often very useful, they do have a negative aspect. They could, for example, contain a virus. Alternatively, they could scan your computer for information such as access codes and passwords, and send these back to their source.

When you allow cookies, you are also exposing your computer to a number of serious risks. Unfortunately, some sites cannot be accessed unless cookies are allowed.

Browsers give some control over cookies. You can set them so that they block all cookies, or allow cookies only from certain trusted sites or allow them all.

If your browser is set to allow all cookies, it’s important that you follow some basic rules of safe computing:
• visit only trusted web sites
• have good virus protection software that is updated daily
Cache

Because web sites often contain a lot of graphics, they can take considerable time to load. To speed up the process of accessing web sites, your browser can make use of a cache.

Cache is the name given to memory used for speeding up operations. A web browser uses cache to store web pages that you have accessed in the past. If you call up the same page, instead of loading it across the Internet, it retrieves it from cache.

There are programs called web accelerators that speed up the operation of browsers. Accelerators make use of cache in a different way. They anticipate the web sites you are likely to use based on the sites you have been accessing. While you are working on a site, the accelerator will load these sites into cache ready for immediate use.

Security

Web Site Security

Most web sites are unprotected. This means anyone can access them and read their contents.

Some sites are protected. As soon as you attempt to access them, a dialogue box will appear on-screen asking for a user ID and password. Unless you can supply these, you will not be able to progress further.

Some sites have a mixture of protected and unprotected areas.

The registration processes required to access protected sites vary. Examples are:

- paying a fee
- on joining an organisation, you may receive a user name and password which allows you access to protected areas of a web site
- completing a questionnaire in which you give personal details. Once this has been done, a user name and password is e-mailed to you
- entering a verification code which is a randomly machine generated code displayed as an image so only a human being could read the image and type the number and not a machine. This prohibits machines accessing personal information.
Banks have more layers of website security, especially when using Internet banking:

- They make use of access numbers and PIN numbers that must be entered by using an on-screen numerical pad. This makes it impossible for a machine to grab your pin number. Furthermore, they can also ask you to enter only certain digits of your password. This is to ensure that not all your logon information is displayed, to help combat Identity fraud.

- **Random Verification Number (RVN)**
  In order to execute PrePaid purchases, create a beneficiary, stop payment or operator on Internet Banking, you have the option to receive a unique code (Random Verification Number) via e-mail or SMS. This Random Verification Number allows you to control PrePaid purchases, the creation of a valid beneficiary, stop order or operator. On entering this number you can proceed with the transaction.

- **Time out**
  If you have logged on and have not used the website for a set number of minutes, you will be logged off. To access your accounts again you will need to LOGON.

**Digital Certificates**

A digital certificate is the equivalent of positive identification, such as a driver's license. Issued by various certificate authorities, digital certificates are used to prove that a web site, or a visitor to a web site, is the entity or person they claim to be. When sending an e-mail the digital certificate proves the identity of the sender.

A digital certificate is a password protected file that includes the following information:

- the name and e-mail address of the certificate holder
- an encryption key that can be used to verify the digital signature of the holder
- the name of the company issuing the certificate
- the period during which the certificate is valid

The certification authority links a public key to the name in the certificate (Public and private keys will be discussed in the next section).

Digital certificates are used when secure connections need to be established between a computer and a web site. If the digital certificate
cannot be verified, the web browser will send a warning message to the user.

The way digital certificates work is explained in the next section on encryption.

A digital signature is an added level of security. Digital signatures have in-built mechanisms that enable recipients to verify that the sender is who he/she says and that information has not been forged. Digital signatures are described more fully in the section called “Know what a digital signature is”.

Sites using these security methods have an address that begins https rather than http. Hypertext Transfer Protocol Secure (HTTPS) is a combination of the Hypertext Transfer Protocol with the SSL/TLS protocol to provide encryption and secure identification of the server.

Digital Encryption

Digital encryption refers to the scrambling of data so that it cannot be read without a key. This means that sensitive and confidential information can be sent across the Internet without being able to be read. The little lock in your browser appears.

For example, if you are doing banking over the Internet, a secure link called SSL (Secure Sockets Layer) is set up between your computer and the server. This involves scrambling the data so that, if it is intercepted, it appears as a meaningless set of characters. Nowadays banks are switching to TSL (Transport Layer Security) which is a higher order security layer as SSL.

Encryption involves the use of private keys and public keys. The public key enables the data to be encrypted by anyone. Once it is encrypted, it can only be deciphered with a private key. Only the owner of the site has this.

When a site sends you a digital certificate, they are also sending you a public key which enables you to encrypt information which only it can read.

You May Ask the Question: When is a Website Secure?

Traditionally when you hear someone say 'Our website is Secure' they imply that their website uses SSL (Secure Sockets Layer) and that the traffic is encrypted (The little lock in your browser usually appears).

It is good to have the “best practices” checklist approach. Check for the following:

- Login pages should be encrypted.
- Data validation should be done at the server-side and do not accept client-side data validation.
- The Web site must be managed through encrypted connections. Unencrypted FTP or HTTP opens you up to attacks and
login/password sniffing.

• Use strong, cross-platform compatible encryption: SSL is not the top-of-the-line technology for Web site encryption any longer. Look into TLS, which stands for Transport Layer Security — the successor to Secure Socket Layer encryption.

• Connect from a secured network: Avoid connecting from networks with unknown or uncertain security characteristics or from those with known poor security such as open wireless access points in coffee shops. This is especially important whenever you must log in to the server or Web site for administrative purposes or otherwise access secure resources.

• Don’t share login credentials.

• Prefer key-based authentication over password authentication: Password authentication is more easily cracked than cryptographic key-based authentication.

• Maintain a secure workstation.


**Internet Fraud and the Use of Credit Cards**

Be aware of the possibility of being subject to fraud when using a credit card on the Internet

In order to make use of some sites or order goods or services across the Internet, you will need to pay by credit card. When you give credit card information without the merchant actually seeing the card, it is referred to as a Card Not Present or CNP transaction. There are a number of dangers to both the buyer and the seller.

Vendors need to be sure that the card is not being used fraudulently.

Clients need to be sure that:

• they can afford the goods they are buying. It is very easy to spend money using a credit card on the Internet

• the vendor will not abuse the information and make unauthorised debits. They should not deal with any unknown sites

• the vendor ensures the client that credit card information is not being kept

• the information will not be stolen by employees and used fraudulently. Once again, well known reputable sites will have measures in place and will generally take responsibility if anything does go wrong

• the information will not be stolen and used by hackers. Only use sites that are able to encrypt the information you send using a secure link such as SSL

**Firewalls**

A firewall is the first line of defence against hackers. It is a computer program that is installed on a computer that connects to the Internet. The firewall software analyses the packets (small groups of data that are transmitted as a unit) that pass between the computer and the Internet. It is programmed to follow certain rules which enable it to decide whether
or not to allow a packet to pass. If a packet does not meet the rules programmed into the firewall software, it is rejected.

**Virus Infection from a Downloaded File**

The Internet is a wonderful source of information and software. Since there is virtually no control exercised over the Internet, it is also a source of danger and even criminal activity.

There are thousands of download sites where you can obtain software and other files, some of it legal some pirated.

Whether or not the software or file is legal, there is always the possibility of viruses being contained in the software or downloaded files. This could be done deliberately by the developer of the site or because it was not checked adequately before being made available.

Remember, viruses can also be transferred in files.

Before downloading software or a file from the Internet, be sure that you can trust the site you are dealing with. There are excellent and safe download sites such as www.tucows.com so you should not need to use dubious sites.

Have excellent virus protection on your computer that you are updating on a regular basis. Run full virus scan regularly on your computer.

**Know your Viruses - Malware**

The first term that is used for is software designed to infiltrate a computer without the owner's informed consent is **Malware**, short for *malicious software*. It is a general term used for a variety of forms of hostile, intrusive, or annoying software or program code.

Malware includes computer viruses, worms, trojan horses, spyware and other malicious and unwanted software.

Software is considered malware based on the perceived intent of the creator rather than any particular features.

Malware was first written as experiments or pranks generally intended to be harmless or merely annoying rather than to cause serious damage to computers. Examples are the first Internet Worm and the Melissa virus.

Later programs were designed to cause harm or data loss. Many DOS viruses, and the Windows ExploreZip worm, were designed to destroy files on a hard disk, or to corrupt the file system by writing invalid data.
However, since the rise of widespread broadband Internet access, malicious software has come to be designed for a profit motive on the black-market.

**Infectious Malware: Viruses and Worms**

**Computer Virus**

A *computer virus* is a computer program that can copy itself and infect a computer without the permission or knowledge of the owner. It infects some *executable software* and causes that software, when run, to spread the virus to other executable software. It literary insert itself into other programs.

How do you get rid of a virus? – If your antivirus software detects a *virus*, that file should be *cleaned*.

**Worms**

A worm is a program which actively transmits itself over a network to infect other computers. It exploited security holes in network server programs and started itself running as a separate process.

How to get rid of a worm? - If your antivirus software detects a worm there is no legitimate file involved and action should be to delete the file.

**Concealed/Camouflaged Malware: Trojan horses**

A *Trojan horse* is a computer program which carries out malicious operations without the user's knowledge.

It is a hidden program which secretly runs commands, and *usually opens up access to the computer running it by opening a backdoor* (think of the Greek legend). Through this backdoor, hackers can get access to your computer and gain control of it.

Unlike viruses, a Trojan does not replicate (i.e. infect other files), nor does it make copies of itself as worms do.

A Trojan horse may, for example:

- steal passwords
- break security
- copy sensitive data
- carry out any other harmful operations

How do you project your computer from a Trojan? - Installing a firewall (a program which filters data entering and leaving your machine).
How to get rid of a Trojan? - If your antivirus software detects a Trojan there is no legitimate file involved and action should be to delete the file.

Spyware

Spyware is a type of malware that is installed on computers and that collects information about users without their knowledge.

You have to run anti-spyware software to protect your computer from infection.

Spyware does not usually self-replicate like viruses and worms. It includes the delivery of unsolicited pop-up advertisements, theft of personal information, monitoring of web-browsing activity for marketing purposes and routing of http request to advertising sites.

Anti-Virus Software

Anti-virus software contains tools that scan for known viruses and take action to disarm and/or remove them. Because viruses are developed daily, the anti-virus industry has grown and release updates regularly.

They are looking constantly for new occurrences of malware and write programs to disarm or remove them.

It is therefore important to apply:

- prevention – not to download files or open e-mails from unknown or suspicious sources
- protection – have a good and trustworthy anti-virus software installed on your system and update it regularly
- cure – run your anti-virus software regularly, at least once a day

e-Safety

Read the article on the next page and think about the role of parents to safeguard their children on the web.

This includes, but is not limited to supervision, web-browsing restrictions, computer games restrictions and computer usage time limits.
Does your school have an e-Safety net?

Online safety and implications for schools

Technology is all pervasive in society; we unwittingly use it all the time. From drawing money at an ATM to passing through a toll-gate, computers enable these activities. We have to ask ourselves questions such as “is all information found on the Internet true?” and “Are all the people I meet online or when using a cell phone really who they say they are?”

"Are children safe when using technology?"

Access to information and communication brings with it a certain responsibility because as much as the world opens up digitally so does it open the darker side of human nature. A couple of issues are that there are many ‘inappropriate’ websites that are easily accessible; moreover people use technology to abuse others. Cyberbullying is a word that is now mainstream—children sending each other hate messages by e-mail or cell phone or even setting up profiles on social networks that encourage others to harm, damage, harass or isolate people, including teachers.

"Cyber-bullying involves the use of information and communication technologies to support deliberate, repeated, and hostile behaviour by an individual or group, that is intended to harm others" [Accessed 4 February 2009 Wikipedia]

So what do about all of this in the educational context? The most pervasive technology of all is the cell phone and what a wonderful tool it is in a country as multilingual and diverse as ours, we love to talk or in the case of the Digital Natives, our children, text. But do we ban cell phones in schools? They are, after all, making the owner a target for theft besides possibly diverting attention away from school work. Do we filter Internet to the extent that that only "whites lists" are used i.e. websites that have been pre-evaluated by teachers? Do we ban social networking, gaming and video streaming? Is this what education is about? One needs to remember that middle and young adults are exposed to technology outside the school environment as well as within it, in much the same way that "adult magazines" are available at every corner shop (albeit on a higher shelf).

So what is a school to do? The challenge for teachers is to ensure that they are not only aware of the burgeoning tools available but also educate their learners in how and when to use them. Moreover they need to familiarise themselves with how these tools can be used to enhance teaching and learning. Podcasts (downloadable audio clips) and RSS feeds (notifications of the latest information in any given field) have a wonderful use in education and need to be incorporated. It also encourages plagiarism and teachers need to adapt their teaching style so that this does not happen. Information literacy is key to managing the new environment.

This further makes it imperative that parents themselves take responsibility and familiarise themselves with technology available and educate their children around responsible use, also including the possible risks. The Web 2.0 environment encourages sharing intellectual capital and the contribution to the knowledge pool. What a pity if this great opportunity is compromised through poorly managed use.

There has been much written on the topic of e-Safety in recent years and there are several very important documents: Safe Children in a Digital World, the Report of the Byron Review published in the UK in March 2008 available at [http://www.dcsf.gov.uk] and also Enhancing Child Safety and Online Technologies published in the US in December 2008 by the Berkman Centre for Internet and Society at Harvard University available at [http://cyber.law.harvard.edu/pubrelease/lotis/extra.html]. Moreover BECTA at [http://www.becta.org.uk] has an excellent section on e-safety, in particular developing an e-safety policy in a school—otherwise known as an Acceptable Use Policy or AUP of which there are many examples on the Internet.

Other strategies are the use of forensic software in a school environment. The object of this is to find the balance in educating children around the meaningful use of technology whilst monitoring their activity to ensure that there is no abuse. This is not to prevent access but for the school management team to identify who is accessing what, for purposes of protection of the child and others. A list of possibly dubious keywords or phrases is selected by a school and when these are used in any activity using computers, including within applications such as e-mail and word processing documents, the author is identified. This is a tool that equips the school in managing inappropriate online behaviour.

Locally the Meraka Institute. [http://www.meraka.org.za], a division of CSIR, has been investigating how mobile technology can be used to support education. There is a parent and educator guide developed which is a useful and accessible tool for both. Similarly there is the BKVEL poster developed by Grade 8 learners at Cornwall Hill College, both documents made available by Adele Botsa, a Senior Researcher at Meraka.

Finally, Europe is well on its way to creating e-safe schools. The website is Safe in which is an excellent resource and explains Safe Internet Day on 10 February 2008. [http://www.safesinternetday.com/en/publisher/safe/index.htm]

Some useful websites are:

- Byron Review [http://www.dcsf.gov.uk]
- Berkman Centre for Internet and Society [http://cyber.law.harvard.edu/pubrelease/lotis/extra.html]
- Child Exploitation and Online Protection Centre [http://www.thinkuknow.co.uk]
- ChildNet International [http://www.childnet.int]
- Internet Watch [http://www.iwf.org.uk]
- Becca e-Safety [http://www.becta.org.uk]
- Ask About Games, parents guide to video games [http://www.askaboutgames.com]
- Bullying UK [http://www.bullying.co.uk]
- Wired Safety [http://www.wiredsafety.org]
Summary

In this section, we discussed what the Internet is and distinguished between the Internet and the World Wide Web. You were introduced to many Internet technical terms.

We also discussed what is involved in Website security, and some of the technologies that are available to enhance your security on the Web.

Through this section you must instill good security habits when using your own computer or using a computer for your private activities such as banking, buying over the Internet and registering for certain sites and giving your personal information.

Always take care when using public computers (Internet cafes) and unsecure networks.
Using a Web Browser

Section Overview

After studying this section you will be familiar with the features of the Mozilla Firefox Web browser, an application included with Ubuntu that is used for browsing content on the World Wide Web.

In this section you will:
- do basic tasks in Firefox (opening, closing a web browser)
- customise the Firefox window
- learn basic techniques for browsing web pages
- become familiar with Firefox Help features

Opening and Closing a Web Browser

Ubuntu is installed with a web browser already in place: Mozilla Firefox. Firefox is a full-featured Web browser that is the second-most installed browser world-wide (after Microsoft’s Internet Explorer).

Opening Firefox

- Choose Applications→Internet→Firefox Web Browser from the Ubuntu menu or click on the “Web” icon.

Close Firefox

- Choose File → Quit from the Firefox menu

or

- click the Close button in the upper right corner
First Introduction to the Firefox Window

Using the Sidebar

The Sidebar is an area on the left side of the screen that you can use for viewing bookmarks or history. Extensions may add new ways to use the Sidebar as well.

To view an item in the Sidebar, select View → Sidebar. From there you can select the Sidebar tab you want.
Setting up a Home Page or Start Page

There are several ways to set your home page:

The Home Page is the web site that is located and displayed by Firefox when it is loaded by the user. This is set in the Firefox Preferences as follows:

1. Choose **Edit**→**Preferences** from the Firefox menu.
2. Under the **MAIN** category (click on **Main Tab**), there is a section titled "Startup".
3. Under **Where Firefox starts**: you will find a drop-down menu (click to open it) with three options:
   - If you choose **Show my home page** as your option you will need to type in that location.

   Your Home Page may be any page you select, a personal site, an educational site, or perhaps a commercial site.

   In this example, the Home Page is set to go to Penn State University at **http://www.psu.edu** (it was typed in).

   ![Firefox Preferences](imageLink)

   - If you choose **Show a blank page** Firefox will load a blank page upon opening.
   - If you choose **Show my windows and tabs from last time** Firefox will remember any windows and tabs open from the last instance and display them.

4. You can also select one of the three buttons:

   ![Buttons](imageLink)

   - **Use current pages** – use the active page in your browser
   - **Use bookmark** – let you choose from your saved bookmarks
   - **Restore to Default** – restore the settings to the machine settings
Display a Web Page in a New Window

To display a web page you need to know its URL (web address). The following example illustrates how to access the Google website. Its URL is http://www.google.com

- Type **www.google.com** into the Address bar as shown on the next screen and press **Enter** or click on the green arrow on the right of the Address bar.

Unsure of URLs

Firefox can make suggestions on the URL you require. For example, if you want to view the website of CNN but you are unsure of the URL, you could type in CNN in the address bar.

Firefox would attempt to find the site for you and would try various possibilities starting with www.cnn.com.

Opening a New Window

You have been able to open more than one document in other programmes. You can also open more than one site in Firefox and work on more than one site simultaneously.

You can do it in one of two ways, either by opening a new window or by opening a new tab.

Open a New Browser Window

You have already one website open and want to open a second one.

Without closing the first window:

1. Choose **File→New Window** from the Firefox menu.
2. Type the second URL into the Address window.
3. Press **Enter**.
A new window will open displaying the second website. Click on the appropriate icon at the bottom of the screen to switch between the web sites.

**Tabbed Browsing**

Tabbed browsing is a very good habit to learn. It lets you open multiple tabs, each displaying a web page, within a single Firefox window. It has the advantage of diminishing the screen clutter of having many windows open.

You have to create and load tabs. To open a new tab, press Ctrl+t, or select **File ➔ New Tab**.

You open a new page on a new tab and enter the URL.

The different tabs appear at the top of the Working space. You can click on the tab you want to work with.

**Tip:** You can open links in new tabs, where they will load while you read the current page.

**Stop a Web Page from Downloading**

Web sites often take a while to download, especially if they contain a lot of graphics or if the Internet is very busy at the time you are using it. You can decide to stop a website for downloading and go to another activity.

To stop a web page form downloading click the **Stop** button next to the Address bar.

**Refresh a Web Page**

In order to speed up your computer when working with web sites, Firefox stores copies of pages in a cache or temporary memory area so that they can be recalled more quickly than if they had to be reloaded across the Internet. You can get the most up-to-date version of the page by using the Reload function.

Click the Reload button next to the Address bar (on the left) or press **Ctrl+R**.
Use Available Help Functions

Firefox comes with an extensive help system. Learning to use the help system can help you become familiar with the full range of the application's functionality.

To access Help, choose Help ➔ Help Contents from the Firefox menu.

Suppose you wish to find out how to copy a web page.

1. Expand Using Mozilla Firefox by clicking the symbol to the left (see the red arrow).
2. Expand Copying, Saving and Printing.
3. Double click on Copying Part of a Page.
Search the Help Function

The Help Contents are useful if you know exactly what topic you are looking for. It may happen that you are looking for all entries containing a particular key word.

The following example illustrates how to find all help entries that contain the word 'cache'.

1. Choose **Help → Help Contents** from the Firefox menu.
2. In the **Search** look-in space to the top-right of the screen, enter the word **cache**.

3. The topics containing 'cache' will appear in the look-in space to the left.
4. Click on the entry you wish to view.
Use the Glossary

The glossary is a dictionary of meanings of terms associated with Firefox. These are listed in alphabetical order.

Click on cache (definition) or any other term’s definition. A glossary of terms will be displayed in the right side window. Scroll and click the term whose meaning you wish to know.

Adjusting Browser Settings

Know more about the Components of the Firefox Interface

On page 19 you have been introduced to the basic terminology of the Firefox window. Before explaining how to show and hide toolbars, it would be useful to become more acquainted with the different components of the Firefox window. These are illustrated on the following screen.
Display, Hide Built-in Toolbars

You can modify the Firefox window by hiding or displaying toolbars. Hiding a toolbar that you don’t use often gives your browser window more room to display web pages.

To show or hide toolbars:

1. Choose View ➔ Toolbars from the Firefox menu.
2. Uncheck the box to the left of the toolbar to hide it, or check the box to show the toolbar.

Set display to Full Screen Mode

Full screen mode allows you to use the entire screen for the display of web pages. The Navigation bar will be displayed at the top of the screen when you place your mouse at the top of the screen, otherwise it will automatically hide. The rest of the screen is used for the display of the web page.

1. Choose View ➔ Full Screen from the Firefox menu, or press <F11>.
2. Press <F11> again to return to normal view mode.

Display, Hide Built-in Web Page

The loading of graphic images when accessing a website can slow down the display of websites very drastically, especially if they are graphic intensive. Often these images are of little use when the user is after information. One way of speeding up access is to suppress the display of images:

1. Choose Edit ➔ Preferences from the Firefox menu.
2. Click on the Content tab.
4. Click Close.
Summary

This section introduced you to the Firefox browser and browsing pages on the Web. You learned how to set up Firefox and how to access the Help features in the application.
Web Navigation

Section Overview

After studying this section you will be familiar with accessing web pages with the Firefox browser, navigating through the Web. You will also learn techniques, such as bookmarking, that will make it easier for you to keep track of the vast amount of information available to you on the Web.

In this section you will:
- understand what a hyperlink is
- learn how to access web pages
- become familiar with navigating the Web.
- learn how to manage your browsing history
- learn how to bookmark pages so they can be easily located and how to manage bookmarks

Accessing Web Pages

Activate a Hyperlink/ Image Link

A hyperlink is a cross-reference to another web site. The hyperlink is attached to an icon or a phrase. When a user clicks on a hyperlink, the browser displays the cross-referenced site. It is possible to do this in the current window or in a new window.

When hyperlinks are attached to phrases, the phrases are usually displayed in underlined blue text e.g. www.col.org. In any case, your mouse cursor will change to a hand when you move your mouse over a hyperlink.

Display the URL of a Hyperlink

The following screen contains a number of hyperlinks at the top of the page:

The underlined headings in blue text all represent hyperlinks. The URL of the hyperlink is displayed on the bottom of your browser window, in the status bar. In the image above, the URL of the hyperlink is http://www.search.com/images.
Navigate to the Home Page

You can navigate immediately to the Home Page (see page 20) by clicking on the Home button - .

History

Firefox keeps track of the web pages you have viewed in your current session and longer. This is called History.

You have control over what is saved in your browser history, and you can clear the history whenever you like.

Using the browser history can be a great way to navigate to pages that you’ve visited recently.

Using the Navigation Toolbar

The easiest way to move back and forth through the web pages you’ve visited in a session is to use the back and forward buttons on the Navigation Toolbar.

Display Previously Visited URLs

When you access a web site, Firefox records this in its History. You can have access to the list of previously visited URLs by using the address bar.

1. Click on the drop down arrow at the right hand side of the browser address bar. A list of recently visited sites is displayed.
2. Click the site you wish to visit.
An alternative is to use the Menu bar. The **History** menu item will display sites visited.

1. Choose **History** from the Firefox menu.

   ![Firefox Menu with History Option](image1.png)

   A list of recently visited sites is displayed at the bottom of the menu.

2. Click on the site you wish to visit.

   ![Firefox History List](image2.png)

   **Show All History**

   You can view the recent browser history by clicking on the History menu. To view all of your browser history:

1. Choose **History**→**Show All History** from the Firefox menu.

   ![Firefox Show All History](image3.png)

   2. Scroll through the history list. You can sort the list by **Name**, **Tags**, or **Location**.

   **Delete Browsing History**

1. Choose **History**→**Show All History** from the Firefox Menu.

2. Select the history item(s) you would like to delete.
3. Press the `<Delete>` key on your keyboard.

4. To delete your entire browsing history, select all entries (you can press the `<Ctrl>` key and `<A>` key at the same time to do this) and then press the `<Delete>` key.

**Clear Private Data**

Your browsing history is just one part of the data that is saved on your computer. Other files, such as cookies, web pages saved in your browser cache and other data are also saved on your computer.

IT IS IMPORTANT TO CLEAR PRIVATE DATA AFTER EACH SESSION WHEN USING A PUBLIC COMPUTER.

To clear your private data:

1. Choose **Tools**→**Clear Private Data** from the Firefox menu.
2. Check the items you want to clear.
3. Click the **Clear Private Data Now** button.

**Pop-ups**

A pop-up is a small window that appears automatically on top of the website you're viewing without your permission. Pop-up windows often open as soon as you visit a website and are usually created by advertisers.

Pop-ups are normally associated with security risks (check spyware in the first section).

Firefox allows you to control pop-up and is normally referred to as a pop-up blocker. A pop-up blocker is a feature that lets you limit or block most pop-ups. You can choose the level of blocking you prefer, from blocking all pop-up windows to allowing the pop-ups that you want to see. When Pop-up Blocker is turned on, you will
get an Information bar message saying "Pop-up blocked. To see this pop-up or additional options click here."

Pop-up blocking is turned on by default.

You can edit pop-up blocker preferences by:

1. Choosing Edit ➔ Preferences.
2. Click on the Connect Tab.
3. Go to Block pop-up windows: Unselect this preference to disable the pop-up blocker.

4. If you click on the Exceptions button to the right, the Allowed Sites Pop Up dialogue box appears.

Here you can choose between:

a. Allow – you can add a website to the list to accept pop-ups from.

b. Remove site – remove a marked website from the list.

c. Remove all sites – will remove all of the sites in the exception list.
Cookies

A cookie is a small file stored on your computer by a website you visit. Cookies often store your settings for a website, such as your preferred language or location. When you return to the site, Firefox sends back the cookies that belong to the site. This allows the site to present you with information customised to fit your needs.

Cookies can store a wide range of information, including personally identifiable information (such as your name, home address, e-mail address, or telephone number). However, this information can only be stored if you provide it - websites cannot gain access to information you didn't provide to them, and they can't access other files on your computer.

By default, the activities of storing and sending cookies are invisible to you. However, you can change you Firefox settings to allow you to approve or deny cookie storage requests, delete stored cookies automatically when you close Firefox, and more.

Cookies are enabled by default in Firefox. To check your settings:

1. Choosing Edit ➔ Preferences
2. Click on the Privacy Tab.
3. Go to Accept cookies from site: Unselect this preference to not accept cookies.

4. If you click on the Exceptions button to the right, a dialogue box appears with sites that cannot store cookies on your computer.
5. You can also see the cookies that are stored on your computer, by clicking on the **Show Cookies** button. You can also mark and hit **Remove Cookie** or click on the **Remove All Cookies** button to clear the list.

![Image of cookie information]

**Complete a Web-Based Transaction**

Many web pages involve a transaction such as purchasing goods, registering for a course or creating a web based e-mail account. Some of these involve a single form while others involve several forms and could include giving credit card information.

**Note:** Only supply credit card information over the Internet if you are sure of the web site that you are using and if the site uses a secure method of transferring the information.

In many cases, although the entire process is electronic, it nevertheless represents a contract between yourself and the company or organisation. Many websites such as WikiEducator offer free registrations based on the user agreeing to certain conditions. Clicking an **I Agree** button is typical of transactions that involve conditions. Only click this button if you agree to the conditions.

**Bookmarks**

You can store URLs to use it at a later stage. A bookmark is the URL of a site that is stored by Firefox either in the Personal toolbar or in the Bookmarks menu. To access a site that has been bookmarked, you open your bookmarks and click on the name of the web site in the toolbar or menu.
Bookmark a Web page in the Bookmark Menu

If you want to bookmark the WikiEducator web page:

1. Access the site by typing http://www.wikieducator.org into the Address bar and press <Enter>.
2. When the page is displayed, select Bookmarks ➔ Bookmark This Page or press <Ctrl><D> on your keyboard.

Display a Bookmarked Web Page

To display saved bookmarks:

1. Choose Bookmarks ➔ Organize Bookmarks.

2. The Bookmarks Manager/Library dialogue box appears with a list of all bookmarks:
Organising Bookmarks

As the number of bookmarks increases, so does the need for a system for organising them. You can organise your bookmarks in folders, move them from one location to another and delete them by displaying your bookmarks (see above).

Create a Bookmark Folder

The best way of organising your bookmarks, is to create a number of folders. Each folder should be a repository for web pages having something in common. The name of the folder should reflect this. Firefox has a special dialogue for managing bookmarks.

1. Choose **Bookmarks ➔ Organize Bookmarks** from the Firefox menu. This displays the **Bookmarks Manager/Library** dialogue window.

2. Choose **Organize ➔ New Folder** or click on the **New Folder** tab.
3. Complete the details as follow:

![Add Folder dialog box](image)

4. Click the **Add Button/OK Button**.

The new folder will be added to the set of existing folders. You can then organise your existing bookmarks by dragging them into the appropriate folder.

### Add Web Pages to a Bookmark Folder

Once you have created folders to organise your bookmarks, you can bookmark pages directly into these folders.

1. Locate the web site you wish to bookmark. For example, the Open University of the UK has been accessed at [http://www.open.ac.uk/](http://www.open.ac.uk/).
2. Choose **Bookmarks ➔ Bookmark this Page** from the Firefox menu.
3. Select the folder in which you wish to place the bookmark.

![Firefox bookmark dialog box](image)

4. Click **Done**.
Delete a Bookmark

To delete a bookmark:
1. Choose **Bookmarks ➔ Organize Bookmarks** from the Firefox menu.
2. Navigate to the folder that contains the bookmark you wish to delete.
3. Select the bookmark by clicking on it.
4. Press the `<Delete>` key.

Delete a Folder and Its Contents

To delete a complete folder with the contents (all the bookmarks in the deleted folder will also be deleted):

1. Choose **Bookmarks ➔ Organize Bookmarks** from the Firefox menu.
2. Select the folder by clicking on it.
3. Press the `<Delete>` key.

Summary

This section discussed the basics of navigating on the Web with Firefox. We learned about the files that are created when you browse the Web, such as history files, cookies, and cache, and how to manage those files. Finally, you learned how to create and manage bookmarks to help you manage the content you access with your Web browsing.
Web Searching

Section Overview

After studying this section you will be familiar with doing sophisticated searches on the Web to help you find the information you want from the vast quantity of information available.

You will also learn how to capture and save Web content to your computer, and some of the issues related to re-using Web content.

In this section you will:
- be introduced to the Google search engine
- carry out searches based on keywords, language, date and other criteria
- learn how to download text, images, and other files from the Web
- learn how to print a web page

Using a Search Engine

Select a Specific Search Engine

It will frequently happen that you want to look up information on the Internet but do not know where to look. In such a case you can make use of a Search engine.

Search engines, include web search engines, selection-based search engines, meta-search engines, desktop search tools, and web portals and vertical market websites that have a search facility for online databases.

For the purpose of this course, we define a search engine as a web site that will find the locations of web sites for you which contain key words or phrases. There are a number of these available. Go to Wikipedia: [http://en.wikipedia.org/wiki/List_of_search_engines](http://en.wikipedia.org/wiki/List_of_search_engines) to see a list of search engines.

The three most popular search engines are Google, Bing and Yahoo. Google is the most popular, because of the relevance and accuracy of its results. ([http://www.weboptimiser.com/search_engine_marketing_news/6013327.html](http://www.weboptimiser.com/search_engine_marketing_news/6013327.html))

This section will focus on a specific search engine Google. You should, however, familiarise yourself with the other search engines and decide for yourself which you prefer.
Opening a Search Engine

1. Go to the following URL: http://www.google.com

The secret of using a search engine such as Google lies in choosing the best key words or phrases to locate useful web sites.

Carry out a Search for Specific Information Using a Keyword or a Phrase

Suppose you have a special interest in mountain climbing and you would like to find websites that can give you information on mountains to visit in Nepal.

You can use one of the following keywords or phrases:

- mountain – gives about 268 000 000 possible sites
- mountain climbing – gives about 9 230 000 possible sites
- “mountain climbing” – gives about 1 590 000 possible sites
- “mountain climbing sites” – gives you 246 000 possible sites
- “mountain climbing sites” Nepal – gives you 4 120 possible sites

What did you do to narrow down the number of sites?

- mountain – search sites that contains the word “mountain”
- mountain climbing – search sites that contains the words “mountain” and “climbing”
- “mountain climbing” – search sites that contains the phrase “mountain climbing” and not the separate words
- “mountain climbing sites” – search sites that contains the phrase “mountain climbing sites” and not the separate words/phrases such as “mountain climbing” or “climbing sites”
- “mountain climbing sites” Nepal – look for websites where the phrase “mountain climbing sites” appear with the word Nepal.

From the above it is evident that you have to be as specific as possible in your searching criteria (and make no spelling errors) to get the best searching results. Always try different combinations and techniques until you get the desired results.
Here is an example of the search results:

![Search Results Example]

The search has been narrowed down to about 1,620,000 web sites.

Clearly the search needs to be narrowed still further. Keep on practicing until you are able to narrow your results so that you can work with the sites provided.

If you specifically want images, maps or videos on the topic, click on the relevant hyperlink at the top of the screen to further narrow your search.

Each of the web sites shown is shown as a hyperlink (the underlined blue text). You can:

1. Click on a link to view the web site.
2. Click the Back icon to return to Google.
3. Scroll to the bottom of the Google web page and Click Next to view the next set of links.
Google Advanced Search

Most search engines have an advanced interface that narrow down your search.

1. Click on the Advanced Search link.

2. The following screen shows how the advanced search can be further refined, in this case to English language sites that have been updated within the past year.
The results are significantly less.

Now we have narrowed it down to about 113,000 sites. The more specific you can be, the more you can reduce the number of results.

The Google Advanced Search facility is a very powerful tool. You can also search by the exact phrase, by excluding words, by date and by file format.

It would be well worth your while to experiment with it and become fully conversant with its use. The Google site also contains tips and a help system.

**Searching a Web-Based Encyclopedia and Dictionary**

**Web-based Encyclopedias**

The web has opened up a vast array of electronic encyclopedias and dictionaries. Some are subscription-based, but some are also free to use.

The most used electronic encyclopedia is Wikipedia. Wikipedia is based on wiki-technology and is defined as:
To search for a topic in an encyclopedia look for the search textbox.

Enter your topic in the text box and hit **Search**. This will take you to text in the encyclopedia containing the words you have entered (wide search).

Wikipedia gives you an option – **Go**. This will take you to the page with the exact name. This will narrow your search significantly.

Check the search options in the encyclopedia you are using. Some gives you also an advance search option as discussed above.

Other examples are found at:
Encyclopedia Britannica: www.britannica.com

World Fact Book: http://www.bartleby.com
Web-based Dictionaries

There are several dictionaries available on-line. Some are free and others are subscription-based.

Examples are:

The Free Dictionary (includes a dictionary and thesaurus): http://thefreedictionary.com

The website: http://www.worldreference.com allows you to choose from a myriad of options to translate.
There are even search sites that search encyclopedias and dictionaries. An example is:

Evaluating Websites

The number of resources available via the Internet is immense - with more than 50 million World Wide Web pages out there. Nobody is controlling the Internet, what is going onto the Internet and what the quality of information is.

When you look at a website that has a lot of information that looks and sounds good, it is easy to believe that it is also correct! Unfortunately this is not always the case. Unlike textbooks, the Internet does NOT have a group of people to check that the information being provided is correct.

A website that aims to give you correct information should always provide you with ways to check this.

The following items need to be checked and verified to evaluate a website:

- **Who is the author?** This can tell you about the [credibility](#) and [reliability](#) of the information published on the website.
- **What is the purpose of the website?** This can tell you if it is biased, opinionated or [objective](#) (factual).
- **Is the information current?** This must however be carefully considered, historical sites don’t need to be current, but news sites must be current.
- **Is the website well designed, organised and easy to use?** - Web sites can provide useful sources of information. However, if they are slow to load or difficult to navigate, search and read, then their contribution and usefulness will be lost.

Carefully consider a website before using the information published on the site.
Duplicate Text and Images from a Web Page to a Document

It is very easy to copy and paste from a website into a document. Before you do it, carefully consider copyright and intellectual property issues.

Copyright is a legal framework that protects creators of documents and artistic works against the publication and reproduction of their work without them receive remuneration. Copyright protection exists as soon as a work is created and does not need to be registered or carrying the © symbol. Copyright therefore protects the intellectual property of people.

Keep this in mind before copying anything from the Internet.

Copy an Image into a Document

Copying an image from a web site displayed in Firefox is a two stage process involving saving the image and then inserting it into a document.

1. **Right click** on the image you wish to copy into a document.
2. **Click** Save Images as ...

![Image saving](image.png)

3. Select the directory in which you wish to save the image.
4. Give the image a suitable name.
5. Click Save.

The image is now available for you to include in your documents using OpenOffice applications or other programs.

Remember to make sure there are no copyright issues regarding your use of images from the Web – refer to the “fair use” policy in your region.

**Copy an Image from a Web Site to a Document**

If your Internet connection is active, you may also be able to copy an image directly as follows:

1. Hold down the left mouse button and drag over the image. It should change colour slightly.
2. Choose Edit ➔ Copy from the Firefox menu.
3. Go to the point in your document where you wish to paste the image.
4. Choose Edit ➔ Paste from the application menu.

**Copy Text from a Web Site**

Depending on how a web site has been constructed, you may or may not be able to copy the text directly. If the following method does not work, you will first need to save the web page as a text or html file (see next section) and then copy the text from there.

1. Go to the start of the text you wish to copy.
2. Hold down the left mouse button and drag over the text you wish to copy.
3. Choose **Edit ➔ Copy** from the Firefox menu.

4. Go to the point in your document where you wish to paste the text.
5. Choose **Edit ➔ Paste** from the application menu.

Save a Web Page to a Location on a Drive as a Text File or a html File

1. Navigate to the web page you wish to save in Firefox.
2. Choose **File ➔ Save As** from the Firefox menu. This will display the **Save as dialogue box**.

3. Select the directory in which you wish to save the web page.
4. Give the file a suitable name.
5. Select the type of file you wish to save it as.
Although the Internet is a wonderful source of information and software, it unfortunately has a negative aspect as it is possible to acquire illegal software from some sites. There are two things you need to keep in mind when downloading sites:

- Downloading illegal software or other electronic material across the Internet amounts to software piracy. This is both illegal and unethical as it infringes on the intellectual property rights of the developer.
- Software from illegal sites may contain viruses.

**Download Software from the Internet**

A very useful site for downloading software legally is Tucows.

The following example will illustrate how to download the current implementation of Wine from Tucows. (Wine is a program that allows you to run some Windows programs under Linux without having Windows on your machine.)

To download form Tucows:

1. Locate the Linux section of Tucows by typing the following URL into the address bar: [http://linux.tucows.com](http://linux.tucows.com)
2. In the TUCOWS search bar, type in wine.
3. Click the **Wine** link on the screen. This will display some information about Wine.

![Wine Link](image)

4. Click the **Download Now** button.
5. When asked whether you wish to open or save the file, select **Save File** and click the **OK** button.

![Save File Option](image)

6. Select a directory in which to save the download.
7. Either keep the name of the file that is displayed (preferable) or give it a new name.

**Note:** If you do change the name of a file, be careful not to change the extension of the file as this could have unforeseen consequences. This is especially the case of files that will be used on Windows systems. On Windows systems the file extension has a special meaning. For example, you can tell executable files in Windows by the fact that they have an .exe extension. In Linux, you can only determine whether or not a file is an executable by viewing its properties. An executable file in Linux may not even have an extension. However, even in Linux some extensions such as .rpm, .tar and .zip do have special significance.
Download Text Files

There are a number of sites where you can download books free of charge. One of these is Project Gutenberg. The URL is www.promo.net/pg/

In this case we will locate a specific book, *Around the World in 80 Days* by Jules Verne.

Follow the following instructions:

1. In the Quick Search window, search for **Jules Verne** under Author, and **Around the World** under Title Word(s), and press the **Search** button.
2. Click on the title to go to the download page.

3. Click on one of the links to begin the download.

4. The next screen shows the HTML download.
**Download Sound and Video**

Most computers have sound cards which enable you to play music and speech files. All are stored as sound files of one type or another. There are a range of different formats. One of the most popular is mp3 which compresses the file while still providing good sound quality.

Similarly, movies can be stored as video files.

In order to play sound or video files, you will need to have the appropriate software installed on your computer.

The process of downloading audio and video files is exactly the same as that described for software and text files. Begin by doing a search for audio or video files you are interested in, and then download.

---

**Note:** Not everything on the Web is downloadable. Understandably, content owners are often concerned that their content is not distributed illegally, and there is often a technical restriction placed on files such as audio and video. Only download from trusted sites with content that is copyright free.

---

**Printing a Web Page**

**Preview a Web Page**

Previewing a web page will enable you to see what it will look like when printed.

1. Choose File→Print Preview from the Firefox menu.

2. Scroll through the pages using the arrow buttons at the top of the preview window.

3. Click the Close button to return to the normal Mozilla window.
Page Setup

Before printing, you may want to change some of the page setup options.

1. Choose **File ➔ Page Setup** from the Firefox menu.

![Page Setup dialog box]

2. You can set the format for your particular printer, change the paper size, and set the orientation. You may need to set your page orientation to Landscape when you are printing Web content that is fairly wide on the page.

**Note:** It’s often wise to print a test page when you are not sure what the content will look like printed, rather than printing a complete document that can’t be read.

Printing

Choose web page print output options such as: entire web page, specific page(s), specific frame, selected text, number of copies and print

1. Choose **File ➔ Print** from the Firefox menu.

![Print dialog box]

OR

2. In this dialogue you can set the following:
   - **Print to the printer or a file:** If you do not want to print to the printer, but to a file, select **Print to file**, you will be prompted for the file name and location.
   - **The printer to use:** Select the printer by clicking on the drop down arrow next to the printer name. The dropdown menu will display all the printers that are installed on your computer.
   - **The range of pages to be printed:** The default is **All pages**. To
select a different range of pages, select the **Pages** radio button and enter the start and end page numbers. Fill in the space or if it does not display the **from:** and **to:** option, type in the pages as 3-14 (note, there are no spaces between the page numbers you have entered).

- **Number of copies:** Enter the number of copies you wish to print in the corresponding window.
- **Print frames:** Some web sites are made up of frames. These are boxes on the screen which can be dealt with as units. If the web page contains frames, you can select how you wish these to be printed.

3. Click **Print** or **OK**.

**Use of Web Forms**

The Web makes it easy to conduct surveys or having polls. Access a website such as: **www.gmail.com** and indicate that you want to sign up for a gmail account. You will see a screen like:

You need to fill in the electronic form to register for a new e-mail account.
Forms consist of the following:

- Information and questions that are text items entered by the creator of the form and cannot be changed.
- Text boxes – where you have to enter text in a box.

3.1 How do you intend using the materials? *

- Drop-down menus or list boxes – where you have to click on the down-arrow and you get a list that you can choose one item from.

Change Language: English

- Check boxes – a check box is a space where you can enter a tick to agree.

☑ Stay signed in

You can normally tick more than one answer to a question when using check boxes.

3.2 What certification does the use of the materials result in? *

☐ Part of a degree/diploma
☐ Institutional certification
☐ Open ICDL
☐ Capacity building - no certification
☐ Other
- Radio buttons – a radio button is normally associated with a specific choice. You cannot have more than one radio button selected in a question.

Forms normally have a submit button at the end to submit the response electronically. As soon as you hit the submit button, it will be submitted and you do not have access to your responses anymore. Make sure that before you hit the submit button, you have checked your responses.

Luckily some forms have a reset button to hit. This will delete all your responses and you can start from the beginning of the form.

Some forms cannot be submitted online and can be printed and faxed to submit responses.

An example can be found at:
http://www.lib.umd.edu/guides/webcheck.html

It is advised that you use this form to practice your evaluation of websites skills on page 46. Print the form for your own records.

**Summary**

This section introduced you to some techniques for searching the Web for specific information. Doing effective searches is a very important skill because of the vast amount of information available on the Web.

You also learnt how to copy images and text from a Web site to another application, how to download files from a Web site to your computer and how to fill in web forms.

Finally, you learnt how to print your web pages to a file or to your printer.

Ensure that you are comfortable to complete the following:
1. Perform a basic search and an advanced search using the Google search engine.
2. Copy text and images from a web page to another document.
3. Download a file from a trusted web site to your hard drive.
5. Print a web page.
Electronic Mail using Evolution Mail

Section Overview

e-mail is one of the most important communication technologies developed and is used by many millions of people worldwide. e-mail has many advantages, and a few disadvantages as well.

In this section you will:
• understand the structure of an e-mail address
• understand e-mail etiquette
• learn about the security issues surrounding e-mail

Concepts and Terms

What is an e-mail?

**e-mail or email** is the abbreviation used for **Electronic mail**.

**e-mail** is the exchange of digital messages.

According to Wikipedia “e-mail systems are based on a store-and-forward model in which e-mail computer server systems accept, forward, deliver and store messages on behalf of users, who only need to connect to the e-mail infrastructure, typically an e-mail server, with a network-enabled device (e.g., a personal computer) for the duration of message submission or retrieval. Rarely is e-mail transmitted directly from one user's device to another’s.”

To communicate via e-mail you have to obtain a valid e-mail address.
Mail Server

e-mail is sent and received through electronic "post offices" known as mail servers.

To read your e-mail, you download it from the mail server.

---

e-mail Client

Normally an e-mail client is the application which resides on every computer. Mail is downloaded from the mail server to the mail client. This can present a problem if you are away from your computer, especially if you are in a foreign country.

---

e-mail Software

You need to have the relevant software to send and receive e-mails. Examples are Microsoft Outlook or Mozilla Thunderbird.

Once you enter the address of the recipient, compose your message and click Send, your e-mail software handles the delivery.

---

Structure of an e-mail Address

An e-mail address can readily be distinguished from a web address (URL) by the fact that an e-mail address always contains a @ symbol while a web address never does.

The structure of an e-mail address is: 

```
mailboxname@domain
```

For example, in the address: 

```
josephine@ct-services.co.za
```

- `josephine` is the unique name of the mailbox. Usually the mailbox has a name which relates to the user. In this case she has used her first name. There cannot be 2 addresses with the same name in the same mailbox.
- `ct-services.co.za` is the name of the domain to which it is attached.
Sometimes you will find e-mail addresses that have the form:

**josephine.taylor@ct-services.co.za**

In this case the period between the first name and surname has no special meaning. A hyphen could equally well have been used.

There can be many mailboxes attached to the same domain. In this case only the part to the left of the @ symbol would change. Thus another mailbox attached to the above domain might be **info@ct-services.co.za**

**Uses of e-mail**

e-mails are the most common used communication technology. It can be used to:

- **Communicate**
  - at personal level (at a fraction of the cost of snail-mail-post)
  - speedily – it is quick to deliver and to respond
  - at business level with buyers and sellers
  - asynchronys – you can send a message and the recipient will receive it when he/she open the e-mail program
  - can attach photos and videos

  e-mail is about communication that is fast, efficient and inexpensive.

- **Inform** people – e-mail is a great way to let for example sellers know about market activity, recent sales, and showings that may have taken place when they were not home.

- **Forward information** – information can be forwarded easily and effectively.

- **Speed up** responses and delivery by sending e-mail reminders.

- **Exchange documents** - You can send an entire file via e-mail.

- Having e-mail also allows you access to **mailing lists**. A mailing list allows a group of people with common interests to exchange messages on that topic. When you send mail to the list, everyone who is subscribed to the list sees your mail.

- **Multiple recipients** – You can send one e-mail to multiple recipients.

- **Brainstorming and problem solving** - Although brainstorming and problem solving typically occur in face-to-face meetings, we can use e-mail to send documents for comments, ask for different views and get input into matters in discussion. It will definitely save on travelling costs and scheduling challenges.

- **Record keeping** - Unlike telephone and face-to-face conversations, e-mail "conversations" provide a built-in record of what you've asked for and what information you've received. Just remember to save it called archiving.
Advantages of e-mail

- **Speed:** e-mail is usually delivered within seconds to the recipient. The only delay occurs in the time taken by the recipient to check his/her e-mail.
- **Low cost:** The only costs are the line costs. Usually many e-mails are sent at once, reducing the cost even further.
- **Attachments:** Documents, images, sound and video files can be sent with e-mail messages as attachments. This further saves cost of delivery of heavy and bulky articles. The recipient can print the attachment or save it to the appropriate medium.
- **Reliability:** Although e-mail is occasionally lost through technical problems on the Internet, it is much more reliable than ordinary mail. Electronic receipts can be requested by the sender to confirm that the mail has arrived at the recipient.
- **Security:** Using encrypted links, sensitive and confidential messages can be sent across the Internet. Sending hard copies of messages has a much greater security risk.
- **Multiple recipients** – You can send one e-mail to multiple recipients.
- **Record keeping:** Unlike telephone and face-to-face conversations, e-mail "conversations" provide a built-in record of what you've asked for and what information you've received. Just remember to save it called archiving.

Disadvantages of e-mail

1. You could send and receive viruses and malware through attachments if you don't scan it.
2. Your inbox can be flooded with spam and unwanted advertisements from many sources. Ensure that you know how to handle and manage junkmail.
3. e-mails "bounce" between different servers all over the world before reaching you and could be stolen or modified by any knowledgeable hacker.
4. e-mail can become time consuming for answering complicated questions and misunderstandings can arise because cultural differences in the interpretation of certain words. The telephone, is much better for providing detailed answers or if you feel that the question is not absolutely clear.
5. e-mail communication can be misunderstood. Be aware of e-mail etiquette and the language you’re using in e-mails. Sensitive matters must not be communicated by e-mail. e-mail can become impersonal or misunderstood.
6. A long e-mail could cause the recipient to lose interest and stop reading the e-mail altogether.
7. It is so easy to send e-mails, that people tend to forward a lot of e-mails to people. Avoid forwarding jokes and presentations to people. It blog up and slow down systems.
8. Sending and receiving big attachments, media files and presentations take up valuable disk space and slow systems down. Avoid sending big files to people. If you receive big files, either delete or save it and delete the e-mail.
9. You must have a computer or something that connects you to the Internet, which only some can afford.
10. If your computer gets a virus or breaks down, there will be no way of e-mailing until it is fixed or you have to use another computer.
11. Slow Internet connections can fail easily when sending and receiving big e-mails. Make sure that your recipient’s connection can handle big files.
12. e-mail can compromise the security of an organisation because sensitive information can be easily distributed accidently or deliberately. e-mail should be entrusted to well trained and trusted staff members.

Web Based e-mail

Web-based e-mail or Webmail is an e-mail service is primarily accessed via a web browser (e.g. Firefox or Explorer), as opposed to through a desktop e-mail client (e.g. Microsoft Outlook, Mozilla's Thunderbird or Apple Inc.'s Mail). Very popular webmail providers include Gmail, Yahoo! Mail, Hotmail and AOL.

A major advantage of webmail over application-based e-mail is that a user has the ability to access their inbox from any Internet-connected computer around the world. You do not need to have a mail server or special software. It offers you plenty of storage, effective spam filtering, a fast interface and desktop e-mail access from any connected machine or device, even on some cell-phones. However, the need for Internet access is also a drawback, in that one cannot access old messages when not connected to the Internet.

To access your mail, you would be required to enter a user name and password. Once these have been accepted, you have access to the mailbox, which from there on functions in very much the same way as an ordinary mail client.

Web based mail clients need to be managed carefully. Usually there are quite strict size limitations. This means that they will fill quickly unless unneeded messages are deleted.

Some organisations provide additional to the normal e-mail, services such as web based mail linked to your own domain.

Web based e-mails can be set up free on sites like Hotmail, Yahoo Mail, Gmail, and Eudoramail. There are also sites which charge a fee. These would offer larger mail boxes and more features. These sites would be more suited to the business user who has to travel frequently.

Most of us use free e-mail services to create e-mail accounts and maintain them. There are real disadvantages of using free web-based e-mails, and you need to be aware of it.

1. The most important disadvantage is the security and privacy. We cannot control our privacy and security of our e-mails and profile data.
2. You can receive a high volume of unwanted e-mails (spam) even if you don't provide your e-mail addresses to a third party. Many free e-mail services sell their e-mail addresses to various marketing companies.

3. Most of the free web-based e-mail services provide simple web-based e-mail facilities where you can't do many modifications.

4. Free web-based e-mail services are a good advertising and marketing medium.

5. Some companies and individuals pay less attention to the e-mails they receive from free web-based e-mail services addresses as they experience that most of them are spam.

e-mail Etiquette

Although e-mail tends to be less formal than written communication, a poorly written and structured e-mail can cause offence. This is especially true in a business environment. Used correctly, it is a valuable business tool.

Below are some points to adhere to when writing e-mails:

- Insert a meaningful subject heading. Users scan their mailboxes before opening e-mails. A brief accurate subject heading can help them decide the relative importance of mail. Many users delete mail that is suspicious. e-mail with empty or meaningless subject headings would fall into this category.
- Use an appropriate mode of addressing the recipient. There is a tendency to start e-mail with the greeting Hi Jo. This level of familiarity and informality may be appropriate if you know the person you are sending the e-mail to. When sending a business e-mail, rather be too formal than too casual. Remember, many people may regard the casual mode of address as disrespectful.
- Be concise and to the point.
- Be clear but brief in constructing e-mail messages. It is quite common for users to receive a hundred or more e-mails at a time. Take into account that they might be under pressure when they receive your e-mail. Use correct paragraphing and headings to enhance the clarity.
- Check the spelling of your e-mail. It is very annoying to receive e-mail with many misspellings. Most e-mail clients allow you to spell check your e-mail.
- Likewise check the grammar of your e-mail.
- Do not use all upper case (capital) letters or all lower case letters when writing e-mail. Use the correct case for text. Even friends could react negatively to such lazy construction. Writing in capital letters in an e-mail means that you are screaming.
- Do not use slang, use emoticons and abbreviations sparingly.
- Include a signature at the end of your e-mails. This should include your full names, the capacity under which you are writing, your e-mail address, phone and fax numbers and any other information which might be relevant to the communication.
- If you respond to someone’s e-mail, answer all questions chronologically.
• Do not attach unnecessary files, especially big media and presentation files.
• Avoid forwarding jokes and “puppy and lovey” presentations to lots of people. If you want to share it with an individual, make sure that he/she wants it.
• Do not forward chain letters.
• Do not overuse the high priority option.
• Read your e-mail before sending it. Make sure about the message before it is going out.
• Check the recipients. Do they need to receive the e-mail? Make sure that you are not sending private e-mails to wrong recipients.
• Do not use e-mail to discuss confidential matters.

Security Considerations

How to Identify Unsolicited e-mail - Detailed Instructions

A distribution list is a set of e-mail addresses which are given a single collective name. A distribution list can have tens or hundreds of thousands of names on them.

Once a distribution list has been compiled, e-mails can be sent to every name on the list by sending it to the name of the list. In other words, it is as easy to send the mail to a hundred thousand recipients as to one.

This has led to a whole industry of creating and selling distribution lists. These lists are then used to send unsolicited e-mail to people on the lists. Unsolicited e-mail, known as spam is a major problem for both users and the Internet. The transmission of millions of messages across the Internet wastes valuable bandwidth and causes deterioration in Internet performance. For users, spam not only causes irritation but also fills up mail boxes.

To deal with the problem, some countries are now introducing legislation to prohibit spam. Some ISPs make use of special anti-spam software to block spam. Sometimes this software makes use of known sources of spam while at other times it uses special techniques to analyse the content. It is also possible to install anti-spam software on your computer.

Be aware of the danger of infecting the computer with a virus by opening an unrecognised mail message, an attachment contained within an unrecognised mail message

e-mail has been one of the major sources of the spread of computer viruses in recent times. These viruses are usually hidden in attachments to e-mails. There are numerous effects of these viruses.

As Linux is relatively unaffected by viruses, these effects apply mostly to non-Linux systems. However, the situation could change.

Viruses could:
• make your computer run more and more slowly to the point where it is inoperable
- delete data or entire hard drives
- change data
- send information stored on your computer back to hackers
- install programs on your computer which monitor your work and send details back to hackers
- use your computer to send infected e-mails to users in your e-mail client address book

On non-Linux systems, one of the standard actions you would take is to install anti-virus software that is able to scan e-mail. However, as the threat to Linux systems is very low, there is little anti-virus software available.

Although the viruses may present little direct threat to a Linux system, it is possible for viruses to lie dormant in files stored on a Linux system and be transmitted to non-Linux systems when mail is sent or forwarded.

You should take the precautions listed below. If you are unsure of an e-mail, do not open it or even preview it. Rather delete it.

- check the e-mail address to see if it is a known source
- if you do not know the sender, check the domain. Be particularly wary of unknown senders using web-based mail
- check the subject heading of the e-mail
- check if there are attachments. Be very careful of e-mail from unknown sources which have attachments
- as we are all becoming increasingly dependent on e-mail, we are often forced to take certain chances. In order to deal with possible loss, make regular backups on removable media such as CD.

**Digital Signatures**

Digital signatures provide a way of verifying that an e-mail is genuine and from the sender.

The process of using digital signatures makes use of a public key and a private key. If you wish to communicate with others using digital signatures, you will make your public key available to everyone but will keep your private key secret.

In order to use digital signatures, you would need special software. First the sender's software compresses the message into a much smaller block of text, the message digest, by a process called hashing. Hashing is a one way process as you cannot derive the original message from the text that has been hashed, even if you know the hashing algorithm. Once this has been done, the message digest is encrypted using the private key. The encrypted message digest is the digital signature which is then attached to the e-mail.

The receiver's software then decodes your digital signature using the public key to create the original message digest. At the same time it also generates a message digest from the e-mail using the same hashing technique. By comparing the two message digests, the receiver can determine the genuineness of the e-mail.
Summary

This section introduced you to electronic mail and some of the security issues that come with it. Electronic mail is a very important communication technology, but it also comes with the threat of viruses and others. Fortunately, for now, Linux operating systems are subject to a very low level of threat from viruses.

This section also discussed some of the etiquette considerations to be considered when using e-mail.
First Steps with e-mail

Section Overview

This section is meant to give you some hands-on experience using the Evolution e-mail client in Ubuntu.

In this section you will:

- Understand the basic features of the Evolution e-mail client.
- Learn how to customise the Evolution workspace.
- Learn how to access available Help features in Evolution.

Opening Evolution Mail

1. Choose Applications→Internet→Evolution Mail from the Ubuntu menu.

The Evolution interface appears as follows:
Close Evolution

Choose File→Exit from the Evolution menu, or click the exit button.

Features of the Evolution Window

When you open the Evolution application, you will see running across the top of the Writer window a menu bar and a toolbar which displays a series of icons or buttons that you can click on when you want to perform certain tasks. The window is further broken down into three panes: a list of folders on the left, a list of messages on the top-right, and a preview pane on the bottom-right.

Switch off the Preview Pane

There are a number of reasons why you might not wish to have the Preview pane displayed. From a security point of view, it is better that it is not displayed. When it is displayed, Evolution has to read the message. This is sufficient to activate certain virus activity. However, viruses are not an issue so far with Linux, so it is OK to leave it viewable if you prefer.
To switch it off choose View → Preview → Show Message Preview from the Evolution menu.

Use Available Help Functions

The help system for Evolution consists of an electronic book divided into a number of sections. Each section may contain one or more chapters.

To open Help:

1. Choose Help → Contents from the Evolution menu, or press the <F1> key on your keyboard.

2. The left hand pane consists of a list of the sections while the right hand pane is more detailed and has the chapters set out as a series of hyperlinks.
3. Click on **Using Evolution: An Overview**.

Display and Hide Built-In Toolbars

Changes to the toolbars are accomplished through the View menu.

1. Choose **View → Layout** from the Evolution menu
2. Check the toolbars you wish to have displayed. Uncheck those you want hidden.
The Inbox and Outbox

1. All receiving messages are placed in your Inbox.
2. When you send messages, it is temporarily stored in the Outbox before they are sent.
3. Deleted messages are placed in the Thrash (Deleted Items box)
4. Saved draft messages are placed in the Drafts box.
5. Sent messages are placed in the Sent Items Box.

The Message List

The message list is the top-right pane of your Evolution window. It contains a list of the messages you have in your active message folder.

You can switch between folders in the Folder List pane, on the left of your Evolution window. When you do, the message list will change.

The message list is split into columns by default:
- A From column, which lists the sender of the message
- A Subject column, which lists the subject of the message
- A Date column, which lists the date of the message.

You can sort your messages in the message list by clicking on any of the column headings to sort under that column.

Remove Message List Headings

By default the inbox displays messages according to who they are from, the subject and the date. Usually this is the information you need. You can remove these headings and add others. Remove a message heading:

1. Right click on the column you wish to remove.
2. Click Remove This Column in the context menu.
Add a New Message List Heading

1. Right click on a column.
2. Click **Add a Column**.
3. A list of possible column headings will be displayed. Drag the column you wish to insert to the desired location.
4. Click the Close button on the column list when done.

Summary

To assess your learning, make sure you are comfortable carrying out the following tasks in Evolution Mail:

1. Open and close the Evolution e-mail application.
2. Use the Help files to get information about using Evolution.
3. Display and hide the Evolution toolbars.
4. Modify the Message List pane.

This section introduced you to the basics of the Evolution e-mail application and showed how to get help when needed, and how to modify the application workspace.
Sending and Receiving Messages

Section Overview

In this section we will become familiar with receiving, opening, replying, and sending e-mails, and with downloading files attached to e-mails. Remember that e-mails can contain malicious content and files, so never open file attachments from unsolicited e-mails or e-mails from unknown sources.

In this section you will:
- learn how to open and close e-mail messages
- understand message flags
- work with file attachments
- reply to messages
- use spell check to check your messages before sending
- duplicate, move, and delete e-mail messages

Receiving, Opening, and Closing Messages

Receiving Messages

By default, Evolution checks for new messages when you open the application and every 10 minutes thereafter. To check for new messages any time:

1. Click the Inbox folder in the left pane.
2. Click on the Send/Receive icon to download messages and to send any outgoing messages.

Opening Mail Messages

Open a Single Message

1. In the message list, select the message you wish to read by clicking on it. If the preview pane is open, the message will appear there.
2. To open the message in a new window, choose Message→Open in New Window from the Evolution menu, or double click on the message.
3. Choose File ➔ Close from the message menu when done, or click on the Close icon on the top-right corner of the message.

Open Several Messages

1. Select multiple messages by holding down the &lt;Ctrl&gt; key and clicking on each of the messages.
2. To open the messages in their own windows, choose Message ➔ Open in New Window from the Evolution menu.

Switch between Open Messages

When a number of messages are open, an icon for each will be displayed at the bottom of the screen, as shown in the figure above. These icons will also include windows of other applications that may be open.

Click the icon corresponding to the message you wish to read. This will make the message the active window.

Close a Mail Message

To close the message window, do one of the following:

- Click the Close icon in the message window.
- Choose File ➔ Close from the message menu.
Marking Messages - Message Flags

You can manage the status of a message – it is called Message Flags. Before you can understand how to change the status, it is important to understand the status of a message.

If you open your mailbox, you can see different ways that messages are displayed:

- Unread messages are shown in bold and read messages in ordinary text in the inbox. In addition, an envelope icon is displayed to the left of the message. In the case of unread mail, this is a closed envelope. If you read a message, the envelope is open.
- Important messages can be marked with a red exclamation mark.
- If you send a file with your message (it is called a attachment), you will see a or a (small paperclip).

You can change the status display of messages in your mailbox. Go to the message, right click on the message. A context menu will appear.
You can do the following:

**To Mark a Message as Important – Add a Red Exclamation Mark**

1. Right-click on the message.
2. Click **Mark as Important**. The message is displayed in red with an exclamation mark.

**To Unmark an Important Message – Remove a Red Exclamation Mark**

1. Right click on the message.
2. Click **Mark as Unimportant**. (This option will only be available if the message is flagged as important.)

**To Mark an Unread Message as Read without Opening it**

1. Right click on the message to display the Context menu.
2. Click **Mark as Read**.

**To Mark a Message that has been Read as Unread**

1. Right click on the message to display the Context menu.
2. Click **Mark as Unread**.

**Note:** Both the Mark as Important/ Unimportant and Mark as Read / Unread are toggles. The option displayed in the context menu reverses the current status. Open and save a file attachment to a location on a drive.

---

**e-mail Attachments**

An attachment is a file that you send along with an e-mail message.

**Note:** Attachments are a major method for the spread of computer sources.

When you receive an attachment you have the option of saving it immediately without looking at it, or of opening it. If it is a text file, it would be opened in your word processor.

An attachment could also be a spreadsheet, presentation, database file, video or audio file, or any other type of file.

Messages that have attachments are marked with a paper clip.
Save a Message Attachment

When you receive a message containing an attachment, there is an attachment icon visible. You can also see a Save button before the message, and a display button after it.

With these, you can save the attachments to your files pace or in an external application.

1. Open a message with an attachment.
2. Scroll down to the bottom of the message where the attachment icon is displayed.
3. Click on the icon.
4. Click Save As.
5. The standard Save as window will be displayed in which you will be required to specify the directory location and name you wish to use.

You can also hit the Save button.

Open Message Attachment

You can choose to open a message attachment directly. This action will load the associated application and open the file. For example, if the attachment was a word processor document, it would open in OpenOffice Writer.

1. Select the Open option in the context menu.
2. Use File→Save as if you wish to save the document.
Reply to a Message

Basic Terminology

You are now able to open, read and close an e-mail. You can also read and save attachments.

To reply to a received message, you must first understand the terminology used in replying.

First you have to determine who is the sender of your e-mail. You will find it in the From: ..... line at the top of the e-mail.

If the message is from a list (not an individual name) – DO NOT REPLY. A lot of unnecessary mails are sent to lots of people unintentionally by replying to a list.

Secondly you have to understand who are contained in the following fields:

<table>
<thead>
<tr>
<th>From</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>To</td>
<td></td>
</tr>
<tr>
<td>Cc</td>
<td></td>
</tr>
<tr>
<td>Bcc</td>
<td></td>
</tr>
</tbody>
</table>

- **From:** - contains the e-mail address of the sender of an e-mail.
  - If the e-mail address indicates that it is from a list, do not reply if you are not 100% sure that you want to send the e-mail to all the people subscribed to that list. The e-mail will go to all the subscribers to that list.
  - If it is from a system, do not reply.

- **To:** - contains the e-mail address/es of the recipient/s of your e-mail. This field is automatically filled when you hit the reply button. **MAKE SURE THAT YOU WANT TO SEND AN E-MAIL TO THAT SPECIFIC PERSON.**

  It is normally expected that people who receives an e-mail directly (Included in To:.....), must respond to the e-mail.

- **Cc:** - is short for "Carbon Copy". Both the original recipient and all the recipients of the carbon copies see the To: and Cc: fields including all the addresses in them.

  It is normally expected that people who receives an e-mail copy (Included in Cc:....), must only take note and don’t need to respond to the message.
- **Bcc**: is short for “Blind Carbon Copy”. A copy of the message goes to every single email address appearing in the Bcc: field, but the recipients do not see the To: and Cc: fields including all the addresses in them. It ensures maximum anonymity of the people in the To: and Cc: fields.

**How do you reply a message?**

To reply to a message, you can hit the **Reply** or the **Reply All** button.

![Email Reply Example](image)

**What is the difference between the ‘Reply’ and the ‘Reply to All’ Function?**

Messages are often sent to a number of people at the same time.

When you reply to a message, you may reply to the sender only or to all the recipients as well as the sender of the original message.

To reply to the Sender only (check that it is not a list or a server):

1. Open a message that has one sender and perhaps multiple recipients.
2. Click the **Reply** button or `<Ctrl>R`.

This will display a new window containing:
- Your name in the **From:** field
- The sender of the previous message and the person you want to reply to in the **To:** field (check again if you have the right address in the **To:** field)
- The subject line appears as Re: ……….. to indicate it is a reply. The Subject will be the same subject as in the original message
- The text of the original message, sometimes preceded by > signs.

Add your new content to the message.
You can:

- Write your whole response at the top of the original message, leaving the message at the bottom for reference.
- If desired, you can delete part or all of the content from the original message.
- You can also add new content at any place in the message so it resembles a conversation. This is called "continuing the thread." If you make comments in the body of the original message, it is a good idea to type your replies in a different colour font such as red or to indicate which part of the mail is the original message and which part is your response. You can type:
  - You said: followed by a part of the original message
  - Your name: followed by your response

3. Click the **Send** button.

**Reply to All**

Be mindful of the recipients receiving a message when you choose to **Reply to All**.

1. Click the **Reply to All** button or press `<Shift><Ctrl>R`.
2. Type in the reply.
3. Click **Send**.

**Sending a Message**

**Create a new message**

1. Click **Message**→**Compose New Message** from the Evolution menu, or click the **New** icon and choose **Message**.
2. Insert a mail address in the **To** field:
   - Type the full e-mail address of the person to whom you are sending the e-mail into the **To** field.
   - If you wish to send the e-mail to more than one person, separate their e-mail addresses with a semi colon
   - You can access your contact list by clicking on the **To** button. Select the contact from the list and press the **Add** button.

![Contact List Image]

3. If you like, you can Copy (Cc), blind copy (Bcc) a message to another address/addresses

   **Remember:**
   - When you send a Cc, this will be indicated to all recipients of the mail. Recipients of a Cc will not be expected to reply. If you expect a reply from a recipient, include their e-mail address in the **To** window, not the **Cc** window.
   - If you wish to send a copy to one or more recipients but do not wish to disclose recipients’ names, use enter their names into the Bcc window.

4. Enter a subject into the **Subject window**. Use a meaningful subject. Many users receive more e-mail each day than they are able to read. Use a subject heading that is meaningful and gives the reader as clear and concise indication of the contents of the e-mail as possible.

5. Click **Send** when done.
Spell-Checking Tool

Use a Spell-Checking Tool for your emails when available. Make all changes such as: correcting spelling errors, deleted repeated words that are suggested by the tool.

Remember to check again before sending your email.

Note: The spell checking tool is not a substitute for good spelling, typing, and editing skills. Just because a word is spelled correctly, doesn’t mean it’s the correct word, as in this sentence:

I couldn’t right with that pen!

By default, spell checking is not enabled. To enable it:

1. Choose Edit ➔ Preferences from the Evolution menu.
2. Click Composer Preferences.
3. Select the dictionary for your location
4. You may also select to check spelling as you type.
5. Click OK.

Spell Check a Mail Message

1. Type your message. If you have selected to spell check as you type, Evolution will mark words it interprets as misspelled.
2. When you have finished, choose Edit ➔ Check Spelling from the Evolution menu.
3. You will be prompted with suggestions for incorrect words. Select a correction or press **Skip** if you do not wish to change the word. Pressing **Ignore** will skip all occurrences of the word.

4. Click **Close** when finished.

---

**Note:** You may add new words to the dictionary by clicking the Add word button when Evolution encounters a new word in a document.

---

**Attach a File to a Message**

File attachments are a great way to share documents.

Whenever sending an attachment, please be wary of SIZE.

Many e-mail systems, especially web-based e-mail, limit the size of the file attachment allowed, but most e-mail systems allow files of up to 2 MB or more.

It is very inconsiderate if you send big attachments, especially to people with slow connections.

To attach a file to a message:

1. Type your message and subject, and add recipients.
2. Click the **Attach** button or choose **Insert** ➔ **Attachment** from the Evolution menu.
3. Locate the directory in which the file is located and select the file.
4. Click **OK**.

An attachment icon will now be displayed at the bottom of the message. If you wish to remove the attachment, right click on it and select **Remove** or press <Delete>.
Send a Message with High, Low Priority

The priority of a message refers to the importance the messaging system gives to the message.

Before sending a message, you can mark it as important. Choose Edit → Mark as Important.

You can still mark the priority of messages while they are waiting in the Outbox.

1. Right click on the message.
2. Select Mark as Important in the context menu. This will display an exclamation mark next to the message indicating high priority.
3. To remove the high priority option, right click on the message and click Select as Unimportant.

Forward a Message

Forwarding a mail message involves sending a message you have received to one or more other recipients. You may edit the mail message and add your own message before you forward it.

The original message may be sent as an attachment or may be incorporated into the body of the e-mail.
Set the Forwarding Options

You can forward messages as an attachment, inline (as part of your message), or quoted.

1. Choose **Edit**→**Preferences** from the Evolution menu and click **Composer Options**.
2. Click the **Forward style** drop-list and select the style you wish.
3. Click **OK** when done.

Forward an e-Mail

To forward an e-mail, open the mail message you wish to forward.

1. Click the **Forward** button.
2. Type in the list of e-mail addresses or a distribution list into the **To** window.
3. Add/edit text in the same way you would if you were replying to a sender.
4. Press **Send** when done.

Duplicate, Move and Delete Messages

Text can be copied or moved between messages in exactly the same way as is done between documents

**Duplicate Text within an e-Mail Message**

1. Highlight the text to be duplicated.
2. Choose **Edit**→**Copy** from the Evolution menu or press **<Ctrl>C**.
3. Position the cursor where the text is to be inserted.
4. Choose **Edit**→**Paste** from the Evolution menu or press **<Ctrl>V**.
Move Text within an e-Mail Message

1. Highlight the text to be moved.
2. Choose Edit  Cut from the Evolution menu or press <Ctrl>-X.
3. Position the cursor where the text is to be inserted.
4. Choose Edit  Paste from the Evolution menu or press <Ctrl>-V.

Duplicate Text from Another Source into a Message

Suppose you have text in another e-mail message or in an OpenOffice.org Writer file that you wish to copy into an e-mail message.

1. Open the document from which you wish to copy the text.
2. Highlight the text and copy using Edit  Copy or press <Ctrl>-C.
3. Switch to the message into which you wish to copy the text.
4. Choose Edit  Paste from the Evolution menu or press <Ctrl>-V.

Delete Text in a Message

1. Highlight the text to be deleted and press the <Delete> key.

Delete a File Attachment from an Outgoing Message

Attachments to messages are shown in an attachment pane at the bottom of the screen.

1. Right click on the attachment you wish to delete.
2. Click Remove in the context menu.

Delete a Message

1. Click on the message you want to delete.
2. Press the <Delete> key on your keyboard. The message is deleted to your trash bin, and can be retrieved if necessary.

Empty the Mail Bin/Deleted Items Folder

If you are sure that you no longer need any message in Trash, you can empty its contents. This will permanently delete all the messages.

1. Choose File  Empty Trash from the Evolution menu.
2. Click OK if you are sure.
Summary

This section brought you further into the practical use of Evolution e-mail. We discussed opening messages, replying, and using file attachments. We also introduced the concept of managing messages by copying, deleting, and moving messages.

To assess your learning, make sure you are comfortable carrying out the following tasks in Evolution Mail:
1. Open and read an e-mail message.
2. Save and open an attachment to an e-mail message.
3. Reply to a message.
4. Attach a file to an e-mail message.
5. Manage your messages by moving, copying, or deleting them.
Mail Management

Section Overview

In the previous section, we introduced you to e-mail management with deleting, copying, and moving messages. This section will help you to develop strategies for managing your e-mail – an important concept since your e-mail boxes are filled up quickly.

In this Section you will be introduced to some techniques to manage e-mail effectively such as creating and naming folders, moving messages to appropriate folders, deleting unnecessary e-mail, and using address lists.

Management Techniques

If you use e-mail as a regular feature of your daily work, it is quite possible that you will receive 50 or 100 e-mails in a day. Over a period of a few months, this adds up to thousands of e-mails. Obviously the frequent user will need to develop strategies not only for dealing with received mail, but also for sending mail.

Using Mail Folders

Mail folders are to e-mail what directories are to files. You can create mail folders in which you store incoming and outgoing mail.

Often users are careful about creating folders for incoming mail but forget completely about organising outgoing mail.

Copies of outgoing mail are allowed to accumulate in the Sent folder. One way of dealing with this is to create a folder for a particular category and then create two sub-folders within this for incoming mail and copies of outgoing mail.

Sometimes you may receive so much mail for a particular category that it needs to be divided into sub-categories which in turn have in-coming and out-going sub-folders.

When you create folders give them meaningful names.

You can modify your folder structure on an on-going basis and drag mail from one folder to the next.

Delete Unwanted Mail

Only keep mail that you need to keep a record of. As a security measure against viruses you may want to delete mail from suspicious sources without opening it.

If you find you are receiving spam, consider making use of anti-spam software that will block spam from known sources.
Make Use of Address Book and Distribution Lists to Send e-Mails

Instead of having to type an address every time you want to send an e-mail, you can make use of an Address Book.

Your address book should store all of your frequently used email addresses, enabling you to select from a list instead of having to re-type the addresses each time you send an email. This is the fastest way to address a message, and more importantly ensures that you will never make a typing mistake and send your email to the wrong address.

Create an Address Book

Create your own Address Book by clicking on Tools→Address Book.

To enter a new address, click on .

Complete the “card” as full as possible. It is good practice to keep a detailed address book. Ensure that there are no spelling errors/typos, especially in the e-mail address.

Hit OK when finished.

Update an Address Book from Incoming Mail

If possible, you should copy each address from a valid email and then paste it into your address book when you create an entry for the first time, because this is faster, and more importantly you will be sure there aren't any typing mistakes.

If the address form has an option like "Include on recipient or nickname list", then you should select that option to make sure the address will show up on your address book menu from anywhere in your email program.
Instead of typing a new entry into the Address Book, Evolution can do it for you directly from e-mail in your mail boxes:

1. Right click on the message.
2. Select Add to Address book in the context menu.
3. A window will appear with the name and e-mail address of the new contact. Click Add to Address Book to add this to your existing address book.

Distribution Lists

A Distribution List is used when you are frequently sending e-mails to a group of people.

A Distribution List is a list of e-mail addresses stored in your Address Book and you only need to enter the name of the distribution list when you want to send e-mails to all the people on the list.

Distribution lists provide a convenient way of sending the same e-mail to a number of users at the same time. By creating a number of distribution lists you can work very efficiently with Evolution.

Create a Distribution List

1. Choose File→New→Contact/Mailing list from the Evolution menu or go to your Address Book Tools→Address Book and hit the New List button.
2. Enter a name for the new List.
3. Type an e-mail address into the top window of the Members area.
4. Click Add.
5. Repeat this process to add new members.
6. Click OK when complete.

You can also get a screen like this one without an add button.

**Send an e-mail to all Recipients on a Contact/Distribution List**

To send an e-mail to a list, type the name of the Contact list into the To field instead of a normal e-mail address or select from your Address Book.

**Note:** You may click on the To icon to display a list of contacts and contact lists. You can then select the recipients (contact lists and contacts). Evolution will enter them automatically in the To field.
Search for Messages

You can enter filter criteria in the Search tool window that will enable you to display messages from a particular sender, messages having a similar subject title or messages containing certain words in the body of the message.

Type your search term in the search window and click on the Search button on the right side of the search window (the small broom icon).

Search Criteria

You can search for messages by subject, sender, or recipient. Choose the search criteria from the drop-down list accessed by clicking on the magnifying glass icon on the left side of the search window.

You can:

Search for messages by subject:
- Click Subject contains.
- Enter text that the subject must contain and click the Search button.
Search for messages by sender:
- Click **Sender contains**.
- Enter text that selects the sender. (It can be part of the sender's name) and click the **Search** button.

Search for messages by body text:
- Click **Body contains**.
- Enter text that selects the sender. (It can be part of the sender's name) and click the **Search** button.

Search messages for content:
The previous three options limited the search to the sender, body text, or the subject. It’s also possible to search all parts of the message.
- Click **Message contains**.
- Enter a word or phrase that the message contains and click the **Search icon**.

Search using the other options:
The main components of a message are the sender, subject and message body. The body of a message is the actual text of the message excluding subject and sender. When you search using the Message contains option, the search function will scan the sender, subject and body. You can include just certain components of the message in the search. The main advantage is that by being more specific about where to search, the speed of the search will improve. This is important if you have thousands of messages in your mailbox.

**Organising Messages**

You can create folders and subfolders to organise your messages, in much the same way as you create a directory structure to organise your files.

**Creating Folders**

1. Make sure the Folder bar is displayed.
2. Choose **File** → **New** → **Mail Folder** from the Evolution menu.

3. Type in a name for the new folder.
4. Click on **On this Computer** in the folder list.
5. Click **Create**.

In the example above, a new folder called **CCNC** will be created at the same level as your Inbox, Drafts etc.
Create Sub-Folders

To create a subfolder within an existing folder:

1. Choose **File**→**New**→**Mail Folder** from the Evolution menu or click the **New** button on the tool bar and choose **Mail Folder**.
2. Type in a name for the new sub-folder.
3. Choose a folder to create the subfolder in (**Specify where to create the folder**).

In the example above, a subfolder called **Module 1** will be created in a folder **CCNC**.
4. Click **Create**. The new folder will be created inside the folder you have selected.
5. Create any number of folders and sub-folders that suit your needs.
Move Messages to a New Folder

Move a message by dragging:

1. Highlight the message you wish to move.
2. Hold down the left mouse button and drag the message to the new folder.
3. Release the left mouse button when the target folder is displayed with a solid border.

Move a message using the context menu:

1. Right click on the message you wish to move.
2. Select Move to Folder in the context menu.
3. Highlight the target folder in the list that is displayed.
4. Click OK.

Copy a Message to a New Folder

You can use a similar method to make a duplicate of a message in a folder.

1. Right click on the message you wish to move.
2. Select Copy to Folder in the context menu.
3. Highlight the target folder in the list that is displayed.
4. Click OK.

Prepare to Print

Messages can be printed just like any other document. In the interest of saving resources, only print messages if necessary. If you need a record of your e-mail, consider backing it up to an electronic storage medium instead.
Preview a Message

You can view what a message will like when printed before actually printing it:

1. Click on the message you wish to preview
2. Choose File ➔ Print Preview from the Evolution menu.

This will display the message as it will print.

3. If the message contains more than one page, you can move to the next or previous page. Alternatively you can move to the last page or the first page.
4. You may also magnify or reduce the image.
5. Click Print if you would like to print the message.
Choose Print Output Options such as: Entire Message, Selected Contents of a Message, Number of Copies and Print

1. Open the message you wish to print.
2. Choose File→Print from the Evolution menu.

3. Set the number of copies you wish to print.
4. If the message contains more than one page, check Collate if you wish the pages to be collated.
5. Specify a range of pages to be printed. By default, all pages are printed.
6. Select the printer you wish to print to.
7. Click on the Print button.

Web-Based e-Mail

There is a huge increase in the use of web-based e-mails. It is important that you are able to set up a web-based e-mail account for yourself. It has advantages and disadvantages as discussed.

You can make use of any Web-based e-mail. Some of them are free. For the purpose of these materials, GMail is used.

What is GMail?

GMail is a web-based e-mail (webmail) platform (tool) where you can communicate messages electronically via the Internet. You can send just about anything instantly (Letters, documents, photos and files) to one or more people!
Some Advantages of using Gmail (and other web-based e-mail)

- it is free
- it is always available (provided you have internet access)
- it has great spam filters
- built-in chat: text, voice, or video (great for meetings)
- it allows you access to other good online tools:
  - Picasa (online photo album sharing)
  - Google docs (Free online office suite)
  - Blogger (free online blogging tool)
  - Google reader (Keep up to date)
  - Gtalk (an instant messenger service)
- you can
  - log into numerous sites using your Gmail address and password (great for privacy)
  - easily access it using your cell phone
  - organise your e-mail in numerous ways
  - separate your work and private e-mail
  - forward your Gmail to your private/work e-mail
  - set it up to download into Outlook for offline reading
- you get lots of space

Registering for a Gmail Account

You have been introduced to the Gmail registration form on page 56.

To register:

- Make sure that you are connected to the Internet
- Open up your browser (eg Firefox)
- Type in www.gmail.com into your browser address bar

As you are a new user, click on Sign up for Gmail. In order to sign up for Gmail, you will first have to create a Google account.

- Fill in your name and your surname
- Choose a username (try to find something that will not already be taken!)
• Hit **Check availability**…..
  Choose new usernames until you get one that is available!

• Type in a password (one that you will remember!). It must consist of at least 6 characters (use numbers and letters)
• Retype password

![](image.png)

If you are using a public, school or work computer used by others, un-tick Remember me on this computer.

• Click on the drop-down arrow next to Security question
• Choose **Write my own question**
• Type in a simple question and answer
• If you have another e-mail (e.g. work), insert it otherwise, leave blank
• Click on the dropdown next to location and choose your country.
• Type in the verification code very carefully.
• Accept the terms.
You will see that your Gmail has the same features as an ordinary e-mail account. Look for the equivalent action on the screen, for example **Compose Mail** means the same as hitting the **New** button.

Familiarise yourself with the functionalities of the tool. You can now:

- Send and receive mail
- Attach documents
- Read and reply to messages
- Forward messages
- Compile an Address Book and Distribution Lists
- Manage your mail boxes
- Print e-mail and attachments

**Summary**

This section introduced you to some strategies for managing your e-mail messages, including using folders to store messages and using contact lists for distributing mail to multiple contacts.

You also learned some techniques for searching your e-mail messages for particular messages using a variety of search criteria. Finally, you learned how to set up your messages for printing.

To assess your learning, make sure you are comfortable carrying out the following tasks in Evolution Mail:
1. Create folders, delete folders, and move folders in the Folder list.
2. Move messages from the Message list to appropriate folders in the Folder list.
3. Create a Contact list for distributing e-mails to many people at the same time.
4. Manage your Contact lists by adding or deleting contacts.
5. Search for messages on a variety of criteria.
6. Set print options and print messages
Web-based Communication Technologies

Section Overview

This section will provide a brief overview of some newer, exciting technologies that enhance our ability to communicate in a number of ways. These include such things as instant messaging, podcasts, and virtual communities.

In this section you will:

- be introduced to some web-based communication technologies
- understand instant messaging technology and its application
- understand how podcasts are used to make media available
- learn about Short Message Service technologies
- understand Really Simple Syndication (RSS)
- learn about Voice over Internet Protocol (VOIP) technologies
- be introduced to virtual communities/social networking such as FaceBook

Instant Messaging (IM)

Instant messaging (IM) is a form of real-time communication between two or more people based on typed text. The text is conveyed using devices connected over a network, usually over the Internet.

What separates IM from e-mail is that the communication is in real-time (or very close to that). Feedback, therefore, is immediate, and that promotes a sense that the communication is synchronous. Also, it’s usually possible to tell if contacts are online or not.

Instant messaging systems came before the Internet, but were limited to communication between users of the same local network. In the mid-1990s, modern IM applications began to arise, with some of the most popular being PowWow and ICQ.

Some systems also attempted to incorporate audio and video (using webcams) into an IM session, most notably CU-SeeMe and Microsoft NetMeeting. File transfer and application sharing were features of some IM applications as well.

At present, there are a variety of protocols used to specify communication with instant messaging. As a result, IM applications often do not work with other IM applications, or sometimes even with a different version of the same application. For best results it’s important to use the same version of the same application.
Most IM applications are freely downloadable, making instant messaging a low cost solution for real-time communication over the Internet.

The most popular IM applications, at least in the western world, are **Windows Live Messenger** and **Yahoo! Messenger**. An application called Tencent QQ, with a massive user base in China, eclipses both of these however.

**Podcasts**

A podcast is a series of audio or video files that are released as episodes. It is this episodic nature that differentiates podcasts from other media downloads. To support this, you must go through a process to subscribe to the podcast service.

Podcasts take advantage of software that can automatically identify and download new “episodes” as they are released. Many popular media player applications double as “podcatchers”, including iTunes, Zune, or Winamp.

**Short Message Service (SMS)**

Short Message Service (SMS) is commonly known as **text messaging** or **“texting”**. It is a standardised service, which means that it uses a set of standard communication protocols that allow various devices to communicate with each other.

SMS is the most widely used data application on the planet, with over
2.4 billion users (over 74% of mobile phone subscribers). In 2006, the SMS industry was worth over 81 billion dollars annually.

Really Simple Syndication (RSS)

RSS or RSS Feeds, are web feeds used to publish content that is frequently updated, such as news headlines, stock market quotations, audio, or video. They benefit users who need to get timely updates to variable content.

RSS formats are specified using XML (extensible markup language), a standard specification for the creation of data formats.

Below is an image of the Canadian Broadcasting Corporation’s headline news RSS feed.

Voice Over Internet Protocol (VoIP)

Voice Over Internet Protocol (VoIP) is a group of technologies that deliver voice communication over Internet networks, essentially bypassing the traditional public switched telephone networks.

The protocol specifies the conversion of the analog voice signal to digital, the translation of
the digital signal to Internet Protocol for transfer over the Internet, and the reverse process at the other end of the call.

VoIP can be a great benefit for reducing communication costs, since there is no need for separate data and voice lines. Also, costs are lower since traditional phone lines are billed by the minute, but VoIP calls are billed by the volume of data transferred (in megabytes). In practice, the amount charged for a 1-hour VoIP call is much less than for a 1-hour call on a regular telephone line.

**Virtual Communities**

Virtual communities have been around for longer than the Internet. It began with electronic bulletin board systems (BBS) which were connected to using a modem and analog telephone lines. These communities were formed by people interested in similar subjects, like computing for example.

The original Internet virtual communities, formed primarily on USENET, were heavily text based. On the other hand, modern virtual communities use Web applications that incorporate a great variety of media and interactive capability such as synchronous text, audio, and video communication.

The social networking applications such as FaceBook and MySpace, are examples of the latest generation of virtual communities.

Virtual communities come with some philosophical issues, particularly centred around what influence the virtual community has on the physical community of an individual, especially with children who are developing their ability to communicate and relate in the “real” world. As well, issues of privacy abound, since many of these communities are not entirely away from the public eye.
Summary

This section introduced the concept of web-based communication technologies. These technologies are evolving rapidly. They offer many benefits to their user groups: the ability to communicate with large groups of people, in real-time, with text, audio, and video, and for a relatively low cost. However, they also are clearly affecting the way we interact as a society, and their social impact on our culture is just beginning to be seen.