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Course overview 

Welcome to Introduction to 3D 
Animation  

In this block, you are going to study about the 3DModelling 

Techniques. Basically 3D Modelling is used for creating 3D model. 

By using Blender software one can create wonderful model. 

Blender is the free and Open Source 3D animation software. 

Blender can be used to create 3D visualizations such as still 

images, video, and real-time interactive video games. Blender is a 

fully integrated 3D content creation suite, offering a broad range 

of essential tools, including Modelling, Rendering, Animation, 

Video Editing, VFX, Compositing, Texturing, Rigging, many types of 

Simulations, and Game Creation. 

It is a Cross-Platform an OpenGL GUI and runs on Linux, Mac OS, 
and MS-Windows systems with less memory and disk footprint. Its 
interface uses OpenGL to provide a consistent experience across 
all supported hardware and platforms. As this is 3D based 
software, the navigation and the working pattern are very 
different unlike any other 2D based software.  

Introduction to 3 D Space in 
Blender  

This Course will teach you, what is 3D Interface and how to 
experience the Navigation within the 3D space using different 
Transformation Tools to manage the work flow and the creation 
of basic Meshes (objects) in Blender; Create Basic Primitives, 
Shortcuts and Identify Buttons and Controls; Customize the user 
interface to limit the tools and option required for the user in 
Blender; Use Hot keys; Interact with 3D scene using 3D View for a 
variety of purposes, such as modeling, animation, texture painting, 
etc. 

file:///D:\++%20Anu%20Ma++\Anu%20Editor\Content%20Edit\Edited\html\modeling\introduction.html
file:///D:\++%20Anu%20Ma++\Anu%20Editor\Content%20Edit\Edited\html\render\introduction.html
file:///D:\++%20Anu%20Ma++\Anu%20Editor\Content%20Edit\Edited\html\animation\introduction.html
file:///D:\++%20Anu%20Ma++\Anu%20Editor\Content%20Edit\Edited\html\editors\sequencer\index.html
file:///D:\++%20Anu%20Ma++\Anu%20Editor\Content%20Edit\Edited\html\editors\movie_clip_editor\index.html
file:///D:\++%20Anu%20Ma++\Anu%20Editor\Content%20Edit\Edited\html\compositing\introduction.html
file:///D:\++%20Anu%20Ma++\Anu%20Editor\Content%20Edit\Edited\html\editors\uv_image\uv_editing\overview.html
file:///D:\++%20Anu%20Ma++\Anu%20Editor\Content%20Edit\Edited\html\rigging\introduction.html
file:///D:\++%20Anu%20Ma++\Anu%20Editor\Content%20Edit\Edited\html\physics\introduction.html
file:///D:\++%20Anu%20Ma++\Anu%20Editor\Content%20Edit\Edited\html\game_engine\introduction.html
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Introduction to Modelling 
techniques  

This unit will instruct you, what 3D Modeling is and about the 
important tools, which support the work flow in 3D modeling 
using various options. You will also learn in detail how to Create, 
Select, duplicate and mirroring a Single Object; To Create Multiple 
Objects with Mirror and Duplicate; Create Object with the 
knowledge of the Pivot; Edit Pivot Point using Snap Tool which 
gives us more flexibility; Organize 3D Scenes using Layers; 
Channelize your work flow that helps you to bring down the 
complexities of the software; and to Load the Objects to layers to 
ensure an organised way of handling complex scenes.   

Inorganic Modelling 

Curves and Surfaces are very important for Modeling.  They are 
the types of Blender Objects. They are expressed by mathematical 
functions rather than a series of points. Using the specific features 
of both Bezier and NURBs curves, you will create a model in 3D, 
and explore how they are computed behind the scenes than how 
they appear from a modeler’s perspective.  Curves are 2D objects, 
and Surfaces are their 3D extension. Note however, that in 
Blender, you only have NURBS Surfaces, no Bezier. Even though 
curves and Surfaces share the same object type, they are not the 
same thing; For example, you cannot have in the same object both 
curves and Surfaces. In this Unit, you will learn the usage of 
Curves and Surfaces for modelling and how to Create Objects 
using Curves and Surfaces in Blender; Edit them using different 
Modes; Work with Surface modelling and Nurbs modelling; Work 
effectively with 2D shapes and to Prepare Curve Deformation and 
Curve Extrusion.  

Organic Modelling 

This course will guide the creation of a 3D scene using three key 
components to create the real-time Geometry Modelling in 
Blender. You will also learn to use the specific features of Blender 
3D software, each one of these Primitives can be manipulated to 
produce an Object. You will create a model in 3D, and explore the 
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various modelling methods used in the production. There are 
three basic methods that will be used to create a 3D model, and 
you will understand how to create a model using each technique 
with 3D Mesh / Primitives; Edit them with different Modes; Work 
with Mesh Modelling; Create Polygon Objects and to Analyse the 
Mesh.  

 

This video will provide a brief overview of this course. 

Topic YouTube link QR 

Code 

Video 1 –Introduction to 3D 

 
https://youtu.be/8d49m8P

NWs0 

 

Video 2 –Introduction to 

Blender 

 

https://youtu.be/RXToUH

OHDxE 

 

Video 3 –Polygon Modeling 
https://youtu.be/9cCgOZI6

frY 

 

 

Course outcomes 

Upon completion of 3D Modelling you will be able to: 

 

Outcomes 

 Interface and customize elements as the Info Editor (Top), 
a large 3D View, Time Line (Bottom), Outliner (Top right), 
properties Editor (Bottom right etc. 

 Use Transformation tools in Blender  

 Create Multiple Objects with Mirror and Duplicate  

 Working Surface modelling  

 Create Polygon Objects  

 

https://youtu.be/8d49m8PNWs0
https://youtu.be/8d49m8PNWs0
https://youtu.be/RXToUHOHDxE
https://youtu.be/RXToUHOHDxE
https://youtu.be/9cCgOZI6frY
https://youtu.be/9cCgOZI6frY


 

 

Course overview Introduction to 3D space 
  

8 
 

 
 

Timeframe 

 

How long? 

This course will be completed within “2” classes. 

This course is of “1” credits. 

1 Hour of study time is required for this unit. 

 

 

 

Study skills 

 

This is a totally practical oriented course. 

Hence, you should have access to personal computer or personal laptop 
for better understanding of this unit. 

Each and every options are explained step by step in the course 
material.  

Apart from this course material, the learner has to adopt the tendency 
of learning from multiple sources i.e., 

 Internet tutorials 

 Video tutorials on YouTube 

 Collaboration with people working in the industry etc. 

Only classroom study will not make you a professional. You have to be 
active to grab the opportunity of learning wherever you get a chance. 

 

Need help? 

 

Help 

In case of any help needed you can browse the internet sites like 
youtube.com for video tutorials about the subject. 

 

Apart from that, you can contact the writer of this course material at 
praseed.nair@manipal.edu 
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Assignments 

 

Assignments 

There will be some assignments at the end of each unit. 

These assignments are mostly practical based and should be submitted 
in CD or DVD. Theoretical assignments are to be submitted neatly 
written on A4 size sheet. 

All assignments will be submitted to Regional centre of Odisha State 
Open University or as directed by Co-ordinator. 

All assignment should be unit wise on separate CD/DVDs clearly 
mentioning course title and unit on Top. Theoretical Assignment will be 
neatly filed or spiral bind with cover clearly mentioning necessary 
information of course, student detain on top. 

 

Assessments 

 

Assessments 

There will be few assessment questions for each unit. 

All practical assessment will be submitted to OSOU. 

Assessment will take place once at the end of each unit. 

Learner will be allowed to complete the assessment within stipulated 
time frame given by the university. 

Video Resources 

This study material comes with additional online resources in the form of 

videos.  As videos puts in human element to e-learning at the same time 

demonstrating the concepts visually also improves the overall learning 

experience.  

You can download any QR code reader from Google Play to view the 

videos embedded in the course or type the URL on a web browser.  

 

Reading 
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Getting around this Course material 

Margin icons 

While working through this Course material you will notice the frequent 
use of margin icons. These icons serve to “signpost” a particular piece of 
text, a new task or change in activity; they have been included to help 
you to find your way around thisCourse material. 

A complete icon set is shown below. We suggest that you familiarize 
yourself with the icons and their meaning before starting your study. 

 

 
 

 

 

Activity Assessment Assignment Case study 

    

Discussion Group activity Help Note it! 

   

 

Outcomes Reading Reflection Study skills 

 
   

Summary Terminology Time Tip 
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Unit-1 

Introduction to 3D space 

Introduction 

Welcome to Blender, the free and Open Source 3D animation 
suite. Blender can be used to create 3D visualizations such as still 
images, video, and real-time interactive video games.  

Blender is well suited to individuals and small studios that benefit 
from its unified pipeline and responsive development process. 

It is a cross-platform and runs on Linux,macOS, and MS-Windows 
systems with less memory and disk footprint. Its interface uses 
OpenGL to provide a consistent experience across all supported 
hardware and platforms. 

Key Features 

 Blender is a fully integrated 3D content creation suite, 
offering a broad range of essential tools,  
includingModelling,Rendering,Animation,Video 
Editing,VFX,Compositing,Texturing,Rigging, many types 
ofSimulations, andGame Creation. 

 Cross platform, with an OpenGL GUI that is uniform on all 
major platforms (and customizable with Python scripts). 

 High-quality 3D architecture enabling fast and efficient 
creation work-flow. 

 Excellent community support fromforumsandIRC. 

 Small executable size, optionally portable. 

 
 
Title-Img 1. 1A rendered image being post-processed. 

../../html/modeling/introduction.html
../../html/render/introduction.html
../../html/animation/introduction.html
../../html/editors/sequencer/index.html
../../html/editors/sequencer/index.html
../../html/editors/sequencer/index.html
../../html/editors/movie_clip_editor/index.html
../../html/compositing/introduction.html
../../html/editors/uv_image/uv_editing/overview.html
../../html/rigging/introduction.html
../../html/physics/introduction.html
../../html/game_engine/introduction.html
http://blenderartists.org/forum/
../../html/getting_started/about/community.html#irc-channels
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Attribution-  
Source- blender.org 
Link- 
https://docs.blender.org/manual/en/dev/getting_started/about/introduction.ht
ml 

 

Despite everything Blender can do, it remains a tool. Talented 
artists do not create masterpieces by pressing buttons or 
manipulating brushes, however, by learning and practicing 
subjects such as human anatomy, composition, lighting, 
animation principles. 

3D Content Creation Software such as Blender has the added 
technical complexity and jargon associated with the underlying 
technologies. Terms like UV maps, Materials, Shaders, Meshes, 
and “Sub surf” are the mediums of the digital artist, and 
understanding them, even broadly, will help you to use Blender to 
its best. As this is a 3D based software, the navigation and the 
working pattern are very different unlike any other 2D based 
software. 

In this Unit, you will learn about the Interface of the software. 

Outcomes 

 

Upon completion of this unit you will be able to: 

 

Outcomes 

Introduct 

 Interface and customize elements as the Info Editor (Top),  
a large 3D View, TimeLine(Bottom), Outliner (Top right), 
properties Editor (Bottom right) etc. 

 Experience the Navigation within the 3D space using 
different Transformation tools and the creation of basic 
meshes (objects) in Blender 

 Use Transformation tools in Blender 

 Manage Navigation in Space 

 Create Basic Primitives 

 Work on the Interface 

 Create Shortcuts and  

 Identify Buttons and Controls 

 

https://docs.blender.org/manual/en/dev/getting_started/about/introduction.html
https://docs.blender.org/manual/en/dev/getting_started/about/introduction.html
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Terminology 

 

 

Terminology 

Header: Header contains various menus and controls 
based on the current mode.  

Menu: Menu offers tools to navigate in 3D space. 

Mode: 

 

Viewport shading: 

 

Transform 
Manipulator: 

 

Snap: 

 

Tool  Shelf: 

 

 

Properties region: 

 

Grid Floor: 

 

Orbit: 

Roll: 

3D view has several modes used for editing 
different kinds of data.  

Allows you to change the way objects are 
displayed in the viewport.  

These handy selectors allow you to rotate or 
move objects by grabbing (clicking with your 
mouse) their controls and moving your mouse 
in the axis.  

Controls the snapping tools that help with 
transforming and modelling objects. 

Tool shelf is a context-sensitive region 
containing tools depending on the current 
mode. 

Properties Region contains properties of the 
active object and selected objects. 

The grey squares forming a floor mark the zero height 
of the world.  

Rotate the view around the point of interest.  

Rotate the viewport camera around its local Z axis in 
15° discrete steps. 

 

 

Introduction to 3D view 

3D View is used to interact with 3D scene for a variety of 
purposes, such as modeling, animation, texture painting, etc. 

Main Region 

One region, which is always visible, is known as the Main Region 
and is the most prominent part of the editor. 
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Each editor has a specific purpose, so the main region and the 
availability of additional regions are different between editors. 

Header 

The header contains various menus and controls based on the 
current mode. 

 
Title-Img 1. 2. 3D View header Attribution 
Attribution- 
Source- blender.org 
Link-
https://docs.blender.org/manual/en/dev/editors/3dview/introduction.html 

 

Menus 

View 

This menu offers tools to navigate in 3D space. 

Select 

Contains tools for selecting objects. 

Add 

Gives a list of different objects types that can be added to a 

scene. 

Object 

This menu appears when in Object Mode. It contains tools 

to edit objects. In edit mode, it will change to the 

appropriate menu with editing tools. 

Controls 

Modes 

The 3D view has several modes used for editing different kinds of 
data: 

Object Mode 

The default mode, available for all object types, as it is 

dedicated to object data-block editing. 

https://docs.blender.org/manual/en/dev/editors/3dview/introduction.html
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Edit Mode 

A mode available for all renderable object types, as it is 

dedicated to their “shape” Object 

Pose Mode 

An armature only mode, dedicated to armature posing. 

Sculpt Mode 

A mesh-only mode, that enables Blender’s mesh 3D-

sculpting tool. 

Particle Edit 

A mesh-only mode, dedicated to particle systems, useful 

with editable systems (hair). 

Arranging the Screen 

Blender uses a novel screen-splitting approach to arrange 
areas. The idea is that you split up the big application 
window into many number of smaller (but still rectangular) 
non-overlapping areas. That way, each area is always fully 
visible, and it is very easy to work in one area and hop over 
to work in another. 

Changing the Size 

You can resize areas by dragging their borders with LMB. Simply 
move your mouse cursor over the border between two areas, until 
it changes to a double-headed arrow, and then click and drag. 

 Splitting and Joining 

 Area Split Widget 

 
Title-Img 1. 3. Changing the size 

Attribution- 
Source- blender.org 
Link-
https://docs.blender.org/manual/en/dev/interface/window_system/areas.html 

https://docs.blender.org/manual/en/dev/interface/window_system/areas.html
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In the upper right and lower left corners of an area are the area 
split widgets, and they look like a little ridged thumb grip. It 
bothsplits and combines areas. When you hover over it, your 

cursor will change to a cross (✛). (Refer Img 1.3) 

LMB and drag it inward split the area. You define the direction of 
that border by either dragging horizontally or vertically. 

In order to join two areas LMB click and drag the area splitter 
outward. They must be the same dimension (width or height) in 
the direction you wish to join. This is so that the combined area 
space results in a rectangle. 

 
Title-Img 1. 3 Properties Editor is being merged “over” the Outliner. 
Attribution-  
Source- blender.org 
Link- 
https://docs.blender.org/manual/en/dev/interface/window_system/areas.html 

 
The area that was closed gets a dark overlaid with an arrow. Now 
you can select the area to be closed by moving the mouse over it. 

Release the LMB to complete the join. If you press Esc or RMB 
before releasing the mouse, the operation will be aborted. 

Area Options 

RMB on the border opens the Area Options. 

Split Area 

Shows an indicator line that lets you select the area and 
position where to split. Tab switches between 
vertical/horizontal. 

Join Areas 

Shows the join direction overlay. 

Confirm or cancel works as described above. 

https://docs.blender.org/manual/en/dev/interface/window_system/areas.html
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Toggle Maximize Area 

 Menu: View ‣ Toggle Maximize Area 

 Hotkey: Ctrl-Up, Shift-Spacebar 

The maximized area fills the whole application window. It contains 
the Info Editor and the select area. 

You can maximize an area with the View ‣ Toggle Maximize Area 

menu entry. To return to normal size use again menu entry, or 
RMB on the editor’s header and select Maximize Area and Tiled 
Area to return. In the Info Editor header, the Back to Previous 
button on the right of the menus also returns to tiled areas. 

A quicker way to achieve this is to use the shortcuts: Shift-
Spacebar, Ctrl-Down or Ctrl-Up to toggle between maximized and 
normal areas. 

Tabs & Panels 

Tabs 

Tabs are overlapping sections in the user-interface. The Tabs 
header can be vertical (Tool Shelf) or horizontal (Properties Editor, 
User Preferences). 

Vertical tabs can be switched with the Wheel within the tab 
header and Ctrl-Wheel changes tabs from anywhere in the region. 

 
Title-Img 1. 4Tools tab (selected), Create, etc 
Attribution- 
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Source- blender.org 
Link- 
https://docs.blender.org/manual/en/dev/interface/window_system/tabs_panel
s.html 

 

 
Title-Img 1. 5 Horizontal tab header 
Attribution- 
Source- blender.org 
Link- 
https://docs.blender.org/manual/en/dev/interface/window_system/tabs_panel
s.html 

 

Panels 

The smallest organizational Unit in the user interface is a Panel. 
Panels can be collapsed to hide its contents. They are used in the 
Properties Editor, but also for example in the Tool Shelf and the 
Properties region. 

In the image on the right there are three panels:  

1. Transform 

2. Edit 

3. History 

The Edit panel is expanded and the other two panels are 
collapsed. 

 
Title-Img 1. 6 Tool Shelf panels. Orange: Panel Headers 
Attribution- 
Source- blender.org 

https://docs.blender.org/manual/en/dev/interface/window_system/tabs_panels.html
https://docs.blender.org/manual/en/dev/interface/window_system/tabs_panels.html
https://docs.blender.org/manual/en/dev/interface/window_system/tabs_panels.html
https://docs.blender.org/manual/en/dev/interface/window_system/tabs_panels.html
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Link- 
https://docs.blender.org/manual/en/dev/interface/window_system/tabs_panel
s.html 

Collapsing and expanding 

A triangle on the left of the title shows the expanded (▼) and 
collapsed (►) state of the panel. 

 A click with the LMB on the panel header expands or 
collapses it. 

 Pressing A expand/collapses the panel under the 
mouse pointer. 

 A Ctrl-LMB click on the header of a specific panel will 
collapse all other panels and make this the only 
expanded one. 

 Dragging with LMB over the headers will expand or 
collapse many at once. 

Panel Position 

You can change the position of a panel within its region by clicking 
and dragging it with the LMB on the grip widget (::::) in the upper 
right corner. 

Pinned Panel 

Often it is desirable to view panels from different tabs at the 
same time. This has been solved by making panels pinnable. 

A pinned panel remains visible regardless of which tab has been 
selected. You can pin a panel by Shift clicking its header, or by 
RMB clicking on the header and choosing Pin in the context menu. 

In the image shown to the right, is an example of the Mesh 
Options pinned in the tools tab. 

Zoom 

The zoom factor of a whole region with panels can be 
changed by Ctrl-MMB clicking and moving the mouse 
anywhere within that region or use the Numpad Plus and 
Numpad Minus to zoom in and out the contents. Pressing 
Home (Show All) will reset the zooming at the screen/panel 
focused by the mouse pointer. 

Alignment 

The alignment of the panels in the Properties Editor can be 
changed between vertical and horizontal. To do this, click 
with RMB somewhere within the main region of the 

https://docs.blender.org/manual/en/dev/interface/window_system/tabs_panels.html
https://docs.blender.org/manual/en/dev/interface/window_system/tabs_panels.html
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Properties Editor and choose either Horizontal or Vertical 
from the appearing menu. Keep in mind though that the 
panels are optimized for vertical alignment. 

Viewport Shading 

It allows you to change the way objects are displayed in the 
Viewport. 

Header: Viewport Shading 

 
 
 
 
 
 
 
 
 
 

Title-Img 1. 7The Viewport Shading menu 
Attribution- 
Source- blender.org 
Link- 
https://docs.blender.org/manual/en/dev/editors/3dview/properties/shading
.html 
 

Bounding Box 

Only shows rectangular boxes that outline an object’s size 

and shape. 

Wireframe 

Objects appear as a mesh of lines representing the edges 

of faces and surfaces. 

Solid 

The default drawing mode using solid coloured surfaces 

and simple lighting. 

Textured 

Shows meshes with an image applied using the mesh’s 

active UV Map. For Cycles materials, the image is the last 

one selected in the Node Editor. For other render engine’s, 

the UV Map’s applied face texture will be shown. 

https://docs.blender.org/manual/en/dev/editors/3dview/properties/shading.html
https://docs.blender.org/manual/en/dev/editors/3dview/properties/shading.html
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Material 

A fast approximation of the applied material. 

Rendered 

An accurate representation using the selected Render 

Engine and lit with the visible scene lights. 

Except for Rendered, these shading modes are not dependent on 
light sources in the scene. Instead they use a simple default 
lighting adjusted by the Solid OpenGL Lights controls on the 
System tab of the User Preferences editor. 

The viewport shading controls the appearance of all objects in a 
scene, but this can be overridden for individual objects using the 
Display panel in their Object Properties. 

3D Space Navigation 

Navigating in 3D space is done with the use of both mouse 
movement and keyboard shortcuts. 

To be able to work in the three-dimensional space that Blender 
uses, you must be able to change your viewpoint as well as the 
viewing direction of the scene. While describing 3D View editor, 
most of the other editors have similar functions. For example, it is 
possible to translate and zoom in the UV/Image editor. 

Orbit 

 Mode: All modes 

 Menu: View ‣ Navigation ‣ Orbit 

 Hotkey: MMB, Numpad2, Numpad4, Numpad6, 

Numpad8, Ctrl-Alt-Wheel 

 

Tip 

Keyboard Shortcuts 

Switches between Wireframe and Solid draw modes. 
Z 

Switches between the current and Rendered draw 
modes. Shift-Z 

Switches between Solid and Textured draw modes. 
Alt-Z 
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Rotate the view around the point of interest. Click and drag MMB 
on the viewport’s area. If you start in the middle of the area and 
move up and down or left and right, the view is rotated around 
the middle of the area. 

To change the viewing angle in discrete steps, use Numpad8 and 
Numpad2 (which correspond to vertical MMB dragging, from any 
viewpoint), or use Numpad4 and Numpad6 (or Ctrl-Alt-Wheel) to 
rotate the scene around the global Z axis from your current point 
of view. Finally, Numpad9 switches to the opposite side of the 
view. 

Alternatively, if the Emulate 3 button mouse option is select in the 
User Preferences you can press and hold Alt while dragging LMB in 
the viewport’s area. 

Roll 

 Mode: All modes 

 Menu: View ‣ Navigation ‣ Roll 

 Hotkey: Shift-Numpad4, Shift-Numpad6, Ctrl-

Shift-Wheel 

Rotate the viewport camera around its local Z axis in 15° discrete 
steps. 

Panning 

 Mode: All modes 

 Menu: View ‣ Navigation ‣ Pan 

 Hotkey: Shift-MMB, Ctrl-Numpad2, Ctrl-

Numpad4, Ctrl-Numpad6, Ctrl-Numpad8 

Move the view up, down, left and right. To pan the view, hold 
down Shift and drag MMB in the 3D View. For discrete steps, use 
the hotkeys Ctrl-Numpad8, Ctrl-Numpad2, Ctrl-Numpad4 and 
Ctrl-Numpad6 as with orbiting (note: you can replace Ctrl by 
Shift). 

 

For those without a middle mouse button, you can hold Shift-Alt 
while dragging with LMB. 
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Zooming 

 Mode: All modes 

 Menu: View ‣ Navigation ‣ Zoom 

 Hotkey: Ctrl-MMB, Wheel, Numpad Plus, 

Numpad Minus 

Move the camera forwards and backwards. You can zoom in and 
out by holding down Ctrl and dragging MMB. The hotkeys are 

Numpad Plus and Numpad Minus. The View ‣ Navigation sub-

menu holds these functions too as well. Refer to the 3D View’s 
View menu image above for more information. If you have a 
wheel mouse, you can zoom by rotating the Wheel. 

 

Tip 

If You Get Lost 

If you get lost in 3D space, which is common, two 
hotkeys will help you: Home changes the view so that 

you can see all objects View ‣ View All, while Numpad 

Period zooms the view to the currently selected 

objects when in perspective mode View ‣ View 

Selected. 

Zoom Border 

 Mode: All modes 

 Menu: View ‣ Zoom Border 

 Hotkey: Shift-B 

The Zoom Border tool allows you to specify a rectangular region 
and zoom in so that the region fills the 3D View. 

You can access this through the View menu, or the shortcut Shift-
B, then LMB click and drag a rectangle to zoom into. 

Alternatively you can zoom out using the MMB. 

Dolly Zoom 

 Mode: All modes 

 Hotkey: Ctrl-Shift-MMB 
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In most cases its sufficient to zoom the view to get a closer look at 
something, however, you may notice that at a certain point you 
cannot zoom any closer. 

This is because, Blender stores a view-point thats used for 
orbiting and zooming. It works well in many cases, however 
sometimes you want to move the view-point to a different place. 
This is what Dolly supports, allowing you to transport the view 
from one place to another. 

You can dolly back and fourth by holding down Ctrl-Shift and 
dragging MMB. 

Transform Manipulators 

These handy selectors allow you to rotate or move objects by 
grabbing (clicking with your mouse) their controls and moving 
your mouse in the axis. 

 

Title-Img 1. 8 Transform Manipulators 
Attribution- 
Source- blender.org 
Link- 
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/tran
sform/control/manipulators.html 

 

 Mode: Object and Edit Modes 

 Menu: 

 Hotkey: Ctrl-Spacebar 

The Transformation manipulator widgets allow mouse controlled 
translation, rotation and scaling in the 3D View. There is a 
separate manipulator for each operation. Each manipulator can be 
used separately or in combination with the others. 

 
Title-Img 1. 9The different Manipulators 
Attribution- 
Source- blender.org 

https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/manipulators.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/manipulators.html


   
 3D Animation 

 
25 

 
 

 

Link- 
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/tran
sform/control/manipulators.html 

Header Controls 

Manipulators can be accessed through the header of the 3D View. 

Axis 

Enable/disable the manipulators Ctrl-Spacebar. 

Manipulators 

Toggles each of the manipulators. Clicking with Shift-LMB 
on multiple manipulator icons will combine the 
manipulators. 

Arrow 

Translation. 

Arc 

Rotation. 

Box 

Scale. 

Basic Transformations 

Grab/Move 

 Mode: Object Mode, Edit Mode, and Pose 

Mode 

 Panel: Tool Shelf ‣ Tools ‣ Transform ‣ Translate 

 Menu: Object type ‣ Transform ‣ Grab/Move 

 Hotkey: G 

In Object Mode, the grab/move option lets you translate (move) 
objects. Translation means changing location of objects. It also 
lets you translate any elements that make up the object within the 
3D space of the active 3D View. 

Pressing G activates “Grab/Move” transformation mode. The 
selected object or element then moves freely according to the 
mouse pointer’s location and camera. 

https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/manipulators.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/manipulators.html


 

 

Unit-1 Introduction to 3D space 
  

26 
 

 
 

You can also move an object by clicking and holding RMB on the 
object to move it. To confirm the action, press LMB. 

Rotate 

 Mode: Object and Edit Modes 

 Panel: Tool Shelf ‣ Tools ‣ Transform ‣ Rotate 

 Menu: Object/Mesh/Curve/Surface ‣ Transform 

‣ Rotate 

 Hotkey: R 

Rotation is also known as a spin, twist, orbit, pivot, revolve, or 
roll and involves changing the orientation of elements (vertices, 
edge, face, Object etc.) around one or more axes or the Pivot Point 

Scale 

 Mode: Object and Edit Modes 

 Panel: Tool Shelf ‣ Tools ‣ Transform ‣ Scale 

 Menu: Object/Mesh/Curve/Surface ‣ Transform ‣ 

Scale 

 Hotkey: S 

Scaling means changing proportions of objects. Pressing S will 
enter the Scale transformation mode where the selected element 
is scaled inward or outward according to the mouse pointer’s 
location. The element’s scale will increase as the mouse pointer is 
moved away from the Pivot Point and decrease as the pointer is 
moved towards it. If the mouse pointer crosses from the original 
side of the Pivot Point to the opposite side, the scale will continue 
in the negative direction and flip the element. 

 
Title-Img 1. 10 Basic scale usage 
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Attribution- 
Source- blender.org 
Link- 
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/tran
sform/basics.html 

 
 From left to right, the panels show: the original Object, a scaled 
down Object, a scaled-up Object and a scale-flipped Object.  
 

Transform Orientations 

 Mode: Object and Edit Modes 

 Panel: Properties region ‣ Transform Orientations 

 Hotkey: Alt-Spacebar 

Orientations affect the behaviour of Transformations: Location, 
Rotation, and Scale. You will see an effect on 3D Manipulator (the 
widget in the centre of the selection), as well as on transformation 
constraints (like axis locking). This means that, when you press G-
X, it will constrain to the global X-axis, but if you press G-X-X it will 
constrain to your Transform Orientations X-axis. 

 
Title-Img 1. 11Transform Orientations selector 
Attribution- 
Source- blender.org 
Link- 
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/tran
sform/control/orientations.html 

 
 

The Orientations options can be set through the Orientation 
selector in 3D View header, with Alt-Spacebar, or in the Transform 
Orientations panel in the Properties region. 

Orientations 

Global 

The manipulator matches the global axis.When using the 

Global orientation, the orientation’s XYZ matches world’s 

XYZ axis. When this mode is selected, the local coordinates 

of the object are subjected to the Global coordinates. This 

is good to place objects in the scene. To constrain an axis, 

https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/basics.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/basics.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/orientations.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/orientations.html
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press G and the desired axis. To constrain to a local axis, 

press the desired axis two times. The difference between 

Global and Local, is more noticeable when you have an 

object in which the origin is not located at the exact centre 

of the object, and does not match the Global coordinates. 

Local 

The manipulator matches the object axis. 

Notice that, here, the Manipulator is at a slight tilt (it is most 
visible on the object’s Y-axis, the green arrow). This is due to our 
15° rotation of the object. This demonstrates the difference 
between local coordinates and global coordinates. If we had 
rotated the object 90° along its X-axis, we would see that the 
object’s “Up” is the world’s “Forward” – or the object’s Z-axis 
would now be the world’s Y-axis. This orientation influences many 
parts of the interface, so it is important to understand the 
distinction. 

Normal 
The Z-axis of the manipulator will match the normal 
vector of the selection. 

In Object Mode, this is equivalent to LocalOrientation, in Edit 
Mode, it becomes more interesting. 

As you see, the light blue lines indicate the faces’ normals, and the 
darker blue lines indicate the vertex normals (these were turned 
on in the N Properties region under  

Mesh Display ‣ Normals ‣ Face and Vertex). Selecting any given 

face will cause our Manipulator’s Z-axis to align with that normal. 
The same goes for Vertex Select Mode. Edge Select is different – A 
selected Edge has the Z-axis aligned with it (so you will have to 
look at the Manipulator widget to determine the direction of X 
and Y). If you select several elements, it will orient towards the 
average of those normals. 

A notable example of how this is useful is in Vertex Select Mode: 
Pick a vertex and then do G, Z, Z to tug it away from the mesh and 
shove it into the mesh. To make this even more useful, select a 
nearby vertex and press Shift-R to repeat the same movement – 
except along that second vertex’s normal instead. 

Gimbal 
 
Uses a Gimbal behaviour that can be changed depending 
on the current Rotation Mode. 
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Creating Basic Primitives 

 Mode: Object Mode and Edit Mode 

 Panel: Tool Shelf ‣ Create ‣ Add Primitive/Mesh 

 Menu: Add ‣ Mesh 

 Hotkey: Shift-A 

A common object type used in a 3D scene is a Mesh. Blender 
comes with several “primitive” mesh shapes that you can start 
modelling from. You can also add primitives in Edit Mode at the 
3D cursor. 

If the created object can be removed by hitting delete key. 

 

Tip 

Undo 

Hotkey: Ctrl-Z 

Redo 

Hotkey: Ctrl-Shift-Z 

 

 
Title-Img 1. 12 Blender’s standard primitives 
Attribution- 
Source- blender.org 
Link- 
https://docs.blender.org/manual/en/dev/modeling/meshes/pri
mitives.html 
 

https://docs.blender.org/manual/en/dev/modeling/meshes/primitives.html
https://docs.blender.org/manual/en/dev/modeling/meshes/primitives.html
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Unit summary 

 

Summary 

In this Unit, you have learnt what is 3D Interface and how to 

 Work effectively and navigate in 3D space within Blender to 
manage the work flow 

 Customize the user interface to limit the tools and option 
required for the user in Blender. 

 Use Hot keys 

 Identify buttons and controls 

 Interact with 3D scene using 3D View for a variety of 
purposes, such as modeling, animation, texture painting, 
etc. 

 Use the Info Editor at the top, a large 3D View, TimeLine at 
the bottom, Outliner at the top right, properties Editor at 
the bottom right etc. 

After learning this Unit, you can download the Open Source 
Software available on the internet for free of cost to practice the 
possibilities of creating 3D Interface. 

 

Assignment 
 

Assignment 

 Create a Dining Table with a table lamp using the basic 

primitives. 

 

https://www.blender.org/download/
https://www.blender.org/download/
https://www.blender.org/download/
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Assessment 

 

Assessment 

 Explain 3D Navigation in Blender.  

 Define Primitives. 

 Write a brief note on Transform Manipulator. 

 Describe the types of Viewport Shading. 

 Write a brief note on Track Panel. 

 How are the splitting and arranging widgets used? 

Fill in the Blanks 

1. ________________ allows you to change the way objects 
are displayed in the viewport.  

2. _____________ tool is used to rotate the view around the 
point of interest.  

3. Pressing ______________expand/collapses the panel 
under the mouse pointer.  

4. In ______________ mode, objects appear as a mesh of 
lines representing the edges of faces and surfaces.  

5. The____________ short cut can be used to grab and move 

object. 
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Resources 

 

 

 

 

 

 

 
Study skills 

While studying this Unit, you can browse the internet links for online 

tutorials and several books and training DVDs available in theBlender 

Storeand on theBlender Cloud. 

 wiki.blender.org 

 archive.org 

 www.blender.org 

 docs.blender.org 

https://store.blender.org/
https://store.blender.org/
https://store.blender.org/
https://cloud.blender.org/
http://www.blender.org/
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Unit 2 

Introduction to Modelling 

Introduction 

In this Unit, you will learn about the important Tools, which support the 
work flow in Modelling and the many ways of Selecting an Object, 
Duplicating, Mirroring, etc. 

Common use of Mirroring is to model Half an Object, duplicate it and 
then use the mirror transform to create a reversed version to complete 
the model. 

You will also learn how to organize 3D scenes by using Layers, as it often 
becomes exponentially more confusing as they grow more complex. 
Sometimes the artist also needs precise control over how individual 
Objects are lit, and does not want lights for one Object to affect nearby 
Objects. 

Outcomes 

 

Upon completion of this unit you will be able to: 

 

Outcomes 

 Draw with Selection Tools 

 Select, duplicate and mirror an Object 

 Create Multiple Objects with Mirror and Duplicate 

 Edit Pivot Point 

 Use Snap Tool 

 Organize 3D Scenes using Layers 
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Terminology 

 

Work Flow of Modelling 

Object Selection 

Selections and the Active Object 

Blender distinguishes between two different states of selection: 

 

Terminology 

Active Object: 
In Object Mode, the last (de)selected item 
is called the “Active Object” 

Point selection: 
Selecting the Object in the viewport with a 
RMB. 

Border select: 
With Border Select, you can draw a 
rectangle while holding down LMB. 

 Lasso select: 
Lasso select is used to draw a dotted line 
around the pivot point of the Objects, in 
Object Mode. 

 Circle select: 
Circle Select is used to move with dotted 
circle through Objects with LMB. 

 Mirror: 
Mirroring an Object or Mesh selection will 
create a reversed version of the selection. 

 Duplicate: 
This will create a visually-identical copy of 
the selected Object(s). 

 Edge Ring: 
In Edge select mode, holding Ctrl-Alt while 
selecting an edge selects a sequence of 
edges that are not connected. 

 Selection to grid: 
Snaps the currently selected Object(s) to 
the nearest grid point. 

 Cursor to Selected: 
Moves the cursor to the centre of the 
selected Object(s). 

 Layers: 
Objects can be placed into one or more 
“layers” using Object layers. 

 Cursor to center: Moves the cursor to the center of the grid. 
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Title-Img 2. 1 Unselected Object in black, selected Object in orange, and active Object 

in yellow. 
Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/editors/3dview/object/select
ing/introduction.html 
 
 

 In Object Mode, the last (de)selected item is called the 

“Active Object” and is outlined in yellow (the others are 

orange). There is exactly one active Object at any time 

(even when nothing is selected). 

 Many actions in Blender use the active Object as a 

reference (for example linking operations). If you already 

have a selection and need to make a different Object the 

active one, simply re-select it with Shift-RMB. 

 All other selected Objects are just selected. You can select 

any number of Objects. 

Point Selection 

 The simplest form of Object selection consists of using 

RMB on it. 

 To add to the selection, use Shift-RMB on more Objects. 

 If the Objects are overlapping in the view, you can use 

Alt-RMB to cycle through possible choices. 

 If you want to add to a selection this way, then the 

shortcut becomes Shift-Alt-RMB. 

https://docs.blender.org/manual/en/dev/editors/3dview/object/selecting/introduction.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/selecting/introduction.html
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 To activate an Object that is already selected, click Shift-

RMB on it. 

 To deselect an active Object, click Shift-RMB one time and 

hence, two clicks if the Object is not active. Note that this 

only works if there are no other Objects under the mouse. 

Otherwise it just adds those to the selection. There 

appears to be no workaround for this bug. 

Border Select 

 Mode: Object Mode and Edit Mode 

 Menu: Select ‣ Border Select 

 Hotkey: B 

With Border Select you draw a rectangle while holding down LMB. Any 
Object that lies even partially within this rectangle becomes selected. 

 For deselecting Objects, use MMB or Border Select again 

with holding Shift. 

 To cancel the selection use RMB. 

Example 

 
Title-Img 2. 2 Border selecting in three steps 
Attribution- 
Source-Blender.org 
Link-http://blender-manual-

i18n.readthedocs.io/ja/latest/modeling/objects/selecting.html 

 

Border Select has been activated in the first image and is indicated by 
showing a dottedcross-hair cursor. In the second image, the selection 
region is being chosen by drawing a rectangle with the LMB. The 
rectangle is only covering two cubes. Finally, in the third image, the 
selection is completed by releasing LMB. 

http://blender-manual-i18n.readthedocs.io/ja/latest/modeling/objects/selecting.html
http://blender-manual-i18n.readthedocs.io/ja/latest/modeling/objects/selecting.html
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Notice in the third image, the bright color of left-most selected cube. This 
means it is the “Active Object”, the last selected Object prior to using the 
Border Select tool. 

Lasso Select 

 Mode: Object Mode and Edit Mode 

 Menu: no entry in the menu 

 Hotkey: Ctrl-LMB 

Lasso select is used by drawing a dotted line around the pivot point of 
the Objects, in Object Mode. 

Circle Select 

 Mode: Object Mode and Edit Mode 

 Menu: Select ‣ Circle Select 

 Hotkey: C 

Circle Select is used by moving with dotted circle through Objects with 
LMB. You can select any Object by touching of circle area. It is possible to 
dynamically change the diameter of circle by scrolling MMB as seen in 
Img 2.3 and Img 2.4. Deselection is under the same principle - MMB. To 
cancel the selection use RMB or key Esc. 

Title-Img 2. 3Circle selection 
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Attribution- 
Source-Blender.org 
Link-
https://wiki.blender.org/index.php/Doc%3A2.6/Manual/Modeling/Objects/Selecting 

 
 

 
Title-Img 2. 4 with huge circle 
Attribution- 
Source-Blender.org 
Link-
https://wiki.blender.org/index.php/Doc%3A2.6/Manual/Modeling/Objects/Selecting 

 

Menu Selection 

The selection methods described above are the most common. There 
are also many more options accessible through the Select menu of the 
3D View. 

Select Grouped 

 Mode: Object Mode 

 Menu: Select ‣ Grouped 

 Hotkey: Shift-G 

There are two ways to organize the Objects in relation to one another.  

1. Parenting 

2. Simple grouping 

Select Grouped uses the Active Object as a base to select all others. 

https://wiki.blender.org/index.php/Doc%3A2.6/Manual/Modeling/Objects/Selecting
https://wiki.blender.org/index.php/Doc%3A2.6/Manual/Modeling/Objects/Selecting
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Title-Img 2. 5 Select Grouped menu 
Attribution- 
Source-wiki.Blender.org 
Link-https://wiki.blender.org/index.php/File:25-Manual-Object-Selection-Grouped.png 

Mirror Object 

 Mode: Object and Edit Modes 

 Menu: Object/Mesh‣ Mirror 

 Hotkey: Ctrl-M 

Mirroring an Object or Mesh selection will create a reversed version of 
the selection. The position of the mirrored version of the selection is 
determined by the Pivot Point. A common use of mirroring is to model 
half an Object, duplicate it and then use the mirror transform to create a 
reversed version to complete the model. 

Title-Img 2. 

6 Mirroring a Selection 

https://wiki.blender.org/index.php/File:25-Manual-Object-Selection-Grouped.png
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Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/mirr
or.html 
 

Duplicate Object 

This will create a visually-identical copy of the selected Object(s). The 
copy is created at the same position as the original Object and you are 
automatically placed in Grab mode.  

This copy is a new Object, which shares some data-blocks with the 
original Object (by default, all the Materials, Textures, and F-Curves), but 
which has copied others, like the mesh, for example. Therefore, this form 
of duplication is sometimes called “shallow link”, because not all data-
blocks are shared; some of them are “hard copied”! 

 Mode: Edit and Object Modes 

 Menu: Object ‣ Duplicate 

 Hotkey: Shift-D 

This will create a visually-identical copy of the selected Object(s). The 
copy is created at the same position as the original Object and you are 
automatically placed in Grab mode. See the example below (Img 2.7). 

Examples 

 
Title-Img 2. 7 The MeshCone.006 of Object Cone.002 is being edited. 
Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/duplica
tion.html 

https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/mirror.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/mirror.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/duplication.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/duplication.html
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The mesh’s unique data-block ID name is highlighted in the Outliner. 
 

The cone in the middle has been  

(1) link duplicated to the left and  

(2) duplicated to the right. 

The duplicated right cone is being edited; the original cone in the middle 
remains unchanged. The Mesh data has been copied not linked. 

Likewise, if the right cone is edited in Object mode, the original cone 
remains unchanged. The new Objects transform properties or data-block 
is a copy, not linked. 

When the right cone was duplicated, it inherited the material of the 
middle cone. The material properties were linked, not copied. 

Snapping 

 Mode: Object and Edit Mode 

 Hotkey: Shift-S 

Transform Snapping 

 
Title-Img 2. 8 Magnet icon in the 3D View header (red when enabled) 
Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/cont
rol/snap.html 

 

The ability to snap Objects and Mesh element to various types of scene 
elements during a transformation is available by toggling the magnet 
icon (which will turn red) in the 3D View’s header buttons. 

Snap Element 

 

https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/snap.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/snap.html
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Title-Img 2. 9 Snap Element menu 
Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/cont
rol/snap.html 

Volume 

Snaps to regions within the volume of the first Object found below the 
mouse cursor. Unlike the other options, this one controls the depth (i.e. 
Z-coordinates in current view space) of the transformed element. By 
toggling the button that appears to the right of the snap target menu 
(Refer Img 2.10), target Objects will be considered as whole, when 
determining the volume center. 

Face 

Snap to the surfaces of faces in Mesh Objects. It is useful for 
retopologizing the surface of the geometry. 

Edge 

Snap to edges of Mesh Objects. 

Vertex 

Snap to vertices of Mesh Objects. 

Increment 
Snap to grid points. When in Orthographic view, the snapping 
increment changes depending on zoom level.

Title-
Img 2. 10Various Snap option 

https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/snap.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/snap.html
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Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/cont
rol/snap.html 

 

Pivot Points  

Origin of the 3D model, which is therefore not the physical center of 
gravity of the Object, but rather the pivot point that will identify the 
location coordinates of the Object in 3D space, and in toward which 
operations (such as rotation and scaling of the entire Object) will be 
carried out, in Object Mode. 

 Mode: Object Mode and Edit Mode 

 Menu: Drop list in the header of the 3D View 

 
Title-Img 2. 11 Pivot Point modes 
Attribution- 
Source-Blender.org 
Link-http://blender-manual-
i18n.readthedocs.io/ja/latest/editors/3dview/transform/transform_control/
pivot_point/ 
 

3D Cursor 

 Mode: Object Mode and Edit Mode 

 Menu: Select from the icon in the 3D View header. 

 Hotkey: . 

The 3D cursor is the most intuitive of the pivot points. With the 3D 
cursor selected as the active pivot point (from either the Editors Header 
or via.), simply position the 3D cursor and then do the required 

https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/snap.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/snap.html
http://blender-manual-i18n.readthedocs.io/ja/latest/editors/3dview/transform/transform_control/pivot_point/
http://blender-manual-i18n.readthedocs.io/ja/latest/editors/3dview/transform/transform_control/pivot_point/
http://blender-manual-i18n.readthedocs.io/ja/latest/editors/3dview/transform/transform_control/pivot_point/
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transformation. All rotation and scaling transformations will now be 
done relative to the location of the 3D cursor. 

The image below shows the difference when rotating an Object around 
the median point (left) and around the 3D cursor (right). 

 
Title-Img 2. 12 Rotation around the 3D cursor compared to the median point. 
Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transfo
rm/control/pivot_point/3d_cursor.html 

 

Individual Origins 

 Mode: Object Mode and Edit Mode 

 Menu: Select from the pivot-icon icon in the 3D View 

header. 

 Hotkey: Ctrl-. 

In Object Mode 

 

Title-Img 2. 13 Rotation around individual origins. 

Attribution- 

https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/pivot_point/3d_cursor.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/pivot_point/3d_cursor.html
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Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/cont
rol/pivot_point/individual_origins.html?highlight=rotation%20around%20individual%20
origins 

 

The Origin of an Object is shown in the 3D View by a small orange circle. 
This is highlighted in the image to the right by the red arrow. The origin 
tells Blender the relative position of that Object in 3D space. What you 
see in the 3D View (vertices, edges etc.) is what makes up the Object. 

While the Origin is equivalent to the center of the Object, it does not 
have to be located in the center of the Mesh. This means that an Object 
can have its center located on one end of the Mesh or even completely 
outside the mesh. For example, the orange rectangle in the image has its 
Origin located on the far left of the mesh. 

Now let us examine: Rotation around the individual origins: 

 The blue rectangle has its Origin located in the center of 

the mesh, while the orange rectangle has its Origin 

located on the left-hand side. 

 When the Pivot Point is set to Individual Origins, the 

center of each Object (indicated by the red arrow) 

remains in place while the Object rotates around it in the 

path shown by the black arrow. 

Title-Img 2. 14 Rotation around individual origins (middle) compared to 

the median point (right) 

Attribution- 

Source-Blender.org 

Link-
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/c

ontrol/pivot_point/individual_origins.html 

https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/pivot_point/individual_origins.html?highlight=rotation%20around%20individual%20origins
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/pivot_point/individual_origins.html?highlight=rotation%20around%20individual%20origins
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/pivot_point/individual_origins.html?highlight=rotation%20around%20individual%20origins
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/pivot_point/individual_origins.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/pivot_point/individual_origins.html
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Title-Img 2. 15 Scaling around individual origins (middle) compared to the 
median point (right). 
Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transfo
rm/control/pivot_point/individual_origins.html 

 

Working with Layers  

3D scenes often become exponentially more confusing as they grow 
more complex. Sometimes the artist also needs precise control over how 
individual Objects are lit, and does not want lights for one Object to 
affect nearby Objects. For this and other reasons below, Objects can be 
placed into one or more “layers”. Using Object layers, you can: 

Selectively display Objects from certain layers in your 3D View, by 
selecting those layers in the 3D View header. This allows you to speed up 
interface redrawing, reduce virtual-world clutter, and help improve your 
workflow. 

 Mode: Object Mode 

 Panel: Object ‣ Relations 

 Menu: Object ‣ Move to Layer... 

 Hotkey: M 

Viewing layers 

Blender provides twenty layers whose visibility can be toggled with the 
small unlabelled buttons in the header (Refer Img 2.16, 3D View layer 
buttons). To select a single layer, click the appropriate button with LMB; 
to select more than one, use Shift-LMB - doing this on an already active 
layer will deselect it. 

https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/pivot_point/individual_origins.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/editing/transform/control/pivot_point/individual_origins.html
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Title-Img 2. 16 3D View layer buttons. 
Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/editors/3dview/object/properties/rela
tions/layers.html 

 
 

To select layers via the keyboard,  

 Step 1: press 1 to 0 (on the main area of the keyboard) for 
layers 1 through 10 (the top row of buttons), and  

 Step 2:Alt-1 to Alt-0 for layers 11 through 20 (the bottom 
row). Use Shift for multiple (de)selection works for these 
shortcuts too. 

You can select or deselect all Scene Layer buttons at once by pressing \. 

Locking to the scene 

By default, the lock button directly to the right of the layer buttons is 
enabled. This means that changes to the viewed layers affect all other 3D 
Views locked to the scene 

Multiple Layers 

An Object can exist on multiple layers. For example, a lamp that only 
lights Objects on a shared layer could “be” on layers 1, 2, and 3. An 
Object on layers 3 and 4 would be lit, whereas an Object on layers 4 and 
5 would not. There are many places where layer-specific effects come 
into play, especially lights and particles. 

Moving Objects between layers 

 
Title-Img 2. 17 Layer selection.Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/editors/3dview/object/properties/relations/la
yers.html 

To move selected Objects to a different layer, press M and then select 
the layer you want from the pop-up menu. Objects can also be on more 

https://docs.blender.org/manual/en/dev/editors/3dview/object/properties/relations/layers.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/properties/relations/layers.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/properties/relations/layers.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/properties/relations/layers.html
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than one layer at a time. To have an Object on multiple layers, hold Shift 
while clicking. 

 
Title-Img 2. 18 Selection in the Object tab 
Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/editors/3dview/object/properties/relations/la
yers.html 

 
Another way to view or change a selected Object layer is via the 
Relations panel, in the Object tab. 

 
Title-Img 2. 19 Layers in Object tab, Relations panel. 
Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/editors/3dview/object/properties/relations/la
yers.html 

 

You will then see the layer buttons in the Relations panel – as before – 
the Object can be displayed on more than one layer by clicking Shift-
LMB. 

 

Objects in Blender 

The geometry of a scene is constructed from one or more Objects. These 
Objects can range from lamps to light your scene, basic 2D and 3D 
shapes to fill it with models, armatures to animate those models, to 
cameras to take pictures or video of it all. 

 

 

Tip 

New Objects can be created with  

Add menu in the 3D Views header. 

 

https://docs.blender.org/manual/en/dev/editors/3dview/object/properties/relations/layers.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/properties/relations/layers.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/properties/relations/layers.html
https://docs.blender.org/manual/en/dev/editors/3dview/object/properties/relations/layers.html
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Object Types 

Mesh 

Meshes are Objects composed of Polygonal Faces, Edges and/or 
Vertices, and can be edited extensively with Blender’s Mesh 
editing tools.  

Curve 

Curves are mathematically defined Objects which can be 
manipulated with control handles or control points (instead of 
vertices), to manage their length and curvature.  

Surface 

Surfaces are patches that are also manipulated with control 
points. These are useful for simple rounded forms and organic 
landscapes.  

Metaball 

Meta Objects (or Metaballs) are Objects formed by a 
mathematical function (with no control points or vertices) 
defining the 3D volume in which the Object exists. Metal Objects 
have a liquid-like quality, where when two or more Metaballs are 
brought together, they merge by smoothly rounding out the 
connection, appearing as one unified Object.  

Text 

Text Objects create a two-dimensional representation of a string 
of characters. 

Armature 

Armatures are used for rigging 3D models in order to make them 
poseable and animateable. 

Lattice 

Lattices are non-renderable wireframes, commonly used for 
taking additional control over other Objects with help of the 
Lattice Modifier. 

Empty 
Empties are null Objects that are simple visual transform nodes 
that do not render. They are useful for controlling the position 
or movement of other Objects. 
Speaker 

Speaker brings to scene source of sound. 
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Camera 

This is the virtual camera that is used to determine what appears 

in the render.  

Lamp 

These are used to place light sources in the scene.  

Force Field 

Force Fields are used in physical simulations. They give 
simulations external forces, creating movement, and are 
represented in the 3D View editor as small control Objects. 

Group Instance 

Let’s you select from a list of existing Object groups. Once 

selected, an Empty Object will be created, with an instance of the 

selected group (group duplication active).  

Objects  

The geometry of a scene is constructed from one or more 

Objects. These Objects can range from lamps to light your scene, 

basic 2D and 3D shapes to fill it with models, armatures to 

animate those models, to cameras to take pictures or video of it 

all. 
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Unit summary 

 

Summary 

In this Unit, you have learnt how to 

 Work with 3D modelling using various options 

 Channelize your work flow that helps you to bring down the 
complexities of the software. 

 Create basic Objects, selection, duplication and mirroring 
Objects 

 Load the Objects to layers to ensure an organised way of 
handling complex scenes. 

 Create Object with the knowledge of the pivot  

 Manipulate the pivot using various options to develop more 
complicated duplication of Objects.  

 Arrange the Object precisely using one of the most important 
features of the software “snap” which gives us more 
flexibility. 

After learning this Unit, you can download the Open Source 

Software available on the internet for free of cost to practice the 

possibilities of creating 3D Objects. 

Assignment 

 

Assignment 

 Create “House model” with proper interiors using the basic 

primitives looking at the given image. 

 

No need to add colors to the model. (you can do it after learning the 

texturing unit)The total length of the video should be 2-5 minutes. 

https://www.blender.org/download/
https://www.blender.org/download/
https://www.blender.org/download/
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Assessment 

 

 

 

 

Assessment 

 

 

1. Explain the various Selection Modes in Blender. 

2. Describe the Method of Duplication and Mirror. 

3. Describe the Uses of Layers. 

4. Why do we need Snap Tool, explain? 

5. Write a brief note on the Object Types in Blender. 

6. Explain any three types of Snap Options. 

Fill in the Blanks 

1. In Object Mode, the last (de)selected item is called the _______________.  

2. The simplest form of Object Selection 
consists of using 
________________on it.  

3. The _______________ icon is used to 
Snap Objects and Mesh element to 
several types of scene elements.  

4. _______________ will identify the location coordinates of the Object in 3D space.  

5. Circle Select is used by moving with dotted circle through Objects with 
____________.  

 

Resources 

 

 

 

 

 

 

Study Skills 

 

While studying this Unit, you can browse the internet 

links for tutorials and several books and training DVDs 

available in theBlender Storeand on theBlender Cloud. 

 wiki.blender.org 

 archive.org 

 www.blender.org 

 docs.blender.org 

https://store.blender.org/
https://cloud.blender.org/
http://www.blender.org/
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Unit 3 

Inorganic Modelling 

Introduction 

Curves and Surfaces are very important for Modelling.   

Curves and Surfaces are types of Blender Objects. They are expressed by 
mathematical functions rather than a series of points. Using the specific 
features ofboth Bezier and NURBs curves, you will create a model in 3D, 
and explore how they are computed behind the scenes than how they 
appear from a modeler’s perspective.  

Bezier curves are generally more intuitive because they start and end at 
the control points that you set, but NURBs curves are more efficient for 
the computer to calculate when there are many twists and turns in a 
curve. 

Curves are 2D objects, and Surfaces are their 3D extension. Note 
however, that in Blender, you only have NURBS Surfaces, no Bezier. 
Even though curves and Surfaces share the same object type, they are 
not the same thing; For example, you cannot have in the same object 
both curves and Surfaces. 

In this Unit, you will learn the usage of Curves and Surfaces for 
modelling. 

Outcomes 

 

Upon completion of this unit you will be able to: 

 

Outcomes 

 Create and work with Curves. 

 Edit the Curves using different Modes. 

 Working Surface modelling. 

 Create Objects using Curves and  

 Prepare Curve Deformation and Curve Extrusion. 
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Terminology 

Bezier Curve: Adds an open 2D Bezier curve with two control points. 

Bezier Circle:  Adds a closed, circle-shaped 2D Bezier curve (made of 
four control points). 

NURBS Curve: It adds an open 2D NURBS curve, with four control. 

NURBS Circle:It adds a closed, circle-shaped 2D NURBS curve (made of 
eight control points). 

Path:  It adds a NURBS open 3D curve made of five aligned 
control points, with Endpoint knots and the Curve Path 
setting enabled. 

NURBS: Non-Uniform Rational B-Splines. 

Extrude:  Will extrude the curve along both the positive and 
negative local Z axes. 

Bevel Depth: Changes the size of the bevel. 

Subdividing: Curve subdivision simply subdivides all selected segments 
by adding one or more control points between the 
selected segments. 

Duplication: This command duplicates the selected control points, 
along with the curve segments implicitly selected (if any).  

Separating Curves: Curve objects that are made of multiple distinct, 
curves can be separated into their own objects by 
selecting the desired segments. 

Fill:  Fill determines the way a Curve is displayed when it is 
bevelled. 

 
 

Introduction to Curves and Surfaces 

Curves 

Bézier Curves 

The main elements used in editing Bezier Curves are the Control Points 
and Handles.  

Control Points 

 

Terminology 
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A Segment (the actual Curve) is found between two Control Points.  

In the image below (Img 3.1), the Control Points can be found in the 
middle of the pink line while the Handles comprise the extensions from 
the Control Point.  

By default, the arrows on the Segment represent the direction and 
relative speed and direction of movement Objects will have when 
moving along the curve. This can be altered by defining a custom F-
Curve. 

 
Title-Img 3. 1 Bezier Curve in Edit Mode. 
Attribution- 
Source-Blender.org 
Link-http://blender-manual-

i18n.readthedocs.io/ja/latest/modeling/curves/introduction.html?highlight=Bezier%20C
urve%20in%20Edit%20Mode. 

 

Editing Bézier Curves 

A Bézier curve can be edited by moving the locations of the Control 
Points and Handles: 

 Step 1: Add a Curve by Shift-A to bring up the Add menu, 

followed by  

Curve ‣ Beziers. 

 Step 2: Press Tab to enter Edit Mode. 

 Step 3: Select one of the Control Points and move it 

around. Use LMB to confirm the new location of the 

Control Point, or use RMB to cancel. 

 Step 4: Now select one of the Handles and move it 

around. Notice how this change the curvature of the 

curve. 

To add more Control Points: 

 Step 1: Select at least two adjacent Control Points. 

http://blender-manual-i18n.readthedocs.io/ja/latest/modeling/curves/introduction.html?highlight=Bezier%20Curve%20in%20Edit%20Mode
http://blender-manual-i18n.readthedocs.io/ja/latest/modeling/curves/introduction.html?highlight=Bezier%20Curve%20in%20Edit%20Mode
http://blender-manual-i18n.readthedocs.io/ja/latest/modeling/curves/introduction.html?highlight=Bezier%20Curve%20in%20Edit%20Mode
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 Step 2: Press W and select Subdivide. 

Optionally, you can press F6 immediately after the subdivision to modify 
the number of subdivisions 

 

Tip 

While in Edit Mode, you cannot directly select a Segment. 

To do so, select all of the Control Points that make up the 

Segment you want to move. 

 

Handles 

There are Four Bézier Curve Handle types. They can be accessed by 
pressing V and selecting from the list that appears, or by pressing the 
appropriate hotkey combination. Handles can be rotated, moved, scaled 
and shrunk/fattened like any vertex in a Mesh. 

Bézier Curve Handle Types 

1. Automatic V-A 

This handle has a completely automatic length and direction 

which is set by Blender to ensure the smoothest result. These 

handles convert to Aligned handles when moved. 

 
Title-Img 3. 2 Bezier handle type. 
Attribution- 
Source- 
Link-http://blender-manual-

i18n.readthedocs.io/ja/latest/modeling/curves/introduction.html?highlight=Bezier%20C
urve%20in%20Edit%20Mode. 

 
2. Vector V-V 

Both parts of a handle always point to the previous handle or the 
next handle which allows you to create curves or sections thereof 
made of straight lines or with sharp corners. Vector handles 
convert to free handles when moved. 

http://blender-manual-i18n.readthedocs.io/ja/latest/modeling/curves/introduction.html?highlight=Bezier%20Curve%20in%20Edit%20Mode
http://blender-manual-i18n.readthedocs.io/ja/latest/modeling/curves/introduction.html?highlight=Bezier%20Curve%20in%20Edit%20Mode
http://blender-manual-i18n.readthedocs.io/ja/latest/modeling/curves/introduction.html?highlight=Bezier%20Curve%20in%20Edit%20Mode
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Title-Img 3. 3 Bezier handle type. 
Attribution- 
Source-Blender.org 
Link-http://blender-manual-

i18n.readthedocs.io/ja/latest/modeling/curves/introduction.html?highlight=Bezier%20C
urve%20in%20Edit%20Mode. 

 
3. Aligned V-L 

These handles always lie in a straight line, and give a continuous 
curve without sharp angles. 

 
Title-Img 3. 4 Bezier handle type. 
Attribution- 
Source-Blender.org 
Link-http://blender-manual-

i18n.readthedocs.io/ja/latest/modeling/curves/introduction.html?highlight=Bezier%20C
urve%20in%20Edit%20Mode. 

 
4. Free V-F 

The handles are independent of each other. 

 
Title-Img 3. 5 Bezier handle type. 
Attribution- 
Source-Blender.org 
Link-http://blender-manual-

i18n.readthedocs.io/ja/latest/modeling/curves/introduction.html?highlight=Bezier%20C
urve%20in%20Edit%20Mode. 

 

Additionally, the V-T shortcut can be used to toggle between Free and 
Aligned handle types. 

http://blender-manual-i18n.readthedocs.io/ja/latest/modeling/curves/introduction.html?highlight=Bezier%20Curve%20in%20Edit%20Mode
http://blender-manual-i18n.readthedocs.io/ja/latest/modeling/curves/introduction.html?highlight=Bezier%20Curve%20in%20Edit%20Mode
http://blender-manual-i18n.readthedocs.io/ja/latest/modeling/curves/introduction.html?highlight=Bezier%20Curve%20in%20Edit%20Mode
http://blender-manual-i18n.readthedocs.io/ja/latest/modeling/curves/introduction.html?highlight=Bezier%20Curve%20in%20Edit%20Mode
http://blender-manual-i18n.readthedocs.io/ja/latest/modeling/curves/introduction.html?highlight=Bezier%20Curve%20in%20Edit%20Mode
http://blender-manual-i18n.readthedocs.io/ja/latest/modeling/curves/introduction.html?highlight=Bezier%20Curve%20in%20Edit%20Mode
http://blender-manual-i18n.readthedocs.io/ja/latest/modeling/curves/introduction.html?highlight=Bezier%20Curve%20in%20Edit%20Mode
http://blender-manual-i18n.readthedocs.io/ja/latest/modeling/curves/introduction.html?highlight=Bezier%20Curve%20in%20Edit%20Mode
http://blender-manual-i18n.readthedocs.io/ja/latest/modeling/curves/introduction.html?highlight=Bezier%20Curve%20in%20Edit%20Mode
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NURBS Curves 

One of the major differences between Bézier Objects and NURBS Objects 
is that Bézier Curves are approximations.  

For example, a Bézier circle approximates a circle, whereas a NURBS 
circle is an exact circle.In practice, many of the Bézier curve operations 
discussed above apply to NURBS curves in the same manner. The 
following text will concentrate only on those aspects that are unique to 
NURBS curves. 

Editing NURBS Curve 

A NURBS Curve is edited by moving the location of the Control Points: 

 Step 1: Place a Curve by Shift-A to bring up the Add menu, 

followed by  

Curve ‣ NURBS curve. 

 Step 2: Press Tab to enter Edit Mode. 

 Step 3: Select one of the Control Points and move it 

around. Use LMB to confirm the new location of the 

Control Point, or use RMB to cancel. 

To add additional Control Points 

 Step 1: select both the Control Points  

 Step 2: press W and  

 Step 3: select Subdivide.  

 Step 4: Press F6 immediately after to determine how 

many subdivisions to make. 

Transform Tools 

Deforming Tool 

 Mode: Edit Mode 

 Menu: Curve ‣ Transform 

The Shear, Warp and Push/Pull transform tools are described in 
the Transformations sections. The two other tools, Tilt and 
Shrink/Fatten Radius are related to Curve Extrusion. 
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Smoothing Tool 

 Mode: Edit Mode 

 Hotkey: W ‣ smooth 

Curve smoothing is available through the specials menu. For 
Bézier curves, this smoothing operation reduces the distance 
between the selected control point/s and their neighbors, while 
keeping the neighbors anchored. Does not affect control point 
tangents. 

Mirror Tool 

 Mode: Edit Mode 

 Menu: Curve ‣ Mirror 

 Hotkey: Ctrl-M 

The Mirror tool is also available, behaving exactly as with Mesh 

vertices. 

Set Bézier Handle Type 

 Mode: Edit Mode 

 Panel: Curve Tools ‣ Handles 

 Menu: Curve ‣ Control Points ‣ Set Handle Type 

 Hotkey: V 

Handle types are a property of Bézier curves that can be used to alter 
features of the curve. For example, switching to Vector handles can be 
used to create curves with sharp corners. Read the Bézier curves page 
for more details.  

Extending Curves 

 Mode: Edit Mode 

 Menu: Curve ‣ Extrude 

 Hotkey: Ctrl-LMB, E 
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Once a curve is created you can add new segments (in fact, new control 
points defining new segments), either by extruding, or placing new 
handles with Ctrl-LMB. Each new segment is added to one end of the 
curve. The Bézier curve can only be extend at the endpoints.  
Ctrl-LMB on inner control points will make unconnected duplicates. 

Subdivision 

 Mode: Edit Mode 

 Panel: Curve Tools 

 Menu: Surface tools ‣ Modeling ‣ Subdivide 

 Hotkey: W 

Curve subdivision simply subdivides all selected segments by adding one 
or more control points between the selected segments. To control the 
number of cuts, press W to make a single subdivision. Then press F6 to 
bring up the Number of Cuts menu. 

Duplication 

 Mode: Edit Mode 

 Menu: Curve ‣ Duplicate 

 Hotkey: Shift-D 

This command duplicates the selected control points, along with the 
curve segments implicitly selected (if any). The copy is selected and 
placed in Grab mode, so you can move it to another place. 

Joining Curve Segments 

 Mode: Edit Mode 

 Menu: Curve ‣ Make Segment 

 Hotkey: F 

Two open curves can be combined into one by creating a segment 
between the two curves. To join two separated curves, select one end 
control point from each curve then press F. The two curves are joined by 
a segment to become a single curve. 
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Separating Curves 

 Mode: Edit Mode 

 Menu: Curve ‣ Separate 

 Hotkey: P 

Curve objects that are made of multiple distinct curves can be separated 
into their own objects by selecting the desired segments and pressing P. 
Note, if there is only one curve in a Curve object, pressing P will create a 
new Curve object with no control points. 

Deleting Elements 

 Mode: Edit Mode 

 Menu: Curve ‣ Delete... 

 Hotkey: X, Delete 

 Selected: This will delete the selected control points, 

without breaking the curve (i.e. the adjacent points will be 

directly linked, joined, once the intermediary ones are 

deleted). 

 Segment: This option is somewhat the opposite to the 

preceding one, as it will cut the curve, without removing 

any control points, by erasing one selected segment. 

Opening and Closing a Curve 

 Mode: Edit Mode 

 Menu: Curve ‣ Toggle Cyclic 

 Hotkey: Alt-C 

This toggles between an open curve and closed curve (Cyclic). Only 
curves with at least one selected control point will be closed/open. The 
shape of the closing segment is based on the start and end handles for 
Bézier curves, and as usual on adjacent control points for NURBS. The 
only time a handle is adjusted after closing is if the handle is an Auto 
one. Open and Closed curves is the same Bézier curve open and closed. 
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Curve Extrution 

 Mode: Object or Edit Mode 

 Panel: Curve and Surface 

 Extrude 

Turns a one-dimensional curve into a two-dimensional curve by giving it 
height. Note that this is not related to Extrude used in Mesh edit-mode. 
With a scale of one, an Extrusion of 0.5 will extrude the curve 0.5 BU in 
both directions, perpendicular to the curves normals. 

 
Title-Img 3. 6Curve Extrution 
Attribution- 
Source-Blender.org 
Link-https://easyblend.org/html/modeling/curves/editing/extrude.html 

 

Tilt 

This setting controls how the normals (visualization: arrows) twist 
around each control point – so it is only relevant with 3D curves! You set 

it using the Tilt transform tool in the T tool shelf, the N ‣ transform ‣ 

Mean tilt, or Curve ‣ Transform ‣ Tilt. 

You can also reset it to its default value (i.e. perpendicular to the original 

curve plane) with Alt-T, Curve ‣ Control Points ‣ Clear Tilt. 

With NURBS, the tilt is always smoothly interpolated. However, with 
Bézier, you can choose the interpolation algorithm between Linear, Ease, 
B-Spline, and Cardinal, in the  

Properties Editor ‣ Object Data ‣ Active 

Spline ‣ Tilt 

https://easyblend.org/html/modeling/curves/editing/extrude.html
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Title-Img 3. 2  30-degree Mean Tilt of all control points. 
Attribution- 
Source-Blender.org 
Link-https://easyblend.org/html/modeling/curves/editing/extrude.html 

 

Bevel Depth 

This will add a bevel to the Extrusion. Refer Img 3.8 for its effects... Note 
that the bevel makes the Extrusion wider and higher. If set to 0.0, there 
is no bevel. 

 
Title-Img 3. 3Bevel depth of 0.25, fill set to full, zero Mean Tilt. 
Attribution- 
Source-Blender.org 
Link-https://easyblend.org/html/modeling/curves/editing/extrude.html 

 
 
Bevel Resolution 

It controls the resolution of the bevel created by a Bevel Depth higher 
than zero. If set the to 0 (the default), the bevel is a simple “flat” Surface. 
Higher values will smooth, round off the bevel, similar to the resolution 
settings of the curve itself. 

https://easyblend.org/html/modeling/curves/editing/extrude.html
https://easyblend.org/html/modeling/curves/editing/extrude.html
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Title-Img 3. 4Bevel resolution set to 10. 
Attribution- 
Source-Blender.org 
Link-https://easyblend.org/html/modeling/curves/editing/extrude.html 

 

Offset 

Offset Moves the Extrusion parallel to the curve normal. Almost like 
scaling 

-1 Offset, 0.5 Extrusion, 0.25 Bevel Depth, 
10 Bevel resolutions 

Radius 

The Radius allows you to directly control the width of the Extrusion 
along the “spinal” curve. The Radius of the points is set using the 

Shrink/Fatten Radius transform tool Alt-S, the Curve ‣ Transform ‣ 

Shrink/Fatten Radius, or the N ‣ transform ‣ Radius. 

 
 
Title-Img 3. 5One control point radius set to zero 
Attribution- 
Source-Blender.org 
Link-https://easyblend.org/html/modeling/curves/editing/extrude.html 

 

https://easyblend.org/html/modeling/curves/editing/extrude.html
https://easyblend.org/html/modeling/curves/editing/extrude.html
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Tip 

Remember, these curves can be converted into Meshes 
with Alt-C in Object Mode. 

Three Sub-Classes of Curve: 

We have three sub-classes of results, depending on whether the curve is 
open or closed or 3D. 

Open 2D Curve 

The Extrusion will create a “wall” or “ribbon” following the curve shape. 
If using a Bevel Depth, the wall becomes a sort of slide or gutter. If your 
normals are facing the wrong way you can switch their direction as 
shown here. 

 
 
Title-Img 3. 6 Open 2D Curve with Alt-C, fill set to none, zero offset, 0.5 Extrusion, 0.25 

Bevel Depth, 10 Bevel resolution. 
Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/curves/properties/geometry.html 
 

Closed 2D Curve 

This is probably the most useful situation, as it will quickly create a 
volume, with (by default) two flat and parallel Surfaces filling the two 
sides of the extruded “wall”. You can remove one or both faces by 
choosing the fill mode: both, front, back, or none. 

The optional bevel depth will always create a 90 degree bevels here. 

https://docs.blender.org/manual/en/dev/modeling/curves/properties/geometry.html
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Title-Img 3. 7Closed 2D Curve, 0.5 extrude, 0.25 Bevel Depth, 10 Bevel resolution, Fill: 

Both. 
Attribution- 
Source-Blender.org 
Link- 
https://docs.blender.org/manual/en/dev/modeling/curves/properties/geometry.html 
 

Advanced Extrution 

These Extrusions use one or two additional curve objects, to create very 
complex organic shapes. 

To enable this type of Extrusion, you must type a valid curve object 
name in the Bevel Object field of the curve you are going to use as the 
“spinal column” of your Extrusion. The “bevel” curve will control the 
cross section of the extruded object. Whether the Bevel Object curve is 
2D or 3D has no importance, but if it is closed, it will create a “tube-like” 
Extrusion; otherwise you will get a sort of gutter or slide object... 

The object is extruded along the entire length of all internal curves. By 
default, the width of the Extrusion is constant, but you have two ways to 
control it,  

1. Radius property of control points 

2. Taper Object. 

Taper Curve 

Taper Curve is evaluated along the local X axis, using the local Y axis for 
width control. Note also that: 

It must be an open curve. 

The taper is applied independently to all curves of the extruded object. 

Only the first curve in a Taper Object is evaluated, even if you have 
several separated segments. 

The scaling starts at the first control-point on the left and moves along 
the curve to the last control-point on the right. 

https://docs.blender.org/manual/en/dev/modeling/curves/properties/geometry.html
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Negative scaling, (negative local Y on the Taper Curve) is possible as well. 
However, rendering artifacts may appear. 

It might need to increase the curve resolution to see more detail of the 
taper. 

With closed curves, the Taper Curve in Taper Object acts along the whole 
curve (perimeter of the object), not just the length of the object, and 
varies the Extrusion depth. In these cases, you want the relative height of 
the Taper Object Taper Curve at both ends to be the same, so that the 
cyclic point (the place where the endpoint of the curve connects to the 
beginning) is a smooth transition. 

Let us taper a simple curve circle extruded object using a Taper Curve.  

 Step 1: Add a curve,  

 Step 2: Then exit Edit Mode.  

 Step 3: Add another one (a closed one, like a circle);  

 Step 4: Call it “Bevel Curve”,  

 Step 5: Enter its name in the Bevel Object field of the first curve 

(Curve and Surface tab). We now have a pipe.  

 Step 6: Add a third curve while in Object Mode and  

 Step 7: Call it “Taper Curve”.  

 Step 8: Adjust the left control-point by raising it up about 5 units. 

 Step 9: Now return to the Object tab,  

 Step 10: Edit the first curve’s Taper Object field in the Curve and 

Surface panel to reference the new Taper Curve which we called 

“Taper Curve”.  

When you hit enter the Taper Curve is applied immediately, with the 
results shown in Img 3.13 Circle curve set as Bevel Object. 
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Title-Img 3. 8Taper curve 
Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/curves/properties/geometry.html 
 

You can see the Taper Curve being applied to the extruded object. Notice 
how the pipe’s volume shrinks to nothing as the Taper Curve goes from 
left to right. If the Taper Curve went below the local Y axis the pipe’s 
inside would become the outside, which would lead to rendering 
artifacts. Of course, as an artist, that may be what you are looking for! 

 

Taper Examples 

 
 
Title-Img 3. 9Taper example 1. 
Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/curves/properties/geometry.html 
 

In Taper example 1 (Img 3.14), You can clearly see the effect the left 
Taper Curve has on the right curve object. Here the left Taper Curve is 

https://docs.blender.org/manual/en/dev/modeling/curves/properties/geometry.html
https://docs.blender.org/manual/en/dev/modeling/curves/properties/geometry.html
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closer to the object center and that results in a smaller curve object to 
the right. 

 
Title-Img 3. 10Taper example 2. 
Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/curves/properties/geometry.html 
 

In Taper example 2 (Img 3.15), A control point in the Taper Curve to the 
left is moved away from the center and that gives a wider result to the 
curve object on the right. 

 
Title-Img 3. 11Taper example 3. 
Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/curves/properties/geometry.html 
 

In Taper example 3 (Img 3.16), We see the use of a more irregular Taper 
Curve applied to a curve circle. 

https://docs.blender.org/manual/en/dev/modeling/curves/properties/geometry.html
https://docs.blender.org/manual/en/dev/modeling/curves/properties/geometry.html
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Title-Img 3. 12 Bevel Extrusion with Tilt example. 
Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/curves/properties/geometry.html 
 

Surfaces 

Surface Editing 

Curves are 2D objects, and Surfaces are their 3D extension. Note 
however, that in Blender, you only have NURBS Surfaces, no Bezier (you 
have the Bezier knot type, though; see below), nor polygonal (but for 
these, you have Meshes!). Even though curves and Surfaces share the 
same object type (with texts also...), they are not the same thing; for 
example, you cannot have in the same object both curves and Surfaces. 

 
 
Title-Img 3. 13Nurbs Surface in edit mode 
Attribution- 

https://docs.blender.org/manual/en/dev/modeling/curves/properties/geometry.html
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Source-Blender.org 
Link-https://docs.blender.org/manual/en/dev/modeling/surfaces/introduction.html 
 

Nurbs Surface in Edit Mode 

You may ask yourself “The Surface appears to be 3D, why is it only 2D?”  

In order to be 3D, the object needs to have “Volume”, and a Surface, 
even when it is closed, does not have volume; it is infinitely thin. If it had 
a volume the Surface would have a thickness (its third dimension). 
Hence, it is only a 2D object, and has only two interpolation dimensions 
or axes or coordinates (if you know a bit of math, think of non-euclidean 
geometry – well, Surfaces are just non-euclidean 2D planes...).  

 
Tip 

To take a more “real life” example, you can roll a sheet of 
paper to create a cylinder; well, even if it “draws” a 

volume, the sheet itself will remain a nearly 2D object! 

 

Primitives 

To get started in creating Surfaces, there are four preset NURBS 

Surfaces, found in the Add ‣ Surface as  

1. NURBS Surface 

2. NURBS Tube 

3. NURBS Sphere 

4. NURBS Torus 

 
Title-Img 3. 14NURBS Surface primitives. 
Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/surfaces/primitives.html#comm
on-options 

https://docs.blender.org/manual/en/dev/modeling/surfaces/introduction.html
https://docs.blender.org/manual/en/dev/modeling/surfaces/primitives.html#common-options
https://docs.blender.org/manual/en/dev/modeling/surfaces/primitives.html#common-options
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Properties 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Title-Img 3. 15Surface Properties. 
Attribution- 
Source-Blender.org 
Link-https://docs.blender.org/manual/en/dev/modeling/surfaces/properties.html 
 

Shape 

 
 
Title-Img 3. 16Shape panel. 
Attribution- 
Source-Blender.org 
Link-https://docs.blender.org/manual/en/dev/modeling/surfaces/properties.html 
 

You can adjust the resolution separately for both preview and render, to 
not slow things down in the viewport, but still get good render results. 

 
Preview 

U, V 

Render 

U, V 

https://docs.blender.org/manual/en/dev/modeling/surfaces/properties.html
https://docs.blender.org/manual/en/dev/modeling/surfaces/properties.html
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Bezier Endpoint 

Just like with NURBS curves, NURBS Surfaces have two knot vectors, one 
for each U and V axis. Here again, they can be one of Cyclic, Endpoint, or 
Bezier, with the same properties as for curves. And as with curves, only 
Open Surfaces (in the relevant direction) are affected by this setting. 

 
 
Title-Img 3. 17Endpoint U. 
Attribution- 
Source-Blender.org 
Link-https://docs.blender.org/manual/en/dev/modeling/surfaces/properties.html 
 

In Img 3.22 Endpoint U, the U interpolation axis is labeled as “U” and the 
V interpolation axis is labeled as “V”. The U’s interpolation axis has been 
set to Endpoint and as such the Surface now extends to the outer edges 
from E1 to E2 along the U interpolation axis. 

Adding or Extruding 

 Mode: Edit Mode 

 Menu: Surface ‣ Extrude 

 Hotkey: E, Ctrl-LMB 

Unlike Meshes or curves, you cannot generally directly add new control 
points to a Surface (with Ctrl-LMB clicks), as you can only extend a 
Surface by adding a whole U- or V-row at once. The only exception is 
when working on a NURBS Surface curve, i.e. a Surface with only one 
control point on each U- or V-row. In this special case, all works exactly 
as with curves. 

Most of the time, only Extrusion is available. As usual, once the tool is 
activated the Extrusion happens immediately and you are placed into 
Grab mode, ready to drag the new extruded Surface to its destination. 

https://docs.blender.org/manual/en/dev/modeling/surfaces/properties.html


 

 

Unit 3 Inorganic Modelling 
  

74 
 

 
 

There are two things very important to understand: 

Surfaces are 2D objects. So, you cannot extrude anything inside 
a Surface (e.g. “inner” row); it would not make any sense! 
 
The control “grid” must remain “squarish”, which means that 
you can only extrude a whole row, not parts of rows here and 
there. 

To summarize, the Extrude tool will only work, when only one whole 
border row is selected, otherwise nothing happens. 

Examples 

Selecting control-point to show a typical Extrusion along the side of a 
Surface. 

In Img 3.23, Selecting control-point and Shift-R, a border row of control 
points was highlighted by selecting a single control point, and then using 
the handy row select tool Shift-R to select the rest of the control points. 

 
Title-Img 3. 18Selecting control point 
Attribution- 
Source-Blender.org 
Link-https://docs.blender.org/manual/en/dev/modeling/surfaces/editing.html 
 
The edge is then extruded using E as shown in Img 3.24 Extruding. 
Notice how the Mesh has bunched up next to the highlighted edge. 
That is because the new extruded Surface section is bunched up there 
as well. 

 

 
Title-Img 3. 19Extruding 

https://docs.blender.org/manual/en/dev/modeling/surfaces/editing.html
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Attribution- 
Source-Blender.org 
Link-https://docs.blender.org/manual/en/dev/modeling/surfaces/editing.html 
 

By moving the new section away from the area, the Surface begins to 
“un-bunch”. 

You can continue this process of extruding or adding new Surface 
sections until you have reached the final shape for your model. 

Deleting Elements 

 Mode: Edit Mode 

 Menu: Curve ‣ Delete... 

 Hotkey: X, Delete 

The Erase pop-up menu of Surfaces offers an option: 

 Selected 

This will delete the selected rows, without breaking the Surface (i.e. the 
adjacent rows will be directly linked, joined, once the intermediary ones 
are deleted). The selection must abide by the following rules: 

Whole rows, and only whole rows must be selected. Only rows along the 
same axis must be selected (i.e. you cannot delete both U- and V-rows at 
the same time). 

Example 

 
 
Title-Img 3. 

20Before and 
After 
Attribution
- 
Source-
Blender.or
g 
Link-https://docs.blender.org/manual/en/dev/modeling/surfaces/editing.html 
 

In Img 3. 21Before and after (left) a row of control points has been 
selected by initially selecting the one control point and using Shift-R to 
select the remaining control points. Then, using the Delete Menu X, the 

https://docs.blender.org/manual/en/dev/modeling/surfaces/editing.html
https://docs.blender.org/manual/en/dev/modeling/surfaces/editing.html
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selected row of control points is erased, resulting in  
Img 3. 22 Before and after (right). 

Joining or Merging Surfaces 

 Mode: Edit Mode 

 Menu: Surface ‣ Make Segment 

 Hotkey: F 

This command is equivalent to creating edges or Faces for Meshes 
(hence its shortcut), and so it only works in Edit Mode. The selection 
must contain only border rows of the same resolution (with the same 
number of control points), else Blender will try to do its best to guess 
what to merge with, or the merge will fail (either silently, or stating that 
Resolution does not match if rows with different number of points are 
selected, or that there are too few selections to merge if you only 
selected points in one Surface).  

Examples 

 
Title-Img 3. 23Before and After 
Attribution- 
Source-Blender.org 
Link-https://docs.blender.org/manual/en/dev/modeling/surfaces/editing.html 
 

 

https://docs.blender.org/manual/en/dev/modeling/surfaces/editing.html
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Unit summary 

 

Summary 

In this Unit, you have learnt what is 3D Interface and how to 

 Create Objects and work with Curves and Surfaces in 

Blender 

 Edit the Curves and Surfaces using different Modes in 

Blender 

 Work with Surface modelling 

 Work with Nurbs modelling 

 Work effectively with 2D shapes 

 Prepare Curve Deformation and Curve Extrusion 

After learning this Unit, you can download the Open Source 

Software available on the internet for free of cost to practice the 

possibilities of creating 3D Interface. 

Assignment 

 Create a Flower Vase, a Wine Glass and a Cup using Nurbs curves 

 

Assignment 

Assessment  

Explain Nurbs Modelling. 
Write a brief note on the Editing methods in Curve. 

Explain Bezier handle types. 
Describe the properties of 2D and 3D shapes. 
Write a brief note on Extending curves 
Explain the types of Curve Extrusion 

Fill in the Blanks 

1. _________________ are the most commonly used curves for designing letters or 

https://www.blender.org/download/
https://www.blender.org/download/
https://www.blender.org/download/
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logos.  

1. _______________ turns a one-dimensional curve into a two-dimensional curve by 

giving it height.  

2. ________________moves the Extrusion parallel to the curve normal.  

3. ______________ allows you to directly control the width of the Extrusion along the 

“spinal” curve.  

4. _______________handle has a completely automatic length and direction which is 

set by Blender to ensure the smoothest result.  

 

Resources 

Study Skills 

 

While studying this Unit, you can browse the internet links for online 

tutorials and several books and training DVDs available in theBlender 

Storeand on theBlender Cloud. 

 wiki.blender.org 

 archive.org 

 www.blender.org 

 docs.blender.org 

 

  

https://store.blender.org/
https://store.blender.org/
https://store.blender.org/
https://cloud.blender.org/
http://www.blender.org/
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Unit 4 

Organic Modelling 

Introduction 

In this Unit, you will learn the creation of a 3D scene and the usage of 

three key components to create the real-time geometry Modelling in 

Blender. 

You will also learn to use the specific features of your chosen 3D 

software, each one of these Primitives can be manipulated to produce 

an Object. You will create a model in 3D, and explore the various 

modelling methods used in the production.  

There are three basic methods that will be used to create a 3D model, 

and you will understand how to create a model using each technique. 

Outcomes 

Upon completion of this unit you will be able to: 

 

Outcomes 

 Create Object with 3D Primitives 

 Edit the Object with different Modes 

 Mesh Modelling 

 Create Polygon Objects 

 Analyse the Mesh 

Terminology 

 Structure: With Meshes, everything is built from three basic 
structures: Vertices, Edges and Faces. 

Vertices: A vertex is primarily a single point or position in 3D 
space. 
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Edges: An edge always connects two vertices by a straight 
line.  

Faces: Faces are used to build the actual surface of the 
Object. 

Loops: Edge and Face Loops are sets of faces or edges that 
form continuous “loops”.  

Edge Lops: Loops (1 and 2) in Img 4. 1 Edge and Face Loops are 
edge Loops. 

Face Lops: These are a logical extension of Edge Loops in that 
they consist of the faces between two Edge Loops. 

Edge Ring: In Edge select mode, holding Ctrl-Alt while selecting 
an edge selects a sequence of edges that are not 
connected. 

Subdividing: Technique for adding more geometry to a Mesh. It 
creates new vertices on subdivided edges, new 
edges between subdivisions and new faces based on 
new edges. 

Tessellation: The tiling of a plane using one or more geometric 
shapes usually resulting in Micro polygons. 

Coplanar: Refers to any set of elements that are all aligned to 
the same 2D plane in 3D space. 

Modelling Modes 

3D View has three principal modes that allow for the creation, editing 
and manipulation of the Mesh models. Each of the three modes has a 
variety of tools. Some tools may be found in one or more of the modes. 

Modes used for Modelling 

Creation of a Mesh Primitive typically starts by adding a Mesh Object in 
Object Mode. Limited types of editing such as size, location, and 
orientation can be accomplished in Object Mode. Object Mode also 
provides the means to Join and Group Multiple Mesh Primitives. 

 Object Mode 

 Edit Mode 

 Sculpt Mode 

 

Terminology 
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More detailed editing of the Mesh model shape is done in Edit Mode, 
and Sculpt Mode. The nature of these three modes determines the tools 
that are available within the various panels of 3D View. Switching 
between modes while Modelling is common. Some tools may be 
available in more than one mode while others may be unique to a 
particular mode. 

You can work with Geometric Objects in two modes. 

Object Mode 

Object Mode Operations in Object Mode affect the whole Object. 

Object Mode has the following header in 3D View: 

 
Title-Img 4. 2Object Mode Header. 
Attribution- 
Source-Blender.org 
Link-https://docs.blender.org/manual/en/dev/modeling/meshes/introduction.html 

 

Edit Mode 

Operations in Edit Mode affect only the geometry of an Object, 

but not global properties such as location or rotation. Edit Mode 

has the following header in 3D View: 

 
Title-Img 4. 2Edit Mode Header. 
Attribution- 
Source-Blender.org 
Link-https://docs.blender.org/manual/en/dev/modeling/meshes/introduction.html 

Visualization 

 
Title-Img 4. 3One cube selected 
Attribution- 

https://docs.blender.org/manual/en/dev/modeling/meshes/introduction.html
https://docs.blender.org/manual/en/dev/modeling/meshes/introduction.html
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Source-Blender.org 
Link-https://docs.blender.org/manual/en/dev/modeling/meshes/introduction.html 

 

 
Title-Img 4. 4Two cube selected efore entering edit mode 
Attribution- 
Source-Blender.org 
Link-https://docs.blender.org/manual/en/dev/modeling/meshes/introduction.html 

 

By default, Blender highlights selected geometry in orange in both 
Object Mode and Edit Mode. 

 In Object Mode with Wireframe shading enabled Z, 
Objects are displayed in black when unselected and in 
orange when selected. If more than one Object is 
selected, all selected Objects except the active Object, 
typically the Object last selected, are displayed in a darker 
orange color. Similarly, in Edit Mode, unselected 
geometry is drawn in black while selected faces, edges, or 
vertices are drawn in orange. The active face is highlighted 
in white. 

 In Edit Mode, only one Mesh can be edited at the time. 
However, several Objects can be joined into a single Mesh 
(Ctrl-J in Object Mode) and then separated again (P in Edit 
Mode). If multiple Objects are selected before entering 
Edit Mode, all the selected Objects remain highlighted in 
orange indicating that they are part of the active selection 
set. 

If two vertices joined by an edge are selected in Vertex selection mode, 
the edge between them is highlighted too. Similarly, if enough vertices or 
edges are selected to define a face, that face is also highlighted. 

https://docs.blender.org/manual/en/dev/modeling/meshes/introduction.html
https://docs.blender.org/manual/en/dev/modeling/meshes/introduction.html
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Tool Shelf 

 
Title-Img 4. 5The Tool Shelf panel in edit mode. 
Attribution- 
Source-Blender.org 
Link-https://docs.blender.org/manual/en/dev/modeling/meshes/introduction.html 

 

Open/Close the Mesh Tools panel using T. When entering Edit Mode, 
several Mesh tools become available. 

Most of these tools are also available as shortcuts (displayed in the 
Tooltips for each tool) and/or in the Specials Menu W, the Edge menu 
Ctrl-E, and Face menu Ctrl-F. The properties of each tool are displayed in 
the operator panel at the bottom of the Tool Shelf. 

 

 

https://docs.blender.org/manual/en/dev/modeling/meshes/introduction.html
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Properties Region 

 
Title-Img 4. 6The Properties Region in edit mode. 
Attribution- 
Source-Blender.org 
Link-https://docs.blender.org/manual/en/dev/modeling/meshes/introduction.html 

 

Open/close the Properties Region using N. 

In the Properties Region, panels directly related to Mesh editing are the 
Transform panel, where numeric values can be entered, and the Mesh 
Display panel, where for example normals and numeric values for 
distances, angles, and areas can be turned on. 

Structure 

With Meshes, everything is built from three basic structures: Vertices, 
Edges and Faces. 

https://docs.blender.org/manual/en/dev/modeling/meshes/introduction.html
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Title-Img 4. 3Example of Mesh structure. 

Attribution- 
Source-Blender.org 
Link-https://docs.blender.org/manual/en/dev/modeling/meshes/structure.html 

 

Vertices 

A vertex is primarily a single point or position in 3D space. It is usually 
invisible in rendering and in Object Mode. Do not mistake the center 
point of an Object for a vertex. It looks similar, but it is bigger and you 
cannot select it. Refer Vertex example (Img 4.8). Shows the center point 
labelled as “A”; “B” and “C” are vertices. 

 
Title-Img 4. 4Vertex example 

Attribution- 
Source-Blender.org 
Link-https://docs.blender.org/manual/en/dev/modeling/meshes/structure.html 

 

https://docs.blender.org/manual/en/dev/modeling/meshes/structure.html
https://docs.blender.org/manual/en/dev/modeling/meshes/structure.html
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A simple way to create a new vertex is to click Ctrl-LMB in Edit Mode. Of 
course, as a computer screen is two-dimensional, Blender cannot 
determine all three vertex coordinates from a single mouse click, so the 
new vertex is placed at the depth of 3D cursor. Using the method 
described above (Img 4.8), any vertices selected previously are 
automatically connected to the new ones by an edge. In the image 
above, the vertex labelled “C” is a new vertex added to the cube with a 
new edge added between “B” and “C”. 

Edges 

An Edge always connects two vertices by a straight line. The edges are 
the “wires” you see when you look at a Mesh in wireframe view. They 
are usually invisible on the rendered image. They are used to construct 
faces. Create an edge by selecting two vertices and pressing F. 

Face 

A Face is defined as the area between either three (triangles), four 
(quadrangles) or more (ngons) vertices, with an edge on every side. 
These are often abbreviated to tris, quads & ngons. 

Triangles are always flat and therefore easy to calculate. On the other 
hand, quadrangles “deform well” and are therefore preferred for 
subdivision Modelling. 

While you could build a cube with triangular faces, it would just look 
more confusing in Edit Mode. 

Loops 

 
Title-Img 4. 5Edge and Face Loops 

Attribution- 
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Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/meshes/structure.html#fig-
mesh-topo-loop 

Edge and Face Loops are sets of faces or edges that form continuous 
“loops” as shown in Img 4. 9. 

Edge and Face Loops: 

 Top row (1 - 4) shows a solid view,  

 Bottom row (5 - 8) a wireframe view of the same loops. 

In the image above (Img 4. 9), loops that do not end in poles are cyclic (1 
and 3). They start and end at the same vertex and divide the model into 
two partitions. Loops can be a quick and powerful tool to work with 
specific, continuous regions of a Mesh and are a prerequisite for Organic 
Character Animation. 

Edge Loops 

Loops (1 and 2) in Img 4. 9Edge and Face Loops are edge Loops. They 
connect vertices so that each one on the loop has exactly two neighbours 
that are not on the loop and placed on both sides of the loop (except the 
start and end vertex in case of poles). 

Edge Loops are an important concept especially in organic (subsurface) 
Modelling and character animation. When used correctly, they allow 
you to build models with relatively few vertices that look very natural 
when used as subdivision surfaces and deform very well in animation. 

Face Loops 

These are a logical extension of Edge Loops in that they consist of the 
faces between two Edge Loops, as shown in loops (3 and 4) in Img 4. 9 
Edge and Face Loops. Note that for non-circular loops (4) the faces 
containing the poles are not included in a Face Loop.  
(Refer Img 4. 9) 

 

Tip 

Loops (2 and 4) do not go around the whole model. 
Loops stop at so called poles because there is no unique 
way to continue a loop from a pole. Poles are vertices 
that are connected to either three, five, or more edges. 
Accordingly, vertices connected to exactly one, two or 
four edges are not poles. 

https://docs.blender.org/manual/en/dev/modeling/meshes/structure.html#fig-mesh-topo-loop
https://docs.blender.org/manual/en/dev/modeling/meshes/structure.html#fig-mesh-topo-loop
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Selection Mode 

Select Mode Header Widgets 

 Mode: Edit Mode 

 Menu: 3D View Header ‣ Select Mode 

 Hotkey: Ctrl-Tab 

In Edit Mode, there are three different selection modes. You can enter 
the different modes by selecting one of the three buttons in the header. 

 
Title-Img 4. 6Edit Mode selection buttons 

Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/meshes/selecting/introduction.h
tml 
 
 

Vertices 

In this mode, vertices are drawn as points.  

 Selected vertices are drawn in orange, 

 Unselected vertices in black 

 Active or last selected vertex in white 

Edges 

In this mode, the vertices are not drawn. Instead,  

 Selected edges are drawn in orange,  

 Unselected edges black,  

 Active or last selected edge in white. 

https://docs.blender.org/manual/en/dev/modeling/meshes/selecting/introduction.html
https://docs.blender.org/manual/en/dev/modeling/meshes/selecting/introduction.html
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Faces 

In this mode, the faces are drawn with a selection point in the middle 
which is used for selecting a face.  

 Selected faces and their selection point are drawn in 

orange,  

 Unselected faces are drawn in black,  

 Active or last selected face is highlighted in white. 

Almost all tools are available in all three Mesh selection modes. So, you 
can Rotate, Scale, Extrude, etc. in all modes. Of course, rotating and 
scaling a single vertex will not do anything useful (without setting the 
pivot point to another location), so some tools are applicable in some 
modes. 

 

Selection Loops 

You can easily select loops of components: 

Edge Loops and Vertex Loops 

 Mode: Edit Mode –> Vertex or Edge select mode 

 Menu: Select ‣ Edge Loop or Mesh ‣ Edges ‣ Edge Loop 

 Hotkey: Alt-RMB or Ctrl-E‣ Edge Loop 

Holding Alt while selecting an edge selects a loop of edges that are 
connected in a line end to end, passing through the edge under the 
mouse pointer. Holding Alt-Shift while clicking adds to the current 
selection. 

Edge loops can also be selected based on an existing edge selection, 

using either Select ‣ Edge Loop, or the Edge Loop Select option of the 

Edge Specials Menu Ctrl-E. 

 
Tip 

Vertex mode 

In Vertex select mode, you can also select edge loops, by using 

the same hotkeys, and clicking on the edges (not on the 

vertices). 
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Title-Img 4. 7Longitudinal and latitudinal edge loops 

Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/meshes/selecting/advanced.htm
l 
 

Face Loops 

 Mode: Edit Mode –> Face or Vertex select modes 

 Hotkey: Alt-RMB 

In face select mode, holding Alt while selecting an edge selects a loop of 
faces that are connected in a line end to end, along their opposite edges. 

In vertex select mode, the same can be accomplished by using Ctrl-Alt to 
select an edge, which selects the face loop implicitly. 

 
Title-Img 4. 8Face loop selection 

Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/meshes/selecting/advanced.htm
l 
 

https://docs.blender.org/manual/en/dev/modeling/meshes/selecting/advanced.html
https://docs.blender.org/manual/en/dev/modeling/meshes/selecting/advanced.html
https://docs.blender.org/manual/en/dev/modeling/meshes/selecting/advanced.html
https://docs.blender.org/manual/en/dev/modeling/meshes/selecting/advanced.html
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This face loop was selected by clicking with Alt-RMB on an edge, in face 
select mode. The loop extends perpendicular from the edge that was 
selected. 

 
Title-Img 4. 9Alt versus Ctrl-Alt in vertex select mode 

Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/meshes/selecting/advanced.htm
l 
 

A face loop can also be selected in Vertex select mode. Technically Ctrl-
Alt-RMB will select an Edge Ring, however, in Vertex select mode, 
selecting an Edge Ring implicitly selects a Face Loop since selecting 
opposite edges of a face implicitly selects the entire face. 

Edge Ring 

 Mode: Edit Mode –> Edge select mode 

 Menu: Select ‣ Edge Ring or Mesh ‣ Edges ‣ Edge Ring 

 Hotkey: Ctrl-Alt-RMB or Ctrl-E ‣Select ‣ Edge Ring 

In Edge select mode, holding Ctrl-Alt while selecting an edge selects a 
sequence of edges that are not connected, but on opposite sides to each 
other continuing along a face loop. 

As with edge loops, you can also select edge rings based on current 

selection, using either Select ‣ Edge Ring, or the Edge Ring Select option 

of the Edge Specials Menu Ctrl-E. 

 
Tip 

Vertex mode 

In Vertex select mode, you can use the same hotkeys when 

clicking on the edges (not on the vertices), but this will directly 

select the corresponding face loop. 

https://docs.blender.org/manual/en/dev/modeling/meshes/selecting/advanced.html
https://docs.blender.org/manual/en/dev/modeling/meshes/selecting/advanced.html
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Title-Img 4. 10A selected edge loop, and a selected edge ring 

Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/meshes/selecting/advanced.htm
l 

In Img 4.14, A selected edge loop, and a selected edge ring. The same 
edge was clicked on, but two different “groups of edges” were selected, 
based on the different commands. One is based on edges during 
computation and the other is based on faces. 

Duplicating  / Mesh Editing Tools 

This section covers Mesh editing tools that add additional geometry by 
duplicating existing geometry in some way. 

Duplicate Geometry 
Extrusion 
Spin 
Screw 

Duplicate Geometry Tool 

 Mode: Edit Mode 

 Menu: Mesh ‣ Duplicate 

 Hotkey: Shift-D 

This tool simply duplicates the selected elements, without creating any 
links with the rest of the Mesh (unlike extrude, for example), and places 
the duplicate at the location of the original. Once the duplication is done, 
only the new duplicated elements are selected, and you are 
automatically placed in grab/move mode, so you can translate your copy 
elsewhere. 

https://docs.blender.org/manual/en/dev/modeling/meshes/selecting/advanced.html
https://docs.blender.org/manual/en/dev/modeling/meshes/selecting/advanced.html
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Extrude Tool 

Extrude Region 

 Mode: Edit Mode 

 Panel: Mesh Tools ‣ Extrude 

 Menu: Mesh‣ Extrude Region 

 Hotkey: E or Alt-E 

One tool of paramount importance for working with Meshes is the 
Extrude tool. It allows you to create parallelepipeds from rectangles and 
cylinders from circles, as well as easily create such things as tree limbs. 
Extrude is one of the most frequently used Modelling tools in Blender 

The selection is extruded along the common normal of selected faces. In 
every other case the extrusion can be limited to a single axis by 
specifying an axis (e.g. X to limit to the X axis or Shift-X to the YZ plane. 
When extruding along the face normal, limiting movement to the global 
Z axis requires pressing Z twice, once to disable the face normal Z axis 
limit, and once to enable the global Z axis limit. 

 
Selected face During extrude Set to Z axis 

Title-Img 4. 15 Extrude face 

Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/extr
ude.html 
 
Ext Mode: Edit Mode 

 Panel: Mesh Tools ‣ Extrude Individual 

 Menu: Mesh ‣ Extrude Individual 

 Hotkey: Alt-E 

Extrude Individual allows you to extrude a selection of multiple faces as 
individuals, instead of as a region. The faces are extruded along their 

https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/extrude.html
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/extrude.html
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own normals, rather than their average. This has several consequences: 
first, “internal” edges (i.e. edges between two selected faces) are no 
longer deleted (the original faces are). 

 
Title-Img 4. 11 Selection of multiple faces, extruded using extrude region and Extruded 

using Extrude Individual 

Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/extr
ude.html 
 

Extrude Edges and Vertices Only 

 Mode: Edit Mode, Vertex and Edge 

 Hotkey: Alt-E 

If vertices are selected while doing an extrude, but they do not form an 
edge or face, they will extrude as expected, forming a non-manifold 
edge. Similarly, if edges are selected that do not form a face, they will 
extrude to form a face. 

 
Title-Img 4. 12Single vertex extruded. Single edge extruded 

Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/extr
ude.html 
 

https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/extrude.html
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/extrude.html
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/extrude.html
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/extrude.html
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Title-Img 4. 13Single edge extruded. Edge only extrude 

Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/extr
ude.html 
 

Inset Tool 

 Mode: Edit Mode 

 Menu: Mesh ‣ Faces ‣ Inset 

 Hotkey: I 

This tool takes the currently selected faces and creates an inset of them, 
with adjustable thickness and depth. The tool is modal, such that when 
you activate it, you may adjust the thickness with your mouse position. 
You may also adjust the depth of the inset during the modal operation by 
holding Ctrl. 

 
Selection to inset Selection with inset 

Title-Img 4. 14Single vertex extruded. Single edge extruded 

Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/inse
t.html 
 

Spin Tool 

 Mode: Edit Mode 

https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/extrude.html
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/extrude.html
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/inset.html
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/inset.html
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 Panel: Mesh Tools 

Use the Spin tool to create the sort of Objects that you would produce 
on a lathe (this tool is often called a “lathe”-tool or a “sweep”-tool in the 
literature, for this reason). In fact, it does a sort of circular extrusion of 
your selected elements, center on 3D cursor, and around the axis 
perpendicular to the working view... 

The point of view will determine around which axis the extrusion spins. 

The position of 3D cursor will be the center of the rotation. (Refer Img. 
4.20) 

Example 

 
Title-Img 4. 15Glass profile 

Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/spin
.html?highlight=glass%20profile 
 

First, create a Mesh representing the profile of your Object. If you are 
Modelling a hollow Object, it is a good idea to thicken the outline. Img. 
4.20 Glass profile Shows the profile for a wine glass we will model as a 
demonstration. 

Go to the Edit Mode and select all the vertices of the Profile with A. 

We will be rotating the Object around the cursor in the top view, so 
switch to the top view with Numpad7. 

https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/spin.html?highlight=glass%20profile
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/spin.html?highlight=glass%20profile
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Title-Img 4. 16Glass profile, top view in Edit Mode, just before spinning. 

Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/spin
.html?highlight=glass%20profile 
 

Place the cursor along the center of the profile by selecting one of the 
vertices along the center, and snapping 3D cursor to that location with 

Mesh ‣ Cursor ‣ Selection. (Img 4. 171  Glass profile, top view in Edit 

Mode, just before spinning.) Shows the wine glass profile from top view, 
with the cursor correctly positioned. 

Click the Spin button. If you have more than one 3D View open, the 
cursor will change to an arrow with a question mark and you will have to 
click in the area containing the top view before continuing. If you have 
only one 3D View open, the spin will happen immediately. Img 4. 18Spun 
profile Shows the result of a successful spin. 

Angle 

 
Title-Img 4. 19Spun Profile with an angle of 360 and 120. 

Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/spin
.html?highlight=glass%20profile 
 

https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/spin.html?highlight=glass%20profile
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/spin.html?highlight=glass%20profile
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/spin.html?highlight=glass%20profile
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/spin.html?highlight=glass%20profile
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Result of spin operation Result of Dupli enabled 

Title-Img 4. 20Result of Spin & Dupli 

Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/spin
.html?highlight=glass%20profile 
 

Merge Duplicates 

 
Title-Img 4. 21Duplicate Vertices 

Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/spin
.html?highlight=glass%20profile 
 

The spin operation leaves duplicate vertices along the profile. You can 
select all vertices at the seam with Box select B shown in Img 4. 24 
Duplicate vertices. Seam vertex selection and perform a Remove 
Doubles operation. 

Bevel Tool 

 Mode: Edit Mode 

 Menu: Mesh ‣ Edges ‣ Bevel or Ctrl-E‣ Bevel 

https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/spin.html?highlight=glass%20profile
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/spin.html?highlight=glass%20profile
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/spin.html?highlight=glass%20profile
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/duplicating/spin.html?highlight=glass%20profile
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 Usage 

The Bevel tool works only on selected edges. It will recognize any 
edges included in a vertex or face selection as well, and perform the 
bevel the same as if those edges were explicitly selected. In “vertex 
only” mode, the Bevel tool works on selected vertices instead of edges. 
The Bevel tool smooths the edges and/or “corners” (vertices) by 
replacing them with faces making smooth profiles with a specified 
number of segments (see the options below  
Img 4. 25for details about the bevel algorithm). 

Use Ctrl-B or a method listed above to run the tool. Move the mouse to 
interactively specify the bevel offset, and scroll the Wheel to increase or 
decrease the number of segments. (See Img 4. 25) 

 
Edge before 
beveling 

Edge Bevel Vertex bevel 

Title-Img 4. 22Bevel 

Attribution- 
Source-Blender.org 
Link-
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/subdividing/bev
el.html 
 

Merge Vertices 

This tool allows you to merge all selected vertices to a unique one, 
deleting all others. You can choose the location of the surviving vertex in 
the menu this tool pops up before executing. 

 
Study 

Skills 

https://en.wikibooks.org/wiki/Blender_3D:_Noob_to_Pro/Mes

h_Modelling 

 

 

https://docs.blender.org/manual/en/dev/modeling/meshes/editing/subdividing/bevel.html
https://docs.blender.org/manual/en/dev/modeling/meshes/editing/subdividing/bevel.html
https://en.wikibooks.org/wiki/Blender_3D:_Noob_to_Pro/Mesh_Modelling
https://en.wikibooks.org/wiki/Blender_3D:_Noob_to_Pro/Mesh_Modelling
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Unit summary 

 

Summary 

 Create Object with 3D Mesh / Primitives 

 Edit the Object with different Modes 

 Work with Mesh Modelling 

 Create Polygon Objects 

 Analyse the Mesh 

After learning this Unit, you can download the Open Image Source 
Software available on the internet for free of cost to practice the 
possibilities of creating 3D Objects. 

Assignment 

 

Assignment 

 Create a flower vase, a wine glass and a cup using Nurbs curves. 

 

 

 

https://www.blender.org/download/
https://www.blender.org/download/
https://www.blender.org/download/


   
 3D Animation 

 
101 

 
 

 

Assessment 

 

Assessment 

1. Explain the Modelling Modes in Blender  

2. Write a brief note on the Structure of a Mesh 

3. Explain the Loops used in Polygon Modelling 

4. Describe the types of selection modes in Mesh modelling  

5. Write a brief note on Edge/Face tool 

6. How is Mirror Editing tool used? 

Fill in the Blanks 

1. _________________ is available in either Edit Mode or Object Mode.  

2. Selected vertices are drawn in ___________color, unselected vertices 

in_______________ color.  

3. Pressing ______________Key when selecting a higher selection mode, all elements 

touching the current selection will be added.  

4. A______________ is primarily a single point or position in 3D space.  

5. Operations in ________________ effect only the geometry of an Object.  

 

Resources 

 

 

 

 

 

Study Skills 

 

While studying this Unit, you can browse the internet links for online 

tutorials and several books and training DVDs available in theBlender 

Storeand on theBlender Cloud. 

 wiki.blender.org 

 archive.org 

 www.blender.org 

 docs.blender.org 
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